×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

vpim sending question

Unanswered Question
Dec 12th, 2006
User Badges:

Unified messaging with exchange 2003. Now we are working on VPIM interationn with another vendor called callxpress.


Unity smtp domain is a.com

callxpress smtp domain is b.com


We were able to send message from unity to callxpress long time ago in the testing phase. But now not working again. Not sure customer changed something in the middle. Anyway here is the NDR message I got in the sender mailbox:(5550 is the dialId to reach callxpress)

the following recipient could not be reached:

"5550_1123" on 12/12/2006

the email account doese not exist at the orgnization this message was sent to. Check the email....


Apparently it doesn't attach the delivery location's smtp domain on the recipient address. It should be [email protected], right? SO does it look like the voice connector not working? Thanks

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
navinger Wed, 12/13/2006 - 18:25
User Badges:
  • Bronze, 100 points or more

When the Voice Connector processes an outbound VPIM message, one of the things it does is set the TO address as [email protected]. So at that point, it would look more like you were expecting - [email protected]. However if the remote system is then generating an NDR, the Voice Connector will process that inbound NDR and return the addresses to a format understood by Unity - which is DeliveryLocationDialID_RemoteMailboxNumber and that is what you are seeing when you look at the NDR in a Unity subscriber's mailbox.


Sounds like maybe the mailbox number being sent doesn't exactly match up with what the receiving system is expecting. First, I'd suggest reviewing the information about dial ids and prefixes in the VPIM networking chapter: http://www.cisco.com/en/US/products/sw/voicesw/ps2237/products_feature_guide_chapter09186a0080449aa1.html


If it seems like you have these configured such that the phone number the VPIM message is being sent to will match the mailbox on the CallXpress system, but it is still not working, then you can enable some additional logging on the Voice Connector.


Here are the steps to do that:

-On the Exchange server where the Voice Connector is installed, create a directory on a drive with space available for logging.

-On the Exchange server where the Voice Connector is installed, run regedit.

-Navigate to the HKeyLocalMachine\Software\Active Voice\AvIvc key and create a new String registry entry called StoreFiles. Set the value to the directory you just created for storing the files (for example: D:\temp\ - you must include the trailing backslash).

-Restart the Exchange 2000 Voice Connector service.

-Send an outbound VPIM message.

-Open the directory you created for logging and you should see a tmp file for each message sent. Open the file with notepad, and the first few lines will be the message header information. You will be able to see the TO address as it is sent to the remote system.

-Make sure this phone number and domain in the TO address are what is expected by the receiving system for message delivery.

***This saves a copy of each outbound message sent by the Voice Connector, so it should be used only while troubleshooting a problem. Delete the StoreFiles registry entry and restart the Voice Connector to disable this logging.

Actions

This Discussion