×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

4M serial link

Unanswered Question
Dec 17th, 2006
User Badges:

Currently we have a 2M serial (V.35) link connecting to our providers MPLS cloud via BGP. We are trying to upgrade to 4M and the soln presented to us is a 2 x 2M serial link. I am trying to decide if I should use mlppp and run BGP on it via the multilink interface or use the eBGP multihop load balancing solution. In this latter scenario the BGP peering would be via the loopback addresses and each of the two serial interface would have an ip address each. has anyone set this up before and can advise which option is better or feasible. Is there any thing in particular that one may look out for - to enable or disable the ip route caching maybe one? We also have (Cisco Modular) MQC QOS enabled on the routers serial interface.


Thanks


Vimal.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (1 ratings)
Loading.
spremkumar Sun, 12/17/2006 - 22:01
User Badges:
  • Red, 2250 points or more

Hi Vimal


I would suggest to go with the second option of running eBGP with multi hop option enabled...


This will also negate the extra load put by MLPP on CPU cycle..


Also do throw more on kinda QOS you have in place in your router..


If possible do post out the config for better clarity on the same..


regds



VPMaharaj Sun, 12/17/2006 - 22:39
User Badges:

Thanks for your reply. I have not worked out the configs for the new 4M setup yet but am pasting the config for the existing 2M service below. The config is big hence I am just pasting the main QOS portion:


!

class-map match-any QPM_apps

etc..

class-map match-all all-traffic

match any

class-map match-any QPM_video

match protocol rtp video

match access-group name QPM_qos-video

class-map match-any QPM_voice

match protocol rtp audio

class-map match-any QPM_scavenger

match access-group name QPM_scavenger

!

!

policy-map QPM_1

class QPM_voice

priority 348

set ip dscp ef

class QPM_video

bandwidth 460

set ip dscp af31

class QPM_apps

bandwidth 512

random-detect dscp-based

set ip dscp af33

class QPM_scavenger

police 768000 2048000 2048000 conform-action set-dscp-transmit 0 exceed-action drop violate-action

class class-default

fair-queue

random-detect dscp-based

set ip dscp default

policy-map QPM

class QPM_voice

set ip dscp ef

class QPM_video

set ip dscp af41

class QPM_apps

set ip dscp af31

class QPM_scavenger

police 768000 2048000 2048000 conform-action set-dscp-transmit 0 exceed-action drop violate-action

class class-default

set ip dscp default


!

interface FastEthernet0/0

description ## LAN ^V data VLAN ##

ip address xx

ip route-cache flow

duplex auto

speed auto

no clns route-cache

!

interface Serial0/0

bandwidth 2048

ip address xx

max-reserved-bandwidth 90

service-policy input QPM

service-policy output QPM_1

encapsulation ppp


BTW I will implement the config change remotely via telnet.With the eBGP option would I be able to do the changes remotely i.e convert from the existing 1 x serial link to the 2 x 2 eBGP multihop option whilst maintaining telnet connectivity. I think I should be able to since since the existing point-to-point serial interface would retain its ip address even though the BGP peering would be via the loopback addresses in the new setup.

spremkumar Sun, 12/17/2006 - 23:49
User Badges:
  • Red, 2250 points or more

Hi Vimal


The QOS configs which you have posted out here is having local significance and i don't think you will be able to get end to end priority or bandwidth guarantee.


It also depends on the SP with which you are having the connectivity.


I don't think in internet cloud the SPs will have some kinda QOS in their Gateway routers or so and its impossible to have some kinda QOS policy agreements with the peering partners too..


If you have delay/latency sensitive traffic in your network better to look after for a separate different mode of connectivity and keep this Internet Leased Line intact..



regds


VPMaharaj Mon, 12/18/2006 - 00:17
User Badges:

Thanks Edwin. I forgot to mention that this link is part of a global private mpls network via the SP's MPLS cloud hence QOS guarantee is actually in operation.


We do have voip, video traffic. I will try to find out some more on QOS under the mlppp and eBGP scenarios and then perhaps make a choice.


Vimal.

spremkumar Mon, 12/18/2006 - 01:04
User Badges:
  • Red, 2250 points or more

Hi Vimal


If you are having Managed VPN services availed from your SP then no need to worry about End to End qos since it will be well taken care at the SP (PE) end..


regds


Actions

This Discussion