×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

MGCP flapping between Publisher and Subscriber

Unanswered Question
Dec 21st, 2006
User Badges:

I have a multi-site environment connected via MPLS and I have one router that flaps being registered between the Publisher and subscriber. This is causing problems with the inbound FXO calls as well as the PRI whichi won't establish layer 2 because it can't back haul the D channel. Everytime the registration switches this is the message from the router:


Dec 21 2006 12:08:33.415 CST: [S] mgcp_msg_ack:6059,Updating (*)=198.192.172.220


This is the show ccm:


Priority Status Host

============================================================

Primary Backup Ready 198.192.172.221

First Backup Registered 198.192.172.220

Second Backup None


Current active Call Manager: 198.192.172.220

Backhaul/Redundant link port: 2428

Failover Interval: 30 seconds

Keepalive Interval: 15 seconds

Last keepalive sent: 12:09:35 CST Dec 21 2006 (elapsed time: 00:00:05

)

Last MGCP traffic time: 12:09:38 CST Dec 21 2006 (elapsed time: 00:00:01

)

Last failover time: 12:09:35 CST Dec 21 2006 from (198.192.172.221)

Last switchback time: 12:09:14 CST Dec 21 2006 from (198.192.172.220)

Switchback mode: Graceful

MGCP Fallback mode: Enabled/OFF

Last MGCP Fallback start time: None

Last MGCP Fallback end time: None

MGCP Download Tones: Disabled




I am having the provider check the circuit but was wondering if there is something else I should be checking. The version of IOS I am running is:


c2801-advipservicesk9-mz.124-3e.bin



Thanks


Dave

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
mparekh Thu, 12/21/2006 - 19:05
User Badges:
  • Bronze, 100 points or more

Can you paste the 'show mgcp statistics' output...this can be useful to see if any MGCP packets failed between the CallManager and gateway.


The most probable cause of the gateway flappping registration is because the MGCP keepalive with the 198.192.172.221 is being dropped. Which causes the gateway to register with 198.192.172.220 and then when it gets a keepalive again from 198.192.172.221 it registers with this CM again.

Jeff Garner Sat, 12/23/2006 - 22:29
User Badges:

What version of ccm are you using? Im having the same issue with one of our 4.2 clusters and its on an MPLS network as well. I suspect the provider is dropping my packets but Im not sure. I opened a TAC case and they confirmed the gateway was reregistering because it was loosing its keep alive packets...


However we have about a dozen other 4.1x clusters setup all the same with this carrier and we have never an issue...


So I'm wondering if there is something in the 4.2 train the makes it more sensitive to a lost mgcp packet.


Also we were told to reboot the publisher when this happens and it does seem to stop the flapping? Otherwise I've seen one of my sites flap between publisher and subscriber for hours?


johnwidby Thu, 06/21/2007 - 08:04
User Badges:

Dave,


Did you ever find out what was causing your issue w/MGCP flapping?


I am having a similar issue with MGCP flapping but the VG and CM-SUB are both on the same 4510 switch. I've done debug mgcp packet & Ethereal captures on a port that spans CM-SUB. The Ethereal capture shows that the CM-SUB is receiving the NTFY's but not responding until 25 seconds later. By then the VG registered with the CM-PUB accross the WAN. This happens a 3 or 4 times a day.


John

Charles Hill Wed, 09/03/2008 - 19:27
User Badges:
  • Gold, 750 points or more

I've got the same issue with MGCP flapping, but my problem is across a point to point T1. Its flapping about every 5 seconds. Unfortunately I turned on "debug mgcp all" and I lost my connection. Future reference I would definitely do a reload in x minutes, just in case. Any ideas why the gateway would be flapping.

Actions

This Discussion