×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

!700 series IOS err

Unanswered Question
Jan 2nd, 2007
User Badges:

Hi guys -----Belated New Year Wishes!!!!

One of my routers reboots frequently. The excerpt of the sh ver is like this


065xx.1.E1 uptime is 1 hours, 2 minutes

System returned to ROM by error - a SegV exception, PC 0x805E6904

System image file is "flash:c1700-y-mz.121-7.bin"


The excerpt of the 'sh stacks' shows


Stack trace from system failure:

FP: 0x80AD5CC8, RA: 0xD0

FP: 0x80AD5CD8, RA: 0x8012C8A8

FP: 0x80AD5CF0, RA: 0x8022412C

FP: 0x80AD5D70, RA: 0x80225F14

FP: 0x80AD5DA0, RA: 0x802271A4

FP: 0x80AD5DB0, RA: 0x801EADEC

FP: 0x80AD5E00, RA: 0x801EB034

FP: 0x80AD5EA0, RA: 0x801F4044


Whatis the problem? How can I fix it?

Any Option other than IOS Upgradation.

Thanks in Advance

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
spremkumar Tue, 01/02/2007 - 03:30
User Badges:
  • Red, 2250 points or more

Hi Raj


I don't think you can avoid a possibility of upgrading the IOS code which may solve your issue..


AFAIK SegV exception mostly occurs coz of the bugs present with the IOS code,you need to upgrade or change the ios code to overcome the same..


do check the below link which can help you to troubleshoot..


http://www.cisco.com/en/US/products/hw/routers/ps359/products_tech_note09186a0080189ddb.shtml


regds


kudru_raj Tue, 01/02/2007 - 05:37
User Badges:

Hi Prem,

I was just hoping that some one would come up with a solution other than IOS Upgradation, But after checking the the URL u have given i have thought of upgrading my IOS.we will have to even consider the n/w uptime na.

Thanx for your support.

Raj


kudru_raj Tue, 01/09/2007 - 01:23
User Badges:

hi guys,

My 1750 box is having 4MB flash and the IOS was c1700-y-mz.121-7b, which was giving SegV Exception err.

To over come this, i tried to upgrade it with c1700-y-mz.121-27b (image size - 3.04MB).Once i upgraded the IOs i started getting these err.


%% Low on memory; try again later


and


00:20:51: %SYS-2-MALLOCFAIL: Memory allocation of 65536 bytes failed from 0x80128C9C, alignment 0

Pool: Processor Free: 7832 Cause: Not enough free memory

Alternate Pool: None Free: 0 Cause: No Alternate pool


Bcoz of this i had to revert back to the old IOS, which is still giving the problem.

Has any one of you come across this problem,If so kindly suggest me a solution for SegV Exception err.,other than upgrading the flash and then going for IOS Upgradation.

Any help would be appreciated.

spremkumar Tue, 01/09/2007 - 02:53
User Badges:
  • Red, 2250 points or more

Hi Raj


Have you tried removing the existing ios and tried with the new ios file ?


Also have you checked out for the required hardware resources (like flash/dram) to have the new ios file in your system ?


regds


kudru_raj Tue, 01/09/2007 - 04:34
User Badges:

Hi Prem,

Nice to be here again with you,As you have told, i had removed the old IOS.

Prior to the upgradation the flash was having the IOS image (size 2.93MB)and three crash info files.I had upgraded the IOS after deleting all the files in the flash.

After upgrading the IOS i had checked the flash it was having 90xKb of free mem.

As for the IOS there are only two IOS available in the Cisco site with this particular feature set and supporting 4MB.

Any suggestions, regarding how to go about this.(As for now i have recewived one standby box.).

Is there anything that i can do with this faulty box.


Thnx & rgds

Raj.

Actions

This Discussion