Newbie: trunk between 6500 and Blade Switch 3020

Unanswered Question
Jan 8th, 2007
User Badges:

Hi,

Beeing newbie , I need advice to setup trunk between my 2 switches.

I would like to use 4 ports as TRUNK


On the 6500 , this is what I have done :

set port channel 5/37-40 61

...

set trunk 5/37 auto isl 1-1005,1025-4094

set trunk 5/38 auto isl 1-1005,1025-4094

set trunk 5/39 auto isl 1-1005,1025-4094

set trunk 5/40 auto isl 1-1005,1025-4094

...


On the Blade Switch 3020 I have done :

interface GigabitEthernet0/17

switchport trunk encapsulation isl

switchport mode trunk

shutdown

channel-group 1 mode on

!

interface GigabitEthernet0/18

switchport trunk encapsulation isl

switchport mode trunk

shutdown

channel-group 1 mode on

!

interface GigabitEthernet0/19

switchport trunk encapsulation isl

switchport mode trunk

shutdown

channel-group 1 mode on

!

interface GigabitEthernet0/20

switchport trunk encapsulation isl

switchport mode trunk

shutdown

channel-group 1 mode on



Will that work ?

Could you tell me if I have to put the trunk port on the same VLAN ?


Many thanks in advance for your help.

regards

David



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.3 (4 ratings)
Loading.
ankbhasi Mon, 01/08/2007 - 02:52
User Badges:
  • Cisco Employee,

Hi David,


Your configuration looks fine and you simple need to no shut the gig interfaces on 3020 blade switch.


Yes the allowed vlans list should match both the sides and on all ports to form a etherchannel bundle and by default it allows all the vlans. Your both the switches allow all default vlans so you are good to go.


HTH


Ankur


*Pls rate all helpfull post

trombidz1 Tue, 01/09/2007 - 08:41
User Badges:

Many thanks for your prompt response

But I have an issue

I did a no shut on one interface and it goes to trunk mode fine

When I did a no shut on the second one , it was ok for 2 minutes , trunks were enabled on both port , but they went to error-disabled after


It seems to work only with one port activated at a time.


any tips ?


many thanks


ankbhasi Tue, 01/09/2007 - 09:09
User Badges:
  • Cisco Employee,

Hi Friend,


Can you try changing the config on CAT switch to something like this


set port channel 5/37-40 61 on

...

set trunk 5/37 on isl 1-1005,1025-4094

set trunk 5/38 on isl 1-1005,1025-4094

set trunk 5/39 on isl 1-1005,1025-4094

set trunk 5/40 on isl 1-1005,1025-4094


May be the blade switch is not doing any negotiation.


After changing the config on CATOS then try "no shut" on all the interfaces on blade switch.


Update if it works.


Regards,


Ankur

trombidz1 Tue, 01/09/2007 - 09:17
User Badges:

again,

thanks for your prompt response


I read an article that you can not do a trunk between a 1000 port and a 10/100 port speed ...

did I understand wrong ?


anyway I will try your tip

thanks

david


EDIT :

SAME situation after changing the conf on the CAT


ankbhasi Tue, 01/09/2007 - 09:41
User Badges:
  • Cisco Employee,

Hi Friend,


Thats an issue. You cannot set and configure an etherchannel between different capability interfaces.


For etherchannel/port channel to work it is mandatory that all the ports are of same capability with same configuration.


HTH


Ankur

glen.grant Tue, 01/09/2007 - 09:45
User Badges:
  • Purple, 4500 points or more

You cannot trunk or ehterchannel between different speed ports , all must have the same capabilities . If you have the catos as auto for trunking then try on the IOS side "swithcport mode dynamic desirable" . If the port were left as auto for speed and duplex then you should be able to trunk between them ok otherwise the links would not even be in an "up" condition if they were mismatched.



catos side

set trunk x/x desirable dot1q



IOS side

switchport mode dynamic desirable




trombidz1 Tue, 01/09/2007 - 23:38
User Badges:

I tried to put all the port into a 1gig switch and it is still the same issue

1 port is trunking fine

but I no shut the other ones , they all goes to err-disable.


what can be wrong?

please help


ON THE BLADE SWITCH , I HAVE :

interface GigabitEthernet0/17

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode on

!

interface GigabitEthernet0/18

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode on

!

interface GigabitEthernet0/19

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode on

!

interface GigabitEthernet0/20

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode on


on the CAT 6500 SWITCH, I HAVE :


set port channel 3/29,3/31-32,3/43 64

...

set trunk 3/29 on dot1q 1-1005,1025-4094

set trunk 3/31 on dot1q 1-1005,1025-4094

set trunk 3/32 on dot1q 1-1005,1025-4094

set trunk 3/43 on dot1q 1-1005,1025-4094

....

set spantree portfast 3/29,3/31-32,3/43 disable



ebanks2006 Thu, 01/11/2007 - 16:25
User Badges:

David, the "show errdisable-timeout" on CatOS should tell you exactly why the port is shut down. That may give us some clues as to what's really going on.


My best guess reading through the posts is that the etherchannel method is different on each side of the link. (And maybe I missed something as I ran through the existing posts a little quickly.) Mode "on" is different than mode "desirable". I recommend you determine exactly which etherchannel method you wish to use, and set both sides the same.


"On" implies that there is no protocol that will negotiate the etherchannel parameters for you. Or, it's a manual process that assumes you know what you're doing.


"Desirable" or "auto" implies PAgP, Cisco's Port Aggregation Protocol. "Desirable" will actively attempt to bring up an etherchannel. "Auto" will accept inbound PAgP traffic and commence with etherchannel establishment, but won't actually initiate the etherchannel himself.


"Active" and "passive" are for LACP (a standards based alternative to PAgP), which I personally wouldn't bother with unless you are etherchanneling to a device that ONLY speaks LACP.


I recommend you either set both sides to mode "on" or both sides to mode "desirable".


As mentioned above, every port in the etherchannel must be configured identically - speed, duplex, trunk, trunk protocol, vlans allowed on the trunk must all match. Any mismatches will cause that port to be disabled as a member of the etherchannel.

iris.deboer Sat, 01/20/2007 - 15:28
User Badges:

Hello David


I do not have a solution to your problem but we are having problems with the CBS3020 switches, so I would like to know which sw version you use on the 3020 blade switch?

We are currently experiencing difficulties with trunking between a CBS3020 and a Cisco 6509 sup720 using the dual media fiber ports. Very curious which sw version you use.


A thought however: I am not familiar with Cat OS or bundeling with pagp but: In IOS using lacp if the port capabilities within a channel do not match; the IOS will generate a message %EC-SP-5-CANNOT_BUNDLE_LACP stating the ports the channel and the particular attributes or capabilities that do not match. My guess would be if Cat OS works similar the port capabilities are identical and the problem could be in the 3020 switch?


Regards,

Iris


trombidz1 Mon, 01/22/2007 - 00:59
User Badges:

version 12.2

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Lux-bl-sw1

!

enable secret xxx

!

no aaa new-model

ip subnet-zero

!

!

no file verify auto

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

interface Port-channel1

!

interface FastEthernet0

no ip address

no ip route-cache

!

interface GigabitEthernet0/1

switchport access vlan 181

speed 1000

spanning-tree portfast

!

interface GigabitEthernet0/2

switchport access vlan 181

speed 1000

spanning-tree portfast

!

interface GigabitEthernet0/3

switchport access vlan 181

speed 1000

spanning-tree portfast

!

interface GigabitEthernet0/4

switchport access vlan 181

speed 1000

spanning-tree portfast

!

interface GigabitEthernet0/5

switchport access vlan 181

speed 1000

spanning-tree portfast

!

interface GigabitEthernet0/6

switchport access vlan 181

speed 1000

spanning-tree portfast

!

interface GigabitEthernet0/7

switchport access vlan 181

speed 1000

spanning-tree portfast

!

interface GigabitEthernet0/8

switchport access vlan 181

speed 1000

spanning-tree portfast

!

interface GigabitEthernet0/9

switchport access vlan 181

speed 1000

spanning-tree portfast

!

interface GigabitEthernet0/10

switchport access vlan 181

speed 1000

spanning-tree portfast

!

interface GigabitEthernet0/11

switchport access vlan 181

speed 1000

spanning-tree portfast

!

interface GigabitEthernet0/12

switchport access vlan 181

speed 1000

spanning-tree portfast

!

interface GigabitEthernet0/13

switchport access vlan 181

speed 1000

spanning-tree portfast

!

interface GigabitEthernet0/14

switchport access vlan 181

speed 1000

spanning-tree portfast

!

interface GigabitEthernet0/15

switchport access vlan 181

speed 1000

spanning-tree portfast

!

interface GigabitEthernet0/16

switchport access vlan 181

speed 1000

spanning-tree portfast

!

interface GigabitEthernet0/17

!

interface GigabitEthernet0/18

!

interface GigabitEthernet0/19

!

interface GigabitEthernet0/20

!

interface GigabitEthernet0/21

!

interface GigabitEthernet0/22

!

interface GigabitEthernet0/23

!

interface GigabitEthernet0/24

!

interface Vlan1

no ip address

no ip route-cache

!

interface Vlan181

ip address xxx.xx.x.xxx 255.255.0.0

no ip route-cache

!

ip default-gateway xxx.xx.x.xx

ip http server

!

control-plane

!

!

line con 0

line vty 0 4

password fsv14m

login

line vty 5 15

password fsv14m

login

!

end


----

Port Name Status Vlan Duplex Speed Type

Gi0/1 connected 181 full 1000 1000BaseX

Gi0/2 connected 181 full 1000 1000BaseX

Gi0/17 connected trunk a-full a-1000 10/100/1000BaseTX

Gi0/18 connected trunk a-full a-1000 10/100/1000BaseTX

Gi0/19 notconnect 1 auto auto Not Present

Gi0/20 notconnect 1 auto auto Not Present

Gi0/21 connected trunk a-full a-1000 10/100/1000BaseTX

Gi0/22 notconnect 1 auto auto 10/100/1000BaseTX

Gi0/23 connected trunk a-full a-1000 10/100/1000BaseTX

Gi0/24 notconnect 1 auto auto 10/100/1000BaseTX

Po1 notconnect 1 auto auto

Fa0 connected routed full a-100 10/100BaseTX


We saw that all the ports on the gig switch are set to be trunk by default.


trunk works

I need to investigate how to setup a ether channel trunk ( to have a 4 gig trunk instead of 4*1 gig )


trombidz1 Mon, 01/22/2007 - 01:02
User Badges:

$oftware, CBS30X0 Software (CBS30X0-LANBASE-M), Version 12.2(25)SEF1, RELEASE SOFTWARE (fc3)

glen.grant Sun, 01/21/2007 - 16:43
User Badges:
  • Purple, 4500 points or more

Try this


ON THE BLADE SWITCH , I HAVE :

interface GigabitEthernet0/17

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode desirable non-silent

!

interface GigabitEthernet0/18

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode desirable non-silent

!

interface GigabitEthernet0/19

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode desirable non-silent

!

interface GigabitEthernet0/20

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode desirable non-silent


on the CAT 6500 SWITCH, I HAVE :


set port channel mode desirable non-silent 3/29,3/31-32,3/43 64

...

set trunk 3/29 on dot1q 1-1005,1025-4094

set trunk 3/31 on dot1q 1-1005,1025-4094

set trunk 3/32 on dot1q 1-1005,1025-4094

set trunk 3/43 on dot1q 1-1005,1025-4094

trombidz1 Mon, 01/22/2007 - 01:00
User Badges:

version 12.2

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Lux-bl-sw1

!

enable secret xxx

!

no aaa new-model

ip subnet-zero

!

!

no file verify auto

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

interface Port-channel1

!

interface FastEthernet0

no ip address

no ip route-cache

!

interface GigabitEthernet0/1

switchport access vlan 181

speed 1000

spanning-tree portfast

!

interface GigabitEthernet0/2

switchport access vlan 181

speed 1000

spanning-tree portfast

!

interface GigabitEthernet0/3

switchport access vlan 181

speed 1000

spanning-tree portfast

!

interface GigabitEthernet0/4

switchport access vlan 181

speed 1000

spanning-tree portfast

!

interface GigabitEthernet0/5

switchport access vlan 181

speed 1000

spanning-tree portfast

!

interface GigabitEthernet0/6

switchport access vlan 181

speed 1000

spanning-tree portfast

!

interface GigabitEthernet0/7

switchport access vlan 181

speed 1000

spanning-tree portfast

!

interface GigabitEthernet0/8

switchport access vlan 181

speed 1000

spanning-tree portfast

!

interface GigabitEthernet0/9

switchport access vlan 181

speed 1000

spanning-tree portfast

!

interface GigabitEthernet0/10

switchport access vlan 181

speed 1000

spanning-tree portfast

!

interface GigabitEthernet0/11

switchport access vlan 181

speed 1000

spanning-tree portfast

!

interface GigabitEthernet0/12

switchport access vlan 181

speed 1000

spanning-tree portfast

!

interface GigabitEthernet0/13

switchport access vlan 181

speed 1000

spanning-tree portfast

!

interface GigabitEthernet0/14

switchport access vlan 181

speed 1000

spanning-tree portfast

!

interface GigabitEthernet0/15

switchport access vlan 181

speed 1000

spanning-tree portfast

!

interface GigabitEthernet0/16

switchport access vlan 181

speed 1000

spanning-tree portfast

!

interface GigabitEthernet0/17

!

interface GigabitEthernet0/18

!

interface GigabitEthernet0/19

!

interface GigabitEthernet0/20

!

interface GigabitEthernet0/21

!

interface GigabitEthernet0/22

!

interface GigabitEthernet0/23

!

interface GigabitEthernet0/24

!

interface Vlan1

no ip address

no ip route-cache

!

interface Vlan181

ip address xxx.xx.x.xxx 255.255.0.0

no ip route-cache

!

ip default-gateway xxx.xx.x.xx

ip http server

!

control-plane

!

!

line con 0

line vty 0 4

password fsv14m

login

line vty 5 15

password fsv14m

login

!

end


----

Port Name Status Vlan Duplex Speed Type

Gi0/1 connected 181 full 1000 1000BaseX

Gi0/2 connected 181 full 1000 1000BaseX

Gi0/17 connected trunk a-full a-1000 10/100/1000BaseTX

Gi0/18 connected trunk a-full a-1000 10/100/1000BaseTX

Gi0/19 notconnect 1 auto auto Not Present

Gi0/20 notconnect 1 auto auto Not Present

Gi0/21 connected trunk a-full a-1000 10/100/1000BaseTX

Gi0/22 notconnect 1 auto auto 10/100/1000BaseTX

Gi0/23 connected trunk a-full a-1000 10/100/1000BaseTX

Gi0/24 notconnect 1 auto auto 10/100/1000BaseTX

Po1 notconnect 1 auto auto

Fa0 connected routed full a-100 10/100BaseTX


We saw that all the ports on the gig switch are set to be trunk by default.


trunk works

I need to investigate how to setup a ether channel trunk ( to have a 4 gig trunk instead of 4*1 gig )

jeff.teoch Thu, 02/01/2007 - 20:37
User Badges:

Hi David,


Did you configure your interface Port-channel1 to trunk configuration as follows:


interface Port-channel1

switchport trunk encapsulation isl

switchport mode trunk

no shut


Try this.


Regards,

Jeff

Actions

This Discussion