IP Communicator + EM + "Use this device name"

Unanswered Question
Jan 11th, 2007

I'm trying to get IP Communicator and Extension Mobility to work with a user defined device name. Unfortunately, no go. When I try to login, I get "Login Unsuccessful" and an Error [11] on the status line of the phone. When I look at the trace files, I get:

7: Jan 11 16:06:07.454 EST %EM-3-UNK:0: LoginService: Dev: SEP000CF1CD12CD- Error #11 - Policy Violation: Device does not exist: Device does not exist

Where SEP000CF1CD12CD is the original name of the device/NIC.

What gives? Anyone had this problem?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
brispin Wed, 01/17/2007 - 14:57

correct link for configuring the extention mobility is http://:8080/emapp/EMAppServlet?device=#DEVICENAME#

lfulgenzi Fri, 02/09/2007 - 07:03

There is a bug in IP Communicator where if you use the service URL button, it injects the MAC address of the device without looking at the user defined device name.

CSCsh60628: IPC 2.0 EM SURL button does not work with a custom devicename (MAC)

gustavo001 Fri, 10/10/2008 - 13:49

Hello,

I have followed all the steps to configure extention mobility but when I try to login appear a message that say "incorrect login error 207 device name".

How I can solve it ?

Thanks,

Gustavo

tim.giles Sat, 10/11/2008 - 02:54

Hi Gustavo,

Here is a list of all the current error codes for EM:

200

NO_ERROR-Successful.

201

Authentication error

AUTHENTICATION_ERROR-Authentication failed for user. Shows the user login page with error title.

202

Blank UserID or PIN

NULL_PARAM-Shows the user login page with error title.

203

Application UserID/Pwd null

APP_AUTHENTICATION_ERROR-Unable to find registry entry for AppUserID/Password.

204

Directory server error

DIR_SERV_ERROR-Exception occurred while performing diraccess.authenticateuserwithpin().

205

User Profile absent or null

DEV_PROF_ERROR-User profile absent or null.

206

No Device Profile associated with User

DEV_PROF_UNAVAILABLE-No Device profile associated with user.

207

Device name empty or absent

NULL_DEV_ERROR-Device name empty or absent.

208

Cannot connect to EM Service

LOGIN_SERVICE_CONN_ERROR-Unable to connect with EMService.

It sounds as though you need to create device profile in CallManager. Have you done this?

Basically, once this is done you can associate this with the end user account which you are using to log on with.

Basic steps are these:

1) Create device profile with dir number

2) add em service to profile

3) Create end user account and add device profile to it

Please rate useful posts..

Actions

Login or Register to take actions

This Discussion

Posted January 11, 2007 at 2:04 PM
Stats:
Replies:4 Avg. Rating:
Views:1083 Votes:0
Shares:0
Tags: No tags.
 

Discussions Leaderboard