×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

PBR Issue Cisco 2 x ISP problems

Unanswered Question
Jan 12th, 2007
User Badges:

I a situation with and 1800 router setup for dual ISP access managed by PBR.


1 x FE Interface (SDSL-EASYNET) and 1 x ATM/Dialer (BT)


This was working ok before we upgraded the 1 x FE connection from ADSL - SDSL (same ISP and same IPs as before).


If I remove the PBR I can ping the tracked IP from the FE interface. However, if I shut down then start the FE interface the "track" remains down.


I have the following config - not sure how to debug this and it driving me mad!


(212.58.224.82 - bbc IP)



interface FastEthernet0

description $ETH-LAN$

ip address 195.172.x.x 255.255.255.240

ip nat outside

duplex auto

speed auto



interface Vlan1

description $ETH-SW-LAUNCH$$INTF-INFO-FE 1$

ip address 192.100.151.2 255.255.255.0

ip nat inside





ip sla 1

icmp-echo 212.58.224.82 source-interface FastEthernet0

timeout 10000

threshold 2

frequency 15

ip sla schedule 1 life forever start-time now



track 100 rtr 1 reachability



ip local policy route-map LOCAL_POLICY


ip route 0.0.0.0 0.0.0.0 195.172.169.17 track 100

ip route 0.0.0.0 0.0.0.0 Dialer0 254


access-list 101 permit icmp any host 212.58.224.82 echo


access-list 40 remark IPs for NAT policy

access-list 40 permit 192.0.0.0 0.255.255.255



ip nat inside source route-map ispA interface FastEthernet0 over

ip nat inside source route-map ispB interface Dialer0 overload



!

route-map LOCAL_POLICY permit 10

match ip address 101

set interface Null0

set ip next-hop 195.172.169.17



!

route-map ispB permit 10

match ip address 40

match interface Dialer0

!

route-map ispA permit 10

match ip address 40

match interface FastEthernet0

!


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
dan.cicioiu Sat, 01/13/2007 - 09:35
User Badges:

Hi ,


i think you have a high timeout. Let the timeout

, threshold and frequency with the default values and it will work.

Actions

This Discussion