×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Multicast over GRE tunnel

Unanswered Question
Jan 15th, 2007
User Badges:

I have a Catalyst 3750 Metro running 12.2(25)EY4 on site A and a 2811 running 12.3(11)T4 on site B. There is an MPLS backbone in between and a GRE tunnel configured from site A to site B. At site B there are several hosts receiving multicast flows from site A.

The multicast flows arrives at site B, but the application running on hosts discards packets because they arrive out of sequence.

I tried to force sequencial trasmission of packets with the command ?tunnel sequence-datagrams?, but multicast packets are still discarded with the same log. Below the configuration of tunnel interface on both sites



site A

!

interface Tunnel2

ip address 192.168.105.105 255.255.255.252

ip pim sparse-dense-mode

keepalive 10 3

no clns route-cache

tunnel source Loopback0

tunnel destination 192.168.105.190

tunnel sequence-datagrams

tunnel checksum

end

!


site B

!

interface Tunnel1

description Multicast verso router CED Master

ip address 192.168.105.106 255.255.255.252

ip pim sparse-dense-mode

ip pgm router

keepalive 10 3

tunnel source Loopback0

tunnel destination 192.168.105.254

tunnel sequence-datagrams

tunnel checksum

!



Could someone help me?


Regards


Stefano

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
lgijssel Mon, 01/15/2007 - 05:39
User Badges:
  • Red, 2250 points or more

The command "tunnel sequence-datagrams" does not order packets for transmission. It rather drops packets that arrive out-of-sequence. You do not want to use this so I suggest that this command is removed from both routers.


To solve the issue, first try to reduce the transmissionrate of your multicast application (by reducing quality or resolution) If this gives an improvement the packets are probably asymetrically load-balanced on the MPLS backbone. In that case, your MPLS provider should make arrangements to solve this issue.

Otherwise, you might need to trace some packets and determine wheter you are having out of sequence packets or not and measure the variation in delay on the MPLS network.


Regards,

Leo


Actions

This Discussion