cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1112
Views
4
Helpful
7
Replies

802.11Q vlans on 2811

fpaolini
Level 1
Level 1

hi everyone. I'm trying to configure a brand new 2811 to route packets between vlans. the question is: is it possible to do it without the switching hwic? the seller said it was possible, but I'm not so confident in this. will I have to buy the 4 port hwic integrated switch module to do it?

thanks

1 Accepted Solution

Accepted Solutions

Yes you can !

I have done so several time on all C28xx platforms, and older routers aswell.

you need to do subinterfaces before you can add the encapsulation:

(Sample output from real router C2801)

interface FastEthernet0/1

no ip address

duplex auto

speed auto

!

interface FastEthernet0/1.10

encapsulation dot1Q 10

ip address 10.10.10.10 255.255.255.0

!

interface FastEthernet0/1.20

encapsulation dot1Q 20

ip address 10.10.20.20 255.255.255.0

!

...

..

.

show ip route:

10.0.0.0/24 is subnetted, 2 subnets

C 10.10.10.0 is directly connected, FastEthernet0/1.10

C 10.10.20.0 is directly connected, FastEthernet0/1.20

View solution in original post

7 Replies 7

mheusinger
Level 10
Level 10

Hello,

This is possible without the switching module. The configuration details and some examples can be found at "Configuring Routing Between VLANs"

http://www.cisco.com/en/US/products/ps6350/products_configuration_guide_chapter09186a0080684bf5.html

Basically you configure one sub-interface per VLAN with a separate IP subnet f.e. on a FastEthernet. After this you can enable IP routing on those interfaces like on any physical interface.

Hope this helps! Please use the rating system.

Regards, Martin

Hi Martin. I'm afraid this is not true. the interface does not accept the "encapsulation" command. I already tried it with the ipbase and enterpriseservices feature code 12.4(11)T1 but it's not working

Here is my config for one of my remote sites. the router is a 2821 running 12.3(14). I don't think the version of a particular IOS should prevent you from using this feature though.

interface GigabitEthernet0/0.1

description Data VLAN

encapsulation dot1Q 1 native

ip address 172.16.1.254 255.255.255.0

ip helper-address 172.20.62.129

no snmp trap link-status

!

interface GigabitEthernet0/0.3

description Phone VLAN

encapsulation dot1Q 3

ip address 172.16.3.254 255.255.255.0

no snmp trap link-status

!

interface GigabitEthernet0/0.30

description Call Manager VLAN

encapsulation dot1Q 30

ip address 172.16.30.6 255.255.255.248

no snmp trap link-status

Where 1,3 and 30 are vlans on the switch attached to gig0/0.

Yes you can !

I have done so several time on all C28xx platforms, and older routers aswell.

you need to do subinterfaces before you can add the encapsulation:

(Sample output from real router C2801)

interface FastEthernet0/1

no ip address

duplex auto

speed auto

!

interface FastEthernet0/1.10

encapsulation dot1Q 10

ip address 10.10.10.10 255.255.255.0

!

interface FastEthernet0/1.20

encapsulation dot1Q 20

ip address 10.10.20.20 255.255.255.0

!

...

..

.

show ip route:

10.0.0.0/24 is subnetted, 2 subnets

C 10.10.10.0 is directly connected, FastEthernet0/1.10

C 10.10.20.0 is directly connected, FastEthernet0/1.20

Hi,

like the two authors above I would be surprised. Still it might be something we do not know yet. Can you please post a show version and the configuration you would like to activate, but is rejected?

Regards, Martin

glen.grant
VIP Alumni
VIP Alumni

Have to have at least IP plus code to run this otherwise it should work without a problem . The enterpriseservices should support it , did you put the encapsulation command on the subinterface ? I have run this on old 3640 without a problem and even trunked a bridged interface across it and it worked fine .

thank you everyone. I found my fault. the encapsulation command had to be related to the subinterface rather than the interface. that's all...

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Innovations in Cisco Full Stack Observability - A new webinar from Cisco