EIGRP neighbor woes

Unanswered Question

I connect 2 routers via 2 wireless links. One primary, one backup link.

The wireless devices block broadcast traffic, so I'm bound to use the "neighbor"

command in order to have EIGRP packets been sent as unicast.


In fact, this HAS been working before, and all of a sudden it doesn't.

What happens is that one "neighbor" statement, although specified in the startup-config,

now vanished from the config.



sh start

{...}

router eigrp 11

redistribute static

network 172.16.10.96 0.0.0.31

network 172.16.20.96 0.0.0.15

neighbor 172.16.20.102 FastEthernet0/0

neighbor 172.16.10.102 Ethernet1/0

no auto-summary

eigrp log-neighbor-changes

{...}


sh runn

{...}

router eigrp 11

redistribute static

network 172.16.10.96 0.0.0.31

network 172.16.20.96 0.0.0.15

neighbor 172.16.20.102 FastEthernet0/0

no auto-summary

eigrp log-neighbor-changes

{...}


Trying to reinstate the command, this is what happens:


C2620#conf t

Enter configuration commands, one per line. End with CNTL/Z.

C2620(config)#router eigrp 11

C2620(config-router)#neighbor 172.16.10.102 eth1/0

EIGRP: Static nbr 172.16.10.102 already in AS 11 Ethernet1/0

C2620(config-router)#^Z


Well, so that means probably what it says - neighbor already there, but somehow "invisible".

When I try to delete the alleged neighbor, this is what I get:


C2620(config-router)#no neighbor 172.16.10.102 eth1/0

EIGRP: AS 11 not running on Ethernet1/0, can't delete static nbr

C2620(config-router)#


The EIGRP packet debug shows:


172.16.20.100 38: EIGRP: Sending HELLO on FastEthernet0/0 nbr 172.16.20.102

172.16.20.100 39: AS 11, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0

172.16.20.100 40: EIGRP: Received HELLO on FastEthernet0/0 nbr 172.16.20.102

172.16.20.100 41: AS 11, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/0

172.16.20.100 42: EIGRP: ddb not configured on Ethernet1/0


I have reloaded the router and cleared the Interface, and I'm clueless...

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
scottmac Sat, 01/27/2007 - 15:55
User Badges:
  • Green, 3000 points or more

Is it possible that the wireless path is not available to the route when the router boots? Or that it (for whatever reason) loses the wireless link?


If that path goes down, the route is removed from the table ... if the path is not available when the router boots, it won't add the path to the table.


What does the SH IP ROUTE command give you for a routing/forwarding table at the time of the failure?


Are either ports plugged into a switchport with spanning tree enabled? When the router reloads / reboots / powers up, the switchport will block traffic for ~50 seconds or so (then the router sees the path as "down" and fails to install the route).


You could try a spanning-tree portfast on those ports to remove the delay.


Check it out and let us know.


Good Luck


Scott


Both the fa0/0 and Eth0/1 interfaces are connected at boot time, and both wireless links are up.

I do not run STP.

Regardless if the path goes down, or even if the interface is shut, it should be possible to enter the configuration line:

"C2620(config-router)#neighbor 172.16.10.102 eth1/0" and have it stay there. The focus here is not so much the routing table, but of course this scenario has an effect on the routing table since the path via Eth1/0 won't establish a neighbor relationship, and EIGRP thinks that this link is down, although it is perfectly working.


Greetings, /Luis

sundar.palaniappan Sat, 01/27/2007 - 20:31
User Badges:
  • Green, 3000 points or more

The following debug error you are seeing indicates the router received hello on an interface that doesn't run EIGRP.


EIGRP: ddb not configured on Ethernet1/0


Can you do a show ip eigrp int and check whether EIGRP is enabled on ethernet 1/0. What's the IP/subnet mask of ethernet1/0 and the subnet mask of 172.16.10.102.


HTH


Sundar



It is:


interface FastEthernet0/0

ip address 172.16.20.100 255.255.255.240


interface Ethernet1/0

ip address 172.16.10.100 255.255.255.128


C2620#sh ip eigrp int

IP-EIGRP interfaces for process 11


Xmit Queue Mean Pacing Time Multicast Pending

Interface Peers Un/Reliable SRTT Un/Reliable Flow Timer Routes

Fa0/0 1 0/0 6 0/10 50 0


I'm not aware of a command to enable EIGRP on a specific interface.

I seems it is enabled on all interfaces unless it is explicitly disabled with "passive-interface {interface #}"


Greetings, /Luis

(And Thanks for all the efforts here!)



And by the way - Issue resolved. Sundar gave me the "wink with the telephone pole" by asking explicitly for the subnet mask.

It is true that i many days ago have widened the subnet mask on the Ethernet 1/0 interface from a /27 to a /25. And did not do the same with the "network" statement in EIGRP.

The funny thing is that this mistake clearly did not have any immediate effect, so I was unable to connect the dots. It took maybe 2 weeks, and then suddenly the line "neighbor 172.16.10.102 Ethernet1/0" disappeared from the running config, and the neighbor association vanished.


Thanks!


/Luis


janf Mon, 02/19/2007 - 14:14
User Badges:

Luis,


What are the wireless devices that you are using that block broadcast traffic? I have two sets of 1400 bridges that I would like to route over with EIGRP and would like to know if I need to use this neighbor command as you did.


Thanks!

We run a Ptp link (Trango) that does pass broadcasts, and the backup link is simple Client Premise equipment (That does not pass broadcasts).

Go and try it. If you find that you don't get a neighbor association (sh ip eigrp neigh), then you most likely will need the 'neighbor' command. Although I assume that a dedicated PtP bridge WILL pass Broadcasts.


Greetings, /Luis


Actions

This Discussion