cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3994
Views
0
Helpful
0
Comments

 

 

Introduction

 

This document covers the examples to configure the Trunk and Carrier based routing on an Originating and Terminating Gateway.

 

Trunk and Carrier Based Routing


Configuring Trunk and Carrier based routing on an Originating Gateway

 

Sample configuration on Originating Gateway

The following output shows how to configure trunk and carrier based routing on the originating gateway.

!
version 12.2
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service internal
!
hostname first
!
!
resource-pool disable
!
!
voice-fastpath enable
ip subnet-zero
no ip domain-lookup
ip host dirt 192.168.254.254
ip name-server 172.20.140.108
!
no ip dhcp-client network-discovery
lcp max-session-starts 0
isdn switch-type primary-5ess
!
voice enum-match-table 1
rule 1 5 /^9\(1.*\)/ /+\1/ e164.cisco.com
rule 10 1 /^(.*)/ /\1/ e164.cisco.com
!
voice translation-rule 1
rule 1 /408/ /804/
rule 2 /804/ /732/
rule 3 /875/ /785/
!
voice translation-rule 2
rule 1 /785/ /786/
rule 2 /786/ /875/
rule 3 /732/ /408/
!
voice translation-rule 3
rule 1 /303/ /330/
rule 2 /330/ /331/
!
voice translation-rule 4
rule 1 reject /4087775555/
rule 2 reject /6503232222/
!
voice translation-profile cb_xrule
translate called 4
translate calling 4
translate redirect-called 4
!
voice translation-profile xrule
translate calling 1
translate called 2
translate redirect-called 3
!
fax interface-type modem
mta receive maximum-recipients 0
!
controller T1 7/0
framing sf
linecode ami
!
controller T1 7/1
framing esf
linecode ami
ds0-group 1 timeslots 1-4 type e&m-fgb dtmf dnis
ds0-group 2 timeslots 5-8 type e&m-fgb dtmf dnis
ds0-group 3 timeslots 9-12 type e&m-fgb dtmf dnis
ds0-group 4 timeslots 13-16 type e&m-fgb dtmf dnis
ds0-group 5 timeslots 17-20 type e&m-fgb dtmf dnis
ds0-group 6 timeslots 21-24 type e&m-fgb dtmf dnis
cas-custom 1
trunk-group 11
cas-custom 2
trunk-group 11
cas-custom 3
trunk-group 11
cas-custom 4
trunk-group 11
cas-custom 5
trunk-group 11
cas-custom 6
trunk-group 11
!
controller T1 7/2
framing esf
linecode b8zs
pri-group timeslots 1-24
!
controller T1 7/3
framing esf
linecode b8zs
pri-group timeslots 1-24
!
controller T1 7/4
framing esf
linecode b8zs
pri-group timeslots 1-24 nfas_d primary nfas_int 1 nfas_group 1
!
controller T1 7/5
framing esf
linecode b8zs
pri-group timeslots 1-24 nfas_d none nfas_int 2 nfas_group 1
!
controller T1 7/6
framing sf
linecode ami
!
controller T1 7/7
framing sf
linecode ami
!
!
interface FastEthernet0/0
ip address 172.16.50.13 255.255.0.0
no ip route-cache
no ip mroute-cache
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 172.20.140.96 255.255.0.0
no ip route-cache
no ip mroute-cache
duplex auto
speed auto
!
interface Serial7/2:23
no ip address
trunk-group 12
isdn switch-type primary-5ess
isdn incoming-voice modem
!
interface Serial7/3:23
no ip address
trunk-group 13
isdn switch-type primary-5ess
isdn incoming-voice modem
isdn T310 60000
no cdp enable
!
interface Serial7/4:23
no ip address
trunk-group 13
isdn switch-type primary-5ess
isdn incoming-voice modem
isdn guard-timer 3000
isdn T306 30000
isdn T310 10000
no cdp enable
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.0.1
ip route 192.168.254.0 255.255.255.0 FastEthernet0/0
no ip http server
!
!
trunk group 11
carrier-id s-mci
!
trunk group 12
carrier-id s-att
!
trunk group 13
carrier-id s-sprint
!
voice-port 7/1:1
!
voice-port 7/1:2
!
voice-port 7/1:3
!
voice-port 7/1:4
!
voice-port 7/1:5
!
voice-port 7/1:6
!
voice-port 7/2:D
!
voice-port 7/3:D
!
voice-port 7/4:D
!
dial-peer voice 5108888 voip
destination-pattern 510888....
session protocol sipv2
session target ipv4:172.16.50.14
!
dial-peer voice 1311 pots
carrier-id source s-alpha
call-block disconnect-cause incoming user-busy
call-block translation-profile incoming cb_xrule
translation-profile incoming xrule
direct-inward-dial
!
dial-peer voice 1312 pots
carrier-id source s-beta
call-block translation-profile incoming cb_xrule
translation-profile incoming xrule
!
dial-peer voice 1313 pots
carrier-id source s-gamma
call-block translation-profile incoming cb_xrule
translation-profile incoming xrule
direct-inward-dial
!
dial-peer voice 510889 voip
destination-pattern 510889....
session protocol sipv2
session target enum:1
!
dial-peer voice 510890 voip
destination-pattern 510890....
session target enum:1
!
dial-peer voice 999 voip
destination-pattern 510........
session target ipv4:172.16.50.14
!
exec-timeout 0 0
logging synchronous
line aux 0
logging synchronous
line vty 0 4
login
line 1/00 1/107
no flush-at-activation
modem InOut
line 3/00 3/107
no flush-at-activation
modem InOut
!
scheduler allocate 10000 400
end


Configuring Trunk and Carrier based routing on a Terminating Gateway

Sample Configuration on a Terminating Gateway

 

The following output shows how to configure trunk and carrier based routing on the terminating gateway.

!
version 12.2
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service internal
!
hostname second
!
!
resource-pool disable
dial-tdm-clock priority 1 freerun
!
voice-fastpath enable
no ip subnet-zero
no ip domain-lookup
ip host second 192.168.254.254 255.255.255.0
ip name-server 172.21.188.171
!
no ip dhcp-client network-discovery
lcp max-session-starts 0
isdn switch-type primary-dms100
voice call carrier capacity active
voice call carrier capacity timer interval 45
!
voice source-group sg-alpha
carrier-id source s-alpha
carrier-id target t-alpha
description route calls from source alpha to target alpha
translation-profile incoming xrule
!
voice source-group sg-beta
carrier-id source s-beta
carrier-id target t-beta
description route calls from source beta to target beta
translation-profile incoming xrule
!
voice source-group sg-gamma
carrier-id source s-gamma
carrier-id target t-gamma
description route calls from source gamma to target gamma
translation-profile incoming xrule
!
voice source-group sg-ip
access-list 1
translation-profile incoming xrule
!
voice translation-rule 1
rule 1 reject /5108880101/
rule 2 /^510888\(01..\)/ /\10101/
rule 3 /5108880.../ /5108880101/
!
voice translation-rule 2
rule 1 /51088802../ /5108880101/
rule 2 /51088803../ /5108880101/
rule 3 /510889..../ /5108880101/
rule 4 /510890..../ /5108880101/
!
voice translation-rule 3
rule 1 /65088801../ /6508880101/
!
voice translation-profile xrule
translate called 1
translate calling 2
translate redirect-called 3
!
fax interface-type modem
mta receive maximum-recipients 0
!
trunk activate port-threshold 33
!
controller T1 7/0
framing sf
linecode ami
!
controller T1 7/1
framing esf
linecode ami
ds0-group 1 timeslots 1-4 type e&m-fgb dtmf dnis
ds0-group 2 timeslots 5-8 type e&m-fgb dtmf dnis
ds0-group 3 timeslots 9-12 type e&m-fgb dtmf dnis
ds0-group 4 timeslots 13-16 type e&m-fgb dtmf dnis
ds0-group 5 timeslots 17-20 type e&m-fgb dtmf dnis
ds0-group 6 timeslots 21 type e&m-fgb dtmf dnis
ds0-group 7 timeslots 22 type e&m-fgb dtmf dnis
ds0-group 8 timeslots 23 type e&m-fgb dtmf dnis
ds0-group 9 timeslots 24 type e&m-fgb dtmf dnis
ds0 busyout 22-23 hard
cas-custom 1
trunk-group 11 1
cas-custom 2
trunk-group 11 2
cas-custom 3
trunk-group 11 3
cas-custom 4
trunk-group 11 4
cas-custom 5
trunk-group 11 5
cas-custom 6
trunk-group 12 1
cas-custom 7
trunk-group 12 2
cas-custom 8
trunk-group 12 3
cas-custom 9
trunk-group 12 4
!
controller T1 7/2
framing esf
linecode b8zs
pri-group timeslots 1-24 nfas_d primary nfas_int 1 nfas_group 1
!
controller T1 7/3
framing esf
linecode b8zs
pri-group timeslots 1-24 nfas_d none nfas_int 2 nfas_group 1
!
controller T1 7/4
framing esf
linecode ami
ds0-group 1 timeslots 1-4 type e&m-fgb dtmf dnis
ds0-group 2 timeslots 5-8 type e&m-fgb dtmf dnis
ds0-group 3 timeslots 9-12 type e&m-fgb dtmf dnis
ds0-group 4 timeslots 13-16 type e&m-fgb dtmf dnis
ds0-group 5 timeslots 17-20 type e&m-fgb dtmf dnis
ds0-group 6 timeslots 21 type e&m-fgb dtmf dnis
ds0-group 7 timeslots 22 type e&m-fgb dtmf dnis
ds0-group 8 timeslots 23 type e&m-fgb dtmf dnis
ds0-group 9 timeslots 24 type e&m-fgb dtmf dnis
ds0 busyout 21-22,24 hard
cas-custom 1
trunk-group 11 5
cas-custom 2
trunk-group 11 6
cas-custom 3
trunk-group 11 7
cas-custom 4
trunk-group 11 8
cas-custom 5
trunk-group 12 5
cas-custom 6
trunk-group 12 5
cas-custom 7
trunk-group 12 5
cas-custom 8
trunk-group 12 5
cas-custom 9
trunk-group 12 5
!
controller T1 7/5
framing esf
linecode b8zs
pri-group timeslots 1-24
!
controller T1 7/6
framing sf
linecode ami
!
controller T1 7/7
framing sf
linecode ami
!
interface FastEthernet0/0
ip address 172.16.50.14 255.255.0.0
no ip mroute-cache
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.0.0.211 255.0.0.0
no ip route-cache
no ip mroute-cache
shutdown
duplex auto
speed auto
!
interface Serial7/2:23
no ip address
isdn switch-type primary-dms100
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.0.1
ip route 192.168.254.0 255.255.255.0 FastEthernet0/0
ip route 192.168.254.0 255.255.255.0 172.16.0.1
no ip http server
!
access-list 1 permit 172.16.50.12
!
!
trunk group 11
carrier-id t-alpha
hunt-scheme longest-idle
!
trunk group 12
carrier-id t-alpha
hunt-scheme least-idle
!
trunk group 13
carrier-id t-beta
hunt-scheme random
!
trunk group 14
carrier-id t-gamma
hunt-scheme random
!
call rsvp-sync
!
voice-port 7/1:1
!
voice-port 7/1:2
!
voice-port 7/1:3
!
voice-port 7/1:4
!
voice-port 7/1:5
!
voice-port 7/1:6
!
voice-port 7/1:7
!
voice-port 7/1:8
!
voice-port 7/1:9
!
voice-port 7/2:D
!
voice-port 7/4:1
!
voice-port 7/4:2
!
voice-port 7/4:3
!
voice-port 7/4:4
!
voice-port 7/4:5
!
voice-port 7/4:6
!
voice-port 7/4:7
!
voice-port 7/4:8
!
voice-port 7/4:9
!
voice-port 7/5:D
!
mgcp profile default
!
dial-peer voice 20001 voip
carrier-id source alpha
!
dial-peer voice 20002 voip
carrier-id source beta
!
dial-peer voice 20003 voip
carrier-id source gamma
!
dial-peer voice 10001 pots
trunkgroup 11 1
trunkgroup 12 2
translation-profile outgoing 1
carrier-id target t-alpha
forward-digits all
!
dial-peer voice 10002 pots
trunkgroup 13
translation-profile outgoing 2
carrier-id target t-beta
!
dial-peer voice 10003 pots
trunkgroup 14
translation-profile outgoing 1
carrier-id target t-gamma
forward-digits all
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
logging synchronous
line vty 0 4
login
line 1/00 1/107
no flush-at-activation
modem InOut
!
scheduler allocate 10000 400
end

 

 

 

Related Information

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Quick Links