Identifying and Troubleshooting SMTP connection issues with T37 OnRamp

Document

Tue, 07/03/2012 - 09:43
Jul 3rd, 2012

Issue:

One of the most common reasons for inbound T37 OnRamp faxes to fail  is connection issues with the SMTP server. This could happen due to one  of the following reasons:

Troubleshooting:

1. If inbound faxes on a T37 OnRamp GW are failing, run the following debugs:

debug voip ccapi inout
debug voip vtsp all
debug fax foip all
debug fax mta all
debug fax fmsp send t30
debug fax fmsp receive t30   
debug fax mspi all
debug fax dmsp default

2. If you see the following message in the debugs then, 

Mar 5 16:48:47.212: (C)S: MAIL FROM:<FAX=@>                                    
Mar 5 16:48:47.708: (C)R: 501 5.5.4 Invalid Address                                   
Mar 5 16:48:47.708: esmtp_client_work: error in response to MAIL FROM

The SMTP server does not like the MAIL FROM information. This is the originator account being used in the From field in the OnRamp email  and is incorrect. Either one of the following needs to be configured on  the gateway and should match what is defined in the SMTP server.

! Define the postmaster mail account for the onramp gateway
mta send postmaster [email protected]

                        OR
! Specifies the hostname and username for the originator (“From:” field of email header)
mta send mail-from hostname cisco.com
mta send mail-from username FAXES

3. If you see the following message in the debugs then,

Mar 4 10:46:48.703: %MSPI-1-MSPI_BAD_CONFIG: MSPI-bad configuration, mspi_setup_req:NULL server ip addressMar 4 10:46:48.703: mspi_setup_req: NULL server address
Mar 4 10:46:48.703: %LAPP_ON_MSGS-6-LAPP_ON_CAUSE_NO_ESMTP_CONNECT: ESMTP client did not connect or lost connection to remote server

The SMTP server may not be configured or configured incorrectly. Please check the following:

! Specify the destination email server that will receive the OnRamp fax email
mta send server 10.1.1.1 port 25

4. If you see the following message in the debugs then,

Mar 20 09:35:30.310: SMTP is in the error state...
Mar 20 09:35:30.310: disc text=no route to destination (3): SMTP client open failed
Mar 20 09:35:30.310: Still waiting for the SMTP connection..... 
Mar 20 09:35:30.310: %LAPP_ON_MSGS-6-LAPP_ON_CAUSE_NO_ESMTP_CONNECT: ESMTP client did not connect or lost connection to remote server
Mar 20 09:35:30.310: mspi_disconnect: cid=0x141, st=DISCONNECTING, cause=no route to destination (3)
Mar 20 09:35:30.310: mspi_on_call_hist: cid=0x141, cause=no route to destination (3): SMTP client open failed
Mar 20 09:35:30.310: disposing smtp ctx 

The SMTP server is configured but either no IP route to it  exists or the OnRamp GW is not able to access port 25. Please verify  connectivity by doing a telnet to the SMTP server's IP Address and port  25. You should see an output similar to below

HQ#telnet 192.168.15.11 25
Trying 192.168.15.11, 25 ... Open
220 testmail.cisco.com Microsoft ESMTP MAIL Service ready at Wed, 14 Dec 2011 17:28:00 -0700

To see a sample OnRamp GW configuration, please check the Configuring T.37 article.

Loading.

Actions

This Document

Related Content