UCCX 8.5: UCCX Agent Login Fails

Document

Fri, 08/30/2013 - 07:07
Aug 2nd, 2012

Introduction

In  a Cisco UCCX environment, UCCX Agent login fails with the AXL Error.  This document discusses how to troubleshoot this issue.

Prerequisites

  • Cisco Unified Contact Center Express 8.x

Components Used

 

  • Cisco Unified Contact Center Express 8.5

Problem

UCCX Agents are unable to login to the UCCX and the MIVR logs shows the following error

%MIVR-LIB_AXL-7-UNK:AXL-ExecutionCmd-23678.CCMExecuteSQLQuerySOAPAdmin: process timeout: interrupt socket

Solution

This issue is documented by Cisco Bug ID CSCtj50884 (registered customers only) and this has been observed in environments where a very large number of AXL queries are done on the CUCM server.

This AXL error message indicates that the AXL server did no’t respond in a timely manner, or the UCCX was not able to send the message across to the AXL server. This issue can be resolved by restarting the Cisco Tomcat Service on UCCX and CUCM.  So, as a workaround, estart the Tomcat service on the CLI using the command "utils service restart Cisco Tomcat".

Also, you can prevent the external application from performing AXL queries. But this is usually not a feasible workaround as AXL queries are a requirement for basic functionality of some applications.

Problem

When  I  login  to the  agent on the  phone,  I  get  this  error  message. "Your request to change  your  agent  state  failed, try  again"

Solution


In CME  7  with  UCCX  8,  while  login  to the  agent on the  phone getting error  message. "Your request to change  your  agent  state  failed try  again".

Check below the compatible version of CME with UCCX

http://www.cisco.com/en/US/docs/voice_ip_comm/cust_contact/contact_center/crs/express_compatibility/matrix/crscomtx.pdf

Please check the workarounds mentioned in the below discussions

https://supportforums.cisco.com/thread/2152343

https://supportforums.cisco.com/thread/2139454

Problem

Receiving "Login failed due to a configuration error with your phone and JTAPI or Unified CM. Contact your administrator."
when new agents try
to login via CAD.

Solution

Following were the solutions to resolve the issue:


  • On the Phone Configuration page in CUCM the  "Allow Control of Device from CTI" was not checked.
    Checked this box, save configuration, apply configuration. Agent was then able to successfully log in.

  • Added user device profile to RMCM user instead of user device MAC. (Documneted in Cisco Bug :CSCtx48427)

  • Restart the CTI Manager

  • This issue could happen if the RMCM Subsystem is stuck in initializing state, to resolve this
        reset the password for the RMCM User from CM Configuration page and restart the CCX Engine Service.

  • Associated the MAC address of the agent's phone under RMCM user.

https://supportforums.cisco.com/thread/2090094

Loading.

Actions

This Document

Related Content