How the EIGRP summary route metric is determined

Document

Thu, 11/21/2013 - 02:00
Nov 19th, 2013
User Badges:

Introduction:

This document describes how the eigrp summary route metrics is determined.

Core Issue:


There is a need to provide information on how the summary route metrics, which is created by the ip summary-address eigrp command, is determined and details of the summary-metric command implemented in association with the command.

Resolution:


  1. Configuration
  2. How the summary route metric is determined
  3. Using the summary-metric command
  4. All Devices Settings



1. Configuration

----------------------------------------------------------------------------

On R2, configure settings to summarize routes to 10.1.0.0/16 on the interface which connected to the R3

ip summary-address eigrp 1 10.1.0.0 255.255.0.0

(All setting examples are described at the end of this document)


(10.1.1.0/24)--1M--+

(10.1.2.0/24)-64K-[R1]-(10.12.1.0/24)-[R2]-(172.20.23/24)-[R3]

(10.1.3.0/24)-10M--+


(※ 15.1(4)M3 is used for all the output examples below)

----------------------------------------------------------------------------




2. How the summary route metric is determined


For EIGRP, the smallest metric among the component routes (routes contained in the summary) will be employed as the summary route metric.

----------------------------------------------------------------------------

R2#show ip eigrp topology

EIGRP-IPv4 Topology Table for AS(1)/ID(172.20.1.2)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,

       r - reply Status, s - sia Status


P 172.20.1.0/24, 1 successors, FD is 281600

      via Connected, Ethernet1/0

P 10.12.1.0/24, 1 successors, FD is 281600

      via Connected, Ethernet0/0

P 10.1.3.0/24, 1 successors, FD is 307200

      via 10.12.1.1 (307200/281600), Ethernet0/0

P 10.1.0.0/16, 1 successors, FD is 307200

      via Summary (307200/0), Null0   <-- 307200, the smallest value among the component routes

P 10.1.2.0/24, 1 successors, FD is 40051200

      via 10.12.1.1 (40051200/40025600), Ethernet0/0

P 10.1.1.0/24, 1 successors, FD is 2611200

      via 10.12.1.1 (2611200/2585600), Ethernet0/0


R2#

----------------------------------------------------------------------------



If a component route is updated and the smallest metric is changed, the summary route metric is also updated.

If there are multiple metric values in a component route, care should be exercised during network design.

----------------------------------------------------------------------------

Example: If 10.1.3.0/24 with the smallest metric goes down


R2#debug ip eigrp summary

EIGRP-IPv4 Summary debugging is on

R2#

06:41:46.167: EIGRP-IPv4(1): summary_depend: dest 10.1.3.0/24 vec 0, metric 307200, add 0 auto 0

06:41:46.167: EIGRP-IPv4(1): summary_depend: revise summary 10.1.0.0/16

06:41:46.167: EIGRP-IPv4(1): summary_revise: result 2

06:41:46.167: EIGRP-IPv4(1): summary_enqueue: 10.1.0.0/16 vec(0) summary changed

06:41:46.167: EIGRP-IPv4(1): summary_depend: dest 10.1.3.0/24 vec 0, metric 0, add 0 auto 0

06:41:46.167: EIGRP-IPv4(1): summary_depend: revise summary 10.1.0.0/16

06:41:46.167: EIGRP-IPv4(1): summary_revise: result 2

06:41:46.167: EIGRP-IPv4(1): summary_process: 3 components with static metric(0)

06:41:46.167: EIGRP-IPv4(1): summary_metric_calc: 10.1.0.0/16 with 3 components and metric 307200

06:41:46.167: EIGRP-IPv4(1): summary_metric overlapping: 10.1.2.0/24 metric 40051200

06:41:46.167: EIGRP-IPv4(1): summary_metric overlapping: 10.1.1.0/24 metric 2611200

06:41:46.167: EIGRP-IPv4(1): summary_metric_calc: 10.1.0.0/16, from 10.1.1.0/24, metric 2611200

06:41:46.167: EIGRP-IPv4(1): summary_process: 10.1.0.0/16 old(307200) new(2611200) processed(yes)

06:41:46.355: EIGRP-IPv4(1): summary_depend: dest 10.1.3.0/24 vec 0, metric 0, add 0 auto 0

06:41:46.355: EIGRP-IPv4(1): summary_depend: revise summary 10.1.0.0/16

06:41:46.355: EIGRP-IPv4(1): summary_revise: result 2

06:41:46.355: EIGRP-IPv4(1): summary_enqueue: 10.1.0.0/16 vec(0) summary changed

06:41:46.355: EIGRP-IPv4(1): summary_decr: 10.1.0.0/16 count(2)

06:41:46.355: EIGRP-IPv4(1): summary_process: 2 components with static metric(0)

06:41:46.355: EIGRP-IPv4(1): summary_metric_calc: 10.1.0.0/16 with 2 components and metric 2611200

06:41:46.355: EIGRP-IPv4(1): summary_metric overlapping: 10.1.2.0/24 metric 40051200

06:41:46.355: EIGRP-IPv4(1): summary_metric overlapping: 10.1.1.0/24 metric 2611200

06:41:46.355: EIGRP-IPv4(1): summary_metric_calc: 10.1.0.0/16, from 10.1.1.0/24, metric 2611200

06:41:46.355: EIGRP-IPv4(1): summary_process: 10.1.0.0/16 old(2611200) new(2611200) processed(yes)

R2#

R2#show ip eigrp topology

EIGRP-IPv4 Topology Table for AS(1)/ID(172.20.1.2)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,

       r - reply Status, s - sia Status


P 172.20.1.0/24, 1 successors, FD is 281600

      via Connected, Ethernet1/0

P 10.12.1.0/24, 1 successors, FD is 281600

      via Connected, Ethernet0/0

P 10.1.0.0/16, 1 successors, FD is 307200

      via Summary (2611200/0), Null0   <-- 2611200, the smallest value among the component routes

P 10.1.2.0/24, 1 successors, FD is 40051200

      via 10.12.1.1 (40051200/40025600), Ethernet0/0

P 10.1.1.0/24, 1 successors, FD is 2611200

      via 10.12.1.1 (2611200/2585600), Ethernet0/0


R2#

----------------------------------------------------------------------------




3. Using the summary-metric command


If there are many component routes to be summarized and the component routes are frequently updated, the metrics are also updated frequently, and thus a high CPU state may be caused depending on the configuration.

To deal with such a situation, the summary-metric command was implemented.


This command has been implemented in 12.2(33)SRE, 12.2(33)SXJ, 12.2(33)XNE/2.5.0, 15.0(1)M, 15.1(1)SG or later.


This command explicitly sets the metric for the summary regardless of the component route metric.

----------------------------------------------------------------------------

R2#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

R2(config)#router eigrp 1

R2(config-router)#summary-metric 10.1.0.0/16 10000 200 255 0 1500

09:09:26.023: EIGRP-IPv4(1): summary metric cmd for 10.1.0.0/16

09:09:26.023: EIGRP-IPv4(1): summary metric dly(51200) bw(256000) r(255), l(0), mtu(1500) dist(5)

09:09:26.023: EIGRP-IPv4(1): summary_update - summary changed

09:09:26.023: EIGRP-IPv4(1): summary_enqueue: 10.1.0.0/16 vec(0) summary changed

09:09:26.039: EIGRP-IPv4(1): summary_process: 2 components with static metric(1)

09:09:26.039: EIGRP-IPv4(1): summary_process: 10.1.0.0/16 old(4294967295) new(307200) processed(yes)

R2(config-router)#end

R2#

R2#show ip eigrp topology

EIGRP-IPv4 Topology Table for AS(1)/ID(172.20.1.2)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,

       r - reply Status, s - sia Status


P 172.20.1.0/24, 1 successors, FD is 281600

      via Connected, Ethernet1/0

P 10.12.1.0/24, 1 successors, FD is 281600

      via Connected, Ethernet0/0

P 10.1.0.0/16, 1 successors, FD is 307200

      via Summary (307200/0), Null0   <-- 307200, regardless of the component route value

P 10.1.2.0/24, 1 successors, FD is 40051200

      via 10.12.1.1 (40051200/40025600), Ethernet0/0

P 10.1.1.0/24, 1 successors, FD is 2611200

      via 10.12.1.1 (2611200/2585600), Ethernet0/0


R2#

----------------------------------------------------------------------------




4. All Devices Settings

----------------------------------------------------------------------------

!

hostname R1

!

interface Ethernet0/0

ip address 10.12.1.1 255.255.255.0

!

interface Ethernet1/0

bandwidth 1000

ip address 10.1.1.1 255.255.255.0

!

interface Ethernet2/0

bandwidth 64

ip address 10.1.2.1 255.255.255.0

!

interface Ethernet3/0

bandwidth 10000

ip address 10.1.3.1 255.255.255.0

!

router eigrp 1

network 10.0.0.0

!

----------------------------------------------------------------------------

!

hostname R2

!

interface Ethernet0/0

ip address 10.12.1.2 255.255.255.0

!

interface Ethernet1/0

ip address 172.20.1.2 255.255.255.0

ip summary-address eigrp 1 10.1.0.0 255.255.0.0

!

router eigrp 1

summary-metric 10.1.0.0/16 10000 200 255 0 1500

network 10.0.0.0

network 172.20.0.0

!

----------------------------------------------------------------------------

!

hostname R3

!

interface Ethernet1/0

ip address 172.20.1.3 255.255.255.0

!

router eigrp 1

network 172.20.0.0

!

----------------------------------------------------------------------------

Original Document: Cisco Support Community Japan DOC-26447

Author: Tsuyoshi Niitani

Posted on August 13, 2012

https://supportforums.cisco.com/docs/DOC-26447

Loading.

Actions

This Document