Sip incoming call from pstn not routing to plar number

Document

Wed, 01/27/2016 - 23:57
Dec 16th, 2013
User Badges:

Please see the logs------------------------------------------


Dec 16 15:30:48.224: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:

   Calling Number=, Called Number=, Voice-Interface=0x47C1C910,

   Timeout=TRUE, Peer Encap Type=ENCAP_VOICE, Peer Search Type=PEER_TYPE_VOICE,

   Peer Info Type=DIALPEER_INFO_SPEECH

*Dec 16 15:30:48.224: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:

   Result=Success(0) after DP_MATCH_PORT; Incoming Dial-peer=6

*Dec 16 15:30:48.224: //-1/DF5272B38CF7/RXRULE/regxrule_stack_pop_RegXruleNumInfo: stack=0x4A427754; count=1

*Dec 16 15:30:48.232: //-1/DF5272B38CF7/RXRULE/regxrule_stack_push_RegXruleNumInfo: stack=0x4A427754; count=0

*Dec 16 15:30:48.232: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:

   Calling Number=4600, Called Number=4600, Peer Info Type=DIALPEER_INFO_SPEECH

*Dec 16 15:30:48.232: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:

   Match Rule=DP_MATCH_DEST; Called Number=4600

*Dec 16 15:30:48.232: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:

   Result=Success(0) after DP_MATCH_DEST

*Dec 16 15:30:48.236: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersMoreArg:

   Result=SUCCESS(0)

   List of Matched Outgoing Dial-peer(s):

     1: Dial-peer Tag=2

*Dec 16 15:30:48.236: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:

   Calling Number=4600, Called Number=, Voice-Interface=0x0,

   Timeout=TRUE, Peer Encap Type=ENCAP_VOIP, Peer Search Type=PEER_TYPE_VOICE,

   Peer Info Type=DIALPEER_INFO_SPEECH

*Dec 16 15:30:48.236: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:

   Result=Success(0) after DP_MATCH_ORIGINATE; Incoming Dial-peer=2

*Dec 16 15:30:48.236: //-1/DF5272B38CF7/DPM/dpMatchPeersCore:

   Calling Number=, Called Number=4600, Peer Info Type=DIALPEER_INFO_SPEECH

*Dec 16 15:30:48.236: //-1/DF5272B38CF7/DPM/dpMatchPeersCore:

   Match Rule=DP_MATCH_DEST; Called Number=4600

*Dec 16 15:30:48.236: //-1/DF5272B38CF7/DPM/dpMatchPeersCore:

   Result=Success(0) after DP_MATCH_DEST

*Dec 16 15:30:48.236: //-1/DF5272B38CF7/DPM/dpMatchPeersMoreArg:

   Result=SUCCESS(0)

   List of Matched Outgoing Dial-peer(s):

     1: Dial-peer Tag=2

*Dec 16 15:30:48.236: //-1/DF5272B38CF7/RXRULE/regxrule_stack_push_RegXruleNumInfo: stack=0x4A427754; count=1

*Dec 16 15:30:48.236: //-1/DF5272B38CF7/RXRULE/regxrule_dp_translate: No profile found in peer 2 for outgoing direction

*Dec 16 15:30:48.236: //-1/DF5272B38CF7/RXRULE/regxrule_dp_translate: calling_number= calling_octet=0x0

        called_number=4600 called_octet=0x80

        redirect_number= redirect_type=0 redirect_plan=0        redirect_PI=0 redirect_SI=0

*Dec 16 15:30:48.240: //-1/DF5272B38CF7/RXRULE/regxrule_stack_pop_RegXruleNumInfo: stack=0x4A427754; count=2

*Dec 16 15:30:48.240: //-1/DF5272B38CF7/RXRULE/regxrule_stack_push_RegXruleNumInfo: stack=0x4A427754; count=1

*Dec 16 15:30:48.240: //-1/DF5272B38CF7/RXRULE/regxrule_stack_pop_RegXruleNumInfo: stack=0x4A427754; count=2

*Dec 16 15:30:48.244: //-1/DF5272B38CF7/RXRULE/regxrule_stack_push_RegXruleNumInfo: stack=0x4A427754; count=1

India2811(config)#

*Dec 16 15:30:54.228: //-1/DF5272B38CF7/RXRULE/regxrule_stack_pop_RegXruleNumInfo: stack=0x4A427754; count=2





Running-config----------------


version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

service internal

!

hostname India2811

!

boot-start-marker

boot system flash:c2800nm-adventerprisek9_ivs-mz.124-15.T1.bin

boot-end-marker

!

logging buffered 10000000

enable secret 5 $1$hf9n$vE3P5wXUeaDPcxymFQU7/0

enable password 7 01120C0D4F2B5756791A

!

no aaa new-model

!

!

ip cef

!

!

no ip domain lookup

!

multilink bundle-name authenticated

!

!

!

trunk group  1

!

voice-card 0

no dspfarm

!

!

voice call send-alert

voice rtp send-recv

!

voice service voip

address-hiding

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

no supplementary-service sip moved-temporarily

no supplementary-service sip refer

redirect ip2ip

fax protocol pass-through g711ulaw

modem passthrough nse codec g711ulaw

sip

  bind control source-interface FastEthernet0/1

  bind media source-interface FastEthernet0/1

  header-passing

  registrar server expires max 3600 min 3600

  no update-callerid

!

!

!

voice class codec 1

codec preference 1 g711ulaw

codec preference 2 g711alaw

codec preference 3 g729r8

!

!

!

!

!

!

!

!

!

!

!

!

voice translation-rule 1

rule 1 /^023392030/ /5678/

!

voice translation-rule 2


rule 1 /^.*/ /9&/ type national national

rule 2 /^.*/ /91&/ type national national

rule 3 /^.*/ /9011&/ type international international

!

voice translation-rule 3

rule 1 /^5.../ /023392030/

!

voice translation-rule 4

rule 1 /\(.*\)/ /9\1/

!

!

voice translation-profile pstn-in

translate calling 2

translate called 1

!

voice translation-profile pstn-out

translate calling 3

!

!

ivr record memory system 15000

ivr record memory session 1000

!

application

  service ajit2013 flash:acme4.vxml

  !

!

!

!

!

!

!

!

username [email protected]

username ajit_tarkar privilege 15 password 7 105D19482B4F110249

username spinsci privilege 15 secret 5 $1$0k5D$bvR0fctDVyqhEgl2jHWKM.

archive

log config

  hidekeys

!

ip tcp path-mtu-discovery

!

!

!

!

interface Tunnel0

no ip address

shutdown

!

interface FastEthernet0/0

ip address 183.82.1.68 255.255.224.0

ip nat outside

ip virtual-reassembly

shutdown

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 192.168.1.220 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1.1

!

interface FastEthernet1/0

!

interface FastEthernet1/1

switchport access vlan 10

!

interface FastEthernet1/2

switchport access vlan 10

!

interface FastEthernet1/3

switchport access vlan 10

switchport voice vlan dot1p

!

interface FastEthernet1/4

switchport access vlan 10

!

interf

switchport access vlan 10

!

interface FastEthernet1/6

switchport access vlan 10

!

interface FastEthernet1/7

switchport access vlan 10

!

interface FastEthernet1/8

switchport access vlan 10

!

interface FastEthernet1/9

switchport access vlan 10

!

interface FastEthernet1/10

switchport access vlan 10

!

interface FastEthernet1/11

!

interface FastEthernet1/12

!

interface FastEthernet1/13

!

interface FastEthernet1/14

!

interface FastEthernet1/15

!

interface Vlan1

no ip address

shutdown

!

ip route 0.0.0.0 0.0.0.0 192.168.1.1

!

!

ip http server

ip http authentication local

no ip http secure-server


tftp-server flash:P00307020200.bin

tftp-server flash:P00307020200.loads

tftp-server flash:P00307020200.sb2

tftp-server flash:P00307020200.sbn

tftp-server flash:P00403020214.bin

!

control-plane

!

!

!

voice-port 0/0/0

ring cadence pattern01

signal groundStart

cptone IN

timeouts call-disconnect 3

description pstn interface

!

voice-port 0/0/1

ring cadence pattern06

signal groundStart

cptone IN

timeouts call-disconnect 3

description accounts

!

voice-port 0/2/0

translation-profile outgoing pstn-out

no echo-cancel enable

cptone IN

connection plar opx 4600

description pstn line

!

voice-port 0/2/1

translation-profile incoming pstn-in

translation-profile outgoing pstn-out

connection plar opx 4500

description vonage line

caller-id enable

!

ccm-manager music-on-hold

!

!

!

!

dial-peer voice 1 voip

destination-pattern 7...

voice-class codec 1

session target ipv4:10.2.0.60

incoming called-number .

dtmf-relay h245-alphanumeric rtp-nte

!

dial-peer voice 2 voip

destination-pattern 4...

voice-class codec 1

session target ipv4:192.168.1.100

dtmf-relay h245-alphanumeric rtp-nte

!

dial-peer voice 3 pots

destination-pattern 9T

incoming called-number 5...

port 0/2/1

!

dial-peer voice 5 pots

destination-pattern 2001

port 0/0/0

!

dial-peer voice 6 pots

destination-pattern 8T

incoming called-number 5...

port 0/2/0

!

!

sip-ua

retry invite 5

retry response 10

sip-server ipv4:192.168.1.100

!

!

!

!

gatekeeper

shutdown

!

!

telephony-service

load 7910 P00403020214

load 7960-7940 P00307020200

max-ephones 20

max-dn 20

ip source-address 192.168.1.220 port 2000

auto assign 1 to 20

timeouts interdigit 4

max-conferences 8 gain -6

moh flash:music-on-hold.au

transfer-system full-consult

create cnf-files version-stamp Jan 01 2002 00:00:00

!

!

ephone-dn-template  3

call-forward busy 2026

call-forward noan 2026 timeout 10

!

!

ephone  2

device-security-mode none

description operator

!

!

banner motd ^C ^C

alias exec s sh run | sec

!

line con 0

password 7 15011B5D2A72282D6D

logging synchronous

login

line aux 0

line vty 0 4

password 7 08325C1F2741061E57

login

!

scheduler allocate 20000 1000


!

webvpn cef

!

end






ace FastEthernet1/5

Loading.
ajit_tarkar Mon, 12/16/2013 - 06:47
User Badges:

my call manager -192.168.1.100

i have one pstn line to fxo 0/2/0

there is no ITSP , No t1/e1

Kevin Monteiro Wed, 01/27/2016 - 23:57
User Badges:
  • Silver, 250 points or more

Ajit,


Can you explain the call-flow:


IP-PHONE>>>CUCM>>SIP/H.323/MGCP/SCCP>>>GW>>FXO>>PSTN


From the "show run" it looks like you have a sip-trunk.


If so, can you check  the "dial-peer voice 2 voip", its missing  the command "session protcol sipv2".


Give it a shot, run the debugs again.


Config t

Logging buffer 50000000  debugging

No logging console

No logging monitor

Logging on

Exit


debug voip vtsp all


debug vpm signa


debug  voip ccapi inout


debug ccsip messages


Rate the post accordingly.


-Regards,


Kevin Monteiro

Muthurani Lavan... Mon, 01/13/2014 - 01:29
User Badges:
  • Gold, 750 points or more

Hello Ajit


Please post this query under the "Discussions" section to get the advice from the experts. 


Regards

Laanya

Actions

This Document