OTV Configuration and Verification

Document

Wed, 01/29/2014 - 08:13
Jan 29th, 2014
User Badges:
  • Cisco Employee,

This document covers basic OTV configuration and Verification between two N7K

Each N7K configured with two VDC


OTV VDC

Core_VDC


VLAN 2 configured on Core_VDC of both N7K, and extending VLAN 2 traffic between two N7K via OTV VDC.

Connectivity will be verified via ping between two N7K.


Topology

OTV VDC Diagram.jpg



Configuration

Nexus 7K1

Create VDC & Allocate required interfaces


Config t

!

vdc Core_VDC

allocate interface Ethernet1/4

!

vdc OTV_VDC

allocate interface Ethernet2/1, Ethernet2/3

!


Switchto Core_VDC and configure VLAN, SVI, and Layer 2 connectivity to OTV_VDC


switchto vdc Core_VDC

!

Vlan 2

!

feature interface-vlan

!

interface Vlan2

no shutdown

ip address 10.0.0.2/24

!

interface Ethernet1/4

switchport mode trunk

switchport trunk allowed vlan all

no shutdown

!


Switchto OTV_VDC and configure VLAN, Internal Interface, Join Interface and Overlay Interface


switchto vdc OTV_VDC

vlan 2

vlan 1999     <<<<< Site Vlan

!

interface Ethernet2/3

description Internal Interface   <<<< Connectivity to Core_VDC

switchport

switchport mode trunk

no shutdown

!


interface Ethernet2/1

description join interface   <<<< Connectivity to another N7K

ip address 172.168.1.1/24

ip igmp version 3

no shutdown

!

feature otv

!

otv site-vlan 1999

otv site-identifier 0x1

!

interface Overlay1

otv join-interface Ethernet2/1

otv extend-vlan 2

otv adjacency-server unicast-only   <<<< N7K1 act as Adjacency Server

no otv suppress-arp-nd

no shutdown

!

                        

Nexus 7K2

Create VDC & Allocate required interfaces


Config t

!

vdc Core_VDC

allocate interface Ethernet1/4

!

vdc OTV_VDC

allocate interface Ethernet2/7, Ethernet2/3

!


Switchto Core_VDC and configure VLAN, SVI, and Layer 2 connectivity to OTV_VDC


switchto vdc Core_VDC

!

Vlan 2

!

feature interface-vlan

!

interface Vlan2

no shutdown

ip address 10.0.0.1/24

!

interface Ethernet1/4

switchport mode trunk

switchport trunk allowed vlan all

   no shutdown

!


Switchto OTV_VDC and configure VLAN, Internal Interface, Join Interface and Overlay Interface


switchto vdc OTV_VDC

vlan 2

vlan 1999     <<<<< Site Vlan

!

interface Ethernet2/3

description Internal Interface   <<<< Connectivity to Core_VDC

switchport

switchport mode trunk

no shutdown

!


interface Ethernet2/7

description join interface   <<<< Connectivity to another N7K

ip address 172.168.1.2/24

ip igmp version 3

no shutdown

!

feature otv

!

otv site-vlan 1999

otv site-identifier 0x2

!

interface Overlay1

otv join-interface Ethernet2/7

otv extend-vlan 2-99

otv use-adjacency-server 172.168.1.1 unicast-only <<< Define adjacency to adjacency server N7K1

no otv suppress-arp-nd

no shutdown

!



Verification

!

D12-N7010-1-OTV_VDC# show otv


OTV Overlay Information

Site Identifier 0000.0000.0001


Overlay interface Overlay1


VPN name           : Overlay1

VPN state           : UP

Extended vlans     : 2-99 (Total:98)

Join interface(s)   : Eth2/1 (172.168.1.1)

Site vlan           : 1999 (up)

AED-Capable         : Yes

Capability         : Unicast-Only

Is Adjacency Server : Yes

Adjacency Server(s) : [None] / [None]


D11-N7010-2-OTV_VDC# show otv


OTV Overlay Information

Site Identifier 0000.0000.0002


Overlay interface Overlay1


VPN name           : Overlay1

VPN state           : UP

Extended vlans     : 2-99 (Total:98)

Join interface(s)   : Eth2/7 (172.168.1.2)

Site vlan           : 1999 (up)

AED-Capable         : Yes

Capability         : Unicast-Only

Is Adjacency Server : No

Adjacency Server(s) : 172.168.1.1 / [None]



D12-N7010-1-OTV_VDC# show otv vlan


OTV Extended VLANs and Edge Device State Information (* - AED)


Legend:

(NA) - Non AED, (VD) - Vlan Disabled, (OD) - Overlay Down

(DH) - Delete Holddown, (HW) - HW: State Down

(NFC) - Not Forward Capable


VLAN   Auth. Edge Device                     Vlan State                 Overlay

----   -----------------------------------   ----------------------       ------

-

   2* D12-N7010-1-OTV_VDC                   active                 Overlay1


D11-N7010-2-OTV_VDC# show otv vlan


OTV Extended VLANs and Edge Device State Information (* - AED)


Legend:

(NA) - Non AED, (VD) - Vlan Disabled, (OD) - Overlay Down

(DH) - Delete Holddown, (HW) - HW: State Down

(NFC) - Not Forward Capable


VLAN   Auth. Edge Device                     Vlan State                 Overlay

----   -----------------------------------   ----------------------       ------

-

   2* D11-N7010-2-OTV_VDC                   active                 Overlay1



Ping from N7K1 Core_VDC to N7K2 Core_VDC


D12-N7010-1-Core_VDC# ping 10.0.0.1

PING 10.0.0.1 (10.0.0.1): 56 data bytes

64 bytes from 10.0.0.1: icmp_seq=0 ttl=254 time=1.652 ms

64 bytes from 10.0.0.1: icmp_seq=1 ttl=254 time=0.924 ms

64 bytes from 10.0.0.1: icmp_seq=2 ttl=254 time=37.35 ms

64 bytes from 10.0.0.1: icmp_seq=3 ttl=254 time=0.933 ms

64 bytes from 10.0.0.1: icmp_seq=4 ttl=254 time=0.849 ms


--- 10.0.0.1 ping statistics ---

5 packets transmitted, 5 packets received, 0.00% packet loss

round-trip min/avg/max = 0.849/8.341/37.35 ms


Loading.

Actions

This Document

Related Content

 

 

Trending Topics: Other DC Subjects