×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Connectivity issue when QOS is applied on the EtherChannel in Catalyst 6500 series switches that run CatOS

Document

Wed, 07/22/2009 - 19:48
Jun 22nd, 2009
User Badges:
  • Gold, 750 points or more

Core issue

This is an expected behavior as you apply the Quality of Service (QoS) on the physical interfaces that make up the EtherChannel. Since the commands get applied line-by-line, the port channel sees the ports mismatched at different instances of time, which causes it to unbundle the ports.


Resolution

Once an EtherChannel is configured, it is recommended that you apply commands to the logical port-channel interface and these get propagated to the individual ports.

In other words, when you configure QoS on a port that is part of an EtherChannel on CatOS, you must always configure it on a per-port basis. Also, you must ensure that you apply the same QoS configuration to all ports, because the EtherChannel can only bundle ports with the same QoS configurations. This means that you need to configure these parameters the same:

  • Port trust type
  • Receive port type (2q2t or 1p2q2t)
  • Transmit port type (1q4t or 1p1q4t)
  • Default port class of service (CoS)
  • Port-based QoS or VLAN-based QoS
  • Access control list (ACL) or protocol pair that the port carries


Refer to the article Configure EtherChannel between Catalyst switches that run CatOS and Cisco IOS system software for more information on how to configure EtherChannel between Catalyst switches that run CatOS and Cisco IOS  software.

Loading.

Actions

This Document

Related Content