Configuring and troubleshooting Router as a PPPoE client

Document

Sep 28, 2009 3:33 PM
Sep 28th, 2009

/* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-parent:""; mso-padding-alt:0in 5.4pt 0in 5.4pt; mso-para-margin-top:0in; mso-para-margin-right:0in; mso-para-margin-bottom:10.0pt; mso-para-margin-left:0in; mso-pagination:widow-orphan; font-size:12.0pt; font-family:"Times New Roman"; mso-ascii-font-family:Cambria; mso-ascii-theme-font:minor-latin; mso-fareast-font-family:"Times New Roman"; mso-fareast-theme-font:minor-fareast; mso-hansi-font-family:Cambria; mso-hansi-theme-font:minor-latin;}

Introduction

This document provides a sample configuration of Point-to-Point Protocol over Ethernet (PPPoE) termination on a C10k router as LNS via L2TP tunnel. In this document, the PPPoE session is initiated by a Cisco 2821 router as the PPPoE client, and transmits the PPP traffic through a secure Layer Two Tunneling Protocol (L2TP) tunnel connection to the L2TP Network Server (LNS). The LNS router terminates the L2TP tunnel from the Cisco ASR1006 router as a L2TP tunnel client, and may forward the traffic to the corporate network.

As we all know, many customers have PPPoE clients as a router or a PC terminated via Layer1 and 2 with the local LAC where PPPoE terminates. After that based on the domain name that is associated with the user, LAC will forward the tunnel to appropriate LNS or Home Gateway router over L2TP tunnel.

Topology:

pppoe-l2tp.gif

v\:* {behavior:url(#default#VML);} o\:* {behavior:url(#default#VML);} w\:* {behavior:url(#default#VML);} .shape {behavior:url(#default#VML);} /* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-parent:""; mso-padding-alt:0in 5.4pt 0in 5.4pt; mso-para-margin-top:0in; mso-para-margin-right:0in; mso-para-margin-bottom:10.0pt; mso-para-margin-left:0in; mso-pagination:widow-orphan; font-size:12.0pt; font-family:"Times New Roman"; mso-ascii-font-family:Cambria; mso-ascii-theme-font:minor-latin; mso-fareast-font-family:"Times New Roman"; mso-fareast-theme-font:minor-fareast; mso-hansi-font-family:Cambria; mso-hansi-theme-font:minor-latin;}

pppoe-l2tp.gif


The information presented in this document was created from devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If you are working in a live network, ensure that you understand the potential impact of any command before using it.

PPPoE Client configuration :

------------------------------------

C2821-CPE#sh run

Building configuration...

Current configuration : 1666 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

service internal

!

hostname C2821-CPE

!

boot-start-marker

boot-end-marker

!

logging buffered 65535

enable secret 5 $1$VfRM$dURjvEzeb5YVNGFg4sbxr/

!

no aaa new-model

no network-clock-participate wic 0

!

!

dot11 syslog

!

!

ip cef

!

!

no ip domain lookup

ip auth-proxy max-nodata-conns 3

ip admission max-nodata-conns 3

!

multilink bundle-name authenticated

!

!

!

interface GigabitEthernet0/0

no ip address

load-interval 30

duplex auto

speed auto

!

interface GigabitEthernet0/1

ip address 10.1.1.2 255.255.255.0

! Configured for inside network

duplex auto

speed auto

pppoe enable group global           

  ! PPPoE configured for this interface

pppoe-client dial-pool-number 1 dial-on-demand

! This interface will be used as a PPPoE client medium using dialer 1 interface

!

interface Dialer1

! This interface will be used as layer 3 interface.

ip address negotiated

! Ip address will be allocated by ISP

ip mtu 900

encapsulation ppp

dialer pool 1

! This command uses interface configured with “dial-pool-number 1” as transmission medium.

ip nat outside

dialer idle-timeout 600 either

dialer-group 1

ppp authentication chap callin

ppp chap hostname ParamPreet@cisco.com

ppp chap password 0 cisco

!Username and password to be used for client authentication

!

ip forward-protocol nd

ip nat inside source list 1 interface Dialer1 overload

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

!

!

ip http server

no ip http secure-server

!

dialer-list 1 protocol ip permit

!

!

!

!

!

!

control-plane

!

!

!

!

!

!

!

!

!

!

line con 0

exec-timeout 0 0

privilege level 15

logging synchronous

line aux 0

privilege level 15

password cisco

login

line vty 0 4

exec-timeout 60 0

privilege level 15

password cisco

logging synchronous

login

line vty 5 10

exec-timeout 60 0

privilege level 15

password cisco

logging synchronous

login

!

scheduler allocate 20000 1000

!

end

C2821-CPE#

C2821-CPE#

C2821-CPE# sh debug

PPP:

  PPP authentication debugging is on

  PPP authorization debugging is on

  PPP protocol negotiation debugging is on

PPPoE:

  PPPoE protocol events debugging is on

  PPPoE control packets debugging is on

  PPPoE protocol errors debugging is on

C2821-CPE#ping 1.1.1.1

! Ping is issued to route the packets via dialer interface so that PPPoE connection “on demand” based on interesting traffic  can be initiated.

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:

*Sep 21 20:24:20.563: pppoe_send_padi:

            FF FF FF FF FF FF 00 1B D4 EE 63 C1 88 63 11 09

            00 00 00 0C 01 01 00 00 01 03 00 04 48 3A 81 9C ...

*Sep 21 20:24:20.567: PPPoE 0: I PADO  R:0024.14ab.d701 L:001b.d4ee.63c1 Gi0/1

            00 1B D4 EE 63 C1 00 24 14 AB D7 01 88 63 11 07

            00 00 00 32 01 01 00 00 01 03 00 04 48 3A 81 9C ....

*Sep 21 20:24:22.447: OUT PADR from PPPoE Session

            00 24 14 AB D7 01 00 1B D4 EE 63 C1 88 63 11 19

            00 00 00 32 01 01 00 00 01 03 00 04 48 3A 81 9C ...

*Sep 21 20:24:22.447: PPPoE 24: I PADS  R:0024.14ab.d701 L:001b.d4ee.63c1 Gi0/1

            00 1B D4 EE 63 C1 00 24 14 AB D7 01 88 63 11 65

            00 18 00 32 01 01 00 00 01 03 00 04 48 3A 81 9C ...

*Sep 21 20:24:22.451: %DIALER-6-BIND: Interface Vi2 bound to profile Di1

*Sep 21 20:24:22.451: Vi2 PPP: Phase is DOWN, Setup

*Sep 21 20:24:22.451: Vi2 PPP: Using dialer call direction

*Sep 21 20:24:22.451: Vi2 PPP: Treating connection as a callout

*Sep 21 20:24:22.451: Vi2 PPP: Session handle[7700005A] Session id[0]

*Sep 21 20:24:22.451: Vi2 PPP: Phase is ESTABLISHING, Active Open

*Sep 21 20:24:22.451: Vi2 PPP: Authorization required

*Sep 21 20:24:22.451: Vi2 PPP: No remote authentication for call-out

*Sep 21 20:24:22.451: Vi2 LCP: O CONFREQ [Closed] id 1 len 10

*Sep 21 20:24:22.451: Vi2 LCP:    MagicNumber 0x1C9E8EAB (0x05061C9E8EAB)

*Sep 21 20:24:22.451: Vi2 LCP: I CONFREQ [REQsent] id 1 len 18

*Sep 21 20:24:22.451: Vi2 LCP:    MRU 800 (0x01040320)

*Sep 21 20:24:22.451: Vi2 LCP:    AuthProto PAP (0x0304C023)

*Sep 21 20:24:22.451: Vi2 LCP:    MagicNumber 0x24E0594C (0x050624E0594C)

*Sep 21 20:24:22.451: Vi2 LCP: O CONFNAK [REQsent] id 1 len 13

*Sep 21 20:24:22.451: Vi2 LCP:    MRU 1500 (0x010405DC)

*Sep 21 20:24:22.451: Vi2 LCP:    AuthProto CHAP (0x0305C22305)

*Sep 21 20:24:22.451: Vi2 LCP: I CONFACK [REQsent] id 1 len 10

*Sep 21 20:24:22.451: Vi2 LCP:    MagicNumber 0x1C9E8EAB (0x05061C9E8EAB)

*Sep 21 20:24:22.455: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to up

*Sep 21 20:24:22.455: Vi2 LCP: I CONFREQ [ACKrcvd] id 2 len 19

*Sep 21 20:24:22.455: Vi2 LCP:    MRU 1500 (0x010405DC)

*Sep 21 20:24:22.455: Vi2 LCP:    AuthProto CHAP (0x0305C22305)

*Sep 21 20:24:22.455: Vi2 .LCP:    MagicNumber 0x24E0594C (0x050624E0594C)

*Sep 21 20:24:22.455: Vi2 LCP: O CONFACK [ACKrcvd] id 2 len 19

*Sep 21 20:24:22.455: Vi2 LCP:    MRU 1500 (0x010405DC)

*Sep 21 20:24:22.455: Vi2 LCP:    AuthProto CHAP (0x0305C22305)

*Sep 21 20:24:22.455: Vi2 LCP:    MagicNumber 0x24E0594C (0x050624E0594C)

*Sep 21 20:24:22.455: Vi2 LCP: State is Open

*Sep 21 20:24:22.455: Vi2 PPP: No authorization without authentication

*Sep 21 20:24:22.455: Vi2 PPP: Phase is AUTHENTICATING, by the peer

*Sep 21 20:24:22.475: Vi2 CHAP: I CHALLENGE id 1 len 35 from "BARI-ASR1006-1"

*Sep 21 20:24:22.475: Vi2 CHAP: Using hostname from interface CHAP

*Sep 21 20:24:22.475: Vi2 CHAP: Using password from interface CHAP

*Sep 21 20:24:22.475: Vi2 CHAP: O RESPONSE id 1 len 36 from "ParamPreet@cisco.com"

*Sep 21 20:24:22.515: Vi2 CHAP: I SUCCESS id 1 len 4

*Sep 21 20:24:22.515: Vi2 PPP: Phase is FORWARDING, Attempting Forward

*Sep 21 20:24:22.515: Vi2 PPP: Queue IPCP code[1] id[1]

*Sep 21 20:24:22.515: Vi2 PPP SSS: Receive SSS-Mgr Connect-Local

*Sep 21 20:24:22.515: Vi2 PPP: Phase is ESTABLISHING, Finish LCP

*Sep 21 20:24:22.515: Vi2 PPP: Phase is UP

*Sep 21 20:24:22.515: Vi2 IPCP: O CONFREQ [Closed] id 1 len 10

*Sep 21 20:24:22.515: Vi2 IPCP:    Address 0.0.0.0 (0x030600000000)

*Sep 21 20:24:22.515: Vi2 CDPCP: O CONFREQ [Closed] id 1 len 4

*Sep 21 20:24:22.515: Vi2 PPP: Process pending ncp packets

*Sep 21 20:24:22.515: Vi2 IPCP: Redirect packet to Vi2

*Sep 21 20:24:22.515: Vi2 IPCP: I CONFREQ [REQsent] id 1 len 10

*Sep 21 20:24:22.515: Vi2 IPCP:    Address 20.20.20.1 (0x030614141401)

*Sep 21 20:24:22.515: Vi2 IPCP: O CONFACK [REQsent] id 1 len 10

*Sep 21 20:24:22.515: Vi2 IPCP:    Address 20.20.20.1 (0x030614141401)

*Sep 2.1 20:24:22.515: Vi2 IPCP: I CONFNAK [ACKsent] id 1 len 10

*Sep 21 20:24:22.519: Vi2 IPCP:    Address 20.20.20.2 (0x030614141402)

*Sep 21 20:24:22.519: Vi2 IPCP: O CONFREQ [ACKsent] id 2 len 10

*Sep 21 20:24:22.519: Vi2 IPCP:    Address 20.20.20.2 (0x030614141402)

*Sep 21 20:24:22.519: Vi2 LCP: I PROTREJ [Open] id 1 len 10 protocol CDPCP (0x820701010004)

*Sep 21 20:24:22.519: Vi2 CDPCP: State is Closed

*Sep 21 20:24:22.519: Vi2 CDPCP: State is Listen

*Sep 21 20:24:22.519: Vi2 IPCP: I CONFACK [ACKsent] id 2 len 10

*Sep 21 20:24:22.519: Vi2 IPCP:    Address 20.20.20.2 (0x030614141402)

*Sep 21 20:24:22.519: Vi2 IPCP: State is Open

*Sep 21 20:24:22.519: Di1 IPCP: Install negotiated IP interface address 20.20.20.2

*Sep 21 20:24:22.519: Di1 IPCP: Install route to 20.20.20.1

*Sep 21 20:24:22.523: Vi2 IPCP: Add link info for cef entry 20.20.20.1

*Sep 21 20:24:23.455: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access2, changed state to up

*Sep 21 20:24:23.503: [0]PPPoE 24: Vi2 O FS..

Success rate is 0 percent (0/5)

C2821-CPE#

C2821-CPE#

C2821-CPE#

C2821-CPE#s

*Sep 21 20:24:33.743: [0]PPPoE 24: Vi2 O FS

C2821-CPE#sh ip int brief

Interface                  IP-Address      OK? Method Status                Protocol

GigabitEthernet0/0         unassigned    YES NVRAM  up                    down   

GigabitEthernet0/1         10.1.1.2      YES NVRAM  up                   up     

Virtual-Access1            unassigned      YES unset  up                    up     

Virtual-Access2            unassigned      YES unset  up                    up     

Dialer1                    20.20.20.2     YES IPCP   up                   up     

Average Rating: 5 (1 ratings)

Actions

Login or Register to take actions

This Document

Posted September 28, 2009 at 3:33 PM
Stats:
Comments:0 Avg. Rating:5
Views:14706 Contributors:0
Shares:0
Tags: client, pppoe
+

Related Content

Documents Leaderboard

Rank Username Points
1 106
2 20
3 9
4 5
Rank Username Points
15
5