Troubleshooting PacketCable Onnet call between MTAs

Document

Sep 30, 2009 2:23 PM
Sep 30th, 2009

v\:* {behavior:url(#default#VML);} o\:* {behavior:url(#default#VML);} w\:* {behavior:url(#default#VML);} .shape {behavior:url(#default#VML);} /* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-parent:""; mso-padding-alt:0in 5.4pt 0in 5.4pt; mso-para-margin-top:0in; mso-para-margin-right:0in; mso-para-margin-bottom:10.0pt; mso-para-margin-left:0in; mso-pagination:widow-orphan; font-size:12.0pt; font-family:"Times New Roman"; mso-ascii-font-family:Cambria; mso-ascii-theme-font:minor-latin; mso-hansi-font-family:Cambria; mso-hansi-theme-font:minor-latin;}

Troubleshooting Packetcable Onnet call between MTAs

Overview of the PacketCable Architecture:

Call management servers (CMSs)- BTS10200, and media gateway controllers (MGCs) provide centralized call-control processing by passing control information and setting up connections between residential MTAs. When these connections are established, voice passes directly between gateway endpoints in the form of Real-Time Transport Protocol (RTP) packet streams, as shown in Figure 2. Most connections with the PSTN are through ISDN User Part (ISUP) trunks with a media gateway providing the bearer connections and a signaling gateway providing the signaling connection into the Signaling System 7 (SS7) network. For some specialized requirements, for example, operator devices, MultiFrequency (MF) or channel associated signaling (CAS) trunks are provided.

/* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-parent:""; mso-padding-alt:0in 5.4pt 0in 5.4pt; mso-para-margin-top:0in; mso-para-margin-right:0in; mso-para-margin-bottom:10.0pt; mso-para-margin-left:0in; mso-pagination:widow-orphan; font-size:12.0pt; font-family:"Times New Roman"; mso-ascii-font-family:Cambria; mso-ascii-theme-font:minor-latin; mso-hansi-font-family:Cambria; mso-hansi-theme-font:minor-latin;}

Dynamic Quality of Service (DQoS)

Quality of service (QoS) is one of the most important aspects of a residential voice service. To ensure that a service offering is acceptable to an MSO's customers, the quality must be as good as or better than the existing voice service that is, the PSTN.

For this purpose, PacketCable has defined dynamic QoS (DQoS). The DQoS architecture focuses on the access portion of the network, specifically between the MTA and the CMTS.

The major concepts of the DQoS specification follow:

  • PacketCable      DQoS gates
  • A gate is a logical entity that resides on a CMTS. A gate consists of a packet      classifier, a traffic policy, and an interface to an entity that gathers      statistics and events (the record keeping server [RKS]). A gate can ensure      that only those sessions that have been authorized by the service provider      receive high-quality service. This is accomplished by using the gate ID as      an authorization token when requests are made to reserve or commit the      flow.
  • Billing      based on the use of resources
  • PacketCable      use of DOCSIS QoS is accounted for on a per-session basis.
  • Two-phase      (reserve-commit) QoS activation model
  • In the      two-phase model, the application reserves the resource and then later      commits it. As in the DOCSIS model, resources that are reserved but not      yet committed are available for temporary assignment to other (for      example, best effort) service flows. Billing is started when the resources      are actually committed.
  • Prevention      of (minimizing) abusive QoS usage
  • Two types      of abusive QoS usage are identified: that which is accurately billed but      leads to denying service to others, and that which is not accurately      billed and leads to theft of service.
  • Provisioning      of admission control mechanisms for both upstream and downstream      directions in the DOCSIS network
  • Both      upstream and downstream QoS should be subject to per-session admission      control.

DQoS uses several protocols and components to establish a guaranteed service. These protocols include DOCSIS 1.1, the Resource Reservation Protocol (RSVP) (not necessary for EMTA), the Common Open Policy Services (COPS), and PacketCable Event Messaging.

Components involved in this architecture follow:

1. Cable modem—The cable modem is responsible for classifying, policing, and marking packets onto the proper service flows after these flows are established by appropriate signaling protocols.

2. CMTS—The CMTS is responsible for allocating and scheduling upstream and downstream bandwidth in accordance with MTA requests and QoS authorizations established by the CMS. The CMTS acts as a policy enforcement point (PEP) as defined by the COPS [5].

3. CMS—The CMS performs services that permit MTAs to establish multimedia sessions. The term gate controller refers to the portion of the CMS that performs the QoS-related functions. In the DQoS architecture, the gate controller controls the operation of the gates implemented on a CMTS. The gate controller acts as a policy decision point (PDP) as defined by the COPS [5].

4. RKS—The RKS coordinates the event messages, specifically DQoS-related messages, as described in the
section "Event Messaging."

The early stages of the PacketCable architecture focuses on embedded MTAs only, and the following describes the relevant messages for this scenario (refer to Figure 3).



PacketCable DQoS Model

voip.jpg

/* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-parent:""; mso-padding-alt:0in 5.4pt 0in 5.4pt; mso-para-margin-top:0in; mso-para-margin-right:0in; mso-para-margin-bottom:10.0pt; mso-para-margin-left:0in; mso-pagination:widow-orphan; font-size:12.0pt; font-family:"Times New Roman"; mso-ascii-font-family:Cambria; mso-ascii-theme-font:minor-latin; mso-hansi-font-family:Cambria; mso-hansi-theme-font:minor-latin;}

1.  After the appropriate voice signaling, the gate controller portion of the CMS requests a gate from the CMTS, via the Gate-Alloc message. This Gate-Alloc message is transported using COPS.

2.  If the EMTA is using less than the maximum number of gates allowed for the subscriber, the CMTS replies with a Gate-Alloc-Ack message, which contains the gate ID of the gate to be used for this session.

3.  If the proper resources can be reserved on both the terminating CMTS and the backbone, the CMS issues a Gate-Set message to the CMTS to authorize the gate.

4.  At this point, the CMS sends the Gate-ID message to the EMTA via voice signaling (NCS) and instructs the EMTA to reserve the flow.

5.  The EMTA in turn sends a DOCSIS 1.1 Dynamic Service Add (DSA) request message to the CMTS that includes the gate ID.

6.  The CMTS sends the QoS-Reserve event message to the RKS in order to audit the start of resource reservation. Event messages are discussed further in the section "Event Messaging." Event messages are transported using Remote Authentication Dial-In User Service (RADIUS).

7.  After the terminating end picks up the phone, the CMS sends a signaling message to the EMTA to inform the EMTA that the flow should be committed.

8.  The EMTA sends a DOCSIS 1.1 Dynamic Service Change (DSC) message to actually commit
the resources.

9.  At this point, the CMTS sends the QoS-Commit event message to the RKS in order to audit the start of resource commitment.

10.  The CMTS also sends a Gate-Open message to the CMS to inform the CMS of the gate state change.

11.  When the call is terminated, the EMTA sends a Dynamic Service Delete (DSD) message to remove the DOCSIS service flow.

12.  The CMTS sends a QoS-Release event message to the RKS, and the auditing is terminated.

13.  The CMTS also sends a Gate-Close message to the CMS to inform the CMS of the gate state change.

14.  For more details on the PacketCable DQoS model, refer to the PacketCable Dynamic
Quality-of-Service Specification
Version I05, Nov. 27, 2002

DQOS signaling between CMTS and MTA :

MTA                                                     CMTS

-------                                                -------------

DSA REQ--------------------------------à

(contains ds and us classifiers plus gate id in auth block

activation state=inactive)

                

ß----------------------------------DSA RESP (conf success)

(service flow ids for us and ds and contains resource id in auth block, activation state=Inactive)

DSA Ack--------------------------------à

DSC REQ-------------------------------à

(communicates any change in classifers and activation state=active, resource id contained in auth block)

ß----------------------------------DSC RESP (conf success)

            (service flow ids for us and ds and contains resource id in auth block,activation state=active)

DSC Ack--------------------------------à

DSD Req--------------------------------à

(us and ds service flow ids)

ß----------------------------------DSD Resp (conf success)

My-CMTS#sh run

Building configuration...

Current configuration : 19759 bytes

!

! Last configuration change at 15:44:37 DST Mon Aug 3 2009

! NVRAM config last updated at 17:33:21 DST Fri Jul 31 2009

!

version 12.3

no service pad

service timestamps debug datetime msec localtime

service timestamps log datetime msec localtime

no service password-encryption

service internal

!

hostname My-CMTS

!

boot-start-marker

boot-end-marker

!

logging buffered 10000000 debugging

enable password ww

!

clock timezone EST -5

clock summer-time DST recurring

cable flap-list aging 1440

cable modem vendor 00.02.00 Apache-ACB

cable modem vendor 00.02.16 ubr924

cable modem vendor 00.08.0D ToshPCX260

cable modem vendor 00.08.0E Moto4200

cable modem vendor 00.06.25 Linksys

cable modem vendor 00.12.25 Moto5100

cable modem vendor 00.0C.41 Linksys

cable modem vendor 00.20.40 Moto4100

cable modem vendor 00.0E.5C Motorola

cable modem vendor 00.04.75 3com3CR292

cable modem vendor 00.50.04 3Com

cable modem vendor 00.0A.73 SA

cable modem vendor 00.30.3B DLink-HW32

cable modem vendor 00.02.8A Ambit60678

cable modem vendor 00.30.54 Belkin5530

cable modem vendor 00.0E.9B Ambit60740

cable modem vendor 00.04.BD Moto4100

cable modem vendor 00.40.7B SA-DPX100

cable modem vendor 00.0C.E5 Moto5100

cable modem vendor 00.02.FD ubr925

cable modem vendor 00.01.03 3com3CR292

cable modem vendor 00.0B.06 Moto5100

cable modem vendor 00.07.11 Acterna

cable modem vendor 00.11.1A Moto5100

cable modem vendor 00.0F.21 SA_DPC2100

cable modem vendor 00.50.DA 3Com

cable modem vendor 00.0F.3D Dlink-202

cable modem vendor 00.90.83 ToshPCX220

cable modem vendor 00.01.64 ubr925

cable modem vendor 00.0F.66 Linksys

cable modem vendor 00.80.C8 DLink-201

cable modem vendor 00.D0.58 ubr924

cable modem vendor 00.01.96 ubr924

cable modem vendor 00.11.80 Moto5120

cable modem vendor 00.0D.88 DLink-201

cable modem vendor 00.0F.9F Moto5100

cable modem vendor 00.E0.6F Terayon715

cable modem vendor 00.11.AE Moto5100

cable modem vendor 00.D0.BA ubr924

cable modulation-profile 5 request 0 16 0 8 qpsk scrambler 152 no-diff 64 fixed uw16

cable modulation-profile 5 initial 5 34 0 48 qpsk scrambler 152 no-diff 128 fixed uw16

cable modulation-profile 5 station 5 34 0 48 qpsk scrambler 152 no-diff 128 fixed uw16

cable modulation-profile 5 short 7 76 7 8 16qam scrambler 152 no-diff 144 shortened uw16

cable modulation-profile 5 long 9 220 0 8 16qam scrambler 152 no-diff 160 shortened uw16

no cable qos permission create

no cable qos permission update

cable qos permission modems

!

cable qos enforce-rule Test-DS

  penalty-period 45

!

cable load-balance group 1 method utilization

cable load-balance group 1 interval 20

cable load-balance group 1 threshold load 1 enforce 5

no cable load-balance group 1 policy ugs

aaa new-model

!

!

aaa group server radius default

!

aaa group server radius myrks1

server 172.18.105.238 auth-port 1812 acct-port 1813

server 172.18.105.239 auth-port 1812 acct-port 1813

!        

aaa authentication login default none

aaa accounting network default start-stop group default

aaa accounting network myrks1 start-stop group myrks1

aaa session-id common

ip subnet-zero

!

!

ip cef

no ip domain lookup

ip dhcp smart-relay

ip dhcp relay information option

!

packetcable element-id 6969

packetcable authorize vanilla-docsis-mta

packetcable multimedia

packetcable

!

crypto ca trustpoint DOCSIS-ROOT-CERT

!

!

!

!

crypto isakmp policy 1

encr 3des

hash md5

authentication pre-share

group 2

crypto isakmp key scpage address 14.80.85.36

crypto isakmp key scpage address 14.80.85.68

crypto isakmp key scpage address 14.80.85.37

crypto isakmp key scpage address 14.80.85.69

!

crypto ipsec security-association lifetime seconds 86400

!

crypto ipsec transform-set 3DES_MD5 esp-3des esp-md5-hmac

mode transport

crypto ipsec transform-set 3DES_SHA1 esp-des esp-md5-hmac

mode transport

!

crypto map COPS 1 ipsec-isakmp

set peer 14.80.85.36

set transform-set 3DES_MD5 3DES_SHA1

match address COPS1

crypto map COPS 2 ipsec-isakmp

set peer 14.80.85.37

set transform-set 3DES_MD5 3DES_SHA1

match address COPS2

crypto map COPS 3 ipsec-isakmp

set peer 14.80.85.68

set transform-set 3DES_MD5 3DES_SHA1

match address COPS3

crypto map COPS 4 ipsec-isakmp

set peer 14.80.85.69

set transform-set 3DES_MD5 3DES_SHA1

match address COPS4

!

!

!

interface GigabitEthernet0/1

ip address 14.80.72.2 255.255.255.252

no ip proxy-arp

no ip route-cache cef

no ip route-cache

no ip mroute-cache

duplex full

speed auto

media-type rj45

negotiation auto

!        

interface GigabitEthernet0/2

ip address 14.80.72.6 255.255.255.252

no ip proxy-arp

no ip route-cache cef

no ip route-cache

no ip mroute-cache

duplex full

speed auto

media-type rj45

negotiation auto

!

interface GigabitEthernet0/3

no ip address

shutdown

duplex auto

speed auto

media-type rj45

negotiation auto

!

interface FastEthernet1/0

description scpage cube 021 blue

no ip address

no ip route-cache cef

no ip route-cache

no ip mroute-cache

duplex full

!

interface Cable3/0

no ip address

shutdown

cable insertion-interval automatic 25 500

cable downstream rate-limit token-bucket shaping max-delay 1024

cable downstream annex B

cable downstream modulation 256qam

cable downstream interleave-depth 32

cable downstream channel-id 0

cable upstream 0 frequency 6000000

cable upstream 0 channel-width 3200000 1600000

cable upstream 0 minislot-size 2

cable upstream 0 power-level 0

cable upstream 0 modulation-profile 5

cable upstream 0 load-balance group 1

no cable upstream 0 shutdown

cable upstream 1 frequency 10000000

cable upstream 1 channel-width 3200000 1600000

cable upstream 1 minislot-size 2

cable upstream 1 power-level 0

cable upstream 1 modulation-profile 5

cable upstream 1 load-balance group 1

no cable upstream 1 shutdown

cable upstream 2 frequency 24000000

cable upstream 2 channel-width 3200000 1600000

cable upstream 2 minislot-size 2

cable upstream 2 power-level 0

cable upstream 2 modulation-profile 5

no cable upstream 2 shutdown

cable upstream 3 frequency 31008000

cable upstream 3 channel-width 3200000 1600000

cable upstream 3 minislot-size 2

cable upstream 3 power-level 0

cable upstream 3 modulation-profile 5

no cable upstream 3 shutdown

cable upstream 4 frequency 38000000

cable upstream 4 channel-width 3200000 1600000

cable upstream 4 minislot-size 2

cable upstream 4 power-level 0

cable upstream 4 modulation-profile 5

no cable upstream 4 shutdown

cable upstream 5 frequency 42000000

cable upstream 5 channel-width 3200000 1600000

cable upstream 5 minislot-size 2

cable upstream 5 power-level 0

cable upstream 5 modulation-profile 5

no cable upstream 5 shutdown

no keepalive

arp timeout 28800

hold-queue 1024 in

!

interface Cable4/0

no ip address

shutdown

cable downstream rate-limit token-bucket shaping max-delay 1024

cable downstream annex B

cable downstream modulation 256qam

cable downstream interleave-depth 32

cable downstream channel-id 0

cable upstream 0 channel-width 3200000 1600000

cable upstream 0 minislot-size 2

cable upstream 0 power-level 0

cable upstream 0 modulation-profile 5

no cable upstream 0 shutdown

cable upstream 1 channel-width 3200000 1600000

cable upstream 1 minislot-size 2

cable upstream 1 power-level 0

cable upstream 1 modulation-profile 5

no cable upstream 1 shutdown

cable upstream 2 channel-width 3200000 1600000

cable upstream 2 minislot-size 2

cable upstream 2 power-level 0

cable upstream 2 modulation-profile 5

no cable upstream 2 shutdown

cable upstream 3 channel-width 3200000 1600000

cable upstream 3 minislot-size 2

cable upstream 3 power-level 0

cable upstream 3 modulation-profile 5

no cable upstream 3 shutdown

cable upstream 4 channel-width 3200000 1600000

cable upstream 4 minislot-size 2

cable upstream 4 power-level 0

cable upstream 4 modulation-profile 5

no cable upstream 4 shutdown

cable upstream 5 channel-width 3200000 1600000

cable upstream 5 minislot-size 2

cable upstream 5 power-level 0

cable upstream 5 modulation-profile 5

no cable upstream 5 shutdown

no keepalive

hold-queue 1024 in

!

interface Cable5/0

no ip address

shutdown

cable downstream annex B

cable downstream modulation 64qam

cable downstream interleave-depth 32

cable downstream channel-id 2

cable upstream 0 channel-width 1600000 1600000

cable upstream 0 minislot-size 4

cable upstream 0 modulation-profile 1

cable upstream 0 shutdown

cable upstream 1 channel-width 1600000 1600000

cable upstream 1 minislot-size 4

cable upstream 1 modulation-profile 1

cable upstream 1 shutdown

cable upstream 2 channel-width 1600000 1600000

cable upstream 2 minislot-size 4

cable upstream 2 modulation-profile 1

cable upstream 2 shutdown

cable upstream 3 channel-width 1600000 1600000

cable upstream 3 minislot-size 4

cable upstream 3 modulation-profile 1

cable upstream 3 shutdown

cable upstream 4 channel-width 1600000 1600000

cable upstream 4 minislot-size 4

cable upstream 4 modulation-profile 1

cable upstream 4 shutdown

cable upstream 5 channel-width 1600000 1600000

cable upstream 5 minislot-size 4

cable upstream 5 modulation-profile 1

cable upstream 5 shutdown

!

interface Cable6/0

no ip address

cable monitor interface FastEthernet1/0 mac-address 000f.66f9.4385 packet-type data docsis

cable monitor interface FastEthernet1/0 mac-address 000f.66f9.4386 packet-type data docsis

cable bundle 1

cable downstream rate-limit token-bucket shaping max-delay 1024

cable downstream annex B

cable downstream modulation 256qam

cable downstream interleave-depth 32

cable downstream frequency 705000000

cable downstream channel-id 0

no cable downstream rf-shutdown

cable downstream rf-power 63

cable upstream 0 connector 0

cable upstream 0 frequency 7000000

cable upstream 0 ingress-noise-cancellation 200

cable upstream 0 docsis-mode tdma-atdma

cable upstream 0 channel-width 3200000 3200000

cable upstream 0 minislot-size 2

cable upstream 0 power-level 0

cable upstream 0 range-backoff 3 6

cable upstream 0 modulation-profile 141

no cable upstream 0 shutdown

cable upstream 1 connector 1

cable upstream 1 frequency 11000000

cable upstream 1 ingress-noise-cancellation 200

cable upstream 1 docsis-mode tdma-atdma

cable upstream 1 channel-width 3200000 3200000

cable upstream 1 minislot-size 2

cable upstream 1 power-level 0

cable upstream 1 range-backoff 3 6

cable upstream 1 modulation-profile 141

no cable upstream 1 shutdown

cable upstream 2 connector 2

cable upstream 2 frequency 15000000

cable upstream 2 ingress-noise-cancellation 200

cable upstream 2 docsis-mode tdma-atdma

cable upstream 2 channel-width 3200000 3200000

cable upstream 2 minislot-size 2

cable upstream 2 power-level 0

cable upstream 2 range-backoff 3 6

cable upstream 2 modulation-profile 141

no cable upstream 2 shutdown

cable upstream 3 connector 3

cable upstream 3 frequency 19000000

cable upstream 3 ingress-noise-cancellation 200

cable upstream 3 docsis-mode tdma-atdma

cable upstream 3 channel-width 3200000 3200000

cable upstream 3 minislot-size 2

cable upstream 3 power-level 0

cable upstream 3 range-backoff 3 6

cable upstream 3 modulation-profile 141

no cable upstream 3 shutdown

!        

interface Cable6/1

no ip address

cable bundle 1

cable downstream rate-limit token-bucket shaping max-delay 1024

cable downstream annex B

cable downstream modulation 256qam

cable downstream interleave-depth 32

cable downstream frequency 711000000

cable downstream channel-id 0

no cable downstream rf-shutdown

cable downstream rf-power 45

cable upstream 0 connector 4

cable upstream 0 frequency 23000000

cable upstream 0 ingress-noise-cancellation 200

cable upstream 0 docsis-mode tdma-atdma

cable upstream 0 channel-width 3200000 3200000

cable upstream 0 minislot-size 2

cable upstream 0 power-level 0

cable upstream 0 range-backoff 3 6

cable upstream 0 modulation-profile 141

no cable upstream 0 shutdown

cable upstream 1 connector 5

cable upstream 1 frequency 27000000

cable upstream 1 ingress-noise-cancellation 200

cable upstream 1 docsis-mode tdma-atdma

cable upstream 1 channel-width 3200000 3200000

cable upstream 1 minislot-size 2

cable upstream 1 power-level 0

cable upstream 1 range-backoff 3 6

cable upstream 1 modulation-profile 141

no cable upstream 1 shutdown

cable upstream 2 connector 6

cable upstream 2 frequency 31000000

cable upstream 2 ingress-noise-cancellation 200

cable upstream 2 docsis-mode tdma-atdma

cable upstream 2 channel-width 3200000 3200000

cable upstream 2 minislot-size 2

cable upstream 2 power-level 0

cable upstream 2 range-backoff 3 6

cable upstream 2 modulation-profile 141

no cable upstream 2 shutdown

cable upstream 3 connector 7

cable upstream 3 frequency 35000000

cable upstream 3 ingress-noise-cancellation 200

cable upstream 3 docsis-mode tdma-atdma

cable upstream 3 channel-width 3200000 3200000

cable upstream 3 minislot-size 2

cable upstream 3 power-level 0

cable upstream 3 range-backoff 3 6

cable upstream 3 modulation-profile 141

no cable upstream 3 shutdown

!

interface Bundle1

ip address 14.80.82.129 255.255.255.128 secondary

ip address 14.80.82.1 255.255.255.128

cable dhcp-giaddr policy

cable helper-address 172.18.105.239

arp timeout 28800

!

ip classless

ip route 0.0.0.0 0.0.0.0 14.80.72.1

ip route 0.0.0.0 0.0.0.0 14.80.72.5 10

no ip http server

no ip http secure-server

!

!

!

ip access-list extended COPS1

deny   udp any eq isakmp any eq isakmp

permit ip host 14.80.72.2 host 14.80.85.36

permit ip host 14.80.85.36 host 14.80.72.2

ip access-list extended COPS2

deny   udp any eq isakmp any eq isakmp

permit ip host 14.80.72.2 host 14.80.85.37

permit ip host 14.80.85.37 host 14.80.72.2

ip access-list extended COPS3

deny   udp any eq isakmp any eq isakmp

permit ip host 14.80.72.2 host 14.80.85.68

permit ip host 14.80.85.68 host 14.80.72.2

ip access-list extended COPS4

deny   udp any eq isakmp any eq isakmp

permit ip host 14.80.72.2 host 14.80.85.69

permit ip host 14.80.85.69 host 14.80.72.2

cdp run

!

snmp-server community mssol RO

!

radius-server host 172.18.105.238 auth-port 1812 acct-port 1813 key 0000000000000000

radius-server host 172.18.105.239 auth-port 1812 acct-port 1813 key 0000000000000000

radius-server timeout 3

radius-server vsa send accounting

!

alias exec sshow cont cable 3/0 | in FEC

alias exec scm show cable modem

alias exec scf show cable flap

alias exec scc show controller cable

alias exec sci show interface cable

alias exec scmd show cable modem detail

alias exec scbr show int cable 3/0 u 0 | in CBR

alias exec sdyn show int cable 3/0 sid | in dyn

alias exec sia show ip accounting

alias exec cia clear ip account

alias exec scr show int cable 3/0 | in rate

alias exec clr clear counters

alias exec ccm clear cable modem all reset

alias exec ccf clear cable flap all

alias exec soff show cable modem | ex online

alias exec shost show int ca3/0 modem 0 | in host

alias exec scr4 show int cable 4/0 | in rate

alias exec scr5 show int cable 5/0 | in rate

alias exec scr6 show int cable 6/0 | in rate

alias exec shu30 show int cable 3/0 u0

alias exec shu31 show int cable 3/0 u1

alias exec shu32 show int cable 3/0 u2

alias exec shu33 show int cable 3/0 u3

alias exec shu34 show int cable 3/0 u4

alias exec shu35 show int cable 3/0 u5

alias exec shu40 show int cable 4/0 u0

alias exec shu41 show int cable 4/0 u1

alias exec shu42 show int cable 4/0 u2

alias exec shu43 show int cable 4/0 u3

alias exec shu44 show int cable 4/0 u4

alias exec shu45 show int cable 4/0 u5

alias exec shu50 show int cable 5/0 u0

alias exec shu51 show int cable 5/0 u1

alias exec shu52 show int cable 5/0 u2

alias exec shu53 show int cable 5/0 u3

alias exec shu54 show int cable 5/0 u4

alias exec shu55 show int cable 5/0 u5

alias exec shu60 show int cable 6/0 u0

alias exec shu61 show int cable 6/0 u1

alias exec shu62 show int cable 6/0 u2

alias exec shu63 show int cable 6/0 u3

alias exec shu64 show int cable 6/0 u4

alias exec shu65 show int cable 6/0 u5

alias exec sh% show proc cpu | ex 0.00

alias exec scm30 show cable modem cable 3/0 up 0

alias exec scm31 show cable modem cable 3/0 up 1

alias exec scm32 show cable modem cable 3/0 up 2

alias exec scm33 show cable modem cable 3/0 up 3

alias exec scm34 show cable modem cable 3/0 up 4

alias exec scm35 show cable modem cable 3/0 up 5

alias exec scm40 show cable modem cable 4/0 up 0

alias exec scm41 show cable modem cable 4/0 up 1

alias exec scm42 show cable modem cable 4/0 up 2

alias exec scm43 show cable modem cable 4/0 up 3

alias exec scm44 show cable modem cable 4/0 up 4

alias exec scm45 show cable modem cable 4/0 up 5

alias exec scm50 show cable modem cable 5/0 up 0

alias exec scm51 show cable modem cable 5/0 up 1

alias exec scm52 show cable modem cable 5/0 up 2

alias exec scm53 show cable modem cable 5/0 up 3

alias exec scm54 show cable modem cable 5/0 up 4

alias exec scm55 show cable modem cable 5/0 up 5

alias exec scm60 show cable modem cable 6/0 up 0

alias exec scm61 show cable modem cable 6/0 up 1

alias exec scm62 show cable modem cable 6/0 up 2

alias exec scm63 show cable modem cable 6/0 up 3

alias exec scm64 show cable modem cable 6/0 up 4

alias exec scm65 show cable modem cable 6/0 up 5

alias exec shost3 show int cable 3/0 modem 0 | in

alias exec shost4 show int cable 4/0 modem 0 | in

alias exec shost5 show int cable 5/0 modem 0 | in

alias exec shost6 show int cable 6/0 modem 0 | in

alias exec ssr show int srp1/0 | in rate

alias exec sidc3 show int cable 3/0 sid counters

alias exec sidc4 show int cable 4/0 sid counters

alias exec sidc5 show int cable 5/0 sid counters

alias exec sidc6 show int cable 6/0 sid counters

alias exec srfe2 show int fast 2/0 | in rate

alias exec srfe1 show int fast 1/0 | in rate

alias exec sfec show contr cable 3/0 | in FEC

alias exec sfec3 show cont cable 3/0 | in FEC

alias exec sfec4 show cont cable 4/0 | in FEC

alias exec sfec5 show cont cable 5/0 | in FEC

alias exec sfec6 show cont cable 6/0 | in FEC

alias exec ssnr show controllers cable 3/0 | in SNR

alias exec ssnr3 show controllers cable 3/0 | in SNR

alias exec ssnr4 show controllers cable 4/0 | in SNR

alias exec ssnr5 show controllers cable 5/0 | in SNR

alias exec ssnr6 show controllers cable 6/0 | in SNR

privilege exec level 1 show cable modem

privilege exec level 12 show cable

privilege exec level 12 show

!

line con 0

transport preferred all

transport output all

stopbits 1

line aux 0

transport preferred all

transport output all

stopbits 1

line vty 0 4

exec-timeout 0 0

password ww

transport preferred all

transport input all

transport output all

line vty 5 15

transport preferred all

transport input all

transport output all

!

scheduler allocate 3999 400

ntp clock-period 17180226

ntp update-calendar

ntp server 14.80.60.6 prefer

end

My-CMTS#  show cops server

COPS SERVER: Address: 14.80.86.42. Port: 32775. State: 0. Keepalive: 60 sec

     Number of clients: 1. Number of sessions: 1.

    COPS CLIENT: Client type: 32778.  State: 0.

COPS SERVER: Address: 14.80.69.100. Port: 33133. State: 0. Keepalive: 2 sec

     Number of clients: 1. Number of sessions: 1.

    COPS CLIENT: Client type: 32776.  State: 0.

COPS SERVER: Address: 14.80.69.4. Port: 33554. State: 0. Keepalive: 10 sec

     Number of clients: 1. Number of sessions: 1.

    COPS CLIENT: Client type: 32776.  State: 0.

COPS SERVER: Address: 14.80.85.36. Port: 49675. State: 0. Keepalive: 2 sec

     Number of clients: 1. Number of sessions: 1.

    COPS CLIENT: Client type: 32776.  State: 0.

COPS SERVER: Address: 14.80.87.132. Port: 35351. State: 0. Keepalive: 2 sec

     Number of clients: 1. Number of sessions: 1.

    COPS CLIENT: Client type: 32776.  State: 0.

My-CMTS#

My-CMTS#show cable modem 0000.cadd.a3ef

MAC Address    IP Address      I/F       MAC         Prim RxPwr  Timing  Num BPI

                                         State       Sid  (dB)   Offset  CPE Enb

0000.cadd.a3ef 14.80.82.18     C6/1/U0   online      35   -1.00 1520     1   N

My-CMTS#show cable modem 0000.cadd.a3ef cpe

IP address        MAC address

14.80.82.141      0000.cadd.a3f0

My-CMTS#show cable modem 0000.cadd.76d3

MAC Address    IP Address      I/F       MAC         Prim RxPwr  Timing  Num BPI

                                         State       Sid  (dB)   Offset  CPE Enb

0000.cadd.76d3 14.80.82.21     C6/1/U1   online      6    -0.50 1519     1   N

My-CMTS#show cable modem 0000.cadd.76d3 cpe

IP address        MAC address

14.80.82.144      0000.cadd.76d4

My-CMTS#sh debug

CMTS:

  CMTS dynsrv debugging is on

CMTS specific:

  Debugging is on for Address 0000.cadd.76d3, Mask ffff.ffff.ffff (verbose)

  Debugging is on for Address 0000.cadd.a3ef, Mask ffff.ffff.ffff (verbose)

PacketCable Client:

  Pktcbl COPS msgs debugging is on

  Pktcbl gate control msgs debugging is on

  Pktcbl commit msgs debugging is on

  Pktcbl event msgs debugging is on

  Pktcbl rsvp-to-docsis msgs debugging is on

  Pktcbl gate database changes debugging is on

PacketCable specific:

  Debugging is on for Subscriber 14.80.82.141, Mask 255.255.255.255 (verbose)

  Debugging is on for Subscriber 14.80.82.144, Mask 255.255.255.255 (verbose)

This call is made from the MTA with mac address 0000.cadd.a3f0 to MTA with mac-address 0000.cadd.76d4

1) COPS  GATE SET message comes from CA to CMTS that has upstream and downstream gates.  Here the session class value for US/DS gates is set to 1 which means Normal priority VOIP call.  It will be set to to  2 for a 911 call which reports high priority voip call.

My-CMTS#

My-CMTS#

My-CMTS#

Sep 17 15:16:12.651: PktCbl(cops): Received callback [code 2, handle: 0x6451F504] from COPS engine

Sep 17 15:16:12.651: PktCbl(cops): Received a COPS DEC message, flags is 0x1

Sep 17 15:16:12.651: Pktcbl(gcp): Received GATE SET message, tid=0x9

Sep 17 15:16:12.651: --- Pktcbl(gcp): Received GCP message ------

Sep 17 15:16:12.651: TRANSACTION ID       : Object.[snum/stype/len 1/1/8]

Sep 17 15:16:12.655:     transaction id   : 0x9

Sep 17 15:16:12.655:     gcp cmd          : 4 (GATE SET)

Sep 17 15:16:12.655: SUBSCRIBER ID (IPV4) : Object.[snum/stype/len 2/1/8]

Sep 17 15:16:12.655:     Addr             : 14.80.82.144

Sep 17 15:16:12.655: ACTIVITY COUNT       : Object.[snum/stype/len 4/1/8]

Sep 17 15:16:12.655:     Count            : 5

Sep 17 15:16:12.655: GATE SPEC            : Object.[snum/stype/len 5/1/60]

Sep 17 15:16:12.655:     direction        : 1 (UPSTREAM)

Sep 17 15:16:12.655:     protocol id      : 17

Sep 17 15:16:12.655:     commit flag      : 0x0

Sep 17 15:16:12.655:     session class    : 1

Sep 17 15:16:12.655:     source           : 14.80.82.144

Sep 17 15:16:12.655:     dest             : 14.80.82.141

Sep 17 15:16:12.655:     src port         : 0 (0x0)

Sep 17 15:16:12.655:     dest port        : 56214 (0xDB96)

Sep 17 15:16:12.655:     dscp             : 0xA0

Sep 17 15:16:12.655:     timer t1         : 200

Sep 17 15:16:12.655:     timer t7         : 200

Sep 17 15:16:12.655:     timer t8         : 0

Sep 17 15:16:12.655:     flowspec # 1     : [r/b/p/m/M 12000/120/12000/120/120] [R/S: 12000/800]

Sep 17 15:16:12.655: GATE SPEC            : Object.[snum/stype/len 5/1/60]

Sep 17 15:16:12.655:     direction        : 0 (DOWNSTREAM)

Sep 17 15:16:12.655:     protocol id      : 17

Sep 17 15:16:12.655:     commit flag      : 0x0

Sep 17 15:16:12.655:     session class    : 1

Sep 17 15:16:12.655:     source           : 14.80.82.141

Sep 17 15:16:12.655:     dest             : 14.80.82.144

Sep 17 15:16:12.655:     src port         : 0 (0x0)

Sep 17 15:16:12.655:     dest port        : 54204 (0xD3BC)

Sep 17 15:16:12.655:     dscp             : 0xA0

Sep 17 15:16:12.655:     timer t1         : 200

Sep 17 15:16:12.655:     timer t7         : 200

Sep 17 15:16:12.655:     timer t8         : 0

Sep 17 15:16:12.655:     flowspec # 1     : [r/b/p/m/M 12000/120/12000/120/120] [R/S: 12000/0]

Sep 17 15:16:12.655: --------------------------------------

2)CMTS allocates gate #

Sep 17 15:16:12.655: Pktcbl(gdb): Allocating gate entry 0/1. Instance cnt: 7, gate_count is now 1

Sep 17 15:16:12.655: Pktcbl(gdb): Created new Subscriber IE for 14.80.82.144

Sep 17 15:16:12.655: Pktcbl(gdb): Updated subscriber IE [subs addr: 14.80.82.144, gate: 22940]

Sep 17 15:16:12.655: Pktcbl(gdb): Created gate IE on Cable6/1, gateid = 22940

Sep 17 15:16:12.655: Pktcbl(gdb): Started gate [id 22940] timer t1 [200000 msec]

3) CMTS sends COPS GATE SET ACK message with Gate ID to BTS.

Sep 17 15:16:12.655: Pktcbl(gcp): Building GCP message, added obj TRANSACTION ID      ; len:8 padding:0

Sep 17 15:16:12.655: Pktcbl(gcp): Building GCP message, added obj SUBSCRIBER ID (IPV4); len:8 padding:0

Sep 17 15:16:12.655: Pktcbl(gcp): Building GCP message, added obj GATE ID             ; len:8 padding:0

Sep 17 15:16:12.655: Pktcbl(gcp): Building GCP message, added obj ACTIVITY COUNT      ; len:8 padding:0

Sep 17 15:16:12.655: Pktcbl(gcp): Built GCP message, GATE SET ACK        , length: 32, copsLen 60

Sep 17 15:16:12.655:  --- Pktcbl: Sending GCP message ------

Sep 17 15:16:12.655: TRANSACTION ID       : Object.[snum/stype/len 1/1/8]

Sep 17 15:16:12.655:     transaction id   : 0x9

Sep 17 15:16:12.655:     gcp cmd          : 5 (GATE SET ACK)

Sep 17 15:16:12.655: SUBSCRIBER ID (IPV4) : Object.[snum/stype/len 2/1/8]

Sep 17 15:16:12.655:     Addr             : 14.80.82.144

Sep 17 15:16:12.655: GATE ID              : Object.[snum/stype/len 3/1/8]

Sep 17 15:16:12.655:     GateID           : 22940 (0x599C)

Sep 17 15:16:12.655: ACTIVITY COUNT       : Object.[snum/stype/len 4/1/8]

Sep 17 15:16:12.655:     Count            : 2

Sep 17 15:16:12.655:  --------------------------------------

4)Similar COPS Gate Set Ack message for caller side

Sep 17 15:16:12.715: PktCbl(cops): Received callback [code 2, handle: 0x6451F504] from COPS engine

Sep 17 15:16:12.715: PktCbl(cops): Received a COPS DEC message, flags is 0x1

Sep 17 15:16:12.715: Pktcbl(gcp): Received GATE SET message, tid=0xA

Sep 17 15:16:12.715: --- Pktcbl(gcp): Received GCP message ------

Sep 17 15:16:12.715: TRANSACTION ID       : Object.[snum/stype/len 1/1/8]

Sep 17 15:16:12.715:     transaction id   : 0xA

Sep 17 15:16:12.715:     gcp cmd          : 4 (GATE SET)

Sep 17 15:16:12.715: SUBSCRIBER ID (IPV4) : Object.[snum/stype/len 2/1/8]

Sep 17 15:16:12.715:     Addr             : 14.80.82.141

Sep 17 15:16:12.715: ACTIVITY COUNT       : Object.[snum/stype/len 4/1/8]

Sep 17 15:16:12.715:     Count            : 5

Sep 17 15:16:12.715: GATE SPEC            : Object.[snum/stype/len 5/1/60]

Sep 17 15:16:12.715:     direction        : 1 (UPSTREAM)

Sep 17 15:16:12.715:     protocol id      : 17

Sep 17 15:16:12.715:     commit flag      : 0x0

Sep 17 15:16:12.715:     session class    : 1

Sep 17 15:16:12.715:     source           : 14.80.82.141

Sep 17 15:16:12.715:     dest             : 14.80.82.144

Sep 17 15:16:12.715:     src port         : 0 (0x0)

Sep 17 15:16:12.715:     dest port        : 54204 (0xD3BC)

Sep 17 15:16:12.715:     dscp             : 0xA0

Sep 17 15:16:12.715:     timer t1         : 200

Sep 17 15:16:12.715:     timer t7         : 200

Sep 17 15:16:12.715:     timer t8         : 0

Sep 17 15:16:12.715:     flowspec # 1     : [r/b/p/m/M 12000/120/12000/120/120] [R/S: 12000/800]

Sep 17 15:16:12.719: GATE SPEC            : Object.[snum/stype/len 5/1/60]

Sep 17 15:16:12.719:     direction        : 0 (DOWNSTREAM)

Sep 17 15:16:12.719:     protocol id      : 17

Sep 17 15:16:12.719:     commit flag      : 0x0

Sep 17 15:16:12.719:     session class    : 1

Sep 17 15:16:12.719:     source           : 14.80.82.144

Sep 17 15:16:12.719:     dest             : 14.80.82.141

Sep 17 15:16:12.719:     src port         : 0 (0x0)

Sep 17 15:16:12.719:     dest port        : 56214 (0xDB96)

Sep 17 15:16:12.719:     dscp             : 0xA0

Sep 17 15:16:12.719:     timer t1         : 200

Sep 17 15:16:12.719:     timer t7         : 200

Sep 17 15:16:12.719:     timer t8         : 0

Sep 17 15:16:12.719:     flowspec # 1     : [r/b/p/m/M 12000/120/12000/120/120] [R/S: 12000/0]

Sep 17 15:16:12.719: --------------------------------------

5)Get # allocation for called side with ip address 14.80.82.141

Sep 17 15:16:12.719: Pktcbl(gdb): Allocating gate entry 0/0. Instance cnt: 12, gate_count is now 2

Sep 17 15:16:12.719: Pktcbl(gdb): Created new Subscriber IE for 14.80.82.141

Sep 17 15:16:12.719: Pktcbl(gdb): Updated subscriber IE [subs addr: 14.80.82.141, gate: 6576]

Sep 17 15:16:12.719: Pktcbl(gdb): Created gate IE on Cable6/1, gateid = 6576

Sep 17 15:16:12.719: Pktcbl(gdb): Started gate [id 6576] timer t1 [200000 msec]

6) CMTS sends COPS REP gate set ack message with Gate ID to BTS.

Sep 17 15:16:12.719: Pktcbl(gcp): Building GCP message, added obj TRANSACTION ID      ; len:8 padding:0

Sep 17 15:16:12.719: Pktcbl(gcp): Building GCP message, added obj SUBSCRIBER ID (IPV4); len:8 padding:0

Sep 17 15:16:12.719: Pktcbl(gcp): Building GCP message, added obj GATE ID             ; len:8 padding:0

Sep 17 15:16:12.719: Pktcbl(gcp): Building GCP message, added obj ACTIVITY COUNT      ; len:8 padding:0

Sep 17 15:16:12.719: Pktcbl(gcp): Built GCP message, GATE SET ACK        , length: 32, copsLen 60

Sep 17 15:16:12.719:  --- Pktcbl: Sending GCP message ------

Sep 17 15:16:12.719: TRANSACTION ID       : Object.[snum/stype/len 1/1/8]

Sep 17 15:16:12.719:     transaction id   : 0xA

Sep 17 15:16:12.719:     gcp cmd          : 5 (GATE SET ACK)

Sep 17 15:16:12.719: SUBSCRIBER ID (IPV4) : Object.[snum/stype/len 2/1/8]

Sep 17 15:16:12.719:     Addr             : 14.80.82.141

Sep 17 15:16:12.719: GATE ID              : Object.[snum/stype/len 3/1/8]

Sep 17 15:16:12.719:     GateID           : 6576 (0x19B0)

Sep 17 15:16:12.719: ACTIVITY COUNT       : Object.[snum/stype/len 4/1/8]

Sep 17 15:16:12.719:     Count            : 2

Sep 17 15:16:12.719:  --------------------------------------

7)Two gates, one for each MTA for onnet call is created.. Activation state is set to inactive.

Sep 17 15:16:12.643: Pktcbl(gdb): Allocating gate entry 0/1. gate_count is now 1

Sep 17 15:16:12.643: Pktcbl(gdb): Created gate IE, gateid = 22940

Sep 17 15:16:12.707: Pktcbl(gdb): Allocating gate entry 0/0. gate_count is now 2

Sep 17 15:16:12.707: Pktcbl(gdb): Created gate IE, gateid = 6576

8)MTA 0000.cadd.a3ef  sends DSA-REQ with US/DS parameters/classifiers to CMTS. Gate ID is in the auth block. Activation state is inactive.

Sep 17 15:16:12.787: DSA-REQ-RECD: OrgMac->0000.cadd.a3ef OrgId->6

Sep 17 15:16:12.787: DSA-STATE-CREATED: OrgMac->0000.cadd.a3ef OrgId->6

Sep 17 15:16:12.787:  122 cmts_set_act_timeout act-to=0

Sep 17 15:16:12.787: PktCbl(d2r): extract id: gate=6576, resource=0

Sep 17 15:16:12.787: PktCbl(d2r): extract id: gate=6576, resource=0

Sep 17 15:16:12.787: PktCbl(d2r): extract id: gate=6576, resource=0

Sep 17 15:16:12.791: PktCbl(d2r): DSA-REQ received, gateid: 6576

Sep 17 15:16:12.791: Pktcbl(gdb): handle=6576 dir=0 type=3 (get gate flowspec)

Sep 17 15:16:12.791: r/b/p/m/M 1178304512 1123024896 1178304512 120 120 (R/S) 1178304512 0

Sep 17 15:16:12.791: PktCbl(r2d): cfr: proto=17 src=14.80.82.141 dst=14.80.82.144 sport=56214 dport=54204

Sep 17 15:16:12.791: PktCbl(r2d): flowspec cfr: proto=17 src=14.80.82.141 dst=14.80.82.144 sport=0 dport=54204

Sep 17 15:16:12.791: Pktcbl(gdb): handle=6576 dir=1 type=2 (get gate flowspec)

Sep 17 15:16:12.791: r/b/p/m/M 1178304512 1123024896 1178304512 120 120 (R/S) 1178304512 800

Sep 17 15:16:12.791: PktCbl(r2d): REQ - r/b/p/m/M 1177792512 1122369536 1177792512 115 115 (R/S) 1177792512 800

Sep 17 15:16:12.791: PktCbl(r2d): cfr: proto=17 src=14.80.82.144 dst=14.80.82.141 sport=0 dport=56214

Sep 17 15:16:12.791: PktCbl(r2d): flowspec cfr: proto=17 src=14.80.82.144 dst=14.80.82.141 sport=0 dport=56214

Sep 17 15:16:12.791: Pktcbl(gdb): handle=6576 dir=0 type=2 (get gate flowspec)

Sep 17 15:16:12.791: r/b/p/m/M 1178304512 1123024896 1178304512 120 120 (R/S) 1178304512 0

Sep 17 15:16:12.791: PktCbl(r2d): REQ - r/b/p/m/M 1178304512 1123024896 1178304512 120 120 (R/S) 1178304512 0

Sep 17 15:16:12.791: Pktcbl(gdb): handle=6576 dir=1 type=3 spec=61B45480 (set gate flowspec)

Sep 17 15:16:12.791: Pktcbl(gdb): handle=6576 dir=0 type=3 spec=61B4549C (set gate flowspec)

Sep 17 15:16:12.791: Pktcbl: params_enc : auth str=0x6198BE50 len=8

9)CMTS returns DSA-RESP to MTA 0000.cadd.a3ef

Sep 17 15:16:12.791: DSA-RSP Message Contents:

Sep 17 15:16:12.791: 0x0000: C2 00 01 00 00 00 00 00 CA DD A3 EF 00 0B BF 54

Sep 17 15:16:12.791: 0x0010: E8 21 00 EE 00 00 03 02 10 00 00 06 00 18 35 01

Sep 17 15:16:12.791: 0x0020: 02 00 01 02 04 00 00 00 5B 03 02 00 2D 06 01 02

Sep 17 15:16:12.791: 0x0030: 0C 02 00 00 0D 02 00 C8 0F 01 06 10 04 00 00 01

Sep 17 15:16:12.791: 0x0040: 7F 13 02 00 93 14 04 00 00 27 10 15 04 00 00 03

Sep 17 15:16:12.791: 0x0050: 20 16 01 01 19 2E 01 02 00 02 02 04 00 00 00 5C

Sep 17 15:16:12.791: 0x0060: 06 01 02 07 01 05 08 04 00 01 AF 40 09 04 00 00

Sep 17 15:16:12.791: 0x0070: 05 F2 0A 04 00 01 AF 40 0B 02 00 8A 0C 02 00 00

Sep 17 15:16:12.791: 0x0080: 0D 02 00 00 16 39 01 01 01 03 02 00 01 02 02 00

Sep 17 15:16:12.791: 0x0090: 05 04 04 00 00 00 5B 05 01 80 06 01 00 09 20 02

Sep 17 15:16:12.791: 0x00A0: 02 00 11 03 04 0E 50 52 8D 05 04 0E 50 52 90 07

Sep 17 15:16:12.791: 0x00B0: 02 DB 96 08 02 DB 96 09 02 D3 BC 0A 02 D3 BC 17

Sep 17 15:16:12.791: DSA-RSP-SENT: CM->0000.cadd.a3ef TranscId->6 ConfCode->0

10) MTA sends DSA-Ack to CMTS with confirmation success for gate 6576

Sep 17 15:16:12.795: DSA-ACK-RECD: OrgMac->0000.cadd.a3ef OrgId->6 Sep 17 15:16:12.799: PktCbl(d2r): DSA-ACK received, gateid: 6576

Sep 17 15:16:12.799: Pktcbl(gdb): Get gate spec info, handle=6576 dir=1 spec=61B454E8

Sep 17 15:16:12.799: Pktcbl(gdb): Get gate spec info, handle=6576 dir=0 spec=61B45510 ConfCode->0

11)Similarly MTA  0000.cadd.76d3 sends DSA-REQ to CMTS..and process continues …

Sep 17 15:16:12.815: DSA-REQ-RECD: OrgMac->0000.cadd.76d3 OrgId->17

Sep 17 15:16:12.815: DSA-STATE-CREATED: OrgMac->0000.cadd.76d3 OrgId->17

Sep 17 15:16:12.815:  122 cmts_set_act_timeout act-to=0

Sep 17 15:16:12.815: PktCbl(d2r): extract id: gate=22940, resource=0

Sep 17 15:16:12.815: PktCbl(d2r): extract id: gate=22940, resource=0

Sep 17 15:16:12.815: PktCbl(d2r): extract id: gate=22940, resource=0

Sep 17 15:16:12.815: PktCbl(d2r): DSA-REQ received, gateid: 22940

Sep 17 15:16:12.815: Pktcbl(gdb): handle=22940 dir=0 type=3 (get gate flowspec)

Sep 17 15:16:12.815: r/b/p/m/M 1178304512 1123024896 1178304512 120 120 (R/S) 1178304512 0

Sep 17 15:16:12.815: PktCbl(r2d): cfr: proto=17 src=14.80.82.144 dst=14.80.82.141 sport=54204 dport=56214

Sep 17 15:16:12.815: PktCbl(r2d): flowspec cfr: proto=17 src=14.80.82.144 dst=14.80.82.141 sport=0 dport=56214

Sep 17 15:16:12.815: Pktcbl(gdb): handle=22940 dir=1 type=2 (get gate flowspec)

Sep 17 15:16:12.815: r/b/p/m/M 1178304512 1123024896 1178304512 120 120 (R/S) 1178304512 800

Sep 17 15:16:12.815: PktCbl(r2d): REQ - r/b/p/m/M 1177792512 1122369536 1177792512 115 115 (R/S) 1177792512 800

Sep 17 15:16:12.815: PktCbl(r2d): cfr: proto=17 src=14.80.82.141 dst=14.80.82.144 sport=0 dport=54204

Sep 17 15:16:12.815: PktCbl(r2d): flowspec cfr: proto=17 src=14.80.82.141 dst=14.80.82.144 sport=0 dport=54204

Sep 17 15:16:12.851: Parsing of DSA message successful

Sep 17 15:16:12.851: PktCbl(d2r): extract id: gate=22940, resource=93

Sep 17 15:16:12.851: Pktcbl(gdb): TOS Overwrite gate spec info,gate_id=22940 dir=1 gie=63C0C7D8

Sep 17 15:16:12.851: Pktcbl(gdb): TOS Overwrite Gate=22940 DSCP=0xA0 mask=0x0

Sep 17 15:16:12.851: PktCbl(d2r): extract id: gate=22940, resource=93

Sep 17 15:16:12.851: PktCbl(d2r): extract id: gate=22940, resource=93

Sep 17 15:16:12.851: PktCbl(d2r): DSA-ACK notification received on RP, gateid : 22940

Sep 17 15:16:12.839: PktCbl(d2r): DSA-ACK received, gateid: 22940

Sep 17 15:16:12.839: Pktcbl(gdb): Get gate spec info, handle=22940 dir=1 spec=61B454E8

Sep 17 15:16:12.839: Pktcbl(gdb): Get gate spec info, handle=22940 dir=0 spec=61B45510

12)Finally DSA activity finished with DSA-ACK for both the gates.

Sep 17 15:16:13.099: DSA-REQ End. Transaction over-T8 timer expired. OrgMac->0000.cadd.a3ef OrgId->6

Sep 17 15:16:13.099: DYN-SRV-STATE-DESTROYED : OrgMac->0000.cadd.a3ef OrgId->6

Sep 17 15:16:13.139: DSA-REQ End. Transaction over-T8 timer expired. OrgMac->0000.cadd.76d3 OrgId->17

Sep 17 15:16:13.139: DYN-SRV-STATE-DESTROYED : OrgMac->0000.cadd.76d3 OrgId->17

Sep 17 15:16:15.395: DSC-REQ-RECD: OrgMac->0000.cadd.76d3 OrgId->18

13)Phone call got answered at destination MTA and  audio direction is now bidirectional. MTA sends DSC-REQ to CMTS with resource id in auth block.  Activation state is now Active.

Sep 17 15:16:15.395: DSC-REQ-RECD: OrgMac->0000.cadd.76d3 OrgId->18

Sep 17 15:16:15.395: DSC-STATE-CREATED: OrgMac->0000.cadd.76d3 OrgId->18

Sep 17 15:16:15.395:  122 cmts_set_act_timeout act-to=0

Sep 17 15:16:15.395: PktCbl(d2r): extract id: gate=22940, resource=93

Sep 17 15:16:15.395: PktCbl(d2r): extract id: gate=22940, resource=93

Sep 17 15:16:15.395: Pktcbl(gdb): TOS Overwrite gate spec info,gate_id=22940 dir=1 gie=629AB014

Sep 17 15:16:15.395: Pktcbl(gdb): TOS Overwrite Gate=22940 DSCP=0xA0 mask=0x0

Sep 17 15:16:15.395: PktCbl(d2r): extract id: gate=22940, resource=93

Sep 17 15:16:15.395: PktCbl(d2r): extract id: gate=22940, resource=93

Sep 17 15:16:15.395: PktCbl(d2r): DSC-REQ received, gateid(22940) flow handle(22940)

Sep 17 15:16:15.395: Pktcbl(gdb): Get gate spec info, handle=22940 dir=0 spec=61B454F8

Sep 17 15:16:15.395: Pktcbl(gdb): Get gate spec info, handle=22940 dir=1 spec=61B454F8

Sep 17 15:16:15.395: Pktcbl(gdb): handle=22940 dir=0 type=4 (get gate flowspec)

Sep 17 15:16:15.395: r/b/p/m/M 1178304512 1123024896 1178304512 120 120 (R/S) 1178304512 0

Sep 17 15:16:15.395: PktCbl(d2r): max_fs_type us=2, ds=2 qos_set_type us=6 ds=6

Sep 17 15:16:15.395: PktCbl(r2d): cfr: proto=17 src=14.80.82.144 dst=14.80.82.141 sport=54204 dport=56214

Sep 17 15:16:15.395: PktCbl(r2d): flowspec cfr: proto=17 src=14.80.82.144 dst=14.80.82.141 sport=0 dport=56214

Sep 17 15:16:15.395: Pktcbl(gdb): handle=22940 dir=1 type=2 (get gate flowspec)

Sep 17 15:16:15.395: r/b/p/m/M 1178304512 1123024896 1178304512 120 120 (R/S) 1178304512 800

Sep 17 15:16:15.395: PktCbl(r2d): REQ - r/b/p/m/M 1177792512 1122369536 1177792512 115 115 (R/S) 1177792512 800

Sep 17 15:16:15.395: PktCbl(r2d): cfr: proto=17 src=14.80.82.141 dst=14.80.82.144 sport=0 dport=54204

Sep 17 15:16:15.395: PktCbl(r2d): flowspec cfr: proto=17 src=14.80.82.141 dst=14.80.82.144 sport=0 dport=54204

Sep 17 15:16:15.395: Pktcbl(gdb): handle=22940 dir=0 type=2 (get gate flowspec)

Sep 17 15:16:15.395: r/b/p/m/M 1178304512 1123024896 1178304512 120 120 (R/S) 1178304512 0

Sep 17 15:16:15.395: PktCbl(r2d): REQ - r/b/p/m/M 1178304512 1123024896 1178304512 120 120 (R/S) 1178304512 0

Sep 17 15:16:15.395: Pktcbl(gdb): handle=22940 dir=1 type=4 spec=61B45468 (set gate flowspec)

Sep 17 15:16:15.395: Pktcbl(gdb): handle=22940 dir=0 type=4 spec=61B45484 (set gate flowspec)

Sep 17 15:16:15.395: Pktcbl: params_enc : auth str=0x6198BE50 len=14

14)CMTS sends DSC-RESP to same CM

Sep 17 15:16:15.395: DSC-RSP Message Contents:

Sep 17 15:16:15.395: 0x0000: C2 00 00 F6 00 00 00 00 CA DD 76 D3 00 0B BF 54

Sep 17 15:16:15.395: 0x0010: E8 21 00 E4 00 00 03 02 13 00 00 12 00 18 37 02

Sep 17 15:16:15.395: 0x0020: 04 00 00 00 5D 03 02 00 2E 06 01 06 0C 02 00 00

Sep 17 15:16:15.395: 0x0030: 0D 02 00 C8 0F 01 06 10 04 00 00 01 7F 13 02 00

Sep 17 15:16:15.395: 0x0040: 93 14 04 00 00 27 10 15 04 00 00 03 20 16 01 01

Sep 17 15:16:15.395: 0x0050: 18 04 00 15 E0 00 19 2A 02 04 00 00 00 5E 06 01

Sep 17 15:16:15.395: 0x0060: 06 07 01 05 08 04 00 01 AF 40 09 04 00 00 05 F2

Sep 17 15:16:15.395: 0x0070: 0A 04 00 01 AF 40 0B 02 00 8A 0C 02 00 00 0D 02

Sep 17 15:16:15.395: 0x0080: 00 00 16 35 02 02 00 0D 04 04 00 00 00 5D 05 01

Sep 17 15:16:15.395: 0x0090: 80 06 01 01 07 01 01 09 20 02 02 00 11 03 04 0E

Sep 17 15:16:15.395: 0x00A0: 50 52 90 05 04 0E 50 52 8D 07 02 D3 BC 08 02 D3

Sep 17 15:16:15.395: 0x00B0: BC 09 02 DB 96 0A 02 DB 96 17 2D 02 02 00 0E 04

Sep 17 15:16:15.395: 0x00C0: 04 00 00 00 5E 05 01 80 06 01 01 07 01 01 09 18

Sep 17 15:16:15.395: 0x00D0: 02 02 00 11 03 04 0E 50 52 8D 05 04 0E 50 52 90

Sep 17 15:16:15.395: 0x00E0: 09 02 D3 BC 0A 02 D3 BC 1E 0E 01 0C 01 04 00 00

Sep 17 15:16:15.395: 0x00F0: 59 9C 02 04 00 00 00 5D

Sep 17 15:16:15.395: DSC-RSP-SENT: CM->0000.cadd.76d3 TranscId->18 ConfCode->0

15)Similarly DSC-REQ received from other CM

Sep 17 15:16:15.395: DSC-REQ-RECD: OrgMac->0000.cadd.a3ef OrgId->7

Sep 17 15:16:15.395: DSC-STATE-CREATED: OrgMac->0000.cadd.a3ef OrgId->7

Sep 17 15:16:15.395:  122 cmts_set_act_timeout act-to=0

Sep 17 15:16:15.395: PktCbl(d2r): extract id: gate=6576, resource=91

Sep 17 15:16:15.395: PktCbl(d2r): extract id: gate=6576, resource=91

Sep 17 15:16:15.395: Pktcbl(gdb): TOS Overwrite gate spec info,gate_id=6576 dir=1 gie=6211A9A0

Sep 17 15:16:15.395: Pktcbl(gdb): TOS Overwrite Gate=6576 DSCP=0xA0 mask=0x0

Sep 17 15:16:15.395: PktCbl(d2r): extract id: gate=6576, resource=91

Sep 17 15:16:15.395: PktCbl(d2r): extract id: gate=6576, resource=91

Sep 17 15:16:15.395: PktCbl(d2r): DSC-REQ received, gateid(6576) flow handle(6576)

Sep 17 15:16:15.395: Pktcbl(gdb): Get gate spec info, handle=6576 dir=0 spec=61B454F8

Sep 17 15:16:15.395: Pktcbl(gdb): Get gate spec info, handle=6576 dir=1 spec=61B454F8

Sep 17 15:16:15.395: Pktcbl(gdb): handle=6576 dir=0 type=4 (get gate flowspec)

Sep 17 15:16:15.395: r/b/p/m/M 1178304512 1123024896 1178304512 120 120 (R/S) 1178304512 0

Sep 17 15:16:15.395: PktCbl(d2r): max_fs_type us=2, ds=2 qos_set_type us=6 ds=6

Sep 17 15:16:15.395: PktCbl(r2d): cfr: proto=17 src=14.80.82.141 dst=14.80.82.144 sport=56214 dport=54204

Sep 17 15:16:15.395: PktCbl(r2d): flowspec cfr: proto=17 src=14.80.82.141 dst=14.80.82.144 sport=0 dport=54204

Sep 17 15:16:15.399: Pktcbl(gdb): handle=6576 dir=1 type=2 (get gate flowspec)

Sep 17 15:16:15.399: r/b/p/m/M 1178304512 1123024896 1178304512 120 120 (R/S) 1178304512 800

Sep 17 15:16:15.399: PktCbl(r2d): REQ - r/b/p/m/M 1177792512 1122369536 1177792512 115 115 (R/S) 1177792512 800

Sep 17 15:16:15.399: PktCbl(r2d): cfr: proto=17 src=14.80.82.144 dst=14.80.82.141 sport=0 dport=56214

Sep 17 15:16:15.399: PktCbl(r2d): flowspec cfr: proto=17 src=14.80.82.144 dst=14.80.82.141 sport=0 dport=56214

Sep 17 15:16:15.399: Pktcbl(gdb): handle=6576 dir=0 type=2 (get gate flowspec)

Sep 17 15:16:15.399: r/b/p/m/M 1178304512 1123024896 1178304512 120 120 (R/S) 1178304512 0

Sep 17 15:16:15.399: PktCbl(r2d): REQ - r/b/p/m/M 1178304512 1123024896 1178304512 120 120 (R/S) 1178304512 0

Sep 17 15:16:15.399: Pktcbl(gdb): handle=6576 dir=1 type=4 spec=61B45468 (set gate flowspec)

Sep 17 15:16:15.399: Pktcbl(gdb): handle=6576 dir=0 type=4 spec=61B45484 (set gate flowspec)

Sep 17 15:16:15.399: Pktcbl: params_enc : auth str=0x6198BE50 len=14

16)DSC-RESP sent from CMTS to CM

Sep 17 15:16:15.399: DSC-RSP Message Contents:

Sep 17 15:16:15.399: 0x0000: C2 00 00 F6 00 00 00 00 CA DD A3 EF 00 0B BF 54

Sep 17 15:16:15.399: 0x0010: E8 21 00 E4 00 00 03 02 13 00 00 07 00 18 37 02

Sep 17 15:16:15.399: 0x0020: 04 00 00 00 5B 03 02 00 2D 06 01 06 0C 02 00 00

Sep 17 15:16:15.399: 0x0030: 0D 02

17)CM/MTA sends DSC-ACK to CMTS with confirmation of success

Sep 17 15:16:15.419: DSC-ACK-RECD: OrgMac->0000.cadd.a3ef OrgId->4

Sep 17 15:16:15.419: PktCbl(d2r): DSC-ACK notification received on RP, gateid : 6576

18)CMTS sends a COPS REP gate open message with corresponding gate id. 6576 for which DSC-ACK is received

Sep 17 15:16:15.419: PktCbl(d2r): extract id: gate=6576, resource=91

Sep 17 15:16:15.419: Pktcbl(gdb): TOS Overwrite gate spec info,gate_id=6576 dir=1 gie=6479FC8C

Sep 17 15:16:15.419: Pktcbl(gdb): TOS Overwrite Gate=6576 DSCP=0xA0 mask=0x0

Sep 17 15:16:15.419: PktCbl(d2r): extract id: gate=6576, resource=91

Sep 17 15:16:15.419: PktCbl(Commit): state: id=6576

Sep 17 15:16:15.419: Pktcbl(gdb): Cancelled gate [id 6576] timer t1

Sep 17 15:16:15.419: Pktcbl(gcp): Building GCP message, added obj TRANSACTION ID      ; len:8 padding:0

Sep 17 15:16:15.419: Pktcbl(gcp): Building GCP message, added obj GATE ID             ; len:8 padding:0

Sep 17 15:16:15.419: Pktcbl(gcp): Built GCP message, GATE OPEN           , length: 16, copsLen 44

Sep 17 15:16:15.419:  --- Pktcbl: Sending GCP message ------

Sep 17 15:16:15.419: TRANSACTION ID       : Object.[snum/stype/len 1/1/8]

Sep 17 15:16:15.419:     transaction id   : 0x0

Sep 17 15:16:15.419:     gcp cmd          : 13 (GATE OPEN)

Sep 17 15:16:15.419: GATE ID              : Object.[snum/stype/len 3/1/8]

Sep 17 15:16:15.419:     GateID           : 6576 (0x19B0)

Sep 17 15:16:15.419:  --------------------------------------flow handle(6576)

19)CM/MTA sends DSC-ACK to CMTS with confirmation of success

Sep 17 15:16:15.423: DSC-ACK-RECD: OrgMac-> 0000.cadd.76d3 OrgId->4

Sep 17 15:16:15.423: PktCbl(d2r): DSC-ACK notification received on RP, gateid : 22940

20)CMTS sends a COPS REP gate open message with corresponding gate id. 22940 for which DSC-ACK was received.

Sep 17 15:16:15.423: PktCbl(d2r): extract id: gate=22940, resource=93

Sep 17 15:16:15.423: Pktcbl(gdb): TOS Overwrite gate spec info,gate_id=22940 dir=1 gie=63C0C7D8

Sep 17 15:16:15.423: Pktcbl(gdb): TOS Overwrite Gate=22940 DSCP=0xA0 mask=0x0

Sep 17 15:16:15.423: PktCbl(d2r): extract id: gate=22940, resource=93

Sep 17 15:16:15.423: PktCbl(Commit): state: id=22940

Sep 17 15:16:15.423: Pktcbl(gdb): Cancelled gate [id 22940] timer t1

Sep 17 15:16:15.423: Pktcbl(gcp): Building GCP message, added obj TRANSACTION ID      ; len:8 padding:0

Sep 17 15:16:15.423: Pktcbl(gcp): Building GCP message, added obj GATE ID             ; len:8 padding:0

Sep 17 15:16:15.423: Pktcbl(gcp): Built GCP message, GATE OPEN           , length: 16, copsLen 44

Sep 17 15:16:15.423:  --- Pktcbl: Sending GCP message ------

Sep 17 15:16:15.423: TRANSACTION ID       : Object.[snum/stype/len 1/1/8]

Sep 17 15:16:15.423:     transaction id   : 0x0

Sep 17 15:16:15.423:     gcp cmd          : 13 (GATE OPEN)

Sep 17 15:16:15.423: GATE ID              : Object.[snum/stype/len 3/1/8]

Sep 17 15:16:15.423:     GateID           : 22940 (0x599C)

Sep 17 15:16:15.423:  --------------------------------------flow handle(22940)

21)All the gates are open and commited with success and DYNSERV process ended

Sep 17 15:16:15.707: DSC-REQ End. Transaction over-T8 timer expired. OrgMac->0000.cadd.a3ef OrgId->7

Sep 17 15:16:15.707: DYN-SRV-STATE-DESTROYED : OrgMac->0000.cadd.a3ef OrgId->7

Sep 17 15:16:15.707: DSC-REQ End. Transaction over-T8 timer expired. OrgMac->0000.cadd.76d3 OrgId->18

Sep 17 15:16:15.707: DYN-SRV-STATE-DESTROYED : OrgMac->0000.cadd.76d3 OrgId->18

*** At this point the call has 2 way voice and the gate is in Committed state on the CMTS ***

My-CMTS#sho cable calls

Interface   ActiveHiPriCalls  ActiveAllCalls  PostHiPriCallCMs  RecentHiPriCMs

Cable3/0    0                 0               0                 0             

Cable4/0    0                 0               0                 0             

Cable5/0    0                 0               0                 0             

Cable6/0    0                 0               0                 0             

Cable6/1    0                 2               0                 0             

My-CMTS#show packetcable gate su

GateID    i/f     SubscriberID   GC-Addr        State     Type  SFID(us) SFID(ds)

6576      Ca6/1   14.80.82.141   14.80.85.36    COMMIT    DQoS  91       92      

22940     Ca6/1   14.80.82.144   14.80.85.36    COMMIT    DQoS  93       94      

Total number of  gates = 2

Total Gates committed(since bootup or clear counter) = 17

My-CMTS#show packetcable gate 6576

GateID                 : 6576

    Subscriber ID      : 14.80.82.141

    COPS connection    :

       server handle  : 0x6451F504

        server address : 14.80.85.36

        server port    : 49675

        client address : 14.80.72.2

    State              : COMMIT

    CALEA Version      :  -

    Gate specs [UPSTREAM]

      Gate classifier  :  protocol 17,

                          src addr/port 14.80.82.141/0,

                         dest addr/port 14.80.82.144/54204

      diffserv dscp    : 0xA0

      timer t1(s)     : 200

      timer t7(s)     : 200

      timer t8(s)     : 0

      commit flags     : 0x0

      session class    : 0x1

      flowspec # 1     : [r/b/p/m/M 12000/120/12000/120/120] [R/S: 12000/800]

    Gate specs [DOWNSTREAM]

      Gate classifier  :  protocol 17,

                          src addr/port 14.80.82.144/0,

                         dest addr/port 14.80.82.141/56214

      diffserv dscp    : 0xA0

      timer t1(s)     : 200

      timer t7(s)     : 200

      timer t8(s)     : 0

      commit flags     : 0x0

      session class    : 0x1

      flowspec # 1     : [r/b/p/m/M 12000/120/12000/120/120] [R/S: 12000/0]

My-CMTS#show packetcable gate 22940

GateID                 : 22940

    Subscriber ID      : 14.80.82.144

    COPS connection    :

        server handle  : 0x6451F504

        server address : 14.80.85.36

        server port    : 49675

        client address : 14.80.72.2

    State              : COMMIT

    CALEA Version      :  -

    Gate specs [UPSTREAM]

      Gate classifier  :  protocol 17,

                          src addr/port 14.80.82.144/0,

                         dest addr/port 14.80.82.141/56214

      diffserv dscp    : 0xA0

      timer t1(s)     : 200

      timer t7(s)     : 200

      timer t8(s)     : 0

      commit flags     : 0x0

      session class    : 0x1

      flowspec # 1     : [r/b/p/m/M 12000/120/12000/120/120] [R/S: 12000/800]

    Gate specs [DOWNSTREAM]

      Gate classifier  :  protocol 17,

                          src addr/port 14.80.82.141/0,

                         dest addr/port 14.80.82.144/54204

      diffserv dscp    : 0xA0

      timer t1(s)     : 200

      timer t7(s)     : 200

      timer t8(s)     : 0

      commit flags     : 0x0

      session class    : 0x1

      flowspec # 1     : [r/b/p/m/M 12000/120/12000/120/120] [R/S: 12000/0]

My-CMTS#show cable modem calls

Cable Modem Call Status Flags:

H: Active high priority calls

R: Recent high priority calls

V: Active voice calls (including high priority)

MAC Address    IP Address      I/F       Prim  CMCallStatus  LatestHiPriCall

                                         Sid                    (min:sec)

0000.cadd.76d3 14.80.82.21     C6/1/U1   6     V                    -

0000.cadd.a3ef 14.80.82.18     C6/1/U0   35    V                    -

My-CMTS#

My-CMTS#

My-CMTS#

My-CMTS#

22)One of the MTA hangs up the call. For that we will see MTA sends DSD-REQ with us/ds sfids to CMTS. Same for the other MTA too.

Sep 17 15:18:01.631: DSD-REQ-RECD: I/F Cable6/1/U-1: OrgMac->0000.cadd.76d3 SFID = 0

Sep 17 15:18:01.635: SID-DELETED 46 SFID 93: Requests 0 Grants 10624 Polls 0

Sep 17 15:18:01.635: SID-DELETED 46 SFID 93: Paks 10001 Concats 0 Frags 0 Thruput 110355

Sep 17 15:18:01.635: PktCbl(d2r): DSD-REQ received, gateid: 22940

Sep 17 15:18:01.635: DSD-STATE-CREATED: OrgMac->0000.cadd.76d3 OrgId->19

23)For that same DSD, CMTS sends DSD-RSP

Sep 17 15:18:01.635: DSD-RSP Message Hex Dump:

Sep 17 15:18:01.635: 0x0000: C2 00 00 1C 00 00 00 00 CA DD 76 D3 00 0B BF 54

Sep 17 15:18:01.635: 0x0010: E8 21 00 0A 00 00 03 02 16 00 00 13 00 00

Sep 17 15:18:01.635: DSD-RSP-SENT: To CM->0000.cadd.76d3 TranscId->19

24)DSD-REQ from other MTA for which CMTS sends DSD-RSP

Sep 17 15:18:01.635: DSD-REQ-RECD: I/F Cable6/1/U-1: OrgMac->0000.cadd.a3ef SFID = 0

Sep 17 15:18:01.639: SID-DELETED 45 SFID 91: Requests 0 Grants 10624 Polls 0

Sep 17 15:18:01.639: SID-DELETED 45 SFID 91: Paks 10000 Concats 0 Frags 0 Thruput 110355

Sep 17 15:18:01.639: PktCbl(d2r): DSD-REQ received, gateid: 6576

Sep 17 15:18:01.639: DSD-STATE-CREATED: OrgMac->0000.cadd.a3ef OrgId->8

Sep 17 15:18:01.639: DSD-RSP Message Hex Dump:

Sep 17 15:18:01.639: 0x0000: C2 00 00 1C 00 00 00 00 CA DD A3 EF 00 0B BF 54

Sep 17 15:18:01.639: 0x0010: E8 21 00 0A 00 00 03 02 16 00 00 08 00 00

Sep 17 15:18:01.639: DSD-RSP-SENT: To CM->0000.cadd.a3ef TranscId->8

25)Now the gate need to be delated and closed for the same MTA

Sep 17 15:18:01.645: Pktcbl(gdb): Gate delete requested, gateid = 22940

Sep 17 15:18:01.645: Pktcbl(gcp): Building GCP message, added obj TRANSACTION ID      ; len:8 padding:0

Sep 17 15:18:01.645: Pktcbl(gcp): Building GCP message, added obj GATE ID             ; len:8 padding:0

Sep 17 15:18:01.645: Pktcbl(gcp): Building GCP message, added obj PKTCBL REASON       ; len:8 padding:0

Sep 17 15:18:01.645: Pktcbl(gcp): Built GCP message, GATE CLOSE          , length: 24, copsLen 52

Sep 17 15:18:01.645:  --- Pktcbl: Sending GCP message ------

Sep 17 15:18:01.645: TRANSACTION ID       : Object.[snum/stype/len 1/1/8]

Sep 17 15:18:01.645:     transaction id   : 0x0

Sep 17 15:18:01.645:     gcp cmd          : 14 (GATE CLOSE)

Sep 17 15:18:01.645: GATE ID              : Object.[snum/stype/len 3/1/8]

Sep 17 15:18:01.645:     GateID           : 22940 (0x599C)

Sep 17 15:18:01.645: PKTCBL REASON        : Object.[snum/stype/len 13/1/8]

Sep 17 15:18:01.645:     reason           : [code/subcode: 0x1/0x0]

Sep 17 15:18:01.645:  --------------------------------------

Sep 17 15:18:01.645: Pktcbl(gdb): Deleting gate IE, gateid = 22940

Sep 17 15:18:01.649: Pktcbl(gdb): Freeing gate 0/1. Instance cnt: 7, gate_count is now 1

Sep 17 15:18:01.649: Pktcbl(gdb): Deleting subs IE, subs id = 14.80.82.144

Sep 17 15:18:01.649: DSD From LC::

Sep 17 15:18:01.649: 0x0000: 00 00 00 00 19 06 02 04 00 00 00 5E 18 06 02 04

Sep 17 15:18:01.649: 0x0010: 00 00 00 5D

26)With that, other gate 6576 needs to be closed and deleted too.

Sep 17 15:18:01.649: Pktcbl(gdb): Gate delete requested, gateid = 6576

Sep 17 15:18:01.649: Pktcbl(gcp): Building GCP message, added obj TRANSACTION ID      ; len:8 padding:0

Sep 17 15:18:01.649: Pktcbl(gcp): Building GCP message, added obj GATE ID             ; len:8 padding:0

Sep 17 15:18:01.649: Pktcbl(gcp): Building GCP message, added obj PKTCBL REASON       ; len:8 padding:0

Sep 17 15:18:01.649: Pktcbl(gcp): Built GCP message, GATE CLOSE          , length: 24, copsLen 52

Sep 17 15:18:01.649:  --- Pktcbl: Sending GCP message ------

Sep 17 15:18:01.649: TRANSACTION ID       : Object.[snum/stype/len 1/1/8]

Sep 17 15:18:01.649:     transaction id   : 0x0

Sep 17 15:18:01.649:     gcp cmd          : 14 (GATE CLOSE)

Sep 17 15:18:01.649: GATE ID              : Object.[snum/stype/len 3/1/8]

Sep 17 15:18:01.649:     GateID           : 6576 (0x19B0)

Sep 17 15:18:01.649: PKTCBL REASON        : Object.[snum/stype/len 13/1/8]

Sep 17 15:18:01.649:     reason           : [code/subcode: 0x1/0x0]

Sep 17 15:18:01.649:  --------------------------------------

Sep 17 15:18:01.649: Pktcbl(gdb): Deleting gate IE, gateid = 6576

Sep 17 15:18:01.649: Pktcbl(gdb): Freeing gate 0/0. Instance cnt: 12, gate_count is now 0

Sep 17 15:18:01.649: Pktcbl(gdb): Deleting subs IE, subs id = 14.80.82.141

27)Finally, DSD process ends…

Sep 17 15:18:04.635: DSD-REQ End. T10 timer expired. OrgMac->0000.cadd.76d3 OrgId->19

Sep 17 15:18:04.635: DYN-SRV-STATE-DESTROYED : OrgMac->0000.cadd.76d3 OrgId->19

Sep 17 15:18:04.639: DSD-REQ End. T10 timer expired. OrgMac->0000.cadd.a3ef OrgId->8

Sep 17 15:18:04.639: DYN-SRV-STATE-DESTROYED : OrgMac->0000.cadd.a3ef OrgId->8

Average Rating: 5 (1 ratings)

Actions

Login or Register to take actions

This Document

Posted September 30, 2009 at 2:23 PM
Stats:
Comments:0 Avg. Rating:5
Views:2068 Contributors:0
Shares:0

Related Content

Documents Leaderboard

Rank Username Points
1 106
2 20
3 9
4 5
Rank Username Points
15