Hwic-ADSL protocol error

Document

Oct 19, 2009 7:26 AM
Oct 19th, 2009

Hi,

I have a 1841 that I am trying to get the ADSL link to come up on.

My ATM interface is showing as Down Down.

Running a debug atm events shows

open failed: Protocol error recived -- retrying?

I have updated the ios to 12.4(24)T1 and before this, the card was working.

Could this be a firmware mismatch error, and if so how can i go about seeing what firmware version the ADSL-WIC card is running and upgrading it if nessery?

Cheers

Aaron

Average Rating: 0 (0 ratings)

Comments

VLA_WeyBridge_2 Mon, 10/19/2009 - 08:04

some more of the error message

*Oct 19 15:02:43.159: DSL(ATM0/0/0): Using preferred open mode
*Oct 19 15:02:43.159: DSL(ATM0/0/0): Using ITU sync first for 5 secs, then ANSI/ITU sync alternatively for 2 secs
*Oct 19 15:02:43.159: DSL(ATM0/0/0): Using subfunction 0x0
*Oct 19 15:02:43.159: LOCAL:Max noise margin for power cutoff 31
*Oct 19 15:02:43.159: DSL(ATM0/0/0): GPCI[0] 0x5
*Oct 19 15:02:43.159: DSL(ATM0/0/0): GPCI[1] 0x9
*Oct 19 15:02:43.159: DSL(ATM0/0/0): GPCI[2] 0x1
*Oct 19 15:02:43.159: DSL(ATM0/0/0): GPCI[3] 0x0
*Oct 19 15:02:43.159: DSL(ATM0/0/0): Sent extended command 0x3
*Oct 19 15:02:45.659: DSL(ATM0/0/0): 1: Modem state = 0x9
*Oct 19 15:02:48.159: DSL(ATM0/0/0): 2: Modem state = 0x9
*Oct 19 15:02:50.659: DSL(ATM0/0/0): 3: Modem state = 0x10
*Oct 19 15:02:53.159: DSL(ATM0/0/0): 4: Modem state = 0x10
*Oct 19 15:02:53.623: DSL(ATM0/0/0): Received response: 0x22
*Oct 19 15:02:53.623: DSL(ATM0/0/0): Open failed: Handshake or init message invalid or had bad CRC -- retrying
*Oct 19 15:02:53.623: DSL(ATM0/0/0): sleep 5 seconds
*Oct 19 15:02:58.623: DSL(ATM0/0/0): Send ADSL_OPEN command.
*Oct 19 15:02:58.623: dslsar enable ATM0/0/0

*Oct 19 15:02:58.623: DSL(ATM0/0/0): Using preferred open mode
*Oct 19 15:02:58.623: DSL(ATM0/0/0): Using ITU sync first for 5 secs, then ANSI/ITU sync alternatively for 2 secs
*Oct 19 15:02:58.623: DSL(ATM0/0/0): Using subfunction 0x0
*Oct 19 15:02:58.623: LOCAL:Max noise margin for power cutoff 31
*Oct 19 15:02:58.623: DSL(ATM0/0/0): GPCI[0] 0x5
*Oct 19 15:02:58.623: DSL(ATM0/0/0): GPCI[1] 0x9
*Oct 19 15:02:58.623: DSL(ATM0/0/0): GPCI[2] 0x1
*Oct 19 15:02:58.623: DSL(ATM0/0/0): GPCI[3] 0x0
*Oct 19 15:02:58.623: DSL(ATM0/0/0): Sent extended command 0x3
*Oct 19 15:03:01.123: DSL(ATM0/0/0): 1: Modem state = 0x9
*Oct 19 15:03:03.623: DSL(ATM0/0/0): 2: Modem state = 0x9
*Oct 19 15:03:06.123: DSL(ATM0/0/0): 3: Modem state = 0x10
*Oct 19 15:03:06.623: DSL(ATM0/0/0): Received response: 0x22
*Oct 19 15:03:06.623: DSL(ATM0/0/0): Open failed: Protocol error received -- retrying
*Oct 19 15:03:06.623: DSL(ATM0/0/0): sleep 5 seconds
*Oct 19 15:03:11.623: DSL(ATM0/0/0): Send ADSL_OPEN command.
*Oct 19 15:03:11.623: dslsar enable ATM0/0/0

dpetrucci1029 Tue, 10/20/2009 - 13:45 (reply to VLA_WeyBridge_2)

I would go into Software Advisor and there is a link where you can find software that is compatible with your hardware. From there you should see the model ADSL card you have and it will tell you what version of code you need for that hardware feature.

Actions

Login or Register to take actions

This Document

Posted October 19, 2009 at 7:26 AM
Stats:
Comments:3 Avg. Rating:0
Views:2050 Contributors:2
Shares:0
Tags: 1841, adsl
+

Related Content

Documents Leaderboard

Rank Username Points
1 106
2 20
3 9
4 5
Rank Username Points
15