×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Configuring Redundancy Primary Backup mode of internet links (ILL, PPPOE broadband) on Cisco Router

Document

Mon, 10/11/2010 - 23:17
Sep 26th, 2010
User Badges:

I am posting an article for circuit redundancy used in working scenario.


Router is Cisco 1841 with IOS image c1841-spservicesk9-mz.124-15.T12.bin.


Router has three Fast Ethernet interfaces, each one for ISP1, ISP2 and customer LAN.

Router is connected with two Internet circuits.

Primary as internet lease line (ILL) with static IP connected to ISP1.

Backup as PPPOE broadband with dynamic IP address connected to ISP2.


You can configure both circuits to work in Primary/backup mode using Cisco SLA monitor services and static route.


Tokai Rubber_Bangalore1.jpg


Below is the Router's config:-

=======================



Router#sh run

Building configuration...


Current configuration : 2421 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

enable password XXXXXXX

!

no aaa new-model

dot11 syslog

ip cef

!

!

no ip dhcp use vrf connected

ip dhcp excluded-address 192.168.1.X

!

ip dhcp pool Customer_LAN

   network 192.168.1.0 255.255.255.0

   default-router 192.168.1.1

   dns-server 218.X.X.X 203.X.X.X

   lease 2

!

!

ip name-server 203.124.X.X

ip name-server 218.248.X.X

multilink bundle-name authenticated

vpdn enable

!

vpdn-group 1

request-dialin

  protocol pppoe

l2tp tunnel receive-window 1024

!

!

!

!

!

archive

log config

  hidekeys

!

!

!

track 1 rtr 1 reachability

!

!

bba-group pppoe global

!

!

interface FastEthernet0/0

description ISP1- Internet Lease Line

ip address 71.X.X.2 255.255.255.0

ip nat outside

duplex auto

speed auto

!

interface FastEthernet0/1

description ISP2- DSL Broadband for Internet

no ip address

ip virtual-reassembly

duplex auto

speed auto

pppoe enable group global

pppoe-client dial-pool-number 1

!

interface FastEthernet0/0/0

description Customer_LAN

ip address 192.168.1.1 255.255.255.0

ip nat inside

ip virtual-reassembly

duplex auto

speed auto

!

interface Dialer1

ip address negotiated

ip mtu 1492

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

dialer-group 1

no cdp enable

ppp authentication chap callin

ppp chap hostname XXXXXXX (Hostname/Username given by ISP)

ppp chap password 0 XXXXX  (Password given by ISP)

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 71.X.X.1 track 1

ip route 0.0.0.0 0.0.0.0 Dialer1 200

!

!

ip http server

no ip http secure-server

!

ip nat inside source route-map ISP1-NAT interface FastEthernet0/0 overload

ip nat inside source route-map ISP2-NAT interface Dialer1 overload

!

ip sla 1

icmp-echo 71.X.X.1 source-interface FastEthernet0/0

timeout 1000

threshold 40

frequency 3

ip sla schedule 1 life forever start-time now

!

access-list 1 permit 192.168.1.0 0.0.0.255

!

no cdp run

!

route-map ISP1-NAT permit 10
match ip address 1
set interface FastEthernet0/0
!
route-map ISP2-NAT permit 10
match ip address 1
match interface Dialer1

!

control-plane

!

!

!

line con 0

line aux 0

line vty 0 4

password XXXXXXX

login

!

scheduler allocate 20000 1000

end

Router#

Router#sh ver
Cisco IOS Software, 1841 Software (C1841-SPSERVICESK9-M), Version 12.4(15)T12, RELEASE SOFTWARE (fc3)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2010 by Cisco Systems, Inc.
Compiled Fri 22-Jan-10 00:40 by prod_rel_team
ROM: System Bootstrap, Version 12.4(13r)T, RELEASE SOFTWARE (fc1)
Router uptime is 17 hours, 21 minutes
System returned to ROM by reload at 11:24:31 UTC Mon Oct 11 2010
System image file is "flash:c1841-spservicesk9-mz.124-15.T12.bin"

This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.
A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html
Cisco 1841 (revision 7.0) with 235520K/26624K bytes of memory.
Processor board ID FHKXXXXXXXX
3 FastEthernet interfaces
DRAM configuration is 64 bits wide with parity disabled.
191K bytes of NVRAM.
62720K bytes of ATA CompactFlash (Read/Write)
Configuration register is 0x2102
Router#
Loading.

Actions

This Document