IPV6 on the Cisco 877

Document

Dec 13, 2010 4:31 PM
Dec 13th, 2010

Example of Cisco 877 CPE using Internode as an IPv6 Service provider, dual stack configuration

(uses DHCPv6 Prefix Delegation to assign lan v6 address /64)

http://ipv6.internode.on.net/

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname IPv6CPE

!

boot-start-marker

boot-end-marker

!

logging message-counter syslog

enable secret 0 <password>

!

aaa new-model

!

!

aaa authentication login default local enable

aaa authorization exec default local if-authenticated

!

!

aaa session-id common

clock timezone ACST 9 30

clock summer-time ACDT recurring 1 Sun Oct 2:00 1 Sun Apr 2:00

!

!

no ip source-route

!

!

ip dhcp excluded-address 192.168.1.1

ip dhcp excluded-address 192.168.1.51 192.168.1.254

!

ip dhcp pool MyLeg

   network 192.168.1.0 255.255.255.0

   default-router 192.168.1.1

   dns-server <dns1> <dns2>

   lease 300

!

!

ip cef

no ip domain lookup

ipv6 unicast-routing

ipv6 cef

!

!

username cisco privilege 15 password 0 <password>

!

!

interface ATM0

mtu 1492

no ip address

no atm ilmi-keepalive

pvc 8/35

  encapsulation aal5mux ppp dialer

  dialer pool-member 6

!

!

interface FastEthernet0

duplex full

speed 100

spanning-tree portfast

!

interface FastEthernet1

duplex full

speed 100

spanning-tree portfast

!

interface FastEthernet2

duplex full

speed 100

spanning-tree portfast

!

interface FastEthernet3

duplex full

speed 100

spanning-tree portfast

!

interface Vlan1

ip address 192.168.1.1 255.255.255.0

ip nat inside

ip virtual-reassembly

ipv6 address NODE-PD ::1/64

ipv6 enable

ipv6 nd ra interval 30

!

interface Dialer6

description --- Dual Stack v4v6 Dialer ---

mtu 1492

ip address negotiated

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 6

dialer-group 6

ipv6 address autoconfig

ipv6 enable

ipv6 dhcp client pd NODE-PD rapid-commit

ppp chap hostname <username>@ipv6.internode.on.net

ppp chap password 0 <password>

!

ip route 0.0.0.0 0.0.0.0 Dialer6

!

!

ip nat inside source list Allow-nat interface Dialer6 overload

!

ip access-list extended Allow-nat

permit ip 192.168.1.0 0.0.0.255 any

!

dialer-list 6 protocol ip permit

dialer-list 6 protocol ipv6 permit

ipv6 route ::/0 Dialer6

!

!

!

!

!

control-plane

!

banner login #

unauthorised access is not permitted

#

!

line con 0

no modem enable

line aux 0

line vty 0 4

access-class 1 in

exec-timeout 90 0

transport input telnet ssh

!

!

Average Rating: 5 (1 ratings)

Actions

Login or Register to take actions

This Document

Posted December 13, 2010 at 4:31 PM
Stats:
Comments:0 Avg. Rating:5
Views:34451 Contributors:0
Shares:0

Related Content

Documents Leaderboard

Rank Username Points
1 177
2 64
3 60
4 50
5 23
Rank Username Points
5
0