RME/LMS Inventory Collection Fails for Catalyst 6500 Switches

Document

Feb 12, 2011 4:19 PM
Feb 12th, 2011

Inventory collection jobs for Catalyst switches running 12.2(33)SXI code may fail with the "Device sensed; collection failed" message.  This can occur in LMS 3.2 (RME 4.3) and LMS 4.0.  The problem is that in 12.2(33)SXI code, the way the CISCO-FLASH-MIB data is fetched is done in a way to prevent overwhelming the supervisor.  However, the downside of this is that SNMP operations take a bit longer.  By default, RME/LMS has a two second SNMP timeout.  This, as it turns out, is too small for properly collecting inventory from these switches.  Not to worry, though; there is a workaround.

In LMS 3.2 (RME 4.3) go to RME > Devices > Device Management > RME Devices, and select the Catalyst 6500s exhibiting the problem.

Screen shot 2011-02-12 at 7.24.00 PM.png

Click Edit Device Attributes.

Screen shot 2011-02-12 at 7.25.05 PM.png

Click Inline Edit.

Screen shot 2011-02-12 at 7.28.36 PM.png

Select each device in the list, and set the SNMP Timeout to 10 seconds.  Then click Modify.  On the previous screen, click Apply to save the changes.

Screen shot 2011-02-12 at 7.30.56 PM.png

Then run a new Inventory Collection job.  It should be successful.

NOTE: In LMS 4.0, this same interface exists but there is no link to it.  Instead, point your browser directly to http://SERVER/rme/rmedevices.do where SERVER is the IP address or hostname of the LMS server (be sure to include the port as well if you are not using HTTPS).

Average Rating: 5 (2 ratings)

Actions

Login or Register to take actions

This Document

Posted February 12, 2011 at 4:19 PM
Stats:
Comments:0 Avg. Rating:5
Views:4497 Contributors:0
Shares:0

Related Content

Documents Leaderboard

Rank Username Points
1 19
2 10
3 5
4 5
5 5
Rank Username Points
5