Upgrading Cisco Unified Communications Manager (CUCM) to Version 9.1 (Drive to 9) - FAQ from Live Webcast

Document

Jul 18, 2013 12:59 AM
Jul 18th, 2013


Introduction

svija.jpg

amitsin.jpg

Vijay Rao is a Network Consulting Engineer and is currently a unified communications (UC) consultant for Bank of America. He has been providing consulting assistance to the bank for the past 6 years. He helps design complex UC networks for large enterprise customers. He was previously part of Cisco IT in the Asia Pacific, Japan, and China (APJC) region and was instrumental in designing and implementing the Bangalore campus. He has been working with Cisco for 9 years and has 12 years of UC experience. He has a Cisco CCVP® certification.

Amit Singh is a customer support engineer at the Cisco Technical Assistance Center in Bangalore, India. He has six and half years of experience in his areas of expertise: wireless, Cisco Unified Communications Manager, multiservices, Cisco Unity, and Cisco Unified Contact Center Express. He has been involved in various escalation requests from India, Singapore, and Australia and is currently working as a technical lead for the Voice team in Bangalore, India. He is a computer science graduate.

Expert, Aashish Jolly was helping Vijay and Amit to answer few of the questions asked during the session. He is a customer support engineer at Cisco and hold a CCIE.

The related Ask The Expert session is available here.

You can download the slides of the presentation in PDF format here.

The Complete Recording of this live Webcast can be accessed here.

1. Upgrading Cisco Unified Communications Manager to Version 9.1

Q. CUCM 8.6 having MCS 7835, can we migrate on same server 9.0 or require virtual server?

A. CUCM 9.0 is also supported on MCS servers, please check the below URL for details on what servers support CUCM 9.0

http://www.cisco.com/en/US/prod/collateral/voicesw/ps6790/ps5748/ps378/prod_brochure0900aecd8062a4f9.html

Q. Do we need to upgrade CUPS also if we are upgrading CUCM to 9.1?

A. Yes, CUPS needs to be upgraded to 9.1 as well, starting with ver 9.X. CUCM, IM & Presence version numbers need to be in sync.

Q. Are there any changes on the Unity side with CUCM 9.x?

A. Unity is EoS, so as such it is recommended to upgrade to Unity Connection.

Q. Is there any utility available for upgrade without bridge server because it is coming with version 10?

A. Currently no automated Tool is available for upgrade. There are plans to introduce it in ver 10.X

Q. We're running CUCM 8.6 and planning to upgrade to 9.1. What's the process to generate licenses?

A. You could use CUCM User Count Tool (UCT) for planning the licenses -

http://www.cisco.com/en/US/docs/voice_ip_comm/cucm/upgrade/uct/9_1_1/CUCM_BK_U0AE00F5_00_uct-admin-guide_chapter_010.html

Q. It would be great if you include session for UCT Application - Lic manager

A. Have a look at this URL, it has a presentation on license migration - https://supportforums.cisco.com/community/netpro/collaboration-voice-video/ip-telephony/blog/2013/05/20/drive-to-9

Q. According to the server matrix the 7835H2 is recommended to have 4gb ram and 146gb HDD. I have a few of these servers and my question is… Is there a way to check or know for sure if a server will go into bridge mode or not when moving from 7.1.3 to 8.x?

A. Have a look at the supported server model for CUCM, that should provide info on which servers support Bridge mode -

http://www.cisco.com/en/US/prod/collateral/voicesw/ps6790/ps5748/ps378/prod_brochure0900aecd8062a4f9.html

Q. How can I upgrade from MCS CUCM version 7 to UCS virtualization CUCM 9.1?

A. There are different upgrade options available starting CUCM 9.1.2, we will be covering that in the PPT, you may also use the Upgrade Assessment Tool which provides the relevant documentation depending on From/To version. Stay tuned for demo ahead

Q. Can I use this to generate information that required by Cisco Licensing?

A. It will help you in planning for licenses. Since licensing changes in 9.1, you can use this utility to find out how many Enhanced, CUWL or relevant licenses are required.

Q. What should be the Unity version supported on CUCM 9.1 ?

A. Unity is EoS, consider upgrading to Unity Connection. Use this url for more on Unity - CM Compatibility

http://www.cisco.com/en/US/docs/voice_ip_comm/unity/compatibility/matrix/cutspmtx.html#wp51076

Q. Is any upgrades need on remote sides with CME and CUCM 9.X as well?

A. Have a look at CUCM Software Compatibility Matrix.You may need to move to CME 9.0

http://www.cisco.com/en/US/docs/voice_ip_comm/uc_system/unified/communications/system/versions/IPTMtrix.html

Q. What is ELM? I was asked by Cisco Licensing to generate information by using this which we don't have it on our UCM 8.6.

A. ELM is Enterprise License Manager, basically a centralized pool for licensing for CUCM + CUC. This is available starting CUCM 9.0

Q. What happens if you use ELM to convert DLUs from version 6.1 to CUWL on version 9.1, and then you realize you needed to assign more licenses to a specific CUWL level?

A. You have to just open a case, give your requirement and the Licensing Team will get licenses for you. However we recommend that you add all un-used licenses prior to upgrade.

Q. In CUCM 8.X and Lower we use DLU licences and gives you huge flexibility because this is linked to device rather than users. Will in CUCM 9.x do we have the flexibility in add/removing devices (no users) and reutilise the licences in company benefit?

A. With CUCM 9.0 we have introduced ELM and licensing has changed, visit this page for a presentation on licensing migration - https://supportforums.cisco.com/community/netpro/collaboration-voice-video/ip-telephony/blog/2013/05/20/drive-to-9

Q. Till 9.1.2 release, can we do a "jump upgrade" by requesting a Demo License for CUCM 6.x,7x. and 8.x ?

A. Jump Upgrade only available + supported from CUCM 9.1.2. Doing a Jump Upgrade on prior versions is not supported by TAC.

Q. Already we integrated unity express 8.6.6 with 9.0 cucm.If we upgrading the uc 9.1 from 9.0 any changes need to done in unity side?

A. CUE 8.6.6 should work with CUCM 9.1. I recommend you keep an eye on this document -

http://www.cisco.com/en/US/docs/voice_ip_comm/unity_exp/compatibility/cuecomp.htm

Q. Does that mean we have to upgrade to 9.0 first to get ELM then use it to generate the information needed for 9.1?

A. You need to use the User Count Tool (UCT) to find out the CUWL, UCL licenses you need pro-actively.

Q. We have 28k+ users and 35k+ devices, how do I know what type of license I need for each user. Do you have some sort of tool to assist with this?

A. We have User Count Tool (UCT) available for planning the licensing needs -

- http://www.cisco.com/en/US/docs/voice_ip_comm/cucm/upgrade/uct/9_1_1/CUCM_BK_U0AE00F5_00_uct-admin-guide.html

Q. My company has ATA186 using SCCP - are they supported in 9.x?

A. ATA186 is really old. It is EoS, I recommend moving to ATA187 or VG20x XM instead. As per CUCM Software Compatibility Matrix, ATA186 isn't listed.

Q. What if I need to migrate only a set of phones from my existing 8.x cluster ?

A. One can use the “Prepare Cluster for Rollback to pre-8.0” enterprise parameter to download empty ITL files in the cluster(follow the documented process). Once the empty ITL file has been downloaded, the phone will accept any ITL file coming its way next. Now you can move this set of phone to another cluster & set the enterprise parameter back to false.

Q.Does the UCT take into account the unused DLUs?

A. Yes, it considers the unused DLUs and it displays the unused DLUs. UCT is not going to give any licenses. It helps us to see how many DLUs are going to look like in the form of UCL/CUWL. UCT Tool pulls up DLU information and then you can calculated add or subtract your licenses. You can use the UCT tool to make a decision on how many licenses of what kind you are going to request from the licensing Team. This is just going to help us make a decision and it show you a picture of how your license lok like in ELM mode.

Q. Is the upgrade readiness assement tool still beta?

A. Upgrade Readiness Assessment is available for use. However continuos enhancements are made to the tool.

Q. I am a bit confused about the Extension Mobility licensing. With CUCM 9.1 we can still issue extension Mobility but it will no longer pull from our DLU's is that correct?

A. Extension Mobility has been removed as a licensed user feature in Cisco Unified Communications Manager 9.1(1a). Users that have only Extension Mobility configured no longer require an Essential license. Extension Mobility is configured when a device profile is entered for Extension Mobility in the End User Configuration.

http://www.cisco.com/en/US/docs/voice_ip_comm/cucm/rel_notes/9_1_1/CUCM_BK_RD7D4696_00_release-notes-for-cisco-unified_chapter_0100.html

Q. Do we need to bother with Upgrade readiness if we are already on UCS ?

A. We recommend using the upgrade readiness assessment tool. It shall let you know the best migration path to take.

Q. Can 9.1.1 be used in place of 9.1.2 for the "Jump" / "Flash-cut" upgrade option?

A. Jump Upgrade is available + supported starting 9.1.2. Earlier versions are not supported by TAC

Q.When you upgrade 8.6 to 9.1 whats happen with licence, I need to contact Cisco to migrate the License or is automatic?

A. You can use license count utility to plan licensing and request licenses. Migration of CUCM License is a manual process and there is a need to contact GLO (Global Licensing Office) team with the UCT output and contract details.

Q.The VM template for 9.x has a single 120GB HD were as the 8.6 10k node template had two 80GB drives. What has to be done to migrate, can we use the existing vm template Or do we need to first create all new vms using the 9x template migrate our existing?

A. If you are migrating from a hardware 8.6 to 9.1 on UCS, you can defintely do an upgrade on existing callmanager template the way its deployed for 9.1 and then take a DRS backup of 9.1 callmanager but when you actually deploy 9.1 you have to rebuild the system based on 9.1 using the template and then restore the backup.We will help to use the new template defined for 9.1.

Q. We are using 8.6 CUPS with 8.6 CUCM for Remote Call Control (RCC) with MS Lync. Will this feature continue to work with CUCM 9.1? What happens to CUPS?

A. CUPS needs to be migrated to IM/Presence 9.1 too and RCC would still be supported

Q. I'm on 8.5, is this a one step upgrade to 9.1?

A. 8.5 - 9.1 is a 1-step upgrade right. Refer to Upgrade paths on this URL -

http://www.cisco.com/en/US/docs/voice_ip_comm/cucm/compat/ccmcompmatr1.pdf

Q. We use HP servers for out VMWare enviroment. If we do an upgrade from CUCM 6.1 to 7.13 on the HP VMWare servers, can that easily be migrated to UCS in the future?

A. CUCM 8.0.3 was the first release to support Virtualization on UCS. For 3rd Party Specs-Based support, I believe it was added in 8.6

Q. Does refresh cop file require IMM default user id and password?

A. It is very similar to a regular cop file install and requires no IMM credentails. However you would need access to CUCM to install cop file.

Q. Will the ELM will be installed along with CUCM automatically if we are doing an upgrade from 8.6.2 to 9.1.1(a)...?

A. ELM can co-reside with CUCM.

Q. Any foreseen issues with the CTL/ITL files when upgrading, especially if changing IP addresses from 8.x to 9.x?

A. Change of IP will require CTL file to be updated.

Q. What is different betwen enhanced and enhanced + UCL licenses?

A. Refer to this URL on features available in different licensing options -

http://www.cisco.com/en/US/prod/collateral/voicesw/ps6882/ps9156/product_solution_overview0900aecd806cc7a4.html

Q. Can you add 2nd node to ELM?

A. ELM doesn't support redundancy at the moment, so no clustering. However, ELM can be backedup.

Also, you have a 60 day grace period with full functionality if your ELM server goes offline.

Q. Is there direct upgrade available from 7.1.5 to 8.5.1?

A. Refer to Supported Upgrade paths here -

http://www.cisco.com/en/US/docs/voice_ip_comm/cucm/compat/ccmcompmatr1.pdf

Q. Customer wants to upgrade the cluster from 8.5 to 9.1 on UCS as a fresh install, as the current MCS doesnt support upgrade also, he wants to clean up the junk configs. If that is the case, what we will do for the licenses?

A. Use the license count tool to plan the licenses for 9.1. This can be done without upgrading to 9.1. Also, by providing the appropriate details to the licensing team, CUCM 9.1 licenses would be issued.

Q. If you have multiple clusters do you have one ELM for all clusters or one ELM per cluster?

A. Co-resident ELM and Standalone ELM are both possible. However, for multiple clusters, we recommend Centralized ELM for easier management.

Q. Is the Jump Upgrade implementation process documented well?

A. More on jump upgrade will be available once 9.1.2 is FCS

Q. We are looking to migrate our CM 8.0.1 that is on physical hardware to a virtual box that is in house and configure the CUCM to be using 9.x. Would we follow the same steps as if we were using the VM environment on the physical CM in use currently?

A. You may want to upgrade your current server to 9.1 (if it supports it) then move to Virtual environment using DRS restore

Q. What are the IP phone firmware requirements of cucm 9.1.2? Will this version of call manager support older IP phones?

A. CUCM 9.1.2 is not FCS'd, so don't know the default phone firmware that will be available with this version. Also, we need to wait and check the support for older phone models.

Q. Where can i find the new feature list for cucm 9.1 version ?

A. Refer to New & Changed information in release notes -

http://www.cisco.com/en/US/docs/voice_ip_comm/cucm/rel_notes/9_1_1/CUCM_BK_R6F8DBD4_00_release-notes-for-cucm-91_chapter_0100.html

Q. What about upgrade procedures when staring from CUCM 5.x releases?

A. Upgrade from 5.x may require multiple hops. You may need to upgrade to 6.1.4 or 6.1.5 before you could consider jump upgrade

Q. When performing a "jump" upgrade and restoring the DRS file on UCS. Do all the servers in the cluster need to be virtualized and accessible for the restore to work?

A. We recommend a cluster backup & restore. Yes, all servers need to be backed up and restored.

Q. In case of jump upgrade of LDAP using cluster, how would jump upgrade work on isolated network ?

A. Most likely isolated network would require LDAP. I recommend watch out for 9.1.2 Jump Upgrade documentation post 9.1.2 FCS for more details

Q. Has CUCM Release 9.1.2 released ?

A. We are targetting early August 2013 for FCS. However this date is not set in stone.

Q.Firewall ports for cucm 9.x URL?

A. Here it is -

http://www.cisco.com/en/US/docs/voice_ip_comm/cucm/port/9_1_1/CUCM_BK_T2CA6EDE_00_tcp-port-usage-guide-91_chapter_01.html

Q. With licensing based on MAC, what happens if we want to move the box to another VM for whatever reason? Would we just contact TAC and are there any chargers if we are covered under smart net?

A. If License MAC changes, you need to re-host the license. You get a 30 day timeframe to do that. this has changed with 9.0 as we introduced ELM

Q. So Jump Upgrade will be a feature available starting 9.1.2 and thus not available yet, right?

A. Jump Upgrade is TAC supported starting 9.1.2

Q. Is any upgrades need to be done on remote offices with CMexpress conected to the CUCM?

A. Refer to CUCM Compatibility Matrix -

http://www.cisco.com/en/US/docs/voice_ip_comm/uc_system/unified/communications/system/versions/IPTMtrix.html May need CME 9.0

Q. If I have MCS 7845 hardware and UCM 7.1.3; Will I be able to do a direct upgrade to 9.1.2.?

A. Depending on your hardware model. 7.1.3 - 9.1.2 should be direct 1-step. Check this url -

http://www.cisco.com/en/US/docs/voice_ip_comm/uc_system/unified/communications/system/versions/IPTMtrix.html

Q. Is Jump supported only for 9.1.2 ?

A. Yes, introduced & TAC supported from 9.1.2 only.

Q. When is 9.1.2 FCS date in Australia?

A. We are targetting early August 2013. However this date is not set in stone. We believe the code would be available globally.

Q. Does UCT tool works for CUCM 5.x releases also?

A. UCT should function with 5.x too.

Q. I have a customer with v5.0.4 (on MCS 7845H2) 2Gb 72Gb HDDs.Can I upgrade the RAM and HDDs to 4Gb> + 146Gb HDDs and then progress with the upgrade path from 5.0.4 to v6.x Once there I can then jump to v9.1.2 ?

A. Yes you can upgrade RAM/HDD, however they need to be procurred from HP directly as MCS 7845 H2 is EOS. Refer to supported server for CUCM doc -

http://www.cisco.com/en/US/prod/collateral/voicesw/ps6790/ps5748/ps378/prod_brochure0900aecd8062a4f9.html

Q. What is best recommendation for upgrading subscriber nodes during CUCM upgrade and move to virtualization? Upgrade the Subs or just delete them and build new?

A. Recommended to restore Subscribers also.

.

Q. We are using CM v8.6.2.20000-2 and CCX 8.0.2.11005-20, when we upgrade to 9.x do we need to upgrade CCX to the new version as well?

A. Most likely yes.

2. Miscellaneous

Q. Will the presentation be available for download or later review?

A. Yes, it will be available so that you can review and download.

https://supportforums.cisco.com/docs/DOC-34669

Related Information

Average Rating: 5 (2 ratings)

Actions

Login or Register to take actions

This Document

Posted July 18, 2013 at 12:59 AM
Stats:
Comments:0 Avg. Rating:5
Views:7999 Contributors:0
Shares:0

Related Content

Documents Leaderboard