Jabber for Windows cannot search LDAP user/not showing Picture after moving from CUPC

Document

May 1, 2012 12:08 PM
May 1st, 2012

TITLE

Jabber for Windows cannot search LDAP user/not showing Picture after moving from CUPC

SYMPTOM:

Jabber for Windows does not use CUPS LDAP.

ENVIRONMENT:

Jabber for Windows on a Windows Workstation

CAUSE:

Most likely problem is that Workstation does not have the needed jabber-config.xml file.

RESOLUTION:

Here is a sample entry at the very basic level for LDAP connectivity issue

(Assumption:

1) Workstation is part of the Domain

2) Active Directory jpegPhoto attribute is used for picture (or any other filed that is specified in CUPS LDAP Settings)

3) LDAP Server/Domain Controller have 389 port open for LDAP query (a simple telnet to 389 port can verify)

)

For Windows 7:

-------------------------

1) Create a text file named 'jabber-config.txt' and rename it to 'jabber-config.xml' under

"%USERPROFILE%\AppData\Roaming\Cisco\Unified Communications\Jabber\CSF\Config" (- Win 7)

"%SYSTEMROOT%\Documents and Settings\user_name\Application Data\Cisco\Unified Communications\Jabber\CSF\Config" (- XP)

Please copy/paste the location on a Windows Explorer and it will open up the location

2) Open the file with notepad and copy/paste the following

<?xml version="1.0" encoding="utf-8"?>

<config version="1.0">

<Directory>

  <DirectoryServerType>EDI</DirectoryServerType>

  <PrimaryServerName>10.10.10.1</PrimaryServerName>

  <UseWindowsCredentials>1</UseWindowsCredentials>

</Directory>

</config>

3) Change the 10.10.10.1 with the LDAP server (Domain Controller) IP Address and save the xml file

4) Exit out jabber for windows and re-login

PREVENTION:

None

Cisco Jabber for Windows User Photos

Problem

Cisco Jabber for Windows Client does not automatically  update with the photos that updated in Active Directory.

You have updated a user's photo in AD and noticed that it would not change. you have   browsed to "C:\Users\<user name>\App Data\Local\Cisco\Unified  Communications\Jabber\CSF\Photos" and had to manually delete the user  photos in this folder. When  re-opend the Jabber client the updated photos were now appearing

Solution

This is a known issue with CUPC that CUPC Contact Picture Cached and not updating dynamically.  The issue is that since the contact list images are cached locally on the PC in (C:\Users\USERFOLDER\AppData\Local\Cisco\Unified Communications\Client Services Framework\Config\Photos), the user's old image still displays on contact list.

When doing a directory search for the user within CUPC it shows a blank image (Since the pic on the Web Server is deleted), but since the contact list images are cached the contact still shows the picture

To resolve this issue Delete Local CUPC Folder:  C:\Users\USERFOLDER\AppData\Local\Cisco\Unified Communications\

This is documented in the Cisco Bug ID CSCtu25084   (Registered customers only)

Average Rating: 0 (0 ratings)

Comments

Paul McGurn Fri, 04/19/2013 - 19:58

In a scenario where Jabber is running on a non-domain machine, are we forced to use UDS + custom web URI for photos in order for directory lookups and photos to work correctly with both domain and non-domain PC's (and OS X clients)?

Actions

Login or Register to take actions

This Document

Posted May 1, 2012 at 12:08 PM
Stats:
Comments:1 Avg. Rating:0
Views:7030 Contributors:1
Shares:0
Tags: windows, jabber
+

Related Content

Documents Leaderboard