Compartir una conexión de 10mbps

Pregunta respondida
Mayo 13th, 2012

Saludos comunidad

Les planteo  el sigueinte problema que tengo.

Dispongo de una conexión a Internet de 10mbps. Un Router 877 hace la conexión a Internet y está conectado a un switch 3750 por un puerto troncal. El punto es que tengo en el switch 5 vlans (están replicadas en el router) a las que les quiero dar un límite de de 2mbps o en el mejor de los casos garantizar que tengan 2mbps.

He probado varias configuraciones pero no puedo lograr el traffic shapping en el switch. Mi pregunta es si esto que quiero hacer es posible. ¿Se hace en el router o en el switch? y en su caso ¿cuál sería la mejor forma de implementarlo?

Gracias

I have this problem too.
0 votos
Correct Answer by Alex Sanchez Jimenez about hace 3 años 1 semana

Hola Luis,

Espero estés bien.

Básicamente lo que tienes que hacer para conseguir reservar 2MB para cada VLAN es una configuracion de shaping pero en la interface del router que va hacia Internet, vas a necesitar un "nested" policy para usar "Class-based Weigthed Fair Queueing" (CBFWQ) con Access Control Lists (ACL), en la cual defines el bandwidth de cada VLAN.

La razón por la que se hace en el router y no en el switch es porque el punto de congestión esta en la conexión hacia Internet no en el enlace troncal entre los mismos que sería de por lo menos de 100MB/s

Un ejemplo de la configuración seria la siguiente:

*****

ip access-list extended VLAN1
permit ip 192.168.1.0 0.0.0.255 any
ip access-list extended VLAN2
permit ip 192.168.1.0 0.0.0.255 any
ip access-list extended VLAN3
permit ip 192.168.1.0 0.0.0.255 any
ip access-list extended VLAN4
permit ip 192.168.1.0 0.0.0.255 any
ip access-list extended VLAN5
permit ip 192.168.1.0 0.0.0.255 any
!
class-map match-any VLAN1
match access-group name VLAN1
class-map match-any VLAN2
match access-group name VLAN2
class-map match-any VLAN3
match access-group name VLAN3
class-map match-any VLAN4
match access-group name VLAN4
class-map match-any VLAN5
match access-group name VLAN5
!
policy-map CBWFQ
class VLAN1
  bandwidth 2000
class VLAN2
  bandwidth 2000
class VLAN3
  bandwidth 2000
class VLAN4
  bandwidth 2000
class VLAN5
  bandwidth 2000
!
policy-map SHAPING
class class-default
  shaping average 10000000
  service-policy CBWFQ
!
interface FastEthernet0/0

description TO INTERNET
service-policy output SHAPING

*****

Esta configuración te permitirá reservar 2MB para cada VLAN y en caso de que alguna VLAN no este usando los 2MB en total las demás clases podrán utilizar ese ancho de banda disponible.

Puede consultar la siguiente documentación para mas información:

Class-Based Shaping:

http://www.cisco.com/en/US/docs/ios/12_1t/12_1t2/feature/guide/clsbsshp.html

Configuring Class-Based Shaping:

http://www.cisco.com/en/US/docs/ios/12_2/qos/configuration/guide/qcfcbshp.html

Si tienes algun problema con los links puedes buscarlos por el nombre.

Saludos,

Alex Sanchez

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (1 ratings)
Correct Answer
Alex Sanchez Jimenez Lun, 05/14/2012 - 06:28

Hola Luis,

Espero estés bien.

Básicamente lo que tienes que hacer para conseguir reservar 2MB para cada VLAN es una configuracion de shaping pero en la interface del router que va hacia Internet, vas a necesitar un "nested" policy para usar "Class-based Weigthed Fair Queueing" (CBFWQ) con Access Control Lists (ACL), en la cual defines el bandwidth de cada VLAN.

La razón por la que se hace en el router y no en el switch es porque el punto de congestión esta en la conexión hacia Internet no en el enlace troncal entre los mismos que sería de por lo menos de 100MB/s

Un ejemplo de la configuración seria la siguiente:

*****

ip access-list extended VLAN1
permit ip 192.168.1.0 0.0.0.255 any
ip access-list extended VLAN2
permit ip 192.168.1.0 0.0.0.255 any
ip access-list extended VLAN3
permit ip 192.168.1.0 0.0.0.255 any
ip access-list extended VLAN4
permit ip 192.168.1.0 0.0.0.255 any
ip access-list extended VLAN5
permit ip 192.168.1.0 0.0.0.255 any
!
class-map match-any VLAN1
match access-group name VLAN1
class-map match-any VLAN2
match access-group name VLAN2
class-map match-any VLAN3
match access-group name VLAN3
class-map match-any VLAN4
match access-group name VLAN4
class-map match-any VLAN5
match access-group name VLAN5
!
policy-map CBWFQ
class VLAN1
  bandwidth 2000
class VLAN2
  bandwidth 2000
class VLAN3
  bandwidth 2000
class VLAN4
  bandwidth 2000
class VLAN5
  bandwidth 2000
!
policy-map SHAPING
class class-default
  shaping average 10000000
  service-policy CBWFQ
!
interface FastEthernet0/0

description TO INTERNET
service-policy output SHAPING

*****

Esta configuración te permitirá reservar 2MB para cada VLAN y en caso de que alguna VLAN no este usando los 2MB en total las demás clases podrán utilizar ese ancho de banda disponible.

Puede consultar la siguiente documentación para mas información:

Class-Based Shaping:

http://www.cisco.com/en/US/docs/ios/12_1t/12_1t2/feature/guide/clsbsshp.html

Configuring Class-Based Shaping:

http://www.cisco.com/en/US/docs/ios/12_2/qos/configuration/guide/qcfcbshp.html

Si tienes algun problema con los links puedes buscarlos por el nombre.

Saludos,

Alex Sanchez

caniculari Lun, 05/14/2012 - 07:31

Muchas gracias Alex


Efectivamente funcionó tu propuesta y al parecer no andaba tan perdido pero me faltaban unos detalles. La documentación también le veo cosas muy útiles. Posteo mi configuración final ya que termine de hacer las pruebas por si a aguien más le sirve

Saludos

Alex Sanchez Jimenez Lun, 05/14/2012 - 08:12

Luis,

Muchas gracias por tu respuesta, me alegra escuchar que la información te fue de gran ayuda.

Y gracias por proveer la configuración para futuras referencias de otros clientes.

Saludos,

Alex Sanchez

lizanyiro Mar, 05/29/2012 - 12:28

Hola Alex.

Saludos, en vista que pudiste ayudar a Luis, acudo a ti porque se me esta presentando un problema  con una politica configurada en mi router principal, que esta provocando congestion, te explico tengo un router 7200 y en una interfaz Wan de 2048 MB, tengo varias conexiones a varias Agencias remotas con FR con distinto BW, y tengo la siguiente politica

class-map match-all P-oracle

match access-group 101

class-map match-all telnet

match access-group 104

policy-map Agencia

class P-oracle

bandwidth percent 60

class telnet

bandwidth percent 5

class class-default

fair-queue

access-list 101 permit tcp any any eq 1521

access-list 101 permit tcp any eq 1521 any

access-list 101 permit tcp any any eq 1526

access-list 101 permit tcp any eq 1526 any

access-list 101 deny   tcp host 10.3.1.212 any

access-list 101 deny   tcp any host 10.3.1.212

access-list 101 deny   tcp host 10.3.8.193 any

access-list 101 deny   tcp any host 10.3.8.193

access-list 101 deny   udp host 10.3.1.212 any

access-list 101 deny   udp any host 10.3.1.212

access-list 101 deny   udp host 10.3.8.193 any

access-list 101 deny   udp any host 10.3.8.193

access-list 101 deny   ip host 10.3.1.212 any

access-list 101 deny   ip any host 10.3.1.212

access-list 101 deny   ip host 10.3.8.193 any

access-list 101 deny   ip any host 10.3.8.193

Aplicada en la interfaz fisica de ese router

interface Serial1/0

description Agencias Region Oriente enlace CANTV

bandwidth 2048

no ip address

ip nbar protocol-discovery

encapsulation frame-relay

ip route-cache flow

timeslot 1-31

crc4

serial restart-delay 0

cdp enable

frame-relay lmi-type ansi

service-policy output Agencia

end

!

interface Serial1/0.53 point-to-point // Una de la Agencia

description Conexion a Agencia Lecherias

ip address 10.30.53.1 255.255.255.0

ip nbar protocol-discovery

ip summary-address eigrp 100 0.0.0.0 0.0.0.0 250

no ip mroute-cache

snmp trap link-status

frame-relay interface-dlci 106  

  crypto map Agencia-053-IPSec

end

con esta politica aplicada del lado remoto  Agencia lecheria pero asi es para todas las otras agencias :

class-map match-all voip

match ip precedence 5

match access-group 102

class-map match-all telnet

match access-group 104

class-map match-all oracle

match access-group 108

class-map match-all signaling

match access-group 103

!

policy-map Agencia

class oracle

  priority percent 60

class class-default

  fair-queue

  random-detect

access-list 108 permit ip host 10.3.1.41 any

access-list 108 permit ip host 10.3.1.42 any

access-list 108 permit ip host 10.3.1.43 any

access-list 108 permit ip any host 10.3.1.41

access-list 108 permit ip any host 10.3.1.42

access-list 108 permit ip any host 10.3.1.43

access-list 108 permit tcp any any eq 1521

access-list 108 permit tcp any eq 1521 any

access-list 108 permit tcp any any eq 1526

access-list 108 permit tcp any eq 1526 any

access-list 108 deny   tcp host 10.3.1.212 any eq www

access-list 108 deny   tcp any host 10.3.1.212 eq www

access-list 108 deny   tcp host 10.3.8.193 any

access-list 108 deny   tcp any host 10.3.8.193

access-list 108 deny   udp host 10.3.1.212 any eq 80

access-list 108 deny   udp any host 10.3.1.212 eq 80

access-list 108 deny   udp host 10.3.8.193 any

access-list 108 deny   udp any host 10.3.8.193

access-list 108 deny   ip host 10.3.1.212 any

access-list 108 deny   ip any host 10.3.1.212

access-list 108 deny   ip host 10.3.8.193 any

access-list 108 deny   ip any host 10.3.8.193

El problema es que hay momento donde hay congestion y tiempo de respuesta de lentos, y mas cuando esta el antivirus activo.

por fa ayudaaaa!!

Acciones

Inicio de sesión or Register to take actions

This Discussion

Posted Mayo 13, 2012 at 11:08 AM
Stats:
Respuestas4 Overall Rating:
Visualizaciones840 Votes:0
Compartido0
Etiquetas 877, 3750, bandwith
+

Related Content