Cisco 1941 /K9 y L2TPv3

Sin Contestar
Feb 26th, 2016
User Badges:

Hola quisera hacer una consulta, a ver si me pueden ayudar


Estoy haciendo una prueba de laboratorio para una implementación que debemos hacer. Debemos pasar tráfico L2 desde un punto a otro a través de una red IP (IP-MPLS), y para ello queremos implementar un tunel L2TPv3. El diagrama del laboratorio es el siguiente:


Diagrama de laboratotio

Probe el tunel con los comandos:


show l2tunn session

show l2tunn session all

show xconnect all

El tunel está establecido completamente, pero el tráfico no pasa a extremo a extremo. Verifiqué en la puerta de entrada del Router y el tráfico llega, lo que no detecto es tráfico en la VLAN 1000, y tampoco al tunel, sólo llegan los paquetes de señalización.

El equipamiento y caracteristicas son los siguientes

Router 1: Cisco 1941 /K9 con una tarjeta HWIC-4ESW (switch de 4 puertas L2), IPbase

Router 2: Cisco 1941 /K9 con una tarjeta HWIC-4ESW (switch de 4 puertas L2), IPbase

Switch MOXA PR-7728, este se interconecta al generador de tráfico L2 y a la tarjeta HWIC del router

Switch MOXA PR-7728, este se interconecta al generador de tráfico L2 y a la tarjeta HWIC del router

Programación del router 1:

hostname R1!

boot-start-marker
boot-end-marker
!

no aaa new-model
!
no ipv6 cef
ip source-route
ip cef
!        
l2tp-class CONECTA-CLASS
 hello 10
 password conectaclass
 cookie size 8
!
multilink bundle-name authenticated
!
crypto pki token default removal timeout 0
!
license udi pid CISCO1941/K9 sn FCZ160690RC
license boot module c1900 technology-package datak9
!
vtp mode transparent
!
redundancy
!        
vlan 500,1000
!
pseudowire-class CONECTA
 encapsulation l2tpv3
 interworking ethernet
 protocol l2tpv3 CONECTA-CLASS
 ip local interface Loopback666
 ip dfbit set
!
bridge irb
!
interface Loopback666
 description LOOPBACK R1
 ip address 1.1.1.1 255.255.255.255
!         
interface Embedded-Service-Engine0/0
 no ip address
 shutdown
!
interface GigabitEthernet0/0
 description TELCO1
 ip address 30.0.4.1 255.255.255.0
 duplex full
 speed 1000
!
interface GigabitEthernet0/1
 description TELCO2
 ip address 10.0.4.1 255.255.255.0
 duplex full
 speed 1000
! AQUI ME CONECTO DESDE EL SWITCH MOXA
interface GigabitEthernet0/0/0
 switchport trunk allowed vlan 1,2,1000,1002-1005
 switchport mode trunk
 no ip address
 duplex full
 speed 100
!
interface GigabitEthernet0/0/1
 switchport access vlan 1000
 no ip address
 duplex full
 speed 100
!
interface GigabitEthernet0/0/2
 no ip address
 duplex full
 speed 100
!
interface GigabitEthernet0/0/3
 switchport mode trunk
 no ip address
 duplex full
 speed 100
!
interface Vlan1
 no ip address
!
interface Vlan500
 description PMU
 no ip address
! AQUI ESTABLEZCO EL TUNNEL L2TPv3
interface Vlan1000
 description LAN
 no ip address
 xconnect 2.2.2.2 1 encapsulation l2tpv3 pw-class CONECTA
!
router ospf 333
 network 20.0.1.0 0.0.0.255 area 0
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip route 2.2.2.2 255.255.255.255 30.0.4.2
!
control-plane
!       
line con 0
line aux 0
line 2
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
 stopbits 1
line vty 0 4
 login
 transport input all
!
monitor session 1 source interface Gi0/0/0
monitor session 1 destination interface Gi0/0/2
scheduler allocate 20000 1000
end


Programación del router 2:

hostname R2
!
boot-start-marker
boot-end-marker
!
no aaa new-model
!
no ipv6 cef
ip source-route
ip cef
!
multilink bundle-name authenticated
!
crypto pki token default removal timeout 0
!
license udi pid CISCO1941/K9 sn FCZ1632C6LT
license boot module c1900 technology-package securityk9
license boot module c1900 technology-package datak9
!
vtp domain CONECTA
vtp mode transparent


no ipv6 cef
ip source-route
ip cef
!        
l2tp-class CONECTA-CLASS
 hello 10
 password conectaclass
 cookie size 8
!
multilink bundle-name authenticated
!
crypto pki token default removal timeout 0
!
license udi pid CISCO1941/K9 sn FCZ160690RC
license boot module c1900 technology-package datak9
!
vtp mode transparent
!
redundancy
!        
vlan 500,1000
!
pseudowire-class CONECTA
 encapsulation l2tpv3
 interworking ethernet
 protocol l2tpv3 CONECTA-CLASS
 ip local interface Loopback666
 ip dfbit set
!
bridge irb
!
interface Loopback666
 description LOOPBACK R1
 ip address 1.1.1.1 255.255.255.255
!         
interface Embedded-Service-Engine0/0
 no ip address
 shutdown
!
interface GigabitEthernet0/0
 description TELCO1
 ip address 30.0.4.2 255.255.255.0
 duplex full
 speed 1000
!
interface GigabitEthernet0/1
 description TELCO2
 ip address 10.0.4.2 255.255.255.0
 duplex full
 speed 1000
! AQUI ME CONECTO DESDE EL SWITCH MOXA
interface GigabitEthernet0/0/0
 switchport trunk allowed vlan 1,2,1000,1002-1005
 switchport mode trunk
 no ip address
 duplex full
 speed 100
!
interface GigabitEthernet0/0/1
 switchport access vlan 1000
 no ip address
 duplex full
 speed 100
!
interface GigabitEthernet0/0/2
 no ip address
 duplex full
 speed 100
!
interface GigabitEthernet0/0/3
 switchport mode trunk
 no ip address
 duplex full
 speed 100
!
interface Vlan1
 no ip address
!
interface Vlan500
 description PMU
 no ip address
! AQUI ESTABLEZCO EL TUNNEL L2TPv3
interface Vlan1000
 description LAN
 no ip address
 xconnect 1.1.1.1 1 encapsulation l2tpv3 pw-class CONECTA
!
router ospf 333
 network 20.0.1.0 0.0.0.255 area 0
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip route 1.1.1.1 255.255.255.255 30.0.4.1
!
control-plane
!
 
line con 0
line aux 0
line 2
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
 stopbits 1
line vty 0 4
 login
 transport input all
!
monitor session 1 source interface Gi0/0/0
monitor session 1 destination interface Gi0/0/2
scheduler allocate 20000 1000
end

Alguna idea?

Gracias

Loading.

Acciones

Este Discusión