×

Mensaje de advertencia

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.
Alejandro Canel... Lun, 10/10/2016 - 10:42
User Badges:
  • Community Spotlight Award,

    Spanish Rookie, December 2016

Hola Jhoni

Existen varios mecanismo de transición, el primero y más sencillo de implementar es Dual-Stack, con este protocolo en todas las interfaces se corre IPV4 como IPv6 al mismo tiempo sin necesidad de utilizar túneles, un ejemplo sería el siguiente:

R1(config)# interface G0/1

R1(config-if)# ip address 192.168.10.254 255.255.255.0

R1(config-if)#ipv6 address 2222:cafe:ded0:c0c4::/64

Después siguen los protocolos de tuneling ya sean manuales o automáticos por ejemplo dentro de los túneles manuales tenemos a GRE e IPv6IP. Como sabrás GRE tiene la capacidad de soportar muchos protocolos incluidos IPv4 e IPV6 además de que puede correr sobre túneles IPSEC en cambio IPv6IP solo puede pasar direcciones IPv6.

Algo importante de destacar es que GRE corre sobre el protocolo IP 47 e IPv6IP sobre el protocolo IP 41, estos no son protocolos TCP ni UDP, se debe tener en cuenta por si se utilizan ACL´s en la red tratar de no bloquear estos puertos ya que no funcionarían si se bloquean. Un ejemplo de GRE es el siguiente:

Configuración IPv4 - IPv6 utilizando túnel GRE

R1(config)# interface tunel 0

R1(config-if)# ipv6 enable

R1(config-if)#ipv6 address 2035::5/64

R1(config-if)# tunnel source 192.168.10.1

R1(config-if)# tunnel destination 192.168.10.254

++++++++++++++++++++++++++++++++++++++++++

R3(config)# interface tunnel 0

R3(config-if)#ipv6 enable

R3(config-if)#ipv6 address 2025::3/64

R3(config-if)#tunnel source 192.168.1.254

R3(config-if)#tunnel destination 192.168.10.1

Después utilizamos algún IGP para correrlo en este caso utilizare OSPFv3


R1(config)#ipv6 router ospf 1

R1(config-rtr)# inter tunnel 0

R1(cofig-if)# ipv6 ospf 1 area 0

R1(config-if)#interface g0/0

R1(config-if)#ipv6 ospf area 0

++++++++++++++++++++++++++++++++++++

R3(config)#ipv6 router ospf 1

R3(config-rtr)# inter tunnel 0

R3(cofig-if)# ipv6 ospf 1 area 0

R3(config-if)#interface g0/1

R3(config-if)#ipv6 ospf area 0


Para utilizar IPv6IP repites los mismo pasos que acabamos de utilizar, la diferencia esta en que por default todos los túneles son GRE, y que además podemos pasar cualquier tipo de tráfico a diferencia de IPv6IP que solo nos permitirá pasar tráfico IPv6.


Para habilitar IPV6IP utilizamos el siguiente comando:

R1(config)# tunnel mode IPV6IP


Dentro de los túneles automáticos, nos encontramos con 6to4 que corre en el protocolo IP41, TEREDO e ISATAP, estos dos últimos es algo difícil de levantarlos, por lo que me enfocare en la configuración de 6to4.


6to4 configuración


Antes de comenzar la configuración de 6to4 debes saber algunas cosas para su implementación:

  • Siempre utiliza la dirección 2002
  • Tiene la ventaja sobre GRE e IPv6IP de que puede levantar túneles automáticamente, pero se deben de cumplir la siguientes reglas:
  • La dirección IPv6 es diagonal 48 y se deriva de una dirección IPv4
  • 192.168.3.0 = C0A8:0300
  • 2002: C0A8:0300::/48
  • Se puede subnetear a un /64 o a lo que se desee 
  • Otra ventaja es que puede levantar túneles dinamicamente desde una fuente hacía varios destinos al mismo tiempo

R1(config)#interface g0/1

R1(config-if)# ipv6 address 2002:C0A8:0500::5/64

R1(config)#interface g0/0

R1(config-if)# ipv6 address 2002:C0A8:0300::3/64

R1(config)#interface tunnel 1

R1(config-if)#ipv6 enable

R1(config-if)#ipv6 address 2002:C0A8:0300:0001::3/64

R1(config-if)#tunnel source 192.168.34.3

R1(config-if)#tunnel mode ipv6ip 6to4

R1(config-if)#ipv6 route 2002::/16 tunnel 1 <Se tiene que aplicar una ruta estática>

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

R3(config)#interface g0/0

R3(config-if)# ipv6 address 2002:C0A8:0500::6/64

R3(config)#interface g0/1

R3(config-if)# ipv6 address 2002:C0A8:0300::4/64

R3(config)#interface tunnel 1

R3(config-if)#ipv6 enable

R3(config-if)#ipv6 address 2002:C0A8:0300:0001::4/64

R3(config-if)#tunnel source 192.168.34.4

R3(config-if)#tunnel mode ipv6ip 6to4

R3(config-if)#ipv6 route 2002::/16 tunnel 1 <Se tiene que aplicar una ruta estática>

Por ultimo tenemos los protocolos de translation, y aquí se encuentra NAT-PT (NAT-PROTOCOL TRANSLATION), este mapea los encabezados de IPv6 a direcciones IPv4

Y  la configuración es la siguiente:

Este ejemplo utiliza esta configuración de la red:

http://www.cisco.com/c/dam/en/us/support/docs/ip/network-address-translation-nat/113275-nat-ptv6-01.gif

Configuraciones

Configuración del r1
hostname R1
ipv6 unicast-routing
!
interface Serial0/0
 ip address 192.168.30.10 255.255.255.0
 duplex auto
 speed auto
 ipv6 nat
!
interface Serial0/1
 no ip address
 duplex auto
 speed auto
 ipv6 address 2001:DB8:3002::9/64
 ipv6 enable
!
ipv6 route ::/0 2001:DB8:3002::10
ipv6 nat v4v6 source 192.168.30.9 2000::960B:202

!--- Translates the ipv4 add of R2 fa0/0 to ipv6 address.
          
ipv6 nat v6v4 source 3001:11:0:1::1 150.11.3.1

!--- Translates the ipv6 add of loop0 of R3 to ipv4 address.
              
ipv6 nat prefix 2000::/96

!--- The destination prefixes that matches 2000::/96 
!--- are translated by NAT-PT.
                            
!
end


Configuración del r2
hostname R2
!
interface Serial0/0
 ip address 192.168.30.9 255.255.255.0
 duplex auto
 speed auto
!
ip route 0.0.0.0 0.0.0.0 192.168.30.10
!

!
end


Configuración R3
hostname R3
ipv6 unicast-routing
!
interface Loopback0
 no ip address
 ipv6 address 3001:11:0:1::1/64
!
interface Serial0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address 2001:DB8:3002::10/64
!
ipv6 route ::/0 2001:DB8:3002::9
!


Como conclusión dentro de las ventajas encontramos que IPv6 le puede ahorrar dinero a aquellos negocios que hacen de IPv6 una prioridad. Esto conducirá a la necesidad de migración a IPv6 y eventualmente creará oleadas de adopción del nuevo protocolo con convincentes ganancias financieras y beneficios tanto para gobiernos como para proveedores de servicios. Con el paso del tiempo, las direcciones obsoletas IPv4 serán muy pocas, por lo que será más costoso conseguirlas con los ISP. Contrariamente, las direcciones IPv6 serán menos costosas dada su abundancia. A los usuarios en hogares y pequeños negocios eventualmente les serán asignadas direcciones IPv6 exclusivamente debido a la escasez de direcciones IPv4.

Espero te sirva y más usuarios puedan enriquecer este tema.

Saludos!!


Acciones

Este Discusión