入力インターフェース(トランク)単位の出力帯域制御

Unanswered Question
May 23rd, 2011

Cisco3925Eにて、2個の物理インターフェースを使用し、片方はトサブインターフェース(L3)×n、

もう一方はメイン(L3)インターフェースである場合、サブインターフェース->物理の方向に向けて、

最低帯域保証を行う手段、他、可能な機種等は無いでしょうか?

サブインターフェースから入ってくるトラフィックのアドレス特定は困難だとお考え下さい

(access-listでのmatchは事実上無理)

旧機種、旧OSでしか試せませんでしたが、match input-interfaceはサブインターフェースには

対応していなさそうな為に苦慮しております。


WICでvlan(svi)対応できたとしても、環境が無く、match分が書けるかが試せない状況です。

・Cisco3925Eではmatch input-interface でサブインターフェースが指定できる。

・Cisco3925Eで他の手段で実施可能

・WIC-4ESW等を使用すれば可能

・ASR1001等であれば可能

等の情報お持ちの方いればご教授頂けると助かります。

実現したい事は

ユーザ毎の複数vlanをルータ1台で集約し、その先の外部ネットワークに出力する際には

ユーザ毎に最低帯域保証を行いたいと言ったイメージです。(本当は入力も保証できると

嬉しいのですが・・)

物理1本   _____

ユーザA---|         |  最低低域保証

ユーザB---|ルータ|---->ユーザA(1Mbps)/ユーザB(1Mbps)/ユーザC(0.5Mbps)

ユーザC---|_____|

(dot1q)

よろしくお願い致します。

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
t-yamashita Mon, 05/23/2011 - 21:04

こんにちは。

サブインターフェースで、service-policy input が対応していたと思うので、dscp 等でマーキングし、それを対象に優先制御する方法はどうでしょうか?

Cisco3825 でよければ検証も可能です。必要であれば、気軽におっしゃってください。

ちょっと時間かかるかもですが。。

j.takahashi Tue, 05/24/2011 - 00:36

ご返信ありがとうございます。

一部簡素化の為に構成を省略してい為、誤解を招いてしまったかもしれません。

大変申し訳有りません。

正確にはOutput方向のインターフェースはもう一つ存在します。

ただし、もう一つのOutputインターフェースに対しては帯域保証を必要としない(もしくは

保証する帯域が異なる)為に、inputインターフェースでの帯域制御だけでは実現したい

事ができない状況です。

最初にお伝えした情報で誤解を招くような事を掲載してしまい大変申し訳有りませんでした。

物理1本        物理2本

        _____

ユーザA---|         |  最低低域保証

ユーザB---|ルータ|---->ユーザA(1Mbps)/ユーザB(1Mbps)/ユーザC(0.5Mbps)

ユーザC---|_____|---->ユーザA(0.5Mbps)/ユーザB(2Mbps)

(dot1q)        帯域保証不要もしくは個別、シェーピング等

お考えの設定が上記条件を満たせるものであると大変助かりますので、是非ご確認

頂けると助かります。

もし、当初の構成から「サブインターフェース毎にpolicyをinput方向で適用する」と言った

事であれば、もしかすると上記構成では実現が難しいかもしれません。大変ご迷惑を

おかけして申し訳有りません。

t-yamashita Wed, 05/25/2011 - 18:34

検証してみましたが、問題なく動作しそうです。
(ご検討されている内容と違ってたらすみません。)

◆検証環境

pervlan_qos.bmp

結果がわかりやすいので、LLQ/CBWFQ ではなく、shaping で試験しました。

◆試験方法

以下のトラフィックフローを作成・印加し、受信 Rate を確認する。

※Framesize:512byte

※送信 rate: 100Mbps

・試験1: 192.168.10.0/24(vlan10) → 10.1.1.0
・試験2: 192.168.10.0/24(vlan10) → 10.1.2.0

・試験3: 192.168.20.0/24(vlan20) → 10.1.1.0

・試験4: 192.168.20.0/24(vlan20) → 10.1.2.0

◆試験結果

・試験1: 1240pps≒5Mbps

・試験2: 744pps≒3Mbps

・試験3: 248pps≒1Mbps

・試験4: 23496pps≒100Mbps

◆設定例(抜粋)

class-map match-all Marked_UserB
  match  dscp cs5
class-map match-all Marked_UserA
  match  dscp cs2
class-map match-all UserA
  match any
class-map match-all UserB
  match any
!
policy-map Shape_for_Users2
  class Marked_UserA
   shape average 3000000
policy-map Marking_for_UserB
  class UserB
   set dscp cs5
policy-map Marking_for_UserA
  class UserA
   set dscp cs2
policy-map Shape_for_Users
  class Marked_UserA
   shape average 5000000
  class Marked_UserB
   shape average 1000000

!

interface GigabitEthernet0/0.10
encapsulation dot1Q 10
ip address 192.168.10.254 255.255.255.0
service-policy input Marking_for_UserA
!
interface GigabitEthernet0/0.20
encapsulation dot1Q 20
ip address 192.168.20.254 255.255.255.0
service-policy input Marking_for_UserB
!
interface GigabitEthernet0/1
ip address 10.1.1.254 255.255.255.0
service-policy output Shape_for_Users
!

ご参考になれば幸いです。

j.takahashi Wed, 05/25/2011 - 21:39

実機検証まで行って頂き、ありがとうございました。

大変恐縮です。

カラーリングして分別する方法についてですが

・VoIP等で既にカラーリングする必要のあるトラフィックが存在する

・サブインターフェースが例では3本程度ですが、実際には20以上となる

以上からカラーリングによる識別は現実的には難しそうな気がしております。

上記についても要件を正確にお伝えできておらず、大変申し訳ございません。

他の識別方法等があれば、再度お教え頂けますと幸いです。

(やはりinput-interfaceのサブインターフェース指定自体は「不可」に変わりは

無いと考えてよろしいでしょうか?)

Cisco3925EにWIC-4ESW等を搭載しSVIを作成した上でinput-interfaceにsviが

指定できれば解決できそうなのですが、sviもサブインターフェース同様に指定不可

か否かが調べ切れていない状況です。

こちらについても何か情報お持ちでしたらご支援頂けると助かります。

本当に申し訳ございません。

sunsong Thu, 05/26/2011 - 19:56

DSCPでも64個までは分類できるのでYamashita様からの案でも行けるような気がしますが、

User毎に2つ以上の分類が必要であれば、Router内部でのみ有効なqos-groupという分類を

使用してみるのは如何でしょうか?

それぞれのUserの一部のTrafficにPriorityまで必要となると設定が複雑にはなりますが、

その他のTrafficに既にDSCPやIP Precedenceが付いてくるのが前提であれば下記のような

設定でできるのではないかと思います。

① Voice traffic をmatchさせる

class-map VOICE

match dscp ef(例です。)

② InboundにてVOICEとその他のTrafficにそれぞれqos-groupを割り当てる

policy-map Inbound_marking_1

class VOICE

  set qos-group 101

class class-default

  set qos-group 102

policy-map Inbound_marking_2

class VOICE

  set qos-group  103

class class-default

  set qos-group 104

③ 割り当てられたqos-groupの為のClass-mapを作成する

class-map QOS101

match qos-group 101

class-map QOS102

match qos-group 102

④ 2つ以上のqos-groupにPolicyを適用する為のClass-mapを作成する

class-map USER1 match-any

match qos-group 101

match qos-group 102

class-map QOS103

match qos-group 103

class-map  QOS104

match qos-group 104

class-map USER2 match-any

match qos-group 103

match qos-group 104

⑤それぞれのUserの為のPolicy-mapを作成する

policy-map USER1_shaping

class QOS101

  priority 10000

class QOS102

  bandwidth 1000000

policy-map USER2_shaping

class QOS103

  priority  10000

class QOS104

  bandwidth 1000000

⑥ Physical interfaceに入れる最上位のPolicy-mapを作成する

policy-map outbound_shaping

class USER1

  service-policy USER1_shaping

class USER2

  service-policy USER2_shaping

※qos-groupは0~1023まで使用可能です。

実際に試してないので100%可能とは言い切れませんが、1つの案として参考にして頂ければと思います。

j.takahashi Thu, 05/26/2011 - 21:27

ご連絡ありがとうございます。

お教え頂いたqos-gruopであれば、分類すべきトラフィックが増えてもある程度

柔軟に対応できそうです。

旧機種でもqos-groupは対応できそうなので、環境あれば確認してみたいと

思います。

ご提案ありがとうございました。

t-yamashita Fri, 05/27/2011 - 14:27

to: sunsong 様

qos-group は、良い手ですね。勉強になりました。ありがとうございます。


to: takahashi 様

Switch ポートを持つ 1812J で、config が入るかどうかだけ確認してみました。

下記のとおり、macth input-interface vlan コマンドが入りました。

これだけでは、確実とはいえませんが、正常に動作しそうな気がします。

来月で良ければ試験してみます。3845 + hwic-4sw になりますが。

ご希望であれば気軽におっしゃってください。


Router#sh policy-map interface fastEthernet 0
FastEthernet0

  Service-policy output: policy

    Class-map: class (match-all)
      0 packets, 0 bytes
      5 minute offered rate 0 bps
      Match: input-interface Vlan1
      Match: input-interface Vlan2
      Match: input-interface Vlan3
      Match: input-interface Vlan4
      Match: input-interface Vlan5
      Match: input-interface Vlan6
      Match: input-interface Vlan7
      Match: input-interface Vlan8

    Class-map: class-default (match-any)
      5 packets, 300 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: any

尚、Hwic-4esw がサポートする最大 vlan は 15 個になりますのでご注意ください。
http://www.pluscom.ru/cisco_product/cc/td/doc/product/software/ios123/123newft/123t/123t_8/esw_cfg.htm

EHWIC(+ 3925)であれば 48 個までサポートされているので、こちらが良いかと思います。
http://www.cisco.com/en/US/prod/collateral/modules/ps5949/qa_c67-612908.html

j.takahashi Sun, 05/29/2011 - 17:05

ご連絡ありがとうございます。

input-interface vlan xx が使用できればqosで支障無い限りはシンプルに実現できそうです。

もしt-yamashita様のお時間、環境にご都合付くようであればお試し頂けると大変助かります。

いろいろとご迷惑をおかけして申し訳有りません。

Actions

Login or Register to take actions

This Discussion

Posted May 23, 2011 at 8:26 PM
Stats:
Replies:8 Avg. Rating:
Views:2687 Votes:0
Shares:0
Tags: qos
+

Discussions Leaderboard

Rank Username Points
1 215
2 24
3 20
4 15
5 10
Rank Username Points
5