BRI回線で特定のIPのみNAT変換する

Unanswered Question
May 24th, 2012

ルータの設定方法について教えてください。

(会社の他チームからのちょっとした話のみで機器の型番、IOSのverが不明で申し訳ないですが)


通常ルート

 お客-ルータB-サーバ


今回設定したいルート

 お客-ルータA-サーバ


設定条件

 ・サーバのIPアドレス変えない

 ・BRI回線の番号は変わる


そのため、NATを行おうと思いますが

ルータAには他のBRIの設定が50ほど入っている状態で

今回設定したいルートのみNATをかけたい

既存設定のダイヤル設定に影響なくする方法をお教えください。


      サーバ

    /   |  ←Ether回線

ルータA  ルータB

   \      | ←BRI回線 

      お客

ip nat inside source static

を使った基本的なNATの設定のみで実現可能でしょうか。

?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
t-yamashita Thu, 05/24/2012 - 22:22

こんにちは。

お客というのは、お客様が使用されているルータという意味でしょうか?

もう少し具体的に経緯・要件を書いて頂けますと、レスがつきやすいと存じます。

「BRI 回線で特定の IP のみ NAT 変換する」事は可能です。以下、一例です。

Router#sh run | b ip nat

ip nat inside source list 100 interface Dialer5 overload

access-list 100 permit ip host 1.1.1.1 host 2.2.2.2

dialer-list 5 protocol ip permit

Router#sh run int di5

Building configuration...

Current configuration : 240 bytes

!

interface Dialer5

ip address negotiated

ip nat outside

encapsulation ppp

dialer pool 5

dialer string 0123456789

dialer caller 0123456789

dialer-group 5

ppp authentication chap callin

ppp chap hostname hostname

ppp chap password 0 password

end

送信元が 1.1.1.1 、送信先が 2.2.2.2 の通信において、送信元アドレスをインターフェース Dialer5 の IP アドレスに変換します。

ご参考になれば幸いです。

Esemadoushi98 Thu, 05/24/2012 - 23:22

同じような形になってしまいましたが担当者と内容を確認しました。

サーバA IP 1.1.1.1
 |            |
 | Ether回線   |
R1         R2
IP 4.4.4.4     IP:3.3.3.3
 |           /
 | BRI回線  /
 |       /
 |     /
お客様 IP:2.2.2.2

通常ルート
 サーバA ←→ R2 ←→ お客様
 
新規ルート
 サーバA ←→ R1 ←→ お客様
 R1でNAT変換したい(IP:4.4.4.4)
 
お客様の設定は
 R1宛ての設定
 R2宛ての設定
がされている。

サーバAの設定は
 R1宛ての設定
 R2宛ての設定
がされている。

要件

 IP4.4.4.4宛ての通信はR1を通るように設定をしたい
 R1のでは他のBRIの設定もあるため、1回線の通信のみNATの設定を入れたい
 それ以外はNATをかけないで通信する。
 BRI回線ポートは1つ

R1の設定方法についてアドバイスをいただけませんでしょうか。

t-yamashita Fri, 05/25/2012 - 00:04

インライン失礼します。

>お客様の設定は

>R1宛ての設定

>R2宛ての設定

>がされている。

>サーバAの設定は

>R1宛ての設定

>R2宛ての設定

>がされている。

こちらですが、以下の認識であってますでしょうか?

■お客様の設定について

サーバーA: 1.1.1.1 への通信において、R1/R2 のそれぞれを経由するルートがある。

■サーバーA の設定について

お客様ネットワーク: 2.2.2.2 への通信において、R1/R2 のそれぞれを経由するルートがある。

また、要件についてですが、4.4.4.4 宛ての通信は R1 を通るようにとはどういう意味でしょう?

(4.4.4.4 は、R1 のアドレスのように見えます。)

どこからどこへの通信を、どのように実現したいのかご教示頂けますと幸いです。

例)サーバーA:1.1.1.1 から、お客様 NW:2.2.2.2 への通信について、R1 を経由したい。

その他の通信については、R2 を経由したい。R1 で NATし、お客様ルータからは、サーバーA の NW は見えないようにしたいが、当該通信以外は、NAT の対象外としたい。 etc..

どうぞよろしくお願いします。

Esemadoushi98 Fri, 05/25/2012 - 01:13

分かりにく説明で申し訳ありません。

一部間違えていました。

・お客様からの通信の宛先のIPはサーバAのIP

・BIRの電話先でR1、R2が分かれている。

・サーバAからのパケットの返信を電話番号の受け元のよってR1,R2に返す。

 基本的にはお客様のIPはひとつのみのため、R1でNATの設定を入れ、

 サーバAの返信先をR1,R2に振り分けたい。

 (サーバAのhostの設定は組み込み済み)

・R1では他にもBRI回線の設定があり、それらはNATをしないようにしたい。

最終形として

・R1でサーバAからのパケットをR1からお客様にパケットをかえしたい。

となります。

t-yamashita Sun, 05/27/2012 - 21:13

返信が遅くなりすみません。

>サーバAからのパケットの返信を電話番号の受け元のよってR1,R2に返す。

サーバー側で「トラフィックに応じて G/W を切り替える」事が可能」という前提で考えると、

最初に投稿させて頂きましたとおり、NAT 対象を ACL で指定すればよいかと存じます。

ご参考になれば幸いです。

Esemadoushi98 Wed, 05/30/2012 - 21:00

再度の質問で申し明けありません。

要件がちょっと違ったみたいです。

通信ができていない状態です。

サーバA IP 1.1.1.1

      新IP:6.6.6.6
 |            |
 | Ether回線   |
R1         R2
 |           /
 | BRI回線  /
 |       /
 |     /
お客様 IP:2.2.2.2

通常ルート
 サーバA ←→ R2 ←→ お客様
 通信先

 1.1.1.1   ←→    2.2.2.2 


新規ルート
 サーバA ←→ R1 ←→ お客様

 通信先

 6.6.6.6   ←→     2.2.2.2 

R1コンフィグ(抜粋)

///////////////ここから////////////

username JJJ password 0 JJJ ←新規ルートで使用のユーザ名

username SSS password 0 SSS

username AAA password 0 AAA

interface BRI0

ip unnumberd FastEtherenet0

ip nat inside ← nat inside設定

encapsulation ppp

dialer map ip 10.10.10.10 name SSS 000000

dialer map ip 2.2.2.2 name JJJ 000000 ←お客様ダイヤル時の設定

 ・・・・・

dailer-group 1

isdn weitch-tipe ntt

isdn point-to-pointo-setup

no fair-queue

no cdp enable

ppp authentication chap pap callin

ppp multilink

・・・・

interfave FastEthernet0

ip address XX.XX.XX.XX 255.255.255.0

ip nat outside ← nat outside設定

speed 100

full-duplex

no cdp enable

ip classless

ip route XXXX XXXXXX

ip route 6.6.6.0 255.255.255.0 6.6.6.6     ←サーバ、ルータ間のルート設定

ip route 6.6.6.6 255.255.255.255.255 BRI0  ←〃

・・・

・・・・・nat設定・・・・・

ip nat pool pool1 6.6.6.7 6.6.6.7 netmask 255.255.255.0

ip nat insde sourece list 110 pool pool1

ip nat outside sourece list 111 intaerface BRI0

・・・・・・・・・・・・・・・・

・・・

access-list 101 permit ip host XXX.XXX host XXX.XXX

access-list 101 permit ip host XXX.XXX host XXX.XXX

・・・

access-list 110 permit ip host 2.2.2.2 host 6.6.6.6 ←nat用アクセスリスト

access-list 111 permit ip host 6.6.6.6 host 2.2.2.2 ←〃

・・・

daialer-list 1 protocol ip list 101

///////////ここまで//////////////////

追加すべきコマンドなどありますでしょうか

(間違いもあるかと思いますが・・・)

申し訳ないのですが手を貸していただけませんか。

t-yamashita Mon, 06/04/2012 - 21:08

返事が遅くなりすみません。

R1 の LAN 側ですが、6.6.6.0 のセグメントを持っていますでしょうか。

持っていない場合は、セカンダリ等で設定してみてはどうでしょうか。

また、上記設定後、ip route 6.6.6.0 , 6.6.6.6 は削除してみてください。

ご確認よろしくお願い致します。

Actions

Login or Register to take actions

This Discussion

Posted May 24, 2012 at 9:45 PM
Stats:
Replies:7 Avg. Rating:
Views:1625 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard

Rank Username Points
1 215
2 24
3 20
4 15
5 10
Rank Username Points
5