
 

Americas Headquarters
Cisco Systems, Inc.
170 West Tasman Drive
San Jose, CA 95134-1706
USA
http://www.cisco.com
Tel: 408 526-4000

800 553-NETS (6387)
Fax: 408 527-0883

Cisco Unified CCX Administration 
Guide, Release 8.5(1) 
Cisco Unified Contact Center Express and Cisco Unified IP IVR

December 2011

http://www.cisco.com


 

THE SPECIFICATIONS AND INFORMATION REGARDING THE PRODUCTS IN THIS MANUAL ARE SUBJECT TO CHANGE WITHOUT 
NOTICE. ALL STATEMENTS, INFORMATION, AND RECOMMENDATIONS IN THIS MANUAL ARE BELIEVED TO BE ACCURATE BUT 
ARE PRESENTED WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED. USERS MUST TAKE FULL RESPONSIBILITY FOR 
THEIR APPLICATION OF ANY PRODUCTS.

THE SOFTWARE LICENSE AND LIMITED WARRANTY FOR THE ACCOMPANYING PRODUCT ARE SET FORTH IN THE INFORMATION 
PACKET THAT SHIPPED WITH THE PRODUCT AND ARE INCORPORATED HEREIN BY THIS REFERENCE. IF YOU ARE UNABLE TO 
LOCATE THE SOFTWARE LICENSE OR LIMITED WARRANTY, CONTACT YOUR CISCO REPRESENTATIVE FOR A COPY.

The Cisco implementation of TCP header compression is an adaptation of a program developed by the University of California, Berkeley (UCB) as 
part of UCB’s public domain version of the UNIX operating system. All rights reserved. Copyright © 1981, Regents of the University of California.

NOTWITHSTANDING ANY OTHER WARRANTY HEREIN, ALL DOCUMENT FILES AND SOFTWARE OF THESE SUPPLIERS ARE 
PROVIDED “AS IS” WITH ALL FAULTS. CISCO AND THE ABOVE-NAMED SUPPLIERS DISCLAIM ALL WARRANTIES, EXPRESSED OR 
IMPLIED, INCLUDING, WITHOUT LIMITATION, THOSE OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND 
NONINFRINGEMENT OR ARISING FROM A COURSE OF DEALING, USAGE, OR TRADE PRACTICE.

IN NO EVENT SHALL CISCO OR ITS SUPPLIERS BE LIABLE FOR ANY INDIRECT, SPECIAL, CONSEQUENTIAL, OR INCIDENTAL 
DAMAGES, INCLUDING, WITHOUT LIMITATION, LOST PROFITS OR LOSS OR DAMAGE TO DATA ARISING OUT OF THE USE OR 
INABILITY TO USE THIS MANUAL, EVEN IF CISCO OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH 
DAMAGES.

Cisco and the Cisco Logo are trademarks of Cisco Systems, Inc. and/or its affiliates in the U.S. and other countries.  A listing of Cisco's trademarks 
can be found at www.cisco.com/web/siteassets/legal/trademark.html.  Third party trademarks mentioned are the property of their respective owners. 
The use of the word partner does not imply a partnership relationship between Cisco and any other company. (1005R)

Cisco Unified CCX Administration Guide, Release 8.5(1)
Copyright © 2011 Cisco Systems, Inc. All rights reserved.

http://www.cisco.com/web/siteassets/legal/trademark.html


 

C O N T E N T S
Preface   i

Audience   1-ii

Organization   1-ii

Glossary   1-v

Conventions   1-vi

Obtaining Documentation and Submitting a Service Request   1-vii

P A R T  1 Unified CCX: Overview

C H A P T E R  1 Introducing Unified CCX   1-1

About the Unified CCX Components   1-1

The Unified CCX Product Family   1-4
Unified  IP IVR    1-4
Unified Contact Center Express   1-5

About Unified CCX Cluster Architecture   1-6
About Unified CCX Active Server   1-7

About Unified CCX Engine    1-8

Setting Up Unified CCX   1-10

Provisioning Telephony and Media Subsystems   1-11

Provisioning Unified CCX Subsystems   1-12

Provisioning the Unified CCX Subsystem   1-12

Provisioning Additional Unified CCX Subsystems   1-13

Viewing License Information   1-14
i
Cisco Unified CCX Administration Guide, Release 8.5(1)



Contents
Uploading Licenses   1-15

Deleting Licenses   1-16

Configuring Unified CCX Applications   1-17

Available Applications   1-17

Managing Scripts, Prompts, Grammars, and Documents   1-18

Configuring Unified CCX Historical Reporting   1-18

Running and Managing Unified CCX   1-19

Where To Go From Here?   1-19

C H A P T E R  2 Introduction to Unified CCX Administration Web Interface   2-1

Accessing Unified CCX Administration Web Interface   2-2

Cisco Unified CCX Administration Menu Bar and Menus   2-3

Navigating the Cisco Unified CCX Administration Application   2-4

Unified CCX Configuration Web Pages   2-6
Displaying Details for Advanced Configuration   2-7
Using Tool Bar and Buttons   2-7
Using Configuration Wizards   2-8

P A R T  2 Unified CCX: Configuration

C H A P T E R  3 Unified CCX Provisioning Checklist   3-1

About Unified CCX   3-2

Unified CCX Provisioning Checklist   3-3

Changing the Licensing Packages   3-5

C H A P T E R  4 Provisioning Unified CM for Unified CCX   4-1

Configuring Unified CM Information   4-2

Modifying Cluster Information from Unified CCX   4-2
ii
Cisco Unified CCX Administration Guide, Release 8.5(1)



Contents
Displaying Unified CM Cluster Nodes in Unified CCX   4-4
Selecting Server for Unified CM Configuration (displayed only in a HA 
over WAN deployment)   4-5

Modifying AXL Information   4-5

Modifying Unified CM Telephony Information   4-8

Modifying RmCm Provider Information   4-10

Configuring Unified CM for Unified CCX   4-12

Invoking Unified CM Administration   4-13

Defining Unified CM Users as Agents   4-13

Guidelines for Configuring Agent Phones   4-14

Assigning Unified CM Users as Cisco TelePresence Virtual Agents   4-16

Assigning Unified CM Users as Unified CCX Agents   4-18

Configuring Tool for Auto-Registered Phones Support (TAPS)   4-22

C H A P T E R  5 Provisioning Unified CCX for Unified CME   5-1

Introducing Unified CME for Unified CCX   5-1
Guidelines   5-2
Supported Features   5-3
Interoperability between Unified CCX and Unified CME   5-4

Verifying Licenses   5-5

Modifying Unified CME Information from Unified CCX   5-5

Configuring the AXL User in Unified CCX   5-6

Provisioning Unified CME Telephony Subsystem   5-7
Validating Unified CME and Unified CCX Data   5-8
Configuring a Unified CME Telephony Provider   5-9
Modifying Unified CME Telephony Call Control Group   5-10

Adding or Modifying a Unified CME Telephony Trigger   5-11

Managing Unified CCX Users   5-14
iii
Cisco Unified CCX Administration Guide, Release 8.5(1)

 



Contents
Assigning Capability Views to Unified CCX Users in a Unified CME 
Deployment   5-15

Creating New Unified CCX Users in a Unified CME Deployment   5-15

Changing Passwords and Pins   5-17

Identifying Agent Directory Numbers   5-18

C H A P T E R  6 Configuring Cisco Applications   6-1

About Unified CCX Applications   6-1
Configuring Script Applications   6-2
Configuring Busy Application    6-7
Configuring Ring-No-Answer Application    6-9
Configuring Unified ICME Post-Routing Application   6-11

Configuring Unified ICME Translation-Routing Application    6-14

Configuring Remote Monitoring Application    6-16

Adding Application Triggers   6-18

Adding a Unified CM/Unified CME Telephony Trigger   6-19

Adding Unified CM/Unified CME Telephony Triggers from an Application 
Web Page   6-20

Adding Unified CM/Unified CME Telephony Triggers from Unified 
CCX   6-21

Adding an HTTP Trigger   6-21

Adding HTTP Triggers from an Application Web Page   6-22

Adding HTTP Triggers from the HTTP Subsystem    6-24

Managing Scripts   6-25

Uploading New Scripts   6-26

Viewing or Downloading a Script File   6-28

Refreshing Scripts   6-30

Individual Script Refresh   6-30

Bulk Script Refresh   6-31

Renaming a Script or Folder   6-32
iv
Cisco Unified CCX Administration Guide, Release 8.5(1)



Contents
Deleting a Script or Folder   6-33

Sample Scripts   6-34

C H A P T E R  7 Provisioning Telephony and Media   7-1

About Unified CCX Telephony and Media   7-1
Media Termination Groups   7-2
Provisioning Channels to Handle Calls   7-3
Telephony and Media Resources Provisioning Checklist   7-4

Provisioning Unified CM Telephony Subsystem   7-5
Resynchronizing Cisco JTAPI Client   7-6
Resynchronizing Unified CM Telephony Data   7-7
Configuring a Unified CM Telephony Provider   7-7
Adding a New Unified CM Telephony Call Control Group   7-9
Adding a Unified CM Telephony Trigger   7-16

Additional Unified CM Telephony Information   7-22

Provisioning Unified CM Telephony Triggers for Unified CCX Queuing   7-22

Resynchronizing Unified CM Telephony Information   7-22

Provisioning Cisco Media Subsystem   7-23

Adding a CMT Dialog Control Group    7-24

Provisioning ASR and TTS in Unified CCX   7-26

Before You Provision ASR/TTS   7-26

Provisioning MRCP ASR Subsystem   7-27

Provisioning MRCP ASR Providers   7-28

Provisioning MRCP ASR Servers   7-29

Provisioning MRCP ASR Dialog Groups    7-31

Provisioning MRCP TTS Subsystem   7-34

Provisioning MRCP TTS Providers    7-35

Provisioning MRCP TTS Servers   7-37

Provisioning MRCP TTS Default Genders   7-39
v
Cisco Unified CCX Administration Guide, Release 8.5(1)

 



Contents
C H A P T E R  8 Provisioning Unified CCX   8-1

Configuring RmCm Provider    8-2
Modifying RmCm Provider   8-2
Associating Agent Extensions with the RmCm Provider   8-3

Configuring Resource Groups   8-4
Creating a Resource Group   8-4
Modifying an Existing Resource Group Name   8-5
Deleting a Resource Group   8-6

Configuring Skills   8-7
Creating a Skill   8-7
Modifying an Existing Skill Name   8-8
Deleting a Skill   8-9

Configuring Agents    8-10

Implications of Deleting Agents in Unified CM   8-11

Assigning Resource Groups and Skills to One Agent   8-12

Assigning Resource Groups and Skills to Multiple Agents   8-14

Removing Skills from Agents   8-16

Configuring Contact Service Queues   8-17

Creating a CSQ   8-18

Modifying an Existing CSQ   8-24

Deleting a CSQ   8-25

Resource Pool Selection Criteria: Skills and Groups   8-26

Resource Skill Selection Criteria Within a CSQ   8-28

Configuring and Using Remote Monitoring   8-30

Creating a Remote Monitoring Supervisor   8-31

Assigning Resources and CSQs to a Supervisor   8-32

Configuring Agent-Based Routing   8-34

Wrap-Up Data Usage   8-35

Configuring Teams   8-35
vi
Cisco Unified CCX Administration Guide, Release 8.5(1)



Contents
Creating a Team Supervisor   8-36

Creating Teams   8-37

Modifying Agents on Teams   8-39

Deleting a Team   8-39

Unified Gateway Auto-Configuration Details   8-40

C H A P T E R  9 Provisioning Additional Subsystems   9-1

About Additional Subsystems   9-2

Provisioning Unified ICME Subsystem   9-3
Configuring General Unified ICME Information   9-4
Configuring Unified ICME VRU Scripts    9-7

Provisioning HTTP Subsystem   9-10

Configuring HTTP Triggers   9-11

Provisioning Database Subsystem    9-12

Configuring Database Subsystem   9-13

Adding a New DataSource   9-14

Polling Database Connectivity   9-15

Provisioning eMail Subsystem   9-16

C H A P T E R  10 Managing Prompts, Grammars, Documents, and Custom Files   10-1

Managing Prompt Files   10-2

Managing Grammar Files   10-5

Managing Document Files   10-7

Managing Languages   10-9
Creating a New Language   10-9
Renaming a Language   10-10

Deleting a Language   10-11

Upload Zip files to a Language Folder   10-11

Recording and Uploading Prompt Files   10-13
vii
Cisco Unified CCX Administration Guide, Release 8.5(1)

 



Contents
Recording a Prompt    10-14

Add Spoken Name Prompts   10-16

Managing Custom Files   10-17

Specify Custom Classpath Entries   10-17

Managing AAR Files   10-18

Creating AAR Files   10-21

Uploading AAR Files   10-21

META-INF Directory   10-22

Prompts, Grammars, Documents, and Scripts Directories   10-22

Prompts Directory   10-23

Grammars Directory   10-23

Documents Directory   10-23

Scripts Directory   10-23

AAR Manifest   10-23

Attribute Types   10-25

Main Attributes   10-26

Per-Entry Attributes   10-28

META-INF Directory Attributes   10-29

C H A P T E R  11 Managing the Unified CCX System   11-1

Basic Terminology   11-2

High Availability and Automatic Failover   11-3
Network Partitions   11-4

Managing Unified CCX CDS Information   11-4

Managing System Parameters    11-5

Changing IP Address of Unified CCX   11-10

Readiness Checklist   11-11

Changing the IP Address   11-13

Changing the IP Address for Server in a Single-Node Deployment   11-13
viii
Cisco Unified CCX Administration Guide, Release 8.5(1)



Contents
Changing the IP Addresses for Servers in a High Availability (HA) 
Deployment   11-16

Post-Change Task List   11-22

Exiting Unified CCX Administration   11-23

C H A P T E R  12 Managing Unified CCX Historical Reporting   12-1

About Unified CCX Historical Datastore   12-1

Historical Reporting Configuration   12-2
Configuring Database Server Limits   12-2
Viewing Historical Reports   12-3

Purging Historical Data   12-3
Configuring Automatic Purging   12-4

Configuring Purge Schedule Configuration Parameters   12-5
Purging Manually   12-6

File Restore   12-7

C H A P T E R  13 Configuring Unified CCX Outbound Dialer   13-1

Unified CCX Outbound IVR Dialer Types   13-1

About the Outbound Feature for Unified CCX   13-3
Outbound Characteristics   13-3
Unified CCX Requirements   13-4
Outbound Components   13-7

Dialing Modes   13-8
Direct Preview Dialing Mode   13-9
Progressive Dialing Mode   13-10

Understanding the Working of an IVR-Based Progressive 
Campaign   13-10

Predictive Dialing Mode   13-12

Predictive Dialing Description   13-12
ix
Cisco Unified CCX Administration Guide, Release 8.5(1)

 



Contents
Steps to Configure an Outbound IVR Subsystem in Unified CCX   13-14

How Is a Contact’s Local Time Determined?   13-15

The Outbound Configuration Checklist   13-16

Verifying the RmCm and Outbound Subsystems   13-17

Configuring General Outbound Properties   13-18

Customer Dialing Lists   13-21

Handling Callbacks   13-27

How the Outbound Option Works with Area Codes   13-28

Handling Configuration Updates   13-29

Allocating CSQ Agent Pool Percentages   13-30

Adding a New Campaign   13-31

Importing Contacts for a Campaign   13-39

Enabling Campaigns   13-41

Adding Area Codes   13-42

Setting-up Communications with the Agent’s Desktop   13-43

Agents Receive Outbound Calls   13-44

Agent Allocation and Queuing   13-45

Previewing Customer Information   13-46

Exchanging Data with CAD   13-48

Call Status Values   13-50

Resetting Contact States at Midnight   13-51

Call Result Values   13-52

Reclassification Status Behavior   13-54

Handling Skip-Next Behavior   13-56

Handling Skip/Reject Behavior   13-57

Call Retrieval Priority   13-58

Handling Failover and System Restarts   13-58

Handling Do Not Call Contacts   13-59
x
Cisco Unified CCX Administration Guide, Release 8.5(1)



Contents
C H A P T E R  14 Reporting on Real-Time Unified CCX Data   14-1

Available Unified CCX Real-Time Reports   14-2

Opening Real-Time Reporting   14-3

Running Reports   14-5

Viewing Detailed Subreports   14-5

Printing Reports   14-6

Resetting Report Statistics   14-6

Clearing Stuck Calls   14-7

Setting Report Options   14-7

Setting Report Appearance   14-8

Application Reporting User Interface   14-8
Report Menu   14-9

Contacts Summary Real-Time Report   14-11

Application Tasks Summary Real-Time Report   14-13

Application Tasks    14-13

Engine Tasks    14-14

Contacts   14-14

Applications   14-19

Sessions    14-20

Datasource Usage    14-20

Overall Cisco Unified Contact Center Express Stats   14-21

CSQ Cisco Unified Contact Center Express Stats    14-25

Preview Outbound Campaign Cisco Unified Contact Center Express 
Stats   14-27

IVR Outbound Campaign Stats   14-29

Overall IVR Outbound Stats   14-31

Resource Cisco Unified Contact Center Express Stats    14-32

Failover Behavior for Unified CCX Stats   14-34

Tools Menu   14-35
xi
Cisco Unified CCX Administration Guide, Release 8.5(1)

 



Contents
The Reset All Statistics Menu Option   14-35

Open Printable Report Menu Option   14-36

Refresh Connections Menu Option   14-36

Clear Contact Menu Option   14-36

Views Menu   14-37

Application Tasks   14-39

Contacts   14-39

Applications   14-39

Sessions   14-40

Settings Menu    14-40

Options Menu Option   14-41

C H A P T E R  15 Using Unified CCX Supervisor and Unified CCX User Options Plug-Ins   15-1

About User Management   15-1

About Unified CCX User Capabilities   15-2
Administrator Privileges   15-3
Supervisor Privileges   15-3
Historical Report User Privileges   15-5
Agent Privileges   15-5

Using Unified CCX Supervisor Web Interface   15-6
Accessing the Unified CCX Supervisor Web Page   15-6
Monitoring Agents   15-7
Monitoring CSQs   15-7
Viewing CSQ IDs for Remote Monitoring   15-8
Installing Client-Side Historical Reporting   15-9

Using the Unified CCX User Options Web Interface   15-9
Accessing the Unified CCX User Options Web page   15-9
Downloading Agent Desktop   15-10

Cisco Unified CCX Desktop Client Configuration Tool   15-11

Adding Alternative Pronunciations    15-12
xii
Cisco Unified CCX Administration Guide, Release 8.5(1)



Contents
Accessing Unified CM User Options page   15-13

P A R T  3 Unified CCX: Reference

C H A P T E R  16 System Menu   16-1

Server Menu Option   16-1

Unified CM Configuration Menu Option   16-3

Unified CME Configuration Menu Option   16-4

System Parameters Menu Option   16-4

Custom File Configuration Menu Option   16-5

License Information Menu Option   16-5
Add License(s)   16-6
Display Licenses   16-6

Language Information Menu Option   16-7

Logout Menu Option   16-8

C H A P T E R  17 Applications Menu   17-1

Application Management Menu Option   17-1

Script Management   17-3

Prompt Management   17-4

Grammar Management   17-5

Document Management   17-6

AAR Management   17-6

C H A P T E R  18 Subsystems Menu   18-1

Unified CM Telephony Menu Option   18-2
Unified CM Telephony Provider Configuration   18-3
Unified CM Telephony Call Control Group Configuration   18-4
xiii
Cisco Unified CCX Administration Guide, Release 8.5(1)

 



Contents
Unified CM Telephony Triggers Configuration   18-4
Unified CM Telephony Data Synchronization   18-5
Unified CM Telephony Cisco JTAPI Resync   18-6
Unified CM Telephony Advanced Settings   18-7

Unified CME Telephony Menu Option   18-8
Unified CME Telephony Provider Configuration   18-8
Unified CME Telephony Call Control Group Configuration   18-9
Unified CME Telephony Triggers Configuration   18-9
Validate Unified CME in Unified CCX Data   18-10

RmCm Menu Option   18-10

Skill Configuration   18-11

Adding a New Skill   18-11

Modifying Skills   18-12

Resources Configuration   18-12

Modifying a Resource   18-12

Resource Group Configuration   18-13

Adding a New Resource Group   18-13

Modifying Existing Resource Groups   18-13

Contact Service Queues Configuration   18-14

Adding a CSQ   18-14

RmCm Provider Configuration   18-15

Assign Skills Configuration   18-15

Adding Skills   18-16

Removing Skills   18-16

Remote Monitor Configuration   18-16

Assigning Resources and CSQs to a Remote Supervisor   18-17

Agent Based Routing Settings Configuration   18-17

Teams Configuration   18-17

Adding a New Team    18-18

Outbound Menu Option   18-18
xiv
Cisco Unified CCX Administration Guide, Release 8.5(1)



Contents
General Configuration   18-19

Campaign Configuration   18-19

Add New Campaigns   18-20

Import Contacts   18-20

Delete Contacts   18-21

Area Code Management   18-21

Add New Area Code   18-22

SIP Gateway Configuration   18-22

Unified ICM Menu Option   18-25

Unified ICME Configuration   18-25

Unified ICME VRU Scripts    18-26

Add a New VRU Script   18-27

Database Menu Option   18-27

DataSource   18-28

Adding a New DataSource    18-28

Adding a New Database Parameter   18-29

Driver   18-29

Adding a New Database Driver   18-29

HTTP Menu Option   18-30

HTTP Configuration   18-31

Add a New HTTP Trigger    18-31

eMail Menu Option   18-31

Cisco Media Menu Option   18-32

MRCP ASR Menu Option   18-33

MRCP ASR Provider   18-33

MRCP ASR Servers    18-33

MRCP ASR Dialog Groups   18-34

MRCP TTS Menu Option    18-35

MRCP TTS Providers   18-35
xv
Cisco Unified CCX Administration Guide, Release 8.5(1)

 



Contents
MRCP TTS Servers   18-36

MRCP TTS Default Genders   18-36

C H A P T E R  19 Wizards Menu   19-1

Application Wizard   19-1

RmCm Wizard   19-3

C H A P T E R  20 Tools Menu   20-1

Plug-ins Menu Option   20-2

Real-Time Reporting Menu Option   20-3

Real-Time Snapshot Config Menu Option   20-4
Creating a System DSN for Wallboard   20-5
Using Wallboard Software in a High Availability (HA) Deployment   20-8

Historical Reporting Menu Option   20-10

Database Server Configuration   20-10

Purge Schedule Configuration    20-11

Purge Now   20-11

File Restore    20-12

User Management Menu Option   20-12

User View Submenu Option   20-13

Name Grammar Generator Configuration   20-14

Spoken Name Upload Submenu Option   20-15

Administrator Capability View Menu Option   20-16

Supervisor Capability View Menu Option   20-16

Reporting Capability View Menu Option   20-16

Agent Capability View Menu Option   20-17

Password Management   20-17

Windows Upgrade Menu Option   20-18
xvi
Cisco Unified CCX Administration Guide, Release 8.5(1)



Contents
C H A P T E R  21 Help Menu   21-1

Contents and Index Option   21-2

For This Page Menu Option   21-3

Troubleshooting Tips Menu Option   21-3

Unified CCX Documentation Link Option   21-3

About Menu Option   21-3

A P P E N D I X  A Unified CCX Licensing Packages   A-1

Application Availability by License Package   A-2

Trigger Availability by License Package   A-2

Subsystem Availability by License Package   A-2

Historical Report Availability by License Package   A-4

Unified CCX Services Availability by License Package   A-4

Unified CCX Component Availability by License Package   A-6

Support Scalability for Unified CME   A-6

I N D E X
xvii
Cisco Unified CCX Administration Guide, Release 8.5(1)

 



Contents
xviii
Cisco Unified CCX Administration Guide, Release 8.5(1)



Preface

Cisco Unified Contact Center Express (Unified CCX), a member of the Cisco 
Unified Communications family of products, manages customer voice contact 
centers for departments, branches, or small to medium-size companies planning 
to deploy an entry-level or mid-market contact center solution. 

The Cisco Unified CCX Administration Guide provides instructions for using the 
Administration web interface to provision the subsystems of the Unified CCX 
package and to configure Unified CCX applications. 

This guide shows you how to implement the following two systems that integrate 
with the Unified CCX: 

 • Cisco Unified Contact Center Express (Unified CCX)

 • Cisco Unified Interactive Voice Response (Unified IP IVR)

This guide also includes a reference section that describes all the menus and menu 
options of the Unified CCX Administration web interface.

This guide will help you to:

 • Perform initial configuration tasks.

 • Administer applications such as the Unified CCX Engine, and other 
components of the Cisco Unified Communication family of products.

 • Familiarize yourself with the menus and menu options of the Unified 
CCX Administration web interface.
i
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Preface
Audience
Audience
The Cisco Unified CCX Administration Guide is written for business analysts and 
application designers who have the domain-specific knowledge required to create 
multimedia and telephony customer response applications. Experience or training 
with Java is not required but is useful for making best use of the capabilities of 
the Cisco Unified Communications family of products.

Organization
This guide is divided into three parts. 

 • Part 1, “Unified CCX: Overview”, provides an overview of the Unified CCX 
components and Administration web interface. 

 • Part 2, “Unified CCX: Configuration,” describes the tasks necessary for 
configuring Unified CCX. 

 • Part 3, “Unified CCX: Reference,” describes the menu options of the 
available real-time reports.

Part 1 contains the following chapters:

Chapter Number and Title Description

Chapter 1, “Introducing 
Unified CCX”

Describes key features of the Unified CCX system. 
Provides an overview of the configuration tasks 
necessary to configure and administer the Unified 
CCX.

Chapter 2, “Introduction 
to Unified CCX 
Administration Web 
Interface”

Provides an overview of the Unified 
CCX Administration web interface.
ii
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Organization
Part 2 contains the following chapters:

Chapter Number and Title Description

Chapter 3, “Unified CCX 
Provisioning Checklist”

Introduces the Unified CCX subsystem and 
provides a configuration checklist for the available 
products.

Chapter 4, “Provisioning 
Unified CM for Unified 
CCX”

Explains how to modify the Unified CM Unified 
CM information from Unified CCX.

Chapter 5, “Provisioning 
Unified CCX for Unified 
CME”

Explains how to modify the Unified CME 
information from Unified CCX.

Chapter 6, “Configuring 
Cisco Applications”

Describes how to configure Cisco Busy 
applications, Cisco Ring-No-Answer applications, 
Unified ICME post-routing applications, Unified 
ICME translation-routing applications, and how to 
manage script files.

Chapter 7, “Provisioning 
Telephony and Media”

Introduces the Unified CCX telephony and media 
subsystems and describes how to provision the 
Unified CM telephony, CMT (Cisco Media 
Termination), MRCP ASR (Automated Speech 
Recognition), and MRCP TTS (Text-To-Speech) 
subsystems.

Chapter 8, “Provisioning 
Unified CCX”

Describes how to provision Unified CM and the 
Unified CCX subsystem.

Chapter 9, “Provisioning 
Additional Subsystems”

Describes how to provision the Cisco Unified 
Intelligent Contact Management Enterprise 
(Unified ICME), HTTP, Database, and eMail 
subsystems.

Chapter 10, “Managing 
Prompts, Grammars, 
Documents, and Custom 
Files”

Describes how to manage prompt, grammar, and 
document files.

Chapter 11, “Managing 
the Unified CCX System”

Describes how to configure, control, and monitor 
Unified CCX component activities and information 
in a Unified CCX Cluster.
iii
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Organization
Part 3 contains the following chapters:

 

Chapter 12, “Managing 
Unified CCX Historical 
Reporting”

Describes how to configure the database server, 
schedule data synchronization, configure historical 
report users, and set up automatic and manual 
purging of the Unified CCX historical reports 
databases.

Chapter 13, “Configuring 
Unified CCX Outbound 
Dialer”

Describes how to configure the Unified Outbound 
Dialer feature for automated outbound activities for 
the Unified CM deployment of Unified CCX.

Chapter 14, “Reporting on 
Real-Time Unified CCX 
Data”

Describes how to run real-time reports on Unified 
CCX data. Provides directions for launching 
sub-reports, printing reports, refreshing reports, 
and setting report options.

Chapter 15, “Using 
Unified CCX Supervisor 
and Unified CCX User 
Options Plug-Ins”

Provides detailed information on the additional 
plug-in options provided by Unified CCX.

Chapter Number and Title Description

Chapter Number and Title Description

Chapter 16, “System 
Menu”

Describes the options under the System menu of the 
Unified CCX Administration menu bar.

Chapter 17, “Applications 
Menu”

Describes the options under the Applications menu 
of the Unified CCX Administration menu bar.

Chapter 18, “Subsystems 
Menu”

Describes the options under the Subsystems menu 
of the Unified CCX Administration menu bar.

Chapter 19, “Wizards 
Menu”

Describes the options under the Wizards menu of 
the Unified CCX Administration menu bar.

Chapter 20, “Tools 
Menu”

Describes the options under the Tools menu of the 
Unified CCX Administration menu bar.
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Glossary
Glossary
For a complete list of terms used in Cisco Unified CCX and Cisco Unified IP IVR, 
see 
http://www.cisco.com/en/US/products/sw/custcosw/ps1846/prod_technical_refer
ence_list.html.

Chapter 21, “Help Menu” Describes the options under the Help menu of the 
Unified CCX Administration menu bar.

Appendix A, “Unified 
CCX Licensing Packages”

Describes the features that are available with each 
Unified CCX license package.

Chapter Number and Title Description
v
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Conventions
This manual uses the following conventions:

Convention Description

boldface font Boldface font is used to indicate commands, such as user 
entries, keys, buttons, and folder and submenu names. For 
example:

 • Choose Edit > Find.

 • Click Finish.

italic font  Italic font is used to indicate the following:

 • To introduce a new term. Example: A skill group is a 
collection of agents who share similar skills.

 • For emphasis. Example: 
Do not use the numerical naming convention.

 • A syntax value that the user must replace. Example: 
IF (condition, true-value, false-value)

 • A book title. Example: 
See the Installation Guide for Cisco Unified CCX and 
Cisco Unified IP IVR, Release 8.5(1).

window font Window font, such as Courier, is used for the following:

 • Text as it appears in code or that the window displays. 
Example:
<html><title>Cisco Systems,Inc. 
</title></html>

< > Angle brackets are used to indicate the following:

 • For arguments where the context does not allow italic, 
such as ASCII output. 

 • A character string that the user enters but that does not 
appear on the window such as a password.
vi
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Related Documentation
Related Unified CCX documentation is available at the URL mentioned below:

http://www.cisco.com/en/US/products/sw/custcosw/ps1846/tsd_products_support_s
eries_home.html

Obtaining Documentation and Submitting a Service 
Request

For information on obtaining documentation, submitting a service request, and 
gathering additional information, see the monthly What’s New in Cisco Product 
Documentation, which also lists all new and revised Cisco technical 
documentation, at:

http://www.cisco.com/en/US/docs/general/whatsnew/whatsnew.html

Subscribe to the What’s New in Cisco Product Documentation as a Really Simple 
Syndication (RSS) feed and set content to be delivered directly to your desktop using 
a reader application. The RSS feeds are a free service and Cisco currently supports 
RSS version 2.0. 
vii
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Cisco Unified CCX 
 

C H A P T E R 1

Introducing Unified CCX

The Unified CCX provides a multimedia (voice, data, and web) IP enabled 
customer-care application environment that enhances the efficiency of contact 
centers by simplifying business integration, easing agent administration, 
increasing agent flexibility, and enhancing network hosting.

The following sections provide an overview of the configuration and management 
components of the Unified CCX product family:

 • About the Unified CCX Components, page 1-1

 • The Unified CCX Product Family, page 1-4

 • About Unified CCX Cluster Architecture, page 1-6

 • Setting Up Unified CCX, page 1-10

 • Running and Managing Unified CCX, page 1-19

 • Where To Go From Here?, page 1-19

About the Unified CCX Components
This section describes the following components of the Unified CCX system:

 • Unified Gateway—Connects the Cisco Unified Communications family of 
products to the Public Switched Telephone Network (PSTN) and to other 
private telephone systems such as PBX.
1-1
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About the Unified CCX Components
 • Unified CM Server—The Cisco Unified Communications Manager (Unified 
CM) provides the features required to implement IP phones, manage 
gateways, provide failover and redundancy service for the telephony system, 
and direct Voice over IP (VoIP) traffic to the Unified CCX system.

Note Cisco Unified Communications Manager was previously known as 
Unified Call Manager. This guide uses Cisco Unified 
Communications Manager at the first occurrence and Unified CM for 
later occurrences.

 • Unified CME interoperability—The Cisco Unified Communications 
Manager Express (Unified CME) provides interoperability between Unified 
CCX and Unified CME, call routing using SIP-based route point, keep alive 
session management, Support of Cisco Agent Desktop for use with Unified 
CME, and the ability to store the users locally in the Unified CCX database.

Note Cisco Unified Communications Manager Express was previously 
known as Unified CallManager Express. This guide uses Cisco 
Unified Communications Manager Express at the first occurrence and 
Unified CME for later occurrences.

 • Unified CCX Server—Contains the Unified CCX Engine that runs 
applications, including Cisco script applications, Unified CM user 
integration, Unified CME interoperability, Cisco Unified Intelligent Contact 
Management Enterprise (Unified ICME) translation-routing and post-routing 
applications, Busy applications, Ring No Answer applications, and Voice 
Extensible Markup Language (VXML) 2.0 applications. 
You can position your Unified CCX application server anywhere on the IP 
network and administer your applications from a web browser on any 
computer on the IP network. Because Unified CCX uses an open architecture 
that supports industry standards, you can integrate your applications with a 
wide variety of technologies and products such as Enterprise databases and 
Unified CCX Agent Desktop. The Unified CCX Server has the following 
components:

 – Unified CCX Configuration Datastore (CDS)—Manages configuration, 
component, and application information within the Unified CCX cluster 
and communicates with Unified CM. See the Cisco Unified Contact 
Center Express Serviceability Administration Guide.
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About the Unified CCX Components
 – Historical Reports Database Server—Dedicated server that stores 
Unified CCX database for the following datastores: Configuration 
Datastore (CDS), Historical Datastore (HDS), Repository Datastore 
(RDS), and Agent Datastore (ADS).

Note If you are using Microsoft Internet Explorer Version 6.0 or higher or 
Mozilla Firefox Version 2.0 or 3.0 browser, verify that the popup 
blocker is disabled.

 • Unified CCX Editor—Allows application developers to use a simple 
Graphical User Interface (GUI) to create, modify, and debug Unified CCX 
scripts for automating customer interactions. Each script consists of a series 
of steps, implemented as Java Beans.

 • Unified CCX Administration and Unified CCX Serviceability web 
interfaces—Provides access through a web browser for administrators to 
configure and manage Unified CCX Datastores, Servers, and Applications.

 • Cisco IP Agent and Supervisor Desktops—Desktop programs that allow 
Unified CCX agents and supervisors to log into the system, change agent 
states, and monitor status.

 • Media Resource Control Protocol (MRCP) Automatic Speech Recognition 
(ASR) server—(optional.) Dedicated server that performs real-time speech 
recognition.

 • MRCP Text-to-Speech (TTS) server—(optional.) Dedicated server that 
converts text into speech and plays it back to the caller.

Note Support for High Availability and remote servers is available only in 
multiple-server deployments.

 • Historical Reporting Client—The Unified CCX and Unified IP IVR 
applications can generate a variety of historical reports that provide detailed 
Call ContactCall Detail record (CCDR) records, application performance, 
and traffic analysis information.
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The Unified CCX Product Family
The Unified CCX product family provides contact-processing functions for your 
Cisco Unified Communications solution. 

The software package you choose determines which steps, components, and 
subsystems you receive. Each Unified CCX product includes Unified 
CCX Engine and Unified CCX Editor.

The Unified CCX product family includes the following packages:

 • Unified  IP IVR, page 1-4

 • Unified Contact Center Express, page 1-5

Unified  IP IVR 
The Unified IP IVR is a multimedia (voice, data, web) IP enabled interactive 
voice response solution that offers an open and feature-rich foundation for the 
creation and delivery of Unified IP IVR applications via Internet technology. 

Unified IP IVR automates call handling by autonomously interacting with 
contacts. Using Unified IP IVR, you can create applications that answer calls, 
provide menu choices for callers, obtain caller data such as passwords or account 
identification, and transfer calls to caller-selected extensions. You can also create 
Unified IP IVR applications that respond to HTTP requests, outbound calling, 
sending e-mail, and processing VXML 2.0 commands.

The Unified IP IVR package provides the following features:

 • JDBC support—Unified IP IVR applications can access Oracle, Sybase, and 
IBM DB2 databases.

 • Real-Time reporting client—Unified IP IVR applications can generate a 
variety of reports that provide detailed information about the real-time status 
of your system.

 • Historical reporting client—Unified IP IVR applications can generate a 
variety of historical reports that provide detailed information about the 
performance of your system.

 • ASR—Unified IP IVR applications can take advantage of ASR to provide 
callers with the option to use speech to navigate through menu options.

 • TTS—Unified IP IVR applications can use TTS to read back documents and 
pre-scripted prompts to callers.
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Unified Contact Center Express
Cisco Unified Contact Center Express (Unified CCX) is an IP-based Automated 
Call Distribution (ACD) system that queues and distributes incoming calls to 
Unified CCX agents, who can be either groups of Unified CM users for Unified 
CM integration or Unified CCX users for Unified CME integration.

You can use Unified CCX applications to route calls to specific agents. You can 
also integrate Unified CCX with Unified IP IVR to gather caller data and classify 
incoming calls.

Unified CCX includes a web-based real-time and historical reporting system that 
you can use to monitor system, Contact Service Queue (CSQ), and resource 
performance.

The Unified CCX system consists of the following major components:

 • Resource Manager—Application program that monitors Unified CCX agent 
phones and allows you to organize agents into resource groups or skills-based 
partitions according to the types of calls each group can handle.

 • CSQ—Application program that places incoming calls in a queue and 
distributes them to the appropriate set of agents as the agents become 
available.

 • Unified CCX Agent Desktop—Application program that Unified CCX agents 
run on their desktop computers to log in to the system, change Unified CCX 
state, and monitor status.

The following licensing options are available for the Unified CCX system:

 • Unified CCX Standard (designed for entry-level users)—Includes the steps 
necessary for creating basic Unified CCX applications including IP Phone 
Agent (IPPA) and skills-based routing and does not include Cisco Agent 
Desktop (CAD). 

 • Unified CCX Enhanced (designed for enterprise-level users)—Includes all 
functions of Unified CCX Standard, plus support for priority queuing. 
Includes a license to enable custom Java extensions.

 • Unified CCX Premium—Adds full Unified IP IVR support (except for 
Unified ICM integration) including database integration, Voice eXtensible 
Markup Language (VoiceXML), HTML web integration, custom Java 
extensions, and e-Notification services. The outbound feature is now bundled 
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About Unified CCX Cluster Architecture
with the Premium package. You will receive one outbound seat free with each 
premium seat. The maximum number of outbound seats supported will be 
based on the hardware type.

 • Unified CCX Outbound IVR—You need to have an Unified CCX Outbound 
IVR license on top of Unified CCX premium license to enable this feature. 
You can increase the number of ports for an existing Outbound IVR license. 
The Display License sub menu option displays the licensed Outbound IVR 
ports and the sum of the dedicated Outbound IVR ports for all IVR campaigns 
that are running currently in your Unified CCX. The dedicated Outbound IVR 
port for a campaign is the number of IVR ports that you want to reserve for a 
campaign based on the number of CTI ports available in the outbound call 
control group. 

Note The Unified CCX Enhanced package and the Unified CCX Premium package are 
provisioned in the same way.

About Unified CCX Cluster Architecture

Note Support for High Availability and remote servers is available only in 
multiple-server deployments.

The Unified CCX cluster consists of one or more servers (nodes) that are running 
Unified CCX components in your Unified CCX deployment.

If you deploy Unified CCX components on a single server, the Unified CCX 
cluster (often referred to as cluster in this manual) consists of that server. If you 
deploy Unified CCX on multiple servers, the cluster includes the Unified CCX 
server and standby server on which you installed Unified CCX. The Unified CCX 
cluster can support up to two Unified CCX Servers, one designated as the active 
Unified CCX Server and the other designated as the standby Unified CCX Server 
for high availability purposes.

When you install or upgrade Unified CCX on a server, you designate the cluster 
to which the server will belong by designating the cluster profile for that cluster.
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Cluster architecture accommodates high availability and failover since, in case of 
the failure of a component, a secondary server will take over the functionality lost 
by that failed component.

All Unified CCX servers within the cluster are configured identically and 
installed with the same features. One server is designated the active server.

About Unified CCX Active Server

Note Support for High Availability and remote servers is available only in 
multiple-server deployments.

The Unified CCX active server makes global decisions for the cluster and keeps 
track of calls in the CSQs, agent states (if Unified CCX is installed) and 
generating historical detail records. 

Note Only one server in the cluster can be the active server at any given time.

If the active server fails, the Unified CCX provides automatic failover to the 
standby server. If the active server fails (for example, in the event a hardware 
failure occurs or the Unified CCX Engine process terminates), some calls being 
handled by the server are lost. The lost calls are restricted to those being handled 
by the system (those in the IVR stage or in queue). Calls answered by agents 
continue to remain live even though related data on the agent desktop is lost. 
When the standby server takes over as the new active server, call processing 
continues (see High Availability and Automatic Failover, page 11-3).

A Unified CCX cluster consists of the one or more servers (nodes) that run 
Unified CCX components in your Unified CCX deployment (see Basic 
Terminology, page 11-2). 

Cluster management consists of two main elements:

 • Cluster Manager—Receives updates about cluster status and subsystem 
states.
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 • Cluster View Daemon (CVD)—Java code that interacts with Platform 
Service Manager and implements inter-node communication on behalf of the 
cluster. It detects availability of the other nodes, components and services, 
provides consistent cluster view and dynamically elects a master service. The 
following figure shows the components of the CVD interaction with nodes.

Figure 1-1 Cluster View Daemon

The CVD has two interfaces:

 • One that monitors inside the node, using:

 – Node Manager to monitor and control local processes.

 – Cluster Manager publisher or subscriber to communicate with local 
applications, such as Engine and Application Administration.

 • Another that monitors outside the node and communicates with other nodes 
in the cluster.

Note For detailed information about Unified CCX clusters, see Chapter 11, “Managing 
the Unified CCX System.”

About Unified CCX Engine 
The Unified CCX Engine enables you to run multiple applications to handle 
Unified CM Telephony calls, Unified CME Telephone calls, or HTTP requests. 
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About Unified CCX Engine
The Unified CCX Engine uses the Unified CM Telephony subsystem to request 
and receive services from the Computer Telephony Interface (CTI) manager that 
controls Unified CM clusters. The Unified CCX Engine is implemented as a 
service that supports multiple applications.

The Unified CCX Engine uses the Unified CME Subsystem to interact with the 
Unified CME application that run on Integrated Service Routers (ISRs) using 
open standard Session Initiation Protocol (SIP).

You can use a web browser to administer the Unified CCX Engine and your 
Unified CCX applications from any computer on the network. Unified CCX 
provides you the following two web applications:

 • Unified CCX Administration web interface - Used to configure system 
parameters, subsystems, view real-time reports that include total system 
activity and application statistics and so on.

 • Unified CCX Serviceability web interface - Used to view alarm and trace 
definitions for Unified CCX services, start and stop the Unified CCX Engine, 
monitor Unified CCX Engine activity, and so on.

Note If you are using Microsoft Internet Explorer Version 6.0 or higher or 
Mozilla Firefox Version 2.0 or 3.0 browser, verify that the popup blocker 
is disabled.

Depending on the Unified CCX products that you are using, the Unified CCX 
server may employ as many as 14 subsystems for communicating with other 
services: 

 • Applications—Manages the applications in the Unified CCX Engine and 
other features such as session management.

 • Cisco Media—Configures Cisco Media Termination (CMT) dialog control 
groups, which can be used to handle simple Dual Tone Multifrequency 
(DTMF) based dialog interactions with customers.

 • Core Reporting—Provides information for Unified IP IVR real-time reports.

 • Database—Handles the connections between the Unified CCX server and the 
enterprise database.

 • eMail—Adds components to the Unified CCX Engine that allows it to send 
e-mail messages.
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 • Enterprise Server—Communicates data for screen pops to the Unified CCX 
Agent Desktop.

 • HTTP—Adds components to the Unified CCX Engine that allow it to respond 
to HTTP requests.

 • ICM Subsytem—Manages the connection between the Unified CCX server 
and ICM.

 • Unified CM Telephony—Manages the connection between Unified CM CTI 
Manager and the Unified CCX Engine.

 • Unified CME Telephony—Manages the SIP connection between Unified 
CME and the Unified CCX Engine.

 • MRCP ASR—Allows a script to respond to voice input in addition to DTMF 
using the MRCP protocol.

 • MRCP TTS—Composes voice prompts that are generated real-time from 
text, such as speaking the words in the text of an e-mail message using the 
MRCP protocol.

 • Resource Manager-Contact Manager (RmCm)—Allows Unified CCX to 
monitor agent phones, control agent states, route and queue calls, and manage 
the historical reporting feature.

 • Voice Browser—Manages Voice Browser functionality.

 • Unified CCX Voice over Internet Protocol (VoIP)—Enables remote 
recording and monitoring

Note Recording and monitoring over pre-configured SPAN port is not 
supported in HA over WAN deployment of Unified CCX.

Setting Up Unified CCX 
After you install the Unified CCX system and perform the initial setup as 
mentioned in the Cisco Unified Contact Center Express Installation Guide, you 
can start provisioning and configuring the system:

 • Provisioning is the process of allocating resources and devising strategies for 
drawing on them to support the needs of your business.
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 • Configuring is the process of making applications available to the Unified 
CCX system.

The sections that follow describe these tasks:

 • Provisioning Telephony and Media Subsystems, page 1-11

 • Provisioning Unified CCX Subsystems, page 1-12

 • Viewing License Information, page 1-14

 • Configuring Unified CCX Applications, page 1-17

Provisioning Telephony and Media Subsystems
The Unified CCX telephony and media subsystems manage telephony and media 
resources and communicate with supporting telephony and media systems.

Depending on the Unified CCX applications you plan to use, you need to 
provision some or all of the following subsystems: 

 • Unified CM Telephony. The Unified CM Telephony subsystem controls the 
Unified CM telephony resources for the Unified CCX system.

Caution While Unified CM supports Unicode characters in first and last names, 
those characters become corrupted in Unified CCX Administration 
web pages for Real Time Reporting, Cisco Agent/Supervisor Desktop, 
and Historical Reports.

 • Unified CME Telephony. The Unified CME Telephony subsystem controls 
the Unified CME telephony resources for the Unified CCX system.

 • Cisco Media. The Cisco Media subsystem controls the CMT media resources 
for the Unified CCX system.

 • MRCP ASR. The MRCP ASR subsystem controls the ASR media resources 
for the Unified CCX system.

 • MRCP TTS. The MRCP TTS subsystem controls the TTS media resources 
for the Unified CCX system.

Note For detailed instructions on provisioning the Unified CCX telephony subsystems, 
see Chapter 7, “Provisioning Telephony and Media.” 
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Provisioning Unified CCX Subsystems
You need to provision your Unified CCX subsystems to enable the Unified CCX 
Engine to run multiple applications to handle Unified Communications calls or 
HTTP requests.

Note You need to configure a particular subsystem only if you are using Unified CCX 
applications that require it and which are installed and activated using the 
appropriate license.

To continue the Unified CCX system configuration process, you will connect to 
the Unified CCX Administration web interface and perform the following tasks:

 • Provisioning Unified CCX Subsystems, page 1-12

 • Provisioning Additional Unified CCX Subsystems, page 1-13

 • Wizards Menu, page 19-1

Provisioning the Unified CCX Subsystem

If you have purchased any of the three versions of Unified CCX, you will need to 
provision the Unified CCX subsystem.

Note If your Unified CCX system does not include Unified CCX, proceed directly to 
the “Provisioning Additional Unified CCX Subsystems” section on page 1-13.

Provision the following settings on the Unified CCX subsystem:

 • RmCm Provider. The Resource Manager (RM) of the Unified CCX system 
uses a Unified CM user (called a Unified CM Telephony provider) for 
monitoring agent phones, controlling agent states, and routing and queueing 
calls.

 • Resources. Agents that answer calls are also called resources. After you 
create a resource group, you must assign agents (resources) to that group. 
You can assign skills to agents if you have Unified CCX Standard license. 

 • Resource Groups. Collections of agents that your CSQ uses to handle 
incoming calls. To use resource group-based CSQs, you must specify a 
resource group.
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 • Skills. (Unified CCX Standard license) Skills are customer-definable labels 
assigned to agents. You can route incoming calls to agents who have the 
necessary skill or sets of skill to handle the call.

 • CSQs. After you assign an agent to a resource group, or assign skills to an 
agent, you need to configure the agent for the CSQ to which the agent will be 
assigned.

 • Agent-Based Routing Settings. You can configure Automatic Work and 
Wrapup Time settings for the agent based routing feature from the 
Agent-Based Routing Settings page (see Configuring Agent-Based Routing, 
page 8-34).

 • Remote Monitoring. If you want to associate agents and CSQs that will be 
monitored by remote supervisors, you need to configure remote monitoring 
settings. This feature is not available when interoperating with Unified CME.

 • Teams. If you want to create or associate teams with various agents, CSQs, 
and supervisors, you need to configure team settings.

Note For detailed instructions on provisioning the Unified CCX subsystem, see 
Chapter 8, “Provisioning Unified CCX” and Chapter 19, “Wizards Menu.”

Provisioning Additional Unified CCX Subsystems

The additional Unified CCX subsystems provide Unified ICME, HTTP, 
Database, and E-mail features.

Provision the following subsystems:

 • Unified ICME. The ICM subsystem communicates with Unified ICME 
software. 

 • HTTP. The HTTP subsystem enables Unified CCX applications to respond 
to requests from a variety of web clients.

 • Database. The Database subsystem enables Unified CCX applications to 
communicate with enterprise database servers.

 • eMail. The eMail subsystem enables Unified CCX applications to create and 
send e-mail.
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Note For detailed instructions on provisioning these four subsystems, see Chapter 9, 
“Provisioning Additional Subsystems.”

Viewing License Information
The initial license configuration is part of the Setup Wizard procedure (during 
installation). The uploaded licenses define the feature set for a Unified CCX 
system. See the Cisco Unified Contact Center Express Installation Guide for 
more information on obtaining and installing licenses for Cisco Unified CCX 
8.5(1). 

You can add additional licenses using the Add Licenses submenu option (see 
Uploading Licenses, page 1-15). See Unified CCX Licensing Packages, page A-1 
for details on license options.

To view the license details of your Unified CCX, choose System > License 
Information > Display License(s) from the Unified CCX Administration menu 
bar. The License Information web page opens displaying the details of the 
configured licenses including the expiry date in case of time bound licenses (see 
License Information Menu Option, page 16-5).

From 8.5(1)SU3 release, the Licence Information web page displays a drop-down 
list with all licenses, active and expired, that have been configured in the system. 
When you choose a license from the list, the content of that license is displayed.

You can view the cumulative content of all the currently active licenses in the 
system by selecting Cumulative License Information from the drop-down list. 
This option also displays a breakup of the temporary and permanent license 
counts.

Note If two licenses with same feature name are uploaded, the Unified 
CCX Administration Display Licenses web page will display the nearest one as 
the expiry date. Though the expiry date refers to the nearest date, it does not mean 
that the license expires on the date displayed in the “Display Licenses” page if you 
had uploaded a permanent license.
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For Unified CCX 8.5(1), if you have a premium license with an Outbound IVR 
license, then this web page will display the number of licensed IVR ports for 
outbound and inbound and the dedicated ports for both outbound and inbound 
calls.

Caution Deleting or reducing the number of Outbound IVR ports in the license is not a 
supported scenario in Unified CCX 8.5(1). Doing this might lead to inaccurate 
data in Dedicated Licensed Ports, which in turn might lead to more number of 
abandoned calls.

Uploading Licenses

Software for all the Unified CCX feature components are loaded on the system 
during installation. However, no feature is available for use unless a license for 
that feature is added and activated.

You can upload and display licenses using the License Information page. To 
upload a license, complete the following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose System > License 
Information > Add License(s).

The License Information web page opens.

Step 2 Specify a License file or click Browse to locate a file.

You can either specify a single file with a .lic extension or a .zip file containing 
multiple .lic files.

Note While upgrading from a previous release, if there are multiple licenses, it is 
recommended to zip all the .lic files into a single .zip file and then upload the zip 
file. If specifying a .zip file, ensure that all .lic files that need to be added are in 
the root of the .zip file and are not in subfolders in the zip file. 

Step 3 Click Upload. 
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Step 4 On successful upload of license, you will see the following confirmation message 
in the status bar on top of this web page - “License has been uploaded 
successfully”. 

If you upload an Add-on license to increase the existing licensed Outbound IVR 
ports, the following message will be displayed - “As the number of licensed 
Outbound IVR Ports have increased, please increase the number of ports in the 
Outbound Call Control Group to utilize all the licensed ports".

Deleting Licenses

From the 8.5(1)SU3 release, there is a provision to delete temporary licenses.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose System > License 
Information > Display License(s).

The Display License(s) web page opens.

Step 2 From the drop-down list, choose the license to be deleted.

The content of the license is displayed. Make sure you have selected the correct 
license to be deleted.

Note The Delete button beside the drop-down list is enabled only when a 
temporary license is selected. For all other licenses, this button remains 
dimmed.

Step 3 Click Delete placed next to the drop-down list.

Note For a High Availability (HA) system, you may delete the license from only one 
node. The delete effect replicates to the other node. Login to the second node to 
confirm that the change is reflected.
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If the HA system is operating in the Island mode where both the nodes are 
masters, it is recommended that you delete the license separately from both the 
nodes.

Configuring Unified CCX Applications
After you provision the Unified CCX subsystems and view your license 
information, you need to configure Unified CCX applications to interact with 
contacts and perform a wide variety of functions.

To continue the Unified CCX system configuration process, connect to the 
Unified CCX Administration web interface and manage the following tasks:

 • Available Applications, page 1-17

 • Managing Scripts, Prompts, Grammars, and Documents, page 1-18

 • Wizards Menu, page 19-1

Available Applications

There are several types of applications you can configure for Unified CCX:

 • Script applications perform such functions as receiving calls, playing back 
prompts, receiving caller input, transferring calls, and queueing calls.

 • The Busy application simulates a busy signal. 

 • The Ring-No-Answer application simulates a ring tone.

In addition, if your Unified CCX system is to be configured to interface with 
Unified IP IVR for Unified ICME (not with Unified CCX by way of the Unified 
Gateway) two extra applications are available: ICME post-routing applications 
and ICME translation-routing applications (see “About Unified CCX 
Applications” section on page 6-1).

After adding a Unified CCX application, you need to define a trigger so that this 
application can respond to telephone calls and HTTP requests. Triggers are 
specified signals that invoke application scripts in response to incoming contacts. 

Note For detailed instructions on configuring Unified CCX applications and defining 
triggers, see Chapter 6, “Configuring Cisco Applications.” 
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Managing Scripts, Prompts, Grammars, and Documents

The process of configuring Cisco script applications includes uploading Unified 
CCX scripts and pre-recorded prompts, installing grammars and customized 
languages, and adding triggers to applications.

Depending on your particular Unified CCX implementation, you may need to 
perform most or all of the following tasks to configure a Cisco script application:

 • Manage scripts: Cisco script applications are based on scripts that you must 
upload to the repository and make available to the Unified CCX system.

 • Manage prompts: Many applications make use of pre-recorded prompts, 
stored as .wav files, which are played back to callers to provide information 
and elicit caller response. You must upload these .wav files to the repository 
and make them available to the Unified CCX system.

 • Install grammars: A grammar is a specific set of all possible spoken phrases 
and Dual Tone Multi-Frequency (DTMF) digits to be recognized by Unified 
CCX applications and acted upon during run time. The Unified CCX 
system uses specific grammars when recognizing and responding to caller 
response to prompts. You must store these grammars in a directory to make 
them available to the Unified CCX system. 

 • Install customized Unified CCX languages: Language packs, such as 
American English, Canadian French, and so on are installed with Unified 
CCX. 

Note For detailed instructions on managing these files, see Chapter 10, “Managing 
Prompts, Grammars, Documents, and Custom Files.”

Configuring Unified CCX Historical Reporting
When you install the Unified CCX system, the installation process creates a 
database named db_cra. This database contains:

 • Information for historical reports, including Unified CCX configuration 
information, stored procedures, and some call statistics.

 • The ContactCallDetail table, which is the main table for call statistics. 
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To conclude the Unified CCX system configuration process, connect to the 
Unified CCX Administration web interface and perform the following Historical 
Reporting Configuration tasks:

1. Define the maximum number of database connections for report client 
sessions.

2. Assign historical reporting capability to users.

3. Configure the Daily Purge Schedule and specify notification parameters.

Note For detailed instructions on how to configure the Unified CCX historical 
reporting database, see Chapter 12, “Managing Unified CCX Historical 
Reporting.” 

Running and Managing Unified CCX 
To manage your Unified CCX, you must first provision and configure it. The 
day-to-day administration of the Unified CCX system and datastores consist of 
many tasks, such as:

 • Starting and stopping the Unified CCX Engine and processes.

 • Managing and monitoring the status of Unified CCX servers and components 
across the cluster.

Note Support for High Availability and remote servers is available only in 
multiple-server deployments.

Where To Go From Here? 
 • Introduction and overview of the Unified CCX system 

 – See Chapter 2, “Introduction to Unified CCX Administration Web 
Interface.”

 • Provisioning and management tasks.

 – See Chapter 3, “Unified CCX Provisioning Checklist”
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 – See Chapter 4, “Provisioning Unified CM for Unified CCX.”

 – See Chapter 5, “Provisioning Unified CCX for Unified CME”

 – See Chapter 7, “Provisioning Telephony and Media.”

 – See Chapter 8, “Provisioning Unified CCX.” 

 – See Chapter 9, “Provisioning Additional Subsystems.”

 – See Chapter 6, “Configuring Cisco Applications.”

 – See Chapter 10, “Managing Prompts, Grammars, Documents, and 
Custom Files.”

 – See Chapter 11, “Managing the Unified CCX System.”

 – See Chapter 12, “Managing Unified CCX Historical Reporting.”

 – See Chapter 13, “Configuring Unified CCX Outbound Dialer”

 – See Chapter 14, “Reporting on Real-Time Unified CCX Data.”

 – See Chapter 15, “Using Unified CCX Supervisor and Unified CCX User 
Options Plug-Ins.”

 • Reference information for each Unified CCX Administration menu option.

 – See Chapter 16, “System Menu.”

 – See Chapter 17, “Applications Menu.”

 – See Chapter 18, “Subsystems Menu.”

 – See Chapter 19, “Wizards Menu”

 – See Chapter 20, “Tools Menu.”

 – See Chapter 21, “Help Menu.”
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Introduction to Unified CCX 
Administration Web Interface

The Unified CCX provides a multimedia (voice, data, and web) IP-enabled 
customer-care application environment, using VoIP technology that allows your 
Cisco Unified Communications network to share resources with your data 
network.

You can then use a web browser located on any computer on the IP network to 
configure and administer your applications with the Unified CCX Administration 
web interface.

Note Support for High Availability and remote servers is available only in 
multiple-server deployments.

The Unified CCX Administration web interfaces, that is, Cisco Unified CCX 
Administration and Cisco Unified CCX Serviceability together allows you to:

 • Configure and monitor overall system functions, applications, and 
subsystems

 • Access a wide variety of system tools, and 

 • Perform many other administrative tasks.

The following sections provide more information about the Unified CCX 
Administration web interface:

 • Accessing Unified CCX Administration Web Interface, page 2-2

 • Cisco Unified CCX Administration Menu Bar and Menus, page 2-3
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 • Unified CCX Configuration Web Pages, page 2-6

Accessing Unified CCX Administration Web 
Interface

The web pages of the Unified CCX Administration web interface allow you to 
configure and manage the Unified CCX system and its subsystems.

Use the following procedure to browse into the server and log on to Unified CCX 
Administration web interface.

Procedure

Step 1 Open the Unified CCX Administration Authentication page from a web browser 
on any computer on your network and enter the following case-sensitive URL:

https://<servername>/appadmin

In this example, replace <servername> with the host name or IP address of the 
required Unified CCX server. 

Step 2 A Security Alert dialog box displays. Click the appropriate button.

The Authentication page appears.

Note Ensure that Cisco Tomcat and Cisco Unified Cluster View Daemon 
services are up and running before you login to the Unified CCX 
Administration using the above-mentioned URL. If you are using 
Microsoft Internet Explorer Version 6.0 or higher or Mozilla Firefox 
Version 2.0 or 3.0 browser, verify that the popup blocker is disabled.

Step 3 At the main Cisco Unified CCX Administration web page, enter your Unified 
CCX username and password. 

Note If you are accessing Unified CCX for the first time, enter the Application 
User credentials specified during installation of the Unified CCX. See the 
Cisco Unified Contact Center Express Installation Guide for further 
instructions. The user id is case-insensitive in Unified CCX 8.5(1).
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Step 4 Click Login.

A web page opens listing information about Cisco Unified CCX Administration 
and the Cisco Unified CCX Administration menu bar appears at the top of the 
page.

Note For security purposes, Cisco Unified CCX Administration logs you out 
after 30 minutes of inactivity, and you must log back in.

Related Topics

 • Using Unified CCX Supervisor Web Interface, page 15-6

 • Using the Unified CCX User Options Web Interface, page 15-9

Cisco Unified CCX Administration Menu Bar and 
Menus

The Cisco Unified CCX Administration menu bar appears at the top of every web 
page of the Unified CCX Administration web interface. You begin every Unified 
CCX configuration and administration task by choosing a menu and submenu 
option from the menu bar. 

The Cisco Unified CCX Administration menu bar contains the following menu 
options:

 • System—Contains options for configuring new servers in the cluster, Unified 
CM information, language information, changing system parameters, custom 
file configuration, and adding or displaying licenses. For a description of all 
System menu options, see Chapter 16, “System Menu.”

 • Applications—Contains options for managing applications, scripts, prompts, 
grammars, documents, and AAR files. For a description of all Applications 
menu options, see Chapter 17, “Applications Menu.”

 • Subsystems—Contains options for configuring parameters for the 
subsystems that are licensed for your Unified CCX server. Your Subsystems 
menu may include submenu options for one or more of the following 
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subsystems: Unified CM Telephony, Unified CME Telephony, Unified CCX, 
Cisco Unified Intelligent Contact Management Enterprise (Unified ICME) 
software, Database, HTTP, Email, Cisco Media, MRCP Automatic Speech 
Recognition (ASR), and MRCP Text-To-Speech (TTS). For a description of 
all Subsystem menu options, see Chapter 18, “Subsystems Menu.”

 • Wizards—Contains options that provide access to the following wizards of 
your Unified CCX server: Application and RmCm. For description of these 
two wizard menu options, see Chapter 19, “Wizards Menu”.

 • Tools—Contains options that allow you to access the following system tools 
such as Plug-ins, Real-Time Reporting, Real-Time Snapshot Config, and 
Historical Reporting, You can also assign access levels to administrators and 
supervisors and reset passwords. For a description of all Tools menu options, 
see Chapter 20, “Tools Menu.”

 • Help—Provides access to online help for Unified CCX. For a description of 
all Help menu options, see Chapter 21, “Help Menu.”

Navigating the Cisco Unified CCX Administration 
Application

After you log on, the main Cisco Unified CCX Administration web page 
redisplays. The web page includes the drop-down list box in the upper, right 
corner called Toolbar. To access the applications in the drop-down list box, 
choose the program that you want and click Go. 

Note The minimum supported screen resolution specifies 1024x768. Devices with 
lower screen resolutions may not display the applications correctly.

The choices in the drop-down list box include the following Cisco Unified CCX 
Administration applications:

 • Cisco Unified CCX Administration—Use Cisco Unified CCX 
Administration to configure system parameters, subsystems, wizards, and 
much more.

 • Cisco Unified CCX Serviceability—Takes you to the main Cisco Unified 
CCX Serviceability web page that is used to configure trace files, alarms, and 
to activate and deactivate services. 
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 • Cisco Desktop Administrator—Takes you to the main Cisco Desktop 
Administrator web page that is used to configure Enterprise Data, Personnel, 
Cisco Unified Presence Settings, and Agent E-Mail Settings.

 • Cisco Unified Serviceability—Takes you to the main Cisco Unified 
Serviceability web page that is used to save alarms and traces for 
troubleshooting, provide alarm message definitions, activate and deactivate 
services and so on.

 • Cisco Unified OS Administration—Takes you to main Cisco Unified OS 
Administration web page, so you can configure and administer the Cisco 
Unified Communications platform.

 • Disaster Recovery System—Takes you to the Cisco Disaster Recovery 
System, a program that provides data backup and restore capabilities for all 
servers in a Cisco Unified CCX Administration cluster. 

After you log in to Cisco Unified CCX Administration, you can access the 
following three applications that display in the Navigation drop-down list box in 
top right corner of the Administration menu bar with single sign-on:

 • Cisco Unified CCX Administration

 • Cisco Unified CCX Serviceability

 • Cisco Desktop Administrator

Note You must be an end user on the configured Unified CM with Administrator 
capability in Unified CCX to log in to any of the Cisco Unified CCX 
Administration web applications.

You can access the following three platform-based web applications using the 
credentials mentioned against the application:

 • Cisco Unified Serviceability—Application User credentials as configured 
during installation of Unified CCX.

 • Cisco Unified Operating System Administration—Platform User credentials 
as configured during installation of Unified CCX.

 • Disaster Recovery System—Platform User credentials as configured during 
installation of Unified CCX.

To access these applications from Cisco Unified CCX Administration, you must 
first choose the desired application from the Navigation drop-down list box in the 
upper, right corner and click Go.
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Unified CCX Configuration Web Pages
When you choose any menu and submenu option from the Unified 
CCX Administration menu bar, a configuration or administration web page 
opens. Use this web page to continue your configuration or administration task. 

In some cases you will perform your configuration or administration task on this 
one web page.

In other cases, the web page that first opens when you choose a submenu item 
leads to a series of web pages. For example, the Unified CM Telephony Call 
Control Group Configuration web page contains both a tool bar in the top with a 
few icons that link to other web pages and a configuration area.

The following table describes the Refresh All button and the Copy, Delete, and 
Refresh icons that are found in several Unified CCX web pages. 

-

Related Topics

 • Displaying Details for Advanced Configuration, page 2-7

 • Using Tool Bar and Buttons, page 2-7

 • Using Tool Bar and Buttons, page 2-7

 • Using Configuration Wizards, page 2-8

Icon/Button Description

Copy Click this icon to copy the information in that specific row.

Note When you click Copy icon, the web page, displays the 
copied configuration so you can make changes, if desired.

Delete Click this icon to delete the information in that specific row.

Refresh Click this icon to refresh the information in that specific row. 

Refresh All Click this button to refresh the information listed on this page. 
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Displaying Details for Advanced Configuration
In Unified CCX Administration web interface, the concept of advanced 
configuration with the Show More and Show Less options exists. On the 
applicable pages, all configuration details can be displayed or reduced based on 
user preferences and requirements.

A page by default displays fewer parameters. Parameters configured with default 
values and not requiring modification or user input are now available in the 
advanced configuration section. You can access this advanced configuration 
section by clicking the Show More button at the bottom of the page. When you 
click this button, the extra parameters become visible and the button changes to 
Show Less. When you click Show Less button, the page reverts to its original list 
of parameters.

Note If you are using Unified CCX with Cisco Contact Center Gateway solution, see 
the Cisco IPCC Gateway Deployment Guide for Cisco Unified ICME/CCE/CCX. 
The instructions for configuring Unified CCX with that solution differs from what 
is described in this guide. The Unified Gateway provides for the integration of the 
Unified ICME system with Unified CCX by way of Unified Gateway. See the 
Cisco Unified Contact Center Enterprise Install and Upgrade Guides available at 
http://www.cisco.com/en/US/products/sw/custcosw/ps1844/prod_installation_gu
ides_list.html for detailed information. The Unified Gateway is a Peripheral 
Gateway (PG) which you configure on the Unified ICME software. 

Related Topics

 • Unified CCX Configuration Web Pages, page 2-6

 • Using Tool Bar and Buttons, page 2-7

 • Using Configuration Wizards, page 2-8

Using Tool Bar and Buttons
On the top left tool bar of many web pages, you will find a Add New icon and the 
same Add New will also be displayed as a button at the bottom of the web page 
also. 
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For example, the Unified CM Telephony Call Control Group Configuration web 
page contains Add New and Refresh All icons on the top left tool bar and the 
same are displayed as buttons at the bottom of the web page. When you click the 
Add New icon or button, another Unified CM Telephony Call Control Group 
Configuration web page opens. Use this area to add a new Unified CM Telephony 
Call Control Group.

Many web pages contain icons or buttons that perform a variety of functions. For 
example, the Refresh All button on the Unified CM Telephony Call Control 
Group Configuration web page refreshes all the Unified CM Telephony call 
control group configurations in the Unified CCX server.

A few web pages (for example, Subsystems > Database > Parameters page) also 
contain a Reset to Default icon and button. This allows you to revert to the 
software set defaults for each parameter on this page.

Related Topics

 • Unified CCX Configuration Web Pages, page 2-6

 • Displaying Details for Advanced Configuration, page 2-7

 • Using Tool Bar and Buttons, page 2-7

 • Using Configuration Wizards, page 2-8

Using Configuration Wizards
In Unified CCX, two wizards are available in the main menu: the Application 
Wizard and the RmCm Wizard. 

To improve the usability and configuration process, these wizards walk you 
through the configuration pages in the required order and help ease the 
configuration process for these two features. You can access these wizards from 
a new main menu option called Wizards.

Related Topics

 • Wizards Menu, page 19-1

 • Unified CCX Configuration Web Pages, page 2-6

 • Displaying Details for Advanced Configuration, page 2-7

 • Using Tool Bar and Buttons, page 2-7
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Unified CCX Provisioning Checklist

The following two product deployments are available for the Unified CCX: 

 • The Unified CM product supports both single-node and two-node (high 
availability) deployments.

 • The Unified CME product only supports a single-node deployment. 

The deployment model is transparent to the Unified CCX installer as the 
clustering for Unified CM is performed through the Unified CCX Administration 
using the Unified CCX setup wizard. HA over WAN feature of Unified CCX is 
supported only for Unified CM deployments and not for Unified CME 
deployments.

Note This guide is applicable for both product deployments and identifies the 
configuration differences between the products where applicable. 

The following topics introduce the Unified CCX subsystem and explain how to 
modify the Unified CM/Unified CME information from Unified CCX. 

 • About Unified CCX, page 3-2

 • Unified CCX Provisioning Checklist, page 3-3
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About Unified CCX
The Unified CCX system uses the Unified CCX subsystem as part of an ACD 
system to provide resource distribution and queueing to call centers.

See Unified Contact Center Express, page 1-5 to know more about the licensing 
options that are available for the Unified CCX system.

Two types of routing are available:

 • Contact Service Queue (CSQ)-based routing: CSQs are entities that route 
calls to your resources (agents). Each CSQ controls incoming calls and 
determines where an incoming call is placed in the queue and to which agent 
the call is sent.

Each CSQ selects resources from an associated resource pool that you define 
or from resource skills for all Unified CCX license packages. When an agent 
becomes available to take a call, the system chooses a queued call from one 
of the CSQs whose resource pool includes the agent, and routes that call to 
that agent. 

 • Agent-based routing: Agent-based routing provides the ability to send a call 
to a specific agent, rather than any agent available in a CSQ.

A Unified CCX agent can participate in both CSQ- and agent-based routing. 
Unified CCX agent can be any one of the following:

 • Cisco Agent Desktop (CAD)

 • IP Phone Agent

 • Extension Mobility (EM) Agent

 • Cisco Agent Desktop Business Edition (CAD-BE) Agent

Note EM agents are not supported with Unified CME deployments.

 • Supervisor (if the supervisor is taking calls). 

Note A supervisor who is not taking calls is not considered as an agent. 
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Calls are queued in the Unified CCX server and sent to agents by the Unified CCX 
server. 

The machine you install your Unified CCX system on determines how many 
agents and IVR ports Unified CCX can accommodate. However, there are several 
general configuration rules that you should be aware of:

 • Each agent cannot be associated with more than: 

 – 25 CSQs. (This is a configuration design guideline; Unified CCX 
Administration does not enforce the rule.)

 – 50 skills. (Unified CCX Administration enforces this rule.)

 • Each CSQ cannot be associated with more than 50 skills. (Unified CCX 
Administration enforces this rule.)

 • A call should not queue for more than 25 CSQs. (This is a configuration 
design guideline; Unified CCX Administration does not enforce the rule.)

Related Topic

Unified CCX Provisioning Checklist, page 3-3

Unified CCX Provisioning Checklist
To provision Unified CCX, complete the following tasks:

Step Task For Unified CM, See... For Unified CME, See...

Step 1 Configure Unified CME to 
enable interoperability with 
Unified CCX.

Not applicable “Provisioning Unified CCX 
for Unified CME” section on 
page 5-1

Also see the Cisco Unified 
Communications Manager 
Express 8.5(1) New 
Features.
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Related Topic

About Unified CCX, page 3-2

Step 2 Configuring Unified CM users 
who will be agents in your 
Unified CCX system.

“Provisioning Unified CM 
for Unified CCX” section 
on page 4-1

Not applicable

Create users and assign the agent 
capability to these users in 
Unified CCX. 

Not applicable “Managing Unified CCX 
Users” section on page 5-14

Step 3 Provisioning the resources 
information for the Unified CCX 
telephony and media

“Provisioning Unified CM 
Telephony Subsystem” 
section on page 7-5

“Provisioning Unified CME 
Telephony Subsystem” 
section on page 5-7

Step 4 Provisioning the RmCm 
Provider to allow the RmCm 
Subsystem to be in service.

“Configuring RmCm Provider” section on page 8-2

Step 5 Creating resource groups. “Configuring Resource Groups” section on page 8-4

Step 6 Creating skills. “Configuring Skills” section on page 8-7

Step 7 Assigning agents to resource 
groups and assigning skills to 
agents.

“Configuring Agents” section on page 8-10 

Step 8 Creating Contact Service 
Queues.

“Configuring Contact Service Queues” section on 
page 8-17

Step 9 Provisioning Remote Monitor-
ing—if you are using Unified 
CCX Premium.

“Configuring and Using 
Remote Monitoring” 
section on page 8-30

Not applicable

Step 10 Provisioning agent-based rout-
ing—if you are using Unified 
CCX Enhanced or Premium.

“Configuring Agent-Based Routing” section on page 8-34

Step 11 Creating teams and assigning 
agents to teams.

“Configuring Teams” section on page 8-35

Step Task For Unified CM, See... For Unified CME, See...
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Changing the Licensing Packages
The following three license upgrade options are available for Unified CCX 
system:

 • Standard to Premium

 • Standard to Enhanced

 • Enhanced to Premium

For detailed information on licensing packages, see Application Availability by 
License Package, page A-2. 

While upgrading the licenses, you need to configure certain system parameters 
details of which are explained below. Choose System > System Parameters from 
the Cisco Unified CCX Administration menu bar to open the System Parameters 
Configuration web page where you can update these values. 

 • Standard to Premium or Enhanced: Only Enhanced and Premium package 
licenses support Recording. When you upgrade to Enhanced or Premium 
license package, you need to manually change the Recording Count to a 
desired value to enable the recording functionality. 

 • Standard or Enhanced to Premium: You need to configure the Number of 
Outbound Seats while upgrading to a Premium license. 

Refer to Managing System Parameters, page 11-5 for more information on 
configuring the system parameters. 

Note Downgrade of license is not supported in Unified CCX.
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Provisioning Unified CM for Unified 
CCX

When you access Unified CCX Administration for the first time in a cluster, the 
system automatically initiates the cluster setup procedure once for each cluster to 
perform the following tasks:

 • Identify Unified CCX license files 

 • Enter information about Unified CM Administrative XML Layer (AXL) and 
Unified CM Telephony and RmCm providers 

You can modify the Unified CM information from Unified CCX. See the 
Installation Guide for Cisco Unified CCX and Cisco Unified IP IVR, Release 
8.5(1) for detailed information on how to perform the initial system setup using 
the Unified CCX Administration web interface.

The following topics explain how to modify the Unified CM information from 
Unified CCX. 

 • Configuring Unified CM Information, page 4-2

 • Modifying Cluster Information from Unified CCX, page 4-2

 • Modifying AXL Information, page 4-5

 • Modifying Unified CM Telephony Information, page 4-8

 • Modifying RmCm Provider Information, page 4-10

 • Configuring Unified CM for Unified CCX, page 4-12

 • Defining Unified CM Users as Agents, page 4-13

 • Configuring Tool for Auto-Registered Phones Support (TAPS), page 4-22
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Configuring Unified CM Information 
During initial setup of Unified CCX using the Unified CCX Administration web 
interface, the administrator who installed the Unified CCX should have already 
provided the Unified CM IP address and host name(s). The administrator must 
also provide the Administrative XML Layer (AXL) authentication (user ID and 
password) information. 

The Unified CM Configuration web page allows you to configure and update the 
Unified CM cluster information, AXL authentication information, Unified CM 
Telephony subsystem information, and RmCm Provider configuration 
information from within Unified CCX. 

This page has four blocks of information: Unified CM cluster details, AXL 
service details, Unified CM Telephony Provider details, and RmCm Provider 
details. 

Related Topics

 • Modifying Cluster Information from Unified CCX, page 4-2

 • Modifying AXL Information, page 4-5

 • Modifying Unified CM Telephony Information, page 4-8

 • Modifying RmCm Provider Information, page 4-10

 • Configuring Unified CM for Unified CCX, page 4-12

 • Configuring RmCm Provider, page 8-2

 • Provisioning Unified CM Telephony Subsystem, page 7-5

Modifying Cluster Information from Unified CCX

Caution If you change the cluster information, you must reconfigure the Unified CM 
Telephony/RmCm setup. After reconfiguring this information, you must restart 
the Unified CCX Engine.
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Tip To log back into Unified CCX Administration, you must associate a user with 
Administrator capabilities. 

The cluster setup is derived from the information provided during the Unified 
CCX installation process—if configured. You can change this information at any 
time as required from Unified CCX. If you do change the cluster, you must 
provide the IP address of the AXL server to which you will move this server. 

For the cluster setup change to take effect, the Administrative XML Layer (AXL) 
service must be enabled on the required server. If the AXL service is enabled on 
that server, the Unified CCX Administration attempts to access that server and 
updates the Unified CM cluster setup information. 

To change previously-configured cluster setup information from Unified CCX, 
complete the following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose System > Cisco Unified 
CM Configuration.

The Cisco Unified CM Configuration web page opens. 

Step 2 Click Change Unified CM Cluster icon that displays in the tool bar in the upper, 
left corner of the window to change the existing cluster setup for this server.

The Change CM Cluster dialog box opens. 

Step 3 Use this dialog box to specify the following three mandatory fields.

-

Field Description

AXL Service Provider Provide the IP address or host name of the AXL server providing access to 
Unified CM. 

Note Ensure to configure multiple AXL providers running the AXL 
Service for a redundant system.

User Name Enter the user name for the AXL server providing access to Unified CM.

Password Enter the corresponding password for the user account providing access to 
Unified CM.
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Step 4 Click OK.

Unified CCX Administration enables that service and then tries to access the 
Unified CM Cluster information and update the Unified CM Configuration page. 

Note In a HA over WAN deployment of Unified CCX, the updated AXL Service 
provider information will be updated against the primary Unified CCX node. 
After successful change of cluster, you can configure the AXL service provider 
for the secondary node from the Cisco Unified CM Configuration web page by 
navigating to System > Cisco Unified CM Configuration menu option from the 
Unified CCX Administration menu bar.

Related Topics

 • Displaying Unified CM Cluster Nodes in Unified CCX, page 4-4

 • Modifying AXL Information, page 4-5

 • Modifying Unified CM Telephony Information, page 4-8

 • Modifying RmCm Provider Information, page 4-10

 • Configuring RmCm Provider, page 8-2

 • Provisioning Unified CM Telephony Subsystem, page 7-5

Displaying Unified CM Cluster Nodes in Unified CCX
When connected to a Unified CM cluster, the Unified CM Configuration page in 
the Unified CCX Administration GUI only displays the IP address of one node. 
However, in a two-node cluster, it should show the IP addresses of both the 
publisher and subscriber nodes. To display both IP addresses, you must configure 
the Domain Name Server (DNS) suffix information (for the required nodes in the 
cluster) in the server in which Unified CCX is installed.
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Selecting Server for Unified CM Configuration (displayed only in a HA over WAN 
deployment)

In a HA over WAN deployment of Unified CCX, when you choose System > 
Cisco Unified CM Configuration from the Unified CCX Administration menu 
bar, the Select Server for UCM Configuration section displays a new field 
called Select Server. You can view the different Unified CCX nodes that are 
available in a drop-down list. Select the node for which you want to update the 
Unified CM configuration and click Go. The Unified CM Configuration for the 
selected node will be displayed. 

Though the user credentials are common for all the nodes in the cluster, you can 
select a different AXL service provider and CTI manager for each node. Thus, you 
can opt to associate the selected Unified CCX node with a different AXL Service 
Provider and CTI Manager that is local rather than those over WAN. Once you 
configure the data for the selected node, click Update to save the configuration 
information. The selected Unified CCX node will communicate only with the 
AXL service provider or CTI Manager with which it is configured. For detailed 
information on behaviour in HA over WAN scenario, refer to Expected Behaviour 
During a Failover Guide.

Modifying AXL Information
To change previously-configured AXL information, complete the following 
steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose System > Cisco Unified 
CM Configuration.

Step 2 The Cisco Unified CM Configuration web page opens. Go to AXL Service 
Provider Configuration section to modify the AXL information using the 
following fields.
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-

Field Description

AXL Service Provider Configuration

Selected AXL Service Providers Lists the AXL service providers selected by the Unified CCX user. 
Select the required entry and move to the opposite list box using 
the right and left arrows. Arrange the order of the selected entries 
using the up and down arrows.

Note If you deselect the AXL service provider from the 
Selected list box, a Microsoft IE or Mozilla Firefox 
window pops up informing you about the (list of) 
deselected service(s). For security reasons (in case the 
service is being used by another AXL service provider), 
manually disable the AXL service only from the Unified 
CM. 

Available AXL Service Providers Lists the Unified CM entries in the cluster. Select the required 
entry and move to the opposite list box using the right and left 
arrows. 

Cluster Wide Parameters
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Step 3 Click Update icon on top of the Cisco Unified CM Configuration web page or the 
Update button that displays at the bottom of the web page to save the changes. 
The Unified CM Configuration web page refreshes to display the new settings. 

User Name The Unified CM User ID. This information is provided during 
cluster setup in the Unified CCX installation process. 

When you select an AXL Service Provider, the corresponding user 
name is automatically displayed in this field. This is a mandatory 
field.

Password Password for the Unified CM User ID. This information is 
provided during cluster setup in the Unified CCX installation 
process. When you select an AXL Service Provider, the 
corresponding user’s password is automatically displayed in this 
field. This is a mandatory field. 

After logging in to the Unified CCX Administration web 
interface, follow the steps mentioned below to update the AXL 
password:

a. Login to Unified CM Administration web interface and 
update the password for the application user (AXL provider).

b. Navigate back to System > Cisco Unified CM 
Configuration web page of Unified CCX and enter the new 
password in the Password field. 

c. A dialog box prompts you to confirm the AXL user name and 
password. Re-enter the AXL user id and password and click 
Login. 

d. The system validates the data and takes you back to the 
Unified CM configuration page. Enter the updated password 
once again to validate and click Update. 

The AXL password is updated successfully and you should be able 
to login to Unified CCX Administration web interface of Unified 
CCX with the new AXL password.

Field Description
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The selected AXL services are now enabled. If the selected AXL services cannot 
be enabled, an error message instructs you to reselect AXL service providers. 

Related Topics

 • Modifying Cluster Information from Unified CCX, page 4-2

 • Modifying Unified CM Telephony Information, page 4-8

 • Modifying RmCm Provider Information, page 4-10

 • Configuring RmCm Provider, page 8-2

 • Provisioning Unified CM Telephony Subsystem, page 7-5

Modifying Unified CM Telephony Information

Note The Unified CM Telephony client is installed in the background after you 
configure the Unified CM Telephony user. The Unified CM Telephony client runs 
silently and verifies that the right version and the right client are installed. 

Configuring the Unified CM Telephony user does not automatically install the 
Unified CM Telephony client. This is normally done during activation of Unified 
CCX engine in component activation (see Cisco Unified Contact Center Express 
Serviceability Guide). To do it manually, go to Subsystems > Unified CM 
Telephony and select Cisco JTAPI Resync submenu option from the Unified 
CCX Administration menu bar. See Configuring a Unified CM Telephony 
Provider, page 7-7 to install the Unified Telephony client.

The latest list of CTI Managers within a cluster are listed in this section. If the 
Unified CM is not functioning or if the Unified CCX is not able to connect to the 
Unified CM for any reason, information obtained from the most recent connection 
is saved as a part of the bootstrap information. 

To change previously-configured Unified CM Telephony information, complete 
the following steps.
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Procedure

Step 1 From the Unified CCX Administration menu bar, choose System > Unified CM 
Configuration.

The Cisco Unified CM Configuration web page opens. 

Step 2 Scroll down to Unified CM Telephony Subsystem - Unified CM Telephony 
Provider Configuration section and reconfigure the Unified CM Telephony 
information using the following fields. 

-

Step 3 Click Update icon on top of the Cisco Unified CM Configuration web page or the 
Update button that displays at the bottom of the web page to save the changes.

The Unified CM Configuration web page refreshes to display the new settings. 

Field Description

Unified CM Telephony Subsystem—Unified CM Telephony Provider Configuration

Selected CTI Managers Lists the CTI Managers selected by the Unified CCX user. 
Select the required entry and move to the opposite list box 
using the right and left arrows. Arrange the order of the 
selected entries using the up and down arrows.

Note If you deselect CTI Managers from the Selected list 
box, a Microsoft IE or Mozilla Firefox window pops 
up informing you about the (list of) deselected CTI 
Manager(s). 

Available CTI Managers Lists the CTI Managers in the cluster. Move to the opposite 
list box using the right and left arrows. 

Cluster Wide Parameters

User Prefix The syntax of the User ID is: <userprefix>_<nodeid>

For example, if you set this field to cti_user, then the User ID 
for Node 1 will be cti_user_1. This is a mandatory field.

Password Password you defined for the User ID in Unified CM.

If a CTI Manager is already selected, then the corresponding 
password is displayed in this field. This is a mandatory field.

Confirm Password Re-enter the password that you provided in the Password 
field. This is a mandatory field.
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The newly selected CTI Manager is now enabled. If the selected CTI Manager 
cannot be enabled, an error message instructs you to reselect CTI Managers. 

Note In a HA over WAN deployment of Unified CCX, the JTAPI user will be created 
only for the selected node. To create JTAPI user for the HA node, you have to 
explicitly select the HA node, make necessary updates, and click Update. See 
Selecting Server for Unified CM Configuration (displayed only in a HA over 
WAN deployment), page 4-5 section for detailed information.

Related Topics

 • Modifying Cluster Information from Unified CCX, page 4-2

 • Modifying AXL Information, page 4-5

 • Modifying RmCm Provider Information, page 4-10

 • Configuring Unified CM for Unified CCX, page 4-12

 • Configuring RmCm Provider, page 8-2

 • Provisioning Unified CM Telephony Subsystem, page 7-5

Modifying RmCm Provider Information
The list of all CTI Managers available in a cluster are saved as a part of the 
bootstrap information. You can change to any available CTI Managers listed in 
the Available CTI Managers list box in this page. 

Note The RmCm Provider specified through the Unified CCX Administration is 
automatically created in Unified CM. You do not need to use the Unified CM web 
interface to create the user.

To change previously-configured RmCm provider information or to configure a 
new RmCm Provider, complete the following steps.
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Procedure

Step 1 From the Unified CCX Administration menu bar, choose System > Unified CM 
Configuration.

The Unified CM Configuration web page opens. 

Step 2 Scroll down to RmCm Subsystem - RmCm Provider Configuration and 
reconfigure the selected CTI Manager using the following fields. 

-

Field Description

RmCm Subsystems—RmCm Provider Configuration

Selected CTI Managers Lists the CTI Managers selected by the Unified CCX user. 
Select the required entry and move to the opposite list box 
using the right and left arrows. Arrange the order of the 
selected entries using the up and down arrows.

Note If you deselect CTI Managers from the Selected list 
box, a Microsoft IE or Mozilla Firefox window pops 
up informing you the list of deselected CTI 
Manager(s). 

Available CTI Managers Lists the CTI Managers in the cluster. Select the required 
entry and move to the opposite list box using the right and left 
arrows. 

User ID User prefix for the Unified CM User IDs to be created in 
Unified CM. 

If a CTI Manager is already selected, then the corresponding 
user name is displayed in this field. If you change the CTI 
Managers, be sure to enter the corresponding user prefix for 
the selected service. This is a mandatory field.

Password Password you defined for the User ID in Unified CM.

If a CTI Manager is already selected, then the corresponding 
password is displayed in this field. If you change the CTI 
Manager, be sure to enter the corresponding password for the 
selected service. This is a mandatory field.

Confirm Password Re-enter the password that you provided in the Password 
field. This is a mandatory field.
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Step 3 Click Update icon on top of the Cisco Unified CM Configuration web page or the 
Update button that displays at the bottom of the web page to save the changes.

The Unified CM Configuration web page refreshes to display the new settings. 

The newly selected RmCm Provider is now enabled. If the selected RmCm 
Provider cannot be enabled, an error message instructs you to reselect RmCm 
Provider. 

Related Topics

 • Modifying Cluster Information from Unified CCX, page 4-2

 • Modifying AXL Information, page 4-5

 • Modifying Unified CM Telephony Information, page 4-8

 • Configuring RmCm Provider, page 8-2

 • Provisioning Unified CM Telephony Subsystem, page 7-5

Configuring Unified CM for Unified CCX
To enable Unified CCX to communicate with Unified CM, you also need to assign 
extensions for the users who will be agents in your Unified CCX system. If you 
delete a Unified CCX user with Administrative rights from Unified CM, the user 
will not be able to log into the Unified CCX Administration web interface.

Note Q Signalling (QSIG) and Path Replacement (PR) feature of Unified CM are not 
supported by Unified CCX.

Caution When logging into Cisco Agent Desktop, agents use the Unified CM user ID and 
password. While the Unified CM limits agent IDs to 128 alphanumeric characters, 
the Unified CCX limits agent IDs to 31 alphanumeric characters. Be sure to abide 
by the 31 character-limit when configuring agents in Unified CM.

This section contains the following procedures:

 • Invoking Unified CM Administration, page 4-13
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 • Defining Unified CM Users as Agents, page 4-13

Invoking Unified CM Administration
Begin the process of configuring Unified CM by connecting to the Unified CM 
Administration web interface.

To connect to the Unified CM Administration web interface, complete the 
following steps.

Procedure

Step 1 From a web browser on any computer on your network, enter the following URL: 
https://servername/ccmadmin. 

In this example, servername is the host name or IP address of your Unified CM 
server. 

Step 2 A Security Alert dialog box displays. Click the appropriate button.

Step 3 At the main Cisco Unified Communications Manager Administration web page, 
enter the Unified CM user name and password, and then click Login.

The Unified CM Administration web page appears. 

You are now ready to use the Unified CM Administration web interface to 
configure users for Unified CCX. 

Related Topic

Defining Unified CM Users as Agents, page 4-13

Defining Unified CM Users as Agents

Warning Do not configure Unified CM users having same username/password as the 
application administration credentials (configured during install). Doing so 
may restrict the Unified CM when shared across multiple Unified CCX servers. 
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To use any version of Unified CM, you must first ensure that you define Unified 
CM users as Unified CCX agents in Unified CM. Once you perform this task, 
these Unified CCX agents can be combined into Resource Groups, assigned 
Skills, and placed in CSQs.

Note In Unified CCX, this operation is called “associating a device.”

Note Languages like Cyrillic use 2 bytes per character. Some of the desktop 
applications do not support more than 16 characters. Ensure that the first name, 
the last name, and the user ID of the agent for these languages are restricted to 16 
characters each.

This section contains the following topics:

 • Guidelines for Configuring Agent Phones, page 4-14

 • Assigning Unified CM Users as Cisco TelePresence Virtual Agents, 
page 4-16

 • Assigning Unified CM Users as Unified CCX Agents, page 4-18

Related Topic

Invoking Unified CM Administration, page 4-13

Guidelines for Configuring Agent Phones

Follow these guidelines when configuring agent phones for Unified CCX agents:

 • Choose Device > Phone in the Unified CM Administration. The Find and List 
Phones window displays. Enter search criteria to locate a specific phone and 
click Find. A list of phones that match the search criteria displays. Click the 
device name of the phone to which you want to add a directory number. The 
Phone Configuration window displays. In the Unified CM Administration 
Phone Configuration web page, select the required Association Information 
(on the left) to get to the Directory Number Configuration web page. In this 
page, make the following changes: 

 – In the Multiple Call/Call Waiting Settings section, set the Maximum 
Number of Calls to 2 (default is 4) for TNP phones and 3 for RT phones.
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 – In the Multiple Call/Call Waiting Settings section, set the Busy Trigger 
value to 1 (default is 2).

 – In the Call Forward and Call Pickup Settings section, verify that you do 
not forward any Unified CM device to the Unified CCX extension of an 
agent.

 – In the Call Forward and Call Pickup Settings section, verify that you do 
not configure the Unified CCX extension of an agent to forward to a 
Unified CCX route point.

 • Always disable (off) Secure Real-Time Transport Protocol (SRTP) when 
configuring a Cisco Unified Communications product. You can disable SRTP 
for a specified device or for the entire Unified CM:

 – For a specified device: Choose Device > Phone. In the Find and List 
Phone page, select the required phone device. In the Phone Configuration 
page for the selected phone, scroll down to the Protocol Specific 
Information section.To turn off SRTP on the phone device, select any 
one of the Non Secure SCCP Profile auth by choices from the 
drop-down list of SCCP Phone Security Profile or SCCP Device 
Security Profile field. 

 – For the entire Unified CM cluster: Choose System > Enterprise 
Parameters. In the Enterprise Parameters Configuration page, scroll 
down to the Securities Parameters section, to verify that the 
corresponding value for the Cluster Security Mode field is 0. This 
parameter indicates the security mode of the cluster. A value of 0 
indicates that phones will register in non-secure mode (no security). 

 • The UCCX extension for the agent must be listed within the top 4 extensions 
on the device profile. Listing the extension from position 5 on will cause 
UCCX to fail to monitor the device, hence the agent will not be able to log in.

 • Do not forward any Unified CM device to the Unified CCX extension of an 
agent.

 • Do not configure the Unified CCX extension of an agent to forward to a 
Unified CCX route point.

 • Do not use characters other than the numerals 0 - 9 in the Unified CCX 
extension of an agent.

 • Do not configure two lines on an agent’s phone with the same extension when 
both lines exist in different partitions.

 • Do not assign a Unified CCX extension to multiple devices.
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 • Do not configure the same Unified CCX extension in more than one device 
or device profile. (Configuring a Unified CCX extension in one device or 
device profile is supported.)

 • To use Cisco Unified IP Phones 9900 Series, 8900 Series and 6900 Series as 
agent devices, the RmCm Application user in Unified Communications 
Manager needs to have 'Allow device with connected transfer/conference' 
option assigned to itself.

To determine a list of Unified CCX agent devices supported by the Cisco Agent 
Desktop, see the Cisco Unified CCX Software and Hardware Compatibility Guide 
for active releases available at: 
http://www.cisco.com/en/US/products/sw/custcosw/ps1846/products_device_sup
port_tables_list.html.

Related Topics

 • Invoking Unified CM Administration, page 4-13

 • Assigning Unified CM Users as Unified CCX Agents, page 4-18

Assigning Unified CM Users as Cisco TelePresence Virtual Agents

The Cisco TelePresence application enables enterprises to create a live, 
face-to-face interaction with customers over the network. This solution allows 
rapid deployment of a virtual contact center infrastructure, Agents using Cisco 
TelePresence are referred to as virtual agents in this guide. Virtual agents connect 
to callers using Unified CCX thus incorporating ACD, CAD, CTI, and Unified IP 
IVR with Cisco Unified CM and providing the entire solution on one server.

Note For more information on the Cisco TelePresence solution, see 
http://www.cisco.com/en/US/products/ps7060/index.html.

The following guidelines apply for the Cisco TelePresence integration with 
Unified CCX:

 • The only commonly-supported codec for Unified CCX and Cisco 
TelePresence is G711.

 • The following supervisor features are not supported:

 – Monitoring and recording is not supported for Cisco TelePresence 
integration with Unified CCX.
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 – Due to the unavailability of third-party call control, Cisco Supervisor 
Desktop (CSD) features, barge-in, and intercept are not supported. 

 • You will not be able to use the call control Cisco Agent Desktop (CAD) 
features (hold, unhold, answer, transfer, conference, Make Call, and touch 
tone). Be sure to remove or disable these features from CAD as specified in 
Step 4 in the following procedure.

Follow this procedure to assign Unified CM users as virtual agents:

Procedure

Step 1 Identify the required Cisco TelePresence system that should participate as a 
virtual agent in the Unified CCX application. 

a. Note the Unified CM extension of the Cisco TelePresence deployment.

Note The Cisco Unified IP Phone 7970G phone and Cisco TelePresence 
system must be assigned the same extension in Unified CM as they 
both share the same line.

b. Note the MAC address or the Directory Number of the Cisco Unified IP 
Phone 7970G phone connected to the identified Cisco TelePresence system. 

Tip From the Unified CCX perspective, this is another SIP end point. 

Step 2 Associate the Cisco Unified IP Phone 7970G phone with the Unified CM user to 
configure this user as a virtual agent (see Defining Unified CM Users as Agents, 
page 4-13).

Step 3 Associate the Cisco Unified IP Phone 7970G phone with the RmCm provider (see 
Configuring RmCm Provider, page 8-2).

Note Do not associate the corresponding Cisco TelePresence system with the RmCm 
provider.

Step 4 Customize the Cisco Agent Desktop workflow groups (see Cisco Desktop 
Administrator User's Guide).
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Tip All the Cisco Agent Desktop call control buttons must be disabled as 
third-party call control will not be available for the Cisco TelePresence 
integration with Unified CCX.

Assigning Unified CM Users as Unified CCX Agents

Warning Do not configure Unified CM users having same username/password as the 
application administration credentials (configured during install). Doing so 
may restrict the Unified CM when shared across multiple Unified CCX servers. 

RmCm uses the Unified CM database to determine which devices it can control 
and provides an interface method for getting the Media Access Control (MAC) 
address of the calling party.

After you install RmCm, you have access to the Unified CM database. The 
database stores parameters that initialize Unified CM Telephony, user profiles, 
application logic, network-specific configuration information, and Directory 
Number Associations such as Primary Extension and Unified CCX Extension.

The Primary Extension field represents the primary directory number for the end 
user. End users can have multiple lines on their phones. From the drop-down list 
box, choose a primary extension when associating devices for this end user. 

Unified CCX Extension allows you to define Unified CM users as Unified CCX 
agents in Unified CM. 

To assign Unified CCX devices to end users and application users in the Unified 
CM, these users must first exist in Unified CM. If these users do not exist, you 
must first add the users. See the Cisco Unified Communications Manager 
Administration guide to obtain detailed information about the Unified CCX web 
interface and configuration procedures. After adding the end user and the 
application user, be sure to modify their Unified CCX settings (see Modifying 
Existing Unified CM Users).
4-18
Cisco Unified CCX Administration Guide, Release 8.5(1)



Chapter 4      Provisioning Unified CM for Unified CCX
Configuring Unified CM for Unified CCX
Modifying Existing Unified CM Users

Note Be sure to assign Unified CCX devices to both end users and application users in 
the Unified CM web interface.

To assign devices to an end user, you must access the End User Configuration 
window for that user. The End User Configuration window in Unified CM 
Administration allows the administrator to add, search, display, and maintain 
information about Unified CM end users. 

To assign devices to an application user, you must access the Application User 
Configuration window for that user. The Application User Configuration window 
in Unified CM Administration allows the administrator to add, search, display, 
and maintain information about Unified CM application users. 

To modify the Unified CCX Extension settings for existing Unified CM users 
who are Unified CCX agents, complete the following steps.

Procedure

Step 1 Connect to the Unified CM Administration web interface. 

For information about connecting to the Unified CM Administration web 
interface (see Invoking Unified CM Administration, page 4-13).

The Unified CM Administration web page appears.

Step 2 From the Unified CM Administration menu bar, choose User Management  >  
End User.

The Find and List End Users page displays. Use the two drop-down list boxes to 
search for an end user.

Tip To find all end users registered in the database, click Find without 
entering any search text. A list of discovered end users displays. If you 
choose to do this step, skip to Step 6.

Step 3 From the first Find end user where drop-down list box, choose one of the listed 
criteria.
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Step 4 From the second Find end user where drop-down list box, choose one of the listed 
criteria,

Step 5 Specify the appropriate search text, if applicable, and click Find. 

A list of discovered end users displays.

Step 6 From the list of records, click the end user name that matches your search criteria.

The End User Configuration page opens displaying the configuration information 
for the end user that you chose.

Step 7 In the Controlled Devices list box below the Device Information section, select 
the device and click the Down arrow below the Available Profiles list box. If the 
device that you want to associate with this end user is not displayed in this pane, 
do the following to associate devices with an end user:

a. From the Device Information pane, click Device Association. The User 
Device Association page opens.

b. Finding a Device - Because you may have several devices in your network, 
Cisco Unified Communications Manager lets you locate specific devices on 
the basis of specific criteria. Click Find. All or matching records display. 
You can change the number of items that display in each page by choosing a 
different value from the Rows per Page drop-down list box.

c. Associating a Device - From the Device association for (this particular user) 
pane, choose the devices that you want to associate with this end user by 
checking the box to the left of the device name(s). You can also use the 
buttons at the bottom of the window to select and deselect devices to 
associate with the end user.

d. To complete the association, click Save Selected/Changes.

e. From Related Links drop-down list box in the upper, right corner of the web 
page, choose Back to User, and click Go.

a. The End User Configuration page displays, and the associated devices that 
you chose display in the Controlled Devices pane.

Step 8 Select the required device, if you are not using the Extension Mobility feature, 
and save your changes to associate that device with this end user.

If you are using Extension Mobility feature, associate the User Device Profile, not 
the device, with this end user.
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After the device is associated, the Controlled Devices field displays the 
description information (for example, the MAC address) that the end user 
controls.

Step 9 In the End User Configuration page, scroll down to the Directory Number 
Associations section. 

Step 10 In the Primary Extension field drop-down list and the IPCC Extension field 
drop-down list, choose the required agent extension for this device. 

These fields represent the primary directory number for the end user. End users 
can have multiple lines on their phones. If you have a single line, be sure to select 
the same extension for both fields.

Step 11 Click Update to apply the changes. 

The specific End User Information page for this user appears, with the message 
that the update was successful.

Step 12 From the Unified CM Administration menu bar, choose User Management  >  
Application User. RmCm Providers are referred to as application users in 
Unified CM.

Note When you associate one device with the Unified CCX agent (end user) 
and you are not using the Extension Mobility feature, you must also be 
sure to associate the same device with the Unified CCX RmCm Provider 
(application user).
If you are using the Extension Mobility feature, associate the device 
profile, instead of the device, with the RmCm Provider (application user).

The Find and List Application Users window displays. Use the two drop-down list 
boxes to search for the application users in Unified CM.

Tip To find all application users registered in the database, click Find without 
entering any search text. A list of discovered end users displays. If you 
choose to do this step, skip to Step 16.

Step 13 From the first Find application user where drop-down list box, choose one of the 
listed criteria.

Step 14 From the second Find application user where drop-down list box, choose one of 
the listed criteria,
4-21
Cisco Unified CCX Administration Guide, Release 8.5(1)

 



Chapter 4      Provisioning Unified CM for Unified CCX
Configuring Unified CM for Unified CCX
Step 15 Specify the appropriate search text, if applicable, and click Find. 

A list of discovered application users displays.

Step 16 From the list of records, click the application user name that matches your search 
criteria.

The window displays the application user that you choose.

Step 17 Repeat Step 7 and Step 8 for the selected Application User.

These steps ensure that the Unified CM application users are also defined as 
Unified CCX agents in Unified CM.

Step 18 Click Update to apply the changes. 

The specific Application Information page for this user appears, with the message 
that the update was successful.

See the “User Management Configuration" section in Cisco Unified 
Communications Manager Administration guide for detailed information on how 
to configure an End User and Application User using Unified CM.

Now that you have defined the agent in Unified CM, you can configure agents in 
Unified CCX (see Configuring Agents, page 8-10). Subsequent to that, you will 
also need to configure resource groups (see Configuring Resource Groups, 
page 8-4) and CSQs (see Creating a CSQ, page 8-18).

Related Topics

 • Guidelines for Configuring Agent Phones, page 4-14

 • Invoking Unified CM Administration, page 4-13

 • Configuring Agents, page 8-10

Configuring Tool for Auto-Registered Phones Support (TAPS)
The Tool for Auto-Registered Phone Support (TAPS) loads a preconfigured 
phone setting on a phone. The TAPS works in conjunction with the Bulk 
Administration Tool (BAT). After the BAT is used to bulk add phones with 
dummy MAC addresses to Cisco Unified Communications Manager Release 
8.5(1) (Unified CM) Administration, you can plug the phones into the network. 
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The administrator or the phones’ users can then dial a TAPS directory number that 
causes the phone to download its configuration. At the same time, the phone gets 
updated in the Unified CM database with the correct MAC address of the phone. 
Refer to Configuring the Bulk Administration Tool (BAT) if you are not familiar 
with the BAT.

For the TAPS to function, you must make sure that Auto-registration is enabled 
in Cisco Unified CM Administration (select System > Cisco Unified CM). 
Follow the instructions mentioned in the procedure below to install and configure 
TAPS application with Unified CCX 8.5(1). 

Procedure

Step 1 Login to Cisco Unified CM Administration Release 8.5(1) and choose 
Application > Plugins from the Cisco Unified CM Administration menu bar. 

Step 2 In the Find and List Plugins web page, search for “Cisco TAPS” and click Find. 

Step 3 Download the TAPS_AAR.aar file to your client PC, which is used for accessing 
Unified CM Administration and Unified CCX Administration.

Step 4 Install Unified CCX 8.5(1) using the procedure mentioned in Installing Cisco 
Unified Contact Center Express Release 8.5(1) Guide. Complete steps 1 to 15 
mentioned in “Performing the Initial Setup for a Deployment with Cisco Unified 
CM” section of the Installing Cisco Unified Contact Center Express Release 
8.5(1) Guide. 

Step 5 After completing Steps 1 to 15, do the following from User Configuration page in 
Unified CCX Administration:

a. In the Cisco Unified CM Users list box, select the Cisco Unified CM user 
whom you want to designate as the Cisco Unified CCX administrator and 
who can configure TAPS.

b. Click the left arrow (<) to move the selected user to the Cisco Unified CCX 
Administrator list box.

c. Click Finish. The Cisco Unified CCX Setup Result Information window 
displays. This window confirms the result of the initial setup. The Cisco 
Unified CCX engine will restart. 

d. Close your web browser.
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Step 6 Login to Cisco Unified CCX Administration as the Unified CCX application 
administrator, who can configure TAPS. After installing and configuring Unified 
CCX 8.5(1) and Unified CM, follow the procedure below to setup TAPS.

a. From the Unified CCX Administration menu bar, choose Applications > 
AAR Management. Click Browse button and upload the TAPS_AAR.aar 
file downloaded in Step 3 from Unified CM. 

b. On successful upload, you will see a confirmation message in the status bar 
on top of the AAR Management web page. 

Note For TAPS configuration, you need to restart the Unified CCX engine and Unified 
CCX Cluster View Daemon (CVD). You can restart the CVD using the CLI 
command - utils service <service name> stop/start. 

c. After restarting the CVD, login once again to Cisco Unified CCX 
Administration as the Unified CCX application administrator. From the 
Unified CCX Administration menu bar, choose Subsystems > Unified CM 
Telephony > Call Control Group. Click Add New and provide the Call 
Control Group Configuration values for TAPS using the following fields: 

 – Group ID

 – Number of CTI Ports

 – Media Termination Support

 – Device Name Prefix

 – Starting Directory Number 

d. From the Unified CCX Administration menu bar, choose Subsystems > 
Cisco Unified CM Telephony > Triggers. Click Add New and specify 
values for the following mandatory fields:

 – Directory Number 

 – Language

 – Application Name

 – Device Name

 – Description

 – Call Control Group: The call control group types can be Inbound or 
Outbound for Unified CCX running with Unified CM.
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e. Choose Subsystems > Cisco Unified CM Telephony > Data Resync from 
the Cisco Unified CCX Administration menu bar to check and resynchronize 
the JTAPI data between Cisco Unified CM and Cisco Unified CCX. 

f. From the Unified CCX Administration menu bar, choose Applications > 
Application Management. The Application Management web page opens 
displaying the details of existing applications. 

g. Click Add New icon or button. The Add a New Application web page opens.

h. From the Application Type drop-down menu, choose Cisco Script 
Application and click Next. The Cisco Script Application configuration web 
page opens.

i. In the Script field, select the script “/TAPS.aef” from the drop-down list and 
enter the IP address of the Cisco Unified CM in the text box below the Script 
drop-down list.

j. Check the check box against Cisco_Unified_CM_IP_Address field.

k. Click Yes radio button in the Enabled field.

l. Click Update.

m. Login to Cisco Unified CM Serviceability Page and restart the TAPS Service.
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Cisco Unified CCX 
 

C H A P T E R 5

Provisioning Unified CCX for Unified 
CME 

After you complete the initial setup of Unified CCX (see the Installation Guide 
for Cisco Unified CCX and Cisco Unified IP IVR, Release 8.5(1)), you will have 
identified the information that Unified CCX requires to provision Unified CME 
for Unified CCX (see Interoperability between Unified CCX and Unified CME, 
page 5-4). You can modify the Unified CME information from Unified CCX.

The following topics explain how to modify the Unified CME information from 
Unified CCX. 

 • Introducing Unified CME for Unified CCX, page 5-1

 • Verifying Licenses, page 5-5

 • Modifying Unified CME Information from Unified CCX, page 5-5

 • Configuring the AXL User in Unified CCX, page 5-6

 • Provisioning Unified CME Telephony Subsystem, page 5-7

 • Managing Unified CCX Users, page 5-14

 • Identifying Agent Directory Numbers, page 5-18

Introducing Unified CME for Unified CCX
Unified CCX enables interoperability with Unified CME, Release 4.2 and later. 
This interoperability allows for the following functions: 

 • Configuration query and update between Unified CCX and Unified CME. 
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 • SIP-based simple and supplementary call control services including call 
routing between Unified CME and Unified CCX using SIP-based route point. 

 • Unified CCX keep alive session management of Unified CME. 

 • Unified CCX device and call monitoring of agent lines and call activities in 
Unified CME.

 • Support of Unified CCX 8.5(1) Cisco Agent Desktop for use with Unified 
CME. 

This section includes the following topics:

 • Guidelines, page 5-2

 • Supported Features, page 5-3

 • Interoperability between Unified CCX and Unified CME, page 5-4

 • Unified CCX Provisioning Checklist, page 3-3

Guidelines
The following guidelines apply when using the Unified CME product for Unified 
CCX:

 • In the Unified CME Telephony subsystem the concept of CTI Ports does not 
exist. When a call is offered at a CME Telephony Route Point, the route point 
accepts the call. The call is not transferred to a CTI Port. 

 • The Unified CME Telephony subsystem only supports G711 codec prompts.

 • Unified CME Telephony users are stored locally in the Unified CCX 
Database.

 • Unified IP Phone Agents are limited to one Unified CCX for each Unified 
CME product.

 • The Unified CME Telephony subsystem supports only SCCP Phones as agent 
devices.

 • Only incoming calls from PSTN trunk are supported for deployment of the 
interoperability feature between Unified CME and Unified CCX. Other 
trunks, such as SIP and H.323, are supported as usual in Unified CME, 
however, not for customer calls to Unified CCX. For more information on 
deployment models, see Deployment Models, page 5-4
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Related Topics

 • Supported Features, page 5-3

 • Interoperability between Unified CCX and Unified CME, page 5-4

 • Unified CCX Provisioning Checklist, page 3-3

 • Configuring Unified CCX Applications, page 1-17

Supported Features
The following Unified CCX features are supported by the Unified CME product 
for Unified CCX:

 • Unified CCX as a whole

 • Limited CAD Functionality

 • Limited CSD Functionality

For more information on Unified CCX features that are not supported by the 
Unified CME offering, see the Release Notes for Cisco Unified Contact Center 
Express and Cisco Unified IP IVR, Release 8.5(1).

Related Topics

 • Guidelines, page 5-2

 • Interoperability between Unified CCX and Unified CME, page 5-4

 • Unified CCX Provisioning Checklist, page 3-3
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Interoperability between Unified CCX and Unified CME
Table 5-1 identifies the tasks to configure interoperability between Unified CCX 
and Unified CME.

Deployment Models

 • Examples of Supported Deployments: 

 • PSTN -- PRI -- CME -- UCCX

 • PSTN -- BRI -- CME -- UCCX

 • PSTN -- FXO/FXS -- CME -- UCCX

 • PSTN -- T1 CAS -- CME -- UCCX

Table 5-1 Tasks to Configure Interoperability between Unified CCX and Unified CME

Step Task Name of Document

1 Verify that the appropriate version of Unified CME is 
installed on the router. 

See the Configuring 
Interoperability with Cisco 
Unified CCX chapter in the 
Cisco Unified Communications 
Manager Express System 
Administrator Guide.

2 Configure the Unified CME router.

Tip Note the AXL user ID, password, and the 
router’s IP address.

3 Configure Unified CME to enable interoperability 
with Unified CCX.

4 Install Unified CCX for Unified CME. See the Installation Guide for 
Cisco Unified CCX and Cisco 
Unified IP IVR, Release 8.5(1). 

5 Launch the setup wizard on Unified CCX and go 
through the setup for the Unified CME. 

Tip When setup launches, you are asked for the 
AXL user ID and password that you created in 
Unified CME. You also need to enter the 
router IP address.

6 Configure Unified CME Telephony Subsystem to 
enable interoperability with Unified CCX.

Provided in this chapter of the 
Cisco Unified CCX 
Administration Guide.7 Create users and assign the agent capability to these 

users in Unified CCX.
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 • Examples of Unsupported Deployments: 

 • SIP Provider -- CME -- UCCX

 • Provider -- H.323 Trunk -- CME -- UCCX

Related Topics

 • Guidelines, page 5-2

 • Supported Features, page 5-3

 • Unified CCX Provisioning Checklist, page 3-3

Verifying Licenses 
Licenses are installed for the first time in the Unified CCX setup wizard. Once 
you have uploaded the licenses, the Unified CME Telephony Call Control Group 
is automatically created. 

Related Topics

 • Viewing License Information, page 1-14

 • Display Licenses, page 16-6

 • Add License(s), page 16-6

Modifying Unified CME Information from Unified CCX
During the Unified CCX setup process, the administrator provides the Unified 
CME IP address and host name(s) and the Administrative XML Layer (AXL) 
authentication (user ID and password) information. You can change this 
information at any time as required from Unified CCX. If you do change the 
information, you must provide the IP address of the AXL server to which you will 
move this server. 

Related Topics

 • Introducing Unified CME for Unified CCX, page 5-1

 • Verifying Licenses, page 5-5

 • Configuring the AXL User in Unified CCX, page 5-6
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 • Provisioning Unified CME Telephony Subsystem, page 5-7

 • Managing Unified CCX Users, page 5-14

 • Identifying Agent Directory Numbers, page 5-18

Configuring the AXL User in Unified CCX
To change previously-configured Unified CME setup information from Unified 
CCX, complete the following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose System > Cisco Unified 
CME Configuration.

The Unified CME Configuration web page opens. This page facilitates 
configuration of Unified CME server information, which is required to 
authenticate the AXL Service of the Unified CME server.

Step 2 Use this web page to specify the following fields.

-

Note The above-mentioned fields are mandatory.

Step 3 Click Update. 

Field Description

Unified CME server host 
name or IP address 

IP address or Host name of the Unified CME router. 

AXL User ID User name for the AXL server providing access to Unified CME. The user 
name is created on the Unified CME router.

AXL User Password The corresponding password for the user account providing access to 
Unified CME. The user name is created on the Unified CME router.
5-6
Cisco Unified CCX Administration Guide, Release 8.5(1)



Chapter 5      Provisioning Unified CCX for Unified CME
Provisioning Unified CME Telephony Subsystem
Unified CCX Administration enables that service and then tries to access the 
Unified CME information and updates the page. 

Provisioning Unified CME Telephony Subsystem
The Unified CCX Engine uses the Unified CME Telephony subsystem to open a 
logical session with Unified CME. This session verifies provider authentication, 
periodically exchanges heartbeats, and monitors Unified CME availability after 
successful authentication. The Unified CME Telephony subsystem is available 
with all Unified CCX license packages.

To enable your Unified CCX server to handle Cisco Unified Communications 
requests, you will need to provision the Unified CME Telephony subsystem.

From the Unified CCX Administration GUI, you can configure and update the 
Unified CME Telephony subsystem information. 

To provision the Unified CME Telephony subsystem, complete the following 
tasks:

Related Topics

 • Provisioning Unified CME Telephony Subsystem, page 5-7

Step Task For instructions, see

 1 Configure a Unified CME Telephony Provider, if not already 
configured. Specify the router on which Unified CME is running, 
and provide a Unified CME user ID and password.

Configuring a Unified 
CME Telephony 
Provider, page 5-9

 2 Validate Unified CME and Unified CCX versions. Validating Unified CME 
and Unified CCX Data, 
page 5-8

 3 Provision Unified CME Telephony call control groups. Modifying Unified CME 
Telephony Call Control 
Group, page 5-10

4 Provision a Unified CME Telephony trigger. Unified CME 
Telephony triggers invoke application scripts in response to 
incoming contacts.

Adding or Modifying a 
Unified CME Telephony 
Trigger, page 5-11
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 • Managing Unified CCX Users, page 5-14

 • Introducing Unified CME for Unified CCX, page 5-1

 • Verifying Licenses, page 5-5

 • Modifying Unified CME Information from Unified CCX, page 5-5

 • Configuring the AXL User in Unified CCX, page 5-6

 • Managing Unified CCX Users, page 5-14

 • Identifying Agent Directory Numbers, page 5-18

Validating Unified CME and Unified CCX Data
Use the validate tool when the configuration in Unified CCX and Unified CME 
are not synchronized. You can also use this tool to perform a comparison between 
the Unified CCX and Unified CME configurations. For example, if the router 
configuration does not match the configuration stored in the Unified CCX 
database, you can run the validate tool to verify the missing information.

Tip You can only run this tool when Unified CME is accessible from Unified CCX.

Caution This tool does not perform the resynchronization, it only points out the problems.

To validate the Unified CME and Unified CCX data, choose Subsystems > Cisco 
Unified CME Telephony > Validate Cisco Unified CME in Cisco Unified 
CCX from the Unified CCX Administration menu bar. The Validation Results 
web page opens, displaying the summary and status of the validation. 

Related Topics

 • Configuring a Unified CME Telephony Provider, page 5-9

 • Modifying Unified CME Telephony Call Control Group, page 5-10

 • Adding or Modifying a Unified CME Telephony Trigger, page 5-11
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Configuring a Unified CME Telephony Provider
The Unified CME Telephony provider opens a logical session with Unified CME 
to detect the state of the connection. This session verifies provider authentication, 
periodically exchanges heartbeats, and continues to monitor Unified CME 
availability after successful authentication. 

Absence of the heartbeats might be caused by various issues. See the 
Troubleshooting Wiki page: 
http://docwiki.cisco.com/wiki/Troubleshooting_Unified_Contact_Center_Expre
ss for more details.

The Unified CME Telephony Providers area of the Unified CME Telephony 
Configuration web page is a configurable page that displays the latest configured 
information.

To modify the Unified CME Telephony subsystem, complete the following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > Cisco 
Unified CME Telephony > Cisco Unified CME Telephony Provider. 

The Unified CME Telephony Configuration web page opens displaying the fields 
mentioned in the following table:

Field Description

Remote Cisco Unified 
CME Telephony Port 

Enter the SIP port number used by Unified CME to communicate with 
Unified CCX. This is a mandatory field and the default value is 5060.

Local Cisco Unified CME 
Telephony Port 

This read only field provides the port number of the available port in 
Unified CCX. The default value is 5062.

User Agent This read-only field provides a description of the owner for this 
connection. 

Keep Alive Interval If a keep alive message is not received for more than the time period 
specified in this field, then the connection between Unified CCX and 
Unified CME is considered broken. This is a mandatory field.

Session Server ID This read only field provides the auto-generated unique ID for the 
Unified CCX server.
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Step 2 Click Update icon that displays in the tool bar in the upper, left corner of the 
window or the Update button that displays at the bottom of the window to save 
the changes.

Related Topics

 • Validating Unified CME and Unified CCX Data, page 5-8

 • Modifying Unified CME Telephony Call Control Group, page 5-10

 • Adding or Modifying a Unified CME Telephony Trigger, page 5-11

Modifying Unified CME Telephony Call Control Group
The Unified CME Telephony call control group is automatically added based on 
license. It is created when you upload the license. The number of channel equals 
the licensed IVR ports.

The Unified CME Telephony Call Control Group Information web page is 
read-only and cannot be modified. 

Related Topics

 • Validating Unified CME and Unified CCX Data, page 5-8

 • Configuring a Unified CME Telephony Provider, page 5-9

 • Adding or Modifying a Unified CME Telephony Trigger, page 5-11

Transport Specify the required protocol to send the keep alive messages. This is a 
mandatory field and only the TCP Protocol is accepted.

Outbound Trigger DN This user-specified trigger must be created before the Unified CME 
Telephony triggers are created. Unified CCX uses this trigger to place 
calls outside of the Unified CCX. This is a mandatory field.

Field Description
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Adding or Modifying a Unified CME Telephony Trigger
Unified CME Telephony triggers define the route point to which a directory 
number is associated. A Unified CME Telephony trigger responds to calls that 
arrive on a specific route point by selecting telephony and media resources to 
serve the call and invoking an application script to handle the call. The Unified 
CME Telephony triggers are available with all Unified CCX license packages.

Unified CME Telephony trigger settings include:

 • Directory Number information, such as the Voice Mail Profile and Calling 
Search Space. 

 • Application information, such as the application name to associate with the 
trigger.

 • Session information, such as the application to associate with the trigger, 
Maximum Number of sessions allowed, and the Idle Timeout value.

To add or modify a Unified CME Telephony trigger, complete the following 
steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > Cisco 
Unified CME Telephony > Cisco Unified CME Telephony Triggers. 

The Unified CME Telephony Trigger Configuration web page opens.

Note You can access the Unified CME Telephony Configuration web page 
only when the Unified CCX Engine is running. 

Step 2 The following table describes the different fields on this page. 

 

Field Description

Directory Number A unique phone number.

Application Application name to associate with the trigger.

Sessions Maximum number of simultaneous calls that the trigger can handle. 

Enabled True if the trigger is enabled; False if the trigger is disabled.
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Step 3 Click Add New icon in the tool bar in the upper, left corner of the window or Add 
New button at the bottom of the window. To modify Unified CME Telephony 
trigger information for an existing record, click the specific record. 

Step 4 The Unified CME Telephony Trigger Configuration web page opens. Use this 
web page to add or update values in the following fields: 

Page Area Field Description

Directory 
Information

Directory Number A unique phone number. The value includes numeric 
characters, preceded or appended by the following special 
characters: 

# * [ ] X -

Examples of valid Directory Numbers: 
*#12#* or 12*23

Examples of invalid Directory Numbers: 
91X+, 91X?, 91!, 813510[^0-5] as it contains a character other 
than numerical and allowed special characters or 
8]90[-, as it doesn't conform with the rule that the square 
bracket ([ ]) characters enclose a range of values. This is a 
mandatory field.

Note See the Wild cards and Special Characters in Route 
Patterns and Hunt Pilots section in the Cisco Unified 
Communications Manager System Guide for more 
information. 

Trigger 
Information

Language Drop-down menu, choose the default language to associate 
with the incoming call when the application is started. This is a 
mandatory field.

Note To add a Language option, click Edit button. The User Prompt dialog box opens.
Enter a locale string value and click OK. The User Prompt dialog box closes, 
and the name of the language opens in the Language field in the Unified CME 
Telephony Configuration web page.

Application Name Drop-down menu, choose the application to associate with the 
trigger. This is a mandatory field.
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Advanced 
Trigger 
Information

(Click Show 
More to see 
these 
settings.)

Enabled Default = Enabled (Yes). Radio buttons, choose the required 
option: Yes - enable the trigger. No - disable the trigger.

Maximum Number of 
sessions

The maximum number of simultaneous calls that this trigger 
can handle. The number is actually governed by the Unified 
CM (10,000 for each separate line). However in Unified CCX, 
this number is restricted to the maximum number of sessions. 
Any call exceeding this number gets the busy tone.

Idle Timeout (in ms) Default = 5000ms. The number of milliseconds (ms) the system 
should wait before rejecting the Unified CME Telephony 
request for this trigger. 

Call Control Group Default = Media Termination. A read-only field displaying the 
call control group to associate with the trigger. To override this 
default, select Yes in the Override Media Termination field.By 
default, only one Unified CME Telephony Call Control Group 
is (Default Call Control Group) is created during the setup 
process. 

Override Media 
Termination

Radio buttons, choose the required option: Yes - Override 
media termination. No - Enable media termination.

Default = Media Termination. If you select Yes, two panes 
open: 

 • Selected Dialog Groups displays the default or selected 
group.

 • Available Dialog Groups lists the configured dialog 
groups. Use the left and right arrow to move the required 
dialog group to the Selected Dialog Group pane.

You can add dialog groups when adding a new dialog group via 
ASR/TTS. Only two dialog groups are allowed to be added to 
Unified CME deployment. 

Description Description of the trigger.

Call Control Group Displays the group type information in the drop down box for 
selecting the call control group.

Page Area Field Description
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Step 5 Click Add icon at the top of the page.

The Unified CME Telephony Trigger Configuration web page opens, and 
displays the new Unified CME Telephony trigger. 

To add a new Cisco Media Termination (CMT) dialog control group, click Add 
New CMT Dialog Control Group icon that displays in the tool bar in the upper, 
left corner of the window. The Cisco Media Termination Dialog Group 
Configuration web page opens. Follow the steps mentioned in Adding a CMT 
Dialog Control Group, page 7-24 for detailed instructions on how to add a new 
CMT dialog control group.

Related Topics

 • Validating Unified CME and Unified CCX Data, page 5-8

 • Configuring a Unified CME Telephony Provider, page 5-9

 • Modifying Unified CME Telephony Call Control Group, page 5-10

 • Adding a CMT Dialog Control Group, page 7-24

Managing Unified CCX Users
Unlike Unified CM users, Unified CCX users on Unified CME are configured and 
managed by Unified CCX.

A Unified CCX user on Unified CME can be assigned one of the following 
Unified CCX capabilities: Administrator, Supervisor, Reporting, or Agent.

This section includes the following topics:

 • Assigning Capability Views to Unified CCX Users in a Unified CME 
Deployment, page 5-15

 • Creating New Unified CCX Users in a Unified CME Deployment, page 5-15

Related Topics

 • User Management Menu Option, page 20-12

 • About Unified CCX User Capabilities, page 15-2
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Assigning Capability Views to Unified CCX Users in a Unified 
CME Deployment

You can assign a capability after you create the Unified CME user or when you 
are creating the Unified CME user. To assign a capability when creating a Unified 
CME user, see Creating New Unified CCX Users in a Unified CME Deployment, 
page 5-15.

To assign a capability to a pre-existing Unified CME user in Unified CCX, 
complete the following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Tools > User 
Management > Administrator Capability View or Supervisor Capability 
View or Reporting Capability View or Agent Capability View.

The User Configuration web page displays with two panes. The pane on the right 
always displays the list of Available Users and the left pane changes to display 
the users assigned to the selected view.

Step 2 Change the users as required for each view using the arrow in either direction.

Your changes are displayed in this page and must be saved to the database. 

Step 3 Click Update icon that displays in the tool bar in the upper, left corner of the 
window or the Update button that displays at the bottom of the window to save 
the changes to the database

Step 4 Repeat this process as needed to assign the required capability for each user. 

See About Unified CCX User Capabilities, page 15-2 for detailed description of 
each roles.

Creating New Unified CCX Users in a Unified CME Deployment
You can create new Unified CME users from Unified CCX at any time. When 
creating these users, you can simultaneously assign the capability level. 
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To create a new Unified CME user and to assign a capability in Unified CCX, 
complete the following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Tools > User 
Management > User View.

The User Configuration web page opens.

Step 2 Click Create New User icon that displays in the tool bar in the upper, left corner 
of the window.

The User Configuration page reopens where you can specify values for the 
following fields:

Field Description

User ID Unique identifier for this new Unified CME user. This is a mandatory field.

First Name The first name for this new Unified CME user. 

Last Name The last name for this new Unified CME user. This is a mandatory field.

Name 
Dialing

An automatically generated field that concatenates the first and last name into a unique 
field to dial a name by function. 

Password This filed cannot be empty. The password requires at least five alphanumeric 
characters. This is a mandatory field.

Confirm 
Password

Retype the password assigned in the previous field. Do not copy and paste the 
password. This is a mandatory field.

PIN This filed cannot be empty. The pin is limited to five numbers and cannot be greater 
than 20 numbers. 

Confirm PIN Retype the pin assigned in the previous field. Do not copy and paste the pin. This is a 
mandatory field.

Capabilities
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Step 3 After entering the information in the fields/boxes, click Update icon that displays 
in the tool bar in the upper, left corner of the window or the Update button that 
displays at the bottom of the window.

The User Configuration page refreshes to dynamically display the newly-added 
Unified CME user. The capabilities for the newly-added user are effective 
immediately. 

Click Show More button to specify values for different fields related to General, 
Localization, and Organizational properties.

Step 4 Repeat this process as needed to assign other new users. 

Changing Passwords and Pins
The Unified CCX users in a Unified CME Deployment are configured and 
managed by Unified CCX. Therefore, in addition to the general privileges, a 
Unified CCX Application User (http://<Cisco Unified CCX IP 
address>/Appuser) has the following additional privileges:

 • Change password 

 • Change the pin 

 • Upload the spoken name 

To access the Unified CCX Supervisor web page, see Accessing the Unified CCX 
Supervisor Web Page, page 15-6.

Selected 
Capabilities 

The capability assigned for each Unified CME user is identified in this box. Use the 
arrow to assign the required capability for this new Unified CME user. If you wish to 
change the assigned capability at a later time, follow the procedure provided in the 
“Assigning Capability Views to Unified CCX Users in a Unified CME Deployment” 
section on page 5-15.

Available 
Capabilities

The list of capabilities that can be assigned for this new Unified CME user. Use the 
arrow in either direction to assign the required capability. 

Field Description
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Identifying Agent Directory Numbers
Directory numbers associated with Unified CCX agent phones must be 
configured in Unified CME. Identifying agent directory numbers in Unified CME 
is an ongoing task. See the Cisco Unified Communications Manager Express 
8.5(1) New Features document for more information.
5-18
Cisco Unified CCX Administration Guide, Release 8.5(1)



Cisco Unified CCX 
 

C H A P T E R 6

Configuring Cisco Applications

The Unified CCX system uses applications to interact with contacts and perform 
a wide variety of functions, such as prompting callers for information, 
transferring calls, and providing information to callers.

To configure Unified CCX applications, you must complete the following tasks:

 • Provision telephony and media resources (see Chapter 7, “Provisioning 
Telephony and Media”) 

 • Provision your Unified CCX subsystem, if required (see Chapter 8, 
“Provisioning Unified CCX”) 

 • Provision additional subsystems, if required (see Chapter 9, “Provisioning 
Additional Subsystems”)

The following sections describe how to configure applications and make them 
available to the Unified CCX system.

 • About Unified CCX Applications, page 6-1

 • Adding Application Triggers, page 6-18

 • Managing Scripts, page 6-25

About Unified CCX Applications
The Unified CCX system uses applications to interact with contacts and perform 
a wide variety of functions. 
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Note Unified CCX licenses you purchase and install determine the applications 
available on your system (see Application Management Menu Option, 
page 17-1).

Unified CCX provides the following application types:

 • Script (see Configuring Script Applications, page 6-2).

 • Busy (see Configuring Busy Application, page 6-7).

 • Ring-No-Answer (see Configuring Ring-No-Answer Application, page 6-9).

 • Remote Monitoring (see Configuring Remote Monitoring Application, 
page 6-16).

If Unified CCX is integrated with Unified ICME, you will also need to configure 
one or both of the following application types: 

 • Unified ICME post-routing (see Configuring Unified ICME Post-Routing 
Application, page 6-11).

 • Unified ICME translation-routing (see Configuring Unified ICME 
Translation-Routing Application, page 6-14).

Note If you are not using Cisco Unified Intelligent Contact Management 
Enterprise (Unified ICME) software, you do not need to configure 
Unified ICME post-routing and Unified ICME translation-routing 
applications. For information about these Unified ICME software 
features, see the Cisco Unified ICME Scripting and Media Routing Guide.

Related Topic

Unified CCX Licensing Packages, page A-1

Configuring Script Applications
The Unified CCX script applications are applications based on scripts created in 
the Unified CCX Editor. These applications come with every Unified CCX 
system and execute scripts created in the Unified CCX Editor 
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Use the Unified CCX Editor to create scripts that direct the Unified CCX system 
to automatically answer calls and other types of contacts, prompt callers for 
information, accept caller input, queue calls, distribute calls to available agents, 
place outbound calls, respond to HTTP requests, and send e-mail messages.

Note The Unified CCX system includes a number of sample scripts. For a description 
of these sample scripts, and for more information on creating scripts with the 
Unified CCX Editor, see the Cisco Unified CCX Scripting and Development 
Series: Volume 1, Getting Started with Scripts. In addition, a script repository is 
available at 
http://www.cisco.com/en/US/products/sw/custcosw/ps1846/products_implement
ation_design_guides_list.html. This repository provides some examples of 
scripting techniques that can leverage Unified CCX abilities.

Cisco script applications can make use of many components, such as scripts, 
pre-recorded prompts, grammars, languages, locales, and custom Java classes. 
For more information about these components, see Chapter 10, “Managing 
Prompts, Grammars, Documents, and Custom Files.”

Tip Upload these components to the Repository before you configure a Cisco script 
application that uses them. 

Depending on your particular Unified CCX implementation, you may need to 
perform most or all of the following tasks to configure a Cisco script application:

1. Manage scripts. Cisco script applications are based on scripts that you must 
upload to the repository and make available to the Unified CCX system.

2. Manage prompts. Many applications make use of pre-recorded prompts, 
stored as .wav files, which are played back to callers to provide information 
and elicit caller response. You must upload these .wav files to the repository 
and make them available to the Unified CCX system.

3. Install grammars. The Unified CCX system uses specific grammars to 
recognize and respond to caller response to prompts. You must store these 
grammars in a directory to make them available to the Unified CCX system.
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4. Install customized Unified CCX languages. Language packs, such as 
American English, Canadian French, and so on, are installed with Unified 
CCX. You install language packs in a directory accessible by the Unified 
CCX system.

5. Install Java files. In addition to the Java files automatically installed as part 
of the Unified CCX installation process, you can install your own custom 
classes and Java Archive (JAR) files to customize the performance of your 
Unified CCX system.

6. Add a Cisco script application. Scripts created in the Unified CCX Editor are 
used as the basis for Cisco script applications.

7. Add an application trigger. Triggers are specified signals that invoke 
application scripts in response to incoming contacts. After adding a new 
Cisco script application, you need to add a trigger so that this application can 
respond to telephone calls and HTTP requests.

To add a new Cisco script application, complete the following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Applications > 
Application Management. 

The Application Management web page opens displaying the details of existing 
applications, if any.

Step 2 Click Add New icon that displays in the tool bar in the upper, left corner of the 
window or the Add New button that displays at the bottom of the window.

The Add a New Application web page opens 

Step 3 From the Application Type drop-down menu, choose Cisco Script Application 
and click Next.

The Cisco Script Application configuration web page opens. 

Step 4 Use this web page to specify the following fields. 
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Field Description

Name A name for the application. This is a mandatory field.

ID Accept the automatically-generated ID, or enter a unique ID. This is a 
mandatory field.

Note The Historical Reporting feature uses this ID to identify this 
application. 

Maximum Number Of 
Sessions

The maximum amount of simultaneous sessions (instances) that the 
application can handle. This is a mandatory field.

Note The limit for the maximum number of simultaneous remote 
monitoring sessions is 16, but the actual number depends on your 
system’s CPU and memory resources. Entering a number that is too 
high can result in unacceptable system performance.

Script Note This field is available only for Cisco Script Application type. This 
is a mandatory field.

Perform one of the following actions:

 • Choose a script from the drop-down list to run the application. If the 
script contains parameters, the parameters display below the Script 
drop-down menu. Each parameter has a check box, which enables you 
to override the default value for that parameter. If you want to override 
the value, check the check box for that parameter.

Note All scripts under the default directory are listed in the drop-down 
list of the Script field in the Cisco Script Application Configuration 
page.

 • Click Edit, enter the script name in the dialog box, and click OK. The 
User Prompt dialog box closes, and the name you entered appears in 
the Script field.

Note If you enter the script name as a file URL, enter the value with 
double backslashes (\\). For example, file://c:\\temp\\aa.aef

Description Use the Tab key to automatically populate this field.

Note For the Busy and Ring-No-Answer application types, this field is 
only visible when you click Show More.
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Step 5 Click Add. 

The Cisco Script Application page refreshes, the Add New Trigger hyperlink 
appears in the left navigation bar, and the following message is displayed in the 
status bar on top:

The operation has been executed successfully.

Click Back to Application List icon or button to view the list of existing 
applications. 

Step 6 Your next step is to add a trigger for the application (see Adding Application 
Triggers, page 6-18).

Related Topics

 • About Unified CCX Applications, page 6-1

 • Configuring Busy Application, page 6-7

 • Configuring Ring-No-Answer Application, page 6-9

 • Configuring Remote Monitoring Application, page 6-16

 • Configuring Unified ICME Post-Routing Application, page 6-11

 • Configuring Unified ICME Translation-Routing Application, page 6-14

Enabled Click the required radio button to accept (Yes = default) or reject (No)

Note For the Busy and Ring-No-Answer application types, this field is 
only visible when you click Show More.

Default Script Note This field is available only for Cisco Script Application type. 

The default script executes when an error occurs with the configured script 
application that causes it to abort.

Perform one of the following actions:

 • Choose a script from the drop-down list to run the application. If a 
Default Script is not defined, the internal system default is executed. 

 • Click Edit, specify a script in the dialog box that appears, and click 
OK. 

Field Description
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Configuring Busy Application 
This application, which comes with every Unified CCX system, plays a busy 
signal.

Note The Cisco Busy application comes with each Unified CCX system.

The Cisco Busy application returns a busy signal when a call reaches a Computer 
Telephony Interface (CTI) route point and the extension is busy.

To configure the Busy application, you will need to perform the following tasks:

1. Add the Busy application.

2. Add a Unified CM Telephony trigger to the Busy application. The Busy 
application is activated when it is triggered by a Unified CM Telephony 
trigger. The Busy application does not support HTTP triggers.

To configure the Unified CCX server with the Busy application, complete the 
following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Applications > 
Application Management. 

The Application Management web page opens displaying the details of existing 
applications, if any.

Step 2 Click Add New icon that displays in the tool bar in the upper, left corner of the 
window or the Add New button that displays at the bottom of the window.

The Add a New Application web page opens 

Step 3 From the Application Type drop-down menu, choose Busy, and then click Next.

The Busy Application Configuration web page appears.
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Step 4 Use this web page to specify the following fields. 

Step 5 Click Add.

The Busy web page refreshes, the Add New Trigger hyperlink appears in the left 
navigation bar, and the following message is displayed in the status bar on top:

The operation has been executed successfully

Step 6 Your next step is to add a trigger for the application (see Adding Application 
Triggers, page 6-18).

Related Topics

 • About Unified CCX Applications, page 6-1

 • Configuring Script Applications, page 6-2

 • Configuring Ring-No-Answer Application, page 6-9

 • Configuring Remote Monitoring Application, page 6-16

 • Configuring Unified ICME Post-Routing Application, page 6-11

Field Description

Name A name for the application. This is a mandatory field.

ID Accept the automatically-generated ID, or enter a unique ID. This is a 
mandatory field.

Note The Historical Reporting feature uses this ID to identify this 
application. 

Maximum Number Of 
Sessions

The maximum amount of simultaneous sessions (instances) that the 
application can handle.

Note The limit for the maximum number of simultaneous remote 
monitoring sessions is 16, but the actual number depends on your 
system’s CPU and memory resources. Entering a number that is too 
high can result in unacceptable system performance.

The following fields are displayed only on click of Show More button

Description Use the Tab key to automatically populate this field.

Enabled (Radio button) Accept Yes (the default).
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 • Configuring Unified ICME Translation-Routing Application, page 6-14

Configuring Ring-No-Answer Application 
This application, which comes with each Unified CCX system, plays a ring tone.

Note The Cisco Ring-No-Answer application comes with each Unified CCX system.

The Cisco Ring-No-Answer application returns a ring tone signal when a call 
reaches a CTI route point.

To configure the Ring-No-Answer application, you will need to perform the 
following tasks:

1. Add the Ring-No-Answer application.

2. Add a Unified CM Telephony trigger to the Ring-No-Answer application. 
The Ring-No-Answer application is activated when it is triggered by a 
Unified CM Telephony trigger.

To configure the Unified CCX server with the Ring-No-Answer application, 
complete the following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Applications > 
Application Management. 

The Application Management web page opens displaying the details of existing 
applications, if any.

Step 2 Click Add New icon that displays in the tool bar in the upper, left corner of the 
window or the Add New button that displays at the bottom of the window.

Step 3 From the Application Type drop-down menu, choose Ring-No-Answer, and then 
click Next.

The Ring-No-Answer web page opens.
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Step 4 Use this web page to specify the following fields. 

Step 5 Click Add.

The Ring-No-Answer web page refreshes, the Add New Trigger hyperlink 
appears in the left navigation bar, and the following message is displayed in the 
status bar on top:

The operation has been executed successfully

Step 6 Your next step is to add a trigger for the application (see Adding Application 
Triggers, page 6-18).

Related Topics

 • About Unified CCX Applications, page 6-1

 • Configuring Script Applications, page 6-2

 • Configuring Busy Application, page 6-7

Field Description

Name A name for the application. This is a mandatory field.

ID Accept the automatically-generated ID, or enter a unique ID. This is 
a mandatory field.

Note The Historical Reporting feature uses this ID to identify this 
application. 

Maximum Number Of Sessions The maximum amount of simultaneous sessions (instances) that the 
application can handle. This is a mandatory field.

Note The limit for the maximum number of simultaneous remote 
monitoring sessions is 16, but the actual number depends on 
your system’s CPU and memory resources. Entering a 
number that is too high can result in unacceptable system 
performance.

The following fields are displayed only on click of Show More button

Description Use the Tab key to automatically populate this field.

Enabled (Radio button) Accept Yes (the default).
6-10
Cisco Unified CCX Administration Guide, Release 8.5(1)



Chapter 6      Configuring Cisco Applications
About Unified CCX Applications
 • Configuring Ring-No-Answer Application, page 6-9

 • Configuring Unified ICME Translation-Routing Application, page 6-14

Configuring Unified ICME Post-Routing Application
These applications are used by the Unified IP IVR system to receive calls directly 
from Unified CM, which sends the call to the post-routing route point on the 
Unified CCX system.

Note The Unified ICME Post-routing application comes with Unified IP IVR.

Unified ICME post-routing applications use the Unified CCX server as a queue 
point for Unified ICME. In Unified ICME post-routing, the Unified IP IVR 
system receives calls directly from Unified CM, which sends the call to the 
post-routing route point on the Unified CCX system. 

If you configure this route point to run an initial application, such as an 
application to welcome the caller and collect an account number, the Unified 
CCX system notifies the Unified ICME software about the call, and then waits for 
further instructions. If you do not configure an initial script, the Unified CCX 
system informs the Unified ICME software about the call, but takes no other 
action.

After notification, the Unified ICME system runs a script, which can be composed 
of many different call-handling steps, including three commands that can be sent 
to the Unified CCX system:

 • Connect—This request is automatically sent by Unified ICME whenever an 
agent is available and the call can be connected to that agent.

 • Release—This request releases the call.

 • Run VRU Script—This request runs the VRU script.

Note Before you can configure a Unified ICME post-routing application, 
you must first upload any VRU scripts that the application will need 
(see Provisioning Unified ICME Subsystem, page 9-3).
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To configure a Unified ICME post-routing application, you will need to perform 
the following tasks:

1. Add a Unified ICME post-routing application. In addition to configuring 
general information such as name and ID, you must specify the script on 
which the Unified ICME post-routing application is based.

2. Add a Unified CM Telephony trigger to the Unified ICME post-routing 
application. The Unified ICME post-routing application is invoked by a 
Unified CM Telephony trigger. The Unified ICME post-routing application 
does not support HTTP triggers.

To configure the Unified CCX server with the post-routing application and to add 
a Unified CM Telephony trigger, complete the following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Applications > 
Application Management. 

The Application Management web page opens displaying the details of existing 
applications, if any.

Step 2 Click Add New icon that displays in the tool bar in the upper, left corner of the 
window or the Add New button that displays at the bottom of the window. 

Step 3 From the Application Type drop-down menu, choose Unified ICME 
Post-Routing.

The Unified ICME Post-Routing configuration web page opens.

Step 4 Use this web page to specify the following fields. 

Field Description

Name A name for the application.

Description Use the Tab key to automatically populate this field.

ID Accept the automatically-generated ID, or enter a unique ID.

This ID is the service identifier that will be reported with the call back to 
Unified ICME. 
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Step 5 Click Add.

The Unified ICME Post-Routing web page refreshes, the Add New Trigger 
hyperlink appears in the left navigation bar, and the following message is 
displayed in the status bar on top:

The operation has been executed successfully

Step 6 Your next step is to add a trigger for the application (see Adding Application 
Triggers, page 6-18).

Related Topics

 • About Unified CCX Applications, page 6-1

 • Configuring Script Applications, page 6-2

Maximum Number Of 
Sessions

The maximum amount of simultaneous sessions (instances) that the 
application can handle.

Note The limit for the maximum number of simultaneous remote 
monitoring sessions is 16, but the actual number depends on your 
system’s CPU and memory resources. Entering a number that is too 
high can result in unacceptable system performance.

Enabled (Radio button) Accept Yes (the default).

Timeout (in seconds) The maximum amount of time (in seconds) that the system will wait to 
invoke the application before rejecting a contact.

Initial Script (Drop-down list) Choose a script to run when the Unified CCX receives a 
call. 

This script can be used to acquire initial digits from the caller and report 
the information to Unified ICME as part of the notification of the incoming 
call. This capability allows Unified ICME to correctly choose a Unified 
ICME script to serve the call.

Default Script (Drop-down list) Choose a script to run to route a call to a default treatment 
in the event of a:

 • System error 

 • Request by Unified ICME

Field Description
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 • Configuring Busy Application, page 6-7

 • Configuring Ring-No-Answer Application, page 6-9

 • Configuring Remote Monitoring Application, page 6-16

 • Configuring Unified ICME Post-Routing Application, page 6-11

 • Provisioning Unified ICME Subsystem, page 9-3

Configuring Unified ICME Translation-Routing Application 
These applications use the Unified CCX server as a queue point for Unified IP 
IVR, so that Unified ICME can route calls to the Unified CCX server.

Note The Unified ICME Translation-routing application comes with Unified IP IVR.

You must configure Unified ICME translation-routing applications when the 
Unified CCX server is used as a queue point for a Unified CCX solution in which 
calls are expected to be routed by the Unified ICME to the Unified CCX server. 

The call attributes will be reported as part of a configured translation-route on the 
Unified ICME.

Note Before you can configure a Unified ICME translation-routing application, you 
must first upload any VRU scripts that the application will need (see Provisioning 
Unified ICME Subsystem, page 9-3).

To configure the Unified ICME translation-routing application, you will need to 
perform the following tasks:

1. Add a Unified ICME translation-routing application.

In addition to configuring general information such as name and ID, you must 
specify the script on which the Unified ICME translation-routing application 
is based.

2. Add a Unified CM Telephony trigger to the Unified ICME translation-routing 
application.

The Unified ICME translation-routing application is invoked by a Unified 
CM Telephony trigger, and does not support HTTP triggers.
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To configure the Unified CCX server with a Unified ICME translation-routing 
application and to add a Unified CM Telephony trigger, complete the following 
steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Applications > 
Application Management.

The Application Management web page opens displaying the details of existing 
applications, if any.

Step 2 Click Add New icon that displays in the tool bar in the upper, left corner of the 
window or the Add New button that displays at the bottom of the window. 

The Add a New Application web page opens. 

Step 3 From the Application Type drop-down menu, choose Unified ICME 
Translation-Routing.

The Unified ICME Translation-Routing configuration web page opens. 

Step 4 Use this web page to specify the following fields.

Field Description

Name A name for the application.

Description Use the Tab key to automatically populate this field.

ID Accept the automatically-generated ID, or enter a unique ID.

This field corresponds to the service identifier of the call reported to the 
Unified ICME and configured in the Unified ICME translation route. 

Maximum Number Of 
Sessions

The maximum amount of simultaneous sessions (instances) that the 
application can handle.

Note The limit for the maximum number of simultaneous remote 
monitoring sessions is 16, but the actual number depends on your 
system’s CPU and memory resources. Entering a number that is too 
high can result in unacceptable system performance.

Enabled (Radio button) Accept Yes (the default).
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Step 5 Click Add.

The Unified ICME Translation Routing web page refreshes, the Add New 
Trigger hyperlink appears in the left navigation bar, and the following message 
is displayed in the status bar on top:

The operation has been executed successfully

Step 6 Your next step is to add a trigger for the application (see Adding Application 
Triggers, page 6-18).

Related Topics

 • About Unified CCX Applications, page 6-1

 • Configuring Script Applications, page 6-2

 • Configuring Busy Application, page 6-7

 • Configuring Remote Monitoring Application, page 6-16

 • Configuring Unified ICME Post-Routing Application, page 6-11

 • Configuring Unified ICME Translation-Routing Application, page 6-14

 • Provisioning Unified ICME Subsystem, page 9-3

Configuring Remote Monitoring Application 
This application, available when you purchase Unified CCX Premium, allows a 
supervisor to monitor an agent’s conversation.

Timeout (in seconds) The maximum amount of time (in seconds) that the system will wait to 
invoke the application before rejecting a contact.

Default Script (Drop-down list) Choose a script to run to route a call to a default treatment 
in the event of a:

 • System error 

 • Request by Unified ICME

Field Description
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Note The Remote Monitoring application comes with Unified CCX Premium systems.

You must configure Remote Monitoring applications when you want to use the 
Remote Monitoring feature to allow a supervisor to monitor an agent’s 
conversation.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Applications > 
Application Management and click Add New.

The Add a New Application web page opens. 

Step 2 Choose Cisco Script Application from the Application Type drop-down menu 
and click Next.

The Cisco Script Application web page appears.

Step 3 Use this web page to specify the following fields.

Field Description

Name A name for the application. This is a mandatory field.

ID Accept the automatically-generated ID, or enter a unique ID. This is a 
mandatory field.

Note The Historical Reporting feature uses this ID to identify this application.

Maximum Number 
of Sessions

The maximum amount of simultaneous sessions that monitoring sessions allow. 
This is a mandatory field.

Note The limit for the maximum number of simultaneous remote monitoring 
sessions is 16, but the actual number depends on your system’s CPU and 
memory resources. Entering a number that is too high can result in 
unacceptable system performance.

Script Select a customized Remote Monitor script or rmon.aef from the drop-down 
list.

Note A new set of fields appears for a remote monitoring script.

Description Use the Tab key to automatically populate this field.
6-17
Cisco Unified CCX Administration Guide, Release 8.5(1)

 



Chapter 6      Configuring Cisco Applications
Adding Application Triggers
Step 4 Click Add.

The Remote Monitoring web page refreshes displaying the following message 
below the Status bar and the Add New Trigger hyperlink appears on the left 
navigation bar:

The operation has been executed successfully

Your next step is to add a trigger for the application (see Adding Application 
Triggers, page 6-18).

Related Topics

 • About Unified CCX Applications, page 6-1

 • Configuring Script Applications, page 6-2

 • Configuring Busy Application, page 6-7

 • Configuring Ring-No-Answer Application, page 6-9

 • Configuring Unified ICME Post-Routing Application, page 6-11

 • Configuring Unified ICME Translation-Routing Application, page 6-14

Adding Application Triggers
After adding a new Cisco application, you need to add one or more triggers so 
that the application can respond to Unified CM/Unified CME Telephony calls and 
HTTP requests. 

Triggers are specified signals that invoke application scripts in response to 
incoming contacts. The Unified CCX system uses Unified CM/Unified CME 
Telephony triggers to trigger responses to telephone calls and HTTP triggers to 
respond to HTTP requests.

Enabled (Radio button) Accept Yes (the default).

Default Script Accept System Default. The default script is executed if an error occurs with 
the configured application script.

Field Description
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You can use either of two methods to add a trigger to an application: Add the 
trigger from the Cisco Application web page or add the trigger from the Unified 
CM/Unified CME Telephony or HTTP Triggers web pages available from the 
Subsystem menu.

This section contains the following procedures:

 • Adding a Unified CM/Unified CME Telephony Trigger, page 6-19

 • Adding an HTTP Trigger, page 6-21

Related Topics

 • About Unified CCX Applications, page 6-1

 • Managing Scripts, page 6-25

 • Provisioning Unified CM Telephony Subsystem, page 7-5

 • Provisioning Unified CME Telephony Subsystem, page 5-7

 • Provisioning HTTP Subsystem, page 9-10

Adding a Unified CM/Unified CME Telephony Trigger
You must add Unified CM/Unified CME Telephony triggers to invoke Cisco 
applications in response to incoming contacts. 

A Unified CM/Unified CME Telephony trigger responds to calls that arrive on a 
specific route point by selecting telephony and media resources to serve the call 
and invoking an application script to handle the call.

This section contains the following procedures:

 • Adding Unified CM/Unified CME Telephony Triggers from an Application 
Web Page, page 6-20

 • Adding Unified CM/Unified CME Telephony Triggers from Unified CCX, 
page 6-21

Related Topics

 • Adding a Unified CM/Unified CME Telephony Trigger, page 6-19

 • Provisioning Unified CM Telephony Subsystem, page 7-5

 • Provisioning Unified CME Telephony Subsystem, page 5-7
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Adding Unified CM/Unified CME Telephony Triggers from an Application Web 
Page

To add a Unified CM/Unified CME Telephony trigger directly from the Cisco 
Application configuration web page, complete the following steps.

Procedure

Step 1 From the configuration web page for the application you want to add a trigger for, 
click Add New Trigger.

The Add a New Trigger window opens. 

Step 2 From the Trigger Type drop-down menu, choose Unified CM/Unified CME 
Telephony and click Next.

The Unified CM//Unified CME Telephony Trigger Configuration window opens. 

Step 3 Follow the procedure described in Adding a Unified CM Telephony Trigger, 
page 7-16.

Related Topics

 • About Unified CCX Applications, page 6-1

 • Adding a Unified CM/Unified CME Telephony Trigger, page 6-19

 • Adding an HTTP Trigger, page 6-21

 • Provisioning Unified CM Telephony Subsystem, page 7-5

 • Provisioning Unified CME Telephony Subsystem, page 5-7

 • Configuring HTTP Triggers, page 9-11
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Adding Unified CM/Unified CME Telephony Triggers from Unified CCX

To add a Unified CM/Unified CME Telephony trigger to an application from the 
Unified CM/Unified CME Telephony subsystem, complete the following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > Unified 
CM/Unified CME Telephony > Triggers.

The respective Unified CM or Unified CME Telephony Trigger Configuration 
summary web page opens. 

Step 2 Click Add New icon that displays in the tool bar in the upper, left corner of the 
window or the Add New button that displays at the bottom of the window. 

Step 3 The Cisco Unified CM Telephony Trigger Configuration web page opens. Follow 
the procedure described in Adding a Unified CM Telephony Trigger, page 7-16 
(Steps 3 and 4) for detailed instructions on adding and configuring a Unified CM 
Telephony trigger.

Related Topics

 • About Unified CCX Applications, page 6-1

 • Adding Application Triggers, page 6-18

 • Adding a Unified CM/Unified CME Telephony Trigger, page 6-19

 • Adding an HTTP Trigger, page 6-21

 • Provisioning Unified CM Telephony Subsystem, page 7-5

 • Provisioning Unified CME Telephony Subsystem, page 5-7

 • Configuring HTTP Triggers, page 9-11

Adding an HTTP Trigger
A Cisco application can be used to handle HTTP requests when the Unified CCX 
system is provisioned with an HTTP trigger. 
6-21
Cisco Unified CCX Administration Guide, Release 8.5(1)

 



Chapter 6      Configuring Cisco Applications
Adding Application Triggers
Note HTTP triggers are available if your system has a license installed for one of the 
following Cisco product packages: Unified IP IVR or Unified CCX Premium.

An HTTP trigger is the relative URL a user enters into the client browser to start 
the application. You can upload either eXtensible Style Language Transformation 
(XSLT) templates or Java Server Pages (JSP) templates to serve as your HTTP 
trigger.

The following path is an example of an HTTP-triggered request (using the HTTP 
trigger name “/hello”):

http://www.appserver.acme.com:9080/hello

In this example, the URL starts the application with the HTTP trigger “/hello” on 
a web server running on port 9080 with the host name www.appserver.acme.com.

You can add the HTTP trigger from the Cisco Script Application web page or add 
the trigger from the HTTP subsystem.

This section contains the following procedures:

 • Adding HTTP Triggers from an Application Web Page, page 6-22

 • Adding HTTP Triggers from the HTTP Subsystem, page 6-24

Adding HTTP Triggers from an Application Web Page

To add an HTTP trigger directly from a Cisco Application Configuration web 
page, complete the following steps.

Procedure

Step 1 From the configuration web page for the application you want to add a trigger for, 
click Add New Trigger hyperlink.

The Add a New Trigger window opens. 
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Step 2 From the Trigger Type drop-down menu, select HTTP and click Next.

The HTTP Trigger Configuration window opens.

Step 3 Use this web page to specify the following fields.

Step 4 Click Add. 

The Cisco Application Configuration web page appears, and the URL of the 
HTTP trigger appears on the navigation bar.

Step 5 Test the trigger by entering the URL you just configured in the address bar of your 
browser.

For example, 

/hello

The browser should display “hello”. 

Field Description

URL The relative URL

For example:

/hello

Language Perform one of the following actions:

 • Choose a default language from the drop-down list.

 • Click Edit, specify a default language in the dialog box that appears, 
and click OK. 

Maximum Number Of 
Sessions

The maximum amount of simultaneous sessions that can be served by the 
HTTP subsystem for this trigger.

 Idle Timeout (in ms) Maximum amount of time (in milliseconds) that the system will wait to 
invoke the application before rejecting a contact.

Enabled (Radio button) Accept Yes (the default).

Note If you disable the trigger, the user receives an error message when 
browsing to the defined trigger URL.
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Related Topics

 • About Unified CCX Applications, page 6-1

 • Adding a Unified CM/Unified CME Telephony Trigger, page 6-19

 • Adding an HTTP Trigger, page 6-21

 • Provisioning Unified CM Telephony Subsystem, page 7-5

 • Configuring HTTP Triggers, page 9-11

Adding HTTP Triggers from the HTTP Subsystem 

To configure a HTTP trigger from the HTTP subsystem, complete the following 
steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > HTTP. 

The HTTP Trigger Configuration web page opens.

Step 2 Click Add New icon that displays in the tool bar in the upper, left corner of the 
window or the Add New button that displays at the bottom of the window.

The HTTP Trigger Configuration window opens. 

Step 3 Use this web page to specify the following mandatory fields.

Field Description

URL The relative URL

For example:

/hello

Language Perform one of the following actions:

 • Choose a default language from the drop-down list.

 • Click Edit, specify a default language in the dialog box that appears, 
and click OK. 

Application Name Choose the name of the Application from the drop-down list.

Maximum Number Of 
Sessions

The maximum amount of simultaneous sessions that can be served by the 
HTTP subsystem for this trigger.
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Step 4 Click Add. 

The Cisco Application Configuration web page appears, and the URL of the 
HTTP trigger appears on the navigation bar.

Step 5 To test the trigger, enter the URL you just configured in the address bar of your 
browser.

For example, 

/hello

The browser should display “hello”. 

Related Topics

 • About Unified CCX Applications, page 6-1

 • Adding a Unified CM/Unified CME Telephony Trigger, page 6-19

 • Adding an HTTP Trigger, page 6-21

 • Provisioning Unified CM Telephony Subsystem, page 7-5

 • Configuring HTTP Triggers, page 9-11

Managing Scripts
Scripts are created with the Unified CCX Editor, and can perform a wide variety 
of functions. For example, scripts can prompt callers for extension numbers to 
transfer calls, place callers in a queue and route calls to available agents, and place 
outbound calls.

Idle Timeout (in ms) Maximum amount of time (in milliseconds) that the system will wait to 
invoke the application before rejecting a contact.

Enabled Click the required radio button to accept - Yes (the default) 

Note If you disable the trigger, the user receives an error message when 
browsing to the defined trigger URL.

Field Description
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The Script Management option of the Applications menu of the Unified CCX 
Administration web interface contains options for managing and refreshing 
Unified CCX scripts that are stored in the repository. 

Note Your Unified CCX system includes sample scripts stored as .aef files. For a 
description of these scripts, see the “Sample Scripts” section on page 6-34.

This section contains the following procedures:

 • Uploading New Scripts, page 6-26

 • Viewing or Downloading a Script File, page 6-28

 • Refreshing Scripts, page 6-30

 • Renaming a Script or Folder, page 6-32

 • Deleting a Script or Folder, page 6-33

 • Sample Scripts, page 6-34

 • Wizards Menu, page 19-1

Caution If a large number of VRU scripts are configured for your system, the Upload a 
New Script and Refresh Scripts operations can take a long time to complete. 
These tasks can also result in high CPU utilization.

Related Topics

 • About Unified CCX Applications, page 6-1

 • Adding Application Triggers, page 6-18

Uploading New Scripts
To make a script available for use as a Unified CCX application, you must first 
upload the script to the repository.

In Unified CCX Release 4.5 and later, uploaded scripts are stored in the 
Repository Datastore (RDS) database, along with prompts, grammars, and 
documents files. Prior to Release 4.5, the RDS database only contained the 
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prompts, grammars, and documents files. The scripts can also be grouped into 
folders and subfolders. When user scripts are uploaded into repository, they get 
synchronized to local disk and are accessed from there. 

To upload a script to the repository, complete the following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Applications > Script 
Management.

The Script Management page opens. 

Note The Script Management page allows you to only work with user scripts; 
it does not have language-based directories.

The following table describes the available columns on the Script Management 
web page.

Field Description

Folder Path The level of the directory that is currently selected in the folder drop-down list.

Name The name of the script.

Note Click the icon in front of the script name to download the script file. 

Size The size of the script file prefixed with KB. The file size is converted from bytes to 
KB. 

Note This column is usually blank on the root page as the items on this page are 
usually folders.

Date Modified The date and time when the document was last uploaded or changed along with time 
zone.

Modified by The user ID of the person who performed these modifications.

Delete To delete the corresponding folder.

Caution When you delete a folder, you permanently remove it from the repository 
and make it unavailable to the Unified CCX system.
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Step 2 Click Upload New Scripts icon that displays in the tool bar in the upper, left 
corner of the window or the Upload New Scripts button that displays at the 
bottom of the window.

Step 3 The Upload Script dialog box opens. 

Step 4 To locate the script, click Browse button next to the File Name field, navigate to 
the directory in which the scripts are located, select a script, and click Open. The 
script path for the profile appears in the File Name field.

Step 5 Click Upload to upload the script to the repository.

A window opens, informing you that the script was successfully uploaded.

You are now ready to manage any existing scripts shown in the Script 
Management page (if necessary) or add prompts that may be useful to your 
applications.

Related Topics

 • About Unified CCX Applications, page 6-1

 • Viewing or Downloading a Script File, page 6-28

 • Refreshing Scripts, page 6-30

 • Renaming a Script or Folder, page 6-32

 • Deleting a Script or Folder, page 6-33

 • Sample Scripts, page 6-34

Viewing or Downloading a Script File
You can view or download any script file that appears in the list on the Script 
Management web page.

To view or download a script file, complete the following steps.

Rename To rename the required subfolder within the default folder. 

Refresh To refresh the corresponding script (see Individual Script Refresh, page 6-30).

Field Description
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Procedure

Step 1 From the Unified CCX Administration menu bar, choose Applications > Script 
Management.

Step 2 The Script Management page opens to display the contents of the default folder. 

Step 3 Click Download Script icon that appears before the Name of the script file you 
want to view or download.

The File Download dialog box opens.

Step 4 Perform one of the following tasks:

 • To view the script file, click Open.

The script file opens in the Unified CCX Editor.

 • To download the script file, click Save, and then follow the prompts to choose 
a directory and file name for the script file.

The file is saved to the specified directory.

Related Topics

 • About Unified CCX Applications, page 6-1

 • Uploading New Scripts, page 6-26

 • Refreshing Scripts, page 6-30

 • Renaming a Script or Folder, page 6-32

 • Deleting a Script or Folder, page 6-33

 • Sample Scripts, page 6-34
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Refreshing Scripts

Caution If a large number of VRU scripts are configured for your system, the Upload a 
New Script and Refresh Scripts operations can take a long time to complete. 
These tasks can also result in high CPU utilization.

When you make changes to a script, you must refresh the script to direct all the 
applications and subsystems that use this script to reload the new version. There 
are two script refresh options:

 • Individual Script Refresh

 • Bulk Script Refresh

Individual Script Refresh

To refresh an individual script on the Unified CCX server from the repository 
(RDS), complete the following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Applications > Script 
Management.

The Script Management page opens to display the contents of the default folder.

Step 2 In the row that contains the script, click Refresh icon.

The script information refreshes and the Script Management page reappears. 

Related Topics

 • About Unified CCX Applications, page 6-1

 • Uploading New Scripts, page 6-26

 • Viewing or Downloading a Script File, page 6-28

 • Refreshing Scripts, page 6-30

 • Renaming a Script or Folder, page 6-32
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 • Deleting a Script or Folder, page 6-33

 • Sample Scripts, page 6-34

Bulk Script Refresh

Note Support for High Availability and remote servers is available only in 
multiple-server deployments.

Bulk scripts refers to multiple .aef script files within one .zip file. 

Note This option is available only when you upload .zip files. You will see the option 
to refresh scripts after the selected file is uploaded successfully.

To refresh all scripts (within a zip file) with one command, complete the 
following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Applications > Script 
Management.

The Script Management page opens to display the contents of the default folder. 

Step 2 Click Upload New Scripts icon or button. 

Step 3 The Upload Script dialog box opens. 

Step 4 To locate the script, click Browse button next to the File Name field, navigate to 
the directory in which the scripts are located, select a file, and click Open. The 
script path for the profile appears in the File Name field.

Tip You can only upload .zip files containing .aef files. The total size of 
the.zip file cannot exceed 20 MB.

Step 5 Click Upload to upload the script to the repository.

A window opens, informing you that the script upload succeeded.
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Step 6 Click Refresh icon in the Script Management page. 

The Script Management web page opens, giving you the option of refreshing the 
script and the applications that reference it, or just refreshing the script.

Step 7 Specify one of the following options:

 • If you want all applications and subsystems that reference the script (in the 
repository) to use the new version, click Yes.

 • If you only want to refresh the scripts, click No.

 • If you want to cancel the operation, click Cancel. 

The script information refreshes and the Script Management page reappears to 
display the newly-loaded .zip file.

Related Topics

 • About Unified CCX Applications, page 6-1

 • Uploading New Scripts, page 6-26

 • Viewing or Downloading a Script File, page 6-28

 • Refreshing Scripts, page 6-30

 • Renaming a Script or Folder, page 6-32

 • Deleting a Script or Folder, page 6-33

 • Sample Scripts, page 6-34

Renaming a Script or Folder
To rename a script, complete the following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Applications > Script 
Management.

The Script Management page opens to display the contents of the default folder. 

Step 2 Click Rename icon for the folder or script that you want to rename. A dialog box 
opens displaying the name of the selected folder or script. 
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Step 3 Enter a new name for this folder or script in the text box. 

Step 4 Click Rename button. 

The dialog box refreshes to state that the folder was successfully renamed.

Step 5 Click Return to Script Management button. 

The dialog box closes and the default folder’s updated Script Management page 
displays the new script name.

Related Topics

 • About Unified CCX Applications, page 6-1

 • Uploading New Scripts, page 6-26

 • Viewing or Downloading a Script File, page 6-28

 • Refreshing Scripts, page 6-30

 • Deleting a Script or Folder, page 6-33

 • Sample Scripts, page 6-34

Deleting a Script or Folder
When you delete a script or a folder, you remove it permanently from the 
repository.

To delete a script or folder, complete the following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Applications > Script 
Management.

The Script Management page opens to display the contents of the default folder. 

Step 2 To delete a folder, click Delete icon for the folder or script that you want to delete.

Step 3 A dialog box opens to confirm your action on the selected script or folder. Click 
OK.
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The dialog box closes and the default folder’s updated Script Management page 
refreshes to display the updated list of folders and scripts.

Related Topics

 • About Unified CCX Applications, page 6-1

 • Uploading New Scripts, page 6-26

 • Viewing or Downloading a Script File, page 6-28

 • Refreshing Scripts, page 6-30

 • Renaming a Script or Folder, page 6-32

 • Deleting a Script or Folder, page 6-33

 • Sample Scripts, page 6-34

Sample Scripts
Your Unified CCX system includes sample scripts stored as .aef files. These 
scripts have been built using Unified CCX Editor steps, including pre-recorded 
prompts. You can use these scripts to create applications without performing any 
script development, or you can use these scripts as models for your own 
customized scripts.

Note The included scripts are bundled with the Unified CCX system solely as samples, 
they are not supported by Cisco. For more information on these sample scripts, 
see the Cisco Unified CCX Scripting and Development Series: Volume 1, Getting 
Started with Scripts.
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Provisioning Telephony and Media

Resource provisioning information for the Unified CCX telephony and media 
subsystems are provided in the following sections:

 • About Unified CCX Telephony and Media, page 7-1

 • Provisioning Unified CM Telephony Subsystem, page 7-5

 • Additional Unified CM Telephony Information, page 7-22

 • Provisioning Cisco Media Subsystem, page 7-23

 • Provisioning ASR and TTS in Unified CCX, page 7-26

About Unified CCX Telephony and Media
The Unified CCX system uses a telephony resource called Computer Telephony 
Interface (CTI) ports to accept incoming calls and to place outbound calls. The 
Unified CCX system uses the following media resources to provide interactive 
services for calls:

 • Unified CM Telephony—The Unified CCX Engine uses the Unified CM 
Telephony subsystem to send and receive calls from the Unified CM by 
interfacing with the CTI Manager through the Unified CM Telephony client.

 • Unified CME Telephony—The Unified CCX Engine uses the Unified CME 
Telephony subsystem to open a logical session with Unified CME. This 
session verifies provider authentication, periodically exchanges heartbeats, 
and monitors Unified CME availability after successful authentication. 
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 • Cisco Media Termination (CMT)—The CMT channels provide media 
terminations in the Unified CCX for Unified CM/CME Telephony Call 
Contacts. These channels enable the Unified CCX to play media to the 
connected party. DTMF digits are received out of band by the Unified 
CM/CME Telephony subsystem. 

 • MRCP Automated Speech Recognition (MRCP ASR)—The ASR media 
resource allows callers to use speech to navigate menus and to provide other 
information to Unified CCX applications.

 • MRCP Text-To-Speech (MRCP TTS)—The TTS media resource enables 
Unified CCX applications to play back documents to callers as speech.

Note Media resources are licensed and sold as Unified IP IVR ports. 
Although you can provision more channels than you are licensed for, 
licensing is enforced at run-time. If more channels are provisioned 
than licensed, the system will not accept the extra calls, as doing so 
would violate your licensing agreements. 

The Unified CCX system uses the concept of groups to share telephony and media 
resources among different applications:

 • Call control groups allow you to control how the system uses CTI ports. For 
example, you can reserve more ports for higher-priority applications or 
provide access to fewer ports for applications with less traffic.

 • Media resource groups allow you to share media resources among different 
applications. For example, you can share ASR media resource groups with 
applications that collect caller information and applications that transfer calls 
to specific extensions.

The Unified CCX system also uses the concept of triggers, which are specified 
signals that invoke application scripts in response to incoming contacts.

Media Termination Groups
Media termination groups are associated with CTI port Groups. 
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During initial Unified CCX Setup, based on the licensed number of CTI ports, a 
default CTI port group and its associated media termination group is created. By 
default, every trigger is associated with this CTI Port Group and the 
corresponding media termination group. 

Note For Unified CME deployments, this will be the only available CTI Port Group. 
But in the Unified CM deployments, you can create and use additional CTI Port 
Groups as required.

If a CTI port group is selected to support media termination and if the number of 
channels are identical to both groups, then the CTI port group is automatically 
created in the background. This auto creation feature eliminates the manual CTI 
port group creation process. 

If you elect to override media termination, then the call control channel chooses 
the media termination automatically. If you wish to select a new dialog group then 
you can have more than one media termination options. The options are used in 
the order displayed in the drop-down list (see Adding a New Unified CM 
Telephony Call Control Group, page 7-9).

Provisioning Channels to Handle Calls
Unified CCX needs two types of channels to process calls:

 • A call control channel, which is provisioned through the Unified CM 
Telephony subsystem and corresponds to CTI port resources in Unified CM.

 • A media channel, which is provisioned through either the CMT subsystem or 
the MRCP subsystem and corresponds to the kernel resources for handling 
the media voice path with the caller. 

Note MRCP channels also correspond to additional resources on the MRCP 
server for performing speech recognition.
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Unified CCX needs access to a channel of each type to successfully process a call. 
However, the capabilities of the two channel types are not identical.

For example, consider a Unified CCX system provisioned with a single Unified 
CM Telephony call control channel (that is, a CTI port) and a single CMT 
channel. The system can handle one call at a time; when that call terminates, the 
system must reinitialize the channel resources before it can accept another call. 

However, the time each channel takes to reinitialize is not equal—CMT channels 
take more time to reinitialize then CTI ports. For example:

 • The Unified CM Telephony call control channel may take approximately 1 
millisecond to reinitialize

 • The CMT channel may take approximately 200 milliseconds to reinitialize. 

This example implies that the system will not be able to accept a new incoming 
call for 200 milliseconds after the first call terminates; although the Unified CM 
Telephony channel is available after one millisecond, the CMT channel is not and 
Unified CCX needs both channels to process a call. 

Such a delay can become an issue when a Unified CCX system is experiencing a 
high load condition or needs to handle a burst of incoming calls. Consequently, 
CMT channels require a higher channel count provisioning. 

Tip To provision Unified CCX systems to handle burst calls equally among all 
required resources, you must configure approximately 10% more CMT channels 
than CTI ports, and approximately 10% more MRCP channels than ASR licenses.

Telephony and Media Resources Provisioning Checklist
To provision telephony and media resources, complete the following tasks:

Step Task For instructions, see

Step 1 Provision the Unified CM Telephony subsystem, which 
controls the telephony resources for the Unified CCX 
system.

Provisioning Unified CM 
Telephony Subsystem, page 7-5

Step 2 Provision the Cisco Media subsystem, which controls 
the CMT media resources for the Unified CCX system.

Provisioning Cisco Media 
Subsystem, page 7-23
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Provisioning Unified CM Telephony Subsystem
The Unified CM Telephony subsystem is the subsystem of the Unified 
CCX Engine that sends and receives call-related messages from the Unified CM 
CTI Manager through the Unified CM Telephony client. To enable your Unified 
CCX server to handle Cisco Unified Communications requests, you will need to 
provision the Unified CM Telephony subsystem. The Unified CM Telephony 
subsystem is available in all the Unified CCX license packages.

Note In previous versions of Unified CCX, it was necessary to configure Unified CM 
Telephony information using Unified CM. In Unified CCX Release 4.0 and later, 
Unified CM Telephony configuration tasks are performed directly through 
Unified CCX Administration web pages. 

To provision the Unified CM Telephony subsystem, complete the following tasks:

Step 3 Provision the MRCP ASR subsystem, which controls 
the ASR media resources for the Unified CCX system.

Provisioning MRCP ASR 
Subsystem, page 7-27

Step 4 Provision the MRCP TTS subsystem, which controls the 
TTS media resources for the Unified CCX system.

Provisioning MRCP TTS 
Subsystem, page 7-34

Step Task For instructions, see

Step Task For instructions, see

 1 Configure a Unified CM Telephony Provider, if not already 
configured. Specify the server on which the 
Cisco Media Convergence Server (Cisco MCS) is running Unified 
CM CTI Manager, and provide a Unified CM user ID and password.

Configuring a Unified 
CM Telephony Provider, 
page 7-7 and 

Modifying Unified CM 
Telephony Information, 
page 4-8

 2 Provision Unified CM Telephony call control groups. Unified CM 
Telephony call control groups pool together a series of CTI ports, 
which the system then uses to serve calls as they arrive at the Unified 
CCX server.

Adding a New Unified 
CM Telephony Call 
Control Group, page 7-9
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Related Topics

Additional Unified CM Telephony Information, page 7-22

Resynchronizing Cisco JTAPI Client
During the resynchronizing process, an additional check ensures that the Unified 
CM Telephony Client (also known as the Cisco JTAPI Client) are the same 
between the clients installed on the Unified CCX node and the Cisco Unified CM. 
If the Unified CCX detects a mismatch, the system downloads and installs the 
required version of Cisco JTAPI Client. 

To resynchronize and view the status of Cisco JTAPI client, complete the 
following steps:

Procedure

Step 1 Choose Subsystems > Cisco Unified CM Telephony > Cisco JTAPI Resync 
from the Unified CCX Administration menu bar. 

Step 2 The Cisco JTAPI Resync web page opens displaying the status of Cisco JTAPI 
Client resynchronization. 

At this point, if there is an incompatible version, it automatically downloads the 
new client.

3 Provision a Unified CM Telephony trigger. Unified CM Telephony 
triggers invoke application scripts in response to incoming contacts.

Adding a Unified CM 
Telephony Trigger, 
page 7-16

 4 Resynchronize Unified CM Telephony versions.

 • Configuring a Unified CM Telephony Provider, page 7-7

 • Resynchronizing Unified CM Telephony Data, page 7-7

Provisioning Unified CM 
Telephony Subsystem, 
page 7-5

Step Task For instructions, see
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Related Topics

 • Configuring a Unified CM Telephony Provider, page 7-7

 • Adding a Unified CM Telephony Trigger, page 7-16

 • Additional Unified CM Telephony Information, page 7-22

Resynchronizing Unified CM Telephony Data
This resynchronizing process ensures that the Unified CM Telephony user, the 
call control groups, and the triggers matches the data of Unified CM being used.

To resynchronize the Unified CM Telephony data, complete the following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > Cisco 
Unified CM Telephony > Data Resync. 

Step 2 The Data Resync web page opens after resynchronization displaying the Data 
Resync status of Unified CM Telephony Port Groups and Unified CM Telephony 
Triggers.

Related Topics

 • Configuring a Unified CM Telephony Provider, page 7-7

 • Adding a Unified CM Telephony Trigger, page 7-16

 • Additional Unified CM Telephony Information, page 7-22

Configuring a Unified CM Telephony Provider
The Unified CM Telephony Provider web page is a read-only page that displays 
the latest configured information.

Caution Some setups may prevent the Unified CM directory administrator from creating 
new Unified CM Telephony providers in a multi-server configuration. If this setup 
applies to you, be sure to delete preexisting Unified CM Telephony providers 
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before creating new Unified CM Telephony providers. For example, if the Unified 
CM Telephony provider prefix is cmtelephony and you have a two-server 
configuration (node_id1 and node_id2), then you must delete both 
cmtelephony_<node_id1> and cmtelephony_<node_id2>. If you do not verify 
and delete preexisting Unified CM Telephony providers, the Unified CM 
Telephony subsystem issues an error and will not allow you to create Unified CM 
Telephony providers from the Unified CM Telephony Provider Configuration web 
page.

To access this configuration area, choose Subsystems > Cisco Unified CM 
Telephony > Provider from the Unified CCX Administration menu bar. The 
Cisco Unified CM Telephony Provider web page opens. 

The following table describes the read-only fields displayed in the Unified CM 
Telephony Provider Configuration web page.

To modify the Unified CM Telephony subsystem, click Modify Cisco Unified 
CM Telephony Provider Information icon that displays in the tool bar in the 
upper, left corner of the window. The Cisco Unified CM Configuration web page 

Field Heading Description

Primary Unified CM 
Telephony Provider

IP address of the Cisco Media Convergence Server (Cisco MCS) running 
Unified CM CTI Manager in the cluster. This is normally the first CTI 
Manager or Cisco Unified CM Telephony Provider selected by the 
Unified CCX user for Unified CM Telephony subsystem using System > 
Cisco Unified CM Configuration web page. 

Secondary Unified CM 
Telephony Provider

IP address of the second Cisco Media Convergence Server (Cisco MCS) 
running Unified CM CTI Manager in the cluster. This is normally the 
second CTI Manager or Cisco Unified CM Telephony Provider selected 
by the Unified CCX user for Unified CM Telephony subsystem using 
System > Cisco Unified CM Configuration web page. 

Note If you have selected only one Unified CM Telephony provider, 
this field will be blank.

User Prefix User prefix for the Unified CM user IDs created in Unified CM. 
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opens. Refer to Modifying Unified CM Telephony Information, page 4-8 section 
for detailed information on how to reconfigure the Unified CM Telephony 
information.

Related Topics

 • Configuring a Unified CM Telephony Provider, page 7-7

 • Adding a New Unified CM Telephony Call Control Group, page 7-9

 • Additional Unified CM Telephony Information, page 7-22

 • Modifying Unified CM Telephony Information, page 4-8

Adding a New Unified CM Telephony Call Control Group
The Unified CCX system uses Unified CM Telephony call control groups to pool 
together a series of CTI ports, which the system uses to serve calls as they arrive 
or depart from the Unified CCX server. You can create multiple Unified CM 
Telephony call control groups to share and limit the resources to be used by 
specific applications.

To configure a new Unified CM Telephony call control group, complete the 
following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > Unified 
CM Telephony > Call Control Group.

The Cisco Unified CM Telephony call control group Configuration web page 
opens, which displays the existing Unified CM Telephony Call Control Group 
information, if any.

Step 2 Click Add New icon that displays in the tool bar in the upper, left corner of the 
window or the Add New button that displays at the bottom of the window to create 
a new CTI port. The Cisco Unified CM Telephony Call Control Group 
Configuration web page opens. 
7-9
Cisco Unified CCX Administration Guide, Release 8.5(1)

 



Chapter 7      Provisioning Telephony and Media
Provisioning Unified CM Telephony Subsystem
Note You can create only one call control group of the Outbound type, in which the 
number of CTI ports must be always equal to or greater than the licensed 
Outbound IVR ports.

Step 3 Use this web page to specify the following information: 

Page Area Field Description

Group 
Information

Group ID Group ID corresponds to the trunk group number reported to Cisco 
Unified Intelligent Contact Management Enterprise (Unified ICME) when 
the Unified CCX server is part of the Unified ICME solution. 

Note This field is not available in the page for adding a new call control 
group. While you add a new call control group the next available 
Group ID is used internally. This field is displayed only in Cisco 
Unified CM Telephony Call Control Group Configuration list / 
update page.

Note If a Stop icon displays beside the Group ID (on the Cisco Unified 
CM Call Control Group Configuration list page), it indicates that 
the data is invalid or out of sync with Unified CM data; if a Head 
icon displays, then the Group is valid.

Description Enter a brief decsription for a call control group that is added. This is a 
mandatory field and this field must be populated before you add a call 
control group.
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Group 
Information 
(continued)

Number of 
CTI Ports

Number of CTI Ports assigned to the call control group. This is a 
mandatory field. 

If you have a Premium license with an Outbound IVR license, you can 
create only one Outbound call control group with a minimum licensed 
number of IVR ports or more. The number of CTI ports for an outbound 
type of call control group can be modified but not below the licensed ports 
for Outbound IVR. This rule does not apply to inbound type call control 
groups. You can continue to create more inbound type call control groups.

Note If this field is set to <n>, the system creates <n> ports for each 
Unified CCX Engine node (node in which Unified CCX Engine 
component is enabled).

Media 
Termination 
Support

Enables the auto-creation of media termination groups. This is a 
mandatory field.
Yes = provides automatic media termination if the CTI port group is 
successful (see Media Termination Groups, page 7-2).

No = Media termination port group is not created (default).

Group Type Select the group type for the call control group using this radio button. 
The choices are Inbound and Outbound. This is a mandatory field and 
Inbound radio button is enabled by default. You cannot change the group 
type from Outbound to Inbound and vice versa. The Outbound type call 
control group will be displayed only if you have uploaded the Outbound 
IVR license on top of the premium license in your Unified CCX.

Note The existing call control groups will have this value as inbound 
after an upgrade from Unified CCX versions prior to 8.5(1). 

Directory 
Number 
Information

Device 
Name Prefix

The Device Name Prefix (DNP) used in the name that will be given all of 
the CTI Ports in this group. This is a mandatory field.

The CTI ports for this port group is restricted to a maximum of 5 
characters and has the following format:

<deviceprefix>_<directoryno> 

For example, if the Device Name Prefix is CTP and the starting Directory 
Number is 7000, then the CTI Port that is created in Unified CM can have 
the device name CTP_7000. 

Select Server for Telephony Port Group Configuration (displayed only in a HA over WAN 
deployment)

Page Area Field Description
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Select 
Server

This field is displayed only in a HA over WAN deployment and it displays 
the different Unified CCX nodes that are available in a HA over WAN 
deployment in a drop-down list. 

In a HA over WAN setup, you need to configure directory information 
along with Unified CM-specific information for the ports in each node. 
Once you select a node, all configuration details displayed below this field 
will be specific to the selected node only. So, if you update any 
node-specific parameters (below the Select Server field), it will be 
applicable only to the ports specific to the selected node. But, if you 
update any configuration data above the Select Server field, it will be 
applicable for the ports in both the nodes except for the Number of CTI 
Ports field. 

Note You need to ensure that the values in Number of CTI ports field 
for both the nodes are the same. If you modify this field, the 
number of ports is modified for the selected node only as the 
device pool selection for both nodes could be different in a HA 
over WAN deployment. If you click Add before updating this 
value for either of the node, then the port group for that node will 
be marked with a red cross in the main Cisco Unified CM 
Telephony Call Control Group Configuration web page to signify 
the fact that the number of ports between the two nodes is different 
and the other node should also be updated. In such a scenario, 
click the hyperlink for the node that is tagged in red and from the 
Cisco Unified CM Telephony Call Control Group Configuration 
page for the selected node, update the value in the Number of CTI 
Ports field and click Update to ensure the number of CTI ports 
for both the nodes are the same.

Once you configure the data for the selected node and click Add or 
Update, the updated configuration information will be saved. For detailed 
information on behaviour in HA over WAN scenario, refer to Expected 
Behaviour During a Failover Guide. In case of LAN deployment, this 
field is not displayed as the same configuration data will be applicable for 
both the nodes in the cluster. 

Page Area Field Description
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Directory 
Number 
Information

Starting 
Directory 
Number

A unique phone number. The value can include numeric characters and 
special characters (#) and (*). The specified number of ports will be 
created starting from the value specified in this field. The Directory 
Number that you enter can appear in more than one partition. This is a 
mandatory field.

Note When a pattern is used as a Directory Number, the phone display 
and the caller ID display on the dialed phone will contain 
characters other than digits. To avoid this, provide a value for 
Display (Internal Caller ID), Line Text Label, and External Phone 
Number Mask.

Device Pool Set of common characteristics for devices, such as region, date/time 
group, softkey template, and MLPP information to which you want to 
assign this phone.

Note The support for having multiple device pools associated with call 
control group(s) has been withdrawn in Unified CCX 8.5(1). If 
you have multiple device pools associated with call control 
group(s) in an older version of Unified CCX, it is recommended 
to manually assign a single device pool to each call control group. 
For more information, see Unified CM Telephony Data 
Synchronization, page 18-5.

DN Calling 
Search 
Space

A collection of partitions that are searched to determine how a dialed 
number should be routed. The calling search space for the device and the 
calling search space for the directory number get used together. The 
directory number calling search space takes precedence over the device 
calling search space.

For more information, see the Cisco Unified Communications Manager 
System Guide.

Location The Cisco Unified Communications phone location setting specifies the total 
bandwidth that is available for calls to and from this location. A location 
setting of HUB_NONE means that the location feature does not keep track of 
the bandwidth that this Cisco Unified Communications phone consumes.

Partition The Cisco Unified Communications phone location setting specifies the 
total bandwidth that is available for calls to and from this location. A 
location setting of HUB_NONE means that the location feature does not 
keep track of the bandwidth that this Cisco Unified Communications 
phone consumes.

Page Area Field Description
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Advanced Directory Number Information (only available if you click Show More)

Directory 
Number 
(continued)

Alerting 
Name 
ASCII

This information is automatically populated based on the configuration in 
the Unified CM setup and displays the ASCII name filed used in one of 
the following situations:

 • if the device is not capable of handling the Unicode strings

 • if the locals on end point devices do not match 

 • if the Unicode string is not specified

Redirect 
Calling 
Search 
Space

A collection of partitions that are searched to determine how a redirected 
call should be routed. 

Media 
Resource 
Group List

A prioritized grouping of media resource groups. An application chooses 
the required media resource, such as a Music On Hold server, from the 
available media resources according to the priority order that is defined in 
a Media Resource Group List. 

If you choose <none>, Unified CM uses the Media Resource Group that 
is defined in the device pool. 

Directory 
Number 
Setting

Voice Mail 
Profile

A list of profiles defined in the Voice Mail Profile Configuration. 

The first option is <None>, which is the current default Voice Mail Profile 
that is configured in the Voice Mail Profile Configuration.

Presence 
Group

See Cisco Unified Communications Manager Administration Guide for 
detailed information on how to configure presence groups.

Page Area Field Description
7-14
Cisco Unified CCX Administration Guide, Release 8.5(1)



Chapter 7      Provisioning Telephony and Media
Provisioning Unified CM Telephony Subsystem
Step 4 Click Add or Save.

The Unified CM Telephony Call Control Group Configuration summary web page 
opens. The corresponding CTI ports are created in the Unified CM Telephony call 
control group. The new call control group appears in the list of call control groups 
displayed in the Cisco Unified CM Telephony Call Control Group Configuration 
web page. 

Require 
DTMF 
Reception

A Unified CM radio button to determine if DTMF reception is required. 
Yes is selected by default. If you select No, a warning message is 
displayed.

AAR Group Automated Alternate Routing (AAR) group for this device. The AAR 
group provides the prefix digits that are used to route calls that are 
otherwise blocked due to insufficient bandwidth. An AAR group setting 
of <None> specifies that no rerouting of blocked calls will be attempted. 

User Hold 
Audio 
Source

Audio source heard by the caller when the Unified CCX Script places the 
caller on hold via the Hold Step (when you press the hold key).

Network 
Hold Audio 
Source

Audio source heard by the caller will when Unified CCX performs a 
Consult Transfer (when Unified CCX calls an agent). Use this entry for 
the .wav file (for example, .wav file playing a ring back tone) to be played 
to the caller during this Consult Transfer.

Call 
Forward 
and Pickup 
Settings

Call Pickup 
Group 

The number that can be dialed to answer calls to this directory number in 
the specified partition. 

Display Use a maximum of 30 alphanumeric characters. Typically, use the user 
name or the directory number (if using the directory number, the person 
receiving the call may not see the proper identity of the caller). 

Leave this field blank to have the system display the extension. 

External 
Phone 
Number 
Mask

Phone number (or mask) that is used to send Caller ID information when 
a call is placed from this line. 

You can enter a maximum of 30 number and X characters. The X 
characters represent the directory number and must appear at the end of 
the pattern. For example, if you specify a mask of 972813XXXX, an 
external call from extension 1234 displays a caller ID number of 
9728131234. 

Page Area Field Description
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Related Topics

 • Configuring a Unified CM Telephony Provider, page 7-7

 • Adding a Unified CM Telephony Trigger, page 7-16

 • Additional Unified CM Telephony Information, page 7-22

Adding a Unified CM Telephony Trigger
You must configure Unified CM Telephony triggers to invoke application scripts 
in response to incoming contacts. A Unified CM Telephony trigger responds to 
calls that arrive on a specific route point by selecting telephony and media 
resources to serve the call and invoking an application script to handle the call. 
The Unified CM Telephony triggers are available with all Unified CCX license 
packages.

Unified CM Telephony trigger settings include:

 • Session information, such as the application to associate with the trigger, 
Maximum Number of sessions allowed (see Media Termination Groups, 
page 7-2), and the Idle Timeout value.

 • CTI information, such as a CTI port device and CTI route points for each call 
Unified CCX simultaneously places or accepts.

 • Directory Number information, such as the Voice Mail Profile and Calling 
Search Space. 

 • Call Forward and Pickup instructions.

To add and configure a Unified CM Telephony trigger, complete the following 
steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > Cisco 
Unified CM Telephony > Triggers. 
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The Unified CM Telephony Trigger Configuration web page opens displaying the 
following fields. 

 

Note If you try to delete a trigger associated with an outbound call control group, then 
the campaigns associated with the trigger become invalid and the application also 
gets deleted. In such cases, on click of Delete icon or button, a dialog box opens 
to confirm your action. Click OK if you want to delete the trigger and disassociate 
the campaigns associated with it. If you delete a trigger and navigate to the 
Campaign Configuration web page, you will also see an alert regarding the 
missing trigger association for that campaign.

Step 2 Click Add New icon that displays in the tool bar in the upper, left corner of the 
window or the Add New button that displays at the bottom of the window.

The Unified CM Telephony Trigger Configuration web page opens. 

Step 3 Use this web page to specify the following mandatory fields: 

Field Description

Route Point Available CTI route point, which is the directory number associated with the trigger. 

Application Application name to associate with the trigger.

Sessions Maximum number of simultaneous calls that the trigger can handle. 

Enabled True if the trigger is enabled; False if the trigger is disabled.
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Field Description

Directory Information

Directory Number A unique phone number. The value includes numeric characters, preceded or 
appended by the following special characters: 

# * [ ] X -

Examples of valid Directory Numbers: 
*#12#* or 12*23

Examples of invalid Directory Numbers: 
91X+, 91X?, 91!, 813510[^0-5] as it contains a character other than numerical 
and allowed special characters or 
8]90[-, as it doesn't conform with the rule that the square bracket ([ ]) characters 
enclose a range of values.

Note See the Wildcards and Special Characters in Route Patterns and Hunt 
Pilots section in the Cisco Unified Communications Manager System 
Guide for more information. 

Trigger Information

Language Choose the default language to associate with the incoming call when the 
application is started from this drop-down menu.

Note To add a Language option, click Edit button. The User Prompt dialog 
box opens. Enter a locale string value and click OK. The User Prompt 
dialog box closes, and the name of the language opens in the Language 
field in the Unified CM Telephony Configuration web page.

Application Name Drop-down menu, choose the application to associate with the trigger.

Device Name A unique identifier for this device, consisting of alphanumeric characters, dots, 
dashes, or underscores.

Description A descriptive name for the CTI route point. 

Call Control Group Choose the call control group to associate with the trigger from this drop-down 
menu. For Outbound IVR Dialer, you must select the call control group from 
Outbound type call control group list. The route point should be created on 
Unified CM. Once you assign the Outbound group for a trigger, you cannot 
change it to an Inbound group and vice versa.

Advanced Configuration (available only if you click Show More).

Advanced Trigger Information
7-18
Cisco Unified CCX Administration Guide, Release 8.5(1)



Chapter 7      Provisioning Telephony and Media
Provisioning Unified CM Telephony Subsystem
Enabled Radio buttons, choose the required option:
Yes - enable the trigger (default)
No - disable the trigger.

Maximum Number of 
Sessions

The maximum number of simultaneous calls that this trigger can handle. The 
number is actually governed by the Unified CM (10,000 for each separate line). 
However in Unified CCX, this number is restricted to the maximum number of 
sessions. Any call exceeding this number gets the busy tone (see the “Adding a 
Unified CM Telephony Trigger” section on page 7-16).

Idle Timeout (in ms) The number of milliseconds (ms) the system should wait before rejecting the 
Unified CM Telephony request for this trigger. 

Override Media 
Termination

Radio buttons to choose the required options:

Yes - Override media termination.

No - Enable media termination (default).

If you select Yes, two panes open:
 • Selected Dialog Groups displays the default or selected group.

 • Available Dialog Groups lists the configured dialog

CTI Route Point Information

Alerting Name ASCII This information is automatically populated based on the configuration in the 
Unified CM setup and displays the ASCII name filed used in one of the 
following situations:

 • if the device is not capable of handling the Unicode strings

 • if the locals on end point devices do not match 

 • if the Unicode string is not specified

Device Pool The device pool to which you want to assign this route point. A device pool 
defines sets of common characteristics for devices, such as region, date/time 
group, softkey template, and MLPP information.

Location The total bandwidth that is available for calls to/from this location. A location 
setting of HUB_NONE indicates that the locations feature does not keep track 
of the bandwidth used by this route point.

Directory Number Settings

Field Description
7-19
Cisco Unified CCX Administration Guide, Release 8.5(1)

 



Chapter 7      Provisioning Telephony and Media
Provisioning Unified CM Telephony Subsystem
Partition The partition to which the Directory Number belongs. The Directory Number 
field value must be unique within the partition that you choose. 

If you do not want to restrict access to the Directory Number, select <None> as 
the partition setting.

Voice Mail Profile A list of profiles defined in the Voice Mail Profile Configuration. 

The first option is <None>, which is the current default Voice Mail Profile that 
is configured in the Voice Mail Profile Configuration.

Calling Search Space A collection of partitions that are searched for numbers that are called from this 
directory number. The specified value applies to all devices that use this 
directory number. 

Note Changes to this field result in an update of the numbers listed in the Call 
Pickup Group field. 

You can configure calling search space for Forward All, Forward Busy, 
Forward No Answer, and Forward on Failure directory numbers. The value you 
choose applies to all devices that are using this directory number. 

If you set the Forward All Calling Search Space field to <None>, Unified CM 
uses the calling search spaces of the line and the phone when you forward the 
calls by using the Cisco IP Phone User Options windows or the CFwdAll 
softkey on the phone. 

To restrict users from forwarding calls on their phones, choose a restrictive 
calling search space from the Forward All Calling Search Space field.

For example, assume you have two calling search spaces: Building and PSTN. 
Building only allows users to call within the building, while PSTN allows users 
to call both in and outside the building. You could assign the phone to the 
Building calling search space and the line on your phone to the PSTN calling 
search space. If you set the Call Forward All calling search space to <None>, 
Unified CM can forward calls to any number within the PSTN or building 
calling search spaces. To prevent a user from forwarding calls to numbers 
outside the building, set the Call Forward All calling search space to Building. 
For more information, see the Cisco Unified Communications Manager System 
Guide.

Presence Group A list of groups to integrate the device with the iPass server. The device/line 
information is provided to integrating applications.

Field Description
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Step 4 Click Add or Save to save the changes. The specified route point is created on the 
the Unified CM. 

The Unified CM Telephony Trigger Configuration web page opens and displays 
the new Unified CM Telephony trigger. 

Related Topics

 • Configuring a Unified CM Telephony Provider, page 7-7

 • Configuring a Unified CM Telephony Provider, page 7-7

 • Adding a New Unified CM Telephony Call Control Group, page 7-9

 • Additional Unified CM Telephony Information, page 7-22

Call Forward and Pickup Settings

Forward Busy Check one of the following options:

Voice Mail - Check this box to use settings in the Voice Mail Profile 
Configuration window.

Note When this box is checked, Unified CM ignores the settings in the 
Destination box and Calling Search Space. 

Destination: to use any disable phone number, including an outside 
destination. 

Calling Search Space: to apply the above setting all devices that are using this 
directory number. 

Display Use a maximum of 30 alphanumeric characters. Typically, use the user name or 
the directory number (if using the directory number, the person receiving the 
call may not see the proper identity of the caller). Leave this field blank to have 
the system display an extension. 

External Phone 
Number Mask

Phone number (or mask) that is used to send Caller ID information when a call 
is placed from this line. 

You can enter a maximum of 30 number and X characters. The X characters 
represent the directory number and must appear at the end of the pattern. For 
example, if you specify a mask of 972813XXXX, an external call from 
extension 1234 displays a caller ID number of 9728131234. 

Field Description
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Additional Unified CM Telephony Information
This section includes the following topics:

 • Provisioning Unified CM Telephony Triggers for Unified CCX Queuing, 
page 7-22

 • Resynchronizing Unified CM Telephony Information, page 7-22

Provisioning Unified CM Telephony Triggers for Unified CCX 
Queuing

When limiting the number of calls per application in Unified CCX applications, 
you need to take care to coordinate the Unified CM Telephony trigger Maximum 
Number of Sessions limit with the Media Group session limit.

For example, say you are using Unified CCX for queuing calls and set the Unified 
CM Telephony trigger Maximum Number of Sessions limit on Unified CCX to 4 
and set the Call Forward and Pickup Settings to send the fifth call to voice mail. 
To make this happen, you must configure the Media Group Session Limit to the 
identical setting (4). This will cause Unified CM to forward the next incoming call 
to voice mail (once the CTI New Call Accept timer setting expires).

The drawback of this approach is that you need to define more media groups for 
each application and you cannot share the same set of media groups across 
multiple applications.

Related Topics

Provisioning Unified CM Telephony Subsystem, page 7-5

Resynchronizing Unified CM Telephony Information
If the Unified CM Telephony information (Unified CM Telephony users, CTI 
ports, triggers) in the Unified CM is missing or not in sync with Unified CCX 
data, choose Subsystems > Cisco Unified CM Telephony > Data Resync from 
the Unified CCX Administration menu bar. Unified CCX checks whether:
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 – The Unified CM Telephony users exist in Unified CM.

 – All the ports belonging to the Port Group exist in Unified CM.

 – The Port Group’s data is in sync with Ports data in Unified CM. 

 – The Ports’ association to users are correct.

 – The Route Point exist in Unified CM.

 – The Triggers data is in sync with the Route Point data in the Unified CM.

 – The Route Points have been associated with all the Unified CM 
Telephony users in Unified CM.

 • Synchronizes the data by:

 – Creating any missing users. 

 – Creating any missing ports.

 – Modifying out-of-sync ports.

 – Associating CTI Ports to Unified CM Telephony users. (For example, 
associating CTI Ports created for Node 1 to the Unified CM Telephony 
User for Node 1, and so forth.)

 – Creating any missing route points.

 – Modifying out-of-sync route points.

 – Associating route points to all the Unified CM Telephony users. 

Related Topics

Provisioning Unified CM Telephony Subsystem, page 7-5

Provisioning Cisco Media Subsystem
The Cisco Media subsystem is a subsystem of the Unified CCX Engine. The Cisco 
Media subsystem manages the CMT media resource. CMT channels are required 
for Unified CCX to be able to play or record media.

The Cisco Media subsystem uses dialog groups to organize and share resources 
among applications. A dialog group is a pool of dialog channels in which each 
channel is used to perform dialog interactions with a caller, during which the 
caller responds to automated prompts by pressing buttons on a touch-tone phone.
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Note The built-in grammars and grammar options that are supported by Unified CCX 
when using an MRCP dialog channel is determined by the MRCP speech software 
you purchase. See the software vendor for information about what built-in 
grammars and features are supported.

To enable your Unified CCX applications to handle simple DTMF-based dialog 
interactions with customers, you will need to provision the Cisco Media 
subsystem to configure CMT dialog groups.

Caution All media termination strings begin with auto and contain the same ID as the call 
control group—not the CMT dialog group. If the default media termination is 
configured and the ID differs, follow the procedure provided in the “Adding a 
CMT Dialog Control Group” section on page 7-24.

Related Topics

 • Adding a New Unified CM Telephony Call Control Group, page 7-9

 • Cisco Media Menu Option, page 18-32

Adding a CMT Dialog Control Group 
To add a CMT dialog control group, complete the following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > Cisco 
Media.

The Cisco Media Termination Dialog Group Configuration web page opens. Any 
preconfigured entry is listed on this page with the following information:
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Step 2 Click Add New icon at the top or Add New button at the bottom of the window. 
The Cisco Media Termination Dialog Group Configuration web page opens. 

Note By default, a Unified CM Telephony Call Control Group with Group ID 0 is 
created. 

Step 3 Use this web page to specify the following fields. 

Step 4 Click Add icon that displays in the tool bar in the upper, left corner of the window 
or the Add button that displays at the bottom of the window. 

The CMT Dialog Group Configuration web page opens, displaying the new CMT 
dialog group.

Field Description

GroupID The unique Group ID associated with the media. 

Description CMT group description. 

Note The ID in the this field need not necessarily match the 
CMT group ID.

Channels Number of channels associated with the group. 

Field Description

Group ID A Group ID value unique within all media group identifiers, 
including ASR group identifiers. This is a mandatory field.

Description Description for the Cisco Media Termination Dialog group.

Number of Licensed IVR ports Number of licensed IVR ports. Display only.

Maximum Number Of Channels Maximum number of channels associated with this group. This is a 
mandatory field.

Note You can specify any value for Maximum Number Of 
Channels, but restrictions are placed on the system when a 
call is made. This restriction is imposed by the number of 
licensed IVR ports on your system. This is a mandatory 
field.
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You are now ready to provision MRCP ASR and MRCP TTS subsystems.

Related Topics

 • Provisioning Cisco Media Subsystem, page 7-23

 • Cisco Media Menu Option, page 18-32

Provisioning ASR and TTS in Unified CCX
Unified CCX supports ASR and TTS through two subsystems:

 • MRCP ASR—This subsystem allows users to navigate through a menu of 
options by speaking instead of pressing keys on a touch-tone telephone. 

 • MRCP TTS—This subsystem converts plain text (UNICODE) into spoken 
words to provide a user with information or prompt a user to respond to an 
action. 

Related Topics

 • Before You Provision ASR/TTS, page 7-26

 • Provisioning MRCP ASR Subsystem, page 7-27

 • Provisioning MRCP TTS Subsystem, page 7-34

Before You Provision ASR/TTS
It is the responsibility of the customer to perform the following tasks:

 • Order ASR/TTS speech servers from Cisco-supported vendors.

Note For more information on supported speech servers for Unified CCX, 
see the Cisco Unified CCX Software and Hardware Compatibility 
Guide for Active Releases available at 
http://www.cisco.com/en/US/products/sw/custcosw/ps1846/products
_device_support_tables_list.html.
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 • Work with the ASR/TTS vendor to size the solutions.

 • Provision, install, and configure the ASR/TTS vendor software on a different 
server (in the same LAN) and not where the Unified CCX runs. You can 
configure the speech software for Unified CCX 8.5(1) in the same way as 
Unified CCX 7.0 (see 
http://www.cisco.com/en/US/prod/collateral/voicesw/custcosw/ps5693/ps18
46/product_bulletin_c25-546866.html for detailed information.

 • Before uploading a ASR/TTS script to Unified CCX Administration, validate 
the script against the capabilities and specifications supported by the 
ASR/TTS vendor.

Provisioning MRCP ASR Subsystem
The MRCP ASR subsystem allows users to navigate through a menu of options by 
speaking instead of pressing keys on a touch-tone telephone. When a user calls local 
directory assistance, for example, ASR can prompt the user to say the city and 
state in which to locate the information, then connect the user to an appropriate 
operator. 

To provision the MRCP ASR subsystem, define the following information:

 • MRCP ASR Providers—Information about the vendor of your speech 
server, including the number of licenses and the grammar type (see 
Provisioning MRCP ASR Providers, page 7-28).

 • MRCP ASR Servers—Information about the ASR server’s name, port 
location, and available languages (see Provisioning MRCP ASR Servers, 
page 7-29).

 • MRCP ASR Groups— Information about the MRCP ASR dialog control 
groups and associated locales, which enable Unified CCX applications to use 
speech recognition (see Provisioning MRCP ASR Dialog Groups, 
page 7-31).

Related Topics

 • Before You Provision ASR/TTS, page 7-26

 • Provisioning MRCP TTS Subsystem, page 7-34
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Provisioning MRCP ASR Providers

Use the MRCP ASR Provider Configuration web page to specify information 
about the vendor of your speech server.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystem > MRCP 
ASR > MRCP ASR Providers.

The MRCP ASR Provider Configuration web page opens, displaying the list of 
currently configured MRCP Providers, licenses, and the corresponding status. 
The following table provides a brief description of these fields.

Step 2 Click Add New icon that displays in the tool bar in the upper, left corner of the 
window or the Add New button that displays at the bottom of the window.

The MRCP ASR Provider Configuration web page opens. 

Step 3 Use this web page to specify the following mandatory fields. 

Field Description

Provider MRCP ASR Providers configured by the Unified CCX 
Administrator.

License The number of ASR port licenses purchased from the ASR vendor.

Status Status or state of the subsystem. 

Field Description

Provider Name Enter the name of the MRCP ASR provider supported by Unified CCX.

Number of Provider Licenses The number of ASR port licenses purchased from the ASR vendor.

Grammar Variant Vendor-specific grammar setting. Valid options:

 • Nuance Open Speech Recognizer servers (OSR 3.1.x)

 • Nuance 8.5 ASR servers (Nuance)

 • IBM WVS ASR servers (2003 SISR)
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Step 4 Click Add icon in the tool bar in the upper, left corner of the window or the Add 
button that displays at the bottom of this window to apply changes. 

Note After you update MRCP ASR/TTS Providers, Servers, and Groups, the 
corresponding Provider needs to be Refreshed for changes to take effect. The 
Unified CCX Engine does not need to be restarted. However, during a Refresh, 
Unified CM Telephony triggers using affected groups will fall back to the dialog 
group that is configured and the MRCP Provider being refreshed will go 
NOT_CONFIGURED until the reload is complete.

Your changes appear in the MRCP ASR Providers List page. You are now ready 
to provision MRCP ASR Servers.

Note If you delete an ASR/TTS provider and all of its associated servers and then create 
a new ASR/TTS provider, its status might become IN_SERVICE immediately, 
even before you create any servers for it. In this situation, click Refresh for that 
ASR/TTS provider, or click Refresh All. These actions change the status of the 
ASR/TTS provider to NOT_CONFIGURED.

Related Topics

 • Provisioning MRCP ASR Servers, page 7-29

 • Provisioning MRCP ASR Dialog Groups, page 7-31

Provisioning MRCP ASR Servers

Use the MRCP ASR Server Configuration web page to specify information about 
the speech server’s name, port location, and available language.

Note You must have a MRCP ASR Provider defined before you can provision a MRCP 
ASR Server.
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Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystem > MRCP 
ASR > MRCP ASR Servers.

The MRCP ASR Server Configuration web page opens, displaying a list of 
previously configured servers, if applicable with the following information:

Step 2 Click Add New icon that displays in the tool bar in the upper, left corner of the 
window or the Add New button that displays at the bottom of the window to 
provision a new MRCP ASR Server.

The MRCP ASR Server Configuration web page opens. 

Step 3 Use this web page to specify the following fields.

Column Description

Computer Name Host name or IP address in which the ASR server software is installed. 

Note ASR server deployment over WAN is not supported in Unified CCX. In 
other words, the ASR server should be in the same LAN where Unified CCX 
is. Thus, you need to specify the ASR server host name or IP address that is 
local with the Unified CCX node while installing the ASR server software 
in this field.

Provider The MRCP ASR Provider to which this server is associated.

Port TCP port numbers used to connect to a MRCP server

 • OSR 3.1x - 4900

 • 2003 SISR - 554

 • Nuance - 554

Status Status or state of the subsystem. 

Field Description

Server Name Host name or IP address of the server where the MRCP ASR server software is 
installed.

Provider Name Select the name of the MRCP ASR Provider to which this server is associated from 
this drop-down list. 
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Step 4 Click Add to apply changes. 

Your changes appear in the MRCP ASR Server list web page. You are now ready 
to provision MRCP ASR Groups.

Related Topics

 • Provisioning MRCP ASR Providers, page 7-28

 • Provisioning MRCP ASR Dialog Groups, page 7-31

Provisioning MRCP ASR Dialog Groups 

Use the MRCP Groups Configuration web page to specify information about 
MRCP ASR dialog control groups, which enable Unified CCX applications to use 
speech recognition.

Note You must have a MRCP ASR Provider defined before you can provision a MRCP 
ASR Group. Also, you should configure MRCP ASR Servers for the specific 
MRCP Provider before configuring the MRCP ASR Groups. This allows users to 
configure languages for the groups based on the languages supported by the 
configured servers.

Port Number TCP port numbers that are used to connect to an MRCP server. Though the default 
value is shown as 4900, you need to provide any one of the following values in this 
field based on the TCP provider or grammar variant you have selected while 
configuring an MRCP ASR provider:

 • OSR 3.1x - 4900

 • 2003 SISR - 554

 • Nuance - 554

Locales Languages supported by the ASR Provider. Select a language (or multiple 
languages) from the drop-down list and click Add Language; the selected language 
appears in the Enabled Language list.

Note Use the check box to disable/enable a language.

Field Description
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Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystem > MRCP 
ASR > MRCP ASR Dialog Groups.

The MRCP ASR Dialog Group Configuration web page opens to display a list of 
preconfigured entries, if applicable with the following information: 

This web page also displays the Number of Licensed IVR Channels.

Step 2 Click Add New icon that displays in the tool bar in the upper, left corner of the 
window or the Add New button that displays at the bottom of the window to 
provision a MRCP ASR Group.

The MRCP ASR Dialog Group Configuration web page opens. 

Step 3 Use this web page to specify the following fields:

Field Description

Group ID Identifier for the group.

Description Description of this dialog group. 

Provider Name of the MRCP ASR provider.

Channels Maximum number of sessions.

Field Description

Group ID Associated group ID. 

Description Description of this dialog group. 

Tip Include languages that will be used by this Group to the 
description. Doing so will provide insight to the languages 
this Group uses when you set up the dialog group in the 
Unified CM Telephony trigger configuration. This also 
ensures that the locales used by the application configured in 
the Unified CM Telephony trigger match the locales 
supported by the MRCP ASR dialog group being selected.

Number Of Provider Licenses Display only.

Number Of Licensed IVR 
Ports

Display only.
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Step 4 Click Add to apply changes. 

Your changes appear in the MRCP ASR Groups list web page.

Related Topics

 • Provisioning MRCP ASR Providers, page 7-28

 • Provisioning MRCP ASR Servers, page 7-29

Maximum Number Of sessions Maximum number of sessions associated with this dialog group. 

Note You can assign any value for Maximum Number Of Channels, 
but restrictions are placed on the system when a call is made. 
This restriction is imposed by the number of licensed IVR 
ports on your system.

Caution Under heavy load, calls that utilize a channel from an 
MRCP ASR Dialog Control Group, might have a reduced 
call completion rate as the MRCP channels used by calls 
can take some additional time to clean up all the sessions 
set up with MRCP resources. To address this situation, you 
can overprovision the value of this field by a factor of 1.2 
or by an additional 20 percent. For example, if your 
application requires 100 MRCP ASR channels, then 
modify the value in this field to be 120 MRCP ASR 
channels. 

Provider Name Select a MRCP Provider name from the drop-down list that contains 
a list of all previously defined provider names.

Enabled Languages Select the language(s) that you wish to configure for this group from 
the list displayed. 

The displayed languages represent the locales configured for all 
MRCP ASR servers for the specified provider. If there are no MRCP 
ASR servers configured, no languages are displayed. In this case, you 
will need to update the group configuration once MRCP ASR servers 
have been configured for the specified provider.

Field Description
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Provisioning MRCP TTS Subsystem
The MRCP TTS subsystem converts plain text (UNICODE) into spoken words to 
provide a user with information or prompt a user to respond to an action. 

For example, a company might use TTS to read back a customer’s name, address, 
and telephone number for verification before the company ships a requested 
product to the customer’s location. Or a customer might dial into a pre-designated 
phone number, access a voice portal, and listen to the latest weather report or 
stock quotes. TTS can also convert e-mail text to speech and play it back to the 
customer over telephone. 

To provision the MRCP TTS subsystem, define the following information:

 • MRCP TTS Providers—Information about the vendor of your TTS system 
(see Provisioning MRCP TTS Providers, page 7-35).

Note If you delete an ASR/TTS provider and all of its associated servers and 
then create a new ASR/TTS provider, its status might become 
IN_SERVICE immediately, even before you create any servers for it. In 
this situation, click Refresh for that ASR/TTS provider, or click Refresh 
All. These actions change the status of the ASR/TTS provider to 
NOT_CONFIGURED.

 • MRCP TTS Servers—Information about the TTS server’s name, port 
location, and available languages (see Provisioning MRCP TTS Servers, 
page 7-37).

 • MRCP TTS Default Genders—Information about the default gender setting 
for the Locales specified during TTS Server provisioning (Provisioning 
MRCP TTS Default Genders, page 7-39).

Note You will need at least one MRCP TTS Provider for each vendor requiring TTS 
server installation.

Related Topics

 • Before You Provision ASR/TTS, page 7-26

 • Provisioning MRCP ASR Subsystem, page 7-27
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Provisioning MRCP TTS Providers 

Use the MRCP TTS Providers Configuration web page to specify information 
about the vendor of your TTS server.

Note After you update MRCP ASR/TTS Providers, Servers, and Groups, the 
corresponding Provider needs to be Refreshed for changes to take effect. The 
Unified CCX Engine does not need to be restarted. However, during a Refresh, 
Unified CM Telephony triggers using affected groups will fall back to the dialog 
group that is configured and the MRCP Provider being refreshed will go 
NOT_CONFIGURED until the reload is complete.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > MRCP 
TTS > MRCP TTS Provider.

The MRCP TTS Provider Configuration web page opens. If providers are already 
configured, this page lists the provider name and corresponding status. The 
following table provides a brief description of these fields:

Step 2 Click Add New icon that displays in the tool bar in the upper, left corner of the 
window or the Add New button that displays at the bottom of the window.

Use this web page to specify the MRCP TTS Provider supported by Unified CCX.

The MRCP TTS Provider Configuration web page reopens. The Provider Name 
drop-down list displays the existing MRCP TTS Providers. Choose the MRCP 
TTS Provider supported by Unified CCX from this list. 

Note Support for High Availability and remote servers is available only in 
multiple-server deployments.

Field Description

Provider Name MRCP TTS Providers supported by Unified CCX. 

Status Status or state of the subsystem. 
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Step 3 Click Add to apply changes. 

Your changes appear in the MRCP TTS Provider Configuration web page. You are 
now ready to provision MRCP TTS Servers.

Related Topics

 • Configuring Default TTS Provider for the Unified CCX System, page 7-36

 • Provisioning MRCP TTS Servers, page 7-37

 • Provisioning MRCP TTS Default Genders, page 7-39

Configuring Default TTS Provider for the Unified CCX System

Optionally, you can configure a default TTS provider. The Unified CCX Prompt 
Manager uses the default TTS provider for rendering TTS prompts if a TTS 
provider is not configured in the TTS Prompt. This usually happens in the case of 
VXML applications. For additional information on supported VXML tags for 
Unified CCX, see Scripting and Development Series: Volume 1, Getting Started 
with Scripts for Cisco Unified CCX and Cisco Unified IP IVR, Release 8.5(1).

To configure a default TTS provider, follow these steps.

Step 1 Choose System > System Parameters. 

Step 2 In the Default TTS Provider drop down list below Media Parameters section, 
select the provider you wish to be the system default. You must select only a 
preconfigured TTS provider as the Default TTS Provider.

Note If you are deploying an VXML applications and the only TTS 
functionality you need is to play pre-recorded .wav files, select the Cisco 
LiteSSMLProcessor option as the Default TTS Provider. This option 
allows you to execute SSML that has .wav file references in them. 

Step 3 Click Update. 

Related Topic

Provisioning MRCP TTS Providers, page 7-35
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Provisioning MRCP TTS Servers 

Use the MRCP TTS Servers Configuration web page to configure the TTS 
server’s name, port location, and available languages.

You need at least one MRCP TTS Server associated with each configured 
provider.

Note You must have a MRCP TTS Provider defined before you can provision a MRCP 
TTS Server.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > MRCP 
TTS > MRCP TTS Server.

The MRCP TTS Server Configuration web page opens, displaying a list of 
previously configured servers, if applicable with the following information:

Column Description

Computer Name Host name or IP address of the server in which the TTS server software is installed.

Note TTS server deployment over WAN is not supported in Unified CCX. In other 
words, the TTS server should be in the same LAN where Unified CCX is. 
Thus, you need to specify the TTS server host name or IP address that is 
local with the Unified CCX node while installing the TTS server software in 
this field. 

Port TCP port numbers used to connect to a MRCP server:

 • IBM WebSphere Voice Server

 • Nuance Vocalizer 4.0

 • Scansoft Realspeak 4.0

Provider The MRCP TTS Provider to which this server is associated.

Status Status or state of the subsystem. 
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Step 2 Click Add MRCP TTS Server icon that displays in the tool bar in the upper, left 
corner of the window or the Add New button that displays at the bottom of the 
window to provision a new MRCP ASR Server.

The MRCP TTS Server Configuration web page opens. 

Step 3 Use this web page to specify the following fields.

Step 4 Click Add to apply changes. 

Your changes appear in the MRCP TTS Server Configuration web page. You are 
now ready to provision MRCP TTS Default Genders.

Note Whenever a new language is added for a MRCP Server—and if this is the first 
instance of this language being added for the corresponding MRCP 
Provider—then the default gender for that locale and for the specified provider is 

Field Description

Server Name Host name or IP address of the server the MRCP TTS server software is installed.

Provider Name Select the name of the MRCP TTS Provider to which this server is associated from 
this drop-down list. 

Port Number TCP port number used to connect to a MRCP TTS server. The port numbers are 
automatically displayed based on the provider or grammar variant that you have 
selected while configuring a MRCP TTS provider. Following are the different TCP 
Provider names along with their port numbers:

 • IBM WebSphere Voice Server V5.1.3 - 554

 • Nuance Vocalizer 4.0 - 554

 • Scansoft Realspeak 4.0 - 4900

Locales Languages supported by the TTS Provider. Select a language (or multiple 
languages) from the drop-down list and click Add Language; the selected language 
appears in the Enabled Language list.

Note Use the check box to disable/enable a language.
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set to Neutral. You should check the MRCP Locales page to review the default 
genders that are set automatically per locale per provider. Default genders are 
used when a prompt for a specific locale is used without specifying any gender. 

Related Topics

 • Provisioning MRCP TTS Providers, page 7-35

 • Provisioning MRCP TTS Default Genders, page 7-39

Provisioning MRCP TTS Default Genders

Use the MRCP TTS Default Genders Configuration web page to configure the 
default gender settings per Locale per Provider. TTS uses default genders when a 
prompt for a specific locale is used without specifying the gender. 

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > MRCP 
TTS > MRCP TTS Default Genders.

The MRCP TTS Default Gender Configuration web page opens displaying the 
default genders currently configured for each locale for every MRCP TTS 
Provider that is currently configured.

Step 2 Optionally, change the default gender setting for each locale for each provider.

Note The Locale radio button has the Male, Female, or Neutral options. By 
default, the “Default Gender” is set to “Neutral” unless configured 
explicitly.

Step 3 Click Update to apply changes. 

The system updates the default gender setting for each Locale per Provider.

Related Topics

 • Provisioning MRCP TTS Providers, page 7-35
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 • Provisioning MRCP TTS Servers, page 7-37
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Provisioning Unified CCX

To provision the Unified CCX subsystem, you must provision your telephony and 
media resources (see the “About Unified CCX Telephony and Media” section on 
page 7-1).

Tip This section is common to both the Unified CM and Unified CME deployments. 
Where applicable, a note calls attention if a particular section does not apply to 
Unified CME.

The following topics introduce the Unified CCX subsystem and explain how to 
provision it in the Unified CCX system. 

 • Configuring RmCm Provider, page 8-2

 • Configuring Resource Groups, page 8-4

 • Configuring Skills, page 8-7

 • Configuring Agents, page 8-10

 • Configuring Contact Service Queues, page 8-17

 • Configuring and Using Remote Monitoring, page 8-30

 • Configuring Agent-Based Routing, page 8-34

 • Configuring Teams, page 8-35

 • Unified Gateway Auto-Configuration Details, page 8-40
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Configuring RmCm Provider 
The Unified CCX Resource Manager (RM) uses a Unified CM/Unified CME 
Telephony user (called the RmCm Provider) to monitor agent phones, control 
agent states, and route and queue calls. See Installing Cisco Unified Contact 
Center Express Release 8.5(1) Guide for detailed instructions on how to configure 
the RmCm Provider user.

Note For Unified CME, the concept of RmCm user does not exist. The AXL Service 
provider account is used to preform this task. 

Note The RmCm user specified through Unified CCX Administration is updated 
automatically in Unified CM.

This section contains the following topics:

 • Modifying RmCm Provider, page 8-2

 • Associating Agent Extensions with the RmCm Provider, page 8-3

Modifying RmCm Provider 

Note This section only applies to Unified CCX Deployments with Unified CM.

Caution While Unified CM supports Unicode characters in first and last names, those 
characters become corrupted in Unified CCX Administration web pages for 
RmCm configuration, Real Time Reporting, Cisco Agent/Supervisor Desktop, 
and Historical Reports.

The RmCm Provider web page is a read-only page that displays the latest 
configured information. To access this configuration area, choose Subsystems > 
RmCm > RmCm Provider from the Unified CCX Administration menu bar. The 
RmCm Provider web page opens displaying the following read-only fields.
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To modify the RmCm Provider, click Modify RmCm Provider Information 
icon in the tool bar in the upper, left corner of the window. The Cisco Unified CM 
Configuration web page opens. See Modifying RmCm Provider Information, 
page 4-10 for detailed instructions on how to change previously-configured 
RmCm provider information.

Related Topic

Modifying RmCm Provider Information, page 4-10

Associating Agent Extensions with the RmCm Provider 

Note This section only applies to Unified CCX Deployments with Unified CM.

For every agent/resource created in Unified CM make sure that the agent phone 
is also associated with the RmCm Provider. You do this from the Unified CM 
User Page for the RmCm Provider. In other words, even though you create the 
RmCm User in Unified CCX Administration, you still need to use the Unified CM 
interface to associate the RmCm user with an agent phone. These phones are the 
same as those associated with each agent (see Assigning Unified CM Users as 
Unified CCX Agents, page 4-18).

Field Description

Primary RmCm Provider The host name or IP address of the Cisco Media Convergence Server 
(Cisco MCS) running CTI Manager (Unified CM that runs CTI 
Manager).

The RmCm subsystem registers with the CTI Manager so that it can 
observe an agent's device when the agent logs in. When the CTI 
Manager fails, the RmCm subsystem registers with the second CTI 
Manager, if there is one configured. 

Secondary RmCm Provider The host name or IP address of the secondary RmCm Provider.

User ID The RmCm user ID.
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For detailed information on Unified CME configuration, see the Configuration 
page for Unified CME at  
http://www.cisco.com/en/US/products/sw/voicesw/ps4625/tsd_products_support
_configure.html.

Configuring Resource Groups
Resource groups are collections of agents that your CSQ uses to handle incoming 
calls. To use resource group-based CSQs, you must specify a resource group.

This section describes:

 • Creating a Resource Group, page 8-4

 • Modifying an Existing Resource Group Name, page 8-5

 • Deleting a Resource Group, page 8-6

Creating a Resource Group
To create a resource group, complete the following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > RmCm 
> Resource Groups.

The Resource Group web page opens with a list of configured resource groups (if 
any). 

Step 2 Click Add New icon in the tool bar in the upper, left corner of the window or Add 
New button at the bottom of the window.

The Resource Group Configuration area opens. 

Step 3 In the Resource Group Name field, enter a resource group name.

Enter a name that identifies the resource group to which you want to assign agents 
(for example, “Languages”). 

Step 4 Click Add.
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The Resource Groups page opens displaying the resource group name in the 
Resource Group Name column. 

Related Topics

 • Modifying an Existing Resource Group Name, page 8-5

 • Deleting a Resource Group, page 8-6

Modifying an Existing Resource Group Name
To modify a resource group name, complete the following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > RmCm 
> Resource Groups.

The Resource Group web page opens. 

Step 2 In the Resource Group Name column, click the resource group that you want to 
modify.

The Resource Group Configuration area opens.

Step 3 Type the name of the resource group in the Resource Group Name text field.

Step 4 Click Update to apply the modifications.

The Resource Groups area opens, displaying the modified resource group name 
in the Resource Group Name column.

Related Topics

 • Creating a Resource Group, page 8-4

 • Deleting a Resource Group, page 8-6
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Deleting a Resource Group
When you delete a resource group, the resource group is removed automatically 
if it is not associated with any agents and CSQs. If the resource group is associated 
with any agents or CSQs and if you click Delete, then you will be directed to 
another web page, where you can see a list of the associated CSQs and agents and 
you are prompted to confirm whether you want to delete the same.

Tip To delete resource groups, you can use the following procedure or open a 
Resource Group and click Delete icon or button in the Resource Group 
Configuration web page.

To delete a resource group, complete the following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > RmCm 
> Resource Groups.

The Resource Group web page opens. 

Step 2 Click Delete icon next to the name of the Resource Group that you want to delete.

A dialog box opens, warning that the resource group is about to be permanently 
deleted

Step 3 Click Continue.

The resource group is deleted. 

Related Topics

 • Creating a Resource Group, page 8-4

 • Modifying an Existing Resource Group Name, page 8-5
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Configuring Skills 
Skills are customer-definable labels assigned to agents. All the Unified CCX 
license packages can route incoming calls to agents who have the necessary skill 
or sets of skill to handle the call.

This section describes:

 • Creating a Skill, page 8-7

 • Modifying an Existing Skill Name, page 8-8

 • Deleting a Skill, page 8-9

Creating a Skill
To create a skill, complete the following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > RmCm 
> Skills.

The Skills web page opens to display the Skill Name (customer-definable label 
assigned to an agent), if configured. 

Step 2 Click Add New icon in the tool bar in the upper, left corner of the window or Add 
New button at the bottom of the window.

Note When the system reaches the maximum number of skills that can be 
created, the Add New icon or button no longer appears.

The Skill Configuration web page opens. 

Step 3 In the Skill Name field, enter a description of a relevant skill (for example, 
French).

Step 4 Click Add.
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The Skills web page opens, showing the skill in the Skill Name column and the 
total number of skills that exist in the system. You can add a maximum of 150 
skills.

Related Topics

 • Modifying an Existing Skill Name, page 8-8

 • Deleting a Skill, page 8-9

Modifying an Existing Skill Name
To modify a skill name, complete the following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > RmCm 
> Skills.

The Skills web page opens. 

Step 2 In the Skill Name column, click the skill that you want to modify.

The Skill Configuration web page opens.

Step 3 Modify the name of the skill in the Skill Name text field.

Step 4 Click Update to apply the modifications.

The Skills Configuration summary opens, displaying the modified skill name in 
the Skill Name column.

Related Topics

 • Creating a Skill, page 8-7

 • Deleting a Skill, page 8-9
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Deleting a Skill
When you delete a skill, the skill is removed automatically if it is not associated 
with any agents and CSQs. If the skill is associated with any agents or CSQs and 
if you click Delete, then you will be directed to another web page, where you can 
see a list of the associated CSQs and agents and you are prompted to confirm 
whether you want to delete the same. 

Tip To delete skills, you can use the following procedure or open a skill and click 
Delete icon or button in the Skills Configuration web page. 

To delete a skill, complete the following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > RmCm. 
> Skills.

The Skills web page opens. 

Step 2 Click Delete icon next to the name of the skill that you want to delete.

A dialog box opens, warning that the skill is about to be permanently deleted.

Step 3 Click Continue.

The skill is deleted.

Related Topics

 • Creating a Skill, page 8-7

 • Modifying an Existing Skill Name, page 8-8
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Configuring Agents 
Once the end users in Cisco Unified Communications1 are defined as agents, the 
list of agents and their associated Unified CCX devices are displayed in the 
Subsystems > RmCm > Resources page. These agents are also called resources. 
After you create a resource group, you can assign agents (resources) to that group. 

If you have Unified CCX Standard license package, you can add skills to agents 
once the skills have been created. You can also select the competence level of the 
agent(s) in assigned skills. Competence level indicates the agent’s level of 
expertise in that skill.

You can assign resource groups and skills to agents either individually or in bulk. 
The bulk option enables you to assign skills and resource groups to multiple 
agents at the same time. 

Once you assign agents to resource groups and skills, you can create a CSQ (see 
Configuring Contact Service Queues, page 8-17).

This section describes:

 • Implications of Deleting Agents in Unified CM, page 8-11

 • Assigning Resource Groups and Skills to One Agent, page 8-12

 • Assigning Resource Groups and Skills to Multiple Agents, page 8-14

 • Removing Skills from Agents, page 8-16

Related Topics

 • Assigning Unified CM Users as Unified CCX Agents, page 4-18

 • Modifying an Existing Resource Group Name, page 8-5

 • Deleting a Resource Group, page 8-6

1. Unified Communications users in a Unified CM deployment refers to a Unified CM 
user. Unified Communications users in a Unified CME deployment refers to a 
Unified CCX user. End users or agents in a Unified CME deployment is created in 
the Unified CCX. 
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Implications of Deleting Agents in Unified CM

Note This section only applies to Unified CCX Deployments with Unified CM.

If you modify an agent’s record in Unified CM (for example, changing the 
Unified CCX extension or deleting the agent), ensure to refresh the user page on 
Unified CCX Administration interface so that the agent’s information in the 
Unified CCX RmCm subsystem is updated. Choose Subsystems > RmCm > 
Resources option to update the Unified CCX information in the Unified 
CCX Administration any time. If you change the Unified CCX extension of an 
agent who is currently logged in, the agent will continue to use the old extension 
until the agent logs off. The agent must log off and then log back in to the 
Cisco Agent Desktop to get the new extension.

When Unified CCX detects that the agent no longer exists in Unified CM, it does 
not automatically delete that agent from the Unified CCX database. Instead, the 
Unified CCX Resources page displays a new link called Inactive Agents. When 
you click this link, Unified CCX displays a list of agents deleted from Unified CM 
but still existing in the Unified CCX database. In this case, select the agents to 
delete from Unified CCX by checking the check box next to the required agent (or 
select all agents for deletion by clicking Check All). Then click Delete to remove 
the selected agents from the Unified CCX database. Unless you follow this 
procedure, agents deleted in Unified CM will continue to appear in the agents list 
in the Unified CCX Resources page, but they will not be able to log in as the 
Unified CM authentication will not be successful.

Caution Deleting Inactive Agents removes the agent details and records from the 
Historical Reporting Database and HR reports will not display historical 
information of these agents. 
If Unified CM connection errors have occurred, all agents will not be visible to 
Unified CCX. In this case, Unified CCX interprets these agents as deleted agents. 
As a result, the Inactive Agents list will not be accurate. When the errors are 
resolved, click Inactive Agents again to see an accurate list.

Related Topics

 • Defining Unified CM Users as Agents, page 4-13

 • Assigning Resource Groups and Skills to One Agent, page 8-12
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 • Assigning Resource Groups and Skills to Multiple Agents, page 8-14

 • Removing Skills from Agents, page 8-16

Assigning Resource Groups and Skills to One Agent
To assign a resource group and skills to an individual agent, complete the 
following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > RmCm 
> Resources.

The Resources web page opens. 

Note Only agents or supervisors who have assigned Unified CCX extensions 
are displayed in the list of resources in the Resources area.

Step 2 Use this web page to view the following fields. 

Step 3 Click the name of the agent in the Resource Name column. 

The Resource Configuration web page opens.

Step 4 Use this web page to specify the following fields. 

Field Description

Resource Name Name of the agent.

Resource Group Resource group to which the agent has been assigned.

IPCC Extension Unified CCX Extension assigned to the resource group. 

Team Team to which the agent belongs.
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Step 5 Click Update to apply the changes. 

The Resources area of the RmCm Configuration summary web page opens, and 
the agent is now assigned to the resource group and skills (if skills were assigned).

Field Description

Resource Name Name of the agent (Display only).

Resource ID Unique identifying number of the agent (Display only). This is the 
alpha-numeric user id assigned in the Unified CM End User Configuration 
page.

Unified CCX Extension Unified CCX Extension assigned to the resource group (Display only). This 
is the IP Phone extension assigned to the user from the Unified CM End 
User Configuration page as IPCC Extension.

Resource Group A resource group with which to associate the agent. (Optional).

Automatic Available Accept the default (Enabled) to automatically put the agent into the 
Available or Ready state after the agent finishes a call and disconnects.

Note When a logged on agent in Ready, Not Ready, or Work state 
answers a call, the agent’s state is subject to the Automatic 
Available setting. (See Creating a CSQ, page 8-18.)

Assigned/Unassigned 
Skills 

Select one or more skills from the Unassigned Skills list and click < to add 
the skills to the Assigned Skills List. 

Select one or more skills from the Assigned Skills List and click > to 
remove skills from the Unassigned Skills list.

You can assign up to 50 skills to the agent.

Note You can change the competency level of one skill at a time, only. 
You cannot change skill competency level as a bulk procedure. 

Competence Level Select a skill from the Assigned Skills list and choosing a number from the 
Competence Level drop-down menu

Changes the competence level of an assigned skill (1 = Beginner, 10 = 
Expert).

Team A group of agents who assign the team to which the resource belongs.
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Related Topics

 • Implications of Deleting Agents in Unified CM, page 8-11

 • Assigning Resource Groups and Skills to Multiple Agents, page 8-14

 • Removing Skills from Agents, page 8-16

Assigning Resource Groups and Skills to Multiple Agents
To assign resource groups and skills to agents in bulk, complete the following 
steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, Subsystems > RmCm > Assign 
Skills.

The Assign Skills summary web page opens. 

Tip Only agents or supervisors who have assigned Unified CCX extensions 
are displayed in the list of resources in the Resources area.

Step 2 Use this web page to view the following fields: 

Step 3 In the Resource Name column, check the check box beside each agent to whom 
you want to assign set of same resource group and skills. In the Resource Name 
column, check the check box next to each agent you want to assign set of same 
resource group and skills.

Note You can check the Select All check box to select all agents.

Field Description

Resource Name Contains the agent’s name. 

Resource Group Contains the resource group assigned to the agent.

Cisco Unified CCX 
Extension

Contains the Unified CCX extension of the agent.
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The Skill summary web page shows the total number of skills created. 

Step 4 Click Add Skill icon that displays in the tool bar in the upper, left corner of the 
window or the Add Skill button that displays at the bottom of the window.

The Add Skill web page opens. 

Step 5 Use this web page to specify the following fields. 

Step 6 Click Update to apply the changes. 

The Assign Skills area of the RmCm Configuration web page opens, and the 
agents are now assigned to the resource group and skills (if skills were assigned).

Related Topics

 • Implications of Deleting Agents in Unified CM, page 8-11

 • Assigning Resource Groups and Skills to One Agent, page 8-12

 • Removing Skills from Agents, page 8-16

Field Description

Resource Group To assign a resource group to all the selected agents, choose a resource 
group from the Resource Group drop-down menu. 

Skills to Add Select one or more skills from the Skills list and click < to add the skills to 
the Skills to Add List.

Note The Skills to Add list contains all skills, not just the skills that 
agents already have.

Skills List of the available skills.

Competence Level Select a skill from the Assigned Skills list and choosing a number from the 
Competence Level drop-down menu
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Note If a resource is not assigned a skill you attempt to remove, the resource is not 
updated. However, the system will still generate a related message.

To remove skills from agents, complete the following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > RmCm 
> Assign Skills.

The Assign Skill summary web page opens. 

Step 2 In the Resource Name column, click the check box next to the agent(s) you want 
to remove skills from. 

Note You can click Select All check box to select all agents.

Step 3 Click Remove Skill icon that displays in the tool bar in the upper, left corner of 
the window or the Remove Skill button that displays at the bottom of the window.

The Remove Skill Configuration web page opens. 

Step 4 Use this web page to specify the following fields. 

 

Step 5 Remove skills by choosing one or more skills from the Skills list and clicking > 
to move the skills to the Skills to Remove list. 

Step 6 Click Update to apply the changes. 

Field Description

Skills to Remove List of skills that can be removed from the selected agents.

Skills List of the skills not assigned to the agents.

Update Click this button to apply changes.

Cancel Click this button to cancel changes.
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The Assign Skills area of the RmCm Configuration web page opens, and the 
agents are no longer assigned to the skills.

Related Topics

 • Implications of Deleting Agents in Unified CM, page 8-11

 • Assigning Resource Groups and Skills to One Agent, page 8-12

 • Assigning Resource Groups and Skills to Multiple Agents, page 8-14

Configuring Contact Service Queues 
The Contact Service Queue (CSQ) controls incoming calls by determining where 
an incoming call should be placed in the queue and to which agent the call is sent. 

After you assign an agent to a resource group and skills, you need to configure the 
CSQs.

You assign agents to a CSQ by associating a resource group or by associating all 
skills of a particular CSQ. Agents in the selected resource group or having all the 
selected skills are assigned to the CSQ.

Skills within the CSQ can be ordered. This means, when resources are selected, 
a comparison is done based on the competency level (highest for “most skilled” 
and lowest for “least skilled”) of the first skill in the list. If there is a “tie,” then 
the next skill within the order is used, and so on.

Skills within the CSQ can also be weighted. The weight value is an integer from 
1 to 1000. Each competency level is multiplied by the skill's associated weight, 
and a final comparison is done on the sum of all the weighted skill competencies 
(highest value for “most skilled” and lowest for “least skilled”).

Note For an example of using skill order and weight to determine agent competency 
level, see “Resource Pool Selection Criteria: Skills and Groups” section on 
page 8-26.
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The maximum number of CSQs in the system depends on the type of server on 
which the engine is running. For example, in Unified CCX Release 8.5(1), the 
following numbers apply:

 • MCS-7845 (or equivalent platform): 150 CSQs 

 • All other platforms: 25 CSQs

For more information, see the Unified CCX Data Sheets at 
http://www.cisco.com/en/US/products/sw/custcosw/ps1846/prod_literature.html
.

Each agent can belong to up to 25 CSQs. To ensure that agents are not assigned 
to more than 25 CSQs, click Resources submenu option in the RmCm 
Configuration web page, and click Open Resources Summary Report icon. The 
report opens, listing each agent and the number of CSQs to which the agent 
belongs. If the agent belongs to more than 25 CSQs, modify the skills and 
resource groups to which the agent is assigned so that the agent does not belong 
to more than 25 CSQs.

This section describes the following procedures:

 • Creating a CSQ, page 8-18

 • Modifying an Existing CSQ, page 8-24

 • Deleting a CSQ, page 8-25

 • Resource Pool Selection Criteria: Skills and Groups, page 8-26

 • Resource Skill Selection Criteria Within a CSQ, page 8-28

Creating a CSQ
To create a new CSQ and assign agents, complete the following steps.

Note See Configuring Contact Service Queues, page 8-17 for the number of CSQs that 
you can create on your system.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > RmCm 
> Contact Service Queues.
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The Contact Service Queues web page opens. 

Step 2 Use this web page to view the following fields:

Step 3 Click Add New icon that displays in the tool bar in the upper, left corner of the 
window or the Add New button that displays at the bottom of the window. 

The Contact Service Queue Configuration web page opens.

Note If this link does not appear on the page, it means that the system has 
reached the maximum number of CSQs that can be created. The CSQ 
Summary page displays the total number of created CSQs.

Step 4 Use this web page to specify the following fields. 

Field Description

Name Name of the resource or skill group. 

Contact Queuing Criteria Algorithm used to order the queued calls (contacts).

Resource Pool Selection Model The resource selection criteria chosen for this CSQ.

Resource Pool The skills or resource group used for this CSQ.

CSQ Type The type of the CSQ.

Delete Deletes the selected CSQ. 

Field Description

Contact Service 
Queue Name

Enter a meaningful name that is concise, yet easy to recognize (for example, 
LanguageExperts). This is a mandatory field.

Contact Service 
Queue Type

Select one of the following options from this drop-down menu:

 • Voice (default)—Agents in this CSQ can handle inbound voice calls. 

 • Email—Agents in this CSQ can handle inbound email.

Note If you select Email CSQ type, you can configure only the Resource Pool 
Selection Model field. All other fields are not configurable.
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Contact 
Queuing 
Criteria

Display-only. Displays the criteria used for queuing the contacts. For example, First 
In, First Out (FIFO).

Automatic 
Work

Determines whether agents in this CSQ automatically enter Work state after a call. 
This is a mandatory field. Options are:

 • Enabled—Causes the agents to go into Work state automatically when a call 
ends. 

 • Disabled (default)—Causes agents to enter Ready or Not Ready state when a call 
ends, depending on the Automatic Available setting for the agent.

Note For more information, see Assigning Resource Groups and Skills to One 
Agent, page 8-12.

Wrapup Time Determines the length of the workstate for this CSQ after a call. Options are:

 • Enabled button with seconds field—The seconds field specifies the length of the 
workstate phase (greater than 0 second but less than 7200 seconds).

 • Disabled—No limit on how long the agent can stay in the workstate. 

Resource Pool 
Selection Model

Select one of the following options from the drop-down menu:

 • Resource Skills—To create a skills-based CSQ.

 • Resource Group—To create a resource group-based CSQ.

Note This is a mandatory field. For information about choosing between 
skill-based or group-based selection, see “Resource Pool Selection Criteria: 
Skills and Groups” section on page 8-26.

Service Level The target maximum number of seconds a call is queued before it is connected to an 
agent. This is a mandatory field.

Service Level 
Percentage

The target goal for percentage of contacts that meet the service level. This is a 
mandatory field.

For example, a call center that has a service level of 20 and a service level percentage 
of 80 percent has a goal of answering 80 percent of its calls within 20 seconds.

Field Description
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Step 5 Click Next. 

The second Contact Service Queue Configuration area opens with the 
newly-assigned CSQ Name. 

Step 6 Select an option from the Resource Selection Criteria drop-down menu. 

Note The Resource Selection Criteria field is displayed only if you have 
selected the CSQ type as Voice. This field is not configurable for an 
E-mail CSQ type.

Note The Resource Pool Selection Model settings determine the options 
available in this drop-down menu.

 • Longest Available—Selects the agent who has been in the Available state for 
the longest amount of time.

 • Most Handled Contacts—Selects the agent who has answered the most 
handled calls.

 • Shortest Average Handle Time—Selects the agent who generally spends 
the least amount of time talking to customers.

Prompt .wav prompt file to associate with the CSQ. You can retrieve the prompt file that you 
select from this Prompt drop-down list using the Create CSQ Prompt Step in the 
Unified CCX Editor. 

In the Unified CCX Editor, Create CSQ Prompt Step is one of the steps used to create 
scripts for the Unified CCX engine. In this step, you need to give the CSQ ID that is 
displayed as the last number in the AppAdmin address bar of the web page that is 
displayed when you click on an existing CSQ. For example, the CSQ ID will be 3 if 
the address bar of an existing CSQ Configuration web page ends with “&csdid=3”. 
When the script executes, it will return the prompt associated with the specific CSQ 
ID. Use the Play Prompt Step within the script to play this prompt. 

See the Cisco Unified CCX Editor Step Reference Guide for detailed information on 
scripting.

Field Description
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 • Most Skilled—Used for expert agent call distribution. Selects the agent with 
the highest total competency level. The total competency level is determined 
by adding the agent’s competency levels for each of their assigned skills that 
are also assigned to the CSQ.

 – Example 1: If Agent1 is assigned Skill1(5), Skill2(6), and Skill3(7) and 
CSQ1 specifies Skill1(min=1) and Skill3(min=1), the total competency 
level for Agent1 for CSQ1 is 12.

 – Example 2: If Agent1 is assigned Skill1(5) and Skill2(6) and Skill3(7) 
and CSQ1 specifies Skill1(min=1), only, the total competency level for 
Agent1 for CSQ1 is 5.

 • Least Skilled—Used for expert agent call distribution. Selects the agent with 
the lowest total competency level. The total competency level is determined 
by adding the agent’s competency level in each assigned skill.

 • Most Skilled by Weight— Used for expert agent call distribution. Selects the 
agent with the highest total competency level multiplied by the skill’s 
associated weight.

 • Least Skilled by Weight—Used for expert agent call distribution. Selects the 
agent with the lowest total competency level multiplied by the skill’s 
associated weight.

 • Most Skilled by Order— Used for expert agent call distribution. Selects the 
agent with the highest total competency level in the ordered list.

 • Least Skilled by Order— Used for expert agent call distribution. Selects the 
agent with the lowest total competency level in the ordered list.

Note If two or more agents have equal competency level, then the selection 
automatically defaults to Longest Available selection criteria.

Step 7 Specify the following settings, as necessary:

Note The Resource Pool Selection Model setting determines the availability of 
these options.

a. Use the Select Skills list to highlight the skills you want; click Add button 
next to the list.
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b. Specify a Minimum Competence Level for the skills assigned to the CSQ. 
Depending on the Resource pool criteria you chose, specify a Weight value 
between 1 and 1000. 

c. If the Resource Selection Criteria is Most Skilled by Order or Least Skilled 
by Order, use the arrow icons to order the skills by moving them up or down 
in the list.

Note Use the Delete icon next to a skill to delete that skill from the Skills 
Required list.

Step 8 If you selected one of the Least/Most Skilled options as shown in the bulleted list 
below for the Resource Selection Criteria, you can view the agent order using 
Show Resources icon or button. 

Note The order of the agents determines the priority, the agent at the top of the 
list having the highest priority.

To change the order of the agents belonging to the CSQ, you should modify the 
skill set of the agents. The Least/Most Skilled Resource Selection Criteria option 
comprises the following:

 • Most Skilled 

 • Least Skilled

 • Most Skilled by Order

 • Least Skilled by Order

 • Most Skilled by Weight

 • Least Skilled by Weight

Step 9 If you selected Resource Groups as the Resource Pool Selection Model on the 
previous page, follow these steps: 

a. Select an option from the Resource Selection Criteria drop-down menu:

 – Longest Available—Selects the agent who has been in the Available 
state for the longest amount of time. 

 – Linear—Selects the next available agent with the highest priority, as 
determined by the agent order in the Resources list. 
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 – Circular—Selects the next available agent with the highest priority, 
based on the last agent selected and the agent order in the Resources list. 

 – Most Handled Contacts—Selects the agent who has answered the most 
handled calls.      

 – Shortest Average Handle Time—Selects the agent who generally 
spends the least amount of time talking to customers. 

b. Choose the resource group for this CSQ from the Resource Group drop-down 
menu.

c. Click Show Resources icon to show all agents who meet the specified 
criteria.

d. If you selected Linear or Circular as the Resource Selection Criteria, if 
necessary, rearrange the order of agents in the Resources list by highlighting 
an agent and using the up and down arrows to move the agent in the list. 

e. Click Add to apply changes and update the system.

The new CSQ is now displayed, and all agents who belong to the resource group 
or all selected skill groups are now a part of this CSQ.

Related Topics

 • Modifying an Existing CSQ, page 8-24

 • Deleting a CSQ, page 8-25

 • Resource Pool Selection Criteria: Skills and Groups, page 8-26

 • Resource Skill Selection Criteria Within a CSQ, page 8-28

Modifying an Existing CSQ

Note Changes take effect when all agents affected by the changes have left the Ready 
state. 

To modify an existing CSQ, complete the following steps.
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Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > RmCm 
> Contact Service Queues.

The Contact Service Queues web page opens. 

Step 2 In the Name list, click the CSQ that you want to modify.

The Contact Service Queue Configuration page opens.

Step 3 Modify the Contact Service Queue Configuration information as necessary. 

Note Click Next icon that displays in the tool bar in the upper, left corner of the window 
or the Next button that displays at the bottom of the window to view and update 
the remaining fields.

Step 4 Click Update icon in the top of the window or the Update button that displays at 
the bottom of the window to apply the modifications.

Related Topics

 • Creating a CSQ, page 8-18

 • Deleting a CSQ, page 8-25

 • Resource Pool Selection Criteria: Skills and Groups, page 8-26

 • Resource Skill Selection Criteria Within a CSQ, page 8-28

Deleting a CSQ
When you delete a CSQ, any skills or resource groups assigned to that CSQ are 
automatically removed from the CSQ, and any application using that CSQ can no 
longer access it. Before deleting the CSQ, change the applications to use a 
different CSQ. If the application is using a CSQ when the CSQ is deleted, new 
incoming calls will get an error and existing queued calls will not be routed to 
agents. 
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To delete a CSQ, complete the following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > RmCm 
> Contact Service Queues.

The Contact Service Queues web page opens.

Step 2 Click Delete icon next to the name of the CSQ that you want to delete. 

Note You can also delete a CSQ from its Contact Service Queue Configuration 
page using the Delete icon or button.

Related Topics

 • Creating a CSQ, page 8-18

 • Modifying an Existing CSQ, page 8-24

 • Resource Pool Selection Criteria: Skills and Groups, page 8-26

 • Resource Skill Selection Criteria Within a CSQ, page 8-28

Resource Pool Selection Criteria: Skills and Groups
The resource selection criteria available for CSQs with Resource Skills is 
different from that of CSQs with Resource Groups. 

Example—In a banking application with two skills (Banking and CreditCard) and 
one Resource Group (General Queries), assume that the following agents, skills, 
and resource groups are defined:
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In addition, suppose you had the following Contact Service Queue information 
defined:

In this scenario, if a caller calls with a question about CreditCard information and 
there are no CSQs currently available with CreditCard skills (that is, Agent1 and 
Agent2), there is a possibility for Agent3—who has no CreditCard skill—to get 
selected as the Longest Available Agent. 

To avoid such a situation, you could design the script to always look into CSQ2 
for available agents since it has the highest competency of 10 for CreditCard, and 
agent selection here is based on most skilled. 

Note If two or more agents have equal competency level, then the selection 
automatically defaults to Longest Available selection criteria.

Agent ID Assigned Skills Resource Group

Agent1 Banking (Competence Level 10)

CreditCard (Competence Level 6)

GeneralQueries

Agent2 Banking (Competence Level 5)

CreditCard (Competence Level 10)

GeneralQueries

Agent3 None GeneralQueries

Table 8-1 Agent Skill and Resource Group Settings

CSQ Name
Resource Pool 
Selection Model 

Resource Selection 
Criteria Skill/Competence

Available 
Agents 

CSQ1 Resource Skills Most Skilled Banking
Minimum competency: 5

Agent1
Agent2

CSQ2 Resource Skills Most Skilled CreditCard
Minimum competency: 5

Agent1
Agent2

CSQ3 Resource Group Longest Available GeneralQueries Agent1
Agent2
Agent3
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Related Topics

 • Creating a CSQ, page 8-18

 • Modifying an Existing CSQ, page 8-24

 • Deleting a CSQ, page 8-25

 • Resource Skill Selection Criteria Within a CSQ, page 8-28

Resource Skill Selection Criteria Within a CSQ
Resource selection within a CSQ is based on the resource competency levels of 
the skills associated to the CSQ. You can choose between the most and least 
skilled. 

The Unified CCX system defines a Level 10 competency to be the highest skill 
level, while a Level 1 denotes the lowest skill level. When more than one skill is 
involved, each skill is given the same weight, meaning no preference is given to 
any skill. A comparison is performed on the sum of all the competency levels for 
the associated skills. (Skills assigned to resources but not associated to the CSQ 
are ignored.) In the case of a tie when skill competencies are equal, the resource 
that has been ready for the longest amount of time will be chosen. 

The following table provides examples of how Unified CCX selects resources 
within a CSQ.

Table 8-2 Resource Skill Selection Criteria

Example CSQ Skills
Agent Competency 
Levels

Sequence Agents 
Become Ready Selection Order 

Most skilled 
resource selection 
model

Technical 
Support

Agent A = 10

Agent B = 10

Agent C = 5

A, B C A, B, C

C, A, B A, B, C

A, C, B A, B, C

C, B, A B, A, C

Least skilled 
resource selection 
model

Technical 
Support

Agent A = 10

Agent B = 10

Agent C = 5

A, B, C C, A, B

C, A, B C, A, B

A, C, B C, A, B

C, B, A C, B, A
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Related Topics

 • Creating a CSQ, page 8-18

 • Modifying an Existing CSQ, page 8-24

 • Deleting a CSQ, page 8-25

 • Resource Pool Selection Criteria: Skills and Groups, page 8-26

Note The ordering in the two examples above are not opposite because the selection criteria has 
changed from most to least skilled—when competency levels are equal, both selection models 
choose the resources that have been available for the longest time.

Most skilled 
resource selection 
model

Sales
Support

Agent A = Sales (10)
Support (5)

Agent B = Sales (5),
Support (10)

Agent C = Sales (5)
Support (1)

A, B, C A, B, C

C, A, B A, B, C

A, C, B A, B, C

C, B, A B, A, C

Least skilled 
resource selection 
model

Sales
Support

Agent A = Sales (10)
Support (5)

Agent B = Sales (5),
Support (10)

Agent C = Sales (5)
Support (1)

A, B, C C, A, B

C, A, B C, A, B

A, C, B C, A, B

C, B, A C, B, A

Table 8-2 Resource Skill Selection Criteria

Example CSQ Skills
Agent Competency 
Levels

Sequence Agents 
Become Ready Selection Order 
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Configuring and Using Remote Monitoring 

Note This section only applies to Unified CCX Deployments with Unified CM.

The Unified CCX Remote Monitoring feature allows a supervisor to call into any 
site where the supervisor has a Unified CM user profile and monitor an agent’s 
conversation.

Note The incoming and outgoing streams to/from the agent phone and the outgoing 
stream to the supervisor phone must have the same encoding with only G.711 
being supported.

When you, as a supervisor, monitor a conversation, you can hear all parties on the 
call. The parties will have no indication that you are monitoring the call. You 
cannot join the call or be heard by the parties. This is referred to as silent 
monitoring.

With Remote Monitoring, you can choose to monitor a call in either of these 
ways:

 • By resource (agent)—In this case, you identify the resource by agent 
extension. If the agent is on a call, monitoring will begin immediately. If the 
agent is not on a call, monitoring will begin when the agent is presented with 
a call (that is, when the agent’s phone rings) or when the agent initiates a call 
(that is, when the agent’s phone goes off-hook).

 • By CSQ—In this case, you will monitor the call of an agent who belongs to 
the CSQ. When you monitor by CSQ, you select the CSQ from a menu. When 
a call is presented to an agent who belongs to the selected CSQ, monitoring 
will begin for that agent and call.

Note For CSQ monitoring, the supervisor cannot start monitoring the call after it 
connects to the agent; the call must arrive at the agent after supervision begins. 
For agent monitoring, supervision can begin after the call connects to the agent.
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This section describes the steps needed to configure Remote Monitoring:

 • Creating a Remote Monitoring Supervisor, page 8-31

 • Assigning Resources and CSQs to a Supervisor, page 8-32

Related Topics

 • Configuring Remote Monitoring Application, page 6-16

 • Viewing CSQ IDs for Remote Monitoring, page 15-8

Creating a Remote Monitoring Supervisor

Note This section only applies to Unified CCX Deployments with Unified CM.

Use the User Management web page to assign supervisor privileges to a user. 

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Tools > User 
Management > Supervisor Capability View.

The User Configuration web page opens displaying the list in two panes. The left 
pane displays the list of existing Unified CCX Supervisors and the right pane 
displays the list of Available Users. 

Step 2 Change the users as required using the arrow in either direction.

Your changes are dynamically displayed in this page and are effective 
immediately.

Step 3 Repeat this process as needed to assign the Supervisor capability for more than 
one user. 
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Click Back to User List icon that displays in the tool bar in the upper, left corner 
of the window or the Back to User List button that displays at the bottom of the 
window to view the list of existing users. This web page display the following 
fields.

Related Topics

 • Configuring and Using Remote Monitoring, page 8-30

 • Assigning Resources and CSQs to a Supervisor, page 8-32

 • Configuring Remote Monitoring Application, page 6-16

 • Viewing CSQ IDs for Remote Monitoring, page 15-8

Assigning Resources and CSQs to a Supervisor

Note This section only applies to Unified CCX Deployments with Unified CM.

Use the Remote Monitor configuration web page to assign a Supervisor a list of 
Resources and CSQs that he/she is allowed to monitor.

Field Description

User Id Unique identifier of the user for which the spoken name is to be uploaded.

Note The User Id must be numerical.

First Name The first name for each user. You can sort this field alphabetically.

Last Name The last name for each user. You can sort this field alphabetically.

Capability The capability assigned for each user. You can sort this field alphabetically.
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Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > RmCm 
> Remote Monitor.

The Remote Monitor web page opens to display the Supervisor, Name, and User 
ID of Unified CM users who are Unified CCX supervisors (if configured).

Note The Remote Monitor submenu option is available only if you are using 
Unified CCX Premium license package.

Step 2 Click a User ID value. 

Note This is a Unified CM user configured as a Unified CCX supervisor. (see 
Creating a Remote Monitoring Supervisor, page 8-31).

The Remote Monitor Configuration web page opens. 

Step 3 Use this web page to specify the following fields. 

Step 4 Click Update to apply the changes. 

The Remote Monitor area of the RmCm Configuration web page reappears.

The Supervisor can now access the Unified CCX Supervisor web page and view 
the allowed CSQs and agents.

Field Description

Contact Service Queues Name (Check box.) CSQ Names the supervisor can monitor.

Resources (Check box.) User IDs of agents the supervisor can monitor.
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Tip When running the Remote Monitoring script, you might need to provide 
a CSQ ID. This ID is internally generated and is only visible on the 
Unified CCX Supervisor page (see Viewing CSQ IDs for Remote 
Monitoring, page 15-8).

Related Topics

 • Configuring and Using Remote Monitoring, page 8-30

 • Creating a Remote Monitoring Supervisor, page 8-31

 • Configuring Remote Monitoring Application, page 6-16

 • Viewing CSQ IDs for Remote Monitoring, page 15-8

Configuring Agent-Based Routing
Agent-based routing provides the ability to send a call to a specific agent, rather 
than any agent available in a CSQ. 

Use the Agent Based Routing Settings web page to configure system-wide 
parameters to be used in an agent-based routing application.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > RmCm 
> Agent Based Routing Settings. The Agent-Based Routing Settings area opens.

Note The Agent Based Routing Settings is available only if you are using 
Unified CCX Enhanced or Premium license packages.

Step 2 Use this web page to specify the following fields. 
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Step 3 Click Save icon that displays in the tool bar in the upper, left corner of the window 
or the Save button that displays at the bottom of the window to apply changes.

Wrap-Up Data Usage
Contact centers use wrap-up data to track the frequency of activities or to identify 
the account to which a call is charged, and other similar situations. Like reason 
codes, wrap-up data descriptions are set up by your system administrator to reflect 
the needs of your contact center. By default this feature is disabled.

If the wrap-up data feature is enabled in Cisco Desktop Administration, the agent 
will see a pop-up window when he moves to work state in which he can select the 
appropriate description that sums up the call outcome.

See the Cisco Desktop Administrator User Guide for more information.

Configuring Teams
A team is a group of agents who report to the same supervisor. A team can have 
one primary supervisor and optional secondary supervisor(s). A supervisor can 
also monitor CSQs that are assigned to the team being supervised.

Field Description

Automatic Work Determines if agents automatically move to the Work state after a call. 

 • Enabled—Causes agents to go into Work state automatically when a call ends.

 • Disabled (default)—Causes agents to enter Ready or Not Ready state when a 
call ends, depending on the Automatic Available setting for the agent.

Wrapup Time Determines if agents automatically enter Wrapup after a call. 

 • Enabled button with seconds field—Controls how long the agent can stay in 
the Work state if Automatic work is enabled. The seconds field specifies the 
Wrapup time length (greater than 0 second but less than 7200 seconds).

 • Disabled (default)—No limit of how long the agent can stay in the Work state 
if Automatic Work is enabled.
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Barge-in is when a supervisor joins an existing call between an agent and a 
customer.

Intercept is when the supervisor joins a call and drops the agent from the call.

A default team is automatically created by the system and cannot be deleted. If 
agents are not assigned to any team, they belong to the default team. When an 
agent is assigned to a team, the team’s supervisor can barge-in and intercept any 
call being handled by the agent.

Note Before creating a team, you must set up supervisors using the User Management 
page.

This section describes:

 • Creating a Team Supervisor, page 8-36

 • Creating Teams, page 8-37

 • Modifying Agents on Teams, page 8-39

 • Deleting a Team, page 8-39

Creating a Team Supervisor
You can use the following procedure to view a list of all users. Double-click the 
required user and change the capability for that user to Supervisor. 

Use the User Management web page to assign supervisor privileges to a user. 

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Tools > User 
Management > Supervisor Capability View. 

The User Configuration web page opens displaying the list in two panes. The left 
pane displays the list of existing Unified CCX Supervisors and the right pane 
displays the list of Available Users. 

Step 2 Change the users as required using the arrow in either direction.

Step 3 Click Update to save your changes so that they are effective immediately.
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Click Back to User List icon that displays in the tool bar in the upper, left corner 
of the window or the Back to User List button that displays at the bottom of the 
window to view the list of existing users. This web page display the following 
fields.

Related Topics

 • Creating Teams, page 8-37

 • Modifying Agents on Teams, page 8-39

 • Deleting a Team, page 8-39

Creating Teams
Use the Teams area of the RmCm Configuration web page to create or associate 
teams with various agents, CSQs, and supervisors.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > RmCm 
> Teams.

The Teams web page opens displaying the following fields. 

Field Description

User Id Unique identifier of the user for which the spoken name is to be uploaded.

Note The User Id must be numerical.

First Name The first name for each user. You can sort this field alphabetically.

Last Name The last name for each user. You can sort this field alphabetically.

Capability The capability assigned for each user. You can sort this field alphabetically.
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Step 2 Click Add New icon that displays in the tool bar in the upper, left corner of the 
window or the Add New button that displays at the bottom of the window.

The Team Configuration page appears. 

Step 3 Use this web page to specify the following fields. 

Note Primary and secondary supervisors are users configured as Unified CCX 
supervisors (see Creating a Team Supervisor, page 8-36).

Step 4 Click Add to apply changes.

Related Topics

 • Creating a Team Supervisor, page 8-36

Field Description

Team Name Name for the team.

Primary Supervisor (Drop-down list.) Primary supervisor for the team. 

The drop-down list contains users designated as supervisors on the User 
Management web page.

Field Description

Team Name Name for the team. This is a mandatory field.

Primary Supervisor Assign a Primary supervisor for the team from this drop-down list.

Secondary Supervisors / 
Available Supervisors

Use the arrow buttons to assign secondary supervisors for the team. 

Assigned Resources / Available 
Resources

Use the arrow buttons to assign or remove resources for the team 
from the available resources. 

Note You cannot remove resources from the default team.

Assigned CSQs / Available 
CSQs

Use the arrow buttons to assign or CSQs for the team. 

Note You can remove CSQs from the default team.
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 • Modifying Agents on Teams, page 8-39

 • Deleting a Team, page 8-39

Modifying Agents on Teams
Use the Teams area to add agents or change agents on an existing Team.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > RmCm 
> Teams.

The Teams web page opens. 

Step 2 Click a name in the Team Name column

The Team Configuration page appears. 

Step 3 Select an agent name in the Resources Assigned to other Teams list and use the 
arrow icon to move it into the Assigned Resources list if you want to add an agent 
to this team. 

To remove an agent from this team, select an agent name in the Assigned 
Resources list and use the arrow icon to move it into the Resources Assigned to 
other Teams list. This agent now belongs to the default team.

Step 4 Click Update to apply changes.

Related Topics

 • Creating a Team Supervisor, page 8-36

 • Creating Teams, page 8-37

 • Deleting a Team, page 8-39

Deleting a Team
Use the Teams area of the RmCm Configuration web page to delete an existing 
Team.
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Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > RmCm 
> Teams.

The Teams web page opens. 

Step 2 Click Delete icon for the Team Name you want to delete.

The system prompts you to confirm the delete. 

Step 3 Click OK.

Related Topics

 • Creating a Team Supervisor, page 8-36

 • Creating Teams, page 8-37

 • Modifying Agents on Teams, page 8-39

Unified Gateway Auto-Configuration Details

Note Unified CCX supports ACD integration with the Cisco Unified Intelligent 
Contact Management Enterprise (Unified ICME) solution by way of the Cisco 
Unified Gateway. The Unified Gateway is a Peripheral Gateway (PG) which is 
configured on the Unified ICME software. The Unified Gateway is no longer 
coresident on the Unified CCX server as opposed to the earlier versions of Unified 
CCX. The CTI protocol, supports integration of Unified Gateway with Unified 
ICME. The Cisco IPCC Gateway Deployment Guide for Cisco Unified 
ICME/CCE/CCX provides an overview of the Unified Gateway feature, lists the 
supported deployment options, provides comparative information, and includes 
information on configuring and integrating the Unified Gateway.

Some of the configurations performed on the Unified CCX using the appropriate 
web page in Unified CCX Administration will be automatically configured on 
Unified ICME via the Unified Gateway. The following table provides a list of 
8-40
Cisco Unified CCX Administration Guide, Release 8.5(1)



Chapter 8      Provisioning Unified CCX
Unified Gateway Auto-Configuration Details
these configurations, the equivalent term used on Unified ICME for these 
configurations, and the Configuration Manager tool that can be used on the 
Unified ICME Admin Workstation to view these configurations.

Note These configurations and their attributes cannot be changed on Unified ICME if 
auto-configuration is enabled on Unified ICME.

Unified CCX Term
Unified ICME 
Term Unified ICME Configuration

Application Service Service Explorer

Route Point (Trigger) Routing Device Peripheral Monitor Table

CSQ Skill Group Skill Group Explorer

Resource Agent Agent Explorer

Note The agent extension goes to 
the Peripheral Monitor 
Table. 
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Provisioning Additional Subsystems

To provision additional subsystems, you must complete the following tasks:

 • Log into the Unified CCX Administration (see Chapter 2, “Accessing 
Unified CCX Administration Web Interface”).

 • Provision your telephony and media resources (see Chapter 7, “Provisioning 
Telephony and Media”).

 • Provision your Unified CCX subsystem, if required (see Chapter 8, 
“Provisioning Unified CCX”).

The following sections introduce the additional Unified CCX subsystems and 
explain how to provision them.

 • About Additional Subsystems, page 9-2

 • Provisioning Unified ICME Subsystem, page 9-3

 • Provisioning HTTP Subsystem, page 9-10

 • Provisioning Database Subsystem, page 9-12

 • Provisioning eMail Subsystem, page 9-16
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About Additional Subsystems
About Additional Subsystems
Your Unified CCX system may include some or all of the following additional 
subsystems:

 • The Unified ICME subsystem—The Unified CCX system uses the Cisco 
Unified Intelligent Contact Management Enterprise (Unified ICME) 
subsystem to communicate with Unified ICME to manage call distribution 
across sites and call-processing environments. (see Provisioning Unified 
ICME Subsystem, page 9-3). 

Note If you are using Unified CCX with Cisco Contact Center Gateway 
solution, please see the Cisco IPCC Gateway Deployment Guide for 
Cisco Unified ICME/CCE/CCX. The instructions for configuring 
Unified CCX with that solution differs from what is described in this 
guide. The Unified Gateway provides for the integration of the 
Unified ICME system with Unified CCX by way of the Unified 
Gateway. The Unified Gateway is a Peripheral Gateway (PG) which 
you configure on the Unified ICME software. 

 • The HTTP subsystem—The Unified CCX system uses the HTTP subsystem 
to enable Unified CCX applications to respond to requests from a variety of 
web clients, including computers and IP phones (see Provisioning HTTP 
Subsystem, page 9-10).

 • The Database subsystem—The Unified CCX system uses the Database 
subsystem to enable Unified CCX applications to interact with customer 
provided enterprise database servers to make database information accessible 
to contacts (see Provisioning Database Subsystem, page 9-12). 

 • The eMail subsystem—The Unified CCX system uses the eMail subsystem 
to communicate with your e-mail server and enable your applications to 
create and send e-mail. (see Provisioning eMail Subsystem, page 9-16).

If you plan to run applications that use any of the additional Unified CCX 
subsystems included in your Unified CCX package, you should now provision 
those subsystems. The Unified CCX system uses these additional subsystems to 
communicate with supporting systems such as Unified ICME, web servers, 
database servers, and e-mail servers. 
9-2
Cisco Unified CCX Administration Guide, Release 8.5(1)



Chapter 9      Provisioning Additional Subsystems
Provisioning Unified ICME Subsystem
Note You need to provision a particular subsystem only if you are using Unified CCX 
applications that require it.

Provisioning Unified ICME Subsystem

Note The Unified ICME subsystem is available if your system has a license installed 
for Unified IP IVR.

The Unified CCX system uses the Unified ICME subsystem to communicate with 
Unified ICME to manage call distribution across sites and call-processing 
environments. 

The Unified CCX server is frequently used as part of a Unified ICME solution 
with Unified ICME. In this type of installation, the Unified ICME uses the 
Unified CCX server to queue calls and perform other functions such as collecting 
caller-entered digits, performing database lookups, and playing back prompts.

Note If you are not using Unified ICME, you do not need to provision the Unified 
ICME subsystem.

Unified ICME scripts can direct calls based on various criteria such as the time of 
day or the availability of subsystems. The Unified ICME uses four different 
commands to interact with the Unified CCX system: 

 • Connect—Connects the call. Unified ICME sends the connect message with 
a label to instruct the Unified CCX system where to direct the call.

 • Release—Hangs up the call.

 • Run VRU Script—Runs a Unified ICME Voice Response Unit (VRU) script 
on the Unified CCX system. 

 • Cancel—Cancels the Unified ICME VRU script that is currently running.

This section includes the following tasks:

 • Configuring General Unified ICME Information, page 9-4

 • Configuring Unified ICME VRU Scripts, page 9-7
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Related Topics

 • About Additional Subsystems, page 9-2

 • Provisioning HTTP Subsystem, page 9-10

 • Provisioning Database Subsystem, page 9-12

 • Provisioning eMail Subsystem, page 9-16

 • Configuring Unified ICME Post-Routing Application, page 6-11

 • Configuring Unified ICME Translation-Routing Application, page 6-14

Configuring General Unified ICME Information
General Unified ICME information includes the TCP/IP socket number for 
receiving messages from the Unified ICME system and the expanded call context 
variables you want to use to pass call-related information. To configure general 
Unified ICME information, complete the following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > ICM > 
General.

The ICME Configuration web page opens displaying the following fields.

Step 2 Use this web page to specify the following fields. 
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Field Description

VRU Connection Port The same number configured in the VRU Peripheral Interface Manager (PIM) 
on the Unified ICME system. The default value in the Unified ICME setup is 
5000. This is a mandatory field.

The system uses this TCP/IP socket number to receive messages from the 
Unified ICME system. You can copy the VRU Connection Port value from 
the VRU PIM configuration dialog box of the VRU PG machine.

PG Hosts Allow By default, any PG will be able to connect in the Unified ICME setup. For 
security reasons, you can configure selected PGs, which you want to connect 
to the Unified IP IVR system using any one of the following three options:

 • All – Click the All radio button if you want any PG to be able to connect 
to the Unified IP IVR. This radio button will be selected by default in the 
Unified ICME setup. 

 • None - Click the None radio button if you do not want even a single PG 
to connect to the Unified IP IVR.

 • Specific – Click the Specific radio button if you want to connect only 
specific PGs to the Unified IP IVR. Once you select this option, you will 
be able to enter the Host name or IP address for any one or both the PGs 
using the following fields:

 – PG 1 Hostname/IP Address 

 – PG 2 Hostname/IP Address 

Note When you select the Specific option, the PG1 Hostname/IP 
Address is a mandatory field.
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Service Control If you click Yes, the Service Control interface allows Unified ICME to 
provide call-processing instructions to the Unified CCX system. It also 
provides Unified ICME software with event reports indicating changes in call 
state.

You must enable the service control interface to use the Unified ICME 
subsystem.

Additional VRU Call 
Information

Select the required variables to pass call-related information by selecting the 
check box. The following expanded call variables are available on the Unified 
ICME subsystem:

 • Task ID: Task ID that handles the current call.

 • Media ID: Media ID that handles the current call.

 • Last Redirected Address: Transient part ID of the call.

 • Arrival Type: Arrival type of the call.

 • Session Handled: Boolean flag that the Unified ICME software or a Set 
Contact Info step with a Handled flag step sets to indicate whether the 
session is handled. 

Note Unified CCX automatically sets the flag whenever a call is 
connected to an agent.

 • VRU Script Name: Script name to run on the PreConnect feature.

Note All scripts under the default directory are listed in the drop-down list 
of the Script field in the Cisco Script Application Configuration page.

 • Config Param: Parameters for the VRU scripts on the PreConnect feature.

Field Description
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Note You can also define your own expanded call variables in the 
Configure ICME tool in the Unified ICME system. The Unified 
CCX Engine registers the user-defined expanded call variables with 
Unified ICME after it loads the VRU scripts that use these variables. The 
variables remain registered until the Unified ICME session is reopened 
(either by request from the VRU PG or when the Unified CCX Engine is 
restarted). The variables remain registered even if you delete the script 
that uses them.

Tip Every Call Context Variable and Expanded Call Context Variable must 
be defined on both sides of the system that receive and send variable data 
in scripts. In a Unified CCX system, these variables must be defined both 
in Unified CCX and in Cisco Desktop Administrator (CDA). In a Unified 
CCX system integrated with Unified ICME through the Unified Gateway, 
these variable must be defined in Unified CCX, in CDA, and also in 
Unified ICME.

Step 3 Click Update.

The configuration information is added to the system. 

You are now ready to configure the Unified ICME VRU Scripts area of the 
Unified ICME Configuration web page.

Related Topic

 • Configuring Unified ICME VRU Scripts, page 9-7

 • About Additional Subsystems, page 9-2

Configuring Unified ICME VRU Scripts 
Configure Unified ICME VRU scripts. Unified ICME VRU Script entries allow 
you to map the VRU script name, used by Unified ICME in the Run VRU Script 
node, to a Unified CCX script name.
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Unified ICME uses VRU scripts to handle interactions with contacts. These 
scripts are loaded as applications on the Unified CCX Engine. 

To configure Unified ICME VRU Scripts, complete the following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > ICM.

The Unified ICME Configuration web page opens, displaying the General area.

Step 2 On the Unified ICME Configuration toolbar, click Unified ICME VRU Scripts.

The Unified ICME VRU Scripts summary web page opens. 

Step 3 Use this web page to specify the following fields. 

Step 4 Click Add a New VRU Script icon or button. 

The Unified ICME VRU Script area of the Unified ICME Configuration web page 
opens.

Step 5 Use this web page to specify the following fields. 

Field Description

VRU Script Name Displays the VRU script name. 

Note All scripts under the default directory are listed in the drop-down list 
of the Script field in the Cisco Script Application Configuration page. 

Script Displays the script associated with the VRU script. 
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Step 6 Click Add. 

The Unified ICME VRU Script area closes, and the name of the VRU script you 
added appears in the Unified ICME VRU Scripts summary web page.

You are now ready to provision any additional subsystems your Unified CCX 
applications require or to begin configuring Unified CCX applications. See 
Chapter 6, “Configuring Cisco Applications.”

Related Topics

 • Configuring General Unified ICME Information, page 9-4

 • About Additional Subsystems, page 9-2

Field Description

VRU Script Name A name for the VRU script you want to add. 

Script The Unified CCX script to associate with the VRU script. You can select 
the script from the drop-down list or click Edit button to specify a new 
script.

Note All scripts under the default directory are listed in the drop-down 
list of the Script field in the Cisco Script Application Configuration 
page. 

To specify a new script, click Edit, enter the script name in the dialog box, 
and click OK. The User Prompt dialog box closes, and the name you 
entered appears in the Script field.

Note If you enter the script name as a file URL, enter the value with 
double backslashes (\\). For example, file://c:\\temp\\aa.aef
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Provisioning HTTP Subsystem

Note The HTTP subsystem is available if your system has a license installed for one of 
the following Cisco product packages: Unified IP IVR or Unified CCX Premium.

The Unified CCX system uses the HTTP subsystem to enable Unified CCX 
applications to respond to requests from a variety of web clients, including 
computers and IP phones.

Note If you are not using HTTP applications, you do not need to provision the HTTP 
subsystem. 

The Unified CCX system uses subdirectories in the Unified CCX installation 
directory to store text substitution, eXtensible Style Language (xsl) templates, 
static and dynamic web pages, and Java Servlet Pages (JSPs). 

Note Use the Document Management page to upload these documents. For more 
information on the Document Management page, see Chapter 10, “Managing 
Prompts, Grammars, Documents, and Custom Files.”

To provision the HTTP subsystem, you need to provision HTTP triggers. HTTP 
applications use triggers to activate the application in response to an incoming 
HTTP message. 

Note You cannot change the TCP/IP port numbers used by the HTTP subsystems or 
triggers in Unified CCX 8.5(1).

This section describes:

 • Configuring HTTP Triggers, page 9-11

Related Topics

 • About Additional Subsystems, page 9-2

 • Provisioning Unified ICME Subsystem, page 9-3
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 • Provisioning Database Subsystem, page 9-12

 • Provisioning eMail Subsystem, page 9-16

 • Adding Application Triggers, page 6-18

Configuring HTTP Triggers
You need to create an application using Applications > Application 
Management menu from the Unified CCX Administration menu bar. Once you 
create an application, you can configure HTTP triggers for the application using 
the steps mentioned below.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > HTTP.

The HTTP Trigger Configuration web page opens. 

Note For a complete description of all columns, icons, and buttons on this page, 
see HTTP Configuration, page 18-31.

Step 2 Use this web page to specify the following fields.

Field Description

URL The relative URL

For example:

/hello

Application Name Select an application for which you want to add a HTTP trigger from this 
list box. 
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Step 3 Click Add New.

The HTTP Trigger Configuration web page closes, and the trigger information 
appears on the HTTP Trigger Configuration summary web page.

You are now ready to provision any additional subsystems your Unified CCX 
applications require or to begin configuring Unified CCX applications. See 
Configuring Cisco Applications, page 6-1.

Related Topics

 • About Additional Subsystems, page 9-2

 • Adding Application Triggers, page 6-18

Provisioning Database Subsystem 

Note The database subsystem is available if your system has a license installed for 
either the Unified IP IVR or Unified CCX Premium product packages. If you are 
not using Unified CCX applications that require access to databases, you do not 
need to provision the Database subsystem. 

Sessions The maximum amount of simultaneous sessions (instances) that the 
application can handle.

 • The limit for the maximum number of simultaneous remote 
monitoring sessions is 16, but the actual number depends on your 
system’s CPU and memory resources. Entering a number that is too 
high can result in unacceptable system performance.

Enabled (Radio button) Accept Yes (the default).

Note If you disable the trigger, the user receives an error message when 
browsing to the defined trigger URL.

Field Description
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The Unified CCX system uses the Database subsystem to enable Unified CCX 
applications to interact with database servers to make database information 
accessible to contacts. 

To provision the Database subsystem, perform the following procedures:

 • Configuring Database Subsystem, page 9-13

 • Adding a New DataSource, page 9-14

Caution The Database subsystem does not support database views or execute store 
procedures.

Related Topics

 • About Additional Subsystems, page 9-2

 • Provisioning Unified ICME Subsystem, page 9-3

 • Provisioning HTTP Subsystem, page 9-10

 • Provisioning eMail Subsystem, page 9-16

Configuring Database Subsystem
The Database subsystem enables the Unified CCX applications to obtain 
information from data sources, which are databases configured to communicate 
with the Unified CCX system. You can connect the Unified CCX system with 
enterprise databases such as Microsoft SQL Server, Sybase, Oracle, or IBM DB2. 

You can upload JDBC driver files using Subsystems > Database > Drivers menu 
option. Refer to Adding a New Database Driver, page 18-29 for detailed 
instructions on how to upload a jdbc driver.

Note To determine a list of enterprise databases supported for the Database subsystem, 
see the Cisco Unified CCX Software and Hardware Compatibility Guide for 
active releases available at 
http://www.cisco.com/en/US/products/sw/custcosw/ps1846/products_device_sup
port_tables_list.html.
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Adding a New DataSource
After uploading the JDBC driver (see Configuring Database Subsystem, 
page 9-13), you need to use this to create the datasource in the Database 
subsystem.

To add a new data source, complete the following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > 
Database > DataSource. Click Add New icon that displays in the tool bar in the 
upper, left corner of the window or the Add New button that displays at the 
bottom of the window.from the DataSources web page. 

The Datasource Configuration web page opens where you can specify the 
following fields. 

Field Description

Data Source Name Data source name for referring to the datasource. This is a mandatory 
field.

User Name Username defined for connecting to the enterprise database. This is a 
mandatory field.

Password Password defined for connecting to the enterprise database.

Confirm Password Re-enter the password that you provided in the Password field.

Maximum Number of 
Connections

Maximum number of connections allowed to connect to the database.

This database is usually an external database to which the customer 
script can connect. While the limit is set by that database and governed 
by your license, if this number in this setting is exceeded, the 
corresponding workflow is aborted and the caller receives an error 
message. However, you can avoid this error by configuring the 
appropriate number of sessions (see Maximum Number Of Sessions, in 
Chapter 6, “Maximum Number Of Sessions”) in the corresponding 
script/application. Also the script writer can provide information about 
how many connections are used per call (or instance of application). 
This is a mandatory field.
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Step 2 Click Add to save the changes.

The Enterprise Database Subsystem Configuration web page opens. You are now 
ready to provision any additional subsystems your Unified CCX applications 
require or to begin configuring Unified CCX applications. See Configuring Cisco 
Applications, page 6-1.

Related Topics

 • Configuring Database Subsystem, page 9-13

 • Adding a New DataSource, page 9-14

 • About Additional Subsystems, page 9-2

Polling Database Connectivity
To poll connectivity to the database on a periodic basis, complete the following 
steps.

Driver Displays the list of available drivers for the enterprise database. One or 
more datasources can use the same driver. Select a driver for this 
datasource from this list box. This is a mandatory field. 

JDBC URL JDBC URL that is used to obtain a connection to the enterprise database. 
This is a mandatory field. The JDBC URL provided will be used by 
Unified CCX to connect to the enterprise database using JDBC. The 
URL to be used is dependent on the database you are connecting. The 
examples provided in the Datasource Configuration web page can be 
used as a reference to define the URL. Refer to the driver documentation 
for more information.

Note If the test connection fails for Oracle JDBC drive connection, 
try the following connection url:
jdbc:oracle:thin:[user/password]@[host][:port]:SID

Field Description
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Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > 
Database > Parameters.

The Parameters web page opens to display the parameter-related fields.

Step 2 Use this web page to specify the following fields: 

Step 3 Click Update to apply changes (or Reset to Default if you prefer to retain the 
default values.

The window refreshes and Unified CCX updates the parameters with your 
changes. You are now ready to provision any additional subsystems your Unified 
CCX applications require or to begin configuring Unified CCX applications (see 
Configuring Cisco Applications, page 6-1).

Related Topics

 • Configuring Database Subsystem, page 9-13

 • About Additional Subsystems, page 9-2

Provisioning eMail Subsystem 

Note The eMail subsystem is available if your system has a license installed for one of 
the following Cisco product packages: Unified IP IVR or Unified CCX Premium.

Field Description

RetryConnectInterval Specifies the interval between two connection attempts when a data source is 
initialized. The default is 15,000 milliseconds.

NumAttempt Specifies the number of attempts to establish connections to the database 
when a data source is initialized. The default is 3 attempts. 

LoginTimeout Sets the maximum time in seconds that a driver will wait while attempting to 
connect to a database. The default is 0 (disabled).
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The Unified CCX system uses the eMail subsystem to communicate with your 
e-mail server and enable your applications to create and send e-mail. You must 
provision the eMail subsystem if you intend to create scripts that use messaging 
steps to create and send e-mail.

Tip If your e-mail system is configured to receive acknowledgments, you should 
process the mailbox you identify in your configuration to determine whether or 
not an e-mail was successfully sent.

The e-mail configuration process identifies the default e-mail address and server 
to be used for sending e-mail (including e-pages and faxes) and for receiving 
acknowledgments. 

Note If you are not using e-mail applications, you do not need to provision the eMail 
subsystem. 

To provision the eMail subsystem, complete the following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > eMail.

The eMail Configuration web page opens.

Step 2 Use this web page to specify the following fields: 

Step 3 Click Update. 

The Unified CCX system saves your changes and the Unified 
CCX Administration web page opens.

Field Description

Mail Server A fully-qualified e-mail server name.
Example: server.domain.com)

email Address An existing fully qualified e-mail address for the administrative account.
Example:administrator@domain.com
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Note Cisco does not currently support multiple email configurations. To remove the 
email information, you must erase the fields and click Update.

You are now ready to provision any additional subsystems your Unified CCX 
applications require, or to begin configuring Unified CCX applications (see 
Chapter 6, “Configuring Cisco Applications,” and Chapter 10, “Managing 
Prompts, Grammars, Documents, and Custom Files.”)

Related Topics

 • About Additional Subsystems, page 9-2

 • Provisioning Unified ICME Subsystem, page 9-3

 • Provisioning HTTP Subsystem, page 9-10

 • Provisioning Database Subsystem, page 9-12

 • Provisioning eMail Subsystem, page 9-16
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Managing Prompts, Grammars, 
Documents, and Custom Files

Unified CCX applications can make use of many auxiliary files that interact with 
callers, such as scripts, pre-recorded prompts, grammars, and custom Java 
classes. 

To manage these auxiliary files, you must complete the following tasks:

 • Provision telephony and media resources (see Chapter 7, “Provisioning 
Telephony and Media”).

 • Provision Unified CCX subsystem, if required (see Chapter 8, “Provisioning 
Unified CCX”).

 • Provision additional subsystems, if required (see Chapter 9, “Provisioning 
Additional Subsystems”.

 • Configure Cisco script applications (see Chapter 6, “Configuring Cisco 
Applications”

Depending on your particular Unified CCX implementation, your applications 
might make use of some or all of the file types described in the following sections:

 • Managing Prompt Files, page 10-2

 • Managing Grammar Files, page 10-5

 • Managing Document Files, page 10-7

 • Managing Languages, page 10-9

 • Recording and Uploading Prompt Files, page 10-13

 • Managing Custom Files, page 10-17
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Managing Prompt Files
 • Managing AAR Files, page 10-18

Managing Prompt Files
Many applications make use of pre-recorded prompts stored as .wav files, which 
are played back to callers to provide information and elicit caller response. 

Several system-level prompt files are loaded during Unified CCX installation. 
However, any file you create needs to be made available to the Unified CCX 
Engine before a Unified CCX application can use them. This is done through the 
Unified CCX cluster’s Repository datastore, where the prompt, grammar, and 
document files are created, stored, and updated. 

Note Support for High Availability and remote servers is available only in 
multiple-server deployments.

The Unified CCX Server's local disk prompt files are synchronized with the 
central repository during Unified CCX Engine startup and during run-time when 
the Repository datastore is modified. For more information about the Repository 
datastore, see Cisco Unified Contact Center Express Serviceability Guide .

To access the Prompt Management page, perform the following steps:

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Application > Prompt 
Management.

Step 2 The Prompt Management web page opens to display the following fields and 
buttons. 

 

Field Description

Language Lists the location of the items listed in the Name column.

Folder Path of the current item selected in the Name column with respect to the root 
folder.

Name Name of the language.
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Size The size of the prompt file prefixed with KB. The file size is converted from 
bytes to KB. 

Note This column is usually blank on the root page because the items on 
this page are usually folders.

Date Modified The date and time when the document was last uploaded or changed along 
with time zone.

Modified by The user ID of the person who performed these modifications.

Delete Click Delete icon to remove the folder and its contents from the repository.

Rename Click Rename icon to rename the folder in the repository.

Refresh Click Refresh icon to refresh the folder in the repository.

Create Language Displays a dialog box that lets you create a new language folder. For detailed 
information on how to create a new language, see Creating a New Language, 
page 10-9.

Upload Zip Files Displays a dialog box that lets you locate and upload a zip file. For detailed 
information on how to upload a zip file, see Upload Zip files to a Language 
Folder, page 10-11.

Note The zip file must contain language folders in the root directory. Be 
sure to place the grammar files in folders and then zip the folders.

Field Description
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When you click a hyperlink (if configured) in the Name folder column, a 
secondary page appears. From this page, you can create a new subfolder or upload 
a new Prompt. The below figure shows the structure of the system prompts.

Related Topics

 • Wizards Menu, page 19-1

 • Managing Grammar Files, page 10-5

 • Managing Document Files, page 10-7

 • Managing Languages, page 10-9

 • Recording and Uploading Prompt Files, page 10-13

 • Managing Custom Files, page 10-17

 • Managing AAR Files, page 10-18

 • Managing Scripts, page 6-25
10-4
Cisco Unified CCX Administration Guide, Release 8.5(1)



Chapter 10      Managing Prompts, Grammars, Documents, and Custom Files
Managing Grammar Files
Managing Grammar Files
The Unified CCX system uses specific grammars when recognizing and 
responding to caller response to prompts. A grammar is a specific set of all 
possible spoken phrases and Dual Tone Multi-Frequency (DTMF) digits to be 
recognized by Unified CCX applications and acted upon during run time.

Several system-level grammar files are loaded during Unified CCX installation. 
However, any file you create needs to be made available to the Unified CCX 
Engine before a Unified CCX application can use them. This is done through the 
Unified CCX cluster’s Repository datastore, where the grammar files are created, 
stored, and updated. 

Note Support for High Availability and remote servers is available only in 
multiple-server deployments.

The Unified CCX Server's local disk grammar files are synchronized with the 
central repository during Unified CCX Engine startup and during run-time when 
the Repository datastore is modified. For more information about the Repository 
datastore, see Cisco Unified Contact Center Express Serviceability Guide.

To access the Grammar Management page, perform the following steps:

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Applications > 
Grammar Management.

Step 2 The Grammar Management web page opens to display the following fields and 
buttons. 

 

Field Description

Language Location of the items listed in the Name column. 

Folder Path of the current item selected in the Name column with respect to the root 
folder.

Codec The codec chosen during installation for this Unified CCX server. Display 
only.

Name Name of the language folder. 
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When you click a hyperlink (if configured) in the Name folder column, a 
secondary page appears. From this page, you can create a subfolder or upload a 
new Prompt, Grammar, or Document. 

Related Topics

 • Wizards Menu, page 19-1

 • Managing Prompt Files, page 10-2

 • Managing Document Files, page 10-7

 • Managing Languages, page 10-9

 • Recording and Uploading Prompt Files, page 10-13

 • Managing Custom Files, page 10-17

 • Managing AAR Files, page 10-18

Size The size of the grammar file prefixed with KB. The file size is converted 
from bytes to KB. 

This column is usually blank on the root page as the items on this page are 
usually folders.

Date Modified The date and time when the document was last uploaded or changed along 
with time zone.

Modified by The user ID of the person who performed these modifications.

Delete Displays a dialog box that lets you delete an existing language folder.

Rename Displays a dialog box that lets you rename an existing language folder.

Refresh Refreshes the specified folder in the repository.

Create Language Displays a dialog box that lets you create a new language folder. For detailed 
information on how to create a new language, see Creating a New Language, 
page 10-9.

Upload Zip Files Displays a dialog box that lets you locate and upload a zip file. For detailed 
information on how to upload a zip file, see Upload Zip files to a Language 
Folder, page 10-11.

Note The zip file must contain language folders in the root directory. Be 
sure to place the grammar files in folders and then zip the folders.

Field Description
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 • Managing Scripts, page 6-25

Managing Document Files
Documents might consist of .txt, .doc, .jsp, or .html files. Documents can also 
include custom classes and Java Archive (JAR) files that allow you to customize 
the performance of your Unified CCX system.

Several system-level document files are loaded during Unified CCX installation. 
However, any file you create needs to be made available to the Unified CCX 
Engine before a Unified CCX application can use them. This is done through the 
Unified CCX cluster’s Repository datastore, where the document files are 
created, stored, and updated. 

Note Support for High Availability and remote servers is available only in 
multiple-server deployments.

The Unified CCX Server's local disk document files are synchronized with the 
central repository during Unified CCX Engine startup and during run-time when 
the Repository datastore is modified. For more information about the Repository 
datastore, see Cisco Unified Contact Center Express Serviceability Guide.

To access the Document Management page, perform the following steps:

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Applications > 
Document Management.

Step 2 The Document Management web page opens to display the following fields and 
buttons. 

 

Field Description

Language Location of the items listed in the Name column. 

Folder Path of the current item selected in the Name column with respect to the root 
folder.

Name Name of the language. 
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When you click a hyperlink (if configured) in the Name folder column, a 
secondary page appears. From this page, you can create a subfolder or upload a 
new Prompt, Grammar, or Document.

Related Topics

 • Wizards Menu, page 19-1

 • Managing Prompt Files, page 10-2

 • Managing Grammar Files, page 10-5

 • Managing Languages, page 10-9

 • Recording and Uploading Prompt Files, page 10-13

 • Managing Custom Files, page 10-17

 • Managing AAR Files, page 10-18

Size The size of the document file prefixed with KB. The file size is converted 
from bytes to KB. 

Note This column is usually blank on the root page because the items on 
this page are usually folders.

Date Modified The date and time when the document was last uploaded or changed along 
with time zone.

Modified by The user ID of the person who performed these modifications.

Delete Displays a dialog box that lets you delete an existing language folder.

Rename Displays a dialog box that lets you rename an existing language folder.

Refresh Refreshes the specified folder in the repository.

Create Language Displays a dialog box that lets you create a new language folder. For detailed 
information on how to create a new language, see Creating a New Language, 
page 10-9.

Upload Zip Files Displays a dialog box that lets you locate and upload a zip file to the 
repository. For detailed information on how to upload a zip file, see Upload 
Zip files to a Language Folder, page 10-11.

Note The zip file must contain language folders in the root directory. Be 
sure to place the grammar files in folders and then zip the folders.

Field Description
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 • Managing Scripts, page 6-25

Managing Languages 
The topics in this section describe the procedure for managing languages:

 • Wizards Menu, page 19-1

 • Creating a New Language, page 10-9

 • Renaming a Language, page 10-10

 • Deleting a Language, page 10-11

 • Upload Zip files to a Language Folder, page 10-11

Creating a New Language
Follow this procedure to create a new Prompt, Grammar, or Document language 
folder in the Repository datastore:

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Applications > Prompt 
Management or Grammar Management or Document Management.

The corresponding Management web page opens. 

Step 2 Click Create New Folder or Create Language icon that displays in the tool bar 
in the upper, left corner of the window or the Create New Folder or Create 
Language button that displays at the bottom of the window.

The Create New Folder or Create Language dialog box opens. 

Step 3 Perform any one of the following actions:

 • Select a value from the Language drop-down list.

 • If you’re unable to find a particular language or if the Language drop-down 
list is empty, click Edit button to add a new Language. The Explorer User 
Prompt dialog box opens. Enter the name of the new language in the 
Language Name field and click OK.

Step 4 Click Create.
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A new language folder Name appears on the summary web page.

Renaming a Language 
Follow this procedure to rename a Prompt/Grammar/Document language folder 
in the Repository datastore:

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Applications > Prompt 
Management or Grammar Management or Document Management.

The corresponding Management web page opens. 

Step 2 Select the Rename icon against the folder you want to rename. 

Step 3 The Rename Folder dialog box opens. 

Step 4 From the Select Language Folder To Rename field, choose the name of the folder 
to be renamed.

Step 5 In the Rename Folder To field, enter the new name. 

Step 6 Click Rename. 

The web page then refreshes itself to provide a summary and status. Click Return 
to Document Management to navigate to the respective Prompt or Grammar or 
Document Management page.
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Deleting a Language
Follow this procedure to delete a Prompt/Grammar/Document language folder in 
the Repository datastore:

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Applications > Prompt 
Management or Grammar Management or Document Management.

The corresponding Management web page opens. 

Step 2 Select the Delete icon against the respective folder, which you want to delete.

Step 3 A dialog box opens to confirm the Delete action for the specific folder. 

Step 4 Click OK to delete.

Upload Zip files to a Language Folder
In addition to adding Prompt or Document files individually, you can upload 
multiple files from a Zip file. 

Note The maximum upload file size is 20MB, whether it is a single file or a Zip file.

Tip Be sure to upload (or download) large zip files in Prompt, Grammar and 
Document Management pages during off-peak hours. 

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Applications > Prompt 
Management or Grammar Management or Document Management.

The corresponding Management web page opens. 
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Step 2 Click Upload Zip Files icon that displays in the tool bar in the upper, left corner 
of the window or the Upload Zip Files button that displays at the bottom of the 
window to upload a new prompt or zip file. 

Step 3 The Upload Document dialog box opens. 

Step 4 Enter the path for the script file or click Browse to locate the script or the zip file 
containing the script files. Select the required script file and click Open.

Note You can upload only files with extension .aef or .zip. 

Step 5 Click the Upload button to upload the new script to the repository. A dialog box 
confirms the successful upload of the files.

Note If you try to upload invalid script files, then the upload would be unsuccessful and 
an error message would be displayed on the upload dialog box. You can also 
create User defined directories using “Create a New folder” option and uploads 
scripts to those directories.

Step 6 By default, the files are unzipped after uploading. If you want to change this 
option, uncheck the Unzip after uploading check box. 

Caution In the Documents Management summary web page, you have the 
option to zip or to unzip the file before uploading. By default, this 
check box is checked to unzip the file before uploading. Ensure to 
uncheck the check box if you want to upload it as a zipped file. 
The maximum upload file size of the Zip file is 20MB.

Step 7 The contents of the zip file is uploaded to the folder. On successful uploading of 
the zip file, the status icon is updated accordingly. Click Return to Document 
Management button to go back to the respective Management web page.
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Recording and Uploading Prompt Files 
Prompts are messages that the Unified CCX system plays back to callers. Unified 
CCX applications often use prompts to elicit caller response so that the Unified 
CCX system can transfer calls, receive account information, and perform other 
functions. 

To use prompts in your Unified CCX applications, you must first create a folder 
to store them. You can then record and upload new user prompts, delete prompts, 
and modify existing prompts.

You store pre-recorded prompts as .wav files. The Unified CCX system also 
allows users to record spoken names, which you can upload to be used in the 
playback of prompts.

Note Unified CCX supports audio playback of RIFF header .wav files only though your 
MRCP vendor might support multiple .wav file header formats. 

ScanSoft uses RIFF headers. When generating a wav file prompt specifically for 
Nuance, be sure to consider the server playing the prompt:

 • If the prompt is played by the Nuance Speech Server, then the .wav file will 
requires a SPHERE header. 

 • If the prompt is played by the Unified CCX server, then the .wav file requires 
a RIFF header.

Nuance provides a tool to convert .wav files from RIFF headers to SPHERE 
headers. 

Managing prompts can include one or more of the following activities: 

 • Creating a folder: You must create a folder to store the .wav files that the 
Unified CCX system uses as prompts. 

 • Recording a prompt: You can record your own prompts to be used in 
applications.

 • Upload one or more prompts: You can replace any of the stored prompts used 
by Cisco script applications with a different .wav file by uploading the 
new.wav file. If necessary, you can also add spoken name prompts. Some 
Unified CCX applications play back the pre-recorded names of the people 
that callers are trying to reach, to allow the caller to confirm the transfer of 
the call.
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This section contains the following topics:

 • Recording a Prompt, page 10-14

 • Add Spoken Name Prompts, page 10-16

Note For instructions for Adding and Uploading prompts, see “Managing Prompt 
Files” section on page 10-2.

Recording a Prompt  
You can record your own prompts to be used in applications. The example 
provided in this section uses the Windows Sound Record option. This option is 
one of many possibilities for recording G711 prompts. G711 is a freely distributed 
public domain codec and has several recording options. Some of these options are 
included in Microsoft Windows systems and are available to any sound recording 
application. 

The G729 codec is licensed and is not freely distributed. A white paper that 
describes the G729 prompt recording options is available on request. The white 
paper is located at 
http://www.cisco.com/en/US/prod/collateral/voicesw/custcosw/ps5693/ps1846/s
olution_overview_c22-524728.html

To record a prompt, complete the following steps.

The following procedure is an example of recording G.711 prompts with 
Microsoft Windows Sound Recorder, using a microphone plugged into your 
computer. If you are not using Microsoft Windows Sound Recorder, see the 
documentation provided with your audio application. 

Procedure

Step 1 From your Windows Start menu, choose Start > Programs > Accessories > 
Entertainment > Sound Recorder. 

The Sound Recorder dialog box opens.

Step 2 Click Record button and speak your greeting into the microphone. 

Step 3 Click Stop button when you finish recording.
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Step 4 To check your greeting, click Rewind button or drag the slider back to the 
beginning of the recording. Then click Play button.

Step 5 When you are satisfied with your greeting, choose File > Save As. 

The Save As window opens. 

Step 6 Click Change to set the recording options. 

You can also set recording properties by choosing Properties from the Sound 
Recorder File menu.

The Sound Selection dialog box opens. 

Step 7 From the Format drop-down menu, choose one of the following options based on 
the prompts selected during the installation of Unified CCX software:

 • If you selected G711 prompts, then CCITT u-Law.

 • If you selected G729 prompts, then see your G.729 white paper.

Note The instructions in this procedure assume that, during Unified CCX 
installation, you configured Unified CCX to use the G.711 codec for 
prompts. If this assumption is incorrect, and you specified the G.729 
codec instead, you would choose a G.729 option from this menu. For 
more information about recording prompts with G.729, see your G.729 
documentation. 

Step 8 From the Attributes drop-down menu, choose 8.000 kHz, 8 Bit, Mono 7 kb/sec.

Step 9 Click Save As.

The Save As dialog box opens.

Step 10 Enter a name for this format, and then click OK.

The Save As Dialog Box closes.

Step 11 In the Sound Selection dialog box, click OK.

The Sound Selection dialog box closes.

Step 12 In the Save As window, navigate to the directory of your choice, preferably a 
directory that you have set aside for prompts.

Step 13 Select the file name, and click Save.

The Save As dialog box closes.
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You are now ready to add this prompt to the Unified CCX system.

Add Spoken Name Prompts
Some Unified CCX applications play back the pre-recorded names of people that 
callers are trying to reach, to allow callers to confirm the transfer of a call.

To upload .wav files of the spoken names of users, complete the following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Tools > User 
Management > Spoken Name Upload.

Step 2 The Spoken Name Prompt Upload web page opens with the following fields:

Step 3 In the User Id field, enter an ID number that will identify the user.

Step 4 In the Spoken Name (.wav) field, enter the path for a .wav file or click Browse to 
navigate to the directory that contains the Spoken Name .wav file.

The Choose File dialog box opens. Select the required script file and click Open.

Step 5 Click Upload icon that displays in the tool bar in the upper, left corner of the 
window or click the Upload button that displays at the bottom of the window to 
upload the file. 

Step 6 Repeat this process as needed to upload all spoken name .wav files. 

Field Description

User Id Unique identifier of the user for which the spoken name is to be 
uploaded. This is a mandatory field.

Codec The codec chosen during installation for this Unified CCX server. 
Display only.

Spoken Name (.wav) Location of the .wav file. This is a mandatory field.
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Managing Custom Files
Use the Custom File Configuration web page to configure the classpath location 
of custom classes.

Specify Custom Classpath Entries
Use the Custom Classes Configuration web page to specify the available classpath 
entries.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose System > Custom File 
Configuration. 

The Custom Classes Configuration web page opens. You can:

 – Select required entries from the Available Classpath Entries list and 
arrange them in the order you want. 

 – Use the arrow icons to move items between the Available Classpath 
Entries and Selected Classpath Entries lists. 

Step 2 Click Update when your selections are complete.

Click Upload Custom Jar Files icon that displays in the tool bar in the upper, left 
corner of the window or the Upload Custom Jar Files button that displays at the 
bottom of the window to upload Jar files. The Document Management web page 
opens. Refer to Managing Document Files, page 10-7 to know the procedure for 
uploading Jar files.
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Managing AAR Files

Caution Ensure that the contents of the AAR file are correct and conform to the 
specifications detailed in this section. If you upload AAR files that do not 
conform to these specifications, the Unified CCX Engine may not function as 
designed. Consequently, you need to manually reconfigure some of the 
applications uploaded through AAR. 

AAR files are archives of prompt, grammar, document, scripts, applications, and 
custom classes that you use as building blocks for applications and extensions. 

An AAR file can be simple—for instance, consisting of a single prompt—or 
complex—for example, containing all the prompts for all languages application 
uses, the workflow, and the configuration information for an application. 

An AAR file is essentially a zip file that contains an optional META-INF 
directory. The META-INF directory, if it exists, stores configuration data, 
including security, versioning, extensions, and services (see META-INF 
Directory, page 10-22).

You create AAR files using Java tools. After creating a file, you need to upload 
it to Unified CCX. 

The example below shows a sample AAR Application Manifest.

Example 10-1 Sample AAR Main Manifest

Manifest-Version: 1.1
Created-By: 1.4.2_05 (Sun Microsystems Inc.)
Built-By: aaruser
Sealed: false
Cisco Unified CCX-Version: 8.5(1)
Class-Path: 
Application-List: customApp1.mf customApp2.mf
Subsystem-List: sub1.mf sub2.mf
Palette-List: Custom1 Custom2
Custom1-Palette-Name: Category1
Custom2-Palette-Name: Category2
Custom1-Step-List: step1.mf
Custom2-Step-List: step2.mf step3.mf
Implementation-Title: AAR Test File
Implementation-Version: 4.5(1)
Implementation-Vendor: Cisco Systems, Inc.
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Implementation-Vendor-Id: 12345
Implementation-URL: http://www.cisco.com

Example 10-2 Sample AAR Application Manifest

Application-Version: 1.1
Created-By:  1.4.2_05 (Sun Microsystems Inc.)
Built-By: aaruser
Sealed: false
Implementation-Title: AAR Application MF
Implementation-Version: 8.5(1)
Implementation-Vendor: Cisco Systems, Inc.
Implementation-Vendor-Id: 12345
Implementation-URL: http://www.cisco.com
Application-Name: Custom AA
Application-Type: Cisco Script Application
Application-Description: Cisco Unified CCX Cisco Custom Application
Application-Id: 100
Max-Sessions: 300
Enabled: true
Script: SSCRIPT[aa.aef]
Default-Script: SSCRIPT[aa.aef]
Initial-Script: SSCRIPT[aa.aef]
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The figure below shows a sample AAR file.

Figure 10-1 Sample AAR File
 

To deploy custom applications, steps, and subsystems through an AAR file, you 
must first create the AAR file using a jar or zip tool and then upload the file 
through the Unified CCX Administration web page.

The sections that follow describe how to: 

 • Creating AAR Files, page 10-21 

 • Uploading AAR Files, page 10-21 

 • META-INF Directory, page 10-22
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 • Prompts, Grammars, Documents, and Scripts Directories, page 10-22

 • AAR Manifest, page 10-23

 • Attribute Types, page 10-25

Creating AAR Files
You create an AAR file using a jar or WinZip tool. 

An AAR file format is similar to a Zip file format. It includes an optional 
META-INF directory, which is used to store configuration data, including 
security, versioning, extension, and services.

Uploading AAR Files
To upload an AAR file, complete the following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Applications > AAR 
Management.

The AAR Management web page opens to display the following fields.

Enter the path for the AAR file or click Browse button to upload the file. The 
Choose File dialog box opens. Select the required script file and click Open.

Step 2 Click Upload.

Field Description

Enter a Valid 
AAR File to 
Upload

You can either enter the name of the AAR file or click Browse button next to this field 
to navigate to the directory in which the file is located. This is a mandatory field.

Overwrite 
existing files

Enable this checkbox in case you want to overwrite the existing 

Upload Click this button to upload the AAR file. 

Clear Click this button to clear the selected file.
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The contents of the AAR file are uploaded to the respective folders.

Note Unified CCX generates an error if the AAR file is not formatted correctly or is 
missing some custom files. 

META-INF Directory
Unified CCX uses the following files and subdirectories in the META-INF 
directory to configure applications, extensions and services: 

 • MANIFEST.MF. The file used to define extension and application related 
data (see AAR Manifest, page 10-23).

 • applications. This directory stores all application configuration files (see 
The application Subdirectory Attributes, page 10-30).

Prompts, Grammars, Documents, and Scripts Directories
The AAR files features also provides directories to store prompts, grammars, 
documents, and scripts to be uploaded to the Repository. 

The AAR directory structure mirrors the function of the Unified CCX Prompt, 
Grammar, Documents, and Scripts Management web pages. Each directory 
corresponds to each language for which to install prompts, grammars, documents 
and scripts. Languages are defined using the Java Locale standard and the special 
default directory is used for prompts, grammars, and documents that are common 
to all languages. 

Only Unified CCX supported prompt files and extensions are allowed within each 
directory. The maximum length of each individual folder name and file name 
within a directory is 64 characters. 
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Prompts Directory

The Prompts directory stores prompts that must be uploaded to the prompt 
repository (to make it seem like they were uploaded through Unified CCX Prompt 
Management). 

Grammars Directory

The Grammars directory stores grammars that must be uploaded to the grammar 
repository (to make it seem like they were uploaded through Unified CCX 
Grammar Management). 

Documents Directory

The Documents directory stores documents that must be uploaded to the 
document repository (to make it seem like they were uploaded through Unified 
CCX Document Management).

Scripts Directory

The Scripts directory stores scripts that must be uploaded to the script repository 
(to make it seem like they were uploaded through Unified CCX Script 
Management). 

Note The Script directory must define a single directory named default under which 
all script files must be listed. 

AAR Manifest
An AAR file manifest consists of a main section followed by a list of sections for 
individual AAR file entries, each separated by a newline. 

Information in a manifest file contains name-value pairs—which are also referred 
to as headers or attributes. Groups of name-value pairs are known as a section; 
sections are separated by empty lines. 
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Table 10-1 describes the expected syntax of the manifest file. 

The main section, which is terminated by an empty line:

 • Contains security and configuration information about the AAR file itself, as 
well as the applications or extensions that this AAR file is defining. 

 • Defines main attributes that apply to every individual manifest entry. No 
attribute in this section can have its name equal to “Name”. 

The individual sections define various attributes for directories or files contained 
in this AAR file. Not all files in the AAR file need to be listed in the manifest as 
entries. The manifest file itself must not be listed. Each section must start with an 
attribute with the name as “Name”, and the value must be a relative path to the 
file or directory. 

If there are multiple individual sections for the same file entry, the attributes in 
these sections are merged. If a certain attribute have different values in different 
sections, the last one is recognized. 

Attributes that are not understood are ignored. Such attributes may include 
implementation specific information used by applications.

Table 10-1 Manifest File Syntax 

Name Value

section: *header +newline 

nonempty-section: +header +newline 

newline: CR LF | LF | CR (not followed by LF) 

header: name: value 

name: alphanum *headerchar 

value: SPACE *otherchar newline *continuation 

continuation: SPACE *otherchar newline 

alphanum: {A-Z} | {a-z} | {0-9}

headerchar: alphanum | - | _ 

otherchar: Any UTF-8 character except NUL, CR and LF 

Note To prevent corruption of files sent through e-mail, do not use 
“From” to start a header. 
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Table 10-2 describes the specification for any file that can be archived in the 
AAR.

Attribute Types
Attributes that appear in the main section are called main attributes. Attributes 
that appear in individual sections are called per-entry attributes. Some attributes 
appear in both the main and individual sections, in which case the per-entry 
attribute value overrides the main attribute value for the specified entry. 

Table 10-2 Syntax for AAR Files 

Name Value

manifest-file main-section newline *individual-section 

main-section version-info newline *main-attribute 

version-info Manifest-Version: version-number 

version-number digit+{.digit+}*

main-attribute (any legitimate main attribute) newline

individual-section Name: value newline *perentry-attribute 

perentry-attribute (any legitimate perentry attribute) newline

newline CR LF | LF | CR (not followed by LF) 

digit {0-9}
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Main Attributes

Main attributes are the attributes that are present in the main section of the 
manifest: 

 • General main attributes: See Table 10-3.

Table 10-3 General Category in the Main Attributes

Attribute Description

Manifest-Version The manifest file version. The value is a legitimate 
version number. Unified CCX 8.5(1) will start with 
version 1.1. 

Created-By The version and the vendor of the java 
implementation on top of which this manifest file is 
generated. This attribute is generated by the jar tool. 

Cisco Unified 
CCX-Version

The minimum Unified CCX version release 
compatible with the AAR file. Unified CCX-version 
is the accumulation of the Unified CCX release, 
Unified CCX Service Release, and Unified CCX 
Engineering Special defined in that order. For 
example, if the AAR file is compatible with Cisco 
Unified CCX release 4.5(1)_Build705, 
SR1_Build001, ES2_Build002, the Cisco Unified 
CCX-Version would be defined as 
4.5(1)SR1ES2_Build002. Only the last build number 
is taken. So for instance, if the AAR file is 
compatible with Cisco Unified CCX release 
4.5(1)_build705, SR1_Build001, then the Cisco 
Unified CCX-Version is 4.5(1)SR1_Build001. As a 
last example, if AAR file is compatible with Cisco 
Unified CCX release 4.5(1)_Build705 and above, 
then Cisco Unified CCX-Version would be 
4.5(1)_Build705.
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 • Attribute defined for extension identification: Extension-Name

This attribute specifies a name for the extension contained in the AAR file. 
The name should be a unique identifier. 

Class-Path The directories or JAR files that need to be installed 
and accessed by scripts directly. Entries are 
separated by one or more spaces. The Unified CCX 
class loader uses the value of this attribute to 
construct its internal search path where each entry is 
defined relative to the /Documents/default/classpath 
directory in this AAR file. 

Application-List The application configuration files from the 
META-INF/applications/ directory to be installed. 
Entries are separated by one or more spaces. 

Subsystem-List The subsystem configuration files from the 
META-INF/subsystems/ directory to be installed. 
Entries are separated by one or more spaces. 

Palette-List The step palettes that need to be installed. Each 
palette listed in this attribute will have a set of 
additional attributes that the Unified CCX editor uses 
to specify the palette name and the palette steps to 
install. Entries are separated by one or more spaces. 

<palette>-Palette-Name The unique name of the palette to define in the 
Unified CCX editor where the specified steps will be 
grouped and accessible.

<palette>-Step-List The step configuration files from the 
META-INF/steps/ directory to be installed under the 
palette. Entries are separated by one or more spaces. 

Table 10-3 General Category in the Main Attributes

Attribute Description
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 • Attributes defined for extension and directory versioning and sealing 
information: These attributes define features of the extension which the AAR 
file is a part of. The values of these attributes apply to all the directories in 
the AAR file, but can be overridden by per-entry attributes. See Table 10-4.

Per-Entry Attributes

Per-entry attributes apply only to individual AAR file entry with which the 
manifest entry is associated. If the same attribute also appears in the main section, 
then the value of the per-entry attribute overwrites the main attribute's value. 

 • Example 1: If AAR file a.aar has the following manifest content, then all the 
files archived in a.aar are sealed, except US English prompts. If the same 
attributes also appeared in an entry representing a parent directory of another 
entry then the value of the per-entry attribute overwrites the parent directory 
per-entry attribute’s value. 

Manifest-Version: 1.1 
Created-By: 1.2 (Sun Microsystems Inc.) 

Table 10-4 Implementation Category in the Main Attributes

Attribute Description

Implementation-Title The title of the extension implementation. 

Implementation-Version The version of the extension implementation. 

Implementation-Vendor The organization that maintains the extension 
implementation. 

Implementation-Vendor-Id The ID of the organization that maintains the 
extension implementation.

Implementation-URL The URL from which the extension 
implementation is downloaded.

Sealed Defines if this AAR file is sealed. Sealing a 
directory means that the files uploaded to the 
corresponding repository will not be modifiable 
once installed unless the AAR file is reinstalled. If 
set to true, then all directories in the AAR file 
default to be sealed, unless individually defined 
otherwise. If set to false, then all directories are 
modifiable.
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Sealed: true 
Name: Prompts/en_US/ 
Sealed: false

 • Example 2: If AAR file a.aar has the following manifest content, then all the 
US English prompts archived in a.aar are sealed, except US English prompts 
located in the AA/ directory.

Manifest-Version: 1.1 
Created-By: 1.2 (Sun Microsystems Inc.) 
Name: Prompts/en_US/ 
Sealed: true
Name: Prompts/en_US/AA/
Sealed: false

The per-entry attributes fall into the following groups: 

 • Attributes defined for file contents: Content-Type

This attribute specifies the MIME type and subtype of data for a specific file 
entry in the AAR file. The value should be a string in the form of 
type/subtype. For example, image/bmp is an image type with a subtype of 
bmp (representing bitmap). This indicates the file entry as an image with the 
data stored as a bitmap. RFC 1521 and 1522 discuss and define the MIME 
types definition.

 • Attributes defined for directory versioning and sealing information: 

These are the same set of attributes defined in Table 10-4 for the main 
attributes. When used as per-entry attributes, these attributes overwrite the 
main attributes for the individual file specified by the manifest entry. 

META-INF Directory Attributes

The Unified CCX recognizes the x.MF file in the applications, subsystems, and 
steps subdirectories in the META-INF directory and interprets each to configure 
applications, subsystems, and steps respectively. The x is the base file name as 
listed on the Application-List main attribute of the manifest file. The X.MF file 
contains one section defining the configuration of a particular application.
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The application Subdirectory Attributes

Table 10-5 describes the syntax of the manifest file for the application 
subdirectory.

The application attributes fall into the following groups: 

 • General main attributes: See Table 10-6.

Table 10-5 Application Subdirectory’s Manifest File Syntax 

Name Value

application-file version-info newline *application-attribute 

version-info Application-Version: version-number 

version-number digit+{.digit+}* 

application-attribute (any legitimate application attribute) newline

newline CR LF | LF | CR (not followed by LF)

digit {0-9}

Table 10-6 Application Attributes

Attribute Description

Application-Version The application configurations file version. The value 
is a legitimate version number. For example, Cisco 
Unified CCX Release 4.5 starts with version 1.1. 

Application-Name The unique name of the application (see Unified CCX 
Application Management). 

Application-Type The type of the application (Cisco Script Application, 
Busy, Ring-No-Answer, Unified ICME Translation 
or Post Routing).

Application-Description 
(optional) 

The description for the application (see Unified CCX 
Application Management). 

Application-Id A unique identifier for the application (see Unified 
CCX Application Management). 

Max-Sessions The maximum number of sessions for the application 
(see Unified CCX Application Management). 
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 • Attributes defined for application versioning and sealing information: These 
attributes define features of the application to which the AAR file belongs. 
These attributes are the same as those listed in “Implementation Category in 
the Main Attributes” (see Table 10-4).

Enabled The application is enabled if the value is set to true 
(see Unified CCX Application Management). If the 
value is set to false, the case is ignored.

Script The main script of a Cisco Script Application (see 
Unified CCX Application Management). The value 
must be relative to the Scripts directory. Unified CCX 
8.5(1) does not support configuring script 
parameters.

Default-Script The default script of a Cisco Script Application, 
Unified ICME Translation or Post Routing 
application (see Unified CCX Application 
Management). The value must be relative to the 
Scripts directory. Unified CCX 8.5(1) does not 
support configuring script parameters.

Initial-Script The initial script of a Unified CCX Post Routing 
application (see Unified CCX Application 
Management). The value must be relative to the 
Scripts directory. Unified CCX 8.5(1) does not 
support configuring script parameters.

Table 10-6 Application Attributes

Attribute Description
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C H A P T E R 11

Managing the Unified CCX System 

Unified CCX administration provides options to configure, control, and monitor 
Unified CCX component activities and information across a cluster. 

Note Support for High Availability and remote servers is available only in 
multiple-server deployments.

See the Installation Guide for Cisco Unified CCX and Cisco Unified IP IVR, 
Release 8.5(1) for instructions about tasks that significantly change your Unified 
CCX deployment, such as: 

 • Changing from a single-server deployment to a multiple-server deployment.

 • Removing a Unified CCX Software component from a server.

 • Moving a Unified CCX Software component to another server.

 • Changes to a Unified CCX cluster (adding, removing, or replacing a server).

The following sections describe the day-to-day management of Unified CCX 
components. 

 • Basic Terminology, page 11-2

 • High Availability and Automatic Failover, page 11-3

 • Managing Unified CCX CDS Information, page 11-4

 • Managing System Parameters, page 11-5

 • Changing IP Address of Unified CCX, page 11-10

 • Exiting Unified CCX Administration, page 11-23
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Basic Terminology
This section provides information about different Unified CCX terminology.

 • Cluster. A Unified CCX cluster (often referred to as cluster in this manual) 
consists of one or more servers (nodes) that are running Unified CCX 
components in your Unified CCX deployment. If you deploy Unified CCX 
components on a single server, the Unified CCX cluster consists of that 
server. If you deploy Unified CCX on multiple servers, the cluster includes 
the Unified CCX server and standby server on which you installed Unified 
CCX. The Unified CCX cluster supports up to two Unified CCX servers, one 
designated as the active Unified CCX server and the other designated as the 
standby Unified CCX server for high availability purposes.

Note Support for High Availability and remote servers is available only in 
multiple-server deployments.

 • Cluster profile. The Unified CCX Administration web page (home page) 
displays information about the cluster profile. A cluster profile includes data 
relating to the Unified CCX servers, components, and licenses installed in a 
cluster. 

 • Node (server). A server that is part of the Unified CCX cluster.

 • Active Server. The active server provides all system services and resources. 
You can deploy one active server in each Unified CCX subsystem. If the 
active server fails, the Unified CCX subsystem automatically fails over to the 
standby server (see High Availability and Automatic Failover, page 11-3).

 • Standby Server. You can deploy up to two servers in each Unified CCX 
system for high availability—one active server (master) and one standby (not 
active) server. With high availability, if an active server becomes 
unavailable, the standby server automatically becomes the active server (see 
High Availability and Automatic Failover, page 11-3).

 • Component.The software units in the Unified CCX system. The main 
software components of the Unified CCX server are the Engine, datastores, 
monitoring, recording, and the Cluster View Daemon (CVD). See the 
Installation Guide for Cisco Unified CCX and Cisco Unified IP IVR, Release 
8.5(1) for more information on setup and installation procedures.
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 • Service. An executable unit. A service may have other services as its 
children. (For example, subsystems and managers are children of the engine 
service).

 • Feature. A logical representation of the functional unit.

 • Master service. A specially-elected service. Only one service from the 
Engine service, desktop services, database services set can be the master 
within the Unified CCX Engine component. See the Cisco Unified Contact 
Center Express Serviceability Guide for detailed information on services.

 • Standby service. An active service that can take over the master 
functionality in case the master service becomes unavailable within the 
Unified CCX Engine component. You cannot configure the standby service. 
The Cluster View Daemon (CVD) dynamically elects the services on the 
active node to be the master. See the Cisco Unified Contact Center Express 
Serviceability Guide for detailed information on services.

High Availability and Automatic Failover

Note Support for High Availability (HA) and remote servers is available only in 
multiple-server deployments. Unified CCX does not support more than two nodes 
in a HA setup. Expansion servers where the Database, Monitoring, or Recording 
components are running on separate servers are not supported.

Unified CCX provides high availability and automatic failover capability through 
the use of two servers, the active server and the standby server.

The active server provides all system services and resources; no services or 
resources are available from the standby server. When you make administrative 
changes on the active server, both the servers are synchronized. 

If the active server fails, there is automatic failover to the standby server. For 
detailed information on HA over WAN deployment, see Cisco Unified CCX 
Solution Reference Network Design. 
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Network Partitions
Network malfunction or misconfiguration can create network partitions and split 
the network into separate islands. If a node enters this state, the node is referred 
to as being in the island mode. Nodes in the island mode are hard to detect. While 
these nodes can communicate within a partitioned island, they cannot 
communicate between partitioned islands. If the islands do not communicate, then 
each island will select its own active server.

Generally, you can connect to the Unified CCX administration on any node, and 
see a consistent cluster view. If a node is in the island mode, you will see different 
cluster views when you connect to nodes in each island.

Note Support for High Availability and remote servers is available only in 
multiple-server deployments.

If your node enters the island mode, it should recover from the island mode as 
soon as the underlying network issue is resolved. If the island mode persists, 
check the network connectivity/reachability between the two CCX servers and 
take action accordingly.

Managing Unified CCX CDS Information
The Unified CCX system stores configuration information in the Cisco 
Configuration Datastore Server (CDS). The Unified CCX Administration 
configurations are stored in the CDS.

Note Support for High Availability and remote servers is available only in 
multiple-server deployments.

The Unified CCX server can receive directory information from one Cisco 
Unified Communications directory and application configuration and script logic 
from a repository on another server. See Cisco Unified Contact Center Express 
Serviceability Guide for detailed information.
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Managing System Parameters 
The parameters in the System Parameters Configuration page are grouped 
logically into sections with headings. Each parameter has a corresponding 
suggested or default value on the right side of the page. Where applicable, radio 
buttons are used to toggle between the parameter options.

In this web page, you can configure the number of historical reporting clients, the 
recording count, port settings, the default session timeout, and codec. 

Note Changing some system parameters like IP address, Network Time Protocol (NTP) 
and so on can result in a different License MAC. You need to get rehosted license 
files (with new License MAC) in such cases within 30-day grace period beyond 
which the system will stop working.

Procedure

Step 1 Choose System > System Parameters from the Unified CCX Administration 
menu bar.

The System Parameters Configuration web page appears displaying the following 
fields.

Field Description

Generic System Parameters

System Time Zone The system or primary time zone will be the same as local time zone of the 
primary Unified CCX node configured during installation. Display only 
field. Unified CCX Administration uses this primary time zone to display 
time-related data.

Note If you have changed the primary time zone, you need to reboot 
both the nodes in the Unified CCX cluster.

Network Deployment Parameters (displayed only in a HA over WAN deployment)

Network Deployment 
Type

Display only field that displays the network deployment type as LAN or 
WAN only if we have more than one node.
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Internationalization Parameters

Customizable Locales Use to specify a unique locale. 

Default: (blank)

Default Currency Default currency, such as American dollars (USD), Euros, and so on. This 
is a mandatory field.

The system uses the default currency for converting currency amounts in a 
playable format when no currency designator is specified.

Default: American Dollar [USD]

Media Parameters

Codec The codec chosen during installation for this Unified CCX server. 

The codec configuration settings differ based on the Unified CCX 
deployment type:

 • In Unified CM deployments, the codec parameter is configurable. 

 • In Unified CME deployments, the codec parameter is not configurable 
and is always G711.

Recording Count The maximum number of simultaneous sessions that are supported with 
this system configuration. This value cannot be greater than the number of 
seats. This is a mandatory field.

Note Standard license package does not support recording. Premium 
package license supports recording, however, when you upgrade 
from Standard to Premium license package, you need to manually 
change this recording count to a suitable value based on the 
hardware type to enable recording functionality.

Default: 0

Default TTS Provider Default TTS (Text-to-Speech) provider. 

Default: By default, no TTS provider is configured. Select a provider from 
the drop-down list to configure it as the default. The system uses the 
default TTS provider to determine which provider to use if the TTS request 
does not explicitly specify the provider to use.

Field Description
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User Prompts override 
System Prompts

When enabled, custom recorded prompt files can be uploaded to the 
appropriate language directory under Prompt Management as described in 
Managing Prompt Files, page 10-2, to override the system default prompt 
files for that language.  By default, this is disabled.

Application Parameters

Supervisor Access The Administrator uses this option to allow certain privileges to 
supervisors (all supervisors have the same privilege). The options are:

 • No access to teams—The supervisor logs into the Supervisor page, but 
will not be able to see any team information (No RmCm info). 

 • Access to all teams—The supervisor logs into the Supervisor page, and 
will be able to see all the teams (RmCm information)

 • Access to supervisor’s teams only—The supervisor logs into the 
Supervisor page, and will be able to see the teams they supervise.

Default: No access to teams

Note A supervisor who does not have administrator privileges can add, 
modify, or remove skills from an agent (see Supervisor Privileges, 
page 15-3). 

Max Number of Executed 
Steps

The maximum number of steps an application can execute before the 
Unified CCX Engine terminates the script or application. This is a 
mandatory field.

This limitation is intended to prevent a script from running indefinitely.

Default: 1000

Note Do not change the default value.

Additional Tasks This field allows you to control the creation of additional threads that the 
Unified CCX server internally initializes based on licensed Unified IP IVR 
ports. This is a mandatory field.

Default: 0

Field Description
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Default Session Timeout Maximum amount of time (in minutes) a user-defined mapping ID remains 
in the session object memory after the session is moved to the idle state. 
During this duration, the session continues to be accessible even if you 
have terminated that session. Use this setting to configure the time required 
to perform your after-call work (for example, writing variables to a 
database before clearing the session). This is a mandatory field.

The default is 30 minutes (recommended). Reducing this number, also 
reduces the system memory usage comparatively.

You can add a user-defined mapping ID to a session using the Session 
Mapping step in the script editor. Once assigned, you can use this mapping 
ID to get the session object from another application instance. By doing so, 
other applications obtain access to the session context. See the Cisco 
Unified CCX Getting Started with Scripts guide for more information.

Enterprise Call Info 
Parameter Separator

A character used Get/Set Enterprise Call Info steps in the Unified CCX 
Editor to act as a delimiter for call data. This is a mandatory field.

Default: | (bar)

Agent State after Ring 
No Answer

Radio button determining how agent state should be set after a Ring No 
Answer event. This is a mandatory field. The choices are: 

 • Ready. If an agent does not answer a call, the Agent State is set to 
Ready.

 • Not Ready (default). If an agent does not answer a call, the Agent State 
is set to Not Ready.

Number of HR session 
licenses

The number of Historical Reporting sessions that can be supported with 
this system configuration. This denotes the number of historical reporting 
clients that can be started simultaneously on different client machines. This 
is a mandatory field.

This value cannot be greater than the number of licensed seats in the case 
of Unified CCX (see Historical Reporting Configuration, page 12-2).

Default: 0 for Unified CCX (Standard, Enhanced, and Premium), 5 Unified 
IP IVR.

Field Description
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Number of Outbound 
seats

The maximum number of Outbound seats. The configuration of Outbound 
seats is done during the initial configuration or setup phase, after the 
installation. 

Note This is a mandatory field. This field will be displayed only if 
you have a Premium license.

The maximum number of preview outbound seats that can be configured is 
the limited by either the Premium Seat Count or the hardware limit, 
whichever is the least. If there is an invalid entry during configuration, an 
error message is displayed.

The hardware limit for the Preview Outbound seat count is as shown in the 
table:

System Ports Parameters

RMI Port The port number used by the Unified CCX CVD to serve RMI requests. 
This is a mandatory field.

Default: 6999

Field Description
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Step 2 Click Update icon that displays in the tool bar in the upper, left corner of the 
window or the Update button that displays at the bottom of the window.

The system notifies all nodes in the cluster about the changes. 

Note If Cluster View Daemon is in Shutdown state during this operation, then the 
changes just made are synchronized on that node when Cluster View Daemon is 
started again.

Changing IP Address of Unified CCX
This section provides the steps you need to follow whenever there is a change in 
IP address for the following Unified CCX deployments:

 • Unified CCX Cluster with Single-node 

 • Unified CCX Cluster with High Availability (HA)

You may want to change the IP address for a variety of reasons, including moving 
the server from one segment to another or resolving a duplicate IP address 
problem. This section contains the following sub-sections:

 • Readiness Checklist, page 11-11

RmCm TCP Port TCP port number on which the CTI server component of the RmCm 
subsystem opens the server socket and listens to the clients. All CTI server 
clients, such as Cisco Agent Desktop, Unified ICME Server, Sync Server, 
and IP Phone Agent Server, use this port number. This is a read-only field 
and cannot be modified.

Default: 12028

Master Listener TCP Port TCP port used for communication between CVD and Cisco 
Agent/Supervisor Desktop Services. This is a read-only field and cannot be 
modified.

Default: 1994

Field Description
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 • Changing the IP Address, page 11-13

 – Changing the IP Address for Server in a Single-Node Deployment, 
page 11-13

 – Changing the IP Addresses for Servers in a High Availability (HA) 
Deployment, page 11-16

 • Post-Change Task List, page 11-22

Note Host name change is not supported in Cisco Unified CCX 8.5(1).

Readiness Checklist
Perform the following tasks to ensure that your system is prepared for a successful 
IP address change.

Note If you do not receive the results that you expect when you perform these tasks, do 
not continue with this procedure until after you resolve any problems that you 
find. DB replication across the entire cluster is essential for this process.

Procedure

Step 1 List all servers in the cluster and note whether the nodes are defined by using IP 
addresses or host names.

 • From Cisco Customer Response Solutions menu bar on the first node, 
navigate to System > Server. A list of all servers in the cluster displays.

 • See whether the servers are defined using IP addresses or host names and 
capture this list of servers for later reference. Ensure that you have saved an 
inventory of both the host name and IP address of each node in your cluster.

Step 2 Ensure that all servers in the cluster are up and available by checking for any 
active ServerDown alerts. You can check by using either the Real Time 
Monitoring Tool (RTMT) or the Command Line Interface (CLI) on the first node.

 • To check by using RTMT, access Alert Central and check for ServerDown 
alerts.
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 • To check by using the CLI on the first node, enter the following command 
and inspect the application event log:

file search activelog syslog/CiscoSyslog ServerDown

Step 3 Check the DB replication status on all the Cisco CRS nodes and Cisco Unified 
Communications nodes in the cluster to ensure that all servers are replicating 
database changes successfully using the steps mentioned below:

a. For Unified CCX: In a High Availability deployment of Unified CCX, you 
can check the DB replication status for the datastores across all servers in the 
cluster using Unified CCX Serviceability Administration. Choose Tools > 
Datastore Control Center > Replication Servers from the Unified CCX 
Serviceability menu bar to view the replication status. The value in State field 
for both the servers in this web page should display ACTIVE/ CONNECTED. 
Refer to Cisco Unified Contact Center Express Serviceability Guide for more 
information on how to reset replication. 

b. For Cisco Unified Communications Platform: You can check the DB 
replication status on all the Cisco Unified Communications nodes in the 
cluster by using either RTMT or a CLI command.

 – To check by using RTMT, access the Database Summary and inspect the 
replication status.

 – To check by using the CLI, enter the command that is shown in the 
following example:

admin: show perf query class "Number of Replicates Created and 
State of Replication"
==>query class :

- Perf class (Number of Replicates Created and State of 
Replication) 
has instances and values:
ReplicateCount  -> Number of Replicates Created   = 344
ReplicateCount  -> Replicate_State                = 2

Be aware that the Replicate_State object shows a value of 2 in this case. The 
following list shows the possible values for Replicate_State:

 – 0—Replication Not Started. Either no subscribers exist, or the Database 
Layer Monitor service is not running and has not been running since the 
subscriber was installed.

 – 1—Replicates have been created, but their count is incorrect.
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 – 2—Replication is good.

 – 3—Replication is bad in the cluster.

 – 4—Replication setup did not succeed.

Step 4 Run a manual DRS backup and ensure that all nodes and active services are 
backed up successfully. For more information, refer the Disaster Recovery System 
Administration Guide for your release.

Step 5 Run the CLI command utils diagnose module validate_network through 
Platform CLI on all nodes in the cluster to ensure network connectivity and DNS 
server configuration are intact.

Changing the IP Address
This section describes how to change the IP address.

Caution Changing the IP address on any node in a Cisco CRS cluster can interrupt call 
processing and other system functions. Also, changing the IP address can cause 
the system to generate certain alarms and alerts such as ServerDown and 
automatic failover to a backup server may not operate. Because of this potential 
impact to the system, you must perform IP address changes during a planned 
maintenance window.

This section contains the following subsections:

 • Changing the IP Address for Server in a Single-Node Deployment 

 • Changing the IP Addresses for Servers in a High Availability (HA) 
Deployment

Changing the IP Address for Server in a Single-Node Deployment

Use this procedure to change the IP address of the server in a single-node 
deployment.
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Procedure

Step 1 Change the DNS record of the server to point to the new IP address. Ensure that 
you correctly update both the forward (A) and reverse (PTR) records, and there 
are no duplicate PTR records. 

Note Skip Step 2 if the server is defined by host name and you are changing only the 
IP address.

Step 2 From Cisco Customer Response Solutions menu bar, perform the following tasks:

a. Navigate to System > Server. Click the IP address of the server. 

b. The Server Configuration page for the server opens. Enter the new IP address 
in the Host Name/IP Address field and click Save. 

Step 3 If you are moving the server to a different subnet that requires a new default 
gateway address, you can change the default gateway and IP address using either 
CLI command or through Cisco Unified Communications Operating System 
Administration interface as explained below:

Using CLI command:

a. To change the default gateway, enter the following CLI command:

set network gateway <IP Address> 

The following sample output displays: 

admin:set network gateway 10.3.90.2
          ***   W A R N I N G   ***
This will cause the system to temporarily lose network 
connectivity

          Do you want to continue ?

Enter "yes" to continue or any other key to abort
yes
executing...
admin:

Note Ensure that the server is moved to the new subnet and has access to the default 
gateway before proceeding to the following sub-step.

b. To change the IP address of the server, enter the following CLI command:
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set network ip eth0 <ip_address> <netmask>

where ip_address specifies the new server IP address and netmask specifies 
the new server network mask.

The following sample output displays:

admin: set network ip eth0 10.3.90.21 255.255.254.0
** W A R N I N G ***
If there are IP addresses (not hostnames)
configured in UCCX Administration
under System -> Servers then you must change
the IP address there BEFORE changing it here
or call processing will fail. This will cause the system to 
restart
=======================================================
Note: To recognize the new IP address all nodes within
the cluster will have to be manually rebooted.
=======================================================
Do you want to continue?
Enter "yes" to continue and restart or any other key to abort

Enter y and press Enter. This will automatically reboot this server with the 
new IP address.

Through Cisco Unified Communications Operating System Administration Interface:

Alternatively, you can change the IP address and default gateway of the 
server from Cisco Unified Communications Operating System 
Administration interface using the steps mentioned below:

a. Choose Settings > IP > Ethernet. 

b. Change the IP address, default gateway, and netmask, and click Save. The 
server reboots automatically with the new IP address. 

Step 4 If you change the IP address, License MAC of the server will also change. Rehost 
the new license. Old license enters its grace period.

Step 5 From Cisco Desktop Administrator web page, choose Services Configuration > 
Silent Monitoring & Recording > Remove VoIP/Recording & Playback 
Services. Remove any VoIP Monitor Service or Recording & Playback Service 
listed, which uses the IP address that has been changed.                                                           
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Step 6 From Cisco Desktop Administrator, navigate to CAD Configuration Setup. 
Update primary location of the CAD-BE Server to the new IP address. The 
Services IP Address should display the new IP address. If not, change it to the new 
IP address. Click Save and then restart all CAD services on the server after 
making these updates. 

Note When you change the IP address in a single node deployment, CAD does not 
launch itself and you need to run the Cisco Unified CCX Desktop Client 
Configuration tool to update the client installations with the new IP address (see 
Post-Change Task List, page 11-22).

Changing the IP Addresses for Servers in a High Availability (HA) Deployment

Use the following subsections to change the IP address of publisher and 
subscriber in a HA deployment:

 • Changing the IP Address for Publisher Server in a HA Deployment, 
page 11-16

 • Changing the IP Address for Subscriber Server in a HA Deployment, 
page 11-19

Changing the IP Address for Publisher Server in a HA Deployment

Use this procedure to change the IP address of publisher server in a HA 
deployment.

Procedure

Step 1 Change the DNS record of the publisher server to point to the new IP address. 
Ensure that you correctly update both the forward (A) and reverse (PTR) records, 
and there are no duplicate PTR records.

Step 2 Verify that the DNS change propagates to other nodes by using the utils 
network host and show tech network hosts CLI commands on all the cluster 
nodes.
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Note Skip Step 3 if the server is defined by host name and you are changing only the 
IP address.

Step 3 From Cisco Customer Response Solutions menu bar, perform the following tasks:

a. Navigate to System > Server. From the List Servers web page, click the IP 
address of the publisher server. 

b. The Server Configuration page for the publisher server opens. Enter the new 
IP address in the Host Name/IP Address field and click Save. 

Step 4 From the Cisco Unified Operating System Administration web page of the 
subscriber server in the cluster, perform the following tasks:

a. Navigate to Settings > IP > Publisher.

b. Change the IP address of the publisher server.

Step 5 To update new IP of the publisher server in subscriber, enter the following CLI 
command on the subscriber server:

utils uccx modify remote_IPAddress <Old_IP_of_Publisher> 

<New_IP_of_Publisher>

The following output displays: 

admin:utils uccx modify remote_IPAddress 10.3.90.21  10.3.90.28

 Old Remote IP Address: 10.3.90.21
 New Remote IP Address: 10.3.90.28

This command should be executed only in case you are changing IP 
Address of remote server.
Are you sure you want to run this command?
Continue (y/n)?

Enter y and press Enter.

Step 6 If you are moving the publisher server to a different subnet that requires a new 
default gateway address, you can change the default gateway and IP address using 
either CLI command or through Cisco Unified Communications Operating 
System Administration interface as explained below:

Using CLI command:

a. To change the default gateway, enter the following CLI command:
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set network gateway <IP Address> 

The following sample output displays: 

admin:set network gateway 10.3.90.2
          ***   W A R N I N G   ***
This will cause the system to temporarily lose network 
connectivity

          Do you want to continue ?

Enter "yes" to continue or any other key to abort
yes
executing...
admin:

Note Ensure that the server is moved to the new subnet and has access to the default 
gateway before proceeding to the following sub-step.

b. To change the IP address of the server, enter the following CLI command:

set network ip eth0 <ip_address> <netmask>

where ip_address specifies the new server IP address and netmask specifies 
the new server network mask.

The following sample output displays:

admin: set network ip eth0 10.3.90.21 255.255.254.0
** W A R N I N G ***
If there are IP addresses (not hostnames)
configured in UCCX Administration
under System -> Servers then you must change
the IP address there BEFORE changing it here
or call processing will fail. This will cause the system to 
restart
=======================================================
Note: To recognize the new IP address all nodes within
the cluster will have to be manually rebooted.
=======================================================
Do you want to continue?
Enter "yes" to continue and restart or any other key to abort

Enter y and press Enter. This will automatically reboot this server with the 
new IP address. 
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Through Cisco Unified Communications Operating System Administration Interface:

Alternatively, you can change the IP address and default gateway of the 
server from Cisco Unified Communications Operating System 
Administration interface using the steps mentioned below:

a. Choose Settings > IP > Ethernet. 

b. Change the IP address, default gateway, and netmask, and click Save. The 
server reboots automatically with the new IP address. 

Step 7 Reboot all other servers in the cluster using the CLI command utils system 
restart. 

Step 8 If you change the IP address, License MAC will also change. Rehost the new 
license for the new LicenseMAC. Old license enters its grace period.

Step 9 From Cisco Desktop Administrator web page, choose Services Configuration > 
Silent Monitoring & Recording > Remove VoIP/Recording & Playback 
Services. Remove any VoIP Monitor Service or Recording & Playback Service 
listed, which uses the IP address that has been changed.                                                           

Step 10 From Cisco Desktop Administrator, navigate to CAD Configuration Setup. 
Update primary and secondary location of the CAD-BE Servers to the new IP 
address. The Services IP Address should display the new IP address. If not, 
change it to the new IP address. Click Save and then restart all CAD services on 
the server after making these updates. 

Note When you change the IP address of publisher, CAD will connect to the subscriber 
and will update the IP address of the publisher automatically through its True 
Update functionality (see Post-Change Task List, page 11-22).

Changing the IP Address for Subscriber Server in a HA Deployment

Use this procedure to change the IP address of a subscriber server in a HA 
deployment.

Procedure

Step 1 Change the DNS record of the subscriber server to point to the new IP address. 
Ensure that you correctly update both the forward (A) and reverse (PTR) records, 
and there are no duplicate PTR records.
11-19
Cisco Unified CCX Administration Guide, Release 8.5(1)

 



Chapter 11      Managing the Unified CCX System
Changing IP Address of Unified CCX
Step 2 Verify that the DNS change propagates to other nodes by using the utils 
network host and show tech network hosts CLI commands on all the cluster 
nodes.

Note Skip Step 3 if the server is defined by host name and you are changing only the 
IP address.

Step 3 From Cisco Customer Response Solutions menu bar, perform the following tasks:

a. Navigate to System > Server. From the List Servers web page, click the IP 
address of the subscriber server. 

b. The Server Configuration page for the subscriber server opens. Enter the new 
IP address in the Host Name/IP Address field and click Save. 

Note You can use the CLI command run sql select name,nodeid from ProcessNode 
to check whether the new IP address has been replicated on all the servers.

Step 4 To update new IP of the subscriber in publisher, enter the following CLI 
command on the publisher server:

utils uccx modify remote_IPAddress <Old_IP_of_Subscriber> 

<New_IP_of_Subscriber>

The following output displays: 

admin:utils uccx modify remote_IPAddress 10.3.90.21  10.3.90.28

 Old Remote IP Address: 10.3.90.21
 New Remote IP Address: 10.3.90.28

This command should be executed only in case you are changing IP 
Address of remote server.
Are you sure you want to run this command?
Continue (y/n)?

Enter y and press Enter.

Step 5 If you are moving the server to a different subnet that requires a new default 
gateway address, you can change the default gateway and IP address using either 
CLI command or through Cisco Unified Communications Operating System 
Administration interface as explained below:
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Using CLI command:

a. To change the default gateway, enter the following CLI command:

set network gateway <IP Address> 

The following sample output displays: 

admin:set network gateway 10.3.90.2
          ***   W A R N I N G   ***
This will cause the system to temporarily lose network 
connectivity

          Do you want to continue ?

Enter "yes" to continue or any other key to abort
yes
executing...
admin:

Note Ensure that the server is moved to the new subnet and has access to the default 
gateway before proceeding to the following sub-step.

b. To change the IP address of the server, enter the following CLI command:

set network ip eth0 <ip_address> <netmask>

where ip_address specifies the new server IP address and netmask specifies 
the new server network mask.

The following sample output displays:

admin: set network ip eth0 10.3.90.21 255.255.254.0
** W A R N I N G ***
If there are IP addresses (not hostnames)
configured in UCCX Administration
under System -> Servers then you must change
the IP address there BEFORE changing it here
or call processing will fail. This will cause the system to 
restart
=======================================================
Note: To recognize the new IP address all nodes within
the cluster will have to be manually rebooted.
=======================================================
Do you want to continue?
Enter "yes" to continue and restart or any other key to abort

Enter y and press Enter. This will automatically reboot this server with the 
new IP address.
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Through Cisco Unified Communications Operating System Administration Interface:

Alternatively, you can change the IP address and default gateway of the 
server from Cisco Unified Communications Operating System 
Administration interface using the steps mentioned below:

a. Choose Settings > IP > Ethernet. 

b. Change the IP address, default gateway, and netmask, and click Save. The 
server reboots automatically with the new IP address. 

Step 6 Reboot all other servers in the cluster using the CLI command utils system 
restart. 

Step 7 From Cisco Desktop Administrator web page, choose Services Configuration > 
Silent Monitoring & Recording > Remove VoIP/Recording & Playback 
Services. Remove any VoIP Monitor Service or Recording & Playback Service 
listed, which uses the IP address that has been changed.                                                           

Step 8 From Cisco Desktop Administrator, navigate to CAD Configuration Setup. 
Update primary and secondary location of the CAD-BE Servers to the new IP 
address. The Services IP Address should display the new IP address. If not, 
change it to the new IP address. Click Save and then restart all CAD services on 
the server after making these updates. 

Post-Change Task List
Once you change the IP addresses of your cluster, complete the following tasks:

Procedure

Step 1 Choose Tools > Plug-ins and click Cisco Unified CCX Desktop Suites from the 
Unified CCX Administration menu bar. From the Cisco Unified CCX web page, 
run the Cisco Unified CCX Desktop Client Configuration tool to update the client 
installations with the new IP addresses. 
On the client, if only one IP address in a HA system has been updated and the 
client is an XP machine with administrator privileges, then the Automatic Update 
process will update the registry the next time the user logs on. However, you will 
have to manually update the client's system by running C:\Program 
Files\Cisco\Desktop\bin\PostInstall.exe program, and update it with the 
correct IP addresses, if any of the following conditions are true: 

 • IP address of a single node deployment is changed
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 • Both IP addresses in a HA system is changed

 • Client OS is Microsoft Vista or Win7

 • Client does not have administrative rights

Step 2 Ensure that all the servers in the cluster are up and available.

Step 3 Check the DB replication status as mentioned in Step 3 of the Readiness Checklist 
to ensure all the servers are replicating database changes successfully. 

Step 4 Run a manual DRS Backup and ensure that all nodes and active services are 
successfully backed up.

Step 5 Run the CLI command utils diagnose module validate_network through 
platform CLI on all nodes in the cluster to ensure network connectivity and DNS 
server configuration are intact.

Step 6 If you have changed the IP address to move the Unified CCX server to a different 
network, then any firewall configuration on the other network must be changed to 
permit or deny traffic from the new IP address. 

Step 7 If you have created any DSN using old IP address, change the DSN to point to the 
new IP. For example, the DSN created for Wallboard.

Step 8 You might have to update the new IP address in the following web pages as well:

 • Cisco Desktop Administrator > Cisco Unified Presence Settings > Cisco 
Unified Presence Cluster - Publisher Host/IP Address and Subscriber 
Host/IP Addresses

 • Cisco Desktop Administrator > Agent E-Mail Settings > Global Settings 
- IMAP Server Host/IP Address and SMTP Server Host/IP Address

 • Work Flow Configuration > User Interface > Browser Setup - URL and 
Home Page

 • Work Flow Configuration > HTTP Action - Host

 • Work Flow Configuration > IPC Action - IP Address

Exiting Unified CCX Administration
To exit Unified CCX Administration without closing your web browser, you can: 
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 • Click the Logout link displayed in the top right corner of any Cisco Unified 
CCX Administration web page or

 • Choose System > Logout from the Unified CCX Administration menu bar.

The system logs you out of Unified CCX and displays the Unified CCX 
Authentication web page.

Note You can also exit Unified CCX Administration by closing your web browser. 
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Managing Unified CCX Historical 
Reporting

The following sections describe how to manage the Unified CCX Historical 
Datastore to accommodate historical reporting.

 • About Unified CCX Historical Datastore, page 12-1

 • Historical Reporting Configuration, page 12-2

 • Purging Historical Data, page 12-3

 • File Restore, page 12-7

About Unified CCX Historical Datastore
In a Unified CCX Cluster, there can be one or more Historical datastores. 

Note Support for High Availability and remote servers is available only in 
multiple-server deployments.

The Historical Unified CCX Datastore can be co-located only on the server with 
the Unified CCX Engine.

Note For more information about Historical datastore, see Cisco Unified Contact 
Center Express Serviceability Guide.
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Historical Reporting Configuration

Note Verify that the Number of HR Session Licenses field is updated to 
reflect the licensed value. This value cannot be greater than the number 
of licensed Unified CCX seats. The default value is 0 for Unified CCX 
(Standard, Enhanced, and Premium), and 5 for Unified IP IVR (see 
Managing System Parameters, page 11-5). 

Caution If this value remains at 0 (default), you may encounter a licensing error 
and you cannot login to the Historical Reporting Client.

The Unified CCX Historical Reporting subsystem provides you with a way to set 
up and manage the purging of the Historical Reporting databases.

Setting up Unified CCX for Historical Reporting consists of three tasks:

1. Configuring Database Server Limits, page 12-2

2. Viewing Historical Reports, page 12-3

3. Configuring Automatic Purging, page 12-4

Configuring Database Server Limits
To limit the performance impact of historical reporting on a particular Unified 
CCX server, you can configure a maximum number of five client/scheduler 
database connections per server. 

To do so, complete the following steps:

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Tools > Historical 
Reporting > Database Server Configuration.
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The Database Server Configuration web page opens with the following fields:

Step 2 Enter a value in the Maximum DB Connections for Report Client Sessions field 
next to a Server Name.

Step 3 Click Update. 

The configuration changes take effect.

Viewing Historical Reports
Choose Tools > User Management > Reporting Capability View to configure 
historical reporting users. The User Configuration web page opens (see Historical 
Report User Privileges, page 15-5) for detailed instructions. You can view the 
historical reports through Historical Reporting client.

Purging Historical Data 
As the Unified CCX Engine runs, it collects information about the status and 
performance of the Unified CCX system. Historical information is stored in a 
database that can then be accessed to provide reports (see the Cisco Unified CCX 
Historical Reports User Guide for more information about Unified CCX 
Historical Reports). 

When the database approaches its maximum size, some or all of the data in it must 
be removed. Removing data from a database is called purging.

Field Description

Server Name The host name or IP Address of the database server.

Maximum DB Connections for 
Report Clients Sessions

The maximum number of client and scheduler connections that can 
access the Historical Reports Database server.

There is a limit of 5 instances of Historical Reporting Client and 
Scheduler based on the load that can be run on each server. The 
historical report client issues an error if you exceed this limit.
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When the system purges data, it removes data from the db_cra database. It 
determines what information to purge based on the number of months you specify 
and on the current date. For example, if you instruct the system to purge data older 
than 12 months, a purge on January 15 will purge data older than January 15 of 
the previous year.

Note When you purge data, you permanently delete it. If you want to keep data that will 
be purged, back up the database.

Unified CCX Administration provides the following features for purging 
historical reports from the database:

 • Daily comparison of the size of the database to a user-specified maximum 
size

 • User-specified time at which the system purges data

 • Automatic purging of the database when it exceeds the user-specified 
maximum sizes

 • Automatic purging of the database based on user-specified parameters

 • Manual purging of the database

This section describes:

 • Configuring Automatic Purging, page 12-4

 • Purging Manually, page 12-6

Configuring Automatic Purging
The Unified CCX Engine performs automatic purging each day at a preset time. 

To help keep your system running most efficiently, schedule automatic purging 
to run when your system is least busy. By default, daily purges are scheduled to 
run at 12:00 a.m. (00:00 Hrs), but you can change this time.

The system bases its purging activities on a variety of parameters. You can change 
the default value for any parameter as needed. 

The following section contains the procedure for setting daily purge schedule and 
auto purge. 
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Configuring Purge Schedule Configuration Parameters

You can change the time of day that the system assesses the need to purge data 
and the age of data to purge. 

When data is purged, the Unified CCX sends a “Database purged” message. This 
message announces that a purge has taken place and includes an explanation of 
the purging activity. If the database is approaching its maximum size, then the 
Unified CCX sends the following message - “Database approaching maximum 
size”.

The system can send notifications through the following two methods:

 • Syslog (system log)

 • SNMP traps 

To set the purge schedule configuration parameters, complete the following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Tools > 
Historical Reporting > Purge Schedule Configuration.

The Purge Schedule Configuration area opens. The following fields are displayed 
in the Purge Schedule Configuration area.

Field Description

Purge Schedule

Daily purge at Time of day for the daily purge along with the time zone. The 
time mentioned here is based on the primary time zone, 
which is specified during initial setup of Unified CCX 
Administration. 

In a High Availability over WAN deployment, the purge 
schedule will happen at the time zone of the primary node.

Purge data older than Number of months data can persist before being purged.

Auto Purge Configuration
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Step 2 From the drop-down list in the Daily purge at field, choose a time of day at which 
the system determines if purging is necessary.

Step 3 From the drop-down list in the Purge data older than field, choose the required 
number of months.

If the system determines that purging is necessary, it will purge both databases of 
data that is older than the number of months specified in this field.

Step 4 From the drop-down list in the Initiate automatic purge when database size 
exceeds field, accept the default, or choose another number. 

Step 5 From the drop-down menu in the Auto purge data for the oldest field, accept the 
default of 15, or choose another number.

Step 6 Click Update icon that displays in the tool bar in the upper, left corner of the 
window or the Update button that displays at the bottom of the window. 

The new purge schedule configuration is added to the Unified CCX system. 

Purging Manually
You can manually purge the databases at any time. This action will not affect the 
automatic purging schedule.

Note Support for High Availability is available only in multiple-server deployments.

To manually purge historical data, complete the following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Tools > 
Historical Reporting > Purge Now.

Initiate automatic purge when database 
exceeds

Percentage of the maximum database size at which an 
automatic purge is initiated (as compared to the total 
available size).

Auto purge data for the oldest Age of data to be purged.

Field Description
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The Purge Now web page opens. The Purge data older than field is displayed in 
the Purge Now web page. You can specify this field in months and days.

Step 2 From the drop-down list in the Purge data older than N months field, keep the 
default (13 months) or specify the required number of months.

If the system determines that purging is necessary, it will purge both databases of 
data that is older than the number of months specified in this field. 

The Initiate automatic purge when database exceeds field displays the current 
historical database size as compared to the total available size.

Step 3 From the drop-down list in the Purge data older than N days field, keep the default 
(15 days) or specify the required number of days.

If the system determines that purging is necessary, it will purge both databases of 
data that is older than the number of days specified in this field.

Step 4 Click Purge Now.

The database purge is initiated in the server and the Purge Now area refreshes.

Related Topic

 • Configuring Purge Schedule Configuration Parameters, page 12-5

File Restore
Use the File Restore menu option to restore the database records written to HR 
files when the database goes down. See File Restore, page 20-12 for detailed 
information on how to restore the database records written to HR files when the 
database goes down. 
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Configuring Unified CCX Outbound 
Dialer 

The Unified CCX Outbound Dialer feature, available in the Unified CM version 
of the Unified CCX product, is bundled along with the Unified CCX Premium 
license package. This chapter provides conceptual, installation, and configuration 
information about the Unified CCX Outbound application.

When you upload the Premium license, the Outbound subsystem will 
automatically appear in the Subsystems menu. With this feature, you can maintain 
high agent productivity by configuring contact centers for automated Outbound 
activities and allow agents who are not busy with inbound calls to perform 
Outbound calls.

Unified CCX Outbound IVR Dialer Types
In addition to the existing preview outbound dialer option, Unified CCX Release 
8.5(1) supports IVR-based dialing. You can configure a campaign as an Outbound 
IVR campaign if you have an Outbound IVR license in addition to the existing 
Unified CCX Premium license. If you select the IVR based option for a campaign, 
the outbound calls will be handled by the IVR scripts. Typical applications 
include appointment and bill payment reminders. 

You can choose any one of the following dialer types for an IVR-based campaign:

 • Progressive

 • Predictive 
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Predictive/Progressive Dialer is developed to leverage call control and Answering 
Machine Detection (AMD) capability of SIP Gateway Interface to perform 
dialing, call control, and Call Progress Analysis for Outbound campaigns. This 
offloads call control off the Unified CM since the calls that need not be treated by 
an agent or an IVR such as no answers, busy tones, and so on are not sent to 
Unified CM. 

You can procure Unified CCX Outbound IVR license based on the IVR ports that 
you want to use for an Outbound IVR campaign. You need to upload an additional 
license for Outbound IVR feature. The Outbound IVR feature will not be 
available with Premium license of Unified CCX (see Unified CCX Requirements, 
page 13-4).

Note The Outbound feature is not supported in the following Unified CCX packages:
- Unified CCX Standard version
- Unified CCX Enhanced version
- Unified CME Version of Unified CCX
- Unified IP IVR

The following sections describe how to configure the Outbound feature in detail.

 • About the Outbound Feature for Unified CCX, page 13-3

 • Dialing Modes, page 13-8

 • Steps to Configure an Outbound IVR Subsystem in Unified CCX, page 13-14

 • How Is a Contact’s Local Time Determined?, page 13-15

 • The Outbound Configuration Checklist, page 13-16

 • Verifying the RmCm and Outbound Subsystems, page 13-17

 • Configuring General Outbound Properties, page 13-18

 • Adding a New Campaign, page 13-31

 • Importing Contacts for a Campaign, page 13-39

 • Enabling Campaigns, page 13-41

 • Adding Area Codes, page 13-42

 • Setting-up Communications with the Agent’s Desktop, page 13-43

 • Handling Do Not Call Contacts, page 13-59
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About the Outbound Feature for Unified CCX
The Outbound feature provides Outbound dialing functionality in addition to 
existing Unified CCX inbound capabilities. This feature allows agents who are 
not busy with inbound calls to handle Outbound calls. 

With the Outbound feature, customer calls are placed using the Cisco Unified 
Communications by way of the Unified CM for call control.

This section contains the following topics:

 • Outbound Characteristics, page 13-3

 • Unified CCX Requirements, page 13-4

 • Outbound Components, page 13-7

 • Dialing Modes, page 13-8

Outbound Characteristics
The Outbound feature includes the following characteristics:

 • An Outbound subsystem that can be monitored from the control center

 • Dialing modes - Direct preview, Predictive, and Progressive

 • Unified CCX Administration web pages to configure the Outbound feature

 • Outbound historical report templates (see the Cisco Unified CCX Historical 
Reports User Guide)

Note Calls made by the Outbound subsystem will not be displayed in the 
Contacts Summary Real-Time Report.

 • Real-Time reports are part of the Unified CCX Administration GUI real-time 
reporting applet (see Chapter 14, “Reporting on Real-Time Unified CCX 
Data”)

 • Access to real-time Outbound data from the GetReportingStatistics step

 • Cisco Agent Desktop (CAD) allows agents to handle Outbound calls (see the 
Cisco Desktop Administrator’s User Guide)

 • Sequential dialing
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Related Topics:

 • About the Outbound Feature for Unified CCX, page 13-3

 • Unified CCX Requirements, page 13-4

 • Outbound Components, page 13-7

 • Direct Preview Dialing Mode, page 13-9

Unified CCX Requirements
To use the Outbound feature, you must adhere to the following requirements:

 • Unified CCX Licensing Requirements: The licensing requirements for 
Outbound feature in Unified CCX will vary depending on the dialing modes 
(see Dialing Modes, page 13-8).

 – For Unified CCX Outbound Direct Preview Dialer: The Unified CCX 
Outbound Preview Dialer feature is automatically available with 
Premium license package without any additional license. It is no longer 
available with Enhanced license (see Unified CCX Licensing Packages, 
page A-1). 

 – For Unified CCX Outbound IVR Dialer: You need to upload an 
Outbound IVR license on top of Unified CCX premium license with the 
required number of IVR ports that you would like to use for the Outbound 
IVR feature (see Uploading Licenses, page 1-15). 

Note The sum of inbound and outbound IVR ports should be less than or equal to 
maximum number of IVR ports supported for your hardware model.

Once you obtain the Outbound IVR license for a specific number of 
ports, the IVR ports will be distributed between the inbound and 
outbound IVR calls using the following approach based on the different 
scenarios explained below. 

You can view the licensed IVR ports for outbound and inbound and the 
dedicated ports for both outbound and inbound calls by navigating to 
System > License Information > Display License(s) submenu from the 
Unified CCX Administration menu bar.
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Scenario 1: 

If your Contact Center is already utilizing maximum licensed IVR ports 
supported for your hardware model, then:

 – Inbound calls will take precedence over the configured Outbound IVR 
calls. 

 – If IVR ports are dedicated for a campaign, then the Outbound IVR ports 
available for the campaign will be gradually incremented as and when the 
inbound ports become free.

For example, if you have an MCS 7845 hardware that supports maximum of 
300 IVR ports and if you have 200 premium seats, then the current licensed 
IVR ports = 300 (Minimum of [seats*2, maximum supported for platform]).

In this case, if you upload an Outbound IVR add-on license for 100 IVR ports 
and add 3 campaigns with 20 dedicated ports each running at the same time, 
then the 60 Outbound IVR ports will be available to the campaigns only when 
the number of inbound ports are freed up to support the Outbound IVR calls. 

In other words, if the number of inbound ports that are used during the 
outbound IVR campaign time is 280, then only 20 Outbound IVR ports will 
be available to the campaigns. The number of Outbound IVR ports will be 
gradually incremented depending on the availability of free inbound ports. 

Scenario 2: 

If your Contact Center is close to utilizing the maximum IVR ports supported 
for your hardware model, then:

 – Inbound calls will take precedence over the configured Outbound IVR 
calls. 

 – If IVR ports are dedicated for a campaign and if you reach the maximum 
inbound call limit, then the Outbound IVR ports available for the 
campaign will be gradually incremented as and when the inbound ports 
become free.

For example, if you have an MCS 7845 hardware that supports maximum of 
300 IVR ports and if you have 130 premium seats, then the current licensed 
IVR ports = 260 (Minimum of [seats*2, max supported for platform]).

In this case, if you upload an Outbound IVR add-on license for 50 IVR ports 
and add 2 campaigns with 25 dedicated ports each running at the same time 
and if you reach the inbound call limit of 260 during the outbound IVR 
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campaign time, then only 40 ports (300-260) will be freed up initially for 
Outbound IVR calls. The number of Outbound IVR ports will be gradually 
incremented depending on the availability of free inbound ports. 

Scenario 3: 

If your Contact Center is using fewer ports than the maximum licensed ports 
supported for your hardware model, then the number of available IVR ports 
for inbound will continue to remain the same.

For example, if you have an MCS 7845 hardware that supports maximum of 
300 IVR ports and if you have 60 premium sea ts, then the current licensed 
IVR ports = 120 (Minimum of [seats*2, max supported for platform]).

In this case if you upload an Outbound IVR add-on license for 50 IVR 
Outbound ports, and add 2 campaigns with 20 dedicated ports each running 
at the same time, then Unified CCX will support 40 IVR Outbound calls and 
inbound port limit will continue to be 120 as the sum of both inbound and 
outbound ports (160) are within the maximum licensed ports (300) for the 
platform.

 • Unified CCX Subsystem Requirements:

 – The Outbound subsystem must be IN SERVICE (see Verifying the 
RmCm and Outbound Subsystems, page 13-17).

 – The RmCm subsystem must be IN SERVICE (see Configuring RmCm 
Provider, page 8-2).

 – The Unified CM Telephony subsystem must be IN SERVICE (see 
Provisioning Unified CM Telephony Subsystem, page 7-5).

 – The Unified CCX Database must be IN SERVICE.

 – IBM Informix Dynamic Server 

 • Cisco Security Agent (CSA) usage: If you plan to use CSA, which Cisco 
highly recommends, you must always use the default directories when 
installing any software on a server. You need not choose the default disk 
drive if an option is available (for example, C: or D:), but you must use default 
directories.
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 • Geographic region support:

 – The Outbound feature can be used in any geographic region supported by 
Unified CCX. The area codes and time zones mapping for North America 
are automatically pre-populated in the system. The system uses this 
information to determine the time zone of a customer’s phone number. 
See Adding Area Codes, page 13-42.

 – For regions outside North America, administrators must enter the 
mapping of the international area codes and their time zones using the 
Unified CCX Administration GUI. See How Is a Contact’s Local Time 
Determined?, page 13-15.

 – The national do_not_call list is not supported in this release. Be sure to 
abide by the national do_not_call list. See Handling Do Not Call 
Contacts, page 13-59.

Note In this guide, the underscore character linking each word differentiates the 
national do_not_call list from the Outbound subsystem’s Do Not Call list. 

Related Topics:

 • About the Outbound Feature for Unified CCX, page 13-3

 • Outbound Characteristics, page 13-3

 • Outbound Components, page 13-7

 • Direct Preview Dialing Mode, page 13-9

Outbound Components
This section provides details about the following Outbound feature components:

 • Unified CCX Administration: Enables the Outbound subsystem 
configuration, creates campaigns, and imports contacts to generate the 
dialing list.

 • Outbound subsystem: Is responsible for the following tasks:

 – Manages campaigns

 – Maintains Outbound system configurations

 – Manages the dialing list
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 – Reserves agents

 – Makes Outbound calls

 – Updates the call data in the dialing list based on the outcome of the call. 

 – Decides which contact records to retrieve from a campaign

The Outbound subsystem views campaigns as logical entities that group a set of 
contacts together in a dialing list. Campaigns deliver outgoing calls to agents. 
Agents are assigned to campaigns using CSQs.

Related Topics:

 • About the Outbound Feature for Unified CCX, page 13-3

 • Outbound Characteristics, page 13-3

 • Unified CCX Requirements, page 13-4

 • Direct Preview Dialing Mode, page 13-9

Dialing Modes
The Outbound feature in Unified CCX Release 8.5(1), supports the following 
dialing modes:

 • Direct Preview Dialing Mode

 • Progressive Dialing Mode

 • Predictive Dialing Mode

This new feature in the Outbound Dialer allows agents who are not busy with 
inbound calls to handle outbound calls, thus maintaining high level of agent 
productivity.

Note In Unified CCX 8.5(1), progressive and predictive dialers will be only used for 
IVR-based campaigns and not for Agent-based campaigns. In other words, the 
agents cannot preview the contact information on their desktops while using 
Predictive and Progressive dialing modes in Unified CCX Release 8.5(1).
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Direct Preview Dialing Mode
The direct preview dialing mode allows agents to preview a customer call on CAD 
before the call is placed. The advantage of this mode is that an agent is already on 
the call when the customer answers and can quickly begin talking with the 
customer immediately. 

The Outbound subsystem presents the agent with a popup window displaying the 
customer information prior to placing the Outbound call. The agent has the choice 
of accepting the call or ignoring it. The Outbound subsystem dials the customer 
only if the agent accepts the call.

If the agent accepts the call in this mode, the Outbound call is initiated from the 
agent’s phone. Since the call is initiated from the agent’s phone, the agent can 
hear the customer’s phone ring and also hear other tones, such as a busy signal. 

Tip You must explicitly disable the Call Waiting option on the agent’s phone to 
successfully use this feature. The Call Waiting option must be disabled (default) 
in Unified CM on each Outbound agent phone to ensure that every customer call 
successfully transfers to an available agent.

Related Topics:

 • About the Outbound Feature for Unified CCX, page 13-3

 • Outbound Characteristics, page 13-3

 • Unified CCX Requirements, page 13-4

 • Outbound Components, page 13-7

When an Outbound call is transferred or conferenced to another agent, the 
second/subsequent agents are not counted towards the number of Outbound 
licenses. For example, if you have five seats licensed for Outbound and Agent1 
gets an Outbound call, Agent1 accepts the call and conferences in Agent2 and 
Agent3. Now, three agents are on one Outbound call but only Agent1 is 
considered an Outbound agent and you are only using one licensed seat. 
Consequently, your system allows four more Outbound calls to agents. 

Caution When Agent A transfers an Outbound call to Agent B, all Preview Outbound 
option buttons are enabled on Agent B’s desktop. Despite all buttons being 
enabled, Agent B must only select the Do Not Call or the callback buttons at this 
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time. 
Likewise, after transferring the call to Agent B, Agent A should not attempt to set 
or change a callback time for that call. 

Related Topics

 • About the Outbound Feature for Unified CCX, page 13-3

 • How Is a Contact’s Local Time Determined?, page 13-15

 • The Outbound Configuration Checklist, page 13-16

Progressive Dialing Mode
Progressive dialer configuration is set for each campaign at the time of creating a 
campaign and can be updated at a later point. 

In the Progressive Dialing mode, you can specify a fixed number of lines that will 
always be dialed per available IVR port. You can configure the progressive dialer 
settings for each campaign while creating the campaign through Unified CCX 
Application Administration web interface. You can also update the configuration 
at a later date (see Adding a New Campaign, page 13-31). 

For example, in Progressive dialer if Number of Lines Per Port is 3 and X number 
of dedicated ports are available for Outbound calls, then the Outbound IVR dialer 
will dial 3X IVR calls (3*X). Depending on the number of calls that are getting 
abandoned due to the shortage of dedicated ports which may occur, you might 
have to adjust the lines per port manually to make the calls efficiently.

An abandoned call occurs when a customer answers the phone, but no port is 
available to play the prompts to the customer. In some cases, the abandoned call 
rate is limited by government regulations (typically, less than 3% for 
telemarketing calls).

Understanding the Working of an IVR-Based Progressive Campaign

The outbound subsystem does the following in an IVR-based Progressive 
campaign of Unified CCX. 
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Procedure

Step 1 The outbound subsystem checks the licensing information to determine the 
number of available ports for the campaign.

Step 2 Then the outbound dialer will multiply the available ports for the campaign with 
the configured number of lines per port. Based on this output and the number of 
contacts, it will start dialing the contacts. For instance, if 50 ports are available 
for a campaign and if you have configured the lines per port as 2 through Unified 
CCX Application Administration web interface, then it can dial 100 contacts.

Step 3 The SIP gateway performs call progressive analysis of the call and informs the 
outcome of the call to Unified CCX. See SIP Gateway Configuration, page 18-22 
for detailed information on how to configure the SIP gateway parameters through 
Unified CCX Administration web interface. The outcome of a call can be anyone 
of the following:

a. All the dialed contacts, which turns out to be live voice will be connected to 
the CTI port, which plays the IVR script and it will disconnect the remaining 
calls. 

If the dialer detects more contacts with live voice than the available ports, 
then it will drop those calls and those will be considered as abandoned calls. 
If the dialer detects less contacts with live voice, then the dialer will connect 
those calls to the CTI port that plays the IVR script and the remaining CTI 
ports will be freed.

b. If the dialer detects an answering machine, then it performs either of the 
following depending on the option selected in the Answering Machine 
Treatment field in the Campaign Configuration web page:

 – Connects to the CTI port that plays the IVR script or 

 – Abandons the call

c. If the dialer detects a fax or modem, then the dialer abandons the call. 

d. If the dialer detects a call as low volume, then it performs either of the 
following depending on the options selected in the Handle Low Volume as 
Voice field in the Campaign Configuration web page:

 – If you have selected Yes radio button in the Handle Low Volume as 
Voice field, then the dialer considers the call as live voice and connects 
the call to the CTI port that plays the IVR script.
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 – If you have selected No radio button in the Handle Low Volume as Voice 
field, then low volume calls are not handled as voice and they are 
abandoned.

See Adding a New Campaign, page 13-31 for detailed information on how to 
configure these values through the Unified CCX Application Administration web 
interface.

Related Topics:

 • About the Outbound Feature for Unified CCX, page 13-3

 • Direct Preview Dialing Mode, page 13-9

 • Predictive Dialing Mode, page 13-12

Predictive Dialing Mode
The Predictive Dialing mode works similar to the Progressive Dialing mode in 
terms of dialing the Outbound IVR calls. The difference remains in tuning the 
lines per port depending on the abandoned call rate thus eliminating manual 
intervention as in the case of the Progressive Dialer.

In other words, in the Predictive Dialing mode, the Dialer adjusts the number of 
customers to dial per available IVR port for transfer to an IVR campaign. The 
number of lines to dial is calculated by an algorithm and gets updated 
automatically.

A Predictive Dialer is designed to increase IVR port utilization in a contact center. 
To increase the chances of reaching a customer, a Predictive Dialer dials several 
outbound calls to customers per available IVR port. The goal is to dial enough 
lines to keep the IVR ports busy while not exceeding the configured maximum 
abandoned call rate. 

Predictive Dialing Description

The Outbound IVR feature in predictive dialing works by keeping outbound 
dialing at a level where the abandoned rate is below the maximum allowed 
abandon rate. For example, each campaign is configured with a maximum 
allowed abandon rate. In Predictive mode, the Dialer continuously increments the 
number of lines being dialed per port until the abandon rate rises to the 
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preconfigured maximum abandon rate. At this point, the Dialer begins lowering 
the lines per port until the abandon rate goes below the preconfigured maximum. 
In this way, the Dialer stays just below the preconfigured maximum abandon rate. 

Under ideal circumstances, the Dialer internally targets an abandon rate of 85% 
of the preconfigured maximum abandon rate. Due to the random nature of 
outbound dialing, the actual attainable abandon rate at any given point in time 
may vary for your Dialer.

When a campaign starts for the first time, the predictive algorithm starts off with 
the seed value of Lines Per Port configured through the AppAdmin web interface. 
The predictive algorithm starts correcting the Lines Per Port value only when the 
number of calls answered by live voice reaches the value defined by the Predictive 
Correction Pace. 

Consecutive corrections happen after Predictive Correction Pace divided by 4, 
number of live voice calls. The amount of correction given by the predictive 
algorithm is controlled by the Predictive Gain as well. The correction factor is 
multiplied by the Predictive Gain and then it is added to the Lines Per Port of the 
previous iteration. 

Note It is advisable not to change the Correction Pace and Predictive Gain values 
unless there is an urgent need to control the output of the predictive algorithm. 
For example, in cases where a campaign runs for a very short time and the Lines 
Per Port needs to be corrected at a very faster pace then you can reduce the 
Predictive Correction Pace and update the value in the Gain field as 1.0, which is 
the maximum value.

If a campaign runs for multiple days, then when the campaign starts up, the 
predictive algorithm starts off with the Lines Per Port value from the previous day 
instead of the seed value in the AppAdmin web interface, so that better correction 
is achieved within a given time.

Related Topics

 • About the Outbound Feature for Unified CCX, page 13-3

 • Direct Preview Dialing Mode, page 13-9

 • Progressive Dialing Mode, page 13-10
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Steps to Configure an Outbound IVR Subsystem in Unified CCX
Table 13-1 identifies the tasks that you need to perform while configuring an 
Outbound IVR subsystem in Unified CCX.

 
Table 13-1 Tasks to Perform while Configuring an Outbound IVR Subsystem in Unified CCX

Step Task
Name of the Document or Related 
Sections in this Guide

1 Install Unified CCX with Unified CM and perform the 
initial system setup using the Cisco Unified CCX 
Administration web interface.

See the Installation Guide for 
Cisco Unified CCX and Cisco 
Unified IP IVR, Release 8.5(1).

2 Verify whether you have performed the different 
requirements mentioned in Unified CCX Requirements, 
page 13-4.

Note You need to have Unified CCX Outbound IVR 
license on top of Unified CCX premium license to 
use the Outbound IVR feature

 • Unified CCX Requirements, 
page 13-4

 • Uploading Licenses, 
page 1-15

3 Configure the General Outbound properties that are 
common for all the campaigns.

Configuring General Outbound 
Properties, page 13-18

4 To enable communication between Unified CCX and SIP 
gateway, configure the SIP Gateway parameters using the 
SIP Gateway Configuration web page in Unified CCX 
Application Administration web interface.

SIP Gateway Configuration, 
page 18-22

5 Create a Call Control Group for Outbound type with the 
required number of IVR ports to be used for Outbound IVR 
campaigns.

Adding a New Unified CM 
Telephony Call Control Group, 
page 7-9

6 Create an application, which will be used for the Outbound 
IVR campaign.

 • Configuring Unified CCX 
Applications, page 1-17

 • About Unified CCX 
Applications, page 6-1

7 Create a trigger and assign the newly created Outbound Call 
Control group to this trigger.

Adding a Unified CM Telephony 
Trigger, page 7-16 
13-14
Cisco Unified CCX Administration Guide, Release 8.5(1)

http://www.cisco.com/en/US/products/sw/custcosw/ps1846/prod_installation_guides_list.html
http://www.cisco.com/en/US/products/sw/custcosw/ps1846/prod_installation_guides_list.html
http://www.cisco.com/en/US/products/sw/custcosw/ps1846/prod_installation_guides_list.html


Chapter 13      Configuring Unified CCX Outbound Dialer
How Is a Contact’s Local Time Determined?
How Is a Contact’s Local Time Determined?
The Outbound subsystem use the area code of a contact’s phone number to 
determine the time zone of the contact’s calling area. The system provides the 
mapping for North American area codes to their corresponding time zones. The 
Area Codes web page allows you to add, modify, and delete any area code to time 
zone mapping (see Adding Area Codes, page 13-42).

Some area codes extend across multiple time zones. For such area codes, you can 
edit the default time zone for that area code and specify a different one, if 
required.

Changes to area codes take affect the next time you import contacts (see 
Importing Contacts for a Campaign, page 13-39). For example, if the time zone 
of area code 603 is changed from 16 to 17, contacts already present in the system 
that have an area code of 603 continue to have the GMT Offset of 16. Any 
contacts with area code 603 that are imported after the area code change have 17 
for the GMT Offset.

When Outbound contacts are imported into the database, all contacts are assigned 
a GMT time zone for the three phone numbers provided. The Outbound subsystem 
determines this GMT time zone by extracting the area code of each phone number 
and checking it against the Area Codes table to obtain the corresponding time 
zone. If the area code cannot be matched, the Outbound subsystem uses the local 
time zone and Daylight Savings Time (DST) setting of the server. The Outbound 
subsystem also considers the DST to determine if an Outbound contact can be 
called at a given time. 

8 Create a new IVR campaign and configure the progressive 
dialer parameters for this campaign. 

Adding a New Campaign, 
page 13-31

9 Import contact for the campaign. Importing Contacts for a 
Campaign, page 13-39

Table 13-1 Tasks to Perform while Configuring an Outbound IVR Subsystem in Unified CCX

Step Task
Name of the Document or Related 
Sections in this Guide
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The Outbound subsystem ensures that the contacts are dialed at valid times. For 
Outbound contacts which have been scheduled for callback, the scheduled 
callback time is converted to GMT time zone and stored in the callbackDateTime 
field in the database. 

For pending records, the Outbound subsystem ensures that Outbound contacts are 
called only within the Customer Dialing Time Range (hh:mm) detected by the 
MinCustomerDialTime and MaxCustomerDialTime, as per federal regulations. 
You can configure this time in the Unified CCX Administration GUI (see 
Configuring General Outbound Properties, page 13-18).

Related Topics

 • About the Outbound Feature for Unified CCX, page 13-3

 • The Outbound Configuration Checklist, page 13-16

 • Adding Area Codes, page 13-42

The Outbound Configuration Checklist
To configure the Outbound subsystem, complete the following tasks:

Step Task For instructions, see

Step 1 Configure RmCM.

Create CSQs.

Assign resources to CSQ.

 • Configuring RmCm Provider, page 8-2

 • Creating a CSQ, page 8-18.

 • Resource Skill Selection Criteria Within a 
CSQ, page 8-28

Step 2 Verify that the RmCm and Outbound 
subsystems are IN SERVICE.

Verifying the RmCm and Outbound 
Subsystems, page 13-17

Configure the general properties of the 
Outbound subsystem.

Configuring General Outbound Properties, 
page 13-18

a Configure customer dialing time 
range as determined by the 
regulations of the required region

How Is a Contact’s Local Time Determined?, 
page 13-15

b Configure the dialing prefixes for 
your geographic area.

How the Outbound Option Works with Area 
Codes, page 13-28
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Related Topics

 • About the Outbound Feature for Unified CCX, page 13-3

Verifying the RmCm and Outbound Subsystems 
The Outbound subsystem’s initial state is OUT OF SERVICE. Next, it goes to 
INITIALIZING state, at which point it checks the conditions listed below. If all 
the conditions are met, the state changes to IN SERVICE.

For the Outbound subsystem to be IN SERVICE, the following conditions apply:

Step 3 c Assign the CSQs and % of Logged in 
Agents for Outbound.

Allocating CSQ Agent Pool Percentages, 
page 13-30

Handling Configuration Updates, page 13-29

To configure CSQs, see Configuring Contact 
Service Queues, page 8-17

Step 4 Create campaigns. Adding a New Campaign, page 13-31

Step 5 Import contacts for each campaign. Importing Contacts for a Campaign, 
page 13-39

Step 6 Enable campaigns. Enabling Campaigns, page 13-41

Step 7 If the dialing list contains contacts outside 
of North America or if Unified CCX is 
installed outside of North America, 
manually add the area codes and their 
corresponding time zones of the regions

Adding Area Codes, page 13-42

Step 8 Enable direct preview in CDA. See the Cisco Desktop Administrator User's 
Guide.

Step 9 Setup communication with the agent’s 
desktop.

Setting-up Communications with the Agent’s 
Desktop, page 13-43

Step 10 Agents log in and get ready to receive 
Outbound calls (agents must belong to 
CSQs assigned to Outbound).

Agents Receive Outbound Calls, page 13-44

Step Task For instructions, see
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 • The RmCm subsystem on the same box must also be in service. The RmCm 
subsystem is considered to be active when you have provisioned the RmCm 
Provider and associated agent extensions with the RmCm Provider (see 
Configuring RmCm Provider, page 8-2).

 • The Unified CCX Database service (on the publisher node) should be up and 
running. For example, if you have a dual node (Node A and B) setup with 
Node A as the publisher node, you need to have the Unified CCX Database 
service up and running on Node A for the Outbound subsystem to be IN 
SERVICE. 

Note The publisher node will always be the first node installed in the cluster.

On the standby service, if all four nodes are up and running and RmCM is in 
service, then the Outbound subsystem is IN SERVICE. 

Tip During a fail over, it might take a couple of minutes before the Outbound 
subsystem displays the correct state (IN SERVICE) as the verification cycle needs 
to complete.

Related Topics

 • About the Outbound Feature for Unified CCX, page 13-3

 • The Outbound Configuration Checklist, page 13-16

Configuring General Outbound Properties 
General Outbound properties refer to the settings information that is common for 
all the campaigns.

Caution Area code and long distance prefix configuration changes made to the Outbound 
subsystem do not take effect for calls/contacts currently in the Outbound 
subsystem’s memory. For example, if you change the long distance prefix or local 
area code, the contacts already in the Outbound subsystem’s memory will 
continue to use the old long distance prefix and local area code.
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To configure general Outbound properties, complete the following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > 
Outbound > General.

The General Configuration web page opens to display the General pane (default 
view). 

Step 2 Use this web page to specify the following fields in the General Configuration 
section. 

Field Description

Customer Dialing Time 
Range (hh:mm)

The time range during which a customer can be called. This time range 
supersedes the time range of individual campaigns and ensures that a 
customer is never called outside the legally allowed time range for that 
country. This is a mandatory field. 

For example, in the USA, the Federal Communications Commission (FCC) 
specifies the legal time range as 8 AM – 9 PM. This does not apply to 
callbacks since the customer explicitly requested to be called at a certain 
time. This time range is always converted to the local time for each contact 
record. 

Default = 8:00 AM - 9:00 PM (USA FCC regulations)

Preview Call Timeout If an agent does not respond to the Outbound preview call on the Cisco 
Agent Desktop (CAD) within the timeout duration specified in this field, 
the system sets the agent to the Not Ready state, similar to the behavior for 
Ring No Answer (RNA) for inbound calls. This is a mandatory field.

Default= 60 seconds, Range = 5 to 3600 seconds. 

Dialing Prefix The number to pre-pend to the phone number for dialing outgoing calls 
(also referred to as switch prefix). This number can have any numeric 
value, including 0 or leading zeros.

Long Distance Prefix The number to pre-pend to the phone number for dialing long distance. 
This number can have any numeric value, including 0 or leading zeros.

International Prefix The number to pre-pend to international phone numbers. This number can 
have any numeric value, including 0 or leading zeros.
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Step 3 Click Update icon that displays in the tool bar in the upper, left corner of the 
window or the Update button that displays at the bottom of the window.

Local Area Code The area code of the Unified CCX server location. This number can have 
any numeric value, including 0 or leading zeros.

Do Not Remove Local 
Area Code When Dialing

If this box is checked, the local area code is included when dialing the 
phone numbers within this area code. If it is unchecked, then the local area 
code is stripped from the phone number before dialing the local numbers. 
It is expected that when contacts are imported into the system, the phone 
numbers include the area code. For international phone numbers, the 
country code must be included when importing contacts.

Include Long Distance 
Prefix

This field will be displayed only if you select the Do Not Remove Local 
Area Code When Dialing check box. For local numbers, the long distance 
prefix will be prepended only if this checkbox is checked. 

The long distance prefix will be prepended to the phone number for all 
non-local numbers (the numbers that do not start with local area code) 
irrespective of the status (checked/unchecked) of this checkbox.

Assigned CSQs Assigned CSQs refer to CSQs used by the Outbound subsystem. To 
allocate CSQs for Outbound, select a CSQ from the Assigned CSQ list, and 
then select a value from the % of Logged in Agents for Outbound 
drop-down to indicate what percentage of the CSQ is allocated for 
Outbound and then click “<” icon. At this point, the selected CSQ is 
removed from the Available CSQs box and shows up in the Assigned CSQs 
box with the percentage allocation in parentheses next to the CSQ name. 
This is a mandatory field.

Available CSQs The Available CSQs pane displays all CSQs configured in the CSQ 
Configuration page under the RmCm subsystem configuration.

% of Logged in Agents 
for Outbound 

The % of Logged in Agents for Outbound field indicates the percentage of 
logged in agents in each of the selected CSQs that are allocated for 
handling Outbound calls. 

Note The CSQ allocation percentage is defined at the global level and 
not at a campaign level. For example, if a CSQ has 100 agents and 
20% are allocated for Outbound, a pool of 20 agents are shared 
among the Outbound campaigns. In the Add New Campaign web 
page, you can specify the CSQs to assign to a campaign.

Field Description
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The System Options components are now updated.

Related Topics

 • About the Outbound Feature for Unified CCX, page 13-3

 • The Outbound Configuration Checklist, page 13-16

 • Customer Dialing Lists, page 13-21

 • Handling Callbacks, page 13-27

 • How the Outbound Option Works with Area Codes, page 13-28

 • Handling Configuration Updates, page 13-29

 • Allocating CSQ Agent Pool Percentages, page 13-30

Customer Dialing Lists
Contact centers purchase or maintain customer dialing lists in files, which can be 
imported using the Unified CCX Administration GUI. When the file is imported, 
the Outbound subsystem generates a dialing list that is then used to dial 
customers.

A dialing list can be in comma-delimited format, with a maximum of 10240 
characters per row.

The following table lists all columns in the dialing list table.

Field Name Data Type Required Description

recordID int Yes A unique identifier for the record.

dialingListID int Yes Unique identifier for a contact.

profileID int Yes Identifier for the Unified CCX profile that is 
associated with this record.

campaignID int Yes A unique identifier for the campaign.

createDateTime datetime Yes The time when the record is created or updated
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accountNumber nvarchar(25) NO Account number of contact. From imported file. This 
field is sent to the agent desktop.

This parameter has a maximum length of 25 
characters.

firstName nvarchar(50) NO First Name of contact. From imported file.

This parameter has a maximum length of 50 
characters.

lastName nvarchar(50) NO Last Name of contact. From imported file.

This parameter has a maximum length of 50 
characters.

phone01 varchar(28) Yes Primary Phone Number of contact. From imported 
file.

This parameter has a maximum length of 28 
characters and must be a valid phone number.

phone02 varchar(28) NO Additional Number of contact. From imported file. 
This number is dialed when agent selects Skip--Next 
for the preview call.

This parameter has a maximum length of 28 
characters and must be a valid phone number.

phone03 varchar(28) NO Additional Number of contact. From imported file. 
This number is dialed if the attempts to dial first two 
numbers were unsuccessful.

This parameter has a maximum length of 28 
characters and must be a valid phone number.

gmtZonePhone01 smallint Yes The time zone for this phone number of this contact. 
GMT time zones are on a 0-23 scale which begins 
with 0 at Greenwich, England and increases to the 
East. For the United States, New York is GMT 19, 
San Francisco is at GMT 16.

dstPhone01 bit Yes 1 - DST is observed at this phone.

0 - DST is not observed at this phone.

Field Name Data Type Required Description
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gmtZonePhone02 smallint Yes The time zone for this phone number of the contact. 
GMT time zones are on a 0-23 scale which begins 
with 0 at Greenwich, England and increases to the 
East. For the United States, New York is GMT 19, 
San Francisco is at GMT 16.

dstPhone02 bit Yes 1 - DST is observed at this phone.

0 - DST is not observed at this phone.

gmtZonePhone03 smallint Yes The time zone for this phone number of the contact. 
GMT time zones are on a 0-23 scale which begins 
with 0 at Greenwich, England and increases to the 
East. For the United States, New York is GMT 19, 
San Francisco is at GMT 16.

dstPhone03 bit Yes 1 - DST is observed at this phone.

0 - DST is not observed at this phone.

callbackNumber varchar(28) NO Phone number to be used for callback - can be 
supplied by the agent.

callbackDateTime datetime NO This column is used, after a call attempt has been 
made, to store the time in which this contact is called 
back. For customer requested callbacks, this time is 
the requested callback time. For retries due to no 
answers or busy attempts, this is the time when the 
system retries this contact. Stored in UTC time.

Field Name Data Type Required Description
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callStatus smallint Yes The status of the contact record.

1 = Pending: The call is pending.

2 = Active: The record is sent (active) to the 
Outbound subsystem for dialing

3 = Closed: The record is closed.

4 = Callback: The record is marked for a callback.

5 = Max Calls: Maximum attempts have been 
reached for this record (considered closed).

6 = Retry: The call is redialed immediately whenever 
there is any miss.

7 = Unknown: If the Outbound subsystem was 
restarted with records in the Active (2) state, they are 
moved to this state.

8 = Retries with delay: The call is redialed as it was 
either busy, no answer, customer abandoned or 
system abandoned. Retry time is set as per the 
corresponding configuration in the Unified CCX 
Application Administration web interface.

Note When contacts are imported, they will have a default value of 1 in the call status column and 
0 in the call result column in the Dialing List table. The call status of 3 and a call result 0 
denotes that the contact was closed without being dialed. This happens if the phone01 column 
is empty for the contact.

Tip If you import contacts with the same phone01 field as an existing contact, then the existing 
contact is overwritten by the imported contact in the following fields: accountNumber, 
firstName, lastName, phone02, phone03. However, other fields like call result, call status are 
not overwritten. Besides, a new contact will NOT be added to the Dialing List table

Field Name Data Type Required Description
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callResult smallint NO The call result from the last call placed for this record 
1 = (Voice) Customer answered and was connected 
to agent

2 = Fax machine or modem detected

3 = Answering machine detected

4 = Number reported as invalid by the network

5 = Customer did not want to be called again

6 = Number successfully contacted but wrong 
number

7 = Number successfully contacted but reached the 
wrong person

8 = Customer requested callback

9 = Agent has skipped or rejected the preview call

10 = Agent has skipped or rejected the preview call 
with the close option (not dialed)

11 = Busy tone detected

12 = Agent did not respond to the preview call within 
the timeout duration

13 = Callback Failed - this value is not written to the 
database; this is for internal use only

14 = Callback missed and marked for Retry

15 = Customer’s phone timed out either due to Ring 
No Answer (RNA) or Gateway failure.

16 = Call was abandoned because IVR port was 
unavailable or Unified CCX failed to transfer the call 
to the IVR port.

17 = Call failed due any one of the reasons mentioned 
in Call Result Values, page 13-52.

18 = Customer abandoned as customer disconnected 
the call within the time limit as configured in 
“Abandoned Call Wait Time” in Unified CCX 
Application Administration web interface.

Field Name Data Type Required Description
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Related Topics

 • About the Outbound Feature for Unified CCX, page 13-3

callResult01 smallint NO The call result from the last time phone01 was called. 

Values same as callResult

callResult02 smallint NO The call result from the last time phone02 was called. 

Values same as callResult

callResult03 smallint NO The call result from the last time phone03 was called. 

Values same as callResult

lastNumberDialed smallint NO The last number dialed.

1 = phone01

2 = phone02

3 = phone03

callsMadeToPhone0
1

smallint NO The number of call attempts made to phone01. If 
there was an error in attempting to call this number, 
the attempt is not counted here.

callsMadeToPhone0
2

smallint NO The number of call attempts made to phone02. If 
there was an error in attempting to call this number, 
the attempt is not counted here.

callsMadeToPhone0
3

smallint NO The number of call attempts made to phone03. If 
there was an error in attempting to call this number, 
the attempt is not counted here.

privateData image(16) NO Any field which is used internally only can be stored 
in this column in a blob

active bit YES Whether the record is active in the system. 

A record becomes inactive if the campaign is deleted 
from the system.

0 = Inactive

1 = Active

dateInactive datetime NO Date this record was deleted.

Field Name Data Type Required Description
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 • The Outbound Configuration Checklist, page 13-16

 • Handling Callbacks, page 13-27

 • How the Outbound Option Works with Area Codes, page 13-28

 • Handling Configuration Updates, page 13-29

 • Allocating CSQ Agent Pool Percentages, page 13-30

Handling Callbacks
A customer can request a callback at a specific callback phone number and also 
specify the time/date of the callback. The Outbound subsystem stores this 
information (the callback phone number, date, time) in the dialing list table. 

The Outbound subsystem handles the callback as follows:

 • Convert to GMT: The callback date and time specified with respect to the 
customer's time zone is converted to GMT time zone and then stored in the 
database.

 • Agent not Available: When the Outbound subsystem looks up the database 
for contacts, it first checks the callbacks. The default callback time limit is 15 
minutes (can be changed) before and after the customer-specified time. If an 
agent is available, then the Outbound subsystem places the callback. If an 
agent is not available, the Outbound subsystem retries agent availability 
(agent state) after 10 minutes. 

 • Missed Callbacks: If a callback is missed, you have three action options: 

 – Reschedule it to the same time on the next business day

 – Mark it as another retry (the callback phone number is removed and the 
callback date time is ignored). In this case, it moves out of the call back 
state and into the retry state.

 – Close the record (never dialed again). 

The selected status is changed at midnight for calls not retrieved (see 
Resetting Contact States at Midnight, page 13-51).

 • Agent reclassifications: If calls were retrieved and presented to the agent and 
if the agent reclassified it (for example, changed it to answering machine 
status), then the call status is updated to answering machine (see 
Reclassification Status Behavior, page 13-54).
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 • Invalid number: If the number is invalid, the callback continues to be retried 
until the callback time limit expires or the agent reaches the customer.

Caution If a callback is presented and the callback number is invalid (or busy), 
the callback continues to be retried irrespective of the number of retries 
set (for normal busy/invalid). It will be retried until the callback time 
limit expires.

Related Topics

 • About the Outbound Feature for Unified CCX, page 13-3

 • The Outbound Configuration Checklist, page 13-16

 • Customer Dialing Lists, page 13-21

 • How the Outbound Option Works with Area Codes, page 13-28

 • Handling Configuration Updates, page 13-29

 • Allocating CSQ Agent Pool Percentages, page 13-30

How the Outbound Option Works with Area Codes
In the Outbound option, the area code determines the geographical location of the 
phone number you dial, which correspondingly provides the Greenwich Meridian 
Time (GMT) zone. The db_cra database contains a mapping of the area codes to 
the time zones. 

The U.S. area code mappings are provided along with the product. International 
customers should provide their own data and add it to the database (see Adding 
Area Codes, page 13-42).

Related Topics

 • About the Outbound Feature for Unified CCX, page 13-3

 • The Outbound Configuration Checklist, page 13-16

 • Customer Dialing Lists, page 13-21

 • Handling Callbacks, page 13-27

 • Handling Configuration Updates, page 13-29

 • Allocating CSQ Agent Pool Percentages, page 13-30
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Handling Configuration Updates
Whenever Outbound parameters are modified in the Unified CCX Administration 
GUI, the changes take effect immediately. If a new CSQ is added using the 
Subsystems -> RmCm -> Contact Service Queues menu option, it is instantly 
displayed in the list of available CSQs in the General configuration page in the 
Unified CCX Administration GUI as this list is dynamically updated. If a CSQ is 
modified and if this impacts the allocation of agents, the Outbound subsystem is 
aware of this change as it refreshes the list of agents in each relevant CSQ 
periodically. 

 • If a configuration change affects the Outbound contacts dialing process (for 
example, if a campaign is disabled or a CSQ is removed from a campaign), 
the Outbound subsystem stops processing the Outbound contacts, recalls 
these contacts to the database, and resets the call status to Pending.

 • If a campaign start time is changed, the Outbound subsystem checks if the 
campaign is enabled. If it is enabled, and if the new start time is after the 
current time, it performs the following actions:

 – Sends a recall contact message to the Outbound subsystem passing the 
campaign ID. 

 – For all Outbound contacts for this campaign in the Outbound 
subsystem’s memory, it resets all Outbound contacts to the pending state 
and clears them from memory. 

If the campaign is disabled or if the new start time is before the current time, 
the Outbound subsystem ignores this change. 

 • If campaign end time is changed, the Outbound subsystem checks if the 
campaign is enabled. If it is enabled, and if the new end time is before the 
current time, it performs the following actions:

 – Sends a recall contact message to the Outbound subsystem passing the 
campaign ID. 

 – For all the Outbound contacts for this campaign in Outbound 
subsystem’s memory, it resets all the Outbound contacts to the Pending 
state and clears them from memory. 

If the campaign is disabled or if the new end time is after the current time, the 
Outbound subsystem ignores this change. 
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 • If a CSQ is deleted from a campaign or if the CSQ itself is deleted, the 
Outbound subsystem sends a recall contacts message with the csq ID of the 
deleted CSQ. It also reallocates any Outbound contacts in its memory that are 
currently allocated to this CSQ among the other existing CSQs for this 
campaign.

Related Topics

 • About the Outbound Feature for Unified CCX, page 13-3

 • The Outbound Configuration Checklist, page 13-16

 • Customer Dialing Lists, page 13-21

 • Handling Callbacks, page 13-27

 • How the Outbound Option Works with Area Codes, page 13-28

 • Allocating CSQ Agent Pool Percentages, page 13-30

Allocating CSQ Agent Pool Percentages
You need to specify a percentage of total agents in the assigned CSQs to be 
allocated for Outbound calls. This pool of agents is shared by all Outbound 
campaigns. 

Tip The CSQs for Outbound are the same as those CSQs for inbound. If you need 
more CSQs, you must first configure them in Unified CCX and assign the 
required CSQs for agents as required by your configuration before allocating 
them as specified in this procedure.

Related Topics

 • About the Outbound Feature for Unified CCX, page 13-3

 • How Is a Contact’s Local Time Determined?, page 13-15

 • The Outbound Configuration Checklist, page 13-16

 • Configuring General Outbound Properties, page 13-18

 • Customer Dialing Lists, page 13-21

 • Handling Callbacks, page 13-27
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 • How the Outbound Option Works with Area Codes, page 13-28

 • Handling Configuration Updates, page 13-29

 • Adding a New Campaign, page 13-31

Adding a New Campaign
Use the Campaign component to configure properties for the campaign, including 
the campaign name and description, CSQ selection, and the time range when a 
campaign can call contacts.

Complete the following steps to define or modify the settings that apply to a 
campaign:

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > 
Outbound > Campaigns.

The Campaign web page opens displaying the details of existing campaigns, if 
any. Click an existing campaign to view or update the configuration settings for 
the campaign.

Step 2 Click Add New icon in the tool bar in the upper, left corner of the window or the 
Add New button at the bottom of the window.

On click of Add New, Add a New Campaign web page opens up where you can 
specify the campaign type and the dialer type for the campaign using the 
following fields. 

Note You need to upload an Outbound IVR license on top of the Premium license for 
Unified CCX to create a campaign for Outbound IVR.
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Note You cannot change the Campaign Type and Dialer Type for an existing campaign.

Once you select the campaign type and dialer type, click Next to continue. The 
Campaign Configuration web page opens displaying the following three column 
headings:

 • Parameter Name

 • Parameter Value 

 • Suggested Value 

You can specify values for a new campaign or modify values for an campaign 
using the fields mentioned below Parameter Value column. See the table below 
for a list of fields along with their description. 

Field Description

Select the type of the campaign 

Campaign Type Type of the campaign to be used for outbound calls. You can specify any 
one of the following two campaign types:

 • Agent based - If you select this, all the outbound calls in a campaign 
will be handled by the available agents. 

 • IVR based - If you select the IVR based option, the outbound calls in 
a campaign will be handled by the IVR scripts.

Select the type of dialer for the campaign

Dialer Type The dialer type options available for a campaign will vary depending on the 
selected Campaign Type. If you select Agent Based campaign type, Direct 
Preview dialer type option is displayed. If you select IVR based campaign 
type, then you can select any one of the following dialer types:

 • Progressive (default)

 • Predictive

See the Importing Contacts for a Campaign, page 13-39 for detailed 
information on different dialing modes for outbound calls. 
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The Suggested Value displays the default configuration value for each campaign. 
You can refer to these values if you want to revert any changes made to one or 
more parameters mentioned in the Campaign Configuration web page. 

Field Description

Campaign Name Name of the campaign (must be a unique identifier). This is a mandatory 
field.

Enabled Indicates to the Outbound subsystem whether this campaign is currently 
active. 

Default = No.

Description Description of the campaign.

Start Time/End Time 
(hh:mm) AM PM Time 
Zone

Indicate the time range during which the campaign runs. These are 
mandatory fields. The name of the primary time zone is also displayed 
adjacent to these two field values.

Default = 8:00 AM - 9:00 PM Pacific Standard Time (USA FCC 
regulations).

Campaign Calling Number The campaign calling number is the number that will be displayed to the 
contact. This number is used by the dialer. This is a mandatory field.

Application Trigger This is the JTAPI trigger associated with this campaign. There will 
one-to-one mapping between a campaign and an application trigger. 
Hence, only those triggers that are not associated with any other 
campaigns are displayed in the trigger list.

Application Name The name of the application associated with the above-mentioned JTAPI 
trigger. This field is auto-populated.

Maximum Attempts to Dial 
Contact 

The maximum number of times the Outbound subsystem attempts to dial 
a contact beyond which the call status will be marked as closed. You can 
choose this value from the drop-down list box.

Default = 3, Range = 1 to 3.

Callback Time Limit The duration before and after the scheduled callback time during which 
the Outbound subsystem attempts to place a callback. For example, if a 
callback was scheduled for 9:30 am and if the Callback Time Limit is set 
to 15 minutes, then the Outbound subsystem calls the customer anytime 
between 9:15 am to 9:45 am. 

Default = 15 minutes, Range = 1 to 60 minutes
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Dialing Options (displayed only if you have selected IVR-based campaign type)

Number of Dedicated Ports Number of dedicated IVR ports that you want to reserve for this 
campaign based on the number of CTI ports available in the outbound 
call control group for the campaign duration. That is, the total number of 
dedicated IVR ports for the selected campaign cannot exceed the 
maximum licensed ports for Outbound IVR minus the sum total of IVR 
ports dedicated to other campaigns running at the same time.

You can enter or update this value for a campaign only after associating 
a trigger with the campaign. Default value = 0, Range = 0 to number of 
available ports for the campaign duration.

For example, if you have an MCS 7845 hardware, which supports 
maximum of 300 IVR ports with 50 licensed ports for Outbound IVR and 
you have already dedicated:

 • 20 ports for Campaign1, which runs between 10-12 pm and

 • 10 ports for Campaign2, which runs between 2-4 pm, then the 
number of dedicated IVR ports that you can enter in this field for a 
new campaign cannot exceed: 

 – 30 ports if the new campaign runs between 10-12 pm and

 – 40 ports if the new campaign runs between 2-4 pm and 

 – 50 ports if the new campaign runs during any time other than 
10-12 pm and 2-4 pm

If the number of configured ports for a campaign is greater than the 
available number of licensed ports at the specified campaign time, then 
an alert message stating the same will be shown while saving the 
campaign. 

See Unified CCX Requirements, page 13-4 to know how the licensed 
IVR ports are distributed between the inbound and outbound IVR calls 
in different scenarios.

Field Description
13-34
Cisco Unified CCX Administration Guide, Release 8.5(1)



Chapter 13      Configuring Unified CCX Outbound Dialer
Adding a New Campaign
Lines Per Port (1-3) Number of lines to be dialed for each port. The dialer will try to connect 
as many live voices to the available port(s) where IVR script is playing 
and it will disconnect the remaining calls. The probability of abandoned 
calls increases geometrically as the lines per port increases.

In an IVR-based Progressive campaign, you can configure the number of 
lines to dial per port at a time. The dialer will determine the number of 
calls to dial based on the following calculation - Lines per port * 
Available number of ports. 

In an IVR-based Predictive campaign, this is the seed value that is passed 
to the predictive algorithm. Initially the dialer starts dialing with this 
value. 

Note If you change this value in the middle, the predictive algorithm 
will take the updated value in this field during the next iteration.

This is a mandatory field. 

Default value = 1.5; Range = 1 to 3.

Handle Low Volume as 
Voice

Determines whether a low volume call should be treated as voice or 
disconnected. Select Yes or No radio button accordingly.

Default is Yes, which means low volume calls are handled as voice and 
they are connected to the IVR port.

Answering Machine 
Treatment

This field enables you to specify how to handle an outbound call if it 
detects an answering machine. If the call detects an answering machine, 
you can choose to abandon the call or transfer it to IVR by selecting the 
desired radio button in this field.

Transfer to IVR radio button is enabled by default.

(The following four fields in Dialing Options are displayed only if you have selected Predictive 
dialer type for an IVR-based campaign)

Maximum Lines Per Port 
(1-3)

Maximum number of lines to be dialed for each port. You can configure 
the maximum number of lines that can be dialed per port and the 
predictive algorithm ensures that it does not exceed this number. 

This is a mandatory field. Default value = 3.0, Range = 1 to 3.

Field Description
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Predictive Correction Pace 
(10-1000)

The number of calls that were answered by live voice that the predictive 
algorithm should consider for each iteration. This is directly proportional 
with the correction frequency made in the Lines Per Port parameter. This 
is a mandatory field. Default value = 100, Range = 10 to 1000.

Note It is advisable not to change this value.

Predictive Gain The Gain parameter controls the size of the lines per port corrections. 
This is directly proportional to the size of the lines per port correction.

This is a mandatory field. Default value = 1.0, Range = Greater than 0 to 
1.0.

Note It is advisable not to change this value.

Call Abandon Limit 
(0-100)

Call abandon percentage, which should be within the limit specified by 
Federal Trade Commission (FTC). This is a mandatory field. 

Default value - 3%, Range 0-100%. This means that no more than three 
percent of calls that are answered by a person are abandoned, measured 
per day per calling campaign. 

Dial Settings (displayed only if you have selected IVR-based campaign type)

No Answer Ring Limit The duration for which the Progressive/Predictive dialer should allow the 
phone to ring before disconnecting an unanswered call. 

Default is 15 seconds, which means that the dialer should wait for a 
minimum of 15 seconds before disconnecting a call. Range = 1-60 
seconds.

Abandoned Call Wait Time If the customer disconnects the call within the time set here, then the call 
is classified as customer abandoned. This is a mandatory field.

Default value = 2 seconds, Range = 1 to 10 seconds.

Retries (displayed only if you have selected IVR-based campaign type): Set the value for the 
following four fields as “0” if you want to disable retry option for an existing IVR campaign.

No Answer Delay Duration (in minutes) for which the dialer waits before calling back a 
no-answer call. 

Default value = 60 minutes.

Busy Signal Delay Duration (in minutes) for which the dialer waits before calling back a 
busy telephone number. 

Default value = 60 minutes.

Field Description
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Customer Abandoned 
Delay

If a customer abandons a call, the duration (in minutes) after which the 
dialer should call the customer back. 

Default value = 30 minutes.

Dialer Abandoned Delay If the dialer abandons a call, the duration (in minutes) after which the 
dialer should call back the customer. 

Default value = 60 minutes.

Displayed only if you have selected Agent Based campaign type

Contact Records Cache 
Size

The number of contact records the Outbound subsystem retrieves from 
the database in bulk for dialing. The allowed values are 1-100. This is a 
mandatory field. For example, if 50 records are retrieved in bulk for 
campaign1 and 10 for campaign2 and they are running at the same time, 
the Outbound subsystem attempts to place 50 Outbound calls for 
campaign1 and 10 Outbound calls for campaign2. The number of 
Outbound calls actually placed for each campaign depends upon the 
number of agents available for the respective campaigns.

Once all the records retrieved for a campaign have been dialed, the 
Outbound subsystem fetches another batch of records for that campaign. 
Over a period of time, it is likely that more contacts would have been 
called from campaign1 than from campaign2.

If two campaigns run simultaneously and share CSQs or agents, the 
records in both campaigns may not be processed at the same rate—even 
if their contact cache sizes are identical. It is possible that more records 
from one of these two campaigns is processed before the other.

Default = 20, Range = 1 to 100

Answering Machine Retry If you select Yes, then the Outbound subsystem tries to call the phone 
number again at a later time if an answering machine was reached the 
first time. 

Default = No

Callback Missed Determines the action that should be taken on the contacts that were not 
called back. The three options for this field are: 

 • Reschedule for same time next business day (default)

 • Mark it for a retry

 • Close the record.

Field Description
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Step 3 Click Add or Save to save the configuration changes. While saving a new or 
updated IVR campaign, the Outbound IVR subsystem validates the Session 
values in the application and trigger pages based on following criteria and it might 
display an alert message to increase Session value in application and trigger 
pages: 

 • In case of Progressive campaign, the Outbound subsytem checks whether the 
Lines Per Port * Dedicated Port is greater than minimum of the Session value 
in application and trigger. 

 • In case of Predictive campaign, the Outbound subsytem checks whether the 
maximum Lines Per Port * Dedicated Port is greater than minimum of the 
Session value in application and trigger. 

You should increase the Session values in the application and trigger to the 
suggested value in the alert message to reduce the number of abandoned calls in 
an IVR campaign.

Once you create a campaign, you need to import contacts for the campaign. See 
Importing Contacts for a Campaign, page 13-39 section for detailed information 
on how to import contacts for different types of campaigns. 

Related Topics

 • About the Outbound Feature for Unified CCX, page 13-3

 • How Is a Contact’s Local Time Determined?, page 13-15

 • The Outbound Configuration Checklist, page 13-16

 • Configuring General Outbound Properties, page 13-18

Assigned CSQs CSQs from which agents are selected for Outbound calls for this 
campaign. This is a mandatory field. 

Available CSQs CSQs that have been allocated for Outbound and are not yet assigned to 
this campaign.

Field Description
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Importing Contacts for a Campaign

Note • You can only import a total of 10,000 contacts for a campaign at any given 
time. When some or all of these contacts are processed, you can import 
additional contacts to add up to a total of 10,000 at any given time.

 • While importing the contacts file for a campaign, use only comma-separated 
plain text file with .txt extension. The contacts file should be ASCII-encoded 
or UTF-8 encoded if it contains special characters (for example, if the contact 
names are in Chinese, Russian, Japanese and so on).

When contacts are imported, the contacts text file is checked for duplicate entries. 
If the phone01 value of a contact matches the phone01, phone02, or phone03 
values of another contact in the contacts list being imported, then the previous 
contact is overwritten with the new contact. 

Caution You must verify all the contacts against the national do_not_call list before 
importing them.

Note In this guide, the underscore character linking each word differentiates the 
national do_not_call list from the Outbound subsystem’s Do Not Call list.

Tip Each time contacts are imported, they are appended to the existing list of contacts 
for the selected campaign. If the new list contains a contact with the same 
phone01 value as the phone01, phone02, or phone03 value or the same phone02 
value as the phone01, phone02, or phone03 value or the same phone03 value as 
the phone01, phone02, or phone03 value, of an existing contact, the existing 
contact is overwritten with the new contact information. The call history for the 
contact (if any) is retained.
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To import contacts for a selected campaign, complete the following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > 
Outbound > Campaigns.

The Campaigns web page opens displaying the details of existing campaigns.

Step 2 Click the hyperlink below the Name column for the campaign for which you want 
to import the contacts.

The Campaign Configuration web page opens for the selected campaign.

Step 3 Click Import Contacts. The Import Contacts web page opens. 

Step 4 Specify a file name to import the contacts from the fields being imported.

A contact list can contain up to 6 fields: AccountNumber, FirstName, LastName, 
Phone1, Phone2, and Phone 3.

Step 5 Navigate to the directory that contains the imported fields in the same order as 
they appear in the text file.

While uploading outbound contacts in a HA over WAN deployment of Unified 
CCX, if all the contacts that are being uploaded exist in the database and are being 
modified, then follow the guidelines mentioned below to avoid long delays:

 • Upload the contacts during non-peak hours 

 • Upload in batches of 500 contacts or less

Related Topics

 • About the Outbound Feature for Unified CCX, page 13-3

 • How Is a Contact’s Local Time Determined?, page 13-15

 • The Outbound Configuration Checklist, page 13-16

 • Configuring General Outbound Properties, page 13-18

 • Adding a New Campaign, page 13-31

 • Enabling Campaigns, page 13-41
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Enabling Campaigns
You must verify that the configured campaigns are active and that the start and 
end times for the enabled campaigns are specified as required.

To verify the state of the required campaign, complete the following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > 
Outbound > Campaigns.

The Campaigns web page opens displaying following information for the existing 
campaigns:

Step 2 Verify that the Enabled field is set to TRUE and that the start and end times are 
specified as required.

Field Description

Name Name of the campaign. 

Start Time/End Time 
(hh:mm) AM PM 

Start Time and End Time fields indicate the time range during which the 
campaign runs.

Remaining Contacts The Remaining Contacts field indicates the number of contacts that are yet 
to be dialed for each campaign. In addition to the contacts that have not 
been dialed, this number also includes contacts that have requested a 
callback and contacts that will be tried again because of unsuccessful prior 
attempt(s) (for example, contact was busy or unavailable). A detailed 
breakdown of the pending contacts is provided in the Printable Reports 
page for each campaign.

Enabled The Enabled field indicates to the Outbound subsystem whether this 
campaign is currently active.

Campaign Type Denotes whether a specific campaign is IVR-based or Agent-based. The 
existing campaigns will be marked as Agent-based after an upgrade.

Delete Click Delete icon next to the name of the campaign that you want to delete.
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Related Topics

 • About the Outbound Feature for Unified CCX, page 13-3

 • How Is a Contact’s Local Time Determined?, page 13-15

 • The Outbound Configuration Checklist, page 13-16

 • Configuring General Outbound Properties, page 13-18

 • Adding a New Campaign, page 13-31

 • Adding Area Codes, page 13-42

Adding Area Codes

Caution Area code and long distance prefix configuration changes made to the Outbound 
subsystem do not take effect for calls/contacts currently in the Outbound 
subsystem’s memory. For example, if you change the long distance prefix or local 
area code, the contacts already in the Outbound subsystem’s memory will 
continue to use the old long distance prefix and local area code. 

The Outbound subsystem provides all of the mappings from North American area 
codes to their corresponding time zones at the time of product release. The Area 
Codes page allows the administrator to add, modify, and delete any area code to 
time zone mappings.

Some area codes extend across multiple time zones. For such area codes, an 
administrator can edit the default time zone for that area code and specify a 
different one, if required.

The Area Codes Management page allows users to find, add, delete, and modify 
the mapping of area codes and time zones. The Outbound subsystem uses the area 
code of a contact’s phone number to determine the time zone of the contact’s 
calling area. This page can also be used for adding international area codes. 
International area codes must include the country code and the city code.
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To add an area code, complete the following steps.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > 
Outbound > Area Codes.

The Area Codes Management web page opens. 

Step 2 In the Area Code field, specify a unique identifier for the area code. This field can 
have any numeric value, including 0 or leading zeros. This is a mandatory field.

Step 3 Click Add New icon that displays in the tool bar in the upper, left corner of the 
window or the Add New button that displays at the bottom of the window.

The new Area Code information is updated.

Related Topics

 • About the Outbound Feature for Unified CCX, page 13-3

 • How Is a Contact’s Local Time Determined?, page 13-15

 • The Outbound Configuration Checklist, page 13-16

 • Configuring General Outbound Properties, page 13-18

 • Adding a New Campaign, page 13-31

 • Importing Contacts for a Campaign, page 13-39

 • Enabling Campaigns, page 13-41

Setting-up Communications with the Agent’s 
Desktop

In Unified CCX, CAD allows agents to handle Outbound calls. The Cisco Agent 
Desktop and Cisco Supervisor Desktop do not support any new reports.

To display the additional buttons for the Outbound feature on CAD, the Direct 
Preview option must be enabled on Cisco Desktop Administrator (CDA). See the 
Cisco Desktop Administrator’s User Guide and the Cisco Agent User Guide for 
further information.
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Related Topics

 • About the Outbound Feature for Unified CCX, page 13-3

 • How Is a Contact’s Local Time Determined?, page 13-15

 • The Outbound Configuration Checklist, page 13-16

 • Configuring General Outbound Properties, page 13-18

 • Adding a New Campaign, page 13-31

 • Importing Contacts for a Campaign, page 13-39

 • Enabling Campaigns, page 13-41

 • Adding Area Codes, page 13-42

 • Agents Receive Outbound Calls, page 13-44

Agents Receive Outbound Calls
Agents can now log in and get ready to receive Outbound calls. To do so, agents 
must belong to CSQs assigned to Outbound (see Allocating CSQ Agent Pool 
Percentages, page 13-30).

This section contains the following topics:

 • Agent Allocation and Queuing, page 13-45

 • Previewing Customer Information, page 13-46

 • Exchanging Data with CAD, page 13-48

 • Call Status Values, page 13-50

 • Call Result Values, page 13-52

 • Reclassification Status Behavior, page 13-54

 • Handling Skip-Next Behavior, page 13-56

 • Handling Skip/Reject Behavior, page 13-57

 • Call Retrieval Priority, page 13-58

 • Handling Failover and System Restarts, page 13-58

Related Topics

 • About the Outbound Feature for Unified CCX, page 13-3
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 • How Is a Contact’s Local Time Determined?, page 13-15

 • The Outbound Configuration Checklist, page 13-16

 • Configuring General Outbound Properties, page 13-18

 • Adding a New Campaign, page 13-31

 • Importing Contacts for a Campaign, page 13-39

 • Enabling Campaigns, page 13-41

 • Adding Area Codes, page 13-42

 • Setting-up Communications with the Agent’s Desktop, page 13-43

 • Handling Do Not Call Contacts, page 13-59

Agent Allocation and Queuing
The Outbound subsystem allocates agents for Outbound calls by pulling a batch 
of contacts from the db_cra database and assigning a Ready agent to each by 
reserving the agents for Outbound calls and presenting them with the Outbound 
calls. Only CAD agents are presented with Outbound calls. 

Agents are chosen from the CSQ using the same criteria configured in Unified 
CCX Administration GUI for inbound calls. If an agent accepts an Outbound call, 
the Outbound subsystem initiates a call on the agent’s behalf. If the agent rejects 
the contact, the agent reservation is cancelled and the agent becomes Ready again 
and may be presented with either an Outbound call or an inbound call. The contact 
that was rejected is assigned to another agent. If the agent decides to skip the 
contact, the agent reservation is not cancelled. Instead, the skipped contact gets 
assigned to another (or the same) agent. 

The agent’s response such as accept, skip, and reject is saved in the database for 
each contact presented during a campaign. If the agent does not respond within 
the timeout configured on the General page of the Outbound subsystem 
configuration in Unified CCX Administration GUI, the Outbound subsystem 
moves the agent to Not Ready state (much like an inbound Not Ready state) and 
assigns the contact to another agent. The status of the contact (for example, the 
contact can be closed or needs to be dialed again) and the call result (for example, 
the contact was reached successfully or contact was not home) is recorded in the 
database and this data is presented in the real-time and historical reports. 
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Note Calls made by the Outbound subsystem will not be displayed in the Contacts 
Summary Real-Time Report.

The goal of the subsystem is to maximize the number of Outbound calls made 
without sacrificing the inbound service level of the CSQs involved in the 
Outbound campaign. It accomplishes this by only using agents sitting idle in 
Ready state, not handling inbound calls. The administrator configures, through 
Unified CCX Administration GUI, the percentage of logged in agents (CAD + 
IPPA in ready, work, reserved, or talking state) in a CSQ that are allocated for 
handling Outbound calls.

Related Topics

 • Previewing Customer Information, page 13-46

 • Exchanging Data with CAD, page 13-48

 • Call Status Values, page 13-50

 • Call Result Values, page 13-52

 • Reclassification Status Behavior, page 13-54

 • Handling Skip-Next Behavior, page 13-56

 • Handling Skip/Reject Behavior, page 13-57

 • Call Retrieval Priority, page 13-58

 • Handling Failover and System Restarts, page 13-58

Previewing Customer Information
Before placing an Outbound call, an available agent is reserved and presented 
with a preview record on the desktop. This lets the agent preview the contact 
before deciding on an action. This dialog contains customer information such as 
name, account number, and phone number.

The enabled buttons when an agent is in the Reserved state are described in the 
following table:
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Related Topics

 • Agent Allocation and Queuing, page 13-45

 • Exchanging Data with CAD, page 13-48

 • Call Status Values, page 13-50

 • Call Result Values, page 13-52

 • Reclassification Status Behavior, page 13-54

 • Handling Skip-Next Behavior, page 13-56

 • Handling Skip/Reject Behavior, page 13-57

 • Call Retrieval Priority, page 13-58

 • Handling Failover and System Restarts, page 13-58

 Status Result of Selecting this Status

Accept Accept the current preview record and initiate the Outbound call to the customer from 
the agent’s phone.

Reject Reject the current preview record, cancel the agent reservation, and change the agent 
state to Ready. The agent can now handle either inbound or Outbound calls.

Reject-Close Reject the current preview call and close the record so that contact is not called again 
for this particular campaign. This cancels the agent reservation and changes the agent’s 
state to Ready so the agent can now handle either inbound or Outbound calls.

Skip Skip the current preview record and retain the agent in the reserved state to allow the 
agent to handle another Outbound contact.

Skip-Close Skip the current preview call and close the record so the contact is not called again for 
this particular campaign. The agent remains reserved to handle another Outbound 
contact.

Cancel 
Reservation

Cancel the agent reservation and set the agent to the Not Ready state. The record 
remains open in the database. This state is similar to the Reject state except that the 
agent is transferred to the Not Ready state instead of the Ready state.
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Exchanging Data with CAD
Unified CCX uses predefined Expanded Call Context (ECC) variables to 
exchange data with CAD for the Preview Outbound option. Unified CCX uses the 
same ECC variables that Unified ICME uses for the Preview Outbound option. 

These ECC variables are present on CDA. To display them on CAD, they must be 
added to the OODefault layout that is associated with the call.

The following table lists the pre-defined ECC variables used for the Preview 
Outbound option: 

Caution Do not use these pre-defined ECC variables in any other context as they are 
reserved for the Outbound feature. 

.

ECC Variable Description

BAStatus Required. Contains two characters indicating the mode and direction of the 
Preview Outbound option initiated call.

 • The first character identifies the call mode:

 – D = Direct Preview reservation for Unified CCX

 – C = Direct Preview call for Unified CCX

 – Z = the Outbound call transferred or conferenced 

 • The second character identifies the direction (always ‘O’ = Outbound for 
Unified CCX). 

So a BAStatus of DO would indicate a Direct Preview Reservation for an 
Outbound Call, which is always the case for Outbound calls in Unified CCX.

BACampaign Optional. The name of the Outbound campaign to which the call belongs.

BAAccountNumber Optional. Identifies a customer account number and can be used by CAD to 
perform a database lookup to obtain additional customer data. This ECC 
variable displays only if the data was available in the customer import file. 
Note: The maximum character length of this ECC variable is 30 characters.
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Related Topics

 • Agent Allocation and Queuing, page 13-45

 • Previewing Customer Information, page 13-46

 • Call Status Values, page 13-50

 • Call Result Values, page 13-52

 • Reclassification Status Behavior, page 13-54

 • Handling Skip-Next Behavior, page 13-56

 • Handling Skip/Reject Behavior, page 13-57

 • Call Retrieval Priority, page 13-58

 • Handling Failover and System Restarts, page 13-58

BAResponse Optional. Multi-purpose placeholder that sends data from CAD to the Preview 
Outbound option. This variable is used when the CAD responds to the server’s 
agent reservation request (for example, Accept, Reject, Skip, etc.). It is also 
used to schedule and cancel callbacks and make changes to the callback 
number.

BADialedListID Optional. Unique key identifying a specific customer record.

BATimeZone Optional. The GMT offset, in minutes, for the customer’s time zone and local 
time.

BABuddyName Optional. Contains the customer’s first and last name separated by a comma, if 
provided in the contacts list imported for the campaign.

BACustomerNumber Optional. Contains dialed customer phone number.

ECC Variable Description
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Call Status Values
For each contact, the call statuses and their corresponding values are recorded in 
the database and described in the following table:

Related Topics

 • Agent Allocation and Queuing, page 13-45

 • Previewing Customer Information, page 13-46

 • Exchanging Data with CAD, page 13-48

 • Resetting Contact States at Midnight, page 13-51

 • Call Result Values, page 13-52

 • Reclassification Status Behavior, page 13-54

 • Handling Skip-Next Behavior, page 13-56

 • Handling Skip/Reject Behavior, page 13-57

 • Call Retrieval Priority, page 13-58

Call Status
Value (stored 
in database) Description

Pending 1 The call is pending. This is the initial state for all records.

Active 2 The record was retrieved by the Outbound subsystem for dialing.

Closed 3 The record is closed (not dialed).

Callback 4 The record is marked for a callback.

Max Calls 5 Maximum attempts have been reached for this record (considered 
closed).

Retry 6 The record is redialed immediately whenever there is any miss in the 
callbacks for Retries with Delay.

Unknown 7 If the Outbound subsystem was restarted with records in the Active (2) 
state, they are moved to this state.

Retries 
with Delay

8 The record is redialed as it was either busy, no answer, customer 
abandoned or system abandoned. Retry time is set as per the 
corresponding configuration in Unified CCX Application Administration 
web interface.
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 • Handling Failover and System Restarts, page 13-58

Resetting Contact States at Midnight

The Outbound subsystem performs the following actions at midnight:

 • The DialingListConfig records with a call status of Unknown are reset to 
Pending.

 • Missed callback records (dialingListConfig records that have call status 
callback and a callBackDateTime smaller than the current time) are updated 
depending on the missed callback action configured in the Unified CCX 
Administration GUI.

 – MissedCallbackAction: Reschedule (for the same time on the next 
business day)

 – MissedCallbackAction: Retry (sets the call status to Retry and deletes the 
callBackNumber from the database).

 – MissedCallbackAction: Close (sets the call status to Closed)

 – Dialing list records with a call status of Closed or Max_Calls are deleted.

Note The records marked as closed today will be deleted the next day at 
midnight. For example, the records closed on 4th June will be deleted 
on 5th June at midnight.

 – Dialing list records with a call result of Do Not Call are not deleted as 
these records are exported to a text file.

 • The DialingListConfig records with a call status of “Retries with delay” and 
which could not be retried due to lapsed time are marked for immediate retry 
at midnight.

 • When the Unified CCX engine goes from offline to online (for example, the 
standby server becomes active (online) if the active (first) server fails), the 
dialing list records with a status of Unknown are reset to Pending.

Related Topics

 • Agent Allocation and Queuing, page 13-45

 • Previewing Customer Information, page 13-46
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 • Exchanging Data with CAD, page 13-48

 • Call Status Values, page 13-50

 • Call Result Values, page 13-52

 • Reclassification Status Behavior, page 13-54

 • Handling Skip-Next Behavior, page 13-56

 • Handling Skip/Reject Behavior, page 13-57

 • Call Retrieval Priority, page 13-58

 • Handling Failover and System Restarts, page 13-58

Call Result Values
For each contact, the call results (as marked by the agent on CAD or automatically 
deleted by the system) and their corresponding values are recorded in the database 
and described in the following table:

Call Result 
Value (stored 
in database) Description

Voice 1 Customer answered and was connected to agent.

Fax 2 Fax machine or modem detected.

Answering machine 3 Answering machine detected.

Invalid 4 Number reported as invalid by the network.

Do Not Call 5 Customer did not want to be called again.

Wrong Number 6 Number successfully contacted but wrong number.

Customer Not Home 7 Number successfully contacted but reached the wrong person.

Callback 8 Customer requested callback.

Agent Rejected 9 Agent skipped or rejected the preview call.

Agent Closed 10 Agent skipped or rejected the preview call with the close 
option (not dialed).

Busy 11 Busy tone detected.
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Related Topics

 • Agent Allocation and Queuing, page 13-45

 • Previewing Customer Information, page 13-46

 • Exchanging Data with CAD, page 13-48

 • Call Status Values, page 13-50

 • Call Result Values, page 13-52

Ring No Answer 12 Agent did not respond to the preview call within the time out 
duration. 

Note You can configure the time out duration using the 
Preview Call Timeout field detailed in the 
“Configuring General Outbound Properties” section 
on page 13-18.

Callback Failed 13 This value should not be written to the database; this is for 
internal use only.

Callback Missed 14 Callback missed and marked for Retry.

Timeout 15 Customer’s phone timed out either due to Ring No Answer 
(RNA) or Gateway failure.

Call Abandoned 16 Call was abandoned because IVR port was unavailable or 
Unified CCX failed to transfer the call to the IVR port.

Call Failed 17 Call failed due any one of the following reasons:

 • Dialer asked the Gateway to cancel a call that has not yet 
been placed

 • Gateway has declined the call

 • Gateway is down or Gateway has timed out while placing 
the call

 • Gateway failure or configuration issues at the Gateway.

Customer Abandoned 18 Customer abandoned as customer disconnected the call within 
the time limit as configured in “Abandoned Call Wait Time” 
in Unified CCX Application Administration web interface.

Call Result 
Value (stored 
in database) Description
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 • Reclassification Status Behavior, page 13-54

 • Handling Skip-Next Behavior, page 13-56

 • Handling Skip/Reject Behavior, page 13-57

 • Call Retrieval Priority, page 13-58

 • Handling Failover and System Restarts, page 13-58

Reclassification Status Behavior
When the Outbound contacts are imported into the database from the Unified 
CCX Administration GUI, the call status column in the Dialing List table is 
assigned the default value of 1 (Pending) indicating that these Outbound contacts 
are yet to be dialed. When the Outbound subsystem retrieves a batch of contacts 
from the database, the call status is set to 2 (Active). After a call is placed to the 
Outbound contact, the call status is set to 3 (Closed) and the call result is set to 1 
(Voice), as all Outbound calls are classified by the agent desktop as voice by 
default. If the agent clicks the reclassification button on the agent desktop and 
reclassifies the call as answering machine/fax/busy/invalid or selects the callback 
button and schedules a callback, the Outbound subsystem updates the call result 
field accordingly, and based on the call result, it also updates the call status. 

The following table describes the relationship between call status and call result 
values and the resulting behavior of the system. The values in brackets are the 
actual values stored in the database.

Note The following information is applicable only for Preview Dialer.

Call Result Call Status Behavior

Voice (1) Closed (3) This contact is not dialed again.

Fax (2) Retry (6) This contact is retried, using a different phone number 
provided for this contact. If alternate phone numbers are not 
available, the call status is closed. 

Answering machine (3) Retry (6) This contact is retried, with the same phone number as before.
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The call status is set to 3 (Closed) when the Outbound contact is no longer dialed 
for this campaign. This happens when a call was successfully placed (call result 
is voice) and also when an agent selects Skip-Closed, Reject-Closed, or Do Not 
Call. This also happens automatically if the system reaches the maximum 
attempts limit for an Outbound contact which means that the system tried dialing 
the Outbound contact the maximum number of times configured in the Unified 
CCX Administration GUI. 

Related Topics

 • Agent Allocation and Queuing, page 13-45

 • Previewing Customer Information, page 13-46

 • Exchanging Data with CAD, page 13-48

 • Call Status Values, page 13-50

 • Call Result Values, page 13-52

 • Handling Skip-Next Behavior, page 13-56

 • Handling Skip/Reject Behavior, page 13-57

Invalid (4) Retry (6) This contact is retried, using a different phone number 
provided for this contact. If alternate phone numbers are not 
available, the call status is closed.

Do Not Call (5) Closed (3) This contact is not dialed again.

Wrong Number (6) Retry (6) This contact is retried, using a different phone number 
provided for this contact. If alternate phone numbers are not 
available, the call status is closed.

CustomerNotHome (7) Retry (6)

Callback (8) Callback (4) This contact is dialed again using the number stored in the 
callbackNumber column, at the time stored in 
callbackDateTime column.

Reject or Skip (9) Active (No 
change)

This contact is presented to another agent.

Reject-Close or 
Skip-Close

Closed (3) This contact is not dialed again.

Busy Retry (6) This contact is retried, with the same phone number as before.

Call Result Call Status Behavior
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 • Call Retrieval Priority, page 13-58

 • Handling Failover and System Restarts, page 13-58

Handling Skip-Next Behavior

Tip To ensure that a skip-next selection is handled as designed, be sure to set at least 
two, if not all three, phone numbers. 

When an agent on an Outbound call with a customer selects the skip-next button 
on CAD, two options (wrong number or not home) are made available to this 
agent. The behavior for both options is the same, the agent continues to remain on 
the call with the customer, while the Outbound subsystem updates the phone 
number to be dialed to the next available number (with up to three phone number 
possibilities—phone01, phone02m and phone03). If the record is imported with 
only one phone number and phone02 and phone03 are empty, this record is closed 
after the agent drops the call. If phone02 is empty, but phone03 is present, then 
phone03 is used as the next number to dial.

If the max attempts to dial contact is set to 2 (default), even if the agent selects 
the skip-next button, the record is closed and the next number is never dialed. 

Related Topics

 • Agent Allocation and Queuing, page 13-45

 • Previewing Customer Information, page 13-46

 • Exchanging Data with CAD, page 13-48

 • Call Status Values, page 13-50

 • Call Result Values, page 13-52

 • Reclassification Status Behavior, page 13-54

 • Handling Skip/Reject Behavior, page 13-57

 • Call Retrieval Priority, page 13-58

 • Handling Failover and System Restarts, page 13-58
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Handling Skip/Reject Behavior
The Outbound subsystem handles an agent’s skip/reject requests as listed below:

 • Skip/reject close request: the contact is always set to Closed.

 • Contact is a callback record: the contact goes back in queue so the callback 
can be retried. 

 • Contact is not a callback: it is set to Pending and is picked up from the 
database the next time that the Outbound subsystem reads records.

 • Contact is recalled (deleted the CSQ to which this contact belonged, or the 
campaign that this contact belongs to was stopped): then this contact is no 
longer considered a callback.

 • Reject: the agent is moved to available or unavailable (depending on 
configuration) after the reject.

 • Skip: The Outbound subsystem verified if there is another contact in queue 
for this agent. If so, the agent remains in the reserved state and receives a new 
DialingListConfig. Now, the agent has the option again to 
accept/reject/skip/… for this new record.

 • No new record for this agent: this agent is moved to available or unavailable, 
again depending on the configuration.

 • No record for this agent: With only one active agent for a CSQ, the Outbound 
subsystem only requests one contact,. If the agent skips this contact, there is 
no other contact available. 

Related Topics

 • Agent Allocation and Queuing, page 13-45

 • Previewing Customer Information, page 13-46

 • Exchanging Data with CAD, page 13-48

 • Call Status Values, page 13-50

 • Call Result Values, page 13-52

 • Reclassification Status Behavior, page 13-54

 • Handling Skip-Next Behavior, page 13-56

 • Call Retrieval Priority, page 13-58

 • Handling Failover and System Restarts, page 13-58
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Call Retrieval Priority
While retrieving Outbound contacts from the database, records that have 
scheduled callbacks have priority as the callback time must be adhered to. 
Outbound contacts are retrieved in the following order of priority:

 • Priority 1: Outbound contacts with scheduled callback (call status = 4) and 
the current time is within the CallbackTimeLimit configured on the 
Campaigns page (default value is15 minutes) of the scheduled callback time.

 • Priority 2: Outbound contacts in the Pending state (call status = 1).

 • Priority 3: Outbound contacts in the Retry state (call status = 6).

Related Topics

 • Agent Allocation and Queuing, page 13-45

 • Previewing Customer Information, page 13-46

 • Exchanging Data with CAD, page 13-48

 • Call Status Values, page 13-50

 • Call Result Values, page 13-52

 • Reclassification Status Behavior, page 13-54

 • Handling Skip-Next Behavior, page 13-56

 • Handling Skip/Reject Behavior, page 13-57

 • Handling Failover and System Restarts, page 13-58

Handling Failover and System Restarts
Outbound contacts with an Active call status during a failover indicate that these 
contacts were retrieved from the database but the system went down either before 
they could be dialed or after they were dialed but before the call status and call 
result columns were updated. When the system restarts, the call status for all such 
Outbound contacts is changed to 7 (Unknown). All Outbound contacts in the 
Unknown state will be reset to the Pending state (should be retrieved for dialing 
again) at midnight every night.
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If there is an Outbound call in progress during a failover, they cannot be dialed 
again as the call status is set to Closed as soon as an Outbound call is placed and 
these records will not be retrieved for dialing again when the system comes back. 
However, if the failover happened before the system could update the call status 
to Closed, these records remain in the Active state and are marked Unknown so 
they transition to Pending state after midnight. Once they are in the Pending state, 
they will be dialed again.

Related Topics

 • Agent Allocation and Queuing, page 13-45

 • Previewing Customer Information, page 13-46

 • Exchanging Data with CAD, page 13-48

 • Call Status Values, page 13-50

 • Call Result Values, page 13-52

 • Call Result Values, page 13-52

 • Reclassification Status Behavior, page 13-54

 • Handling Skip-Next Behavior, page 13-56

 • Handling Skip/Reject Behavior, page 13-57

 • Call Retrieval Priority, page 13-58

Handling Do Not Call Contacts

Note In this guide, the underscore character linking each word differentiates the 
national do_not_call list from the Outbound subsystem’s Do Not Call list.

When an agent reclassifies an outbound contact as Do Not Call from CAD, then 
the record of the contact is closed and marked inactive in the database and it will 
not be dialed again. In addition to this, for all contacts in other campaigns that 
contain the same phone number as the outbound contact marked as Do Not Call, 
the records will be closed and marked inactive in the database and those contacts 
will not be dialed again. 

The following actions are performed by the Outbound subsystem:
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 • All contacts marked Do Not Call are exported to a text file <root 
dir>:\DoNotCall.txt. If the file already exists, the new contacts being 
exported are appended to the file along with a timestamp of when the export 
was done.

 • After the Do Not Call contacts are exported to the text file, they are marked 
inactive in the Dialing List table and are permanently deleted from the 
database when the database is purged (see Purging Historical Data, 
page 12-3).

Related Topics

 • About the Outbound Feature for Unified CCX, page 13-3

 • How Is a Contact’s Local Time Determined?, page 13-15

 • The Outbound Configuration Checklist, page 13-16

 • Verifying the RmCm and Outbound Subsystems, page 13-17

 • Configuring General Outbound Properties, page 13-18

 • Adding a New Campaign, page 13-31

 • Importing Contacts for a Campaign, page 13-39

 • Enabling Campaigns, page 13-41

 • Adding Area Codes, page 13-42

 • Setting-up Communications with the Agent’s Desktop, page 13-43
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C H A P T E R 14

Reporting on Real-Time Unified CCX 
Data

When the Unified CCX system is configured and functioning, you can run reports 
to monitor real-time activity using the Unified CCX Administration web 
interface. 

If you have the Cisco Agent Desktop and Cisco Supervisor Desktop, you also can 
run real-time reports directly from these applications. Cisco Agent Desktop and 
Cisco Supervisor Desktop do not use the same calculations or data display 
methods as those that Unified CCX real-time reporting uses. Therefore, a report 
run using Unified CCX real-time reporting and a report run using Cisco 
Supervisor Desktop may not display the same information for a given statistic. To 
avoid confusion, it might help to make one of these tools your standard reporting 
tool. 

You must be logged into the Unified CCX Administration web interface to run 
Unified CCX real-time reports.

Caution While Unified CM supports Unicode characters in first and last names, 
those characters become corrupted in Unified CCX Administration 
web pages for RmCm configuration, Real Time Reporting, Cisco 
Agent/Supervisor Desktop, and Historical Reports.

The following sections provide more information about real-time Unified CCX 
data.

 • Available Unified CCX Real-Time Reports, page 14-2
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Available Unified CCX Real-Time Reports
 • Opening Real-Time Reporting, page 14-3

 • Running Reports, page 14-5

 • Viewing Detailed Subreports, page 14-5

 • Printing Reports, page 14-6

 • Resetting Report Statistics, page 14-6

 • Clearing Stuck Calls, page 14-7

 • Setting Report Options, page 14-7

 • Setting Report Appearance, page 14-8

 • Application Reporting User Interface, page 14-8

Available Unified CCX Real-Time Reports
Unified CCX real-time reporting provides up to 12 reports that you can use to 
monitor Unified CCX system activity. The following table briefly describes each 
of these reports.

Report Description

Application Tasks Provides information about currently active applications.

Application Tasks Summary Provides a summary of specific applications’ activity.

Applications Provides a list of all applications loaded on the Unified CCX server.

Contacts Summary Provides information for call contacts, e-mail contacts, and HTTP 
contacts. Also provides the total number of contacts.

Note Calls made by the Outbound subsystem will not be displayed 
in the Contacts Summary Real-Time Report.

Contacts Provides information about currently active contacts.

CSQ Cisco Unified Contact 
Center Express Stats 

Provides information about CSQ activity. This report is available only 
if Unified CCX has been configured.

Data source Usage Provides information about configured data source names (DSNs).

Engine Tasks Provides information about currently active Engine tasks.
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Opening Real-Time Reporting
Related Topic

Report Menu, page 14-9

Opening Real-Time Reporting
Real-Time reporting is available from the Unified CCX Administration web 
interface.

Note Real-Time Reporting requires the Java plug-in. If the Java plug-in is not 
already installed on the PC on which you are viewing the reports, the Unified 
CCX system will automatically install it when you choose Tools > Real Time 
Reporting.

Preview Outbound Campaign 
Cisco Unified Contact Center 
Express Stats

Provides information about real-time Unified CCX information for the 
Outbound preview dialer.

IVR Outbound Campaign 
Stats

Provides real-time statistics on progressive and predictive Outbound 
IVR campaigns since the statistics were last reset.

Note This report will be available only if you have an Outbound IVR 
license on top of Unified CCX premium license in your 
Unified CCX.

Overall IVR Outbound Stats Provides real-time statistics across all predictive and progressive 
campaigns for all the configured Outbound IVR campaigns since the 
statistics were last reset.

Note This report will be available only if you have an Outbound IVR 
license on top of Unified CCX premium license in your 
Unified CCX.

Overall Cisco Unified 
Contact Center Express Stats

Provides information about Unified CCX resources and calls. This 
report is available only if Unified CCX has been configured.

Resource Cisco Unified 
Contact Center Express Stats

Provides information about Unified CCX resources activity.

Sessions Provides information on all active sessions.

Report Description
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Opening Real-Time Reporting
The Application Reporting web page is a stand-alone component of the Unified 
CCX Administration interface. It has its own menu bar, which replaces the 
Unified CCX Administration menu bar. 

To open real-time reporting, complete the following steps.

Procedure

Step 1 If you are running Real-Time Reporting for the first time on this system, log into 
Unified CCX Administration as an Administrator. 

The system prompts you to download the Java plug-in; follow the prompt 
instructions.

Note After you perform the initial download of the Real-Time Reporting Java 
plug-in, non-Administrative users can access Real-Time Reporting on 
this system.

Step 2 Choose Tools > Real-Time Reporting from the Unified CCX Administration 
menu bar.

The Application Reporting web page opens in a new window. The real-time 
reporting tool requires a Java plug-in. If the plug-in is not installed on the machine 
you are using, the Unified CCX system prompts you to accept the automatic 
installation of the plug-in. If you do not accept the installation, you cannot use 
real-time reporting.

Related Topics

 • Application Reporting User Interface, page 14-8.
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Running Reports
Open the real-time reporting tool from the Unified CCX Administration web 
interface to run reports.

To run a real-time report, complete the following steps.

Procedure

Step 1 From the Application Reporting menu bar, choose Reports.

Step 2 From the Reports menu, choose the report to run.

The report opens in the Application Reporting window.

Note For detailed information about the real-time reports that are available, see “Report 
Menu” section on page 14-9.

Viewing Detailed Subreports
You can view more detailed information for selected items in these four reports:

 • Application Tasks report

 • Contacts report

 • Applications report

 • Sessions report

To view detailed subreports, complete the following steps.

Procedure

Step 1 Run the Application Tasks, Contacts, Applications, or Sessions report. 

Step 2 Click a line in the report for which you want to view more detailed information. 
For example, click an e-mail address in the Contacts report.
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Step 3 From the Application Reporting menu bar, choose Views and click the subreport 
that you want to run. 

You can also open a subreport by right-clicking the selected item and choosing a 
subreport.

The subreport opens.

Note For detailed information about the subreports that are available, see “Views 
Menu” section on page 14-37.

Printing Reports
To facilitate printing, you can open a printable version of a report.

To print a report, complete the following steps.

Procedure

Step 1 Run a report.

Step 2 From the Application Reporting menu, choose Tools > Open Printable Report.

A printable version of the report opens in a separate window.

Step 3 Print the report using your browser’s print functionality.

Resetting Report Statistics
The Unified CCX system automatically resets all statistics each day at midnight. 
You can reset the accumulated statistics manually at any time. Resetting statistics 
does not reset active statistics, such as active contacts and active tasks.

To reset report statistics, complete the following steps.
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Clearing Stuck Calls
Procedure

Step 1 From the Application Reporting menu bar, choose Tools > Reset All Stats.

The Reset Stats dialog box opens for you to confirm the reset.

Step 2 Click Yes.

Accumulated statistics are reset.

Clearing Stuck Calls
You may sometimes see a Contact/Call as waiting in Real Time Reports in CSQ 
Stats and even though there are available Agents in the queue, the call does not 
seem to get routed to these Agents. The waiting time for the Queued call 
accumulates and will not clear even if the user activates “Reset All Stats” option 
from the Real-Time Reporting menu. 

To enable clearing such stuck call entries from the system, Unified CCX system 
provides the Clear Contact option. This has the ability to clear stuck calls in the 
system without requiring a restart of the engine.

For information on clearing stuck calls, see Clear Contact Menu Option, 
page 14-36

Setting Report Options
You can set the following reporting options:

 • Refresh interval

 • Number of times that the Unified CCX Administration web interface should 
attempt to reconnect to the Unified CCX server.

 • Whether logged off users appear in reports

To set report options, complete the following steps.
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Setting Report Appearance
Procedure

Step 1 From the Application Reporting menu bar, choose Settings > Options.

Step 2 The Options dialog box opens.

Step 3 From the Polling Interval drop-down menu, choose the refresh rate in seconds.

Step 4 From the Server Connect Retry Count drop-down menu, choose the number of 
times that the Unified CCX Administration web interface should attempt to 
reconnect to the Unified CCX server.

Step 5 From the Show Logged Off Resources drop-down menu, choose whether logged 
off agents appear in reports.

Step 6 Click Apply to apply the settings.

Setting Report Appearance
You can select from three report appearances:

 • Windows, which displays reports in colors based on your Windows settings

 • Motif, which displays reports in purple and menu items in brown

 • Metal, which displays reports in grey and menu items in black

To set the report appearance, choose Settings from the Application Reporting 
menu bar and click the appearance that you want.

Note For more information, see “Settings Menu” section on page 14-40.

Application Reporting User Interface

Note Support for High Availability and remote servers is available only in 
multiple-server deployments.
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When you choose Tools > Real-Time Reporting from the Unified 
CCX Administration menu, the Application Reporting tool opens a web page in a 
new window.

The Application Reporting tool menu bar contains the following options:

 • Report—Choose this option to display a list of the available top-level 
real-time reports (see Report Menu, page 14-9).

 • Tools—Choose this option to reset all the statistics and refresh connections 
(see Tools Menu, page 14-35).

 • Settings—Choose this option to set the look and feel of the real-time 
Reporting client, set the polling (refresh) interval times, and set the amount 
of times the server will attempt to reconnect (see Views Menu, page 14-37).

 • Help—Choose this option to display system information and to access 
Unified CCX online help (Settings Menu, page 14-40).

Report Menu

Note All real-time reports display a Last Updated At field, which indicates the time of 
the snapshot. All summary reports display both a start time (which indicates when 
the summary statistics started being collected) and the current time. All real-time 
reports display a Connected or Not Connected status for each node in the cluster. 

The Report menu provides access to a variety of top-level reports. It contains the 
following menu options:

 • Contacts Summary Real-Time Report, page 14-11

 • Application Tasks Summary Real-Time Report, page 14-13

 • Application Tasks, page 14-13

 • Engine Tasks, page 14-14

 • Contacts, page 14-14

 • Applications, page 14-19

 • Sessions, page 14-20

 • Datasource Usage, page 14-20
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 • Overall Cisco Unified Contact Center Express Stats, page 14-21

 • CSQ Cisco Unified Contact Center Express Stats, page 14-25

 • Preview Outbound Campaign Cisco Unified Contact Center Express Stats, 
page 14-27

 • IVR Outbound Campaign Stats, page 14-29

 • Overall IVR Outbound Stats, page 14-31

 • Resource Cisco Unified Contact Center Express Stats, page 14-32

 • Failover Behavior for Unified CCX Stats, page 14-34

High Availability (HA) Setup

In a HA setup, IVR real-time reports obtain data from both nodes in the cluster. 

Note Support for High Availability and remote servers is available only in 
multiple-server deployments.

Failover in a two-node cluster is available for Unified IP IVR reports as described 
in the following table.

 

Unified CCX real-time reports obtain data only from the current master 
node—failover in a two-node cluster is available as described in the following 
table.

Failover Scenario Connection Status Node 1 Status Node 2

Both nodes are up Fully Connected Node ID current/start-time Node ID current/start-time

Node 1 is up
Node 2 is down

Partially Connected Node ID current/start-time Node ID Not Connected

Node 1 is down
Node 2 is up

Partially Connected Node ID Not Connected Node ID current/start-time

Both nodes are down Not Connected Node ID Not Connected Node ID Not Connected
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Contacts Summary Real-Time Report

Use the Contacts Summary report to view specific contact information for call 
contacts, e-mail contacts, HTTP contacts, and total number of contacts.

To access the Contacts Summary real-time report, choose Reports > Contacts 
Summary from the Application Reporting menu bar. 

Note You display the data on this report as numbers or percentages by clicking the 
Display Value/Display % toggle button.

The following fields are displayed on the Contacts Summary report.

 

Failover Scenario Connection Status Node 1 Status Node 2

Both nodes are up
Node 1 is master

Fully Connected Node ID current/start-time Node ID Not Connected

Node 1 is master
Node 2 is down

Fully Connected Node ID current/start-time Node ID Not Connected

Node 1 is down 
Node 2 is master

Fully Connected Node ID Not Connected Node ID current/start-time

Both nodes are down Not Connected Node ID Not Connected Node ID Not Connected

Field Description

Active Active contacts that are currently running.

Inbound Number of inbound contacts since the statistics were last reset.

Outbound Number of outbound contacts since the statistics were last reset. 

Connected Number of connected contacts since the statistics were last reset. 

Provides a total for contacts that are connected to resources (for example, a call 
connected to an ACD agent).
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Terminated Number of terminated contacts since the statistics were last reset.

This row reports contacts that are ended normally by the application (for example, 
a caller hangs up and the application terminates), indicating whether the contact 
was terminated:

 • Locally—On the local server.

 • Remotely—On a remote server in the cluster.

Note Use the + toggle button to access these statistics.

Rejected Number of rejected contacts since the statistics were last reset. 

This row reports contacts that are not accepted and processed (as a result, for 
example, of insufficient resources or the rejection of the contact based on some 
customer-defined logic). Indicates the reason code for the reject:

 • Channels busy

 • No channel license

 • No trigger

Note Use the + toggle button to access these statistics.

Aborted Number of aborted contacts since the statistics were last reset. 

This row reports contacts improperly ended by a task associated with the 
application (as when, for example, the system generates an exception or can not 
invoke the application because of some error in the application) and includes the 
associated Java exception code. 

Note Java exception codes are dynamic, as they can be generated from a variety 
of sources.

Note Use the + toggle button to access these statistics.

Handled Number of handled contacts since the statistics were last reset.

This row reports contacts that are explicitly marked “Handled” by the application 
(typically when the application connects the contact to a Unified CCX agent).

Abandoned Number of abandoned contacts since the statistics were last reset. 

This row reports contacts that end without being marked “Handled” by the 
application.

Field Description
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Application Tasks Summary Real-Time Report

Use the Application Tasks Summary report to display statistics that summarize 
the activity of specific applications. 

To access the Application Tasks Summary real-time report, choose Reports > 
Application Tasks Summary from the Application Reporting menu bar.

The following fields are displayed on the Application Tasks Summary report.

 

Application Tasks 

Use the Application Tasks real-time report to view information about currently 
active applications. 

To access the Application Tasks report, choose Reports > Application Tasks 
from the Application Reporting menu bar. The following fields are displayed on 
the Application Tasks report.

 

Field Description

Application Name Names of the applications that are running or have run. 

Running Currently running applications. 

Completed Applications that have stopped running. 

Total Number of times an application was invoked since the statistics were last reset. 

DTMF VB and AA Application names configured from the Unified CCX administration.

Status Displays the failover connection status. The possibilities are: Fully connected, 
Partially connected, and Not connected. See the following tables for detailed 
status information for Unified IP IVR and Unified CCX reports.

Field Description

ID Unique application task ID. 

Node ID Unique ID for a server in the cluster. 

Application Name of the application. 

Start Time Time when the application task started. 

Duration Length of time that the application has been active.
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Note If this report indicates that an application is running for an unusually long time, 
there may be a problem with the application. The application’s script may not 
include error handling that prevents infinite retries if a call is no longer present. 
If the application does not receive a disconnect signal after a call, the application 
repeatedly retries to locate the call, and causes the application to run for an 
unusually long time. To prevent this problem, include the proper error handling 
in the application script.

Engine Tasks 

Use the Engine Tasks real-time report to view information about currently active 
Engine tasks.

To access the Engine Tasks report, choose Reports > Engine Tasks from the 
Application Reporting menu bar. 

The following fields are displayed on the Engine Tasks report.

 

Contacts

Use the Contacts real-time report to view information for all the active contacts 
for all servers across clusters.

Field Description

ID Unique identifier of the engine task. 

If the engine task is the main task running the application and the parent ID is 
empty, its identifier will match the Application Task Identifier.

Parent ID Unique identifier for the parent of the engine task (if any). 

Node ID Unique identifier for a server in the cluster. 

Server IP Address IP address identifying the server in the cluster. 

Script Name of the script that is running the task (if the task is running a Unified CCX 
script). 

Start Time Time that the task started. 

Duration Length of time the task has been active. 
14-14
Cisco Unified CCX Administration Guide, Release 8.5(1)



Chapter 14      Reporting on Real-Time Unified CCX Data
Application Reporting User Interface
Note Support for High Availability and remote servers is available only in 
multiple-server deployments.

To access the Contacts report, choose Reports > Contacts from the Application 
Reporting menu bar. 

The following fields are displayed on the Contacts report.

 

You can access detailed information about specific contacts listed on the Contacts 
web page by performing one of the following procedures:

 • Accessing Detailed Call Contact Information, page 14-16

 • Accessing Detailed E-mail Contact Information, page 14-17

 • Accessing Detailed HTTP Contact Information, page 14-18

Note The information displayed is dependent on the type of contact selected. 
Depending on the type of call, some fields may not be supported and will appear 
blank.

Field Description

ID Unique identifier representing a contact. 

Type Type of contact: Unified CM Telephony call, Cisco agent call, or Cisco HTTP Contact.

Impl ID Unique identifier provided by the particular type of contact. For example, for a call 
contact, this identifier would represent the Unified CM global call ID.

Node ID Unique identifier for a server in the cluster. 

Start Time Time stamp when the contact was created. 

Duration Length of time that the contact is active. 

Handled If True, the contact is handled; if False, the contact is not handled.

Aborting If True, the contact is aborted with a default treatment; if False, the contact is not 
aborted.

Application Name of the application currently managing the contact.

Task Unique identifier of the application task that is currently responsible for the contact.

Session Unique identifier of the session currently managing the contact (if any). 
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Related Topic

Clear Contact Menu Option, page 14-36

Accessing Detailed Call Contact Information

Use the Call Contacts Detailed Info real-time report to view all information 
related to the call contact.

To access the Call Contacts Detailed Info report, right-click a specific call contact 
record on the Contacts report; information for that specific record displays. 

The following fields are displayed on the Call Contacts Detailed Info report.

 

Field Description

State Current state of the contact.

Inbound If True, this call was received by the Unified CCX server; if False, this call 
was placed as an outbound call by an application.

Language The selected language context of the call.

Application ID Unique identifier of the associated application.

Called Number Called number for this call leg from the perspective of the called party.

Dialed Number Dialed number for this call leg from the perspective of the calling party.

Calling Number Calling number of the originator of this call.

ANI Automatic number identification.

DNIS Dialed number identification service.

CLID Caller ID. 

Arrival Type Information on how the call contact arrived in the system.

Last Redirected Number Number from which the last call diversion or transfer was invoked.

Original Called Number Originally called number.

Original Dialed Number Originally dialed number.

ANI Digits Automatic Number Identification information indicator digit codes.

CED Entered digits that were gathered by the network before the call was 
received. 

Note Calls running Unified ICME applications are also reported here.
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Accessing Detailed E-mail Contact Information

Use the Email Detailed Info real-time report to view all information related to the 
e-mail contact.

To access the Email Detailed Info report, right-click a specific e-mail contact 
record on the Contacts report; information for that specific record displays.

The following fields are displayed on the Email Detailed Info report.

 

Field Description

State Current state of the contact.

Inbound If True, this e-mail message was received by the Unified CCX server; if False, 
this e-mail was created by an application. 

Note Inbound e-mail messages are not currently supported.

Language Selected language context of the e-mail message.

Application ID Unique identifier of the associated application. 

From Sender of this e-mail message.

To All the recipients of this e-mail message.

Subject “Subject” field of this e-mail message. 

Attachments List of all attachments (file names) associated with this e-mail message. 
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Accessing Detailed HTTP Contact Information

Use the HTTP Detailed Info real-time report to view all information related to the 
HTTP contact.

To access the HTTP Detailed Info report, right-click a specific HTTP contact 
record in the Contacts report; information for that specific record displays.

The following fields are displayed on the HTTP Detailed Info report.

 

Field Description

State Current state of the contact.

Inbound If True, this HTTP request was received by the Unified CCX server; if False, 
this HTTP request was created by an application. 

Note This information will always be reported as True, because the Unified 
CCX server does not currently track outbound HTTP requests in this 
way.

Language Language currently associated with the HTTP request.

Application ID Unique identifier of the associated application. 

Authentication Type Name of the authentication scheme used to protect the servlet; for example, 
“BASIC” or “SSL.” 

Character Encoding Length, in bytes, of the request body, which is made available by the input 
stream, or -1 if the length is not known.

Note This length is the same as the value of the CGI1 variable 
CONTENT_LENGTH.

Content Length MIME type of the body of the request, or null if the type is not known.

Note This is the same as the value of the CGI variable CONTENT_TYPE.

Content Type Type of HTTP contact request.

Request Language Preferred language for client content (the language that the client accepts for 
its content), based on the Accept-Language header. 

Path Info Any extra path information associated with the URL the client sent when the 
HTTP request was made. 
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Applications

Use the Applications real-time report to view all the applications loaded on the 
server.

To access the Applications report, choose Reports > Applications from the 
Application Reporting menu bar. 

The following fields are displayed on the Applications report.

 

Protocol Name and version of the protocol the request uses in the form: 
protocol/majorVersion.minorVersion; for example, HTTP/1.1 

Note This value is the same as the value of the CGI variable 
SERVER_PROTOCOL. 

Remote Address IP address of the client that sent the request 

Note This value is the same as the value of the CGI variable 
REMOTE_ADDR. 

Remote Host Fully qualified name of the client that sent the request, or the IP address of the 
client, if the name cannot be determined 

Note This value is the same as the value of the CGI variable 
REMOTE_HOST.

Remote User Login of the user making this request, if the user has been authenticated.

Requested Session ID HTTP session ID as specified by the client. 

Request URL Section of the URL of the HTTP request, from the protocol name up to the 
query string in the first line of the HTTP request. 

1. CGI = Common Gateway Interface

Field Description

Field Description

Name Unique name of the currently loaded application.

ID Application ID.

Type Type of application that is currently running (for example, a Cisco Script 
Application).

Description Description of the application as entered on the Unified CCX Administration web 
site.
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Sessions 

Use the Sessions real-time report to view real-time information on all the active 
sessions.

To access the Sessions report, choose Reports > Sessions from the Application 
Reporting menu bar. 

The following fields are displayed on the Sessions report.

 

Datasource Usage 

Use the Data Source Usage real-time report to view real-time information on all 
configured Data Source Names (DSNs). 

Enabled If True, the application is enabled; if False, the application is disabled.

Max. Sessions Maximum number of simultaneous task instances that can run simultaneously on 
the Unified CCX server. 

Valid If True, the application is valid; if False, the application is invalid.1

1. An application is valid if it was successfully loaded and initialized from its configuration. At any time, an application can 
become invalid if it internally fails to be refreshed.

Field Description

Field Description

ID Session ID.

Note This identifier is guaranteed to remain unique for a period of 12 months. 

Mapping ID User- or system-defined identifier that maps to this session.

Node ID Unique identifier for a server in the cluster. 

Parent Sessions that were created as a result of consult calls propagated in the system. 

Creation Time Creation time of the session.

State Current state of the session.

Note When marked IDLE, the session is subject to being “garbage collected” 
by the system after a specified period of time. In addition, a session is 
IN_USE if it still has a contact associated or a child session. 

Idle Time Length of time that the session has been idle.
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To access the Data Source Usage report, choose Reports > Datasource Usage 
from the Application Reporting menu bar.

The following fields are displayed on the Data Source Usage report.

 

Overall Cisco Unified Contact Center Express Stats

Use the Overall Cisco Unified Contact Center Express Stats real-time report to 
view real-time Unified CCX resource and call information.

Note Unified CCX reports contain information for calls that have been queued in one 
or more CSQs. If a call is not queued (for example, the caller hangs up before 
being queued), the reports do not display data for that call. 

Unified CCX reports retrieve the following statistics:

 • Unified CCX statistics from the current Master node. 

 • Unified IP IVR statistics from all nodes in the cluster. 

To access the Overall Unified CCX Stats report, choose Reports > Overall Cisco 
Unified Contact Center Express Stats from the Application Reporting menu 
bar. 

Field Description

Data Source Name Name of the data source, as configured through the Unified 
CCX Administration web interface. 

Available Connections Number of connections available.

Busy Connections Number of busy connections.

Note Busy + available = Maximum number of connections configured.

Checkouts Granted Number of times the database connections have been used up since the 
statistics were last reset. 

Checkouts Denied Number of times the Database connections have been denied since the 
statistics were last reset.
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Note Preview Outbound durations are updated when the preview outbound call 
disconnects and all agents (resources) involved in the call move out of the work 
and talking state.

The following fields are displayed on the Overall Cisco Unified Contact Center 
Express Stats report.

 

Field Description

Resource Information

CSQs Number of CSQs currently configured. If a CSQ is added or removed, this 
statistic reflects that change. 

Logged-in Resources Number of resources currently logged in. 

Talking Resources Number of resources currently talking. 

Note This number includes resources in Talking, Work, and Reserved 
states.

Ready Resources Number of resources currently ready. 

Not Ready Resources Number of resources currently not ready. 

Call Information — Inbound

Total Contacts Number of total contacts that have arrived since the statistics were last reset. 
This includes contacts that are waiting, contacts connected to a resource, and 
contacts that have disconnected. 

If a resource transfers to or conferences with a route point, this value 
increases.

Contacts Waiting Number of contacts waiting to be connected to a resource.

Note A contact is shown as waiting until the call is answered by the agent. 
This means that, even if the phone is ringing at the agent, the contact 
will still show as waiting in RTR.

Contacts Handled Number of contacts that have been handled by a resource. 

Oldest Call in Queue Displays the wait time for the oldest contact in the queue.

Contacts Abandoned Number of contacts that have arrived and disconnected before being 
connected to a resource.
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Avg Talk Duration Average duration (in seconds) that resources spend talking on Unified CCX 
contacts. Talk duration starts when a contact first connects to a resource and 
ends when the contact disconnects from the last resource to which it was 
connected.

Talk duration does not include hold time.

Avg Wait Duration Average wait time (in seconds). It begins when the contact enters the system 
and ends when the contact stops waiting. Wait duration does not include hold 
time. The time a contact spends on a CTI port prior to getting queued is 
included in this report.

Longest Talk Duration Longest talk duration (in seconds) of a contact. Talk duration does not 
include hold time.

Longest Wait Duration Longest wait (in seconds) for a contact to be connected to a resource. Wait 
duration does not include hold time.

Call Information — Preview Outbound

Active Total number of preview outbound calls currently previewed or connected to 
agents.

Preview Total number of preview outbound calls currently previewed but have not 
been accepted, rejected. or closed by the agents.

Connected Total number of preview outbound calls currently connected to agents. When 
an agent conferences in other agents, the call is counted once towards the 
total number of connected calls.

Offered Total number of preview outbound calls offered. A call is considered offered 
when it is presented to an agent. A contact that is presented to an agent, 
skipped/rejected by that agent, and then presented to the same agent or to 
another agent is counted twice towards the number of calls offered. Offered 
= Accepted + Rejected + Closed + Timed-out.

Accepted Total number of preview outbound calls accepted. A call is considered 
accepted if an agent has clicked Accept when presented the call. A call that 
is presented to an agent, skipped/rejected by that agent, presented to another 
agent, and then accepted by that other agent is counted once towards the 
number of calls accepted.

Field Description
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Rejected The number of preview outbound calls that were skipped or rejected by an 
agent. This means that the agent selected Reject, Skip, or Cancel Reservation. 
These contacts will be dialed again. If a contact is rejected by multiple agents, 
this field increments each time the contact is rejected.

The number Rejected is also incremented each time an agent drops the 
preview call while it is ringing at the customer’s contact. 

Closed The number of preview outbound contacts that were closed by agents. This 
means that the agent selected Skip-Close or Reject-close. These contacts will 
not be dialed again.

Timed-Out Total number of preview outbound calls that timed out. A call is considered 
timed out when it is presented to an agent and not accepted, rejected, or 
closed within the allocated time. These contacts will be dialed again. If a 
contact timed out multiple agents, this field is incremented each time the 
contact is timed out for each agent. 

Invalid Number The number of preview outbound calls that were dialed to an invalid number. 
This means that the agent accepted the call (by clicking Accept), got 
connected to the customer, and selected the Invalid Number option from the 
contact Reclassification drop down. It also includes the number of preview 
outbound calls that failed at the network level.

Note The agent can manually reclassify the contact as Invalid Number 
while the customer contact is on the call or when the agent has gone 
into the Work state after the call.

Voice The number of preview outbound calls that ended in successful customer 
contact. This means that an agent accepted the call (by clicking Accept) and 
selected a classification of Voice (default) or Do Not Call for this contact.

Answering Machine The number of preview outbound calls that connected to an answering 
machine for this campaign. This means that the agent accepted the call (by 
clicking Accept), got connected to the answering machine and selected the 
Answering Machine option from the contact Reclassification drop down. 

Note The agent can manually reclassify the contact as Answering Machine 
while the customer contact is on the call or when the agent has gone 
into the Work state after the call.

Field Description
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Related Topic

Clear Contact Menu Option, page 14-36

CSQ Cisco Unified Contact Center Express Stats 

Use the CSQ Cisco Unified Contact Center Express Stats real-time report to view 
real-time information.

Note Unified CCX reports contain information for calls that have been queued in one 
or more CSQs. If a call is not queued, the reports do not display data for that call. .

To access the CSQ Cisco Unified Contact Center Express Stats report, choose 
Reports > CSQ Cisco Unified Contact Center Express Stats from the 
Application Reporting menu bar. 

Requested Callback The number of contacts marked for callback. This means that the agent 
accepted the call (by clicking Accept), got connected to the contact, the 
contact requested a callback, and the agent selected the CallBack option. A 
call that is accepted by an agent, marked for callback, later presented to and 
accepted by another agent (at the callback time), and marked for callback 
again is counted twice towards the number of callback calls. 

Avg Talk Duration The average time in HH:MM:SS (hours, minutes, seconds) that agents spend 
talking on outbound calls. The durations consider all calls that were Agent 
Accepted and classified as Voice. If a preview outbound call is transferred or 
conferenced to a route point, this average outbound talk duration does not 
include the talk time of agents who handle the call after it came through the 
route point. Instead, the talk time is included in the inbound talk duration.

Longest Talk Duration The longest talk duration of a preview outbound call in HH:MM:SS (hours, 
minutes, seconds). The durations consider all calls that were Agent Accepted 
and classified as Voice.

Field Description
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The following fields are displayed on the CSQ Cisco Unified Contact Center 
Express Stats report.

 

Related Topic

Clear Contact Menu Option, page 14-36

Field Description

Name Name of the CSQ.

Talking/
Ready Resources/
Not Ready Resources/
Logged-In Resources

Number of resources who are in the talking, ready, and not ready states, and 
the number of resources logged in for this CSQ. Values for the four items are 
separated by colons. Values are displayed in the same order that the items 
appear in the column heading.

Note This number includes resources in Talking, Work, and Reserved 
states. If you are logged into the Unified CCX Administration web 
interface as a Supervisor and opening the Real-Time Reporting 
plug-in, you will be able see all the logged in agents from all the 
teams independent of team membership. 

Total Contacts Number of total contacts since the statistics were last reset for this CSQ.

Contacts Waiting Number of contacts waiting to be connected to a resource in this CSQ.

This column also displays how long the oldest contact has been waiting.

Contacts [oldest 
contact in queue] 

Duration of longest currently waiting contact.

Contacts Handled Number of contacts that have been handled by this CSQ.

Contacts Abandoned Number of contacts that have been abandoned by this CSQ.

Contacts Dequeued Number of contacts that have been dequeued from this CSQ.

Avg Talk Duration Average time (in seconds) agents in this CSQ spent talking to contacts.

Avg Wait Duration Average wait time (in seconds). It begins when the call was queued (when 
you execute the “Select Resource” step) and ends when the call reaches the 
agent. Wait duration does not include hold time.The time a contact spends on 
a CTI port prior to getting queued is not included in this wait time.

Longest Talk Duration Longest time (in seconds) agents in this CSQ spend talking to contacts.

Longest Wait Duration Longest wait (in seconds) for a contact to be connected to a resource.
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Preview Outbound Campaign Cisco Unified Contact Center Express Stats

Use the Preview Outbound Campaign Cisco Unified Contact Center Express Stats 
real-time report to view real-time Unified Contact CCX information for the 
Outbound preview dialer.

To access the Preview Outbound Campaign Cisco Unified Contact Center 
Express Stats report, choose Reports > Preview Outbound Campaign Cisco 
Unified Contact Center Express Stats from the Application Reporting menu 
bar. 

The following fields are displayed on the Preview Outbound Campaign Cisco 
Unified Contact Center Express Stats report.

 

Field Description

Campaign The name of the preview outbound campaign.

Status The current activation state of the preview outbound campaign:

 • Running: an active preview outbound campaign

 • Stopped: an inactive preview outbound campaign. 

Active Total number of outbound calls currently previewed by or connected to agents for this 
preview outbound campaign. Active Calls = Previewed + Connected.

Preview Total number of outbound calls currently previewed but have not been accepted, 
rejected or closed by the agents as part of this preview outbound campaign.

Connected Total number of outbound calls currently connected to agents for this preview 
outbound campaign. When an agent conferences in other agents, the call is counted 
once towards the total number of connected calls.

Offered Total number of outbound calls offered for this preview outbound campaign. A call 
is considered offered when it is presented to an agent as part of this preview outbound 
campaign. A contact that is presented to an agent, skipped/rejected by that agent, and 
then presented to the same agent or to another agent is counted twice towards the 
number of calls offered. Offered = Accepted + Rejected + Closed + Timed-out.

Accepted Total number of outbound calls accepted for this preview outbound campaign. A call 
is considered accepted if an agent has clicked Accept when presented the call. A call 
that is presented to an agent, skipped/rejected by that agent, presented to another 
agent, and then accepted by that other agent is counted once towards the number of 
calls accepted.
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Rejected The number of outbound calls that were skipped or rejected by an agent as part of this 
preview outbound campaign. This means that the agent selected Reject, Skip, or 
Cancel Reservation. These contacts will be dialed again. If a contact is rejected by 
multiple agents, this field increments each time the contact is rejected.

The number Rejected is also incremented each time an agent drops the preview call 
while it is ringing at the customer’s contact. 

Closed The number of outbound contacts that were closed by agents as part of this preview 
outbound campaign. This means that the agent selected Skip-Close or Reject-close. 
These contacts will not be dialed again.

Timed-Out Total number of outbound calls that timed out. A call is considered timed out when it 
is presented to an agent and not accepted, rejected, or closed within the allocated time. 
These contacts will be dialed again. If a contact times out for multiple agents, this 
field is incremented each time the contact is timed out for each agent. 

Invalid 
Number

The number of outbound calls that were dialed to an invalid number for this preview 
outbound campaign. This means that the agent accepted the call (by clicking Accept), 
got connected to the customer, and selected the “Invalid Number” option from the 
contact Reclassification drop down. It also includes the number of outbound calls that 
failed at the network level.

Note The agent can manually reclassify the contact as Invalid Number while the 
customer contact is on the call or when the agent has gone into the Work state 
after the call.

Voice The number of outbound calls that ended in successful customer contact. This means 
that an agent accepted the call (by clicking Accept) and selected a classification of 
Voice or Do Not Call for this contact.

Answering 
Machine

The number of outbound calls that connected to an answering machine for this 
preview outbound campaign. This means that the agent accepted the call (by clicking 
Accept), got connected to the answering machine and selected the Answering 
Machine option from the contact Reclassification drop down. 

Note The agent can manually reclassify the contact as Answering Machine while 
the customer contact is on the call or when the agent has gone into the Work 
state after the call.

Field Description
14-28
Cisco Unified CCX Administration Guide, Release 8.5(1)



Chapter 14      Reporting on Real-Time Unified CCX Data
Application Reporting User Interface
IVR Outbound Campaign Stats

If you have an Outbound IVR license, use the IVR Outbound Campaign Stats 
report to view real-time statistics on each progressive and predictive IVR 
Outbound campaign configured in Unified CCX. 

Note This report will be available only if you have an Outbound IVR license on top of 
Unified CCX premium license in your Unified CCX.

To access the IVR Outbound Campaign Stats report, choose Reports > IVR 
Outbound Campaign Stats from the Application Reporting menu bar. The 
following fields are displayed on the IVR Outbound Campaign Stats report.

Requested 
Callback

The number of contacts marked for callback for this preview outbound campaign. 
This means that the agent accepted the call (by clicking Accept), got connected to the 
contact, the contact requested a callback, and the agent selected the CallBack option. 
A call that is accepted by an agent, marked for callback, later presented to and 
accepted by another agent (at the callback time), and marked for callback again is 
counted twice towards the number of callback calls. 

Avg Talk 
Duration

The average time in HH:MM:SS (hours, minutes, seconds) that agents spend talking 
on outbound calls for this preview outbound campaign. The durations consider all 
calls that were Agent Accepted and classified as Voice. If a call is transferred or 
conferenced back to the route point, the preview outbound campaign talk duration 
does not handle the talk time of agents who handle the call after it came through the 
route point.

Longest Talk 
Duration

The longest talk duration of an outbound call in HH:MM:SS (hours, minutes, 
seconds) for this preview outbound campaign. The durations consider all calls that 
were Agent Accepted and classified as Voice.

Field Description
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Field Description

Campaign 
Name

The name of the progressive or predictive campaign.

Status The current activation state of the campaign:

 • Running: an active progressive or predictive campaign

 • Stopped: an inactive progressive or predictive campaign. 

Type The dialer type of the campaign, which can be one of the following:

 • Progressive 

 • Predictive

Attempted The number of calls that were attempted since the statistics were last reset. 

Attempted will be equal to sum of the following counters - Voice + Answering 
Machine + Invalid Number + Fax/Modem + No Answer + Busy + Failed if there are 
no Customer Abandoned calls. 

Voice The number of calls that are connected to live voice since the statistics were last reset. 

 • If you have selected Answering Machine Treatment as "Abandon Call" for an 
Outbound IVR campaign through Campaign Configuration web page, then Voice 
=  Active + System Abandoned.

 • If you have selected Answering Machine Treatment as "Transfer to IVR" for an 
Outbound IVR campaign through Campaign Configuration web page, then Voice 
+ Answering Machine =  Active + System Abandoned.

Note Whenever there is an exception while executing some steps in an IVR script, 
the call will be marked as System Abandoned after it has been marked as 
Voice and Active. For example, if there is any codec mismatch issue, there 
will be an exception in the Accept Step. In such cases, the same call will be 
marked in the following three categories - voice, active, and system 
abandoned.

Answering 
Machine

The number of calls that reached an answering machine since the statistics were last 
reset.

Invalid 
Number

The number of calls that reached an invalid number since the statistics were last reset.

Fax/Modem The number of calls that reached fax or modem since the statistics were last reset.

No Answer The number of calls that were not answered since the statistics were last reset.
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Overall IVR Outbound Stats

If you have an IVR Outbound license, you can use the Overall Outbound IVR 
Stats report to view real-time statistics across all predictive and progressive 
campaigns since the statistics were last reset.

To access the Overall IVR Outbound Stats report, choose Reports > Overall IVR 
Outbound Stats from the Application Reporting menu bar. The following fields 
are displayed on the Overall IVR Outbound Stats report for all the configured IVR 
outbound campaigns.

Busy The number of calls that reached a busy destination since the statistics were last reset.

Failed The number of calls that were failed due to any one of the following reasons since the 
statistics were last reset:

 • Dialer asked the Gateway to cancel a call that has not yet been placed

 • Gateway has declined the call

 • Gateway is down or Gateway has timed out while placing the call

 • Gateway failure or configuration issues at the Gateway.

Active The number of calls that were connected to Outbound IVR ports since the statistics 
were last reset. 

All the voice calls that will be connected to Outbound IVR ports will be marked as 
active. If you have selected Answering Machine Treatment as "Transfer to IVR", then 
the answering machine calls that are getting transferred to Outbound IVR ports will 
also be marked as active.

Customer 
Abandoned

The number of calls that were abandoned by the customer since the statistics were last 
reset.

System 
Abandoned

The number of calls that were abandoned due to non-availability of ports or any issues 
at system level since the statistics were last reset.

Abandon Rate 
(in %)

The call abandon rate since the statistics were last reset. 

Abandon Rate = (System Abandoned/Voice)*100

Field Description
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Resource Cisco Unified Contact Center Express Stats 

Use the Resource Cisco Unified Contact Center Express Stats real-time report to 
view real-time Unified Contact CCX resource information.

To access the Resource Cisco Unified Contact Center Express Stats report, choose 
Reports > Resource Cisco Unified Contact Center Express Stats from the 
Application Reporting menu bar. 

Field Description

Attempted The total number of Outbound IVR calls that were attempted since the statistics were 
last reset. 

Voice The total number of Outbound IVR calls that were connected to live voice since the 
statistics were last reset. 

Answering 
Machine

The total number of Outbound IVR calls that reached answering machine since the 
statistics were last reset.

Invalid 
Number

The total number of Outbound IVR calls that reached an invalid number since the 
statistics were last reset.

Fax/Modem The total number of Outbound IVR calls that reached fax or modem since the statistics 
were last reset.

No Answer The total number of Outbound IVR calls that were not answered since the statistics 
were last reset.

Busy The total number of Outbound IVR calls that reached a busy destination since the 
statistics were last reset.

Failed The total number of failed Outbound IVR calls for all the Outbound IVR campaigns.

Active The total number of Outbound IVR calls that were connected to Outbound IVR ports 
since the statistics were last reset.

Customer 
Abandoned

The total number of Outbound IVR calls that were abandoned by the customer since 
the statistics were last reset.

System 
Abandoned

The total number of Outbound IVR calls that were abandoned by the system since the 
statistics were last reset.
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Note If multiple lines are configured for an agent, only the calls on the agent’s primary 
extension are reported in Resource Cisco Unified Contact Center Express Stats 
report.

The following fields are displayed on the Resource Cisco Unified Contact Center 
Express Stats report.

 

Field Description

Name (ID) Unique identifier of the resource.

State Current state of the resource.

Duration in State Length of time (in seconds) the resource has remained in the current state.

Contacts Presented Number of contacts that have been connected to this resource.

Contacts Handled Number of contacts that have been handled by this resource.

Avg Talk Duration Average time (in seconds) that this resource spends talking to contacts.

Avg Hold Duration Average time (in seconds) that the resource keeps contacts on hold.

Longest Talk Duration Longest time (in seconds) that this resource has spent talking to a contact. 

Longest Hold Duration Longest time (in seconds) that this resource has placed a call on hold.

Outbound Offered Total number of outbound calls offered to this resource. A call is considered 
offered when it is presented to an agent. A contact that is presented to an 
agent, skipped/rejected by that agent, and then presented to the same agent or 
to another agent is counted twice towards the number of calls offered. 
Offered = Accepted + Rejected + Closed + Timed-out.

Outbound Accepted Total number of outbound calls accepted by this resource. A call is 
considered accepted if an agent has clicked Accept when presented the call. 
A call that is presented to an agent, skipped/rejected by that agent, presented 
to another agent, and then accepted by that other agent is counted once 
towards the number of calls accepted. For transferred or conferenced 
outbound calls, the call is considered handled by the resource if it is answered 
by that resource
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Failover Behavior for Unified CCX Stats

All failovers, regardless of whether the Unified CCX engine is restarted, will 
cause the Unified CCX stats to reset. 

Outbound Rejected The number of outbound calls that were skipped or rejected by this agent. 
This means that the agent selected Reject, Skip, or Cancel Reservation. These 
contacts will be dialed again.

The number Rejected is also incremented each time an agent drops the 
preview call while it is ringing at the customer’s contact. 

Outbound Closed The number of outbound contacts that were closed by this agent. This means 
that the agent selected Skip-Close or Reject-close. These contacts will not be 
dialed again.

Outbound Timed-Out Total number of outbound calls that timed out. A call is considered timed out 
when it is presented to an agent and not accepted, rejected, or closed within 
the allocated time. These contacts will be dialed again. If a contact timed out 
for multiple agents, this field is incremented each time the contact is timed 
out for each agent. 

Outbound Voice The number of outbound calls that ended in successful customer contact for 
this resource. This means that the agent accepted the call (by clicking Accept) 
and selected a classification of Voice or Do Not Call for this contact.

Outbound Avg Talk 
Duration

The average time in HH:MM:SS (hours, minutes, seconds) that agents spend 
talking on outbound calls. The durations consider all calls that were Agent 
Accepted and classified as Voice. This talk duration includes talk time spent 
by a resource handling an outbound call that was transferred or conferenced 
to a route point.

Outbound Avg Hold 
Duration

The average time in HH:MM:SS (hours, minutes, seconds) that the Resource 
has spent holding an outbound call among accepted calls. The duration 
considers all calls that were Agent Accepted and classified as Voice.

Outbound Longest 
Talk Duration

The longest time in HH:MM:SS (hours, minutes, seconds) that an agent has 
spent talking on an outbound call. The durations consider all calls that were 
Agent Accepted and classified as Voice.

Outbound Longest 
Hold Duration

The average time in HH:MM:SS (hours, minutes, seconds) that the Resource 
has spent holding on the outbound calls among accepted calls. The duration 
considers all calls that were Agent Accepted and classified as Voice. 

Field Description
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The Unified IP IVR stats do not reset in all cases if the Unified CCX engine is not 
restarted on a node. However, the node loses its active server status. The Unified 
IP IVR stats on that node will not be reset.

Tools Menu
The Tools menu gives you access to the following Application Reporting tools:

 • Reset All Stats—Choose this option to reset all statistics.

 • Open Printable Report—Choose this option to get a printable report of all 
currently active contacts in the system.

 • Refresh Connections—Choose this option to refresh connections with the 
Unified CCX system

 • Clear Contact—Choose this option to clear contacts/calls that have been 
stuck in the system for a long time.

This section contains the following topics:

 • The Reset All Statistics Menu Option, page 14-35

 • Open Printable Report Menu Option, page 14-36

 • Refresh Connections Menu Option, page 14-36

 • Clear Contact Menu Option, page 14-36

The Reset All Statistics Menu Option

Use the Reset All Stats option to reset all statistics accumulated since the last time 
the statistics were reset. It will not reset active statistics, such as active contacts, 
tasks, and so on.

Note The Unified CCX system automatically resets all statistics each day at 
midnight.

To reset all statistics, choose Tools > Reset All Statistics from the Application 
Reporting menu bar. The Unified CCX system resets all statistics.
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Open Printable Report Menu Option

Use the option to get a printable report of all currently active contacts in the 
system.

To get a printable report, choose a real-time report from the Report menu option 
and then Tools > Open Printable Report from the Application Reporting menu 
bar.

Refresh Connections Menu Option

To refresh connections with the Unified CCX system, choose Tools > Refresh 
Connections from the Application Reporting menu bar. The Unified CCX system 
refreshes all connections.

Clear Contact Menu Option

You can use the Clear Contact menu option to clear contacts in the following three 
situations:

Clearing Stuck Calls from the Contacts real-time report

To clear stuck calls/contacts from the Unified CCX system, 

Step 1 Choose the contact from Reports > Contacts.

Step 2 From the Application Reporting menu bar, choose Tools > Clear Contact. A 
Clear Call dialog box is displayed to warn you. If you want to continue with the 
clear action, click No. To cancel the action, click Yes.

Step 3 Click No to proceed with the clear action. A Clear Contact dialog box is displayed 
for you to confirm the action. You can click Yes to proceed or No to cancel.

Step 4 Click Yes. The Unified CCX system removes the contact from all its queues.

Clearing Stuck Calls from the Overall Cisco Unified Contact Center Express Stats real-time report

To clear stuck calls/contacts from the Unified CCX system, 

Step 1 Choose Reports > Overall Cisco Unified Contact Center Express Stats.
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Step 2 Choose the contact from Views and click Overall Waiting Contacts Info.

Note Please note that the Overall Waiting Contacts Info menu option displays 
only those calls that are queued in CSQs and not Agent Based routing 
calls.

Step 3 From the Application Reporting menu bar, choose Tools and click Clear 
Contact. A Clear Call dialog box is displayed to warn you. If you want to 
continue with the clear action, click No. To cancel the action, click Yes.

Step 4 Click No to proceed with the clear action. A Clear Contact dialog box is displayed 
for you to confirm the action. You can click Yes to proceed or No to cancel.

Click Yes. The Unified CCX system removes the contact from all its queues.

Clearing Stuck Calls from the CSQ Cisco Unified Contact Center Express Stats real-time report 

To clear stuck calls/contacts from the Unified CCX system, 

Step 1 Choose Reports > CSQ Cisco Unified Contact Center Express Stats.

Step 2 Choose the contact from Views and click CSQ Waiting Contacts Info.

Step 3 From the Application Reporting menu bar, choose Tools > Clear Contact. A 
Clear Call dialog box is displayed to warn you. If you want to continue with the 
clear action, click No. To cancel the action, click Yes.

Step 4 Click No to proceed with the clear action. A Clear Contact dialog box is displayed 
for you to confirm the action. You can click Yes to proceed or No to cancel.

Click Yes. The Unified CCX system removes the contact from all its queues.

Views Menu
The Views menu allows you to access more detailed information for six reports: 
The Application Tasks report, the Contacts report, the Applications report, the 
Sessions report, Overall Cisco Unified Contact Center Express Stats report, and 
the CSQ Cisco Unified Contact Center Express Stats report. 
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Note For some reports, detailed information is also available by right-clicking a record 
in that report.

The Views menu contains different options, depending on the report you have 
chosen. Possible options are:

 • Contacts by Application Task ID—Choose this option to view contacts 
according to Application Task ID numbers.

 • Engine Tasks by Application Task ID—Choose this option to view Engine 
tasks according to Application Task ID numbers.

 • Detailed Info—Choose this option to view more detailed information on 
selected reports.

 • Application Tasks by Application Name—Choose this option to view 
application tasks by application name.

 • Contacts by Session ID—Choose this option to view contacts by session ID.

 • Overall Waiting Contacts Info—Choose this option to view detailed 
information for the overall waiting contacts. To clear stuck calls in this view, 
see Scenario 2 in Clear Contact Menu Option, page 14-36

 • CSQ Waiting Contacts Info—Choose this option to view detailed 
information for the CSQ waiting contacts. To clear stuck calls in this view, 
see Scenario 3 in Clear Contact Menu Option, page 14-36

This section contains the following topics:

 • Application Tasks, page 14-39

 • Contacts, page 14-39

 • Applications, page 14-39

 • Sessions, page 14-40

 • Overall Cisco Unified Contact Center Express Stats, page 14-21

 • CSQ Cisco Unified Contact Center Express Stats, page 14-25
14-38
Cisco Unified CCX Administration Guide, Release 8.5(1)



Chapter 14      Reporting on Real-Time Unified CCX Data
Application Reporting User Interface
Application Tasks

When you use the Views options with the Application Tasks reports, the Views 
menu contains the following options:

 • Contacts by Application Task ID, page 14-39

 • Engine Tasks by Application Task ID, page 14-39

Contacts by Application Task ID 

This report displays the same report as the Contact report (see the “Contacts” 
section on page 14-14,) with the exception that the Contacts by Application Task 
ID report has been filtered using only the contact currently being managed by the 
selected application task.

Engine Tasks by Application Task ID 

This report displays the same report as the Engine Task reports (see the “Engine 
Tasks” section on page 14-14,) except that the Engine Tasks by Application Task 
ID report has been filtered to display only the engine tasks that are associated with 
the application task.

Contacts 

When you use the Views options with the Contacts report, the Views menu 
contains only the Detailed Info option.

The Detailed Info option provides various detailed information, depending on the 
type of contact selected. For example, if the contact is a call, the Calling Party 
number, the Called Number, and so on, are displayed for that particular call.

For more information, please see the “Accessing Detailed Call Contact 
Information” section on page 14-16.

Applications 

When you use the Views options with the Application reports, the Views menu 
contains only the Application Tasks by Application Name option.
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The Application Task By Application Name report displays the same report as the 
Application Task report (see Application Tasks, page 14-39), except that the 
Application Task By Application Name report is filtered using only the active 
application tasks associated with this application.

Sessions 

When you use the Views options with the Session reports, the Views menu 
contains the following options:

 • Contacts By Session ID, page 14-40

 • Detailed Info, page 14-40

Contacts By Session ID 

This report displays the same report as the Contact report (see the “Contacts” 
section on page 14-14,) with the exception that the Contacts By Session ID report 
is filtered using only the contacts associated with the selected session.

Detailed Info

Detailed info displays the time the session was created and its current state.

Settings Menu 
The Settings menu of the Application Reporting menu bar allows you to adjust 
various settings of the Real Time Reporting tool.

The Settings menu contains the following menu options:

 • Options—Choose this option to set the polling (refresh) interval times and to 
set the amount of times the server will attempt to reconnect.

 • Window—Choose this option to display reports in colors based on your 
Windows settings.

 • Motif—Choose this option to display reports in purple and menu items in 
brown.

 • Metal—Choose this option to display reports in grey and menu items in 
black.
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This section contains the following topic:

 • Options Menu Option, page 14-41

Options Menu Option

Choose Settings and click Options to access the Options dialog box. Use the 
Options dialog box to set the polling (refresh) interval time, set the number of 
times the server will attempt to reconnect, and specify whether logged off agents 
appear in reports. 

The following fields are displayed in the Options dialog box.

Click Apply to submit configuration changes.

Field Description

Polling Interval Time between two requests to the server for new statistics by the client.

Server Connect Retry Count The number of times that the Unified CCX Administration web 
interface should attempt to reconnect to the Unified CCX server.

Note If an error occurs, an Error dialog box opens to alert you that 
the server is not communicating with the web interface. 

Show Logged Off Resources Specifies whether logged off agents appear in reports.
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C H A P T E R 15

Using Unified CCX Supervisor and 
Unified CCX User Options Plug-Ins

The following sections provide detailed information on the additional plug-in 
options provided by the Unified CCX.

 • About User Management, page 15-1

 • About Unified CCX User Capabilities, page 15-2

 • Using Unified CCX Supervisor Web Interface, page 15-6

 • Using the Unified CCX User Options Web Interface, page 15-9

Related Topics

 • Accessing Unified CCX Administration Web Interface, page 2-2

About User Management
In earlier versions of Unified CCX, many user parameters like user ID, password, 
and pin were configured from the Unified CM Administrator. Some Unified 
CCX-related user parameters were configured through the Unified CCX 
Administration.

In Unified CCX, all Unified CCX user roles (capabilities) are consolidated into 
one User Configuration area.
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In Unified CCX versions supporting Unified CME, the user configuration and 
management is entirely done by Unified CCX. Therefore, in addition to 
consolidating all user management under one menu, Unified CCX users are 
managed from within the same menu.

The user information for each product is stored in different locations:

 • The Unified CM user details are stored in the Unified CM database.

 • The Unified CME user details are stored in the Unified CCX Database.

Related Topics

 • About Unified CCX User Capabilities, page 15-2

 • Administrator Privileges, page 15-3

 • Supervisor Privileges, page 15-3

 • Historical Report User Privileges, page 15-5

 • Agent Privileges, page 15-5

About Unified CCX User Capabilities
The capability for each user refers to the Unified CCX access level assigned for 
each user. Unified CCX users can be assigned to one of the following four roles 
(or capabilities): 

 • Administrator

 • Supervisor

 • Historical Report User

 • Agent

Each of these roles are described in this section. 

Related Topics

 • About User Management, page 15-1

 • Administrator Privileges, page 15-3

 • Supervisor Privileges, page 15-3

 • Historical Report User Privileges, page 15-5
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 • Agent Privileges, page 15-5

Administrator Privileges
A Unified CCX Administrator is a user with complete access to the Unified CCX 
Administration and has the authority to configure the entire system. An 
Administrator can also be assigned a combination of other roles. 

The Administrator can turn on/off the authority of a Supervisor to manage the 
teams and agents. 

Related Topics

 • Administrator Capability View Menu Option, page 20-16

 • About User Management, page 15-1

 • About Unified CCX User Capabilities, page 15-2

 • Supervisor Privileges, page 15-3

 • Historical Report User Privileges, page 15-5

 • Agent Privileges, page 15-5

Supervisor Privileges
Supervisors can additionally modify and view skills, view the list of all teams for 
which this user is the supervisor, view the skills, CSQs, and resource groups 
configured in this system, view and manage resources, and configure the teams 
managed by the supervisor.

Unified CCX provides three types of Supervisors:

 • Application Supervisor: A basic supervisor role applicable to a Unified 
CCX Application server without a Unified CCX license. An application 
supervisor can only view reports.

 • ACD Supervisor: A supervisor with an agent’s role. This role is applicable 
to a Unified CCX Application server with any Unified CCX license. An ACD 
supervisor can administer teams/agents and also view reports. Thus Unified 
CCX enables dynamic reskilling, the ability by which an ACD supervisor can 
add or remove skills from an agent without an administrator privilege. 
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 • Remote Monitoring Supervisor: An application supervisor role with all 
numeric characters in the assigned user ID. This role is applicable to a 
Unified CCX Application server with only a Unified CCX Premium license. 
This role is not available for Unified CCX users in a Unified CME 
deployment. In addition to viewing reports, this supervisor can also view the 
list of agents and CSQs being monitored. 

Depending on the license allowed, Unified CCX Supervisors have the following 
privileges:

 • Download and install the Historical Reporting client to view reports.

 • View agents and CSQ being monitored. This is only for a remote Supervisor.

 • Download and install the Supervisor Desktop and the Agent Desktop.

 • View the list of all Teams for which this user is the Supervisor.

 • Configure the Teams managed by the Supervisor.

 • View the Skills, CSQs, and Resource Groups configured in this system. 

Note The RmCm menu can be viewed by the Supervisor only when any one of the 
following two options are selected as the parameter value for the Supervisor 
Access field located in System -> System Parameters page -> Application 
Parameters:
- Access to all Teams 
- Access to Supervisor's Teams only

 • View and manage all the resources.

Related Topics

 • About User Management, page 15-1

 • About Unified CCX User Capabilities, page 15-2

 • Administrator Privileges, page 15-3

 • Historical Report User Privileges, page 15-5

 • Agent Privileges, page 15-5

 • Using Unified CCX Supervisor Web Interface, page 15-6

 • Supervisor Capability View Menu Option, page 20-16
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Historical Report User Privileges
A user with a historical report client role can view various historical reports. The 
number and types of reports allowed to be viewed depends on the licenses 
available on a given Unified CCX system. 

Related Topics

 • Reporting Capability View Menu Option, page 20-16

 • About User Management, page 15-1

 • About Unified CCX User Capabilities, page 15-2

 • Administrator Privileges, page 15-3

 • Supervisor Privileges, page 15-3

 • Agent Privileges, page 15-5

Agent Privileges

Note An agent capability is only available with a Unified CCX license.

Unified CM users in Unified CCX are assigned an agent’s role when an agent 
extension is associated to the user in the Unified CM User Configuration page. 
Consequently, this role can only be assigned or removed for the user using 
Unified CM Administrator’s End User configuration web page (see Chapter 4, 
“Provisioning Unified CM for Unified CCX”). These users can not be assigned or 
removed in Unified CCX Administration.

Unified CCX users in a Unified CME deployment are entirely managed by 
Unified CCX. This ability to change an agent’s role is available only for Unified 
CCX users in a Unified CME deployment. Hence, on selecting the required 
agents, this page leads you to the Bulk Resource Configuration web page where 
you can configure multiple users and assign skills/resource groups at the same 
time.

Related Topics

 • Agent Capability View Menu Option, page 20-17
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 • About User Management, page 15-1

 • About Unified CCX User Capabilities, page 15-2

 • Administrator Privileges, page 15-3

 • Supervisor Privileges, page 15-3

 • Historical Report User Privileges, page 15-5

Using Unified CCX Supervisor Web Interface
Use the Unified CCX Supervisor web page to:

 • View and monitor permitted agents (see Monitoring Agents, page 15-7).

 • View and monitor permitted CSQs (see Monitoring CSQs, page 15-7). 

 • Install client-side Historical Reporting (see Installing Client-Side Historical 
Reporting, page 15-9)

 • Access real-time reports, tools, and settings (see Chapter 14, “Reporting on 
Real-Time Unified CCX Data”).

Accessing the Unified CCX Supervisor Web Page
To access the Unified CCX Supervisor web page, perform the following steps:

Procedure

Step 1 Ensure supervisor capability is assigned to the user designated as supervisor (see 
Supervisor Privileges, page 15-3 and User View Submenu Option, page 20-13). 

Note If the supervisor is assigned administrator capability as well, then the 
Unified CCX Administration window is opened instead of the Supervisor 
web page. 

Step 2 From a web browser on any computer on your network, enter the following 
case-sensitive URL:

https://<servername>/appadmin
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In this example, replace <servername> with the host name or IP address of the 
required Unified CCX server.

Tip If you have already accessed the Unified CCX Administration application 
or Supervisor web page in the browser, be sure to logout from the current 
session using Logout link displayed in the top right corner of any Cisco 
Unified CCX Administration web page or System -> Logout and login 
with respective user credentials.

The Unified CCX Supervisor web page appears.

Monitoring Agents 
The Supervisor can view and monitor agents only when the following conditions 
are met:

 • The Supervisor has to be a remote monitoring Supervisor. See Creating a 
Remote Monitoring Supervisor, page 8-31.

 • The resources that are to be monitored should be assigned to the remote 
monitoring Supervisor. See Assigning Resources and CSQs to a Supervisor, 
page 8-32.

Related Topics

 • Supervisor Privileges, page 15-3

Monitoring CSQs
The Supervisor can view and monitor CSQs only when the following conditions 
are met:

 • The Supervisor has to be a remote monitoring Supervisor. See Creating a 
Remote Monitoring Supervisor, page 8-31.
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 • The CSQs that are to be monitored should be assigned to the remote 
monitoring Supervisor. See Assigning Resources and CSQs to a Supervisor, 
page 8-32.

To monitor CSQs from the Unified CCX Supervisor web page, perform the 
following steps:

Procedure

Step 1 Select Tools > Plug-ins from the Unified CCX Administration menu bar. 

Step 2 Click Cisco Unified CCX Desktop Suites hyperlink.

Step 3 Click View CSQ hyperlink to view allowed CSQs.

Step 4 When finished, click Logout.

Related Topics

 • Supervisor Privileges, page 15-3

Viewing CSQ IDs for Remote Monitoring
To view CSQ IDs from the Unified CCX Supervisor web page, perform the 
following steps:

Procedure

Step 1 From the Unified CCX Supervisor web page, log in as the Remote Monitoring 
supervisor.

Step 2 Select Tools > Plug-ins from the Unified CCX Administration menu bar.

Step 3 Click Cisco Unified CCX Desktop Suites hyperlink.

Step 4 Click View CSQ hyperlink to view allowed CSQs.
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The CSQ ID column shows the ID value that you should enter for the CSQ that 
you selected in the Start Monitor Step. See the Start Monitor Step in the Cisco 
Unified CCX Scripting and Development Series: Volume 2, Editor Step Reference 
for more information.

Installing Client-Side Historical Reporting
To install client-side Historical Reporting, perform the following steps:

Procedure

Step 1 Select Tools > Plug-ins from the Unified CCX Administration menu bar. 

Step 2 Click Cisco Unified CCX Historical Reports hyperlink.

Step 3 For more instructions, see the Cisco Unified CCX Historical Reports User Guide.

Using the Unified CCX User Options Web Interface
Use the Unified CCX User Options web page to perform:

 • Unified CCX downloads

 • Alternate pronunciations for call by name

 • Access the Unified CM User Page

Note For a Unified CME deployment, you can also change the password/PIN and 
upload a spoken name prompt.

Accessing the Unified CCX User Options Web page
To access the Unified CCX User Options web page, perform the following steps:
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Procedure

Step 1 From the Unified CCX Administration enter http://<Cisco Unified CCX IP 
address>/appuser.

Step 2 If prompted to do so, enter your User ID and Password.

The Unified CCX User Options web page appears.

Step 3 When finished, click Logout.

Downloading Agent Desktop
To install and configure the Agent Desktop, perform the following steps: 

Procedure

Step 1 In the Unified CCX User Options Welcome web page, go to User Options > 
Cisco Unified CCX Downloads.

The Download page appears. 

Step 2 Click Cisco Unified CCX Agent Desktop hyperlink displayed on this page.

Step 3 The File Download dialog box appears. Click Run to install the Unified CCX 
Agent Desktop on your computer.

Note You need to download Cisco Unified CCX Desktop Client Configuration tool 
prior to installing any application(s) from the Cisco Unified CCX Desktop 
Product Suite.
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Cisco Unified CCX Desktop Client Configuration Tool
After completing a fresh installation or upgrade of Unified CCX, you need to run 
the Cisco Unified CCX Desktop Client Configuration tool prior to installing any 
desktop application(s) from the Cisco Unified CCX Desktop Product Suite. 

Since Unified CCX Release 8.5(1) is developed on the Cisco's Unified 
Communications Operating System (UCOS), which in turn is based on Redhat 
Linux, the client MSIs cannot be created while installing the desktop applications. 
The Unified CCX Desktop Client Configuration Tool uses the client PC for 
configuring the client MSIs. 

It downloads the files that are needed to create the MSIs into a temporary folder, 
creates the MSIs, and then uploads those MSIs to the server from where they can 
be launched through the hyperlinks in the Plug-ins page. This tool uploads the 
MSIs to the Linux server, cleans up all the folders and files it created on the 
Windows PC.

From the client PC, which you use to access Unified CCX Administration, choose 
Tools > Plug-ins menu option and in the Plug-ins web page, click Cisco Unified 
CCX Desktop Suites. You will see another web page with the following two 
categories:

 • Cisco Unified CCX Desktop Client Configuration tool 

 • Cisco Unified CCX Desktop Product Suite  

To launch this tool, click Cisco Unified CCX Desktop Client Configuration 
tool hyperlink from the Cisco Unified CCX web page. You will see a File 
Download dialog box. Click Run to run the CAD Client Configuration.msi, which 
is a Windows Installer (MSI). You will see a dialog box with progress bars 
showing the status of Agent, Supervisor, and Administrator MSIs that are being 
packaged and uploaded to the Unified CCX. 

If you run this tool from either of the node(s) in a High Availability deployment 
of Unified CCX, the MSIs are uploaded on both the primary and secondary nodes 
of Unified CCX.

You need to run the Desktop Client Configuration tool in the following scenarios:

 • After fresh installation of Unified CCX 8.5(1)

 • After installing Service Release (SR) and Engineering Special (ES) release of 
Unified CCX

 • After changing the IP address of one or more nodes of Unified CCX
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 • After installing Unified CCX on the second node

 • Moving to single-node from a HA deployment of Unified CCX

 • After changing the CAD Language that you want to be available for use in 
the agent desktops and supervisor desktops of Unified CCX.

Adding Alternative Pronunciations  
Alternative Pronunciations for Call by Name is an independent feature located on 
the Unified CCX User Options Welcome web page. This feature lets you add one 
or more alternate pronunciations for your first or last name and is useful if callers 
might refer to you by more than one name. For example, if your first name is Bob, 
you might add the alternate pronunciations “Bob” and “Bobby.” Similarly, if your 
last name is Xhu, you might add the alternate pronunciation “Xhu.” 

To access the Alternative Pronunciations for Call by Name web page, perform the 
following steps:  

Procedure

Step 1 In the Cisco Unified CCX User Options Welcome web page, choose User 
Options > Alternative Pronunciations for Call by Name. 

The Alternate Pronunciations web page appears.

Step 2 In the First Name field, you can enter an alternate pronunciation of your first 
name. For example, if your name is “Mary,” you might enter “Maria.”

Step 3 Click Add>>.

The name moves to a list of alternate first name pronunciations.

Step 4 Repeat Steps 2 and 3 as needed to add other alternate pronunciations.

To remove an alternate pronunciation for your first name, click the alternate 
pronunciation and then click Remove.

Step 5 In the Last Name field, you can enter an alternate pronunciation of your last name. 
For example, if your last name is “Smith,” you might enter “Smitty.”

Step 6 Click Add>>.

The name moves to a list of alternate last name pronunciations.

Step 7 Repeat Steps 5 and 6 as needed to add other alternate pronunciations.
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To remove an alternate pronunciation of your last name, click the alternate 
pronunciation and then click Remove.

Step 8 Click Save to apply the changes. 

Accessing Unified CM User Options page
To access the Unified CM User Options web page, perform the following steps: 

Procedure

Step 1 In the Unified CCX User Options Welcome web page, choose User Options > 
Cisco Unified CM User Page.

The Unified CM User Options Log On dialog box appears.

Step 2 Enter your Unified CM User ID and Password and click Log On.

The Unified CM User Options web page appears.

Step 3 Click the option you want.

Step 4 When finished, click Logout.
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System Menu

The System menu of the Unified CCX Administration system provides options for 
performing system-related tasks. Depending on the product package you 
purchased, the System menu contains some or all of the following menu options:

 • Server (see Server Menu Option, page 16-1)

 • Installation-based options:

 – Unified CM Configuration (see Unified CM Configuration Menu 
Option, page 16-3).

 – Unified CME Configuration (see Unified CME Configuration Menu 
Option, page 16-4).

 • System Parameters (see System Parameters Menu Option, page 16-4). 

 • Custom File Configuration (see Custom File Configuration Menu Option, 
page 16-5).

 • License Information (see License Information Menu Option, page 16-5).

 • Language Information (see Language Information Menu Option, 
page 16-7).

 • Logout (see Logout Menu Option, page 16-8).

Server Menu Option
Choose System > Server from the Cisco Unified CCX Administration menu bar 
to access the List Servers web page. Use the List Servers web page to view, add, 
remove, and view servers in the cluster. 
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To view, modify, or delete the server configuration information of any server, 
click the respective hyperlink in Host Name/IP Address field. The Server 
Configuration web page opens to display Host Name/IP Address, MAC Address, 
and Description of the server. Update the values in the fields and click Save to 
save the changes. Click Delete to delete the configuration information of a server.

Note You cannot delete the publisher. 

To configure a new server that needs to be added to the cluster in a High 
Availability setup, complete the following steps:

Procedure

Step 1 Click Add New icon that displays in the tool bar in the upper, left corner of the 
window or the Add New button that displays at the bottom of the window to add 
the new server from the List Servers web page. 

Note You can add only one additional server. If you have already installed two servers 
in the cluster or if you have a Unified CME deployment the server details of only 
one server is displayed in this web page and the Add New button is disabled. 

Note Host name change is not supported in Cisco Unified CCX 8.5(1)

The Server Configuration web page opens where you can specify values for the 
following fields: 

Step 2 Click Add to add details of the new server. 

Field Description

Host Name/IP 
Address

Host name or IP address of the new Unified CCX server to 
be added to the cluster. This is a mandatory field.

MAC Address MAC address of the new server.

Description Description for the new server.
16-2
Cisco Unified CCX Administration Guide, Release 8.5(1)



Chapter 16      System Menu
Unified CM Configuration Menu Option
Warning Before installing Unified CCX on the second node, you need to configure the 
second server using the procedure mentioned above. Installation of second 
node will fail if you fail to do this configuration.

Note You will see a warning message if you click the Add New button without having 
a High Availability license.

Related Topics 

 • Managing System Parameters, page 11-5

 • Configuring Default TTS Provider for the Unified CCX System, page 7-36

Unified CM Configuration Menu Option
Use the Unified CM Configuration web page to update the following information: 

 • Unified CM cluster

 • AXL authentication

 • Unified CM Telephony subsystem

 • RmCm Provider configuration from within Unified CCX. 

Choose System > Unified CM Configuration from the Unified 
CCX Administration menu bar to access the Unified CM Configuration web page. 

Related Topics

 • Modifying Cluster Information from Unified CCX, page 4-2

 • Modifying AXL Information, page 4-5

 • Modifying Unified CM Telephony Information, page 4-8

 • Modifying RmCm Provider Information, page 4-10

 • Configuring RmCm Provider, page 8-2

 • Provisioning Unified CM Telephony Subsystem, page 7-5
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Unified CME Configuration Menu Option
Use the Unified CME Configuration web page to update the following 
information: 

 • Unified CME cluster

 • Unified CME Telephony subsystem

 • AXL Service Provider configuration from within Unified CCX. 

Choose System > Unified CME Configuration from the Unified 
CCX Administration menu bar to access the Unified CME Configuration web 
page. 

Related Topic 

Introducing Unified CME for Unified CCX, page 5-1

System Parameters Menu Option
Use the System Parameters web page to configure system parameters such as port 
settings, locale settings for Cisco Agent Desktop, and set the default session 
timeout.

Choose System > System Parameters from the Unified CCX Administration 
menu bar to access the System Parameters Configuration web page. 

Related Topics 

 • Managing System Parameters, page 11-5

 • Configuring Default TTS Provider for the Unified CCX System, page 7-36

Note You can configure only RMI port in Unified CCX 8.5(1). RmCm TCP and Master 
Listener TCP ports are display only fields.
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Custom File Configuration Menu Option
Use the Custom Classes Configuration web page to specify the classpath for 
custom classes.

Choose System > Custom File Configuration from the Unified 
CCX Administration menu bar to access the Custom Classes Configuration area.

Related Topics 

 • Specify Custom Classpath Entries, page 10-17

License Information Menu Option
Use the License Information web pages to display the cluster licensing 
information and to upload additional licenses.

Choose System > License Information > Add License(s) or Display License(s) 
from the Cisco Unified CCX Administration menu bar to access the License 
Information web pages.

Related Topics 

 • Add License(s), page 16-6

 • Display Licenses, page 16-6

 • Viewing License Information, page 1-14

 • Unified CCX Licensing Packages, page A-1
16-5
Cisco Unified CCX Administration Guide, Release 8.5(1)

 



Chapter 16      System Menu
License Information Menu Option
Add License(s)
From the Unified CCX Administration menu bar, choose System > License 
Information > Add License(s). The License Information web page displays.

In the License File field, enter the path for the license file or click Browse to 
locate the license file. Select the required license file and click Open. Use this 
page to specify a license file and upload it to Unified CCX.

Related Topics

 • Display Licenses, page 16-6

 • Uploading Licenses, page 1-15

 • Viewing License Information, page 1-14

 • Unified CCX Licensing Packages, page A-1

Display Licenses
From the Unified CCX Administration menu bar, choose System > License 
Information > Display License(s). The License Information web page opens 
displaying the details of the Configured License such as the license type, number 
of IVR ports, number of seats, maximum number of agents, and so on.

Note The License Information page displayed on click of Display License(s) menu 
option will also specify the expiry date in case of time bound licenses.

From 8.5(1)SU3 release, the Licence Information web page displays a drop-down 
list with all licenses, active and expired, that have been configured in the system. 
When you choose a license from the list, the content of that license is displayed.

You can view the cumulative content of all the currently active licenses in the 
system by selecting Cumulative License Information from the drop-down list. 
This option also displays a breakup of the temporary and permanent license 
counts.

Related Topics

 • Add License(s), page 16-6
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 • Viewing License Information, page 1-14

 • Unified CCX Licensing Packages, page A-1

Language Information Menu Option
Customized Unified CCX languages such as American English, Canadian French, 
and so on are installed with Unified CCX. 

Use the Languages Configuration web page to:

 • Enable languages that can be used to play prompts and grammars through 
Cisco Unified IP IVR.

 • Configure the languages that you want to use with Cisco Unified Contact 
Center Express CAD and CSD.

Choose System > Language Information from the Cisco Unified CCX 
Administration menu bar to access the Languages Configuration web page. The 
Languages Configuration web page opens to display the following fields and 
buttons. 

 

Field Description

IVR Language Configuration

Language Language that you wish to use with Unified IP IVR. You can select the 
language from the drop-down list. You can also specify the group and 
country-specific information for the language by selecting the desired radio 
button and check box respectively. Some languages have only one choice. 
US English (en_US) is the default.

Default IVR Language Configuration

Default Language System default language setting, which could be either one of the selected 
IVR languages or country-specific or a user-defined language entered using 
the Edit button. This is a mandatory field and you can choose from the 
drop-down list. Click Edit to add a new Language option.

Default: English (United States) [en_US]

CAD/CSD Language Configuration
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Logout Menu Option
To exit Unified CCX Administration without closing your web browser, you can: 

 • Choose System > Logout from the Unified CCX Administration menu bar or 

 • Click Logout link displayed in the top right corner of any Cisco Unified CCX 
Administration web page.

The system logs you out of Unified CCX and displays the Unified CCX 
Authentication web page.

Note You can also exit Unified CCX Administration by closing your web browser. 

CAD/CSD Language Language that you wish to use with Cisco Agent Desktop (CAD) or Cisco 
Supervisor Desktop (CSD). You can configure this language by choosing 
from the drop-down list. 

Note If you are upgrading from CRS 4.5 to Unified CCX 8.5(1), ensure 
that you have the same CAD and CSD Language Selection settings 
as that of your CRS 4.5 system.

Update Click Update icon that displays in the tool bar in the upper, left corner of the 
window or the Update button that displays at the bottom of the window to 
save your changes.

Clear Click Clear icon that displays in the tool bar in the upper, left corner of the 
window or the Clear button that displays at the bottom of the window to 
restore the default settings.

Field Description
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Applications Menu

The Applications menu on the top contains the following menu options:

 • Application Management—to add, configure, copy, delete, or refresh a 
specific application (see Application Management Menu Option, page 17-1.)

 • Script Management—to add a new script and to view, refresh, upload, or 
delete an existing script (see Script Management, page 17-3.)

 • Prompt Management—to display, modify, or delete existing prompts, and 
to add new prompts (see Prompt Management, page 17-4.)

 • Grammar Management—to display, modify, or delete existing grammars, 
and to add new grammars (see Grammar Management, page 17-5.)

 • Document Management—to display, modify, or delete existing documents, 
and to add new documents (see Document Management, page 17-6.)

 • AAR Management—to upload AAR files to Unified CCX (see AAR 
Management, page 17-6.)

Application Management Menu Option
The Application Management menu option in the Unified CCX Administration 
web interface contains options for configuring and managing the applications the 
Unified CCX system uses to interact with contacts and perform a wide variety of 
functions. 
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To access the Application Management web pages, perform the following steps:

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Applications > 
Application Management.

The Applications Configuration web page opens displaying a list of applications 
that are currently configured on your Unified CCX server.

Step 2 Click Add New icon that displays in the tool bar in the upper, left corner of the 
window or the Add New button that displays at the bottom of the window to add 
a new application. Add a New Application web page opens.

Step 3 Select the type of application that you want to create from the Application Type 
drop-down list. See About Unified CCX Applications, page 6-1 to know more 
about the different application types available in Unified CCX and how to 
configure them.

Related Topics

 • Configuring Script Applications, page 6-2

 • Configuring Busy Application, page 6-7

 • Configuring Ring-No-Answer Application, page 6-9

 • Configuring Unified ICME Post-Routing Application, page 6-11

 • Configuring Unified ICME Translation-Routing Application, page 6-14

 • Adding Application Triggers, page 6-18

 • Application Availability by License Package, page A-2

 • Provisioning Unified ICME Subsystem, page 9-3
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Use the Script Management web page to add a new script and to rename, refresh, 
or delete an existing script. Unified CCX applications are based on scripts created 
in the Unified CCX Editor.

To access the Script Management web page, choose Applications > Script 
Management from the Unified CCX Administration menu bar. The Script 
Management web page opens displaying the default directory that contains the 
scripts uploaded to the repository. 

See Uploading New Scripts, page 6-26 section to view description for the various 
fields that are displayed in the Script Management web page for the default folder 
(if it already exists).

To create a new subfolder under the default folder, perform the following steps:

Procedure

Step 1 Click Create New Folder icon that displays in the tool bar in the upper, left 
corner of the window or the Create New Folder button that displays at the bottom 
of the window.

The Create New Folder dialog box opens. 

Step 2 Enter a name of the new subfolder in the Folder Name field and click Create. 

Once the folder is successfully created, the dialog box refreshes with the 
following message:

Folder successfully created

Step 3 Click Return to Script Management button to return to the default folder’s 
updated Script Management page. You can create any number of folders within 
the default folder.

Related Topics

 • About Unified CCX Applications, page 6-1

 • Viewing or Downloading a Script File, page 6-28

 • Refreshing Scripts, page 6-30

 • Sample Scripts, page 6-34
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Prompt Management
Several system-level prompt files are loaded during Unified CCX installation. 
However, any file you create needs to be made available to the Unified 
CCX Engine before a Unified CCX application can use them. This is done 
through the Unified CCX cluster’s Repository datastore, where the prompt files 
are created, stored, and updated. 

Note You can use a custom script or the Unified CCX Administration to upload 
a prompt.

To access the Prompt Management page, choose Applications > Prompt 
Management from the Unified CCX Administration menu bar.

The Prompt Management web page contains the following icons and buttons: 

 • Create Language—Click Create Language icon that displays in the tool bar 
in the upper, left corner of the window or the Create Language button that 
displays at the bottom of the window to create a new language folder (see 
Creating a New Language, page 10-9). 

 • Upload Zip Files—Click Upload Zip Files icon that displays in the tool bar 
in the upper, left corner of the window or the Upload Zip Files button that 
displays at the bottom of the window to upload a new prompt or zip file (see 
Upload Zip files to a Language Folder, page 10-11). 

See Managing Prompt Files, page 10-2 section to know more about the different 
fields in this page and how to rename, refresh, or delete existing prompts.

Related Topics

 • Managing Prompt Files, page 10-2

 • Managing Languages, page 10-9

 • Recording and Uploading Prompt Files, page 10-13

 • Managing Custom Files, page 10-17

 • Refreshing Scripts, page 6-30
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Grammar Management
Several system-level grammar files are loaded during Unified CCX installation. 
However, any file you create needs to be made available to the Unified CCX 
Engine before a Unified CCX application can use them. This is done through the 
Unified CCX cluster’s Repository datastore, where the grammar files are created, 
stored, and updated. 

To access the Grammar Management page, choose Applications > Grammar 
Management from the Unified CCX Administration menu bar.

The Grammar Management web page contains the following icons and buttons: 

 • Create Language—Click Create Language icon that displays in the tool bar 
in the upper, left corner of the window or the Create Language button that 
displays at the bottom of the window to create a new language folder (see 
Creating a New Language, page 10-9). 

 • Upload Zip Files—Click Upload Zip Files icon that displays in the tool bar 
in the upper, left corner of the window or the Upload Zip Files button that 
displays at the bottom of the window to upload a new grammar or zip file (see 
Upload Zip files to a Language Folder, page 10-11). 

See Managing Grammar Files, page 10-5 section to know more about the different 
fields in this page and how to rename, refresh or delete existing grammars. 

Related Topics

 • Managing Grammar Files, page 10-5

 • Managing Languages, page 10-9

 • Recording and Uploading Prompt Files, page 10-13

 • Managing Custom Files, page 10-17

 • Refreshing Scripts, page 6-30
17-5
Cisco Unified CCX Administration Guide, Release 8.5(1)

 



Chapter 17      Applications Menu
Document Management
Document Management
Several system-level document files are loaded during Unified CCX installation. 
However, any file you create needs to be made available to the Unified CCX 
Engine before a Unified CCX application can use them. This is done through the 
Unified CCX cluster’s Repository datastore, where the document files are 
created, stored, and updated. 

To access the Document Management page, choose Applications > Document 
Management from the Unified CCX Administration menu bar.

The Document Management web page contains the following icons and buttons: 

 • Create Language—Click Create Language icon that displays in the tool bar 
in the upper, left corner of the window or the Create Language button that 
displays at the bottom of the window to create a new language folder (see 
Creating a New Language, page 10-9). 

 • Upload Zip Files—Click Upload Zip Files icon that displays in the tool bar 
in the upper, left corner of the window or the Upload Zip Files button that 
displays at the bottom of the window to upload a new document or zip file 
(see Upload Zip files to a Language Folder, page 10-11). 

See Managing Document Files, page 10-7 section to know more about the 
different fields in this page and how to rename, refresh or delete existing 
documents. 

Related Topics

 • Managing Document Files, page 10-7

 • Managing Languages, page 10-9

 • Recording and Uploading Prompt Files, page 10-13

 • Managing Custom Files, page 10-17

 • Refreshing Scripts, page 6-30

AAR Management
Use the AAR Management web page to upload an AAR file to Unified CCX. 
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To access the AAR Management web page, choose Applications > AAR 
Management from the Unified CCX Administration menu bar. The AAR 
Management web page displays. See Uploading AAR Files, page 10-21 to know 
the procedure for uploading an AAR file.

Related Topic

Managing AAR Files, page 10-18 
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Subsystems Menu

The Subsystems menu of the Unified CCX Administration web interface provides 
access to the subsystems that are licensed for your Unified CCX system. 

The Unified CCX system uses subsystems for communicating with other services. 
Depending on the Unified CCX package you have installed, the Subsystems menu 
may contain some or most of the following menu options:

 • Telephony: Depending on the installation, you can select one of two options:

 – Cisco Unified CM Telephony—to enter Unified CM Telephony 
provider information, Computer Telephony Interface (CTI) port group 
information, Unified CM Telephony trigger information, and to 
resynchronize Unified CM Telephony information (see Unified CM 
Telephony Menu Option, page 18-2). 

 – Unified CME Telephony—to enter Unified CME Telephony provider 
information, Computer Telephony Interface (CTI) port group 
information, Unified CME Telephony trigger information, and to 
validate CME and Unified CCX data (see Unified CME Telephony Menu 
Option, page 18-8).

 • RmCm—to set up your Unified CCX resources (RmCm Menu Option, 
page 18-10).

 • Outbound—to configure contact centers for automated outbound activities 
(Outbound Menu Option, page 18-18).

 • ICM—to configure the Unified Intelligent Contact Management Enterprise 
(Unified ICME) subsystem to interact with Unified ICME software and to 
add new Voice Response Units (VRU) scripts (see Unified ICM Menu 
Option, page 18-25).
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 • Database—to configure the Unified CCX system to communicate with 
database servers (see Database Menu Option, page 18-27).

 • HTTP—to configure the Unified CCX Engine to respond to requests from a 
variety of web clients, including computers and IP phones (see HTTP Menu 
Option, page 18-30).

 • eMail—to configure the Unified CCX Engine to communicate with your 
e-mail server and enable your applications to create and send e-mail (see 
eMail Menu Option, page 18-31).

 • Cisco Media—to configure Cisco Media Termination (CMT) dialog groups 
that can be used to handle simple Dual-Tone Multi-Frequency (DTMF) based 
dialog interactions with customers (see Cisco Media Menu Option, 
page 18-32).

 • MRCP ASR—to configure the MRCP Automated Speech Recognition 
(ASR) subsystem, which allows users to navigate through a menu of options 
using spoken responses to prompts (see MRCP ASR Menu Option, 
page 18-33).

 • MRCP TTS—to configure the MRCP Text-to-Speech (TTS) subsystem, 
which converts plain text (UNICODE) into spoken words to provide a user 
with information or to prompt a user to respond to an action (see MRCP TTS 
Menu Option, page 18-35).

Unified CM Telephony Menu Option
The Unified CCX system uses the Unified CM Telephony subsystem of the 
Unified CCX Engine to send and receive call-related messages from the Unified 
CM Computer Telephony Interface (CTI) Manager.

To access the Unified CM Telephony Configuration web pages, choose 
Subsystems > Cisco Unified CM Telephony from the Unified 
CCX Administration menu bar. 
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The Unified CM Telephony Configuration menu contains the following submenu 
options:

 • Unified CM Telephony Provider—Choose this option to enter Unified CM 
Telephony provider information (see Unified CM Telephony Provider 
Configuration, page 18-3). 

 • Unified CM Telephony Call Control Group Configuration—Choose this 
option to configure CTI port groups for applications (see Unified CM 
Telephony Call Control Group Configuration, page 18-4).

 • Unified CM Telephony Trigger Configuration—Choose this option to 
configure Unified CM Telephony triggers for applications (see Unified CM 
Telephony Triggers Configuration, page 18-4).

 • Data Synchronization—Choose this option to check and synchronize data 
components like Unified CM Telephony Users (JTAPI Application Users), 
Unified CCX Triggers/Route points, and Call Control Groups between 
Unified CCX and Unified CM (see Unified CM Telephony Data 
Synchronization, page 18-5).

 • Cisco JTAPI Resync—Choose this option to resynchronize Cisco JTAPI 
Client versions (see Unified CM Telephony Cisco JTAPI Resync, page 18-6).

 • Advanced Settings—Choose this option to configure advanced settings for 
the Cisco Unified CM Telephony client (see Unified CM Telephony 
Advanced Settings, page 18-7). 

Unified CM Telephony Provider Configuration
To access this configuration area, choose Subsystems > Cisco Unified CM 
Telephony > Provider from the Unified CCX Administration menu bar. The 
Cisco Unified CM Telephony Provider web page opens.

Use the Unified CM Telephony Provider Configuration web page to view and 
modify the primary and secondary location of your Unified CM Telephony 
provider, and user prefix.

Related Topics

 • Modifying Unified CM Telephony Information, page 4-8

 • Provisioning Unified CM Telephony Subsystem, page 7-5

 • Additional Unified CM Telephony Information, page 7-22
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 • Resynchronizing Unified CM Telephony Information, page 7-22

Unified CM Telephony Call Control Group Configuration
Choose Subsystems > Cisco Unified CM Telephony > Call Control Group 
from the Unified CCX Administration menu bar to access the Unified CM 
Telephony Call Control Group list web page. Use the Unified CM Telephony Call 
Control Group Configuration web pages to display, add, modify, and delete 
information about the call control group.

To add a new Unified CM Telephony Call Control Group, click Add New icon or 
button on the Unified CM Telephony Call Control Group Configuration web 
page. 

To modify an existing Unified CM Telephony Call Control Group, click any 
hyperlink within the Ports List table entry; the Cisco Unified CM Telephony Call 
Control Group Configuration web page opens. 

Related Topics

 • Adding a New Unified CM Telephony Call Control Group, page 7-9

 • Additional Unified CM Telephony Information, page 7-22

Unified CM Telephony Triggers Configuration
Choose Subsystems > Cisco Unified CM Telephony > Unified CM Telephony 
> Triggers from the Cisco Unified CCX Administration menu bar to configure 
Unified CM Telephony Triggers. 

The Cisco Unified CM Telephony Trigger Configuration web page opens where 
you can view, add, modify, and delete Unified CM Telephony triggers. To add a 
Unified CM Telephony trigger, click Add New icon or button. The Cisco Unified 
CM Telephony Trigger Configuration web page opens.

Related Topics

 • Adding a Unified CM Telephony Trigger, page 7-16

 • Additional Unified CM Telephony Information, page 7-22

 • Adding Application Triggers, page 6-18
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Unified CM Telephony Data Synchronization
Since Unified CCX Release 8.5(1), you can configure the telephony data 
synchronization through a new web page called Cisco Unified CM Telephony 
Data Synchronization.

The data synchronization process ensures that data components like Unified CM 
Telephony Users (JTAPI Application Users), Unified CCX Triggers/Route 
points, and Call Control Groups between Unified CCX and Unified CM are in 
sync, without any inconsistency. 

Data Check displays whether the selected data components are in synch or not 
between Unified CCX and Unified CM. If you find any inconsistency, click Data 
Resync to rectify the issue. To check and synchronize the JTAPI data components 
between Cisco Unified CM and Cisco Unified CCX, perform the following steps:

Caution It is important that you plan to perform this task during off peak hours to avoid 
hampering routine contact center operations.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > Cisco 
Unified CM Telephony > Data Synchronization.

The Cisco Unified CM Telephony Data Synchronization page appears.

Step 2 Select one or more of the following three components by checking the 
corresponding check boxes:

 • Call Control Group(s)

 • Trigger(s)

 • CM Telephony User(s)

Step 3 Click Data Check or Data Resync. Once you click Data Check or Data Resync, 
a confirmation message dialog box appears prompting you to either proceed or 
cancel. Click OK to continue.

Note Once you click OK in the confirmation message for Data Check or Data 
Resync, you will not be allowed to cancel the process. 
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Step 4 The Cisco Unified CM Telephony Data Synchronization web page continues to 
update until the Data Check or Data Resync process is complete. On completion 
of the Data Check or Data Resync process, the result is displayed in the same web 
page in a tree structure. The result for each selected component is displayed in 
collapsed format with a tick mark if no mismatch is found. Click the arrow 
adjacent to each selected component to expand and view the detailed results. 

If any mismatch is found in the elements of the selected component, the results 
for those components are displayed automatically in an expanded format.

Note If you had multiple device pools (for Call Control Groups) in your older versions 
of Unified CCX setup, performing Data Resync after an upgrade (from an older 
version to Unified CCX 8.5(1)) would merge all multiple device pools to a single 
default device pool. However, you can manually assign a different device pool to 
the Call Control Group if the default device pool is not the intended one.

Related Topics

 • Resynchronizing Unified CM Telephony Data, page 7-7

 • Configuring a Unified CM Telephony Provider, page 7-7

 • Unified CM Telephony Provider Configuration, page 18-3

Unified CM Telephony Cisco JTAPI Resync
Choose Subsystems > Cisco Unified CM Telephony > Cisco JTAPI Resync 
from the Cisco Unified CCX Administration menu bar to resynchronize the 
JTAPI client version on the Unified CCX with the JTAPI version on the Unified 
CM. You can view the status of Cisco JTAPI client resynchronization in this web 
page.

If the Unified CCX detects a mismatch, the system downloads and installs the 
compatible or JTAPI client. required installer version. Restart the Unified CCX 
engine to view these configuration changes. 

The JTAPI client update happens only on the local node and not on the second 
node in case of High Availability deployment.

Related Topics

 • Resynchronizing Unified CM Telephony Data, page 7-7
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 • Configuring a Unified CM Telephony Provider, page 7-7

 • Unified CM Telephony Provider Configuration, page 18-3

Unified CM Telephony Advanced Settings
Choose Subsystems > Cisco Unified CM Telephony > Advanced Settings from 
the Cisco Unified CCX Administration menu bar to configure advanced settings 
for the Unified CM Telephony Client. 

Note This will be available only in Unified CM deployment of Unified CCX. 

Use the Unified CM Telephony Advanced Settings web page to update the 
following information: 

 • Periodic Wakeup Interval (seconds): Select the check box before Enable 
Periodic Wakeup prior to updating the existing value in this field.

 • Queue Size Threshold: Select the check box before Enable Queue Stats prior 
to updating the existing value in this field.

 • CTI Request Timeout (sec)

 • Provider Open Request Timeout (sec)

 • Provider Retry Interval (sec)

 • Server Heartbeat Interval (sec)

 • Route Select Timeout (ms)

 • Post Condition Timeout

 • Use Progress As Disconnect

Click Update icon that displays in the tool bar in the upper, left corner of the 
window or the Update button that displays at the bottom of the window to save 
the changes. Restart the Unified CCX engine to view these configuration changes.

In case of High Availability deployment, the changes are propagated to the second 
node. If the second node cannot be contacted, an alert message indicating that the 
update has failed on the remote node is displayed.

Related Topics

 • Resynchronizing Unified CM Telephony Data, page 7-7
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 • Configuring a Unified CM Telephony Provider, page 7-7

 • Unified CM Telephony Provider Configuration, page 18-3

Unified CME Telephony Menu Option
The Unified CCX system uses the Unified CME Telephony subsystem of the 
Unified CCX Engine to send and receive call-related messages from the Unified 
CME CTI Manager.

To access the Unified CME Telephony Configuration web pages, choose 
Subsystems > Unified CME Telephony from the Unified CCX Administration 
menu bar. 

The Unified CME Telephony Configuration navigation bar contains the following 
submenu options:

 • Unified CME Telephony Provider—Choose this option to enter Unified 
CME Telephony provider information (see Unified CME Telephony Provider 
Configuration, page 18-8). 

 • Unified CME Telephony Call Control Groups—Choose this option to 
configure CTI port groups for applications (see Unified CME Telephony Call 
Control Group Configuration, page 18-9).

 • Unified CME Telephony Triggers—Choose this option to configure 
Unified CME Telephony triggers for applications (see Unified CME 
Telephony Triggers Configuration, page 18-9).

 • Validate Unified CME in Unified CCX Data—Choose this option to 
resynchronize Unified CCX with Unified CM (see Validate Unified CME in 
Unified CCX Data, page 18-10).

Unified CME Telephony Provider Configuration
To access this configuration area, choose Subsystems > Unified CME 
Telephony > Provider from the Unified CCX Administration menu bar. 

Use the Unified CME Telephony Provider Configuration web page to enter the 
location of your Unified CME Telephony provider, user ID, and password. 
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Related Topics

 • Configuring a Unified CME Telephony Provider, page 5-9

 • Adding or Modifying a Unified CME Telephony Trigger, page 5-11

Unified CME Telephony Call Control Group Configuration
Use the Unified CME Telephony Call Control Group Configuration web pages to 
display, add, modify, and delete information about the call control group.

Choose Subsystems > Unified CME Telephony > Call Control Group from the 
Unified CCX Administration menu bar to access the Unified CME Telephony 
Call Control Group web page. 

Related Topics

 • Verifying Licenses, page 5-5

 • Modifying Unified CME Telephony Call Control Group, page 5-10

Unified CME Telephony Triggers Configuration
Choose Subsystems > Unified CME Telephony > Triggers from the Unified 
CCX Administration menu bar to access the Unified CME Telephony Triggers 
Configuration web page.

You can display, add, modify, and delete information about Unified CME 
Telephony triggers using this configuration page.

To add a Unified CME Telephony trigger, click Add a New CME Telephony 
Trigger icon or button on the Unified CME Telephony Triggers Configuration 
web page; the Unified CME Telephony Triggers Configuration page opens.

Related Topics

 • Configuring a Unified CME Telephony Provider, page 5-9

 • Adding or Modifying a Unified CME Telephony Trigger, page 5-11
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Validate Unified CME in Unified CCX Data
To access this configuration area, Choose Subsystems > Unified CME 
Telephony > Validate Unified CME in Unified CCX Data from the Unified 
CCX Administration menu bar.

Related Topics

 • Introducing Unified CME for Unified CCX, page 5-1

 • Validating Unified CME and Unified CCX Data, page 5-8

RmCm Menu Option
Use the RmCm Configuration web page to configure skills groups, resources, 
resource groups, Contact Service Queues (CSQs), and RM (Resource Manager) 
Unified CM Telephony providers. To access the Unified CCX Configuration web 
page, choose Subsystems > RmCm from the Unified CCX Administration menu 
bar.

The RmCm menu contains the following submenu options:

 • Skills—Click this submenu to create skills. This option is available only with 
the Unified CCX Enhanced and Unified CCX Premium license packages (see 
Skill Configuration, page 18-11).

 • Resources—Click this submenu to assign a resource group and skills to 
agents (see Resources Configuration, page 18-12). 

 • Resource Groups—Click this submenu to create resource groups (see 
Resource Group Configuration, page 18-13).

 • Contact Services Queues (CSQs)—Click this submenu to configure CSQs 
(see Contact Service Queues Configuration, page 18-14). 

 • RmCm Provider—Click this submenu to configure the RM (Resource 
Manager) Unified CM Telephony provider for the RmCm subsystem (see 
RmCm Provider Configuration, page 18-15). 

 • Assign Skills—Click this submenu to assign skills and a resource group to 
agents in bulk (see Assign Skills Configuration, page 18-15).
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 • Remote Monitor—Click this submenu to associate agents and CSQs that 
will be monitored by supervisors (see Remote Monitor Configuration, 
page 18-16).

 • Agent Based Routing Settings—Click this submenu to send a call to a 
specific agent, rather than to any agent available in a CSQ (see Agent Based 
Routing Settings Configuration, page 18-17).

 • Teams—Click this submenu to create or associate teams with various agents, 
CSQs, and supervisors (see Teams Configuration, page 18-17).

For details on the maximum number of agents, skills, and CSQs that you can 
configure on your system, see About Unified CCX, page 3-2.

Skill Configuration
Use the Skills page to add, modify, or delete skill. 

Choose Subsystems > RmCm > Skills from the Unified CCX Administration 
menu bar to access the Skills summary web page.

Related Topic

Configuring Skills, page 8-7

Adding a New Skill

Use the Skill Configuration area to add a new skill name. 

Click Add New icon that displays in the tool bar in the upper, left corner of the 
window or the Add New button that displays at the bottom of the window to 
access the Skill Configuration area. 

Related Topic

Creating a Skill, page 8-7
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Modifying Skills

Click the required skill in the Skill name column on the Skill Configuration web 
page to access the Skill Configuration area. 

Click Open Printable Report of this Skill Configuration icon to view a list of 
the resources associated with that skill.

Related Topics

 • Modifying an Existing Skill Name, page 8-8

 • Deleting a Skill, page 8-9

Resources Configuration
Use the Resources Configuration area to assign a resource group and skills to a 
resource. 

To access this configuration area, choose Subsystems > RmCm > Resources 
from the Unified CCX Administration menu bar. The main area of the Resources 
area of the Unified CCX Configuration web page contains a list of resources (if 
configured).

Click Open Resources Summary Report icon to open the Resources Summary 
Report in a new window. For each resource, this report lists the resource groups 
associated with the resource, the Unified CCX extension of the resource, and the 
number of CSQs and team to which the resource is assigned.

Related Topic

 • Configuring Agents, page 8-10

 • Configuring Contact Service Queues, page 8-17

Modifying a Resource

Use the Resource Configuration area to modify resource configuration. 

To access the Resource Configuration area, click any of the required resource in 
the Resource area of the Unified CCX Configuration summary web page. 
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Click Open Printable Report of this Resource Configuration icon to open a 
Resource Report for the agent. The Resource Report lists each agent’s resource 
ID, resource name, Unified CCX extension, resource group, automatic available 
status, skills, CSQs, and team.

Related Topic

 • Assigning Resource Groups and Skills to One Agent, page 8-12

 • Removing Skills from Agents, page 8-16

Resource Group Configuration
Use the Resource Group Configuration web page to display and modify the names 
of existing resource groups and to add new resource groups.

Choose Subsystems > RmCm > Resource Groups from the Unified 
CCX Administration menu bar to access the Resource Groups web page.

Related Topic

Configuring Resource Groups, page 8-4

Adding a New Resource Group

Use the Resource Configuration area to enter resource group name in the 
Resource Group Name field.

Add a new Resource Groups by clicking Add New icon or button in the Resource 
Group area of the Unified CCX Configuration web page. 

Related Topic

Creating a Resource Group, page 8-4

Modifying Existing Resource Groups

Use the Resource Modification page to change or update the resource group name 
into the Resource Group Name field.
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Modify an existing Resource Group by clicking the required resource group in the 
Resource Groups area. In the Resource Group Configuration area, change the 
Resource Group and update.

Click Open Printable Report of this Resource Group Configuration icon to 
view a list of the available resources for this resource group.

Related Topics

 • Modifying an Existing Resource Group Name, page 8-5

 • Deleting a Resource Group, page 8-6

Contact Service Queues Configuration
Use the Contact Service Queues area of the Unified CCX Configuration web page 
to display existing CSQs, delete a CSQ, and add a new CSQ.

To access the Contact Service Queues area, choose Subsystems > RmCm > 
Contact Service Queues from the Unified CCX Administration menu bar. 

Related Topic

Configuring Contact Service Queues, page 8-17

Adding a CSQ

Use the Contact Service Queues Configuration area to add a new CSQ.

To access the Contact Service Queues Configuration area, click Add New icon or 
button in the Contact Service Queues area of the Unified CCX Configuration web 
page. 

To open the Contact Service Queue Report for the required CSQ, click Open 
Printable Report of this CSQ Configuration icon from the Contact Service 
Queues Configuration area.

Related Topics

 • Creating a CSQ, page 8-18

 • Modifying an Existing CSQ, page 8-24

 • Deleting a CSQ, page 8-25
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 • Resource Pool Selection Criteria: Skills and Groups, page 8-26

 • Resource Skill Selection Criteria Within a CSQ, page 8-28

RmCm Provider Configuration
Use the RmCm Provider area of the Unified CCX Configuration web page to 
identify the Unified CM Telephony user for the Resource Manager.

Choose Subsystems > RmCm > RmCm Provider from the Unified 
CCX Administration menu bar to access the RmCm Provider web page.

Related Topics

 • Configuring Agents, page 8-10

 • Modifying RmCm Provider Information, page 4-10

 • Invoking Unified CM Administration, page 4-13

 • Defining Unified CM Users as Agents, page 4-13

Assign Skills Configuration
Use the Assign Skills area of the Unified CCX Configuration web page to modify 
an existing resource group and skill configuration or to assign new resource 
groups and skills to all or selected agents.

Choose Subsystems > RmCm > Assign Skills from the Unified 
CCX Administration menu bar to access this configuration area.

This web page also contains the following icons and buttons:

 • Add Skill—to add new skills or resource groups to all or selected agents (see 
Adding Skills, page 18-16).

 • Remove Skill—to remove skills of all or selected agents (see Removing 
Skills, page 18-16).

Related Topic

Configuring Skills, page 8-7
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Adding Skills

When you click Add Skill button in the Assign Skills area of the Unified CCX 
Configuration web page, the Add Skill area opens. Use the Add Skill area to add 
a resource group and skills to the selected agents.

Related Topic

Assigning Resource Groups and Skills to Multiple Agents, page 8-14

Removing Skills

When you click Remove Skill button in the Assign Skills area of the Unified CCX 
Configuration web page, the Remove Skill area opens. Use the Remove Skill area 
to remove skills of all or selected agents.

Related Topic

Removing Skills from Agents, page 8-16

Remote Monitor Configuration
Use the Remote Monitor area of the Unified CCX Configuration web page to 
specify the monitoring method: by agent or by CSQ.

Choose Subsystems > RmCm > Remote Monitor from the Unified 
CCX Administration menu bar to access this configuration area.

Related Topics

 • Configuring and Using Remote Monitoring, page 8-30

 • Creating a Remote Monitoring Supervisor, page 8-31

 • Assigning Resources and CSQs to a Supervisor, page 8-32

 • Configuring Remote Monitoring Application, page 6-16.

 • Viewing CSQ IDs for Remote Monitoring, page 15-8
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Assigning Resources and CSQs to a Remote Supervisor

Use the Remote Monitor configuration web page to assign a Supervisor a list of 
Resources and CSQs that he/she is allowed to monitor.

To access the Remote Monitoring Configuration web page, click a User ID value. 

Related Topics

 • Configuring and Using Remote Monitoring, page 8-30

 • Creating a Remote Monitoring Supervisor, page 8-31

 • Assigning Resources and CSQs to a Supervisor, page 8-32

 • Configuring Remote Monitoring Application, page 6-16.

 • Viewing CSQ IDs for Remote Monitoring, page 15-8

Agent Based Routing Settings Configuration
Use the Agent Based Routing Settings area of the Unified CCX Configuration 
web page to configure Automatic Work and Wrapup Time.

Choose Subsystems > RmCm > Agent Based Routing Settings from the Unified 
CCX Administration menu bar to access this configuration area.

Related Topic

Configuring Agent-Based Routing, page 8-34

Teams Configuration
Use the Teams area of the Unified CCX Configuration web page to create or 
associate teams with various agents, CSQs, and supervisors.

Choose Subsystems > RmCm > Teams from the Unified CCX Administration 
menu bar to access this configuration area.

Related Topics

 • Configuring Teams, page 8-35

 • Creating a Team Supervisor, page 8-36
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Adding a New Team 

Click Add New icon or button on the Teams summary web page. The Team 
Configuration page appears. 

Click Open Printable Report of this Team Configuration icon in the Teams 
web page to open the report in a new window and send it to a printer.

Related Topics

 • Creating a Team Supervisor, page 8-36

 • Creating Teams, page 8-37

 • Modifying Agents on Teams, page 8-39

 • Deleting a Team, page 8-39

Outbound Menu Option
Use the Outbound Configuration web page to provision outbound dialing 
functionality feature in Cisco Unified Preview Outbound Dialer Express 
(Outbound).

The Outbound menu option will be displayed when you upload the Cisco Unified 
Premium license.

This section contains the following options:

 • General Configuration, page 18-19

 • Campaign Configuration, page 18-19

 • Area Code Management, page 18-21

 • SIP Gateway Configuration, page 18-22

Related Topic

Configuring Unified CCX Outbound Dialer
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General Configuration
Choose Subsystems > Outbound > General from the Cisco Unified CCX 
Administration menu bar to access the General Configuration web page. 

Use this web page to add or modify Outbound dialing preferences.

Related Topics

 • Configuring Unified CCX Outbound Dialer, page 13-1

 • Configuring General Outbound Properties, page 13-18

 • Campaign Configuration, page 18-19

 • Area Code Management, page 18-21

 • Add New Campaigns, page 18-20

 • Delete Contacts, page 18-21

 • Add New Area Code, page 18-22

Campaign Configuration
Choose Subsystems > Outbound > Campaigns from the Cisco Unified CCX 
Administration menu bar to access the Campaigns web page. You can create and 
schedule campaign, modify the settings that apply to campaign, and import a list 
of contacts (in bulk from a text file) into the Unified CCX database for each 
campaign using this web page. 

In Unified CCX Release 8.5(1), you can define any one of the following two types 
for a campaign:

 • Agent based - If you select this campaign type, all the outbound calls will be 
handled by the available agents

 • IVR based - In this campaign type, the outbound calls will be handled by the 
IVR scripts.

Note The existing campaigns will be marked as Agent based after an upgrade from 
Unified CCX versions prior to 8.5(1).
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Related Topics

 • Add New Campaigns, page 18-20

 • Import Contacts, page 18-20

 • Delete Contacts, page 18-21

Add New Campaigns

To configure the properties for the campaign, including the campaign name and 
description, personal callback settings, skill group selection, and the time range, 
click Add New icon or button in the Campaigns web page.

Related Topics

 • Adding a New Campaign, page 13-31

 • Import Contacts, page 18-20

 • Delete Contacts, page 18-21

 • Add New Area Code, page 18-22

Import Contacts

To import contacts for a selected campaign, click the hyperlink for the required 
campaign under the Name column and click Import Contacts button. This will 
open Import Contacts window through which you can import contacts.

The Open Printable Report for this Campaign Configuration icon provides 
following information for the selected campaign in addition to call-specific 
information, which varies depending on the selected dialer type for outbound 
IVR:

 • Campaign Name

 • Enabled - Yes or No

 • Description

 • Start Time of the campaign

 • End Time of the campaign

 • Contact Records Cache Size

 • Remaining Contacts
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Related Topics

 • Importing Contacts for a Campaign, page 13-39

 • Add New Campaigns, page 18-20

 • Delete Contacts, page 18-21

 • Add New Area Code, page 18-22

Delete Contacts

To ensure that a contact does not get called again for subsequent campaigns, you 
must delete the contact from all campaigns to which it belongs.

Click Delete All Contacts icon or button in the Campaign Configuration web 
page to delete all contacts of a particular campaign. Once you click Delete All 
Contacts, you will see a dialog box with the following message - “This campaign 
will be disabled and all its contacts will be permanently deleted. Continue?" with 
OK and Cancel buttons. 

If you click OK, the outbound subsystem checks whether the contacts are used in 
an active outbound IVR campaign. If the contacts are used as part of an active 
Outbound IVR campaign, then you will see the following alert message in the 
status bar on top of the Campaign Configuration web page - "Campaign is active. 
Cannot remove contacts from an active campaign. Disable the campaign and try 
again." In such cases, disable the campaign first and then try deleting all contacts. 
Click Cancel if you do not want to delete all contacts for the specific campaign.

Related Topics

 • Handling Do Not Call Contacts, page 13-59

 • Add New Campaigns, page 18-20

 • Import Contacts, page 18-20

 • Add New Area Code, page 18-22

Area Code Management
Use this page to manually add new area codes, update existing area codes, and to 
add international area codes. 
18-21
Cisco Unified CCX Administration Guide, Release 8.5(1)

 



Chapter 18      Subsystems Menu
Outbound Menu Option
Related Topics

 • Adding Area Codes, page 13-42

 • General Configuration, page 18-19

 • Campaign Configuration, page 18-19

 • Add New Campaigns, page 18-20

 • Delete Contacts, page 18-21

 • Add New Area Code, page 18-22

Add New Area Code

The Area Codes Management page allows you to find, add, delete, and modify the 
mapping of area codes and time zones. The dialer uses the area code of a contact’s 
phone number to determine the time zone of the contact’s calling area. 

Related Topics

 • Adding Area Codes, page 13-42

 • General Configuration, page 18-19

 • Area Code Management, page 18-21

 • Chapter 13, “Configuring Unified CCX Outbound Dialer”

 • Add New Campaigns, page 18-20

 • Delete Contacts, page 18-21

SIP Gateway Configuration
Choose Subsystems > Outbound > SIP Gateway from the Cisco Unified CCX 
Administration menu bar to access the SIP Gateway Configuration page. You can 
use the SIP Gateway Configuration web page to add or modify the parameters that 
enable the outbound subsystem of Unified CCX to communicate with the SIP 
gateway. You can also update the parameters specific to Call Progress Analysis 
functionality of the gateway using this web page. 
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Call Progress Analysis is a feature of the SIP gateway by which it determines 
whether the outcome of a call is an answering machine, live voice, fax, or beep 
tone and so on. The SIP gateway performs call progressive analysis of the call and 
informs the outcome of the call to Unified CCX.

Note The SIP Gateway is used by the outbound subsystem to place calls only in case of 
IVR campaigns. Hence, it is mandatory to configure the SIP Gateway if you want 
to make Outbound IVR Campaigns.

Follow the procedure mentioned below to configure the SIP gateway parameters 
through Unified CCX Administration web interface: 

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > 
Outbound > SIP Gateway Configuration.

The SIP Gateway Configuration area opens. Use this web page to view or update 
values in the following fields.

Field Description

Gateway Configuration

Gateway Hostname/IP Address The HostName or IP Address of the SIP Gateway in the 
Unified CCX server, which will be used by the outbound 
subsystem to place calls for the predictive or progressive 
campaigns.

Gateway Port The SIP port used by the gateway to communicate with 
Unified CCX. The default value is 5060.

Local CCX Port The port number to be used on the Unified CCX server to 
communicate with the gateway. The default value is 5060.

Local User Agent This read-only field provides a description of the owner for 
this connection. The default value is Cisco-UCCX/8.0.
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Step 2 Click Update to save the configuration changes. The new SIP gateway 
configuration is added to the Unified CCX system. 

Transport(TCP/UDP) The protocol required to send SIP messages. You can select 
any one of the following protocols: 

 • TCP - Transport Control Protocol or 

 • UDP - User Datagram Protocol

The default value is UDP.

Call Progress Analysis Configuration (displays the Parameter Name, Parameter Value, and 
Suggested Value for the following fields)

Minimum Silence Period (10-1000) The amount of time that the signal must be silent after speech 
detection to declare a live voice (in milliseconds). 

Default = 375 milliseconds, Range = 10-1000 milliseconds

Analysis Period (1000 - 0000) Maximum amount of time (from the moment the system first 
detects the speech) during which analysis will be performed 
on the input audio. 

Default = 2500 milliseconds, Range = 1000-10000 
milliseconds

Maximum Time Analysis 
(1000-10000)

The amount of time to wait when it is difficult for the dialer 
to determine voice or answering machine. 

Default = 3000 milliseconds, Range = 1000-10000 
milliseconds

Minimum Valid Speech Time (50-500) Amount of time that the energy must be active before being 
declared speech. Anything less is considered as a glitch. 

Default = 112 milliseconds, Range = 50-500 milliseconds

Maximum Term Tone Analysis 
(1000-60000)

This is the amount of time the gateway will look for a 
terminating beep once an answering machine has been 
detected. 

Default = 15000 milliseconds, Range = 1000-60000 
milliseconds

Field Description
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Click Cancel to restore the default settings.

Related Topics

 • Configuring General Outbound Properties, page 13-18

 • Campaign Configuration, page 18-19

 • Area Code Management, page 18-21

 • Add New Campaigns, page 18-20

Unified ICM Menu Option
Use the Intelligent Contact Manager (ICM) Configuration web pages to add or 
modify Unified ICME configuration parameters and to modify VRU script 
information.

Related Topics

 • Provisioning Unified ICME Subsystem, page 9-3

 • Configuring General Unified ICME Information, page 9-4

 • Configuring Unified ICME VRU Scripts, page 9-7

 • Unified Gateway Auto-Configuration Details, page 8-40

 • Configuring Unified ICME Post-Routing Application, page 6-11

 • Configuring Unified ICME Translation-Routing Application, page 6-14

Unified ICME Configuration

Note If you are using Unified CCX with Cisco Contact Center Gateway solution, see 
the Cisco IPCC Gateway Deployment Guide for Cisco Unified ICME/CCE/CCX. 
The instructions for configuring Unified CCX with that solution differs from what 
is described in this guide. The Unified Gateway provides for the integration of the 
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Unified ICME system with Unified CCX by way of the Unified Gateway. The 
Unified Gateway is a Peripheral Gateway (PG) which you configure on the 
Unified ICME software. 

Use the General area of the Unified ICME Configuration page to add or modify 
Unified ICME configuration parameters.

To configure the Unified ICME subsystem, choose Subsystems > ICME > 
General from the Unified CCX Administration menu bar to access the Unified 
ICME Configuration web page.

Related Topics

 • Provisioning Unified ICME Subsystem, page 9-3

 • Configuring General Unified ICME Information, page 9-4

 • Configuring Unified ICME VRU Scripts, page 9-7

 • Unified Gateway Auto-Configuration Details, page 8-40

 • Configuring Unified ICME Post-Routing Application, page 6-11

 • Configuring Unified ICME Translation-Routing Application, page 6-14

Unified ICME VRU Scripts 
Unified ICME uses Unified ICME Voice Response Unit (VRU) scripts to handle 
interaction with contacts. These scripts are loaded as applications on the Unified 
CCX Engine. 

Choose Subsystems > ICME > ICME VRU Scripts from the Unified 
CCX Administration menu bar to access the ICME VRU Scripts web page.

Related Topics

 • Provisioning Unified ICME Subsystem, page 9-3

 • Configuring General Unified ICME Information, page 9-4

 • Configuring Unified ICME VRU Scripts, page 9-7

 • Unified Gateway Auto-Configuration Details, page 8-40

 • Configuring Unified ICME Post-Routing Application, page 6-11

 • Configuring Unified ICME Translation-Routing Application, page 6-14
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Add a New VRU Script

To add a new VRU Script, click Add New icon that displays in the tool bar in the 
upper, left corner of the window or the Add New button that displays at the 
bottom of the window on the ICME VRU Scripts web page. 

To modify a VRU script, click any hyperlink within the VRU Script list table 
entry; the ICME VRU Scripts web page opens displaying the list of VRU Scripts 
in the Scripts drop-down box. Click Update to save the changes.

Related Topics

 • Provisioning Unified ICME Subsystem, page 9-3

 • Configuring General Unified ICME Information, page 9-4

 • Configuring Unified ICME VRU Scripts, page 9-7

 • Unified Gateway Auto-Configuration Details, page 8-40

 • Configuring Unified ICME Post-Routing Application, page 6-11

 • Configuring Unified ICME Translation-Routing Application, page 6-14

Database Menu Option
The Unified CCX system uses the Database subsystem of the Unified CCX 
Engine to communicate with database servers, to obtain information that can be 
relayed to callers or to make application decisions. The Database subsystem 
enables the Unified CCX applications to obtain information from data sources, 
which are databases configured to communicate with the Unified CCX system. 

The Database menu contains the following options, which are explained below:

 • Datasource

 • Parameters

 • Drivers

Related Topics

 • DataSource, page 18-28

 • Adding a New Database Parameter, page 18-29

 • Configuring Database Subsystem, page 9-13
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 • About Additional Subsystems, page 9-2

 • Provisioning Unified ICME Subsystem, page 9-3

 • Provisioning HTTP Subsystem, page 9-10

 • Provisioning Database Subsystem, page 9-12

 • Provisioning eMail Subsystem, page 9-16

DataSource
Use the DataSources web page to add a new data source, display, modify, or 
delete existing datasources.

Choose Subsystems > Database > DataSource from the Cisco Unified CCX 
Administration menu bar to access the DataSources web page. 

Related Topics

 • Adding a New Database Parameter, page 18-29

 • About Additional Subsystems, page 9-2

Adding a New DataSource 

From the DataSources web page, click Add New icon that displays in the tool bar 
in the upper, left corner of the window or the button that displays at the bottom of 
the window to add a new data source.

The Datasource Configuration web page opens. 

For instructions on Adding a new Datasource, see Adding a New DataSource, 
page 9-14.

Related Topics

 • Adding a New Database Parameter, page 18-29

 • Configuring Database Subsystem, page 9-13

 • About Additional Subsystems, page 9-2
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Adding a New Database Parameter
To add a new database parameter, choose Subsystems > Database > Parameter 
from the Unified CCX Administration menu bar. The Parameters web page 
displays. See Polling Database Connectivity, page 9-15 section to know more 
about how to update parameter-related fields.

Related Topics

 • Configuring Database Subsystem, page 9-13

 • About Additional Subsystems, page 9-2

 • Adding a New DataSource, page 18-28

Driver
Use the Driver List web page to upload new drivers, or to view and delete existing 
drivers. 

Adding a New Database Driver
Follow the steps mentioned below to add a new jdbc driver:

Procedure

Step 1 From the Unified CCX Administration menu bar, choose Subsystems > 
Database > Drivers.

The Driver List web page opens up displaying a list of uploaded driver class file 
names along with a Delete icon. 

Step 2 Click Add New icon that displays in the tool bar in the upper, left corner of the 
window or the Add New button that displays at the bottom of the window to add 
a new driver class name. The Driver Management web page opens. 

Step 3 Specify a valid JDBC driver jar file in the Driver File field or click Browse to 
locate the driver file. The driver file is validated before uploading.

Step 4 Choose the supported class name for the new driver from the Driver Class Name 
drop-down list box.
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Step 5 Click Upload to save the new driver to the database.

Tip • Contact your database vendor to know the appropriate JDBC driver 
version(s) that is compatible with your Enterprise database server. Though 
multiple jdbc driver versions are supported, the following table lists the 
JDBC drivers that have been tested with different databases.

 • While uploading com.ibm.db2.jcc.DB2Driver, if your IBM DB2 deployment 
also requires a license Jar to be in the application's classpath, upload the 
license Jar as a Custom Jar File using the procedure detailed in Specify 
Custom Classpath Entries, page 10-17. Then, restart the UCCX Engine on all 
nodes through Unified CCX Serviceability.

Table 18-1 JDBC Driver Versions Tested with Enterprise Databases

Related Topics

 • Adding a New DataSource, page 9-14

 • About Additional Subsystems, page 9-2

HTTP Menu Option
The Unified CCX system uses the HTTP subsystem of the Unified CCX Engine 
to add components to the Unified CCX Engine that allow applications to be 
triggered in response to requests from a variety of web clients, including 
computers and IP phones. 

Databases Tested JDBC Drivers

Oracle 10g R2 ojdbc14.jar

Oracle 10g XE ojdbc14.jar

Sybase Adaptive Server 12 jTDS 1.2.2, jconn2.jar 

IBM DB2 8.2 db2jcc4.jar

MS SQL Server 2000 jTDS 1.2.2

MS SQL Server 2005 jTDS 1.2.2

MS SQL Server 2008 jTDS 1.2.5
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Related Topics

 • Provisioning HTTP Subsystem, page 9-10

 • Adding Application Triggers, page 6-18

HTTP Configuration
Use the HTTP Trigger Configuration web pages to display, add, modify, and 
delete existing HTTP triggers. 

Choose Subsystems > HTTP from the Cisco Unified CCX Administration menu 
bar to access the HTTP Trigger Configuration web page. 

Related Topics

 • Provisioning HTTP Subsystem, page 9-10

 • Adding Application Triggers, page 6-18

Add a New HTTP Trigger 
To add a new HTTP trigger, click Add New icon or button on the HTTP Trigger 
Configuration web page to access the HTTP Trigger Configuration web page. 

To modify an existing trigger, click any hyperlink within the HTTP Trigger List 
table; the HTTP Trigger Configuration page opens. 

Related Topics

 • Provisioning HTTP Subsystem, page 9-10

 • Adding Application Triggers, page 6-18

eMail Menu Option
The Unified CCX system uses the eMail subsystem of the Unified CCX Engine 
to communicate with your e-mail server and enable your applications to create 
and send e-mail. The e-mail configuration identifies the default e-mail address 
and server to be used for sending e-mail (including e-pages and faxes) and for 
receiving acknowledgments. 
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Choose Subsystems > eMail from the Cisco Unified CCX Administration menu 
bar to access the eMail Configuration web page. You need to configure e-mail 
functionality so that Unified CCX scripts created with the e-mail steps will 
function correctly. 

Related Topics

 • About Additional Subsystems, page 9-2

 • Provisioning Unified ICME Subsystem, page 9-3

 • Provisioning HTTP Subsystem, page 9-10

 • Provisioning Database Subsystem, page 9-12

 • Provisioning eMail Subsystem, page 9-16

Cisco Media Menu Option
Choose Subsystems > Cisco Media from the Unified CCX Administration menu 
bar to access the Cisco Media Termination Dialog Group Configuration web 
page.

The Unified CCX system uses the Media subsystem of the Unified CCX Engine 
to configure Cisco Media Termination (CMT) dialog groups that can be used to 
handle simple Dual-Tone Multi-Frequency (DTMF) based dialog interactions 
with customers. A dialog group is a pool of dialog channels in which each channel 
is used to perform dialog interactions with a caller.

To modify an existing CMT dialog group, click any hyperlink within the trigger’s 
summary table entry; Cisco Media Termination Dialog Group Configuration web 
page opens. 

To add a new CMT dialog group, click Add New icon or button in the Cisco 
Media Termination Dialog Group Configuration web page. The Cisco Media 
Termination Dialog Group Configuration web page opens.

Related Topics

 • Provisioning Cisco Media Subsystem, page 7-23

 • Adding a CMT Dialog Control Group, page 7-24
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MRCP ASR Menu Option
The Unified CCX system uses the MRCP ASR (Automatic Speech Recognition) 
subsystem to allow navigation through a menu of options by speaking instead of 
pressing keys on a touch-tone telephone. 

The MRCP ASR submenu has the following options:

 • MRCP ASR Provider, page 18-33

 • MRCP ASR Servers, page 18-33

 • MRCP ASR Dialog Groups, page 18-34

Related Topics

 • Before You Provision ASR/TTS, page 7-26

 • Provisioning MRCP ASR Subsystem, page 7-27

MRCP ASR Provider
Choose Subsystems > MRCP ASR > MRCP ASR Provider from the Cisco 
Unified CCX Administration menu bar to configure information about the vendor 
of your speech server, including the number of licenses, and the grammar type.

To modify an existing ASR Provider information, click any hyperlink within the 
provider’s summary table entry; the ASR Provider Configuration web page opens. 

To add a new ASR Provider information, click Add New icon or button.

Related Topic

Provisioning MRCP ASR Providers, page 7-28

MRCP ASR Servers 
Choose Subsystems > MRCP ASR > MRCP ASR Servers from the Cisco 
Unified CCX Administration menu bar to configure your speech server’s name, 
port location, and available languages.
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Note You must have a MRCP ASR Provider defined before you can provision a MRCP 
ASR Server.

To modify an existing ASR Server, click any hyperlink within the server’s 
summary table entry; the ASR Server Configuration web page opens. 

To add a new ASR Server, click Add New icon or button.

Related Topic

Provisioning MRCP ASR Servers, page 7-29

MRCP ASR Dialog Groups 
Use the MRCP ASR Dialog Group Configuration web page to display, add, 
modify, and delete information about MRCP ASR dialog control groups, which 
enable Unified CCX applications to use speech recognition.

Choose Subsystems > MRCP ASR > MRCP ASR Dialog Groups from the 
Cisco Unified CCX Administration menu bar to configure the MRCP ASR dialog 
control groups.

Note You must have a MRCP ASR Provider defined before you can provision a MRCP 
ASR Group.

To modify an existing MRCP ASR Dialog Group, click any hyperlink within the 
group’s summary table entry; the MRCP ASR Dialog Control Group 
Configuration web page opens. 

To add a new MRCP ASR Group, click Add New icon or button. 

Related Topic

Provisioning MRCP ASR Dialog Groups, page 7-31
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MRCP TTS Menu Option 
The Unified CCX system uses the MRCP (Text-to-Speech) subsystem to convert 
plain text (UNICODE) into spoken words to provide a user with information or to 
prompt a user to respond to an action.

Use one or more of the following MRCP TTS Configuration hyperlinks to access 
the following web pages:

 • MRCP TTS Providers, page 18-35

 • MRCP TTS Servers, page 18-36

 • MRCP TTS Default Genders, page 18-36

Related Topics

 • Before You Provision ASR/TTS, page 7-26

 • Provisioning MRCP TTS Subsystem, page 7-34

MRCP TTS Providers 
Use the MRCP TTS Provider Configuration web pages to display, add, modify, 
and delete information about your TTS Provider. 

Choose Subsystems > MRCP TTS > MRCP TTS Provider from the Cisco 
Unified CCX Administration menu bar to configure information about the vendor 
of your TTS system.

To modify an existing MRCP TTS Provider, click any hyperlink within the 
provider’s summary table entry; the MRCP TTS Provider Configuration web page 
opens. 

Related Topics

 • Provisioning MRCP TTS Providers, page 7-35

 • Configuring Default TTS Provider for the Unified CCX System, page 7-36
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MRCP TTS Servers 
Use the MRCP TTS Server Configuration web page to display, add, modify, and 
delete the text-to-speech server’s name, port location, and available language. 

To modify an existing MRCP TTS Server, click any hyperlink within the server’s 
summary table entry; the MRCP TTS Server Configuration web page opens. 

To add a new MRCP TTS Server, click Add New icon or button in the MRCP TTS 
Server Configuration web page. 

Related Topic

Provisioning MRCP TTS Servers, page 7-37

MRCP TTS Default Genders 
Use the MRCP TTS Default Genders Configuration web page to display or 
modify the gender setting for each Locale. You can modify the default gender 
setting for the Locales specified during TTS Server provisioning using this page. 
Click Update icon or button to save the changes.

Related Topic

Provisioning MRCP TTS Default Genders, page 7-39
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Wizards Menu

The Wizards menu of the Unified CCX Administration web interface provides 
access to the wizards available for your Unified CCX system. 

In each Wizard web page, you are provided with a list of procedures and a 
description for each procedure in the main pane. 

Click Exit icon in the tool bar in the upper, left corner of the window or the Exit 
button that displays at the bottom of the window to exit the wizard at any time and 
to go to the main Unified CCX Administration menu bar. Click Next to go to the 
next wizard menu option.

The Unified CCX system contains the following options in the Wizards menu:

 • The Application Wizard (see Application Wizard, page 19-1).

 • The RmCm Wizard (see RmCm Wizard, page 19-3).

Application Wizard
Application Configuration is one of the very basic requirements in Unified CCX 
Administration. You need to complete several steps in the suggested order to 
successfully complete Application Configuration. 

To access the Application Wizard, select Wizards > Application Wizard > 
Description of Steps from the Unified CCX Administration menu bar. The 
Application Configuration Wizard: Description of Steps web page opens up 
displaying the different steps in which you can perform the configuration along 
with a brief description of each step as shown in the bulleted list below. 
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Click Next to proceed to the subsequent steps from the main Application 
Configuration Wizard web page or jump directly to any step using Wizards > 
Application Wizard and clicking the desired submenu (see Configuring Unified 
CCX Applications, page 1-17).

 • Scripts—In this step, you can view a list of existing custom scripts. On click 
of Next from the main Application Configuration Wizard web page, you are 
transferred to Script Management web page, which lists the available scripts, 
provides links to create a folder, and upload custom scripts. Scripts can be 
uploaded as either a single script file or a zip file of scripts. You can upload 
multiple scripts in this step (see Managing Scripts, page 6-25). 

 • Prompts—In this step, you can view a list of existing custom prompts. The 
Prompt Management web page lists the available prompts, provides links to 
create new folders, and upload custom prompts. Prompts can be uploaded as 
either a single prompt file or a zip file of prompts. You can upload multiple 
prompts in this step (see Managing Prompt Files, page 10-2). 

 • Grammars—In this step, you can view a list of existing custom grammar 
files that are used to recognize and respond to caller prompts. The Grammar 
Management web page lists the available grammars, provides the links to 
create new folders, and upload custom grammars. Grammars can be uploaded 
as either a single grammar file or a zip file of grammars. You can upload 
multiple grammars in this step (see Managing Grammar Files, page 10-5). 

 • Documents—In this step, you can view a list of existing custom documents 
such as .txt, .doc, .jsp, or .html, custom classes, and Java Archive (JAR) files 
that allow you to customize the performance of your Unified CCX system. 
The Document Management web page lists the available documents, provides 
the links to create new folders, and upload custom documents. Documents 
can be uploaded as either a single document file or a zip file of documents. 
You can upload multiple documents in this step (see Managing Document 
Files, page 10-7).

 • Application Configuration—In this step, you can select the type of 
application to be configured using Add a New Application page. Click Next 
to provide configuration details for the selected application type. Each 
application can be any combination of the scripts, prompts, grammars, and 
documents on file. By default, the uploaded script, prompt, document and 
grammar are selected, if applicable. You can create multiple applications in 
this step (see About Unified CCX Applications, page 6-1). 
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 • Triggers—In this step, you can create different types of triggers for the 
applications that were created in the previous step using the Trigger 
Configuration page. More than one trigger can be created for one application. 
By default, the application configured in the previous step is automatically 
selected. On providing the Directory Number, device name and language, the 
trigger configuration is complete. You can create multiple triggers in this step 
(see Adding Application Triggers, page 6-18).

Selecting the type of the trigger concludes the Application Configuration wizard 
process.

Related Topics

 • Using Configuration Wizards, page 2-8

 • RmCm Wizard, page 19-3

RmCm Wizard
RmCm Configuration is commonly performed procedure in the contact center 
environment. You need to complete several steps in the suggested order to 
successfully complete RmCm Configuration. The RmCm Configuration wizard 
leads you through the suggested steps.

Note The RmCm Wizard option is available with all Unified CCX license packages.

To access the Application Wizard, select Wizards > RmCm Wizard > 
Description of Steps from the Unified CCX Administration menu bar. The 
Application Configuration Wizard: Description of Steps web page opens up 
displaying the different steps in which you can perform the configuration along 
with a brief description of each step as shown in the bulleted list below. 

Click Next to proceed to the subsequent steps from the main RmCm Wizard web 
page or jump directly to any step using Wizards > RmCm Wizard and clicking 
the desired submenu (see Provisioning the Unified CCX Subsystem, page 1-12).

 • Add a Skill—Choose this submenu to configure the skills to be associated 
with the user. In this step, you are transferred to the RmCm > Skills web page 
(see Creating a Skill, page 8-7). Repeat this step to create multiple skills.
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 • Add a Resource Group—Choose this submenu to upload multiple custom 
scripts. In this step, you are transferred to the Resource Group Configuration 
web page, where you can enter the Resource Group Name (see Configuring 
Resource Groups, page 8-4).

 • Add Resources—Choose this submenu to create resource groups that will 
later be assigned to resources. In this step, you are transferred to RmCm 
Wizard - User Configuration web page, which has a hyperlink to Add 
resources in Unified CM. This link invokes Unified CM automatically (see 
the following related topics:

 – Configuring RmCm Provider, page 8-2

 – Configuring Unified CM for Unified CCX, page 4-12

 – Defining Unified CM Users as Agents, page 4-13).

 • Add Supervisors—Choose this submenu to assign supervisor privileges to a 
user. In this step, you are transferred to the User Management web page, 
which allows you to search for a specific user (see Creating a Remote 
Monitoring Supervisor, page 8-31). 

 • Configure Resources—Choose this submenu to add or remove skills that are 
associated with resources. In this step, you are transferred to the RmCm 
Configuration Resources web page, which lists the configured resources. 
Resources can be modified together to obtain the same skills, or they can be 
modified separately to be assigned different skills.(see Configuring Agents, 
page 8-10). 

 • Modify Existing Contact Service Queues—Choose this submenu to skills 
that are associated with a contact service queue. In this step, you are 
transferred to the RmCm Configuration Contact Service Queue web page, 
which lists the configured CSQs (see Modifying an Existing CSQ, 
page 8-24). 

 • Add a Contact Service Queue—Choose this submenu to add contact service 
queues. Skills or resource groups are associated to these contact service 
queues to filter out the resources. In this step, you are transferred to the 
RmCm Configuration Contact Service Queue Configuration web page, which 
allows you to add CSQs (see Creating a CSQ, page 8-18). 

 • Modify Existing Teams—Choose this submenu to modify agents in existing 
teams. In this step, you are transferred to the RmCm Configuration Contact 
Teams web page, which lists the configured teams (see Modifying Agents on 
Teams, page 8-39). 
19-4
Cisco Unified CCX Administration Guide, Release 8.5(1)



Chapter 19      Wizards Menu
RmCm Wizard
 • Add a Team—Choose this submenu to create new teams and associate those 
teams with new agents. In this step, you are transferred to the RmCm 
Configuration Team Configuration web page, which allows you to create new 
teams (see Creating Teams, page 8-37). 

 • Create an Application—On completing the RmCm configuration, you can 
optionally proceed to the Application Wizard configuration (see Application 
Wizard, page 19-1). 

Related Topics

 • Using Configuration Wizards, page 2-8

 • Application Wizard, page 19-1
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Tools Menu

The Tools menu of the Unified CCX Administration web interface provides 
access to system tools you can use to perform a variety of administrative tasks and 
contains the following menu options:

 • Plug-ins—to download plug-ins that you can use to enhance the Unified 
CCX Engine (see Plug-ins Menu Option, page 20-2).

 • Real-Time Reporting—to generate reports that provide detailed information 
about the status of your Unified CCX system (see Real-Time Reporting Menu 
Option, page 20-3).

 • Real-Time Snapshot Config—to configure the Unified CCX database 
connection to a wallboard display (see Real-Time Snapshot Config Menu 
Option, page 20-4).

 • Historical Reporting—to perform Historical Reporting tasks, including 
configuring the database server, synchronizing data, configuring users, 
installing client software, and purging your database (see Historical 
Reporting Menu Option, page 20-10).

 • User Management—to assign access levels to administrators and 
supervisors (see User Management Menu Option, page 20-12).

 • Password Management—to reset passwords for external database access 
users like workforce management, historical reporting user and so on (see 
Password Management, page 20-17). 

 • W1 Upgrade—to (see Windows Upgrade Menu Option, page 20-18).
20-1
Administration Guide, Release 8.5(1)



Chapter 20      Tools Menu
Plug-ins Menu Option
Plug-ins Menu Option
The Unified CCX system includes software components called plug-ins that you 
can use to enhance the Unified CCX Engine. You can download these plug-ins 
from the Plug-ins web page.

To access the Plug-ins web page, choose Tools > Plug-ins from the Unified 
CCX Administration menu bar. 

The Plug-ins web page contains one or more of the following hyperlinks 
(depending on the Unified CCX package you have purchased):

 • Cisco Unified CCX Editor—Click this hyperlink to install the client-side 
Unified CCX Editor. For more information, see the Cisco Unified Contact 
Center Express Scripting and Development Series: Volume 1, Getting Started 
with Scripts 8.5(1) and Volume 2, Editor Step Reference 8.5(1) Guide. 

Caution Do not install the Unified CCX editor on the same machine as the Cisco 
Unity Editor. Both editors cannot coexist on the same machine.

 • Cisco Unified CCX Desktop Suites—Click this hyperlink to install 
Cisco Desktop Administrator, Supervisor Desktop, Agent Desktop, and 
Client Configuration tool. For more information, see Cisco Unified CCX 
Supervisor Desktop Plug-in Tasks and the Cisco Unified CCX Agent Desktop 
Plug-in Tasks.

Note You need to download Cisco Unified CCX Desktop Client Configuration tool 
prior to installing any application(s) from the Cisco Unified CCX Desktop 
Product Suite. 

 • Cisco Unified CCX Historical Reports—Click this hyperlink to install 
client-side historical reporting. For more information, see the Cisco Unified 
CCX Historical Reports User Guide.

Note If you use Historical Reporting, the Unified CCX Historical Reports 
client system must be same version as the Unified CCX system.
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 • Cisco Unified CCX Real-Time Monitoring Tool for Windows—Click this 
hyperlink to install client-side Unified CCX Serviceability Real-Time 
Monitoring Tool (RTMT) for Windows. This tool monitors real-time 
behavior of the components in a Unified CCX cluster. RTMT uses 
HTTP/HTTPS and TCP to monitor device status, system performance, device 
discovery, and CTI applications. It also connects directly to devices by using 
HTTP/HTTPS for troubleshooting system problems. This plug in is available 
only for users with administrator capability. 

Note To download on Windows, right-click Download hyperlink and select 
Save Target As option.

 • Cisco Unified CCX Real-Time Monitoring Tool for Linux—Click this 
hyperlink to install client-side Unified CCX Serviceability Real-Time 
Monitoring Tool (RTMT) for Linux. RTMT uses HTTP/HTTPS and TCP to 
monitor device status, system performance, device discovery, and CTI 
applications. It also connects directly to devices by using HTTP/HTTPS for 
troubleshooting system problems. This plug in is available only for users with 
administrator capability. 

Real-Time Reporting Menu Option

Caution While Unified CM supports Unicode characters in first and last names, those 
characters become corrupted in Unified CCX Administration web pages for 
RmCm configuration, Real Time Reporting, Cisco Agent/Supervisor Desktop, 
and Historical Reports.

The Real-Time Reporting tool is a Java applet that you can use to generate a 
variety of reports that provide detailed information about the status of your 
Unified CCX system. You use the Application Reporting web page to access the 
Real-Time Reporting tool.

To access the Application Reporting web page, choose Tools > Real Time 
Reporting from the Unified CCX Administration menu bar. 
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Note For complete information about using the Application Reporting component, see 
Chapter 14, “Reporting on Real-Time Unified CCX Data.”

Real-Time Snapshot Config Menu Option
Many call centers use wallboards to display their real-time reporting status. 
Wallboards can display data such as available agents in CSQs, call volumes, talk 
times, wait times, and number of handled calls. You can enable the Unified CCX 
system to write Unified CCX real-time information to a database that can then be 
displayed on a wallboard. 

Note You must purchase the wallboard separately, and configure and control it with its 
own wallboard software. Wallboard software and hardware are supported by the 
third-party wallboard vendors, not by Cisco. 

You must install the wallboard software on a separate machine or desktop, not on 
the Unified CCX server. During installation of your wallboard software, you will 
need to configure your wallboard software to access the Unified CCX database. 
To do this, you need to assign a DSN, User ID, and password. 

Use the Real-Time Snapshot Writing Configuration for Wallboard web page to 
enable the system to write data to the wallboard system.

To access the Real-Time Snapshot Writing Configuration for Wallboard web 
page, choose Tools > Real Time Snapshot Config from the Unified CCX 
Administration menu bar. 
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The following fields are displayed on the Real-Time Snapshot Writing 
Configuration for Wallboard web page.

Note For details about the information written to the RtCSQsSummary and 
RtICDStatistics database tables, see the Cisco Unified CCX Database Schema 
Guide. Only the RtCSQsSummary and RtICDStatistics statistics tables can be 
used in wallboard queries. Use of historical reporting tables in wallboard queries 
is not supported.

See the Cisco Unified CCX Software and Hardware Compatibility Guide for 
compatibility information.

Creating a System DSN for Wallboard

You can create a system Data Source Name (DSN) on your Windows server by 
performing the following procedure.

Field Description

Data Writing Enable If checked, the system writes the data to the database. If not checked, the 
system does not write the data to the database. 

The default is disabled.

Data Writing Interval Sets the refresh interval for the wallboard data. Valid options: 5, 10, 15, 
20, and 25. 

Cisco Unified CCX CSQs 
Summary

If checked, writes information about each CSQ to the RtCSQsSummary 
table in the Unified CCX database.

Cisco Unified CCX System 
Summary

If checked, writes overall Unified CCX system summary to the 
RtICDStatistics table in the Unified CCX database. 

Wallboard System

Server Name IP addresses of the Servers running the Wallboard software pointing to 
the HDS Database Server, which contains the Wallboard Real-Time 
Snapshot data. If you have multiple Wallboard servers, you can list their 
IP addresses in this field separated by commas.
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Procedure

Step 1 Install the wallboard software and IBM Informix ODBC Driver (IDS version 
3.0.0.13219 and above) on the wallboard client desktop. 

Note You can download the Informix ODBC driver from the following URL: 
http://www14.software.ibm.com/webapp/download/search.jsp?rs=ifxdl. 
Download the IBM Informix Client Software Development Kit (CSDK) version 
3.00 or higher for the operating system you are installing with the wallboard 
client. More information about the CSDK can be found at the following URL: 
http://www.ibm.com/software/data/informix/tools/csdk/.

Step 2 Select Start > Settings > Control Panel.

Step 3 From the Control Panel menu, select Administrative Tools > Data Sources 
ODBC to launch the OBDC Data Source Administrator. 

Step 4 Click the System DSN tab. Then click Add to open the Create New Data Source 
dialog box.

Step 5 Scroll down to locate and select the IBM INFORMIX ODBC DRIVER.

Step 6 Click Finish to open the IBM Informix Setup dialog box.

Step 7 On the General tab, enter and apply a Data Source Name and Description.

Step 8 On the Connection tab, enter the values for the fields as shown in the table below:
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Step 9 Click Apply.

Step 10 Click the Environment tab and enter the values for the following fields:

Leave the values unchanged (keep blank or use defaults) for all other fields. 

Field Description

Server Name This is the instance name of the Informix database. 

Informix database instance name can be formed using Host Name of the 
Unified CCX server by following the conventions mentioned below: 

 • Convert all upper case letters to lower case.

 • Replace hyphens with underscore.

 • Add the letter “i” as a prefix to the instance name, if the host name 
starts with a number.

 • Append the letters "_uccx" to the instance name. 

For example, if the host name is "802UCCX-Ha-Node1", then you should 
enter "i802uccx_ha_node1_uccx” in the server name field.

Host Name Enter the host name of the primary Unified CCX server. 

Service Enter 1504.

Protocol Enter onsoctcp. 

Options Leave blank.

Database Name Enter db_cra.

User ID Enter uccxwallboard. This is the user id of the Unified CCX database 
created for wallboard.

Password The password for the wallboard user that has been configured. You can 
change the password by going to Tools > Password Management 
submenu option from the Unified CCX Administration menu bar (see 
Password Management, page 20-17).

Field Description

Client Locale Enter en_US.UTF8.

Database Locale Enter en_US.UTF8.
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Step 11 Click OK. 

Step 12 Return to the Connection tab and click Apply and Test Connection.

If the phrase “Test completed successfully” is returned, then click OK.

If the test is unsuccessful, return to the configuration sequence and fix any errors.

Using Wallboard Software in a High Availability (HA) Deployment

If you use wallboard software in a High Availability (HA) deployment of Unified 
CCX 8.5(1) and do not want any manual intervention in case of failover, you need 
to upgrade your Wallboard software.

Upgraded wallboard software should have a new service which periodically 
requests Unified CCX server for database mastership information using REST 
API (URL - http://<Unified CCX server IP Address>/uccx/isDBMaster). During 
failover, this new service in wallboard will update DSN registry to use new 
database master server.

This REST API can be requested only from those wallboard servers, which are 
configured through Tools > Real Time Snapshot Config web page from the 
Unified CCX Administration menu bar. See the following sub-sections for 
detailed information on different scenarios.

Using Upgraded Wallboard Software with New Service in a High Availability (HA) Deployment

If you use wallboard software in a High Availability (HA) deployment of Unified 
CCX 8.5(1), you will need to work with your wallboard vendor to use the new API 
exposed by Unified CCX 8.5(1). 

Wallboard software with the new service ensures that the wallboard server always 
displays data from the master database server of Unified CCX and no manual 
intervention is required. Follow the steps mentioned below to complete the setup:

Procedure

Step 1 Create DSN using secondary server information and modify the same DSN using 
primary server information. This will create sqlhost entries for both the servers in 
a registry at HKEY_LOCAL_MACHINE\SOFTWARE\Informix\SqlHosts.

Step 2 Configure the wallboard software with new service as mentioned in the wallboard 
software documentation.
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Step 3 Configure information of both the Unified CCX servers with new service of 
wallboard as mentioned in the wallboard software documentation.

Once you complete the steps mentioned above, no manual intervention is required 
in case of failover. 

Using Existing Wallboard Software (without the New Service) in a HA Deployment

If you use the existing wallboard software without the new service in a High 
Availability (HA) deployment of Unified CCX 8.5(1), you will need to complete 
the following actions:

Procedure

Step 1 Create DSN using secondary server information and modify the same DSN using 
primary server information. This will create sqlhost entries for both the servers in 
a registry at HKEY_LOCAL_MACHINE\SOFTWARE\Informix\SqlHosts.

Step 2 Configure the wallboard software as mentioned in the wallboard software 
documentation.

Step 3 Whenever there is a failover, you need to manually change the DSN registry entry 
using the sub steps mentioned below:

a. Enter http://<Unified CCX server IP Address>/uccx/isDBMaster in a web 
browser from any wallboard client to know whether the requested Unified 
CCX IP address server has a database master or not.

b. On failover, change SERVER value to master DB instance name in registry 
of DSN under HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBC.INI

c. You can find the exact database instance name at 
HKEY_LOCAL_MACHINE\SOFTWARE\Informix\SqlHosts 
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Historical Reporting Menu Option

Caution While Unified CM supports Unicode characters in first and last names, 
those characters become corrupted in Unified CCX Administration 
web pages for RmCm configuration, Real Time Reporting, Cisco 
Agent/Supervisor Desktop, and Historical Reports., page 22-3

Use the areas of the Historical Reporting Configuration web page to perform a 
variety of tasks, including configuring users, installing client software, and 
purging your database.

To access the different Historical Reporting Configuration options, choose Tools 
> Historical Reporting and click any of the following submenu options from the 
Unified CCX Administration menu bar:

 • Database Server Configuration—to specify the maximum number of client 
and scheduler connections to the database server (see Database Server 
Configuration, page 20-10).

 • Purge Schedule Configuration—to automatically purge data as per the 
following configurations:

 – Timing of the purge (see Purge Now, page 20-11).

 – Automatic purge configuration (see Purge Schedule Configuration, 
page 20-11).

 • Purge Now—to manually purge data (see Purge Now, page 20-11).

 • File Restore - to restore the database records written to HR files when the 
database goes down (see File Restore, page 20-12).

Note For additional information on Historical Reporting, see the Cisco Unified CCX 
Historical Reports User Guide.

Database Server Configuration
Use the Database Server Configuration area to specify the maximum number of 
client and scheduler connections that can access the database server. 
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Choose Tools > Historical Reporting > Database Server Configuration from 
the Unified CCX Administration menu bar to access the Database Server 
Configuration area.

Related Topics

Historical Reporting Configuration, page 12-2

Purge Schedule Configuration 
Use the Purge Schedule Configuration area to select a user for whom you want to 
choose a reporting package for the Unified CCX Historical Reports system.

Choose Tools > Historical Reporting > Purge Schedule Configuration from 
the Unified CCX Administration menu bar to access the Purge Schedule 
Configuration web page. 

The Historical Reporting Configuration web page opens enabling you to 
configure the following:

 • Daily purge schedule 

 • Automatic purge (you can specify how long records should persist before the 
system purges them)

See Configuring Purge Schedule Configuration Parameters, page 12-5 section to 
know the procedure for setting up the purge schedule configuration parameters.

Related topic

Configuring Automatic Purging, page 12-4

Viewing Historical Reports, page 12-3

Purge Now
Use the Purge Now area to manually purge data.

Choose Tools > Historical Reporting > Purge Now from the Unified CCX 
Administration menu bar to access the Purge Now area. 

Related Topic

Purging Manually, page 12-6
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File Restore 
Use the File Restore area to restore the database records written to HR files when 
the database goes down. 

To access the Historical Reporting Configuration area, choose Tools > Historical 
Reporting > File Restore from the Unified CCX Administration menu bar to 
access the Historical Reporting Configuration web page. Restore Now radio 
button is enabled by default on this page.

Click Start icon that displays in the tool bar in the upper, left corner of the 
window or the Start button that displays at the bottom of the window to restore 
the database records. You can view the status of the restore operation on this page. 

In case of a High Availability setup, files from both the nodes are restored to the 
HR Database of the first and second node respectively. If it is unable to connect 
to the second node, you will see an alert message stating that the remote node is 
not reachable. When the second node comes up the restored data will be replicated 
but you need to repeat this Restore operation to restore the HR files, if any, on the 
second node. 

User Management Menu Option
The User Management menu option allows you to assign access levels to Unified 
CCX system administrators and supervisors. 

When you configure a Unified CCX supervisor, you are configuring users who 
can access the Unified CCX Supervisor web pages. You are not creating a 
supervisor for Unified CCX.

Note Only Administrators can update the Unified CCX system. You must select at least 
one Administrator, so that someone is available to perform updates.

Choose Tools > User Management and click any of the following submenu 
options from the Unified CCX Administration menu bar to assign administrative 
privileges to administrators and supervisors:

 • User View Submenu Option, page 20-13

 • Name Grammar Generator Configuration, page 20-14
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 • Spoken Name Upload Submenu Option, page 20-15

 • Administrator Capability View Menu Option, page 20-16

 • Supervisor Capability View Menu Option, page 20-16

 • Reporting Capability View Menu Option, page 20-16

 • Agent Capability View Menu Option, page 20-17

Related Topics

 • Managing Unified CCX Users, page 5-14

 • About Unified CCX User Capabilities, page 15-2

 • Configuring and Using Remote Monitoring, page 8-30

 • Creating a Remote Monitoring Supervisor, page 8-31

 • Assigning Resources and CSQs to a Supervisor, page 8-32

 • Viewing CSQ IDs for Remote Monitoring, page 15-8

 • Creating a Team Supervisor, page 8-36

 • Managing Unified CCX Users, page 5-14

User View Submenu Option
From the Unified CCX Administration menu bar, choose Tools > User 
Management > User View to access the User Configuration web page.

Use this page to view existing users, create new users (for CME only), and assign 
administrative privileges to administrators and supervisors. You can provide a 
search string based on a user’s ID. For example, if you provide the search string as 

 • "*Agent1", it will display user IDs ending with Agent1, 

 • "Agent1*", it will display user IDs starting with Agent1, and 

 • "Agent1", it will display user IDs that contain Agent1. 

All the columns are hyperlinked to the user configuration page.
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Related Topics

 • Configuring and Using Remote Monitoring, page 8-30

 • Creating a Remote Monitoring Supervisor, page 8-31

 • Assigning Resources and CSQs to a Supervisor, page 8-32

 • Configuring Remote Monitoring Application, page 6-16.

 • Viewing CSQ IDs for Remote Monitoring, page 15-8

 • Creating a Team Supervisor, page 8-36

 • Managing Unified CCX Users, page 5-14

 • About Unified CCX User Capabilities, page 15-2

Name Grammar Generator Configuration
Use the Name Grammar Generator Configuration web page to define scheduling 
information for the Name Grammar Generator.

From the Unified CCX Administration menu bar, choose Tools > User 
Management > Name Grammar Generator Configuration to access Name 
Grammar Generator Configuration area.

Name Grammars need to be generated if you wish to use the Name to User Step 
with ASR. The Name Grammar Generator scans the User Directory and creates a 
speech recognition grammar containing every user in the directory. These 
grammars are saved in the grammar repository.

You may use the Name Grammar Generator Configuration page to run the Name 
Grammar Generator or schedule it to run at some later time. The page also 
displays date and time the Name Grammar Generator was last run and the 
completion status of that run.

The following fields are displayed on the Name Grammar Generator web page.

Field Description

Frequency How often Name Grammar Generator is automatically run. Valid 
options: Never, Daily, Weekly. This is a mandatory field.

Run task on (hrs of day) Time of day to run the task. This is a mandatory field.

Run task on (day of week) Day of week to run the task. This is a mandatory field.
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Click Generate Name Grammar Now icon or button to trigger the Name 
Grammar Generator. 

Note Clicking Generate Name Grammar Now will not apply changes to the 
scheduling configuration; you must click Update to apply scheduling changes.

Spoken Name Upload Submenu Option
When a caller requests to be transferred to a specific extension, Unified CCX 
applications can playback a recording of the spoken name of the person to whom 
the caller has called. These spoken name recordings are stored as .wav files and 
managed by the Spoken Name Upload tool of the Unified CCX Administration 
web interface. 

To access the Spoken Name Prompt Upload web page, choose Tools > User 
Management > Spoken Name Upload from the Unified CCX Administration 
menu bar.

The Spoken Name Prompt Upload web page also contains the Click Here for 
Recording Information icon and button, which displays a .htm page in your 
browser with more information on recording spoken name prompts.

Related Topic

Add Spoken Name Prompts, page 10-16

Last Completed on (Display only.) Date of last generation of name grammar .

Last Completion Result (Display only.) The status after the last name grammar generation.

Grammar Variant Select one or more grammar variants to generate from the check box next 
to the following three options:

 • OSR 3.1.x 

 • 2003 SISR 

 • Nuance

Current Status (Display only.) Running status of the Name Grammar Generator. 

Field Description
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Administrator Capability View Menu Option
From the Unified CCX Administration menu bar, choose Tools > User 
Management > Administrator Capability View to access the capability view 
for the Administrator User Management area. 

This web page contains a pane for the user(s) identified as the Unified CCX 
Administrator and another pane with the list of Available Users. Based on your 
requirements, you can move users back and forth between these two panes by 
clicking the arrows in either direction. Click Update to save the changes.

Related Topics

 • Managing Unified CCX Users, page 5-14

 • Administrator Privileges, page 15-3

Supervisor Capability View Menu Option
From the Unified CCX Administration menu bar, choose Tools > User 
Management > Supervisor Capability View to access the capability view for 
the Supervisor User Management area. 

This web page contains a pane for the user(s) identified as the Unified CCX 
Supervisor and another pane with the list of Available Users. Based on your 
requirements, you can move users back and forth between these two panes by 
clicking the arrows in either direction. 

Related Topics

 • Supervisor Privileges, page 15-3

 • Using Unified CCX Supervisor Web Interface, page 15-6

 • Managing Unified CCX Users, page 5-14

Reporting Capability View Menu Option
From the Unified CCX Administration menu bar, choose Tools > User 
Management > Reporting Capability View to access the capability view for the 
Historical Report Users area. 
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The capability view for the Reporting Management web page contains a pane for 
the user(s) identified as the Unified CCX Historical Report Users and another 
pane with the list of Available Users. Based on your requirements, you can move 
users back and forth between these two panes by clicking the arrows in either 
direction. 

Related Topics

 • Managing Unified CCX Users, page 5-14

 • Historical Report User Privileges, page 15-5

Agent Capability View Menu Option
From the Unified CCX Administration menu bar, choose Tools > User 
Management > Agent Capability View to access the capability view for Unified 
CCX agents. 

The capability view for the Agent User Management web page contains a pane for 
the user(s) identified as the Unified CCX Agents and another pane with the list of 
Available Users. Based on your requirements, you can move users back and forth 
between these two panes by clicking the arrows in either direction. 

Note This role is assigned by default to Unified CCX users in a Unified CME 
deployment with an Agent Extension association in Unified CCX. 

Related Topics

 • Managing Unified CCX Users, page 5-14

 • Agent Privileges, page 15-5

Password Management
From the Unified CCX Administration menu bar, choose Tools > User 
Management to access the password management web page.
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You can set or reset the passwords for the following external database users using 
this web page:

 • Wallboard

 • Recording SFTP

 • Workforce Management

 • Historical Reporting

 • System Call Tracking (part of Real Time Monitoring Tool/ Analysis 
Manager)

Click Save icon that displays in the tool bar in the upper, left corner of the window 
or the Save button that displays at the bottom of the window. Click the Clear 
button to remove the data entered and to retain the existing passwords. You will 
see an error message if the old and new passwords are the same for any of the 
users. Click Check Consistency to confirm

In case of a High Availability deployment, the password change will not be 
propagated to the second node. You need to access the AppAdmin web interface 
of the second node manually to change the password. In a HA setup, you will be 
able to see Check Consistency icon or button in the Password Management page. 
Use this button to check and confirm whether the passwords between the two 
nodes match or not. You will be able to see the status of the password check in 
the Password Management page.

Windows Upgrade Menu Option

Note This menu option will be visible only if you are upgrading to Unified CCX 8.5(1) 
from a previous Unified CCX release. In other words, this menu option will show 
only if you have selected "Upgrade from a previous Unified CCX release" option 
during initial Appadmin setup in a single-node or high availability deployment. 

Choose Tools > Windows Upgrade from the Unified CCX Administration menu 
bar to view the status of data migration. The Unified CCX Upgrade Setup web 
page opens where you can view the status messages for the migration activities at 
each stage in the text box below the Windows to Linux Upgrade field. Click Next 
to acquire control of the upgrade.
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Note You can close this window without affecting the data migration in progress. Go 
to Tools > Windows Upgrade from the Unified CCX Administration menu bar 
to come back and view the status once again. 

For additional information, see the following documents:

 • For upgrade issues, see the Cisco Unified CCX Upgrade Guide. 

 • For Installation issues, see the Installation Guide for Cisco Unified CCX and 
Cisco Unified IP IVR, Release 8.5(1). 
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Help Menu

The Help Menu of the Unified CCX Administration web interface provides access 
to online help for the Unified CCX system.

Use the Help menu to access configuration procedures and description of Unified 
CCX components.

The Help menu contains the following menu options:

 • Contents and Index—Choose this option to view the entire Unified CCX 
Administrator Guide online help system and index (see Contents and Index 
Option, page 21-2).

 • For this page—Choose this option to view context-sensitive help (see For 
This Page Menu Option, page 21-3).

 • Troubleshooting Tips—Choose this option to view troubleshooting wiki 
page for suggestions on how to solve problems that may arise in the 
performance of your Unified CCX system (see Troubleshooting Tips Menu 
Option, page 21-3).

 • Unified CCX Documentation on Cisco.com—Choose this option to view 
the documentation index page (see For This Page Menu Option, page 21-3).

 • About—Choose this option to view Unified CCX version information (see 
About Menu Option, page 21-3).
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Contents and Index Option
To view the entire Unified CCX Administrator Guide online help system and 
index, choose Help > Contents and Index from the Unified CCX Administration 
menu bar. The Unified CCX Administrator Guide Online Help window opens. 

When you click any topic in the top pane, the section of the online help that 
corresponds to that topic appears in the bottom pane.

The following table describes the menu options in the Unified CCX Administrator 
Guide Online Help window.

Table 21-1 Online Help Menu Options 

Menu Option Description

Home Returns you to the beginning of the online help 
document.

Search Opens a search window, in which you can search 
for specific words in the online help files.

Using Help Opens a file explaining how to use the online help 
files.

Glossary Opens a glossary of definitions for terms used in 
Cisco Unified CCX and Cisco Unified IP IVR.

View PDF Opens a PDF1 version of the Cisco Unified CCX 
Administration Guide.

1. PDF = Portable Document Format

Contents and Index Displays the index and contents of the Unified 
CCX Administrator Guide online help files in a 
separate web page. The index is displayed in the 
left pane while the contents are displayed in the 
right pane in the online help page.
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For This Page Menu Option
To access context-sensitive help, open the web page for which you want help and 
choose Help > For This Page from the Unified CCX Administration menu bar. 
The Unified CCX Administration online help displays information that is specific 
to the open web page.

Troubleshooting Tips Menu Option
The Unified CCX system provides the Troubleshooting Tips tool as a way for you 
to search the troubleshooting wiki page for suggestions on how to solve problems 
that may arise in the performance of your Unified CCX system.

Note For more information, see the Troubleshooting Wiki page: 
http://docwiki.cisco.com/wiki/Troubleshooting_Unified_Contact_Center_Expre
ss.

To access the Troubleshooting Tips wiki page, choose Help > Troubleshooting 
Tips from the Unified CCX Serviceability Administration menu bar. 

Unified CCX Documentation Link Option
To access the complete Unified CCX documentation set for Unified CCX, and 
Unified IP IVR, choose Help > Cisco Unified CCX Documentation on 
Cisco.com from the Unified CCX Administration menu bar. A new browser 
window opens to display the following documentation index page: 
http://www.cisco.com/en/US/products/sw/custcosw/ps1846/tsd_products_suppo
rt_series_home.html.

About Menu Option
To access Unified CCX version information, choose Help > About from the 
Unified CCX Administration menu bar. The Unified CCX Administration web 
page opens, displaying version information and package information. 
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Unified CCX Licensing Packages

This appendix describes the features that are available with each Unified CCX 
license package. It includes the following sections:

 • Application Availability by License Package, page A-2

 • Trigger Availability by License Package, page A-2

 • Subsystem Availability by License Package, page A-2

 • Historical Report Availability by License Package, page A-4

 • Unified CCX Services Availability by License Package, page A-4

 • Unified CCX Component Availability by License Package, page A-6
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Application Availability by License Package
The following table lists the applications available with each license package:

Trigger Availability by License Package
The following table lists the triggers available with each license package:

Subsystem Availability by License Package
The following table lists the subsystems available with each license package:

Application
Unified IP 
IVR

Unified CCX 
Standard

Unified CCX 
Enhanced

Unified CCX 
Premium

Cisco Script Application X X X X

Busy X X X X

Ring No Answer X X X X

Unified ICME Post Routing X

Unified ICME Translation Routing X

Trigger Unified IP IVR
Unified CCX 
Standard

Unified CCX 
Enhanced

Unified CCX 
Premium

Unified CM Telephony X X X X

Unified CME Telephony X X X X

HTTP X X

Subsystem Unified IP IVR
Unified CCX 
Standard

Unified CCX 
Enhanced

Unified CCX 
Premium

CMT Subsystem X X X X

Core RTR Subsystem X X X X

Database Subsystem X X
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eMail Subsystem X X

Enterprise Server Data Subsystem X X X

HTTP Subsystem X X

Unified CM Telephony Subsystem X X X X

Unified CME Telephony 
Subsystem

X X X X

MRCP ASR Subsystem X X

MRCP TTS Subsystem X X

Outbound Subsystem1 X

RmCm Subsystem X X X X

Voice Browser Subsystem X X

VoIP Monitor Subsystem X X

1. The Unified CCX Outbound Preview Dialer feature does not require an additional license and it comes as part of the Premium 
license package.

Subsystem Unified IP IVR
Unified CCX 
Standard

Unified CCX 
Enhanced

Unified CCX 
Premium
A-3
Cisco Unified CCX Administration Guide, Release 8.5(1)

 



Chapter A      Unified CCX Licensing Packages
Historical Report Availability by License Package
Historical Report Availability by License Package
The following table lists the historical reports available with each license 
package:

Unified CCX Services Availability by License 
Package

The following table lists the Unified CCX Services available with each license 
package:

Historical Report Type Unified IP IVR
Unified CCX 
Standard

Unified CCX 
Enhanced

Unified CCX 
Premium

Unified IP IVR X X X X

Unified CCX Standard X

Unified CCX Enhanced X X

Wrap-up code and reports X X

Unified CCX Services None1 Unified IP IVR
Unified CCX 
Standard

Unified CCX 
Enhanced

Unified CCX 
Premium

Unified CCX Cluster View 
Daemon

X X X X X

Unified CCX 
Administration

X X X X X

Unified CCX Engine X X X X

Cisco Desktop Call/Chat 
Service

X X X

Cisco Desktop Enterprise 
Service

X X X

Cisco Desktop IP Phone 
Agent Service

X X X
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Cisco Desktop LDAP 
Monitor Service 

X X X

Cisco Desktop License and 
Resource Manager

X X X

Cisco Desktop Recording 
Service (call recording)

X X

Cisco Desktop Recording 
and Statistic Service

X X X

Cisco Desktop Sync Service X X X

Cisco Desktop VoIP Service X X

Cisco Unified CCX 
Database

X X X X

1. Available upon installation, before license package is activated.

Unified CCX Services None1 Unified IP IVR
Unified CCX 
Standard

Unified CCX 
Enhanced

Unified CCX 
Premium
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Unified CCX Component Availability by License 
Package

The following table lists the Unified CCX Component available with each license 
package:

Support Scalability for Unified CME
See the Release Notes for Unified CCX, Release 8.5(1) at 
http://www.cisco.com/en/US/partner/products/sw/custcosw/ps1846/prod_release
_notes_list.html.

Unified CCX Component None1

1. Available upon installation, before license package is activated.

Unified IP 
IVR

Unified CCX 
Standard

Unified CCX 
Enhanced

Unified CCX 
Premium

Unified CCX Cluster View 
Daemon (CVD)

X X X X X

Unified CCX Engine X X X X

Unified CCX Repository Datastore X X X X

Unified CCX Historical Datastore X X X X

Unified CCX Configuration 
Datastore

X X X X

Unified CCX Agent Datastore X X X

Unified CCX Recording X X

Unified CCX Monitoring X
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