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Introduction 

This document describes how to configure Bring Your Own Device (BYOD) Supplicant 

Provisioning with Cisco Identity Services Engine (ISE) and a Cisco Wireless Lan Controller (WLC). 

  

This document attempts to include all the neccessary steps from Installing ISE to User 

Experience. 

  

The goal of this configuration is to provide differentiated access between hypothetical 

Employees and Contractors. 

• Employees will authenticate via Central Web Authentication (Dual SSID) or PEAP (Single 

SSID) and be provisioned with an identity certificate via Simple Certificate Enrollment 

Protocol (SCEP) for EAP-TLS. 

• Contractors will recieve immediate network access regardless of their network access 

method. 

We are going to implement a mix of Single SSID BYOD and Dual SSID BYOD. 

Dual SSID BYOD Client enters network via open SSID, 

authenticates via MAC Address Bypass (MAB) 

and CWA Guest portal redirects Employees to 

supplicant provisioning and 

Guests/Contractors to Internet Access. 

Single SSID BYOD Employee enters network via PEAP on secured 

SSID and is provisioned for EAP-TLS access on 

the same SSID. Contractors recieve immediate 

network access. 

  



  

Prerequisites 

  

  

Requirements 

Cisco recommends that you have knowledge of these topics: 

• Identity Services Engine (ISE) 

• Wireless Lan Controllers 

• Windows Server 

  

Components Used 

  

• ISE 1.1.3 Patch 1 

• WLC 7.2+ 

• Windows Server 2008 SR2 

  

Configure 

  

  

Bootstrapping ISE 

  

  



Download and Install ISE 

1. Download ISE’s installer .iso file. 

Download Link: 

http://software.cisco.com/download/release.html?mdfid=283801620&softwareid=283802505 

1. Install ISE on your favourite physical or virtual infrastructure and perform post 

installation tasks 

Relevant Guide: 

http://www.cisco.com/en/US/docs/security/ise/1.1.1/installation_guide/ise_install_guide.html 

Note: ISE installation requires: Network connectivity, DNS server, NTP. Without these 

installation will break. 

  

1. For our example deployment we will be using ISE 113-1.sec.lab and ISE113-2.sec.lab. 

The domain will be sec.lab. 

ISE113-1 will be our PAP/PAN (Primary Administration Point / Administration Node) and MNT 

(Monitoring) Node. 

ISE113-2 will be out PSN (Policy Service Node). 

  

10.66.83.1 will be our gateway 

10.66.83.88 will be our NTP, DNS, DC/GC (Active Directory) 

  

ISE113-1 (PAP/PAN + MNT) ISE113-2 (PSN) 

hostname ise113-1 

!        

ip domain-name sec.lab 

!        

hostname ise113-2 

!        

ip domain-name sec.lab 

!        



interface GigabitEthernet 0 

  ip address 10.66.83.155 255.255.255.0 

  ipv6 address autoconfig 

!        

ip name-server 10.66.83.88  

!        

ip default-gateway 10.66.83.1 

!        

ip route 192.168.0.0 255.255.0.0 gateway 

10.66.83.254 

!        

clock timezone Australia/Sydney 

!         

ntp server 10.66.83.88 

! 

username admin password hash 

$1$E3/BSl7F$FPF1Ad18dumzG2pStzjwd. role 

admin 

! 

service sshd 

! 

repository FTP 

  url ftp://10.137.8.64 

  user administrator password hash 

interface GigabitEthernet 0 

  ip address 10.66.83.156 255.255.255.0 

  ipv6 address autoconfig 

!        

ip name-server 10.66.83.88  

!        

ip default-gateway 10.66.83.1 

!        

ip route 192.168.0.0 255.255.0.0 gateway 

10.66.83.254 

!        

clock timezone Australia/Sydney 

!        

ntp server 10.66.83.88 

! 

username admin password hash 

$1$t72wHUqd$cmVOlbBGQr/qAgcxxfceu. role 

admin 

! 

service sshd 

! 

repository FTP 

  url ftp://10.137.8.64 

  user administrator password hash 



cc14bc179d2708cc31cbc21ee6a679cd22c095a

e 

! 

password-policy 

  lower-case-required 

  upper-case-required 

  digit-required 

  no-username 

  disable-cisco-passwords 

  min-password-length 6 

  password-lock-enabled 

  password-lock-retry-count 5 

! 

logging localhost 

logging loglevel 6 

! 

cdp timer 60 

cdp holdtime 180 

cdp run GigabitEthernet 0 

! 

icmp echo on 

! 

cc14bc179d2708cc31cbc21ee6a679cd22c095a

e 

! 

password-policy 

  lower-case-required 

  upper-case-required 

  digit-required 

  no-username 

  disable-cisco-passwords 

  min-password-length 6 

  password-lock-enabled 

  password-lock-retry-count 5 

! 

logging localhost 

logging loglevel 6 

! 

cdp timer 60 

cdp holdtime 180 

cdp run GigabitEthernet 0 

! 

icmp echo on 

! 

  



1. Let's login with the credentials we defined during the post-installation setup. 

 

 

1. We are greeted by the ISE dashboard. 



 

 

  

  

Provisioning CA and Server Certificates 

Provision both ISE nodes with the CA root certificate and their own individual server certificates 

(generated by certificate signing requests). 

Relevant documentation: 

http://www.cisco.com/en/US/docs/security/ise/1.1.1/user_guide/ise_man_cert.html 

  

CA Certificate 

1. First, download the Root CA Certificate from your Certificate Authority 



http://<ca>/certsrv/ 

Click “Download a CA certificate, certificate chain, or CRL” 

  

 

  

1. Click “Download CA Certificate” 



  

1. Save it to a location on your file system. 

  

1. On ISE go to Administration > System > Certificates > Certificate Store. Click “Import” 



2. Click Browse and locate the root CA Certificate. 

3. Tick “Trust for Client Authentication”. If you don’t you may see failures with “12514 

EAP-TLS failed SSL/TLS handshake because of an unknown CA in the client certificates 

chain” when using EAP-TLS 

4. Click “Submit”. 

  

1. The CA Certificate will appear alongside the original self-signed certificate generated by 

ISE. 

 

 

1. Repeat these steps on all nodes that will be in the deployment. 

ISE Local Server Certificates 

1. On each node go to Administration > System > Certificates > Local Certificates 

2. Click Add > Generate Certificate Signing Request 



3. Fill in the CN with the ISE nodes FQDN and any other relevant fields. Click “Submit” 

  

1. Go to Administration > System > Certificates > Certificate Signing Requests > 

2. Tick the request and click export. 

 

 



1. Save the request onto your computer and open it in notepad. 

2. On your Microsoft CA Server (http://dc.sec.lab/certsrv/ ) go to Request Certificate > 

advanced certificate request > 

3. Paste the contents of the CSR into the request field and select “Web Server” as the 

template. 

  

1. Click Submit 

2. Download the DER encoded certificate. Click “Download Certificate” 

3. On ISE go to go to Administration > System > Certificates > Local Certificates 

4. Click “Add” > “Bind CA Certificate” 

5. Select the certificate from your computer. Tick “EAP” and “Management Interface” and 

click “Submit” 



  

1. ISE will need to reload to complete the certificate installation. 

2. Perform this task on all nodes in the deployment before joining them together. 

  

Registering Nodes and Setting up a Distributed Deployment 

Now we will register our policy node (PSN) to our primary administration/monitoring 

(PAP/PAN/MNT) node. 

Relevant documentation: 

http://www.cisco.com/en/US/docs/security/ise/1.1.1/user_guide/ise_dis_deploy.html 

Setting up the primary node 

1. Go to Administration > System > Deployment and click on the current node to edit it. 

2. Click the “Make Primary” button. 



 

 

1. Since this will be our Administration and Monitoring node, we should untick Policy 

Service. 

  

1. Click “Save”. The node will be restarted. 

Joining secondary / PSN nodes 

  

1. On the PAP go to Administration > System > Deployment and click “Register > An ISE 

node” 



2. Enter the FQDN/IP and credentials of the new node. 

  

1. Since this will be a Policy Service Node (PSN) we will untick Administration and 

Monitoring and leave Policy Service Ticked. 

  

1. Click “Submit”. 

2. Synchronisation will occur and the PSN node will be restarted. When finished the 

Replication Status will be COMPLETE and the Sync Status will be SYNC COMPLETED. 



 

  

  

Adding a Network Device to ISE 

We will need to add our Wireless Lan Controller (WLC) or switch as a Network Device in ISE so 

that ISE trusts RADIUS traffic coming from it. 

1. Go to Administration > Network Resources > Network Devices 

2. Click the ‘Add’ button. 

 

 

1. Fill out the Network Devices page with the required information. Select authentication 

and define a RADIUS shared secret. 



  

1. Click save and you’re done. 

  



Configuring the Wireless LAN Controller 

We need to add the PSN as a RADIUS Authentication and Accounting Server, Create an 

unsecure SSID (for Central Web Authentication) and a Secure SSID (for EAP-TLS and PEAP) and 

define a redirection ACL. 

Relevant Guides: 

Central Web Authentication on the WLC and ISE Configuration Example 

http://www.cisco.com/en/US/products/ps11640/products_configuration_example09186a0080

bead09.shtml 

Central Web Authentication with a Switch and Identity Services Engine Configuration Example 

http://www.cisco.com/en/US/products/ps11640/products_configuration_example09186a0080

ba6514.shtml 

Switch and Wireless LAN Controller Configuration Required to Support Cisco ISE Functions 

http://www.cisco.com/en/US/docs/security/ise/1.1.1/user_guide/ise_sw_cnfg.html 

Cisco TrustSec How -To Guide: Central Web Authentication 

http://www.cisco.com/en/US/solutions/collateral/ns340/ns414/ns742/ns744/docs/howto_40_

webauthenticat... 

  

Add ISE as a RADIUS Authentication/Accounting Server 

1. Go to Security > AAA > RADIUS > Authentication 

2. Set the Calling Station ID Type as “System MAC Address” 

 

 



1. Click the ‘New’ button. 

2. Enter the IP address of the PSN node, RADIUS shared secret (configured on ISE) and 

leave the other options as default. 

 

 

Note: Support for RFC 3576 enables CoA, which is required to send redirect URLs and new 

Authz profiles. 

1. Click Apply. The RADIUS Authentication Server will appear in the list: 

 

 

1. Perform the same steps to add ISE as an accounting server under Security > AAA > 

RADIUS > Accounting. 



  

  

Creating the redirect ACL 

When we perform URL redirection on a WLC we need to define a redirection ACL. This ACL will 

identify traffic which should NOT be processed for redirection by PERMITTING it. Traffic which 

should be redirected will be identified via an explicit or implicit DENY. 

When we perform a redirection on a switch a similar ACL will be used, however, the syntax is 

the opposite. On a switch we identify traffic we DO wish to redirect using a PERMIT and traffic 

we do NOT want to redirect using a DENY. 

1. On the WLC go to Security > Access Control Lists > Access Control Lists 

2. Click ‘New’ and give the ACL a name. For example, ACL-NSP-REDIRECT. Select IPv4. 

  

1. Click ‘Add New Rule’. 



This ACL is referenced in the access-accept from the ISE and defines what traffic should be 

redirected (denied by the ACL) and what traffic should not be redirected (permitted by the 

ACL). Basically, DNS and traffic to/from the ISE needs to be permitted. 

  

  

Se

q 

Actio

n 
Source IP/Mask Destination IP/Mask 

Protoc

ol 

Sourc

e 

Port 

Des

t 

Por

t 

DSC

P 

Directio

n 

1 
Perm

it 
0.0.0.0/ 0.0.0.0 

10.66.83.156/255.255.255

.255 
Any Any Any Any Any 

2 
Perm

it 

10.66.83.156/255.255.255

.255 
0.0.0.0/ 0.0.0.0 Any Any Any Any Any 

3 
Perm

it 
0.0.0.0/ 0.0.0.0 

10.66.83.88/255.255.255.

255 
UDP Any 

DN

S 
Any Any 

4 
Perm

it 

10.66.83.88/255.255.255.

255 
0.0.0.0/ 0.0.0.0 UDP DNS Any Any Any 

Note: An explicit deny any any exists at the end. All traffic not permitted will be marked for 

redirection. 



  

As an example of Switch redirect ACL: 

Ip access-list extended ACL-NSP-REDIRECT 

remark explicitly deny DNS from being redirected 

Deny udp any host <dns ip> eq 53 

remark explicitly deny traffic to ISE from being redirected 

deny ip any host <ise PSN IP> 

remark define which traffic should trigger a redirect 

permit tcp any any eq www 

permit tcp any any eq 443 

permit tcp any any eq 8443 

remark implicit deny will stop all other traffic from being redirected on. 

  

See the following for more information: 

Switch Configuration Required To Support ISE Functions 

http://www.cisco.com/en/US/docs/security/ise/1.1.1/user_guide/ise_sw_cnfg.html 

Central Web Authentication with a Switch and Identity Services Engine Configuration Example 

http://www.cisco.com/en/US/products/ps11640/products_configuration_example09186a0080

ba6514.shtml 

  

Proxy Considerations 

NOTE: By default Cisco switches and WLCs only process packets marked for redirection which 

have a destination port of 80 or 443. If we are going to use a proxy on our Web Browser then 



we need to explicitly allow traffic to ISE without proxying. All modern browsers support this 

function. 

If the proxy uses a non-standard port, then we will need to configure our WLC and Switch to 

support this: 

On Wireless Lan Controllers: 

(Cisco Controller) >config network web-auth port ? 

<port>         Configures additional ports for web-auth redirection. 

On Cisco Switches: 

ip http port 8080 

ip port-map http port 8080 

Where ‘8080’ is any port the customer is using for their proxy. 

  

Create the WLANs / SSIDs 

We will need two SSIDs since we are going to perform a combination of Single and Dual SSID 

BYOD. 

Dual SSID BYOD Client enters network via open SSID and and is 

redirected to CWA. Guest portal redirects 

Employees to supplicant provisioning and 

Guests to Internet Access. 

Single SSID BYOD Employee enters network via PEAP-MSCHAPv2 

on secured SSID and is provisioned for EAP-TLS 

access on the same SSID. 

Guest cannot access this SSID. 

  

The open SSID, called Onboarding, will redirect employees to supplicant provisioning and guests 

to internet access. 

The closed SSID, called Corporate, will redirect employees to supplication provisioning if they 

authenticate via PEAP and allow full access if they authenticate via EAP-TLS. 



Open SSID (For Dual SSID BYOD) 

  

1. On the WLC go to WLANs. Select ‘Create New’ and click ‘Go’. 

  

 

1. Fill in the Profile name and SSID with an appropriate name and click ‘Apply’. E.g. Guest, 

Onboarding, CWA. 

 



1. On the General Page tick ‘Status Enabled’ and ‘Broadcast SSID Enabled’. Configure an 

Interface Group. 

  

1. Under Security > Layer 2 select: 

Layer 2 Security None 

MAC Filtering Ticked – This will enable MAB/Call-Check based authentication. 

  



1. Under Security > AAA Servers

Configure the ISE PSN as the radius and accounting server.

Tick ‘Interim Update’ 

Set RADIUS as the first authentication source used.

 

1. Under Advanced 

Enable ‘AAA Override’ 

Set the NAC State as ‘Radius NAC’

Enable ‘DHCP Profiling’ 

Under Security > AAA Servers 

Configure the ISE PSN as the radius and accounting server. 

Set RADIUS as the first authentication source used. 

Set the NAC State as ‘Radius NAC’ 

 



 

 

  

1. Click the ‘Apply’ button. 

Secure SSID (For Dual and Single SSID BYOD) 



  

1. On the WLC go to WLANs. Select ‘Create New’ and click ‘Go’. 

 

 

1. Fill in the Profile name and SSID with an appropriate name and click ‘Apply’. E.g. 

Corporate, Secure. 

 

 

1. On the General Page tick ‘Status Enabled’ and ‘Broadcast SSID Enabled’. Configure an 

Interface Group. 



  

1. Under Security > Layer 2 select: 

Layer 2 Security WPA+WPA2 

WPA2 Policy Ticked 

WPA2 Encryption AES 

Key Management > 802.1X Enable 



  

1. Under Security > AAA Servers 

Configure the ISE PSN as the radius and accounting server. 

Tick ‘Interim Update’ 

Set RADIUS as the first authentication source used. 



 

1. Under Advanced 

Enable ‘AAA Override’ 

Set the NAC State as ‘Radius NAC’

Enable ‘DHCP Profiling’ 

Set the NAC State as ‘Radius NAC’ 



 

 

 

  

As far as the WLC is concerned, we’re done. Users authenticating on the Open SSID 

‘Onboarding’ will generate a MAB based authentication to ISE. Users authenticating on the 

Secure SSID ‘Corporate’ will generate a 802.1x RADIUS PEAP/EAP-TLS authentication to ISE. 

  

Configuring Identity Sources 

Joining Nodes to Active Directory 

  

Managing External Identity Stores 

http://www.cisco.com/en/US/docs/security/ise/1.1.1/user_guide/ise_man_id_stores.html 



  

1. Go to Administation > Identity Management > External Identity Sources > Active 

Directory 

2. Tick all the relevant nodes. 

 

1. Click the Join button and type in the credentials to join the domain. 

Note: The Active Directory account required for domain access in ISE should have either of 

these:  

    • 'Add workstations to domain' user right in corresponding domain.  

    • 'Create Computer Objects' or 'Delete Computer Objects' permission on corresponding 

computers container where ISEs machine's account is created before joining ACS machine to 

the domain. 

 

By Default AD Domain Admins, Administrators and Account Operators can add/delete 

computers to the domain 

  



  

1. The join should complete successfully. 

  

1. The nodes will display which domain controller they have joined to. 

  

Adding Active Directory Groups 

We are going to use two Active Directory groups for our example configuration. 

Contractors will not undergo provisioning and will be provided network access. 

Employees will undergo provisioning before being provided with network access. 



1. Go to Administration > Identity Management > External Identity Sources > Active 

Directory 

2. Click the ‘Groups’ tab. 

3. Click the ‘Add’ button and choose ‘Select Groups from Directory’. 

 

 

1. Click the ‘Retrieve Groups’ button to retrieve the groups. Optionally: Specify a group 

name. 

2. Tick the desired groups and click ‘Ok’ to add them. 

 

 

  

1. You will see the groups appear in the Groups list on ISE. 



  

  

Certificate Authentication Profile 

This will be the ‘identity source’ which authenticates client certificates as in the case of EAP-TLS. 

The principle username x509 attribute will be the field from the client certificate that ISE uses 

to perform a lookup in Active Directory. This means we can perform certificate authentication, 

but still match groups and attributes of certain users and computers. 

1. Go to Administration > Identity Management > External Identity Sources > Certificate 

Authentication Profile 

2. Click Add 

3. Give the profile a name and selected the principle username attribute. 

The principle username x509 attribute will be the field from the client certificate that ISE uses 

to perform a lookup in Active Directory. 

  



1. Click ‘Save’ and the Certificate Authentication Profile will appear in the list. 

  

Identity Source Sequence 

We’re going to use an Identity Source Sequence for our Guest Portal and Secure SSID 

‘Corporate’ authentication rules. This is essentially a catch-all Identity Source Sequence that will 

authenticate users from Active Directory, Certificate based authentications and Internal Users. 

1. Go to Administration > Identity Management > Identity Source Sequences 

2. Click the Add button 

 

 

1. Name: AD_InternalUsers_Cert 

Tick ‘Certificate Authentication Profile’ and select our previously created cert profile from the 

list. 

Select ‘AD1’ and ‘Internal Users’ as possible Identity Sources. 

Under ‘Advanced’ select ‘Treat as if the user was not found and proceed to the next store in the 

sequence’. This will allow us to continue authentications even in the case of Active Directory 

connectivity issues. 



 

 

1. Click Save and the Identity Source Sequence will appear in the list. 



 

 

  

Guest Portal Setup 

We need to create a guest portal which we can send to users performing Web Authentication. 

We must assign an authentication sequence as well such that Internal Users and Active 

Directory Users can authenticate via the portal. 

1. Go to Administration > Web Portal Management > Settings > Guest > Multi-Portal 

Configuration 

2. Click the “Add” button 

 

1. On the General tab, name the portal and choose either “Default Portal” or “Custom 

Default Portal” if you want to upload custom HTML pages. 



  

1. On the operations tab make the following configuration: 

Untick “Enable Self-Provisioning Flow” – Ticking this option forces Non-Guest users through 

provisioning. However, if we don’t have any provisioning rules you may see the error “Your 

device configuration is not supported by the setup wizard”. We also want to be more granular 

with which users will undergo provisioning so we will leave this option unticked. 

  

1. On the Authentication tab make the following configuration: 

Authentication Type – Choose “Both” 

Identity Store Sequence – Choose the one we setup earlier “AD_Internal_Cert” 



Note: Guest allows only Internal Guest users to authenticate. Central Web Auth allows only 

Internal and External Users to Authenticate. 

  

1. Click “Save” and the portal will be stored. 

  

Client Provisioning Setup 

Enable Client Provisioning 

  

1. Go to Administration > System > Settings > Client Provisioning 

2. Check that Client Provisioning is set to “Enabled”. 

  



1. Enable Feeds if desired. This will allow ISE to pull the latest supplicant provisioning 

wizard from Cisco.com. 

2. Set “Native Supplicant Provisioning Policy Unavailable” to “Apply Defined Authorization 

Policy”. This means that devices without client provisioning polices will proceed to the 

next most relevant Authorization rule. 

Download Provisioning Resources 

  

1. Go to Policy > Policy Elements > Results > Client Provisioning > Resources 

2. Click the “Add” Button and select “Agent Resourced from Cisco Site” 

  

1. We are interested in the agent resourced ending with SPWizard (Supplicant Provisioning 

Wizard). We will be using WinSPWizard 1.0.0.28 so we will tick this then click “Save” 



  

1. After the download finishes the wizard will appear in the list of Resources. 

  

  

  

Create Provisioning Profile 

The provisioning profile or Native Supplicant Profile is pushed to devices using the supplicant 

provisioning wizard. It contains settings concerning the protocol we are expect to use after 

provisioning, and which SSID we will connect to (as in the case of Dual SSID BYOD). 

1. Go to Policy > Policy Elements > Results > Client Provisioning > Resources 

2. Click “Add” and select “Native Supplicant Profile”. 



3. Configure the following: 

• Name – Can be anything. We’ll use BYOD. 

• Operating System – All 

• Connection Type – Wired and Wireless. This allows the profile to be used to provision 

devices on wired and wireless connections 

• Security – WPA2 Enterprise 

• Allowed Protocol – TLS. Since we intend to provision endpoints with certificates we will 

choose TLS. PEAP is used for Username / Passwords. 

• Key Size – 2048 

  

1. Click “Save” and the profile will appear in the list of resources. 



  

Client Provisioning Rules / Policies 

These policies / rules are used to decide which Identity Group, Operating System or Other 

Conditions receive which Supplicant Provisioning Wizard and Provisioning Profile. 

We are going to push WinSPWizard 1.0.0.28 and the “BYOD” profile for AD group “Employees” 

who are on Windows. 

Enabled Rule 

Name 

Identity 

Group 

Operating 

System 

Other Conditions Results 

Yes Windows Any Windows 

All 

AD1:ExternalGroups EQUALS 

sec.lab/Users/Employees 

WinSPWizard 

1.0.0.28 AND BYOD 

  

1. Go to Policy > Client Provisioning Policy 

2. Per the table above, enter in each of the required conditions. The basic requirement 

here is that we specify and Operating System and User Group and select which BYOD 

profile and provisioning wizard they will receive. 

 

 

  

Simple Certificate Enrolment Protocol (SCEP) 

Relevant Guides: 

TrustSec How-to BYOD Using Certificates for Differentiated Access 



http://www.cisco.com/en/US/solutions/collateral/ns340/ns414/ns742/ns744/docs/howto_60_

byod_certifica... 

TrustSec BYOD Smart Solution Design Guide 

http://www.cisco.com/en/US/docs/solutions/Enterprise/Borderless_Networks/Unified_Access/

byoddg.html 

Configure SCEP Support for BYOD 

http://www.cisco.com/en/US/products/ps11640/products_tech_note09186a0080bff108.shtml 

  

Windows Server Setup 

1. Install Windows Server 2008 RS Enterprise Server 

2. After installation completes activate the Windows License and download all Microsoft 

Updates. 

Before you configure SCEP support for BYOD, ensure that the Windows 2008 R2 NDES server 

has these Microsoft hotfixes installed: 

  

Renewal request for a SCEP certificate fails in Windows Server 2008 R2 if the certificate is 

managed... -  This issue occurs because NDES does not support the GetCACaps operation. 

http://support.microsoft.com/kb/2483564 

NDES does not submit certificate requests after the enterprise CA is restarted in Windows 

Server 200... - This message appears in the Event Viewer: "The Network Device Enrolment 

Service cannot submit the certificate request (0x800706ba). The RPC server is unavailable." 

http://support.microsoft.com/kb/2633200 

  

1. Install and configure Active Directory Domain Services 

1. Select the “advanced” mode checkbox. 

2. Create a new domain in a forest. 

3. Insert the name for the forest root domain. 

4. Install DNS Server. 

5. Wait for Active Directory Services to finish installing and reboot. 



 

 

1. Install and configure Active Directory Certificate Services. 

1. Role Services: 

• Certificate Authority 

• Certificate Authority Web Enrolment 

1. Setup Type: Select “Enterprise” 

2. CA Type: Root CA 

3. Private Key: Create New Private Key 

• Cryptography: Default Value, select SHA256 for hash algorithm. 

• CA Name: leave as default 

• Validity Period: Default 

1. Certificate Database: Default 



 

 

  



1. Web Server (IIS): Click Next 

• Role Services: Default 

1. Click Install 

2. Go to Server Manager > Roles > Active Directory Certificate Services 

• Select “Network Device Enrolment Service” and “Certificate Authority Web Enrollment” 

• For the Web Enrollement user account, this may be a local Administrator or a SCEP 

service account (one added to the IIS_USERS Group). 

RA Information – Default 

Cryptography – Default 

CA for CES – Default 

Authentication Type – Default 

Service Account – Default / Choose an administrator account. 

Server Authentication Certificate 

Choose an existing certificate for SSL encryption - Select the certificate with ‘Client 

Authentication’ as the Intended Purpose. 

Web Server (IIS) – Click Next 

Role Servers – Default 

Confirmation: Install 

  

1. Disable SCEP Enrollement Challenge Password Requirement 

By default, Microsoft's SCEP (MSCEP) implementation uses a dynamic challenge password to 

authenticate clients and endpoints throughout the certificate enrollment process.  With this 

configuration requirement in place, users must browse to the MSCEP admin web GUI on the 

NDES server to generate a password on-demand.  As part of the registration request, the user 

must include this password. 

In a BYOD deployment, the requirement of a challenge password defeats the purpose of a user 

self-service solution.  In order to remove this requirement, this registry key must be modified 

on the NDES server: 

  

• Click Start and enter regedit in the search bar. 

• Navigate to:  Computer > HKEY_LOCAL_MACHINE > SOFTWARE > Microsoft > 

Cryptography > MSCEP > EnforcePassword. 



Computer\HKEY_LOCAL_MACHINE

ord 

  

• Ensure that the EnforcePassword value is set to "0" (default is "1").

 

1. Extend URL Length in IIS

It is possible for ISE to generate URLs, which are too long for the IIS web server. To avoid this 

problem, the default IIS configuration can be modified to allow longer URLs.

Enter the following command in a CLI cmd.exe:

  

%systemroot%\system32\inetsrv

/section:system.webServer/security/requestFiltering /requestLimits.maxQueryString:"8192" 

/commit:apphost 

 

1. Certificate Template Configuration

1. On your CA Server go to Administrative Tools > Certification Authority

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Cryptography\MSCEP

Ensure that the EnforcePassword value is set to "0" (default is "1").

Extend URL Length in IIS 

nerate URLs, which are too long for the IIS web server. To avoid this 

problem, the default IIS configuration can be modified to allow longer URLs.

Enter the following command in a CLI cmd.exe: 

inetsrv\appcmd.exe set config 

section:system.webServer/security/requestFiltering /requestLimits.maxQueryString:"8192" 

Certificate Template Configuration 

On your CA Server go to Administrative Tools > Certification Authority

MSCEP\EnforcePassw

Ensure that the EnforcePassword value is set to "0" (default is "1"). 

 

nerate URLs, which are too long for the IIS web server. To avoid this 

problem, the default IIS configuration can be modified to allow longer URLs. 

section:system.webServer/security/requestFiltering /requestLimits.maxQueryString:"8192" 

 

On your CA Server go to Administrative Tools > Certification Authority 



2. Open the Certificate Templates folder. These are the currently enabled 

Certificate Templates. 

  

1. Right Click on the Certificate Templates Folder and choose Manage. This will open the 

Certificates Templates Console. 



 

 

1. Right Click on the ‘User’ template and duplicate it. 



 

1. Then choose Windows 2003 

operating system (OS) in the environment.

 

1. On the General tab add a display name, such as BYOD.

Then choose Windows 2003 or Windows 2008, dependent upon the minimum CA 

operating system (OS) in the environment. 

 

On the General tab add a display name, such as BYOD. 

 

or Windows 2008, dependent upon the minimum CA 



Check ‘Publish Certificate in Active Directory’ 

  

1. On the Extensions tab: 

• Click Application Policies > Edit 

• Ensure ‘Client Authentication’ is added as an application policy. 

• Click Ok 



 

• If possible, configure ‘Basic Constraints’ to ‘Enable this Extension’. This sets the 

certificate to belong to an endpoint, and not a subsequent signer. (optional)

If possible, configure ‘Basic Constraints’ to ‘Enable this Extension’. This sets the 

certificate to belong to an endpoint, and not a subsequent signer. (optional)

 

If possible, configure ‘Basic Constraints’ to ‘Enable this Extension’. This sets the 

certificate to belong to an endpoint, and not a subsequent signer. (optional) 



 

 

• Edit ‘Issuance Policies’ and add ‘All Issuance Policies’. Issuance Policies must be 

configured, to allow the CA to actually issue the certificate. 



 

1. On the Request Handling Tab:

• Uncheck Allow Private Key to be Exported.

• Select ‘Enroll Subject without Requiring any us

On the Request Handling Tab: 

Uncheck Allow Private Key to be Exported. 

Select ‘Enroll Subject without Requiring any user input’ 

 



  

1. On the Subject Name Tab 

• Select “Supply In Request”, ignore any security warnings. This is necessary since the 

certificate is not being created by an Active Directory member, but through SCEP 

instead. 



  

1. On the Cryptography Tab 

• Select ‘Requests can use any provider available on the subject’s computer’. 



 

1. If you are using a SCEP service account add this user in the Security Tab.

See the following for more details: 

http://www.cisco.com/en/US/solutions/collateral/ns340/ns414/ns742/ns744/docs/howto_60_

byod_certifica... 

For our test we are just using ‘Administrator’.

 

If you are using a SCEP service account add this user in the Security Tab.

See the following for more details: 

http://www.cisco.com/en/US/solutions/collateral/ns340/ns414/ns742/ns744/docs/howto_60_

For our test we are just using ‘Administrator’. 

If you are using a SCEP service account add this user in the Security Tab. 

http://www.cisco.com/en/US/solutions/collateral/ns340/ns414/ns742/ns744/docs/howto_60_



 

1. Click ‘OK’ and the finished template should appear in the lis

 

Click ‘OK’ and the finished template should appear in the list of Certificate Templates:t of Certificate Templates: 



 

1. Assign the Template for Issuance

1. Return to the Certificate Authority management console (Administrative Tools > 

Certification Authority). Right Click ‘Certificate Templates’ and click ‘New > 

Certificate Template to Issue’

Alternatively, this step can be performed from the command line CLI:

certutil -SetCAtemplates +BYOD

 

Assign the Template for Issuance 

Return to the Certificate Authority management console (Administrative Tools > 

Certification Authority). Right Click ‘Certificate Templates’ and click ‘New > 

Certificate Template to Issue’ 

Alternatively, this step can be performed from the command line CLI: 

SetCAtemplates +BYOD 

 

Return to the Certificate Authority management console (Administrative Tools > 

Certification Authority). Right Click ‘Certificate Templates’ and click ‘New > 



1. Select the ‘BYOD’ Certificate Template we made earlier and click ‘OK’. It should then 

appear in the list of CA Certificate Templates.

 

 

Select the ‘BYOD’ Certificate Template we made earlier and click ‘OK’. It should then 

appear in the list of CA Certificate Templates. 

Select the ‘BYOD’ Certificate Template we made earlier and click ‘OK’. It should then 

 

 



1. Modify the Default Certificate that is Issued (Certificate Template Registry 

Configuration) 

1. Go to Start > Run > Regedit 

2. Navigate to 

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Cryptography\MSCEP 

3. Change the EncryptionTemplate, GeneralPurposeTemplate, and 

SignatureTemplate keys from IPSec (Offline Request) to the BYOD template 

previously created. 

 

 

1. Restart the Server to apply these settings. 

2. Test the SCEP URL in your browser, usually http://domain-controller-

fqdn/certsrv/mscep 

  

  

  

Configure ISE as a SCEP Proxy 

In a BYOD deployment, the endpoint does not communicate directly with the backend NDES 

server. Instead, the ISE policy node is configured as a SCEP proxy and communicates with the 

NDES server on behalf of the endpoints. The endpoints communicate directly with ISE. The IIS 



instance on the NDES server can be configured to support HTTP and/or HTTPS bindings for the 

SCEP virtual directories. 

1. In ISE, go to Administration > Certificates > SCEP CA Profiles. 

2. Click ‘Add’. 

3. Enter a Server Name and Description 

 

 

1. Click the ‘Test Connectivity’ button to ensure ISE can load the URL. 

  

1. Click ‘Submit’, the SCEP profile should appear in the list of profiles. 

  

Authentication and Authorization 

Authentication Rules 



We need four authentication rules to cover Wireless MAC Address Bypass (Wireless MAB), 

Wireless dot1x (such as PEAP and EAP-TLS), Wired MAB and Wired Dot1x. 

The MAB rules should use the Internal Endpoints Identity Store. The other special requirement 

here is that the MAB rules be set to ‘Continue’ in the case of ‘User Not Found’. This is because 

ISE has no prior knowledge of the endpoint and we need it to proceed through to authorization 

so we can redirect it to CWA. 

The dot1x rules should use the ‘AD_InternalUsers_Cert’ Identity Sequence we configured 

earlier. This will allow 802.1x clients to authenticate with their choice of PEAP and EAP-TLS and 

hit Active Directory, Internal Users or a Certificate Profile. 

Name Conditions Allowed Protocol Identity Source Options 

Wireless 

MAB 

Wireless_MAB Default Network 

Access 

Internal Endpoints Authentication Failed = 

Reject 

User Not Found = 

Continue 

Process Failed = Drop 

Wireless 

Dot1X 

Wireless_802.1X Default Network 

Access 

AD_InternalUsers_Cert Authentication Failed = 

Reject 

User Not Found = 

Reject 

Process Failed = Drop 

MAB Wired_MAB Default Network 

Access 

Internal Endpoints Authentication Failed = 

Reject 

User Not Found = 

Continue 

Process Failed = Drop 

Dot1X Wired_802.1X Default Network 

Access 

AD_InternalUsers_Cert Authentication Failed = 

Reject 

User Not Found = 

Reject 

Process Failed = Drop 

  



Relevant Documents: 

Central Web Authentication on the WLC and ISE Configuration Example 

http://www.cisco.com/en/US/products/ps11640/products_configuration_example09186a0080

bead09.shtml 

Central Web Authentication with a Switch and Identity Services Engine Configuration Example 

http://www.cisco.com/en/US/products/ps11640/products_configuration_example09186a0080

ba6514.shtml 

  

1. Go to Policy > Authentication 

2. Click Actions > Insert New Row Above for each of the needed rules. 

  

1. Fill out each rule per the table above. 

2. For the Condition choose Compound Condition then the appropriate condition for the 

rule as outlined in the above table. 



  

1. For the Allowed Protocol choose ‘Default Network Access’. 

  

More rules may be created or edited, if desired, in Policy > Results > Authentication. This is 

where you may choose which authentication methods (Host Lookup, EAP, PEAP etc) are 

allowed for a specific Authentication Rule. 



 

 

1. Click the drop down arrow and for the Identity Store choose the relevant Identity Source 

and Reject/Drop/Continue options for each scenario as outlined in the table above. 

 

1. Once all the rules have been recreated they should look like this: 



  

  

  

Authorization Profiles 

The Authorization Profiles define what kind of access we push back to a user that succeeds 

Authentication. Authorization Profiles can contain many things such as: Web Authentication 

Redirection, Client Provisioning, Posture Assessment and Provisioning, VLANs, DACLS, etc. 

For our implementation we will need to create two Authorization Profiles: 

CWA – To push a Centralised Web Authentication (CWA) Redirect to users who have 

authenticated via MAB. 

NSP – To push the Supplicant Provisioning Wizard and EAP-TLS Client Provisioning Profile to 

users who authenticate via PEAP. 

1. Go to Policy > Results > Authorization Profiles. 

2. Click the ‘Add’ button. 

3. For the ‘CWA’ profile configure as follows: 

• Name: CWA 

• Access Type: Access_Accept 

• Common Tasks: 

• Web Authentication – Centralized – ACL: ACL-NSP-REDIRECT – Redirect: Default 

Note: ACL-NSP-REDIRECT is the redirect ACL defined on the WLC or Switch for redirect traffic. 

We configured this earlier. 



Note: ‘Redirect:’ may be set to ‘Manual’ and we can manually specify ‘DefaultGuestPortal’ or 

our own Custom Portal. 

  

 

  

1. For the ‘NSP’ profile, configure as follows: 

• Name: NSP 



• Access Type: Access_Accept 

• Common Tasks: 

• Web Authentication – Supplicant Provisioning – ACL: ACL-NSP-REDIRECT 

 

 

1. We should now have our CWA, NSP, PermitAccess and DenyAccess authorization 

profiles: 



  

  

Authorization Rules 

We are going to implement the rules necessary for both Single SSID and Dual SSID Mode. 

-          In Single SSID mode we are going to check which group the user belongs to and whether 

they authenticate via PEAP or EAP-TLS. 

• If the user access is PEAP and a Contractor: we permit them access. 

• If the user access is PEAP and an Employee: we send them through supplicant 

provisioning and they reconnect to the Corporate SSID with EAP-TLS. 

• If the user access is EAP-TLS and an Employee: we permit them access. 

  

-          In Dual SSID mode users will authenticate via MAB and login via the CWA Guest Portal 

before we allow access or provision them. 

• If the user access is Guest Flow and a Contractor: we permit them access. 

• If the user access is Guest Flow and an Employee: we send them through supplicant 

provisioning and they reconnect with EAP-TLS. 

The way this looks in terms of actual rules is as such: 

  Name Conditions Permissions 

1 Contractor AD1:ExternalGroups EQUALS sec.lab/Builtin/Contractor PermitAccess



2 Employee_PostCWA (AD1:ExternalGroups EQUALS 

sec.lab/Users/Employee AND Network Access:UseCase 

EQUALS Guest Flow ) 

NSP 

3 Employee_PEAP (AD1:ExternalGroups EQUALS 

sec.lab/Users/Employee AND Network 

Access:EapTunnel EQUALS PEAP ) 

NSP 

4 Employee (AD1:ExternalGroups EQUALS 

sec.lab/Users/Employee AND Network 

Access:EapAuthentication EQUALS EAP-TLS ) 

PermitAccess

5 Guest Guest PermitAccess

6 CWA Wireless_MAB CWA 

7 Default -- DenyAccess 

  

Note: ISE evaluates each rule sequentially. It will choose the first rule that satisfies all the 

criteria conditions. In this sense, we ‘fail’ each rule until we hit one that matches. 

For example, unknown endpoints authenticating via Wireless_MAB will fail all previous rules 

because ISE will not know their Group Membership or Username. They will match the CWA rule 

and receive the CWA authorization profile, which redirects them to the Guest Portal. 

  

Note: The condition ‘Network Access:UseCase EQUALS Guest Flow’ refers to a session flag 

which is set if the client authenticates via the Guest Portal. With this condition, when 

referenced in an authorization rule, we are checking to see if the user came in through the 

Guest Portal or not. 

  

As part of this configuration example we will configure the Employee_PEAP rule. The 

Employee_PEAP rule will match employees authenticating on the Corporate SSID with their 

Active Directory credentials (PEAP). It will then push an authorization profile that will redirect 

employees through supplicant provisioning. 

1. Go to Policy > Authorization 

2. Click the Down Arrow and click “Insert New Rule Above” 

  



1. Name the rule Employee_PEAP 

  

1. For the Identity Group choose ‘Any’. These Identity Groups refer to Internal groups in 

ISE. We will be referencing the Active Directory group in our Conditions. 

2. Expand the conditions box, click the cog and select ‘Add Attribute/Value’. 

  

1. Add the following attributes/values to build our conditions: 

AD1:ExternalGroups EQUALS sec.lab/Users/Employee 

Network Access:EapTunnel EQUALS PEAP  

 

 

1. Close the Conditions box and expand the Permissions box. Select Standard then ‘NSP’. 



  

1. Repeat the above steps for each of the needed authorization rules 

  

  

User Experience 

Dual SSID Employee 

1. The employee connects to WLAN SSID ‘Onboarding’ and authentication takes place in 

the background via MAB. 



  

1. This is what the MAB authentication and CWA authorization looks like on the ISE 

 

 

1. When the user attempts to access a website, for example http://www.cisco.com/, they 

are redirected by the WLC to the ISE Guest Portal. 

The default web address for the ISE Guest Portal is https://ise113-

2.sec.lab:8443/guestportal/Login.action with a session ID on the end. 



 

 

1. The user passes authentication and is asked to retry their original URL. 

Although there is no way for ISE to automatically redirect users to their originally requested 

page, if we use a custom portal then we can include a HTML or Javascript redirect in our success 

html page to force their browsers to a page of our choice. 



 

 

1. The makes another request for http://www.cisco.com/ and is redirected once more to 

the Self-Provisioning Portal. 

Note: We can avoid needing to make a second website request by forcing users directly into 

provisioning. This achieved by ticking ‘Enable Self-Provisioning Flow’ for the specific portal 

setup in ISE. This is covered in the section ‘Guest Portal Setup’ above. 



 

 

1. After the user clicks ‘Register’ they are prompted to download and sun the Network 

Setup Assistant, also known as the Native Supplicant Provisioning Wizard (NSP or SPW). 



 

 

1. The Network Setup Assistant appears. The user may be prompted by browser security 

warnings. 



  

1. The wizard prompts the user for permission to install the CA certificate chain. 



  

1. The wizard should successfully install the CA certificate chain and provision an identity 

certificate for the device via SCEP. 

If an error occurs, check the spwProfileLog.txt file located in C:\Users\[your 

username]\AppData\Local\Temp. 



  

1. The wizard will automatically connect the user to the network defined in the 

Provisioning profile. In our case it is ‘Corporate’. The user now has full network access. 



  

1. This is what the final set of authentications/authorizations look like on the ISE 

dashboard: 

  

Note how the user proceeds through CWA, NSP and finally PermitAccess. 

1. If we open the Windows Management Console (Start > Run > mmc) and then the 

Certificates snap-in (File > Add/Remove Snap-in) we can see the Identity certificate 

provisioned by ISE via SCEP: 



 

Single SSID Employee

1. The employee connects to WLAN SSID ‘Corporate’ and is prompted for their Active 

Directory credentials. 

Single SSID Employee 

The employee connects to WLAN SSID ‘Corporate’ and is prompted for their Active 

 

 

The employee connects to WLAN SSID ‘Corporate’ and is prompted for their Active 



  

For this example the employee is jsmith. 



 

1. The user goes through the same steps as 5

above. 

2. This is what the final set of authentications/authorizations look like on the ISE 

dashboard: 

 

Note how the user proceeds through NSP and PermitAccess.

Single and Dual SSID Contractor

Since our authorization rule permits access to contractors regardless of their Network Access 

type (Guest Portal, PEAP, etc) they will never go through supplicant provisioning.

Contractors connecting via the open ‘Onboarding’ or s

immediately proceed to full network access.

 

The user goes through the same steps as 5-10 in the section ‘Dual SSID Employee’ 

This is what the final set of authentications/authorizations look like on the ISE 

Note how the user proceeds through NSP and PermitAccess. 

and Dual SSID Contractor 

Since our authorization rule permits access to contractors regardless of their Network Access 

type (Guest Portal, PEAP, etc) they will never go through supplicant provisioning.

Contractors connecting via the open ‘Onboarding’ or secure ‘Corporate’ network will 

immediately proceed to full network access. 

10 in the section ‘Dual SSID Employee’ 

This is what the final set of authentications/authorizations look like on the ISE 

 

Since our authorization rule permits access to contractors regardless of their Network Access 

type (Guest Portal, PEAP, etc) they will never go through supplicant provisioning. 

ecure ‘Corporate’ network will 



Here is how a contractor authentication appears on the ISE dashboard. In this case the 

contractor has connected to SSID ‘Onboarding’ and authenticated via the guest portal. 

  

 

 

  

  


