link down entre WS-C2970-24TS-E e WS-C2960G-24TC-L

Unanswered Question
Feb 15th, 2012

Viva,

Configurei 2 switches catalyst, uma do modelo 2970 (WS-C2970-24TS-E) e outra do modelo 2960 (WS-C2960G.24TC-L) para ter conectividade entre os dois estou a usar fibra ótica SM, utilizado as portas 25 do swittch 2970 e 22 do switch 2960.

2970

interface GigabitEthernet0/25

description uplink b01-sw01

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 50,280

switchport mode trunk

speed nonegotiate

2960

interface GigabitEthernet0/22

description b01-sw10 (mon)

switchport trunk allowed vlan 50,280

switchport mode trunk

media-type sfp

speed nonegotiate

Mas não faz link.

Como tenho outro switch mas do modelo 3750 (WS-C3750G-24TS), configurei a porta g1/0/28 como a porta g0/25 do 2970 e consegui link (funcional com show cdp neighbors).

Como no switch 2960 não é possível definir o tipo de encasulation (bydefault é dot1q), logo o que falta para não estar a "linkar"?

Obrigado,

António

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 1.3 (6 ratings)
rcochenos Wed, 02/15/2012 - 15:43

António,

Esperimenta remover o speed nonegotiate de ambos os switchs.

abraço.

adeus Thu, 02/16/2012 - 00:50

Olá,

Este procedimento já foi testado e não dá link, também.

Obrigado,

António

andcastr Thu, 02/16/2012 - 10:32

Oi Antonio,

Uma possível causa seria a falta das vlans referidas na tabela do 2960. Outra possível causa é o conflito de vlan nativa nos switches. Elas precisam ter o mesmo número de identificação.

Consegues passar mensagens cpd entre o 2960 e o 2670?

De fato, o 2960 não dá a opção do encapsulamento do trunk, é 802.1q por padrão.

rcochenos Thu, 02/16/2012 - 10:37

António,

Confirma se alguma das portas está em err-disable e confirmação a polarização das Fibras, ou seja, se o TX de uma fibra está no RX da outra.

alemolina Thu, 02/16/2012 - 12:48

Antonio,

  Por acaso quando voce verifica  a conectividade dos link  pelo comando abaixo.

  show interface 0/25 status no switch 2970, apresenta not connected?

   Tente configurar manualmente a velocidade e a modo de operação duplex.

   speed 1000

   duplex full

  Obs:  Necessario configurar em ambos switches.

adeus Thu, 02/16/2012 - 13:22

Galera,

Todas as dicas que indicaram foram realizadas mas o resultado é o mesmo.

Neste momento vou trocar as SFP e depois trocar ambos os cabos de fibra ótica.

Assim que terminar os testes comunicarei.

António

P.S. No 2970 as interfaces a gigabit são por "padrão" a 1000 e o duplex é full, porque o gigabit é full duplex. E não existem qualquer erro nas interfaces nem err-disable.

adeus Fri, 02/17/2012 - 03:21

O problema estava num cabo de FO SM que estava na outra ponto (lado do 2970) que fica a 1 Km.

Neste momento tudo está operacional, com a substituição do cabo de fibra ótica.

Obrigado.

andcastr Fri, 02/17/2012 - 08:00

Ok, Antonio por favor marque essa discussão como respondida e também se desejar marque aquelas respostas que te ajudaram de alguma maneira a resolver o problema através das estrelar junto de cada resposta.

Um abraço,

adeus Fri, 02/17/2012 - 08:07

Oi André,

Como faz a discussão como respondida?

Obrigado,

António

andcastr Fri, 02/17/2012 - 08:11

Oi Antonio,

Escolha alguma resposta como "resposta correta", vc pode selecionar mais de uma resposta correta nessa discussão se for o caso.

Daí a questão fica marcada como respondida.

adeus Fri, 02/17/2012 - 08:15

Mas André,

A resposta correta foi a minha resposta. Eu não consigo colocar resposta correta à minha colocação (my post).

andcastr Fri, 02/17/2012 - 08:19

Escolhe a(s) pergunta(s) que te ajudaram, aquelas que aplicastes pra tentar resolver o problema por exemplo.

A ideia é reconhecer a ajuda provida.

Actions

Login or Register to take actions

This Discussion

Posted February 15, 2012 at 10:31 AM
Stats:
Replies:12 Avg. Rating:1.33333
Views:1121 Votes:0
Shares:0
Tags: 2960, vs, 2970
+

Related Content