Configurar MOH CME 8.6

Perguntas não respondidas
jul 16th, 2012
User Badges:

Boa tarde.


Tou a ter algumas dificuldades em configurar o Music On Hold no CME. Bom o que eu já fiz está abaixo:


#show run | s moh

moh flash:/Mozart.au


Tinha tambem configurado o:


multicast moh 239.10.16.4 port 2000 mas como não funcionou acabei por retirar da configuração. Anyway, este multicast IP é atribuido de qualquer maneira ou tem a ver com a interface do CME que autentica os IP Phones?


Alguma configuração que falte?



Obrigado

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.4 (8 ratings)
Loading.
Leonardo Tadeu qua, 07/18/2012 - 04:53
User Badges:
  • Blue, 1500 points or more

Olá Mario,


Tente tirar a barra do mapeamento da localização do arquivo de MoH.


moh flash:Mozart.au


Internamente o MoH funciona, entre ramais ou apenas para chamadas para PSTN?


Este arquivo de MoH estã nos padrões aceitaveis pelo CME?


O formato pode ser .au or .wav .Tem que conter 8-bit  8-kHz de dados


Caso não funcione tente realizar a config abaixo:


multicast moh 239.10.16.4  port 16384 route


Att


Leonardo Santana

tekknova2008 sex, 07/20/2012 - 00:02
User Badges:

Leonardo,


O arquivo está sim nos padrões aceitaveis pelo CME.

O MOH não está funcionando nem para o PSTN nem internamente.


Uma coisa que queria entender é o seguinte: o ip multicast tem que existir configurado ou é algo que por defeito o CME se encarrega? Tou confuso em relação a isso.

Pode-me explicar a linha que vc postou ai:


multicast moh 239.10.16.4  port 16384 route


o 239.10.16.4 onde configuro?

depois do route vem o IP do gateway para os multicasts addresses correcto? E é opcional?


Abrc

tekknova2008 sex, 07/20/2012 - 02:12
User Badges:

O MOH funciona agora para o PSTN. Mas internamente entre os telefones não.


Alguma ideia?

Bruno rangel ter, 07/24/2012 - 11:05
User Badges:
  • Green, 3000 points or more
  • Participante em Destaque,

    Prêmio 'Escolha da Audiência' fevereiro 2015

  • Events Top Contributors,

    External, 2014

Mario

Conforme o Leonardo disse para o MOH funcionar "internamente", vc deve habilitar o Multicast para MOH.

Isso vc configura na seção:  telephony-service

Esse comando queo o Leonardo postou é justamente para habilitar o CME suportar Multicast,

O IP: 239.10.16.4 é justamente o ip de Multicast...

Port: 16384 (Porta que será usada/reservada para o multicast)

route (Vc mostra a direção que os pacotes MOH devem sair, normalmente sua interface apontada para sua VLAN de Voz ou onde está os phones, o default usa o ip source address configurado)


Na pratica fica mais ou menos assim:

MyCME> enable

MyCME# configure terminal

MyCME(config)# telephony-service

MyCME(config-telephony)# moh flash:Mozart.au

MyCME(config-telephony)# multicast moh 239.10.16.4 port 16384 route 10.10.29.17



Espero ter ajudado

Leonardo Tadeu ter, 07/24/2012 - 11:25
User Badges:
  • Blue, 1500 points or more

Em adição ao que Bruno explicou, verifique aonde não esta funcionando o MoH?

Entre ramais?

Para a PSTN?


Att


Leonardo Santana

tekknova2008 ter, 07/24/2012 - 23:27
User Badges:

Leonardo e Bruno,


O MOH não estava funcionando entre os ramais.


Para o PSTN estava tranquilo.


Parece que o que resolveu o problema foi um "no create cnf-files" e um "create cnf-files"  seguido de um reset aos phones


Se houver alteração do estado informo.


Grato pelo vosso tempo.


Abrc

Bruno rangel qua, 08/15/2012 - 07:59
User Badges:
  • Green, 3000 points or more
  • Participante em Destaque,

    Prêmio 'Escolha da Audiência' fevereiro 2015

  • Events Top Contributors,

    External, 2014

Olá Mario

Se possivel classifique as respostas que te ajudaram e escolha a resposta que vc achou mais correta para ajuda-lo a resolver seu problema.

Ações

This Discussion

Related Content