×

Mensagem de aviso

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Esconder IP da rede privada

Pergunta respondida
out 6th, 2015
User Badges:

Olá,

Estou configurando um servidor ownCloud na minha rede. Tenho um endereço IP fixo e alguns servidores na rede privada. No caso específico, o servidor ownCloud tem ip 10.10.10.15 e atente as solicitações na porta 21000. Para chegar até ele, configurei o seguinte no roteador:

ip nat inside source static tcp 10.10.10.15 21000 interface Dialer1 21000

Está funcionando, ou seja, posso acessar o servidor através da internet no endereço http://201.xx.xxx.xxx:21000, porém na barra do browser eu vejo o endereço privado, no caso 10.10.10.15, conforme figura abaixo:


Depois de algum tempo recebo a tela abaixo, com o endereço privado e uma mensagem de erro.


Clicando no botão <Voltar> do browser consigo acessar o servidor normalmente e posso fazer upload de arquivos e também baixa-los. Tela abaixo:


Já pesquisei nos forums de configuração do Cisco 1841, mas não achei nada similar a este problema. Qualquer ajuda será útil.

Grato,

 

Marcio

 

 

 

Correct Answer by Daniel Vieceli about 1 ano 10 meses atrás

Boa noite.

Nesse casso o que esta ocorrendo que sua apache esta fazendo esse redirecionamento pode ter algum http redirect algo assim, se você caiu na pagina de login do owncloud seu nat está correto.

da uma olhada nesse link fala disso:

 

https://github.com/owncloud/core/issues/17201

 

abraço

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (3 ratings)
Loading.
Correct Answer
Daniel Vieceli ter, 10/06/2015 - 15:21
User Badges:
  • Silver, 250 points or more

Boa noite.

Nesse casso o que esta ocorrendo que sua apache esta fazendo esse redirecionamento pode ter algum http redirect algo assim, se você caiu na pagina de login do owncloud seu nat está correto.

da uma olhada nesse link fala disso:

 

https://github.com/owncloud/core/issues/17201

 

abraço

Marcio Souza qua, 10/07/2015 - 05:14
User Badges:

Bom dia Daniel,

Olhei o post que você recomendou mas a solução não funcionou para mim. Vou continuar investigando nesta linha de que o problema possa ser no ownCloud e não na configuração do roteador.

Fiz uma pequena mudança no roteador para ver se resolvia, mas ficou no mesmo. Antes estava assim:

ip nat inside source static tcp 10.10.10.15 21000 interface Dialer1 21000

Depois de ler alguns papers da Cisco sobre PAT/NAT eu deixei assim:

ip nat inside source static tcp 10.10.10.15 21000 201.XX.XXX.XXX 21000 extendable

Não mudou nada, mas continuo conseguindo acessar como relatado no post inicial.

Grato,

Marcio

Marcio Souza qua, 10/07/2015 - 13:13
User Badges:

Pessoal,

 

Só para deixar registrado, a solução foi na configuração do ownCloud e não no roteador, conforme o Daniel Vieceli havia suspeitado.

 

Marcio

 

Ações

This Discussion