Melhores práticas para configuração de Port-Channel no Nexus 1000v

Document

Nov 28, 2011 10:36 AM
Nov 28th, 2011

O Nexus 1000v requer port-channels para os port-profiles que contenham mais de uma interface por host. Este documento descreve algumas melhores práticas para a configuração de port-channels no Nexus 1000v.

N1kv no UCS-B em "End-Host Mode"

O Cisco UCS utiliza dois caminhos entre o "blade server" e a rede upstream. Atualmente, os "Fabric Interconnencts" não suportam LACP/vPC na direção dos "blade servers". Isto significa que da perspectiva do N1kv um port-channel estático  deve ser utilizado. "Mac Pinning" é necessário, uma vez que o switch upstream não suporta "Multi-Chassis Etherchannel".

# Configuração do VSM

port-profile type ethernet system-uplink

  vmware port-group

  switchport mode trunk

  switchport trunk allowed vlan 100, 101, 102, 103, 200 - 300

  channel-group auto mode on mac-pinning

  no shutdown

  system vlan 100,101,102,103

  state enabled

# Configuração do Switch Upstream

-None required

N1kv no UCS-C ou Servidores de Rack (“Rack Mount servers”) conectados ao Nexus 5k/7k com vPC


Nesta topologia cada servidor de rack está fisicamente conectado a dois switches Nexus diferentes – um cabo para cada um. LACP é o modo preferencial pois permite uma melhor distribuição do tráfego e a adição/remoção de links de forma não ruptiva. Assume-se que o switch Nexus upstream já possui vPC peer-link configurado.


# Configuração do VSM

feature lacp

lacp offload

port-channel load-balance ethernet source-mac

  port-profile type ethernet system-uplink

  vmware port-group

  switchport mode trunk

  switchport trunk allowed vlan 100, 101, 102, 103, 200 - 300

  channel-group auto mode active

  no shutdown

  system vlan 100,101,102,103

  state enabled

# Configuração do Nexus 5k/7k #1 & #2

interface port-channel1000

  switchport mode trunk

  vpc 1000

  switchport trunk allowed vlan 100-103,200-300

  spanning-tree port type edge trunk

  spanning-tree bpduguard enable

  spanning-tree bpdufilter enable

  no lacp suspend-individual   <--- Nexus 7k only!

!

interface Ethernet1/11

  description ESX-Host1

  switchport mode trunk

  switchport trunk allowed vlan 100-103,200-300

  spanning-tree port type edge trunk

  spanning-tree bpduguard enable

  spanning-tree bpdufilter enable

  channel-group 1000 mode active

 
N1kv no UCS-C ou Servidor de Rack (“Rack Mount server”) conectado a um switch sem vPC

Nesta topologia cada servidor de rack está fisicamente conectado a dois switches diferentes, porém sem vPC disponível. A única configuração suportada é “mac-pinning”. Esta configuração é idêntica à utilizada no UCS-B. Um port-channel estático ("mode on") uma vez que o switch upstream não suporta “Multi-Chassis Etherchannel”.

# Configuração do VSM

port-profile type ethernet system-uplink

  vmware port-group

  switchport mode trunk

  switchport trunk allowed vlan 100, 101, 102, 103, 200 - 300

  channel-group auto mode on mac-pinning

  no shutdown

  system vlan 100,101,102,103

  state enabled


# Configuração do Switch Upstream

-None required

N1kv no UCS-C ou Servidor de Rack (“Rack Mount server”) conectado ao 6500 VSS ou “stacking switches”

Nesta topologia o switch upstream age como uma único chassis. Isto permite que o N1kv se conecte utilizando LACP.

# Configuração do VSM

feature lacp

lacp offload

port-profile type ethernet system-uplink

  vmware port-group

  switchport mode trunk

  switchport trunk allowed vlan 100, 101, 102, 103, 200 - 300

  channel-group auto mode active

  no shutdown

  system vlan 100,101,102,103

  state enabled

# Configuração do 6500 VSS

interface Port-channel1000

  switchport

  switchport trunk encapsulation dot1q

  switchport trunk allowed vlan 100-103,200-300

  switchport mode trunk

  spanning-tree portfast edge trunk

  spanning-tree bpduguard enable

  spanning-tree bpdufilter enable

!

interface GigabitEthernet1/1/1

  description ESX-Host1 adapter 1

  switchport

  switchport trunk encapsulation dot1q

  switchport trunk allowed vlan 100-103,200-300

  switchport mode trunk

  spanning-tree portfast edge trunk

  spanning-tree bpduguard enable

  spanning-tree bpdufilter enable

  channel-group 1000 mode active

!

interface GigabitEthernet2/1/1

  description ESX-Host1 adapter 2

  switchport

  switchport trunk encapsulation dot1q

  switchport trunk allowed vlan 100-103,200-300

  switchport mode trunk

  spanning-tree portfast edge trunk

  spanning-tree bpduguard enable

  spanning-tree bpdufilter enable

  channel-group 1000 mode active

N1kv no UCS-C ou Servidores de Rack (“Rack Mount servers”) conectados ao Nexus 5k / 7k com vPC.

Nesta topologia cada servidor de rack está fisicamente conectado a dois switches Nexus diferentes – um cabo para cada um. LACP é o modo preferencial pois permite uma melhor distribuição do tráfego e a adição/remoção de links de forma não ruptiva. Assume-se que o switch Nexus uptream já possui vPC peer-link configurado.

# VSM configuration

feature lacp

lacp offload

port-channel load-balance ethernet source-mac

port-profile type ethernet system-uplink

vmware port-group

switchport mode trunk

switchport trunk allowed vlan 100, 101, 102, 103, 200 - 300

channel-group auto mode active

no shutdown

system vlan 100,101,102,103

state enabled

# Nexus 5k/7k switches #1 & #2 configuration

interface port-channel1000

switchport mode trunk

vpc 1000

switchport trunk allowed vlan 100-103,200-300

spanning-tree port type edge trunk

spanning-tree bpduguard enable

spanning-tree bpdufilter enable

no lacp suspend-individual  <- Nexus 7k only!!!

!

interface Ethernet1/11

description ESX-Host1

switchport mode trunk

switchport trunk allowed vlan 100-103,200-300

spanning-tree port type edge trunk

spanning-tree bpduguard enable

spanning-tree bpdufilter enable

channel-group 1000 mode active

Average Rating: 5 (1 ratings)

Actions

Login or Register to take actions

This Document

Posted November 28, 2011 at 10:36 AM
Stats:
Comments:0 Avg. Rating:5
Views:708 Contributors:0
Shares:0

Related Content