Применение технологий 6PE and 6VPE

Блог

чт, 03/09/2017 - 02:16
Мар 9th, 2017
User Badges:

Ни для кого не будет секретом, что в настоящее время IPv6 является уже довольно широко распространенным протоколом. Но не всегда у оператора связи есть возможность реализации IPv6 на своей магистральной сети. Причины могут быть самые разные. Тем не менее, возникают ситуации, когда существующие, либо новые клиенты компании заказывают услугу получения доступа в сеть с помощью IPv6. Как же быть в данном случае, отказывать ли клиенту  в предоставлении услуги?  К счастью, прогресс не стоит на месте, уже довольно давно существуют и применяются на практике различные способы решения данной проблемы, например, передачи IPv6 трафика по сетям IPv4 с помощью туннелирования.

Практически каждый оператор реализует на своей магистральной сети коммутацию с помощью меток (MPLS), чаще всего посредством IGP+LDP.  MPLS позволяет организовать туннелирование IPv6 пакетов, через сеть IPv4. Осуществить  это позволяют две схожие технологии 6PE и 6VPE, реализацию которых на оборудовании Cisco мы рассмотрим в данном блоге.

Сначала немного теории.

6PE описан в RFC4798.

6VPE описан в RFC4659.

6PE

⦁ IPv6 префиксы клиента маршрутизируются в глобальной таблице маршрутизации
⦁ Обмен IPv6 префиксами/метками происходит между IPV4 соседями с помощью добавления дополнительной метки, используется address-family IPv4

6VPE

⦁ IPV6 префиксы клиенты маршрутизируются внутри VRF
⦁ Обмен IPv6 префиксами/метками происходит между IPV4 соседями с помощью добавления дополнительной метки, используется address-family vpnv6

Использование технологии 6PE, как и технология 6VPE  предоставляет провайдеру  ряд следующих преимуществ, при этом 6VPE расширяет данный ряд:

-  реализация предоставления IPV6 без изменения магистральной MPLS сети (6PE, 6VPE);

- нет потребности в реализации дополнительной сигнализации на сети (6PE, 6VPE);

- снижение операционных издержек (6PE, 6VPE);

- улучшенная безопасность путем изоляции клиентского трафика (6VPE);

- логическое разделение клиентского трафика (6VPE);

- возможность реализации Inter-AS и CsC(Carrier-supporting-Carrier) (6VPE).

 

 

 Кратко рассмотрим реализацию 6PE, на примере следующей сети. (см. Схема 1)


Схема 1

На магистральной сети настроен  IPv4, в качестве IGP используется IS-IS. Протокол маршрутизации между CE и PE в сети клиента 1 – OSPFv3, клиента 2 – BGP.

Для достижения большей масштабируемости в сети используется Route Reflector. Остальные особенности конфигурации отражены в схеме и названиях объектов.

Рассмотрим прохождение трафика между CE маршрутизаторами в сети клиента1, CE14 и CE11, а также конфигурацию маршрутизаторов.

CE11#tra

Protocol [ip]: ipv6

Target IPv6 address: 2001::14

Source address: 2001::11

 

  1 2001:DB8:1:1000::1 24 msec 4 msec 5 msec

  2 ::FFFF:10.1.2.2 [MPLS: Labels 23/32 Exp 0] 20 msec 19 msec 17 msec

  3 2001:DB8:1:1000::6 [MPLS: Label 32 Exp 0] 26 msec 8 msec 20 msec

  4 2001:DB8:1:1000::14 7 msec 10 msec 26 msec

 

От CE11 до CE14 трафик проходит.

В обратную сторону тоже.


CE14#ping 2001::11 so lo0

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 2001::11, timeout is 2 seconds:

Packet sent with a source address of 2001::14

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 9/12/19 ms

 

 

Посмотрим, что происходит на магистральном интерфейсе PE4 (R6),  во время прохождения ICMP с CE14 до CE11.

В дампе Wireshark видно следующее (см. Рис. 1)


Рис.1

Как видно, пакет содержит две MPLS метки, одна транспортная – 25, вторая, «туннельная», 24014.

Посмотрим, как это выглядит с точки зрения маршрутизатора

Сначала посмотрим, как выглядит маршрут до конечного хоста - 2001::11/128

 

R6#sh bgp ipv6 unicast 2001::11/128

BGP routing table entry for 2001::11/128, version 9

Paths: (1 available, best #1, table default)

  Not advertised to any peer

  Refresh Epoch 2

  Local

    ::FFFF:1.1.1.1 (metric 20) from 7.7.7.7 (7.7.7.7)

      Origin incomplete, metric 1, localpref 100, valid, internal, best

      Originator: 1.1.1.1, Cluster list: 7.7.7.7

      mpls labels in/out nolabel/24014

      rx pathid: 0, tx pathid: 0x0

 

В данном выводе видно метку для передачи IPV6 префикса  - 24014.

Трафик должен идти через роутер с адресом 1.1.1.1, посмотрим транспортную метку до 1.1.1.1.

Сейчас трафик до 1.1.1.1 идет через  10.2.6.2.

R6#sh mpls forwarding-table 1.1.1.1 detail

Local      Outgoing   Prefix           Bytes Label   Outgoing   Next Hop

Label      Label      or Tunnel Id     Switched      interface

28         25         1.1.1.1/32       0             Gi0/0.26   10.2.6.2

        MAC/Encaps=18/22, MRU=1500, Label Stack{25}

        5000001600005000001200008100001A8847 00019000

        No output feature configured

    Per-destination load-sharing, slots: 0

           24010      1.1.1.1/32       0             Gi0/0.56   10.5.6.5

        MAC/Encaps=18/22, MRU=1500, Label Stack{24010}

        500000010001500000120000810000388847 05DCA000

        No output feature configured

    Per-destination load-sharing, slots: 1

 

 

Также в памяти есть маршрут  до 1.1.1.1 через 10.5.6.5. Попробуем положить интерфейс Gi0/0.26, транспортная метка должна поменяться на 24010. ( См. рис.2)

Рис.2

Все верно.

 

Конфигурация выглядит так.

 

PE1

router ospfv3 1

 default-information originate always

 area 0

  interface Loopback0

   passive

  !

  interface GigabitEthernet0/0/0/1.111

  !

 

RP/0/0/CPU0:R1#sh run int GigabitEthernet0/0/0/1.111

Mon Mar  6 15:13:46.818 UTC

interface GigabitEthernet0/0/0/1.111

 ipv6 address 2001:db8:1:1000::1/64

 encapsulation dot1q 111

!

 

RP/0/0/CPU0:R1#sh run router bgp

Mon Mar  6 15:14:01.297 UTC

router bgp 150

 bgp log neighbor changes detail

 address-family ipv6 unicast

  redistribute ospfv3 1

  allocate-label all

# надо включить распространение меток протоколом BGP для назначения

# туннельных VPN меток

 !

 neighbor 7.7.7.7

  remote-as 150

  update-source Loopback0

  address-family ipv6 labeled-unicast

   next-hop-self

  !

 !

!

 

PE4

R6#sh run | sec router ospfv3

router ospfv3 1

 !

 address-family ipv6 unicast

  default-information originate always

 exit-address-family

 

R6#sh run | sec router bgp

router bgp 150

 bgp log-neighbor-changes

 no bgp default ipv4-unicast

 neighbor IBGP peer-group

 neighbor IBGP remote-as 150

 neighbor IBGP update-source Loopback0

 neighbor 7.7.7.7 peer-group IBGP

 !

 address-family ipv4

 exit-address-family

 !

 address-family ipv6

  redistribute connected

  redistribute ospf 1

  neighbor IBGP next-hop-self

  neighbor IBGP send-label

  neighbor 7.7.7.7 activate

 exit-address-family

R6#

 

 

Прежде чем продолжить, обратим внимание на конфигурацию RR, при создании конфигурации использовалась опция  Selective RIB download, рассмотренная мной, в одном из предыдущих постов.

( https://supportforums.cisco.com/ru/blog/13236101 )

Ранее мы разбирались, как работает эта технология в сети IPV4, сейчас мы посмотрим, как работает эта опция с AF отличной от IPV4.

  

RR

R7#sh run | sec router bgp

router bgp 150

 bgp log-neighbor-changes

 no bgp default ipv4-unicast

 neighbor IBGP peer-group

 neighbor IBGP remote-as 150

 neighbor IBGP update-source Loopback0

 neighbor 1.1.1.1 peer-group IBGP

 neighbor 3.3.3.3 peer-group IBGP

 neighbor 4.4.4.4 peer-group IBGP

 neighbor 6.6.6.6 peer-group IBGP

 !

 address-family ipv4

 exit-address-family

 !

 address-family ipv6

  table-map NO_CLIENTS_ROUTES filter

  neighbor IBGP route-reflector-client

  neighbor IBGP send-label

  neighbor 1.1.1.1 activate

  neighbor 3.3.3.3 activate

  neighbor 4.4.4.4 activate

  neighbor 6.6.6.6 activate

 exit-address-family

 

route-map NO_CLIENTS_ROUTES deny 10

 

В RIB ipv6 и FIB ipv6 информация отсутствует, но между конечными узлами трафик ходит.

R7#sh ipv6 ro bgp

IPv6 Routing Table - default - 1 entries

Codes: C - Connected, L - Local, S - Static, U - Per-user Static route

       B - BGP, R - RIP, H - NHRP, I1 - ISIS L1

       I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary, D - EIGRP

       EX - EIGRP external, ND - ND Default, NDp - ND Prefix, DCE - Destination

       NDr - Redirect, RL - RPL, O - OSPF Intra, OI - OSPF Inter

       OE1 - OSPF ext 1, OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1

       ON2 - OSPF NSSA ext 2, la - LISP alt, lr - LISP site-registrations

       ld - LISP dyn-eid, a - Application

R7#sh ipv6 cef

::/0

  no route

::/127

  discard

FE80::/10

  receive for Null0

FF00::/8

  multicast

FF02::/16

  Receive

 

Уберем table-map и сравним.

R7#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

R7(config)#router bgp 150

R7(config-router)# address-family ipv6

R7(config-router-af)#no   table-map NO_CLIENTS_ROUTES filter

 

R7(config-router-af)#do clear ip bgp ipv6 unicast table-map

Обратите внимание, сейчас мы очищаем информацию об IPv6.

 

R7(config-router-af)#do sh ipv6 ro bgp | b B

       B - BGP, R - RIP, H - NHRP, I1 - ISIS L1

       I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary, D - EIGRP

       EX - EIGRP external, ND - ND Default, NDp - ND Prefix, DCE - Destination

       NDr - Redirect, RL - RPL, O - OSPF Intra, OI - OSPF Inter

       OE1 - OSPF ext 1, OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1

       ON2 - OSPF NSSA ext 2, la - LISP alt, lr - LISP site-registrations

       ld - LISP dyn-eid, a - Application

B   2001::1/128 [200/0]

     via 1.1.1.1%default, indirectly connected

B   2001::6/128 [200/0]

     via 6.6.6.6%default, indirectly connected

B   2001::11/128 [200/1]

     via 1.1.1.1%default, indirectly connected

B   2001::14/128 [200/1]

     via 6.6.6.6%default, indirectly connected

B   2001:DB8:1:1000::/64 [200/0]

     via 1.1.1.1%default, indirectly connected

 

R7(config-router-af)#do sh ipv6 cef

::/0

  no route

::/127

  discard

2001::1/128

  nexthop 10.2.7.2 GigabitEthernet1.27 label 25() 24015()

  nexthop 10.5.7.5 GigabitEthernet1.57 label 24010() 24015()

2001::6/128

  nexthop 10.2.7.2 GigabitEthernet1.27 label 23() 30()

  nexthop 10.5.7.5 GigabitEthernet1.57 label 24008() 30()

2001::11/128

  nexthop 10.2.7.2 GigabitEthernet1.27 label 25() 24014()

  nexthop 10.5.7.5 GigabitEthernet1.57 label 24010() 24014()

2001::14/128

  nexthop 10.2.7.2 GigabitEthernet1.27 label 23() 32()

  nexthop 10.5.7.5 GigabitEthernet1.57 label 24008() 32()

2001:DB8:1:1000::/64

  nexthop 10.2.7.2 GigabitEthernet1.27 label 25() 24015()

  nexthop 10.5.7.5 GigabitEthernet1.57 label 24010() 24015()

FE80::/10

  receive for Null0

FF00::/8

  multicast

FF02::/16

  Receive

 

 

 

Эффект очевиден.

 

На этом закончим рассмотрение 6PE  и перейдем к изучению 6VPE.

Рассмотрим на примере уже знакомой нам сети с небольшими изменениями. (см. Схема 2.)

Схема 2.

 

Рассмотрим пример обмена трафиком между сетями Клиента1. Между маршрутизаторами CE14 и CE11 связность есть.

CE14#ping 2001::11 so lo0

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 2001::11, timeout is 2 seconds:

Packet sent with a source address of 2001::14

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 24/26/32 ms

 

Посмотрим, что происходит на PE4.

В отличие от реализации 6PE, в глобальной таблице маршрутизации информации  о  маршруте  до префикса 2001::11/128 нет.

 

R4(config-router-af)#do sh bgp ipv6 unicast 2001::11/128

% Network not in table

 

Все верно, мы «переместили» клиентские префиксы в VRF.

 

 

R6(config-router-af)#do sh bgp vpnv6 unicast vrf CUST1 2001::11/128

BGP routing table entry for [1:1]2001::11/128, version 60

Paths: (1 available, best #1, table CUST1)

  Not advertised to any peer

  Refresh Epoch 1

  Local

    ::FFFF:1.1.1.1 (metric 20) (via default) from 7.7.7.7 (7.7.7.7)

      Origin IGP, metric 1, localpref 100, valid, internal, best

      Extended Community: RT:1:1

      Originator: 1.1.1.1, Cluster list: 7.7.7.7

      mpls labels in/out nolabel/24017

      rx pathid: 0, tx pathid: 0x0

 

И на PE1, соответственно есть маршрут до CE14.

 

RP/0/0/CPU0:R1(config)#do sh bgp vpnv6 unicast vrf CUST1 2001::14/128

Tue Mar  7 07:58:43.138 UTC

BGP routing table entry for 2001::14/128, Route Distinguisher: 1:1

Versions:

  Process           bRIB/RIB  SendTblVer

  Speaker                 40          40

Last Modified: Mar  6 22:00:12.668 for 09:58:30

Paths: (1 available, best #1)

  Not advertised to any peer

  Path #1: Received by speaker 0

  Not advertised to any peer

  Local

    6.6.6.6 (metric 30) from 7.7.7.7 (6.6.6.6)

      Received Label 33

      Origin IGP, metric 1, localpref 100, valid, internal, best, group-best, import-candidate, imported

      Received Path ID 0, Local Path ID 1, version 40

      Extended community: OSPF router-id:6.6.6.6 OSPF route-type:0:2:0x0 RT:1:1

      Originator: 6.6.6.6, Cluster list: 7.7.7.7

      Source AFI: VPNv6 Unicast, Source VRF: CUST1, Source Route Distinguisher: 1:1

 

Судя по выводу, VPN метка равна 33, посмотрим, какая будет транспортная.

Префиксу 6.6.6.6/32 назначено 2 метки, но судя по количеству переданных байтов, сейчас используется метка 23.

 

 

RP/0/0/CPU0:R1#sh mpls forwarding prefix 6.6.6.6/32

Tue Mar  7 08:05:29.240 UTC

Local  Outgoing    Prefix             Outgoing     Next Hop        Bytes

Label  Label       or ID              Interface                    Switched

------ ----------- ------------------ ------------ --------------- ------------

24011  23          6.6.6.6/32         Gi0/0/0/0.12 10.1.2.2        113152

       24008       6.6.6.6/32         Gi0/0/0/0.15 10.1.5.5        0

 

 

 

Посмотрим, что видно в дампе Wireshark на магистральном интерфейсе PE1. (см. рис.3)

 

Рис. 3

 

Top label (транспортная) равна 23, bottom label (туннельная VPN метка) равна 33.

Приведу конфигурацию PE, CE и RR, с комментариями.

PE1

vrf CUST1

address-family ipv6 unicast

#  так как IPV4 не используется, настраиваем только IPV6 AF

  import route-target

   1:1

  !

  export route-target

   1:1

  !

 !

interface GigabitEthernet0/0/0/1.111

 vrf CUST1

 ipv6 address 2001:db8:1:1000::1/64

 encapsulation dot1q 111

!

router ospfv3 1

 router-id 1.1.1.1

 vrf CUST1

  default-information originate always

# Отдаем маршрут по умолчанию на CE

  area 0

   interface GigabitEthernet0/0/0/1.111

   !

router bgp 150

 bgp log neighbor changes detail

 address-family vpnv6 unicast

 !

 neighbor 7.7.7.7

  remote-as 150

  update-source Loopback0

  address-family vpnv6 unicast

# При конфигурации 6VPE используем AF vpvn6

  !

 !

 vrf CUST1

  rd 1:1

  address-family ipv6 unicast

   redistribute ospfv3 1

# Анонсируем маршруты с CE11

  !

 !

!

 

PE4

vrf definition CUST1

 rd 1:1

 !

 address-family ipv6

  route-target export 1:1

  route-target import 1:1

 exit-address-family

!

ipv6 unicast-routing

ipv6 cef

!

interface GigabitEthernet0/1.614

 encapsulation dot1Q 614

 vrf forwarding CUST1

 ipv6 address 2001:DB8:1:1000::6/64

 ospfv3 1 ipv6 area 0

!

router ospfv3 1

 router-id 6.6.6.6

 !

 address-family ipv6 unicast

 exit-address-family

 !

 address-family ipv6 unicast vrf CUST1

  default-information originate always

 exit-address-family

!

router bgp 150

 bgp log-neighbor-changes

 no bgp default ipv4-unicast

 neighbor IBGP peer-group

 neighbor IBGP remote-as 150

 neighbor IBGP update-source Loopback0

 neighbor 7.7.7.7 peer-group IBGP

 !

 address-family ipv4

 exit-address-family

 !

 address-family vpnv6

  neighbor IBGP send-community extended

  neighbor 7.7.7.7 activate

 exit-address-family

 !

 address-family rtfilter unicast

# настраиваем RTC для фильтрации «ненужных» префиксов

  neighbor IBGP send-community extended

  neighbor 7.7.7.7 activate

 exit-address-family

 !

 address-family ipv6 vrf CUST1

  redistribute ospf 1

 exit-address-family

!

 

RR

router bgp 150

 bgp log-neighbor-changes

 no bgp default ipv4-unicast

 neighbor IBGP peer-group

 neighbor IBGP remote-as 150

 neighbor IBGP update-source Loopback0

 neighbor 1.1.1.1 peer-group IBGP

 neighbor 3.3.3.3 peer-group IBGP

 neighbor 4.4.4.4 peer-group IBGP

 neighbor 6.6.6.6 peer-group IBGP

 !

 address-family ipv4

 exit-address-family

 !

 address-family vpnv6

  neighbor IBGP send-community extended

  neighbor IBGP route-reflector-client

  neighbor 1.1.1.1 activate

  neighbor 3.3.3.3 activate

  neighbor 4.4.4.4 activate

  neighbor 6.6.6.6 activate

 exit-address-family

 !

 address-family rtfilter unicast

  neighbor IBGP send-community extended

  neighbor IBGP route-reflector-client

  neighbor 3.3.3.3 activate

  neighbor 3.3.3.3 default-originate

  neighbor 4.4.4.4 activate

  neighbor 4.4.4.4 default-originate

  neighbor 6.6.6.6 activate

  neighbor 6.6.6.6 default-originate

 exit-address-family

 

 

CE11

ipv6 unicast-routing

ipv6 cef

interface Loopback0

 no ip address

 ipv6 address 2001::11/128

 ospfv3 1 ipv6 area 0

!

interface GigabitEthernet0/0.111

 encapsulation dot1Q 111

 ipv6 address 2001:DB8:1:1000::11/64

 ospfv3 1 ipv6 area 0

!

router ospfv3 1

 router-id 11.11.11.11

 !

 address-family ipv6 unicast

 exit-address-family

!

 

CE14

ipv6 unicast-routing

ipv6 cef

 

interface Loopback0

 no ip address

 ipv6 address 2001::14/128

 ospfv3 1 ipv6 area 0

!

interface GigabitEthernet0/1.614

 encapsulation dot1Q 614

 ipv6 address 2001:DB8:1:1000::14/64

 ospfv3 1 ipv6 area 0

!

router ospfv3 1

 router-id 14.14.14.14

 !

 address-family ipv6 unicast

 exit-address-family

!

 

 

Далее мы рассмотрим настройку Inter-AS 6VPE. Наш Клиент1 рос, рос и вырос, и открыл зарубежное представительство, и подключился к зарубежному оператору,  где у нашего оператора связи точки присутствия нет. Но у зарубежного оператора есть точка присутствия в нашей стране, и мы организуем присоединение к этому оператору по IPV6, для того чтобы объединить филиалы нашего клиента. Для организации присоединения будем использовать Inter-AS VPN Option A (back-to-back VRF), так как использование этой опции в данном случае представляется наиболее оптимальным с точки зрения обеспечения безопасности.

 

Сеть  выглядит следующим образом. (см. Схема 3)

Схема 3.

Разберем конфигурацию ASBR маршрутизаторов.

 

PE2 (R3)

 

vrf definition CUST1

 rd 1:1

 !

 address-family ipv6

  route-target export 1:1

  route-target import 1:1

 exit-address-family

!

!

interface GigabitEthernet1.355

 encapsulation dot1Q 355

 vrf forwarding CUST1

 ipv6 address 2001:10:3:55::3/64

!

R3#sh run | sec router bgp

router bgp 150

 bgp router-id 3.3.3.3

 bgp log-neighbor-changes

 no bgp default ipv4-unicast

 neighbor IBGP peer-group

 neighbor IBGP remote-as 150

 neighbor IBGP update-source Loopback0

 neighbor 7.7.7.7 peer-group IBGP

 neighbor 2001:10:3:55::55 remote-as 250

 !

 address-family ipv4

 exit-address-family

 !

 address-family ipv6

  neighbor IBGP send-label

  neighbor 7.7.7.7 activate

  neighbor 2001:10:3:55::55 activate

 exit-address-family

 !

 address-family vpnv6

  neighbor IBGP send-community extended

  neighbor 7.7.7.7 activate

 exit-address-family

 !

 address-family rtfilter unicast

  neighbor IBGP send-community extended

  neighbor 7.7.7.7 activate

 exit-address-family

 !

 address-family ipv6 vrf CUST1

  neighbor 2001:10:3:55::55 remote-as 250

  neighbor 2001:10:3:55::55 activate

 exit-address-family

# Настройка соседа для обмена IPV6 маршрутами

 

 

 

Просмотр состояния соседа

R3(config-router)#do sh bgp vrf CUST1 vpnv6 unicas sum | b Nei

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd

2001:10:3:55::55

                4          250      29      40       17    0    0 00:24:15        2

 

 

Несмотря на то, что мы создаем соседа в AF ipv6 vrf CUST1, просмотр осуществляется в vpnv6.

 

Маршруты до CE роутеров находятся в VRF CUST1

R3(config-router)#do sh bgp vrf CUST1 vpnv6 unicast

     Network          Next Hop            Metric LocPrf Weight Path

Route Distinguisher: 1:1 (default for vrf CUST1)

 *>i 2001::11/128     ::FFFF:1.1.1.1           1    100      0 ?

 *>i 2001::14/128     ::FFFF:6.6.6.6           1    100      0 ?

 *>  2001::15/128     2001:10:3:55::55

                                                1             0 250 ?

 *>i 2001:DB8:1:1000::/64

                       ::FFFF:1.1.1.1           0    100      0 ?

 *                    2001:10:3:55::55

                                                0             0 250 ?

 

 

Сейчас посмотрим, что происходит в AS250.

Маршруты до CE в наличии есть.


 

RP/0/0/CPU0:R55(config-bgp-af)#do sh bgp vpnv6 unicast vrf CUST1 | b Net

Tue Mar  7 11:39:06.601 UTC

   Network            Next Hop            Metric LocPrf Weight Path

Route Distinguisher: 1:1 (default for vrf CUST1)

*> 2001::11/128       2001:10:3:55::3                        0 150 ?

*> 2001::14/128       2001:10:3:55::3                        0 150 ?

*> 2001::15/128       fe80::5200:ff:fe07:0

                                               1         32768 ?

*> 2001:db8:1:1000::/64

                      ::                       0         32768 ?

*                     2001:10:3:55::3                        0 150 ?

 

Processed 4 prefixes, 5 paths

 

 

 

RP/0/0/CPU0:R55(config-bgp-af)#do sh bgp vpnv6 unicast vrf CUST1 2001::14/128

Tue Mar  7 11:41:25.521 UTC

BGP routing table entry for 2001::14/128, Route Distinguisher: 1:1

Versions:

  Process           bRIB/RIB  SendTblVer

  Speaker                 20          20

    Local Label: 24003

Last Modified: Mar  7 11:24:06.578 for 00:17:19

Paths: (1 available, best #1)

  Not advertised to any peer

  Path #1: Received by speaker 0

  Not advertised to any peer

  150

    2001:10:3:55::3 from 2001:10:3:55::3 (3.3.3.3)

      Origin incomplete, localpref 100, valid, external, best, group-best, import-candidate

      Received Path ID 0, Local Path ID 1, version 20

      Extended community: RT:1:1

 

Конфигурация маршрутизатора.

PE5 (R55)

vrf CUST1

 address-family ipv6 unicast

  import route-target

   1:1

  !

  export route-target

   1:1

  !

 !

!

interface GigabitEthernet0/0/0/0.355

 vrf CUST1

 ipv6 address 2001:10:3:55::55/64

 encapsulation dot1q 355

!

interface GigabitEthernet0/0/0/0.1555

 vrf CUST1

 ipv6 address 2001:db8:1:1000::55/64

 encapsulation dot1q 1555

!

router ospfv3 1

 router-id 55.55.55.55

 vrf CUST1

  default-information originate always

  area 0

   interface GigabitEthernet0/0/0/0.1555

   !

  !

 !

!

router bgp 250

 bgp unsafe-ebgp-policy

 address-family ipv6 unicast

 !

 address-family vpnv6 unicast

 !

 vrf CUST1

  rd 1:1

  bgp unsafe-ebgp-policy

  address-family ipv6 unicast

   redistribute ospfv3 1

  !

  neighbor 2001:10:3:55::3

   remote-as 150

   address-family ipv6 unicast

   !

  !

 !

!

Обратите внимание, трафик между автономными системами в данной конфигурации передается уже без меток, посмотрим дамп Wireshark  ICMP трафика на интерфейсе PE5, который смотрит в AS150. (см. Рис. 4)


Рис.4

 

Ну и чтобы окончательно удостовериться, что все работает, проверим связность между конечными хостами.

CE15#ping 2001::14 so lo0

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 2001::14, timeout is 2 seconds:

Packet sent with a source address of 2001::15

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 11/20/33 ms

 

CE15#ping 2001::11 so lo0

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 2001::11, timeout is 2 seconds:

Packet sent with a source address of 2001::15

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 32/41/50 ms

CE15#

 

 

CE14#ping 2001::15 so lo0

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 2001::15, timeout is 2 seconds:

Packet sent with a source address of 2001::14

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 11/23/41 ms

CE14#

 

 

CE11#ping 2001::15 so lo0

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 2001::15, timeout is 2 seconds:

Packet sent with a source address of 2001::11

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 27/43/58 ms

CE11#

 

Все работает.

 

 

Подведем итог – с помощью применения технологий 6PE и 6VPE оператор связи получает возможность предоставления  своим клиентам присоединения по протоколу IPV6  без реализации IPV6 на магистральной сети. Для пропуска IPV6, трафик туннелируется в сети MPLS, на магистральной сети настраивается только IPV4+LDP.

 

 

 




Loading.

Действия

Информация о блоге