Настройка внутренних коммутаторов EHWIC 4ESG

Неотвеченый вопрос
янв 16th, 2014
User Badges:

Доброе время суток!


Есть: CISCO 2901/K9 с интерфейсами Gi0/0 – 0/1, и два установленных модуля расширения EHWIC 4ESG с интерфейсами Gi0/0/0 – 0/0/3, Gi0/1/0 – 0/1/3. Провайдер выделил 5 белых IP адресов, для каждого из которых свой шлюз, но проводок от провайдера идёт один.

Задача: настроить аппарат таким образом, чтобы проводок от провайдера подключался в один из интерфейсов (допустим Gi0/0), и через NAT (PAT) + DHCP на другой интерфейс (допустим Gi0/1) раздавался интернет. При этом надо чтобы оборудование, подключенное к интерфейсам Gi0/0/0 – 0/0/3 думало, что проводок провайдера вставлен непосредственно в него, а на остальных интерфейсах Gi0/1/0 – 0/1/3 раздавались адреса через DHCP и был доступ в интернет через NAT (PAT).

Первая часть задачи решена. PAT + DHCP настроен. Через интерфейс Gi0/1 интернет раздаётся. Что делать со второй частью задачи? По идее с использованием двух внешних коммутаторов задача решается влёт, но хотелось бы использовать уже имеющееся оборудование.

I have this problem too.
0 голоса
Loading.
Vitaliy Zinatov чт, 01/16/2014 - 21:09
User Badges:
  • Gold, 750 points or more
  • Почетные Знаки Сообщества,

    Лучшая публикация, Декабрь 2013

Добрый день Юрий могли бы вы пояснить:


"Провайдер выделил 5 белых IP адресов, для каждого из которых свой шлюз "  имеется ввиду выделено 5 сетей с маской /30 или 255.255.255.252? 

5 сетей выделено в виде 5-ти виланов или посредством 1-го L3 линка?


А так в общем решить вашу задачу можно посредством SVI интерфейсов. Но при этом 1 порт мы потеряем на плате EHWIC 4ESG, т.к. он будет смотреть в сторону провайдера.


Детальный ответ уже дам после вашего ответа. Т.к. нужно знать до провайдера идет 802.1q у вас или просто Access. В обоих случаях ваша задача решаема.





-----------------------------------------------------------
Прошу вас оценивать и отмечать полезные для вас сообщения.
Please rate helpful answers.

YuriiPecherkin чт, 01/16/2014 - 21:25
User Badges:

Добрый день Виталий.


Провайдер выделил 5 сетей с маской 255,255,255,252 по средством 1-го L3 линка.

Vitaliy Zinatov чт, 01/16/2014 - 21:47
User Badges:
  • Gold, 750 points or more
  • Почетные Знаки Сообщества,

    Лучшая публикация, Декабрь 2013

Ну тогда приступим.


Создадим 2 Vlan-a (нумерацию сами уже выберете):

#vlan database

% Warning: It is recommended to configure VLAN from config mode,

  as VLAN database mode is being deprecated. Please consult user

  documentation for configuring VTP/VLAN in config mode.

(vlan)#vlan 10 name ISP

(vlan)#vlan 20 name LAN

(vlan)#apply

(vlan)#exit


Далее убираем конфигурацию с вашего  Gi0/0


Создаем SVI который будет смотреть в сторону провайдера и прописываем туда всю конфигурацию удаленную с Gi0/0

(config)#interface vlan 10


Далее убираем конфигурацию с вашего  Gi0/1


Создаем SVI который будет смотреть в сторону LAN и прописываем туда всю конфигурацию удаленную с Gi0/1

(config)#interface vlan 20


Далее  вставляем провайдер в порт Gi0/0/0


Далее вставляем LAN в порт Gi0/1/0


Далее назначаем виланы на порты


ISP вилан портам Gi0/0/0-3

(config)#interface range Gi0/0/0 - 3

(config-if-range)# switchport mode access

(config-if-range)# switchport access vlan 10


LAN вилан портам Gi0/1/0-3

(config)#interface range Gi0/1/0 - 3

(config-if-range)# switchport mode access

(config-if-range)# switchport access vlan 20


В общем примерно так будет выглядеть решение вашей задачи


-----------------------------------------------------------
Прошу вас оценивать и отмечать полезные для вас сообщения.
Please rate helpful answers.

Действия

Информация о дискуссии

Related Content