×

Предупреждение

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

CUCM 8.6 + Cisco IOS conference bridge для ВКС

Answered Question
сен 8th, 2014
User Badges:

Есть CUCM 8.6, есть cisco 2911 c 64 PVDM3 и есть телефоны CIP8945. Согласно мануалов сервером для ВКС сам CUCM не может выступать, требуется отдельный MCU. Таким MCU может выступать роутер с PVDM3 модулем. 

согласно мануала CallManager and IOS Gateway DSP Farm Configuration Example  пытаюсь настроить сам роутер. Но при настройке dspfarm profile 1 conference -> maximum sessions дает выбрать только 0, соответственно нет возможности активировать dspfarm профиль. В чем может быть проблема, не подскажите ? 

 

config cisco (синим помечены секции , касающиеся настройки bribge )

service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname R_2911
!
boot-start-marker
boot system flash:c2900-universalk9-mz.SPA.154-1.T.bin
boot-end-marker
!
aqm-register-fnf
!
card type e1 0 3
logging buffered 10000
enable secret 5 xxxxxxxx.
!
aaa new-model
!
!
aaa authentication login default local enable
aaa authorization exec default local if-authenticated
!
!
!
!
!
aaa session-id common
clock timezone MSK 4 0
network-clock-participate wic 3
network-clock-select 1 E1 0/3/1
!
!
!
!
!
!
!
ip domain name xxxxxxx
ip host cucm1 10.168.0.2
ip host cucm2 10.168.0.3
ip cef
no ipv6 cef
multilink bundle-name authenticated
!
vpdn enable
!
vpdn-group PPTP
 ! Default PPTP VPDN group
 description PPTP_VPN_for_remote_access
 accept-dialin
  protocol pptp
  virtual-template 1
!
!
!
!
isdn switch-type primary-4ess
!
!
crypto pki trustpoint TP-self-signed-3035757267
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-3035757267
 revocation-check none
 rsakeypair TP-self-signed-3035757267
!
!
crypto pki certificate chain TP-self-signed-3035757267
 certificate self-signed 01
  xxxxxx
        quit
voice-card 0
 dspfarm
 dsp services dspfarm

 no local-bypass
!
!
voice rtp send-recv
!
voice service voip
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 supplementary-service h450.12
 no supplementary-service sip moved-temporarily
 no supplementary-service sip refer
 redirect ip2ip
 fax protocol pass-through g711alaw
 h323
 modem relay nse codec g711ulaw gw-controlled
 sip
  registrar server expires max 3600 min 120
!
!
!
!
voice translation-rule 1
 rule 1 /^853$/ /2106488/
!
voice translation-rule 2
 rule 1 /^9/ //
 rule 2 /^98/ /8/
 rule 3 /^9810/ /810/
!
voice translation-rule 3
 rule 1 // /98/
!
voice translation-rule 5
 rule 1 /^2106488$/ /853/
!
!
voice translation-profile Incoming9
 translate calling 3
!
voice translation-profile PSTN_Outgoing
 translate calling 1
 translate called 2
!
voice translation-profile PSTN_Outgoing_avaya
 translate calling 5
 translate called 2
!
voice translation-profile TO_AVAYA
 translate called 104
!
!
!
license udi pid CISCO2911/K9 sn XXXXXXXX
hw-module pvdm 0/0
!
!
!
username XXXX
!
redundancy
!
!
controller E1 0/3/0
 framing NO-CRC4
 clock source internal
 pri-group timeslots 1-31 service mgcp
 description ---TO_AVAYA---
!
controller E1 0/3/1
 framing NO-CRC4
 pri-group timeslots 1-31 service mgcp
 description ---PRI---
!
ip ssh version 2
ip scp server enable
!
!
!
!
interface Loopback0
 no ip address
!
interface Tunnel100
 description MULTI-POINT GRE TUNNEL for OZAGS
 ip address 172.16.3.1 255.255.255.0
 no ip redirects
 ip mtu 1400
 ip nhrp authentication dmvpn
 ip nhrp map multicast dynamic
 ip nhrp network-id 99
 ip nhrp holdtime 300
 ip ospf network broadcast
 ip ospf priority 10
 delay 1000
 tunnel source GigabitEthernet0/0.1
 tunnel mode gre multipoint
 tunnel key XXXXXX
!
interface Embedded-Service-Engine0/0
 no ip address
 shutdown
!
interface GigabitEthernet0/0
 description LINK_TO_ASA5510
 no ip address
 duplex auto
 speed auto
!
interface GigabitEthernet0/0.1
 description ---TO SW_ ASA---
 encapsulation dot1Q 3
 ip address 172.16.1.2 255.255.255.0
!
interface GigabitEthernet0/0.2
 description ---TO SW_ LAN---
 encapsulation dot1Q 4
 ip address 192.168.1.254 255.255.254.0
!
interface GigabitEthernet0/0.3
 description ---TO  BRANCH---
 encapsulation dot1Q 101
 ip address 192.168.63.1 255.255.255.0
!
interface GigabitEthernet0/0.4
 description ---TO CUCM---
 encapsulation dot1Q 2
 ip address 10.168.0.1 255.255.255.0
!
interface GigabitEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface GigabitEthernet0/2
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface GigabitEthernet0/0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface ATM0/1/0
 no ip address
 shutdown
 no atm ilmi-keepalive
!
interface Serial0/3/0:15
 no ip address
 encapsulation hdlc
 isdn switch-type primary-net5
 isdn overlap-receiving T302 2000
 isdn protocol-emulate network
 isdn incoming-voice voice
 isdn bind-l3 ccm-manager
 isdn send-alerting
 isdn sending-complete
 no cdp enable
!
interface Serial0/3/1:15
 no ip address
 encapsulation hdlc
 isdn switch-type primary-net5
 isdn incoming-voice voice
 isdn bind-l3 ccm-manager
 isdn send-alerting
 isdn bchan-number-order ascending
 isdn sending-complete
 no cdp enable
!
interface Virtual-Template1
 ip unnumbered GigabitEthernet0/0.1
 autodetect encapsulation ppp
 peer ip address forced
 peer default ip address pool vpnpool
 ppp authentication ms-chap-v2 ms-chap eap
!
router ospf 1
 redistribute connected subnets
 redistribute static subnets route-map redistr-static
 network 10.168.0.0 0.0.0.255 area 0
 network 172.16.1.0 0.0.0.7 area 0
 network 172.16.3.0 0.0.0.255 area 0
!
ip local pool vpnpool 192.168.1.253
ip forward-protocol nd
!
no ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip route 0.0.0.0 0.0.0.0 172.16.1.1
ip route 11.0.0.0 255.0.0.0 172.16.1.3
ip route 192.168.11.0 255.255.255.0 172.16.1.3
ip route 192.168.13.0 255.255.255.0 172.16.1.3
ip route 192.168.25.0 255.255.255.0 172.16.1.3
ip route 192.168.64.0 255.255.255.0 192.168.63.252
ip route 192.168.115.12 255.255.255.255 172.16.1.3
ip route 192.168.200.0 255.255.255.0 172.16.1.1
ip route 192.168.254.1 255.255.255.255 172.16.1.1
!
ip access-list extended test
 permit ip any host 192.168.1.250 log
 permit ip any any
!
logging dmvpn rate-limit 20
logging trap debugging
logging facility local5
logging host 192.168.1.95
logging host 192.168.200.34
!
route-map redistr-static permit 200
 match ip address 20
!
!
access-list 20 permit 192.168.200.0 0.0.0.255
!
!
!
control-plane
!
!
voice-port 0/3/0:15
 cptone RU
 bearer-cap Speech
!
voice-port 0/3/1:15
 echo-cancel coverage 64
 cptone RU
 bearer-cap Speech
 !
 !
 !
 !
!
mgcp
mgcp call-agent zagscucm1 2427 service-type mgcp version 0.1
mgcp rtp unreachable timeout 1000 action notify
mgcp modem passthrough voip mode nse
mgcp package-capability rtp-package
mgcp package-capability sst-package
mgcp package-capability pre-package
no mgcp package-capability res-package
no mgcp timer receive-rtcp
mgcp sdp simple
mgcp fax t38 inhibit
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
sccp local GigabitEthernet0/0.4
sccp ccm 10.168.0.2 identifier 1 version 7.0
sccp ip precedence 1
sccp

!
ccm-manager music-on-hold
!
ccm-manager mgcp
no ccm-manager fax protocol cisco
ccm-manager config server 10.168.0.2
ccm-manager config
!
dspfarm profile 888 conference
 description FOR_VKS
 codec g711ulaw
 codec g711alaw
 codec g729ar8
 codec g729abr8
 codec g729r8
 codec g729br8
 maximum conference-participants 16
 shutdown
!
dspfarm profile 1 conference
 description FOR_VKS
 codec g711ulaw
 codec g711alaw
 codec g729ar8
 codec g729abr8
 codec g729r8
 codec g729br8
 associate application SCCP
 shutdown

!
dial-peer cor custom
 name GOROD
 name MEZHGOROD
 name INTERNATIONAL
 name LOCAL
 name SOSEDI
 name PG
!
!
dial-peer cor list CALL-GOROD
 member GOROD
!
dial-peer cor list CALL-MEZHGOROD
 member MEZHGOROD
!
dial-peer cor list CALL-INTERNATIONAL
 member INTERNATIONAL
!
dial-peer cor list G-MG-I
 member GOROD
 member MEZHGOROD
 member INTERNATIONAL
 member LOCAL
 member PG
!
dial-peer cor list G-MG
 member GOROD
 member MEZHGOROD
 member LOCAL
 member SOSEDI
 member PG
!
dial-peer cor list G
 member GOROD
 member LOCAL
 member SOSEDI
 member PG
!
dial-peer cor list CALL-LOCAL
 member LOCAL
!
!
dial-peer voice 861 pots
 description ### to GOROD ###
 translation-profile outgoing PSTN_Outgoing_avaya
 destination-pattern ^9[2-9]......$
 no digit-strip
 direct-inward-dial
 port 0/3/1:15
 forward-digits 7
!
dial-peer voice 98 pots
 corlist outgoing CALL-MEZHGOROD
 description ### to MEZHGOROD ###
 translation-profile outgoing PSTN_Outgoing
 destination-pattern ^98[2-9].........$
 no digit-strip
 direct-inward-dial
 port 0/3/1:15
 forward-digits 11
!
dial-peer voice 100 pots
 corlist outgoing CALL-GOROD
 description ### to Emergancy ###
 translation-profile outgoing PSTN_Outgoing
 destination-pattern ^0[1,2,3,4,9]$
 no digit-strip
 direct-inward-dial
 port 0/3/1:15
 forward-digits 2
!
dial-peer voice 101 pots
 corlist outgoing CALL-GOROD
 description ### to Information ###
 translation-profile outgoing PSTN_Outgoing
 destination-pattern ^0..$
 no digit-strip
 direct-inward-dial
 port 0/3/1:15
 forward-digits 3
!
dial-peer voice 102 pots
 corlist outgoing CALL-INTERNATIONAL
 description ### to INTERNATIONAL ###
 translation-profile outgoing PSTN_Outgoing
 shutdown
 destination-pattern 9810.T
 no digit-strip
 direct-inward-dial
 port 0/3/1:15
 forward-digits all
!
dial-peer voice 200 pots
 corlist outgoing CALL-LOCAL
 description ### AVAYA 8XX ###
 destination-pattern ^8..$
 no digit-strip
 direct-inward-dial
 port 0/3/0:15
 forward-digits 3
!
dial-peer voice 300 pots
 corlist outgoing CALL-GOROD
 description =-test-=
 translation-profile outgoing PSTN_Outgoing_avaya
 shutdown
 destination-pattern ^9[29]......$
 incoming called-number .%
 no digit-strip
 direct-inward-dial
 port 0/3/1:15
 forward-digits 7
!
dial-peer voice 201 pots
 port 0/3/0:15
!
dial-peer voice 202 pots
 port 0/3/0:15
!
!
!
!
gatekeeper
 shutdown
!
!
alias exec se1 show controller e1
alias exec c conf t
alias exec r sh run
alias exec i sh ip ro
alias exec ib sh ip int brie
alias exec sg show run | s gatekeeper
alias exec ge sho gatekeeper end
alias exec g sho gatekeeper
alias exec rs sh run | s
alias exec ri sh run | i
alias exec rb sh run | b
alias exec acl sh run | be access-list
alias exec epdn sh run | be ephone-
alias exec dp sh run | be dial-peer
!
line con 0
line aux 0
line 2
 no activation-character
 no exec
 transport preferred none
 transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
 stopbits 1
line vty 0 4
 access-class 23 in
 exec-timeout 0 0
 privilege level 15
 transport input ssh
line vty 5 15
 access-class 23 in
 exec-timeout 0 0
 privilege level 15
 transport input ssh
!
scheduler allocate 20000 1000
ntp master
ntp update-calendar
ntp server 91.194.10.40
ntp server 93.185.187.89
ntp server 194.149.67.130
ntp server 192.43.244.18
ntp server 80.93.53.29
!
end

 

 

 

I have this problem too.
0 голоса
Correct Answer by Kirill Glushenkov about 2 года 11 месяцев назад

Добрый день!

Вы пользуетесь старым документом, для настройки video conference, необходимо использовать следующий документ:

http://www.cisco.com/c/en/us/td/docs/voice_ip_comm/cucme/admin/configura...

В Вашем случае проблема заключается в том, что скорее всего закончились DSP ресурсы.

Как видно из конфигурации, используется 2 Е-потока, на остальные сервисы скорее всего просто не осталось ресурсов.

Необходимо воспользоваться DSP-калькулятором на cisco.com/go/tools . Так же можно обратиться к данному посту:

https://supportforums.cisco.com/document/123061/understanding-output-sho...

Regards,

Kirill

Loading.
Correct Answer
Kirill Glushenkov ср, 09/10/2014 - 01:57
User Badges:
  • Cisco Employee,

Добрый день!

Вы пользуетесь старым документом, для настройки video conference, необходимо использовать следующий документ:

http://www.cisco.com/c/en/us/td/docs/voice_ip_comm/cucme/admin/configura...

В Вашем случае проблема заключается в том, что скорее всего закончились DSP ресурсы.

Как видно из конфигурации, используется 2 Е-потока, на остальные сервисы скорее всего просто не осталось ресурсов.

Необходимо воспользоваться DSP-калькулятором на cisco.com/go/tools . Так же можно обратиться к данному посту:

https://supportforums.cisco.com/document/123061/understanding-output-sho...

Regards,

Kirill

Действия

Информация о дискуссии