×

Предупреждение

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Проброс порта Cisco C881

Answered Question
Мар 24th, 2015
User Badges:

Здравствуйте!

Несколько дней боюсь на задачей проброса порта к iLO Web интерфейсу HP.

Все действия провожу на реальном оборудовании, но в рамках локальной сети. 

Задача состоит в том, чтобы получить доступ через браузер к iLO интерфейсу по HTTPS с WAN порта к серверу находящемуся в LAN сегменте.

По локальной сети iLO доступен.

Подскажите пожалуйста в чем ошибка?

 

version 15.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname R
!
boot-start-marker
boot-end-marker
!
!
!
aaa new-model
!
!
aaa authentication login default local-case
!
!
!
!
!
aaa session-id common
clock timezone SPb 3 0
clock calendar-valid
!
!
!
!
!
!
ip dhcp pool LAN
 network 10.0.1.0 255.255.255.0
 default-router 10.0.1.1
 dns-server 10.0.0.6 10.0.0.114
 domain-name TESTLAN
!
!
!
no ip bootp server
ip domain name office.local
ip cef
no ipv6 cef
!
!
cts logging verbose
!
!
license udi pid C881-K9 sn FCZ190690P6
!
!
username xxx privilege 15 secret 5 xxx
!
no cdp run
!
ip ssh time-out 60
ip ssh authentication-retries 2
ip ssh version 2
!
!
!
!
interface FastEthernet0
 no ip address
!
interface FastEthernet1
 no ip address
!
interface FastEthernet2
 no ip address
 shutdown
!
interface FastEthernet3
 no ip address
 shutdown
!
interface FastEthernet4
 description INTERNET
 ip address dhcp
 ip nat outside
 ip virtual-reassembly in
 duplex auto
 speed auto
!
interface Vlan1
 ip address 10.0.1.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
!
no ip forward-protocol nd
no ip http server
no ip http secure-server
!
ip nat inside source list 1 interface FastEthernet4 overload
ip nat inside source static tcp 10.0.1.2 443 10.0.0.207 443 extendable
!
!
access-list 1 permit 10.0.1.0 0.0.0.255
!
!
!
!
line con 0
 exec-timeout 5 0
 privilege level 15
 no modem enable
 transport output none
line aux 0
 exec-timeout 0 0
 no exec
 transport output none
line vty 0 4
 privilege level 15
 transport input ssh
line vty 5 189
 privilege level 15
 transport input ssh
!
scheduler allocate 20000 1000
ntp update-calendar
ntp server 3.ru.pool.ntp.org
ntp server 1.ru.pool.ntp.org
ntp server 0.ru.pool.ntp.org
ntp server 2.ru.pool.ntp.org
!
!
!
end

 

I have this problem too.
0 голоса
Correct Answer by Sergey Goffert about 2 года 4 месяца назад

Ну собственно трансляции-то у вас успешно строятся:

tcp 10.0.0.207:8000    10.0.1.2:443       10.0.0.10:54559    10.0.0.10:54559

Дело не в них, скорее всего все же что-то не так с этим сервером.

Вы так и не ответили ЯВНО на вопрос на счет взаимных пингов.

На сервер приходят запросы с адреса 10.0.0.10, и ответ он отправляет туда же. С сервера пингуется адрес 10.0.0.10 ? Если нет, покажите трасировку с сервера до этого адреса.

И во время пинга сделайте еще раз

sh ip nat translations
Loading.
Sergey Goffert вт, 03/24/2015 - 03:35
User Badges:
  • Silver, 250 points or more
  • Почетные Знаки Сообщества,

    Выбор участников, Ноябрь 2014

Добрый день!

 

А сервер получает IP по dhcp от этой циски ?
И если там статика, то какой там шлюз по умолчанию ? 10.0.1.1 ?

 

У вас на интерфейсе Fa4 настроен DHCP, и не очень понятно, как клиент вообще узнает его IP, но вы точно на него обращаетесь ?

 

Так-то на вскидку всё правильно, поэтому возникают сомнения в корректности настройки сервера и клиента.

Vitaliy Kudryavtsev вт, 03/24/2015 - 06:39
User Badges:

Да, интерфейс iLO получает адрес от циски.

Bindings from all pools not associated with VRF:
IP address          Client-ID/              Lease expiration        Type
                    Hardware address/
                    User name
10.0.1.2            0184.3497.11b5.52       Mar 25 2015 04:28 PM    Automatic

Шлюз по умолчанию соответственно получает по DHCP 10.0.1.1

На Fa4 прилетает адрес по DHCP 10.0.0.207, обращаюсь точно на него, т.к. подключаюсь к циске по SHH.

 

С траблшутингом пока на Вы, если скажите команды выложу выход.

 

Sergey Goffert вт, 03/24/2015 - 07:14
User Badges:
  • Silver, 250 points or more
  • Почетные Знаки Сообщества,

    Выбор участников, Ноябрь 2014

Ну т.е. с маршрутизатора и сервер и клиент доступны и пингуются ?

 

А попробуйте снаружи указать нестандартный порт, например 8000:
ip nat inside source static tcp 10.0.1.2 443 10.0.0.207 8000 extendable

Проверить текущие трансляции можно командой:

sh ip nat translations

 

Vitaliy Kudryavtsev вт, 03/24/2015 - 07:53
User Badges:

Клиента нет, только один сервер с iLO интерфейсом. В качестве клиента выступает Web браузер с ПК IP адрес которого 10.0.0.10

Попробовал изменить порт как вы сказали, но результата не дало.

R#sh ip nat translations
Pro Inside global      Inside local       Outside local      Outside global
tcp 10.0.0.207:8000    10.0.1.2:443       10.0.0.10:54559    10.0.0.10:54559
tcp 10.0.0.207:8000    10.0.1.2:443       10.0.0.10:54560    10.0.0.10:54560
tcp 10.0.0.207:8000    10.0.1.2:443       ---                ---

 

 

Correct Answer
Sergey Goffert вт, 03/24/2015 - 21:30
User Badges:
  • Silver, 250 points or more
  • Почетные Знаки Сообщества,

    Выбор участников, Ноябрь 2014

Ну собственно трансляции-то у вас успешно строятся:

tcp 10.0.0.207:8000    10.0.1.2:443       10.0.0.10:54559    10.0.0.10:54559

Дело не в них, скорее всего все же что-то не так с этим сервером.

Вы так и не ответили ЯВНО на вопрос на счет взаимных пингов.

На сервер приходят запросы с адреса 10.0.0.10, и ответ он отправляет туда же. С сервера пингуется адрес 10.0.0.10 ? Если нет, покажите трасировку с сервера до этого адреса.

И во время пинга сделайте еще раз

sh ip nat translations
Vitaliy Kudryavtsev ср, 03/25/2015 - 02:49
User Badges:

Да, все верно дело было не в циске.

На iLO интерфейсе не было отмечено галкой "Use Supplied Gateway", в связи с этим адрес шлюза не был установлен. Сейчас работает как надо.

Спасибо большое за поддержку.

Attachment: 

Действия

Информация о дискуссии