Cisco Support Community
отмена
Отображаются результаты для 
Вместо этого искать 
Вы имели в виду: 
cancel
Объявления
Добро пожаловать в Сообщество Технической поддержки Cisco. Мы рады получить обратную связь .
Community Member

Срабатывание Port-Security, непонятная ситуация

Добрый день. Возникает непонятное срабатывание port-security на интерфейсах.

В логах это:

Aug  8  08:11:14 172.17.0.22 4403: 007651: Aug  8 03:11:13.556:  %PORT_SECURITY-CLUSTER_MEMBER_6-2-PSECURE_VIOLATION: Security violation  occurred, ca

used by MAC address b4b0.1784.2650 on port FastEthernet0/3.

Данная  ошибка повторяется много раз с одним и тем же мак-адресов с  периодичностью где-то 15 секунд. Возникает не только на данном  интерфейсе, но и на некоторых других. Отчего она возникает, ведь  переполнения маков нет?

К сожалению, гугл ничего именно по данной проблеме не сказал.

Порт настроен вот так:
interface FastEthernet0/3
switchport access vlan 20
switchport mode access
switchport voice vlan 104
switchport port-security maximum 10
switchport port-security
switchport port-security violation restrict
no snmp trap link-status
storm-control broadcast level 10.00 1.00
storm-control action shutdown
storm-control action trap
spanning-tree portfast

К порту подключен IP-телефон и рабочая станция через него, т.е. на порту видно всего 2 мак-адреса.

4 ОТВЕТ.
Community Member

Срабатывание Port-Security, непонятная с

У нас было что-то аналогичное, полный анализ я не проводил, но было подозрение на skype

который поставили и потом пошла блокировка портов (было давно и возможно какая-то конкретная версия имела не понятный баг/фичу), снесли и стало работать без проблем.

Во всяком случае стоит обратить внимание на софт на ПК, понятно что вылавливать будет сложно

Community Member

Срабатывание Port-Security, непонятная с

Может вот это поможет:

switchport port-security maximum 10 vlan access

switchport port-security maximum 10 vlan voice

А еще можно добавить:

switch(config)#errdisable recovery cause psecure-violation

switch(config)#errdisable recovery interval 300

Это позволит автоматически выводить порт из состояния error-disabled.

Срабатывание Port-Security, непонятная с

А вы уверены, что там два MAC ?

Вы проверяли это сами в момент проблем ?

Некоторые сетевые карты когда умирают начинают слать в сеть пакеты с немного изменённым собственным MAC. Обычно меняется буквально пара октетов, но в как следствие у каждого пакета может быть свой MAC.

В результате такого поведения на порту могут висеть пара десятков MAC'ов, хотя подключен только один ПК.

Cisco Employee

Срабатывание Port-Security, непонятная с

Добрый день, Владимир,

switchport port-security violation restrict

restrict—Drops packets with unknown source addresses until you remove a sufficient number of

secure MAC addresses to drop below the maximum value and causes the SecurityViolation counter

to increment

Если софт позволяет, поменяйте на replace. Тогда новый адрес будет заменять предыдущие (после заполнения до максимально возможного количества).

Cудя по MAC-адресу, это Avaya. Так что скорее всего, проблема связана с вашими телефонами. К какому порту подключён телефон с этим мак-адресом? Какой на нём (порту) конфиг? В скольких VLAN'ах виден этот MAC?

Cheers, Iron

712
Просмотры
0
Полезный материал
4
Ответы
СоздатьДля создания публикации, пожалуйста в систему