отмена
Отображаются результаты для 
Вместо этого искать 
Вы имели в виду: 
Объявления
Добро пожаловать в Сообщество Технической поддержки Cisco. Мы рады получить обратную связь .
New Member

Caller can not hear the internal network IP telephony, and they can hear me???

There are 2 offices

1 office, where:

Yota ( picks to kriptoshlyuzu on Istomin ( tuning kriptoshlyuze Sovestky prescribed tunnel) ) - Kriptoshlyuz -Cisco 2800 ( DHCP distributes phones in one office )-Cisco 2960 Poe

2 office where :

Kriptoshlyuz -cisco 3560 -Cisco2911 who gives DHCP phones in the office 2

And cisco Cisco 3560- Server 7800 on which registration etc.

By 3560 -Cisco 2960 Poe

When connecting one office in the office 2

All the phones in the office can not hear 2 1 office, except nesolkih phones with number 7945 may be the same example

And even on phones 9971 solved the problem in the phone settings menu Protocol Specific Information put there daw Media Termination Point Required, if this video is no longer working , and the phone hears Soviet ! (I'm on all phones 9971 did it, except his ) ? ? ? What Problem ? Codecs ? where?

27 ОТВЕТ.

Caller can not hear the internal network IP telephony, and they

Комьюнити русское, потому отвечу по-русски, чего и вам советую.

Насколько я понял, проблема: односторонняя слышимость при звонке между офисами, но проблема устраняется после включения принудительного MTP.

Зайдите на 2800-й роутер офиса 1, и сделайте:

router#ping

Protocol [ip]:

Target IP address: [IP адрес телефона в другом офисе]

Repeat count [5]:

Datagram size [100]:

Timeout in seconds [2]:

Extended commands [n]: y

Source address or interface: [интерфейс, в котором находятся телефоны этого офиса]

Type of service [0]: 184

Set DF bit in IP header? [no]:

Validate reply data? [no]:

Data pattern [0xABCD]:

Loose, Strict, Record, Timestamp, Verbose[none]:

Sweep range of sizes [n]:

А после этого:

ping [IP адрес телефона в другом офисе] source [интерфейс, в котором находятся телефоны этого офиса]

и контрольный:

ping [IP адрес CUCM] source [интерфейс, в котором находятся телефоны этого офиса]

New Member

Caller can not hear the internal network IP telephony, and they

Во 2 офисе телефоны модели 7911 из которых 11 штук слышат 2 офис.Другие телефоны 7911 не слышат офис 2.Такая же картина с 7945. МТР имеется 2 штуки.

Cisco Media Termination Point Software и 

Cisco IOS Enhanced Software Media Termination Point

в обоих случаях проставил галки
и проверил-не работает!

Caller can not hear the internal network IP telephony, and they

Есть ли фильтрация пакетов, файрволы, ACL и т.д. между офисами? Чем различаются настройки работающего и неработающего телефона одной модели?

New Member

Caller can not hear the internal network IP telephony, and they

Фильтрация была.но сейчас ее нет.Ничем.Было что код загрузки был разный,но на работающем и не работающем такой же был-один и тот же.Пробую обновить прошивку телефонов 7911 на CUCM

Caller can not hear the internal network IP telephony, and they

Работающие и неработающие телефоны в 1-м офисе (который не всегда слышит 2-й офис) с точки зрения сети идентичны? Один VLAN, одна подсеть?

Установите вызов между двумя телефонами, один из которых не слышит другого, и на обоих дважды нажмите на физическую кнопку со знаком вопроса (или settings-status-call statistics). Убедитесь, что оба отправляют и получают пакеты. Если один отправляет, но другой не получает, то проверьте еще раз наличие фильтров на сети, на каждом этапе маршрутизации/коммутации пакетов. И ACLи на роутерах, и портовые ACL на свитчах, на уровне каждого интерфейса, через который проходят пакеты. Если не найдете, то придется ловить пакеты на роутерах и/или делать SPAN на свитчах.

New Member

Caller can not hear the internal network IP telephony, and they

vlan один но сети разные

Caller can not hear the internal network IP telephony, and they

Т.е. различие между работающими и неработающими телефонами - то, в какой подсети они находятся? Проверяйте, есть ли везде маршруты на ту подсеть, в которой находятся телефоны, которые кого-то не слышат. Если нужны более конкретные рекомендации, то дайте конфигурации протокола маршрутизации на ближайших к телефонам L3 устройствах, а также настройки интерфейсов/VLANов в сторону телефонов.

New Member

Caller can not hear the internal network IP telephony, and they

Получается так!

Раньше было так-1 офисс -Телефон-Cisco 2960Poe-Cisco2800-Туннель (по цифровому каналу не шифрованнуому)-соеденено ко 2 офису -Cisco2911-Cisco3560-Cisco7800 (сам сервер регистрации телефонов)

А сейчас 1 офис -Телефон-Cisco 2960Poe-Cisco2800-Криптошлюз-тоннель во 2 офис-криптошлюз-Cisco 3560-

Cisco7800.

TFTP один для всех.

А вот сети разные.

Маршруты прописаны (иначе регистрации телефонов не было бы)

И получается что звонки идут с 1 офиса во второй,часть телефонов в кол-ве 11 штук работают нормально, а остальные таких же марок во 2 офисе не слышат 1 офис,при этом 1 офис слышыт 2 офис.

New Member

Caller can not hear the internal network IP telephony, and they

Может быть из-за транскодера???который находиться на 2911???так как раньше проходила через нее сеть

Caller can not hear the internal network IP telephony, and they

Голосовой трафик между телефонами ходит напрямую между ними, а не через сервер (в отличие от трафика сигнализации). Потому первое подозрение - дропается трафик. Давайте говорить детально.

1) Установите вызов, чтобы одна сторона другую не слышала, а затем добавьте в конференцию третьего и проверьте, устранилась ли проблема.

2) Раз сети у работающих и неработающих телефонов в пределах одного офиса разные, жду конфигурацию интерфейсов и IGP, "show ip route" на затронутые сети, а также конкретные IP адреса телефонов.

New Member

Caller can not hear the internal network IP telephony, and they

1) Установите вызов, чтобы одна сторона другую не слышала, а затем добавьте в конференцию третьего и проверьте, устранилась ли проблема.

Мы слышали друг друга в троем в режиме конференции! А когда я просто звонил 1 на 1 то, опять не слышно!???

New Member

Re: Caller can not hear the internal network IP telephony, and t

Телефоны 2 офиса с которых звонили:7945 и 9971

набрал номер 1 офиса телефон 7911(не слышем его),

затем 7945 набрал 2 офис 9971 и я объеденил в конференцию и мы услышали друг друга.

IP 2 офиса: 7945 - 10.50.51.1

                  9971 - 10.30.4.56 (я использую блок питания)

IP 1 офиса: 7911 - 10.50.52.6


Так же проверили и на других телефонах:

IP 2 офиса: 7945 - 10.50.51.1

                  7975 - 10.50.51.7

IP 1 офиса: 7911 - 10.50.52.6

И конференция работает.

А так на прямую нет!

New Member

Caller can not hear the internal network IP telephony, and they

вот 2 конфиги 1 офиса с2800 и с2960 пое:

C2800#show run

Building configuration...

Current configuration : 13700 bytes

!

! Last configuration change at ******* Wed Dec 11 2013 by *******

!

version 12.4

service timestamps debug datetime localtime show-timezone

service timestamps log datetime localtime show-timezone

service password-encryption

!

hostname C2800

!

boot-start-marker

boot system flash:c2801-adventerprisek9-mz.124-22.T.bin

boot-end-marker

!

logging message-counter syslog

logging buffered 128000

enable secret *********

!

aaa new-model

!

!

aaa authentication login default local

!

!

aaa session-id common

clock timezone ******

clock calendar-valid

cef table consistency-check IPv4 data-checking

dot11 syslog

ip source-route

!

!

ip dhcp excluded-address 10.50.55.240 10.50.55.254

ip dhcp excluded-address 10.30.3.240

ip dhcp excluded-address 10.30.3.1 10.30.3.49

ip dhcp excluded-address 10.30.3.201 10.30.3.254

!

ip dhcp pool Phones

   network 10.50.52.0 255.255.252.0

   option 150 ip 10.50.51.250

   default-router 10.50.55.240

!

ip dhcp pool LAN668

   network 10.30.3.0 255.255.255.0

   domain-name ********

   default-router 10.30.3.240

   dns-server 10.30.1.1 10.30.1.4

!

!

ip cef

no ip domain lookup

ip domain name ********

ip name-server ************

no ipv6 cef

!

multilink bundle-name authenticated

!

!

!

!

!

!

!

voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

sip

  subscription maximum accept 24

  registrar server expires max 3600 min 3600

!

!

voice class codec 1

codec preference 1 g711alaw

codec preference 2 g711ulaw

codec preference 3 g729br8

!

!

!

!

voice class h323 1

  h225 timeout tcp establish 3

  h225 timeout setup 2

!

!

!

!

!

!

!

!

!

voice register global

mode cme

source-address 172.16.0.254 port 5060

load 7911 term11.default

load 3951 SIP3951.8-1-1b

timezone 49

date-format D/M/Y

tftp-path flash:

file text

create profile sync *****

network-locale RU

user-locale RU

!

voice hunt-group 1 sequential

final 101

list 101,110,193,192,191,100

timeout 15

pilot 190

!

!

voice hunt-group 3 parallel

list 131,133,135,136

timeout 180

pilot 191

!

!

voice hunt-group 4 parallel

list 142,143,144

timeout 180

pilot 193

!

!

voice hunt-group 5 parallel

list 151,152

timeout 180

pilot 192

!

!

voice hunt-group 6 parallel

list 170,171,174,175,176

timeout 180

pilot 166

!

!

voice hunt-group 7 parallel

list 177,179,180,181,182

timeout 180

pilot 165

!

!

voice hunt-group 8 parallel

list 123,124,160

timeout 180

pilot 167

!

!

voice hunt-group 9 parallel

list 172,183,184,135

timeout 180

pilot 168

!

!

!

voice translation-rule 1

rule 1 /^***/ /1/

rule 2 /^***/ /2/

rule 3 /^***/ /3/

rule 4 /^**/ /4/

rule 5 /^***/ /5/

rule 6 /^****/ /6/

rule 7 /^****/ /7/

rule 8 /^***/ /8/

!

voice translation-rule 2

rule 1 /^***/ /5/

!

voice translation-rule 4

rule 1 /^9\(.*\)/ /\1/

!

voice translation-rule 5

rule 1 /^1[0,1,9]./ /*****/

rule 3 /^13./ /******/

rule 4 /^14./ /********/

rule 5 /^15./ /**/

rule 6 /^17./ /*****/

rule 7 /^1[2,6]./ /***/

rule 8 /18./ /*******/

!

!

voice translation-profile TTK_IN

translate called 1

!

voice translation-profile TTK_IN_FAX

translate called 2

!

voice translation-profile TTK_OUT

translate calling 5

translate called 4

!

!

voice-card 0

!

!

!

!

!

username ********* privilege 15 secret **********

archive

log config

  hidekeys

!

!

!

!

!

ip ftp username ******

ip ftp password************

!

!

!

!

interface Tunnel0

no ip address

shutdown

!

interface FastEthernet0/0

description C-2960

no ip address

duplex auto

speed auto

!

interface FastEthernet0/0.22

encapsulation dot1Q 22

ip address 192.168.22.240 255.255.255.0

!

interface FastEthernet0/0.50

encapsulation dot1Q 50

ip address 10.50.55.240 255.255.252.0

h323-gateway voip interface

h323-gateway voip bind srcaddr 10.50.55.240

!

interface FastEthernet0/0.668

encapsulation dot1Q 668

ip address 10.30.3.240 255.255.255.0

!

interface FastEthernet0/1

description Kontinent

ip address 10.1.0.2 255.255.255.0

duplex auto

speed auto

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 10.1.0.1-это континент

ip http server

ip http authentication local

no ip http secure-server

!

!

!

!

!

!

!

!

!

tftp-server flash:apps70.8-3-2-27.sbn

tftp-server flash:cnu70.8-3-2-27.sbn

tftp-server flash:cvm70sccp.8-3-2-27.sbn

tftp-server flash:dsp70.8-3-2-27.sbn

tftp-server flash:jar70sccp.8-3-2-27.sbn

tftp-server flash:SCCP70.8-3-3S.loads

tftp-server flash:term70.default.loads

tftp-server flash:term71.default.loads

tftp-server flash:apps11.8-3-2-27.sbn

tftp-server flash:cnu11.8-3-2-27.sbn

tftp-server flash:cvm11sccp.8-3-2-27.sbn

tftp-server flash:dsp11.8-3-2-27.sbn

tftp-server flash:jar11sccp.8-3-2-27.sbn

tftp-server flash:SCCP11.8-3-3S.loads

tftp-server flash:term06.default.loads

tftp-server flash:term11.default.loads

tftp-server flash:7921-dictionary.xml

tftp-server flash:7921-font.dat

tftp-server flash:7921-kate.utf-8.xml

tftp-server flash:7921-kate.xml

tftp-server flash:be-sccp.jar alias be-sccp.jar

tftp-server flash:g3-tones.xml alias g3-tones.xml

tftp-server flash:gp-sccp.jar alias gp-sccp.jar

tftp-server flash:ipc-sccp.jar alias ipc-sccp.jar

tftp-server flash:tc-sccp.jar alias tc-sccp.jar

tftp-server flash:td-sccp.jar alias td-sccp.jar

tftp-server flash:/Russian_Federation/g3-tones.xml alias Russian_Federation/g3-tones.xml

tftp-server flash:/Russian_Russia/tc-sccp.jar alias Russian_Russia/tc-sccp.jar

tftp-server flash:ringlist.xml

tftp-server flash:DistinctiveRingList.xml

tftp-server flash:Pop.raw

tftp-server flash:Jamaica.raw

tftp-server flash:Analog1.raw

tftp-server flash:Chime.raw

tftp-server flash:Bass.raw

tftp-server flash:BOOT3951.0-0-0-9.zz

tftp-server flash:DSP3951.0-0-0-2.zz

tftp-server flash:SIP3951.8-1-1-4.zz

tftp-server flash:SIP3951.8-1-1b.loads

tftp-server flash:apps75.8-4-1-23.sbn

tftp-server flash:cnu75.8-4-1-23.sbn

tftp-server flash:dsp75.8-4-1-23.sbn

tftp-server flash:jar75sccp.8-4-1-23.sbn

tftp-server flash:SCCP75.8-4-2S.loads

tftp-server flash:term75.default.loads

tftp-server flash:B015-1-0-4.SBN

tftp-server flash:mk-sccp.jar alias Russian_Russia/mk-sccp.jar

tftp-server flash:SCCP42.9-1-1SR1S.loads

tftp-server flash:term42.default.loads

tftp-server flash:term62.default.loads

tftp-server flash:jar42sccp.9-1-1TH1-16.sbn

tftp-server flash:dsp42.9-1-1TH1-16.sbn

tftp-server flash:cvm42sccp.9-1-1TH1-16.sbn

tftp-server flash:cnu42.9-1-1TH1-16.sbn

tftp-server flash:apps42.9-1-1TH1-16.sbn

tftp-server flash:flash/kern9971.9-1-1SR1.sebn alias kern9971.9-1-1SR1.sebn

tftp-server flash:flash/rootfs9971.9-1-1SR1.sebn alias rootfs9971.9-1-1SR1.sebn

tftp-server flash:flash/sip9971.9-1-1SR1.loads alias sip9971.9-1-1SR1.loads

tftp-server flash:flash/dkern9971.100609R2-9-1-1SR1.sebn alias dkern9971.100609R2-9-1-1SR1.sebn

tftp-server flash:flash/sboot9971.031610R1-9-1-1SR1.sebn alias sboot9971.031610R1-9-1-1SR1.sebn

tftp-server flash:flash/skern9971.022809R2-9-1-1SR1.sebn alias skern9971.022809R2-9-1-1SR1.sebn

tftp-server flash:cnu11.8-4-1-23.sbn

tftp-server flash:apps11.8-4-1-23.sbn

tftp-server flash:dsp11.8-4-1-23.sbn

tftp-server flash:jar11sccp.8-4-1-23.sbn

tftp-server flash:cvm11sccp.8-4-1-23.sbn

!

control-plane

!

!

!

voice-port 0/0/0

cptone RU

caller-id enable

!

voice-port 0/0/1

cptone RU

caller-id enable

!

voice-port 0/0/2

cptone RU

caller-id enable

!

voice-port 0/0/3

cptone RU

caller-id enable

!

ccm-manager fax protocol cisco

!

mgcp fax t38 ecm

!

sccp local FastEthernet0/0.50

sccp ccm 10.50.51.250 identifier 1 version 4.1

sccp

!

dspfarm profile 1 transcode

associate application SCCP

shutdown

!

!

dial-peer voice 100 voip

description ### TTK Outgoing ###

translation-profile outgoing TTK_OUT

destination-pattern 9T

rtp payload-type cisco-codec-fax-ack 126

session protocol sipv2

session target ipv4:****

dtmf-relay rtp-nte

codec g711alaw

fax-relay ecm disable

fax protocol cisco

no vad

!

dial-peer voice 101 voip

description ### TTK Incoming ###

translation-profile incoming TTK_IN

session protocol sipv2

session target ipv4:****

incoming called-number *,*,*,*,mf-relay rtp-nte

codec g711alaw

!

dial-peer voice 195 pots

description Fax-server

destination-pattern 195

port 0/0/0

!

dial-peer voice 196 pots

destination-pattern 196

port 0/0/1

!

dial-peer voice 197 pots

destination-pattern 197

port 0/0/2

!

dial-peer voice 198 pots

destination-pattern 198

port 0/0/3

!

dial-peer voice 102 voip

description ### TTK Incoming FAX ###

translation-profile incoming TTK_IN_FAX

session protocol sipv2

incoming called-number *****

dtmf-relay rtp-nte

codec g711alaw

!

!

sip-ua

sip-server ipv4:10.0.0.254

!

!

!

telephony-service

sdspfarm units 1

sdspfarm transcode sessions 10

sdspfarm tag 1 mytranscoder

video

  maximum bit-rate 256

em logout 0:0 0:0 0:0

pin 2105 override

max-ephones 30

max-dn 40

ip source-address 10.0.0.254 port 2000 secondary 192.168.0.245-это была раньше 2911(когда была старая сеть)

service phone videoCapability 1

timeouts interdigit 7

timeouts ringing 30

system message *****

cnf-file perphone

user-locale RU

network-locale RU

load 7915-24 B015-1-0-4

load 7911 SCCP11.8-3-3S

load 7941 SCCP41.8-3-3S

load 7962 SCCP42.9-1-1SR1S

load 7970 SCCP70.8-3-3S

load 7975 SCCP75.8-4-2S

time-zone 51

time-format 24

date-format dd-mm-yy

voicemail 300

max-conferences 8 gain -6

call-forward pattern .T

call-forward system redirecting-expanded

moh flash:summertime.au

web admin system name *** password ******

dn-webedit

transfer-system full-consult

transfer-pattern 9 blind

transfer-pattern .T

after-hours date Jan 8 00:01 23:59

night-service day Sun 00:01 23:59

night-service day Sat 00:01 23:59

night-service date Jan 8 00:01 23:59

create cnf-files version-stamp Jan 01 2002 00:00:00

!

!

ephone-dn  8  dual-line

number 105

label Conference

description Conference

name Conference

hold-alert 30 originator

!

!

их 30 штук

!

!

ephone  1

device-security-mode none

mac-address 0023.3319.F4FC

speed-dial 1 9540940# label "DOM"

type 7911

!

!

!

ephone  2

device-security-mode none

mac-address 0023.331A.0425

type 7911

......их 30 штук

!

!

banner login ^CWelcome to C2800^C

!

line con 0

line aux 0

line vty 0 4

session-timeout 30

password ******

transport input telnet ssh

line vty 5 15

transport input telnet ssh

!

scheduler allocate 20000 1000

ntp authenticate

ntp update-calendar

ntp server 10.50.51.250

end

C2960#show run

Building configuration...

Current configuration : 24438 bytes

!

! Last configuration change at ****** Thu Dec 12 2013 by ********

! NVRAM config last updated at **** Thu Dec 12 2013 by *******

!

version 12.2

no service pad

service timestamps debug datetime localtime show-timezone

service timestamps log datetime localtime

service password-encryption

!

hostname C2960

!

boot-start-marker

boot-end-marker

!

enable secret *******

!

username ******** privilege 15 secret ********

aaa new-model

!

!

aaa authentication login default local

!

!

!

aaa session-id common

clock timezone *****

system mtu routing 1500

ip subnet-zero

!

!

no ip domain-lookup

ip domain-name *******

ip name-server *****

!

!

crypto pki trustpoint TP-self-signed-362695808

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-362695808

revocation-check none

rsakeypair TP-self-signed-362695808

!

!

crypto pki certificate chain TP-self-signed-362695808

certificate self-signed 01

  30820250 308201B9 A0030201 02020101 300D0609 2A864886 F70D0101 04050030

  30312E30 2C060355 04031325 494F532D 53656C66 2D536967 6E65642D 43657274

  69666963 6174652D 33363236 39353830 38301E17 0D393330 33303130 30303131

  345A170D 32303031 30313030 30303030 5A303031 2E302C06 03550403 1325494F

  532D5365 6C662D53 69676E65 642D4365 72746966 69636174 652D3336 32363935

  38303830 819F300D 06092A86 4886F70D 01010105 0003818D 00308189 02818100

  B3AEAF78 CAD7BAB9 8560606A 1061AA59 AF72FF04 169DF16C 5139A13D 22716FFF

  05542B18 3C5C7779 9BE483EB AF6B4612 A5972232 17B02CDF 5FBFF854 B60D47CB

  EA5E608D F026B967 3F518A6B FF44D6AB 0733E003 55C4A504 8B8297AC 4D1FBEC3

  E3ADF5E1 587686C6 5D8D4E3B BE0BAB64 9B2A30C3 5BE92851 3B1101FE 691099E5

  02030100 01A37A30 78300F06 03551D13 0101FF04 05300301 01FF3025 0603551D

  11041E30 1C821A4D 4941432D 43323936 302D536F 7633342E 6D65646B 68762E72

  75301F06 03551D23 04183016 8014E89E 9369009B 838315A7 A3289845 68C8F341

  1F87301D 0603551D 0E041604 14E89E93 69009B83 8315A7A3 28984568 C8F3411F

  87300D06 092A8648 86F70D01 01040500 03818100 02A737AF 114FD71F C193B0A6

  ADA2A356 62560A17 CDC984F4 86E0A3EA 1306B86C 9709B57D E29100D2 11F429EA

  E36A99EB 50E0A00F BFD0DBC1 73CAC870 EB1CCAAE 0867BB32 2122F429 2D0BFE9C

  FD746BBB 99C3768E A81ADBAB 24280F48 1EEA069C A595BAB5 1D805180 14D754DB

  C91EF896 EE3FD2A3 4019C0E4 B13169F4 54E7177A

  quit

!

!

!

!

!

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

!

interface FastEthernet0/1

switchport access vlan 668

switchport mode access

switchport voice vlan 50

switchport port-security maximum 2

switchport port-security

switchport port-security aging time 2

switchport port-security violation restrict

switchport port-security aging type inactivity

mls qos trust cos

macro description cisco-phone

spanning-tree portfast

spanning-tree bpduguard enable

!

interface FastEthernet0/19

switchport access vlan 668

switchport mode access

switchport voice vlan 50

switchport port-security maximum 2

switchport port-security

switchport port-security aging time 2

switchport port-security violation restrict

switchport port-security aging type inactivity

mls qos trust cos

macro description cisco-phone

spanning-tree portfast

spanning-tree bpduguard enable

!

interface FastEthernet0/20

switchport access vlan 668

switchport mode access

switchport voice vlan 50

switchport port-security maximum 2

switchport port-security

switchport port-security aging time 2

switchport port-security violation restrict

switchport port-security aging type inactivity

mls qos trust cos

macro description cisco-phone

spanning-tree portfast

spanning-tree bpduguard enable

!

..........всего 48 портов, а используется 19. Я оставил 20,т.к. 20 использовал старую конфигу.(19 портов я исправил как во 2 офисе)

!

interface GigabitEthernet0/1

!

interface GigabitEthernet0/2

!

interface GigabitEthernet0/3

description C2800

switchport trunk allowed vlan 50,668

switchport mode trunk

spanning-tree portfast trunk

!

interface GigabitEthernet0/4-не используется!!!

description Server

switchport access vlan 3

switchport mode access

switchport port-security

switchport port-security aging time 2

switchport port-security violation restrict

switchport port-security aging type inactivity

storm-control broadcast level 0.10

spanning-tree portfast

spanning-tree bpduguard enable

!

interface Vlan1

no ip address

no ip route-cache

!

interface Vlan668

ip address 10.30.3.246 255.255.255.0

no ip route-cache

!

ip default-gateway 10.30.3.240

ip http server

ip http authentication local

ip http secure-server

!

control-plane

!

banner login ^CWelcome to C2960^C

!

line con 0

line vty 0 4

transport input telnet ssh

line vty 5 15

transport input telnet ssh

!

ntp authenticate

ntp clock-period 36028586

ntp server 10.50.51.250

end

New Member

Re: Caller can not hear the internal network IP telephony, and t

вот маршруты который прописан на центральном маршрутизатора с3560 (2 офис)

ip classless

ip route 10.50.52.0 255.255.252.0 192.168.255.5 - для телефонов (после этого маршрута регистрация прошла телефонов)

Сам сервер с7800 CUCM подключен к 3560

192.168.255.5 - это континент к котрому подключен другой континет

Caller can not hear the internal network IP telephony, and they

Вот они, типичные проблемы отсутствия динамической маршрутизации

Итак, проблема: пакеты из 1 офиса не доходят до 2 офиса (конкретнее - до сети 10.50.51.0). Насколько я понял, трафик между офисами проходит через этот 3560-й. На нем есть маршрут до 10.50.51.0?

И я не вижу устройства, на котором приземляется сеть 10.50.52.0.

Давайте так. С устройства в сети 10.50.52.0 сделайте traceroute 10.50.51.1. Если на каком-то устройстве трассировка прервется, то сделайте на нем "show ip cef 10.50.51.1 detail". Если трассировка покажет, что пакеты ходят кругами, и здесь нет конфига устройства, которое первым послало пакет не туда - дайте с него "show run | sec interface|ip route".

Если есть визуальная схема топологии между этими двумя локациями - было бы здорово увидеть ее.

New Member

Caller can not hear the internal network IP telephony, and they

Кароче звонки проходят на четные номера.А на нечетные офис 2 не слышит, а 1 слышит.

И трасировка до не четных доходит только до интернета 2 офиса (криптошлюза и все)

а если пингуем четные то,норм доходит.

New Member

Caller can not hear the internal network IP telephony, and they

офис 1

C2960#tracer 10.30.4.56

Type escape sequence to abort.

Tracing the route to 10.30.4.56

  1 10.30.3.240 0 msec 0 msec 9 msec

  2 5.8.193.118 0 msec 8 msec 0 msec

  3 192.168.255.6 17 msec 0 msec 0 msec

  4 10.30.4.56 9 msec 0 msec 8 msec

нормально

C2960#tracer 10.50.51.15

Type escape sequence to abort.

Tracing the route to 10.50.51.15

  1 10.30.3.240 9 msec 0 msec 0 msec

  2 5.8.193.118 8 msec 0 msec 9 msec

  3  *  *  *

  4  *  *  !H

вот такая ерунда. Т.е.доходит до внешнего IP 2 офиса

New Member

Re: Caller can not hear the internal network IP telephony, and t

сам

Gateway Configuration

New Member

Caller can not hear the internal network IP telephony, and they

вот конфига 2 офиса с2911(в которую раньше была вставлена по туннелю с2800 1 офиса)

C2911#show run

Building configuration...

Current configuration : 12023 bytes

!

! Last configuration change at *** Wed Nov 27 2013 by *****

! NVRAM config last updated at ***Tue Oct 8 2013 by ***

! NVRAM config last updated at 18 Tue Oct 8 2013 by ****

version 15.2

service timestamps debug datetime localtime

service timestamps log datetime localtime

service password-encryption

!

hostname C2911

!

boot-start-marker

boot system flash c2900-universalk9-mz.SPA.152-1.T.bin

boot-end-marker

!

!

logging buffered 51200 notifications

no logging console

enable secret ******

!

aaa new-model

!

!

aaa authentication login default local

!

!

!

!

!

aaa session-id common

clock timezone ***

clock calendar-valid

!

no ipv6 cef

!

!

!

ip dhcp excluded-address 10.50.51.201 10.50.51.254

ip dhcp excluded-address 10.50.51.54

!

ip dhcp pool Phones

network 10.50.48.0 255.255.252.0

default-router 10.50.51.251

option 150 ip 10.50.51.250

!

!

no ip domain lookup

ip domain name *****

ip name-server ****

ip cef

multilink bundle-name authenticated

!

!

!

!

!

crypto pki token default removal timeout 0

!

crypto pki trustpoint TP-self-signed-****

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-****

revocation-check none

rsakeypair TP-self-signed-35645599

!

!

crypto pki certificate chain TP-self-signed-35645599

certificate self-signed 01

  3082024C 308201B5 A0030201 02020101 300D0609 2A864886 F70D0101 04050030

  2F312D30 2B060355 04031324 494F532D 53656C66 2D536967 6E65642D 43657274

  69666963 6174652D 33353634 35353939 301E170D 31313031 31323034 30393537

  5A170D32 30303130 31303030 3030305A 302F312D 302B0603 55040313 24494F53

  2D53656C 662D5369 676E6564 2D436572 74696669 63617465 2D333536 34353539

  3930819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281 8100AE8F

  3C0056CF 260A252F 35CC7C50 BB1091CE 274300FA 00AD8E2F BCFEB6D7 2D426AD1

  F2B82A89 7EE78E95 5ECAB794 4AFE2673 4C266A20 3380FB59 DDD9C43C 5C7901DF

  9EAC453F BA1D5488 5F69B458 4CD86C14 69211CEF 39767DB0 2F055145 8BF4E30E

  1D5AF6B6 C056A932 0A5B380F C7F448FD E6D7B8DA 2296D972 59B63350 41870203

  010001A3 78307630 0F060355 1D130101 FF040530 030101FF 30230603 551D1104

  1C301A82 18633239 31312D49 53542E79 6F757264 6F6D6169 6E2E636F 6D301F06

  03551D23 04183016 801403AF E6AED8EB E694F218 7F71766C 0D28957E 3133301D

  0603551D 0E041604 1403AFE6 AED8EBE6 94F2187F 71766C0D 28957E31 33300D06

  092A8648 86F70D01 01040500 03818100 36992A07 4698A358 7736BD32 AB18E439

  B26AE525 FDC61BF7 E9408B79 06C593C3 C8CE368D 41983448 0F16038C AE331098

  F518D4D3 DF5ADDDD 2587323C 546D1245 E4508960 BC4F6E38 D85E79DF 051CFB59

  8D3860AA 03338761 4D43C0F6 3D8263F0 1050FE65 041D2B36 BE3FC737 BDE7D129

  78328EA7 8A3F97F2 0A3D2A54 3AC00F00

        quit

voice-card 0

dsp services dspfarm

!

!

voice rtp send-recv

!

voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none

h323

  emptycapability

sip

  subscription maximum accept 24

  registrar server expires max 600 min 60

  early-offer forced

!

voice class codec 1

codec preference 1 g711alaw

codec preference 2 g711ulaw

!

voice class h323 1

  h225 timeout tcp establish 3

  h225 timeout setup 2

!

!

!

!

voice translation-rule 1

rule 1 /^0\(.*\)/ /\1/

!

voice translation-rule 2

rule 1 /^*****/ /1*/

!

voice translation-rule 3

rule 1 // /******/

!

voice translation-rule 4

rule 1 /^1\(.*\)/ /\1/

!

voice translation-rule 5

rule 1 /1*/ /*****/

!

!

voice translation-profile FAX

translate called 3

!

voice translation-profile TTK_IN_FAX

translate called 2

!

voice translation-profile TTK_OUT

translate calling 5

translate called 4

!

voice translation-profile to_*****

translate called 1

!

!

!

fax receive called-subscriber $d$

fax interface-type fax-mail

mta send server 192.168.0.147 port 25

mta send subject "FAX"

mta send origin-prefix "Cisco-powered Fax System"

mta send postmaster *********

mta send mail-from hostname cisco2911

mta send mail-from username ***

license udi pid ********* sn ******

license accept end user agreement

hw-module ism 0

!

hw-module pvdm 0/0

!

!

!

username ********** privilege 15 secret ******

!

redundancy

!

!

!

!

!

!

interface Tunnel0

no ip address

shutdown

!

interface Embedded-Service-Engine0/0

no ip address

shutdown

!

interface GigabitEthernet0/0

description ### LAN ###

no ip address

duplex auto

speed auto

!

interface GigabitEthernet0/0.50

description ### Voice CUCM ###

encapsulation dot1Q 50

ip address 10.50.51.251 255.255.252.0

h323-gateway voip interface

h323-gateway voip bind srcaddr 10.50.51.251

!

interface GigabitEthernet0/0.325

description ###_Data_LAN###

encapsulation dot1Q 325

ip address 192.168.0.245 255.255.255.0

ip nat outside

ip virtual-reassembly in

!

interface ISM0/0

ip address 192.168.250.250 255.255.255.0

ip nat inside

ip virtual-reassembly in

service-module ip address 192.168.250.251 255.255.255.0

!Application: CUE Running on ISM

service-module ip default-gateway 192.168.250.250

!

interface GigabitEthernet0/1

description ###_telephony_TTK_###

ip address ------------***

duplex auto

speed auto

!

interface GigabitEthernet0/2

description ### старая сеть(не действует) ###

no ip address

duplex auto

speed auto

!

interface ISM0/1

description Internal switch interface connected to Internal Service Module

no ip address

shutdown

!

interface Vlan1

no ip address

!

ip forward-protocol nd

!

ip http server

ip http authentication local

ip http secure-server

!

ip nat inside source list 1 interface GigabitEthernet0/0.325 overload

ip route 0.0.0.0 0.0.0.0 192.168.0.240

ip route 10.30.10.0 255.255.255.0 192.168.255.6

ip route 10.30.10.0 255.255.255.0 10.50.51.250

ip route ttk*********** ***********

ip route 192.168.0.0 255.255.255.0 192.168.0.240

ip route 192.168.250.251 255.255.255.255 ISM0/0

!

access-list 1 permit 192.168.250.0 0.0.0.255

access-list 23 permit 192.168.0.0 0.0.0.255

!

!

snmp-server community *******

snmp-server enable traps snmp authentication

snmp-server enable traps entity-sensor threshold

snmp-server enable traps config

snmp-server host **********

!

!

!

control-plane

!

!

voice-port 0/0/0

cptone RU

caller-id enable

!

voice-port 0/0/1

cptone RU

caller-id enable

!

voice-port 0/0/2

cptone RU

caller-id enable

!

voice-port 0/0/3

cptone RU

caller-id enable

!

voice-port 0/1/0

translation-profile incoming FAX

disc_pi_off

cptone RU

connection plar *******

caller-id enable

!

voice-port 0/1/1

!

voice-port 0/1/2

!

voice-port 0/1/3

!

!

!

mgcp profile default

!

sccp local GigabitEthernet0/0.50

sccp ccm 10.50.51.250 identifier 1 version 4.1

sccp

!

sccp ccm group 1

associate ccm 1 priority 1

associate profile 1 register mytranscoder

keepalive retries 5

switchover method immediate

switchback method immediate

switchback interval 15

!

dspfarm profile 1 transcode universal

codec g711alaw

codec g711ulaw

maximum sessions 8

associate application SCCP

!

dial-peer voice 100 voip

description ### TTK Outgoing ###

translation-profile outgoing TTK_OUT

destination-pattern 9T

rtp payload-type cisco-codec-fax-ack 126

session protocol sipv2

session target ipv4:*********

dtmf-relay rtp-nte

codec g711alaw

fax-relay sg3-to-g3

fax protocol pass-through g711alaw

no vad

!

dial-peer voice 101 voip

description ### TTK Incoming ###

session protocol sipv2

session target ipv4:*****

incoming called-number 11[1,2,34,5,6,66,]

dtmf-relay sip-notify

codec g711alaw

!

dial-peer voice 195 pots

description ### Loop to FXO 0/1/0 ###

destination-pattern 195

port 0/0/0

forward-digits all

!

dial-peer voice 196 pots

destination-pattern 196

port 0/0/1

!

dial-peer voice 197 pots

destination-pattern 197

port 0/0/2

!

dial-peer voice 198 pots

destination-pattern 198

port 0/0/3

!

dial-peer voice 102 voip

description ### TTK Incoming FAX ###

translation-profile incoming TTK_IN_FAX

session protocol sipv2

incoming called-number *******

dtmf-relay rtp-nte

codec g711alaw

fax-relay sg3-to-g3

fax protocol pass-through g711ulaw

!

dial-peer voice 2000 voip

description ## CUE VoiceMail ##

destination-pattern 707

b2bua

session protocol sipv2

session target ipv4:192.168.250.251

voice-class sip outbound-proxy ipv4:192.168.250.251

dtmf-relay sip-notify

codec g711ulaw

no vad

!

dial-peer voice 2010 voip

description ## CUE AutoAttendant ##

destination-pattern 700

b2bua

session protocol sipv2

session target ipv4:192.168.250.251

voice-class sip outbound-proxy ipv4:192.168.250.251

dtmf-relay sip-notify

codec g711ulaw

no vad

!

dial-peer voice 194 pots

description ### Inbound from FXS 0/0/0 ###

service onramp

shutdown

information-type fax

direct-inward-dial

port 0/1/0

forward-digits all

!

dial-peer voice 2200 mmoip

service fax_on_vfc_onramp_app out-bound

shutdown

destination-pattern ******

information-type fax

session target mailto:*******

image encoding MH

image resolution fine

!

dial-peer voice 200 voip

description ## to_CUCM ##

destination-pattern 12[1,2,3,4,56,]

session target ipv4:10.50.51.250

voice-class h323 1

dtmf-relay h245-alphanumeric

codec g711alaw

!

dial-peer voice 201 voip

description ## from_CUCM_to_City ##

incoming called-number 9T

voice-class h323 1

dtmf-relay h245-alphanumeric

codec g711alaw

no vad

!

dial-peer voice 202 voip

description ## to_CUCM_**** ##

destination-pattern ****

session target ipv4:10.50.51.250

voice-class h323 1

dtmf-relay h245-alphanumeric

codec g711alaw

!

dial-peer voice 103 voip

description ###_TTK_Inbound_***_###

session protocol sipv2

incoming called-number ****

dtmf-relay sip-notify

codec g711alaw

!

dial-peer voice 120 voip

description ###_Inbound_from_CUCM_###

incoming called-number 0...

voice-class h323 1

dtmf-relay h245-alphanumeric

codec g711alaw

no vad

!

dial-peer voice 121 voip

description ###_Outbound_to_1_###

translation-profile outgoing to_1

destination-pattern 0...

session protocol sipv2

session target ipv4:10.50.0.10

dtmf-relay rtp-nte sip-kpml

codec g711alaw

!

dial-peer voice 122 voip

description ###_to_Internal_CUCM_###

destination-pattern [1-3]...

session target ipv4:10.50.51.250

voice-class h323 1

dtmf-relay h245-alphanumeric

codec g711alaw

no vad

!

dial-peer voice 123 voip

description ###_I1_###

session protocol sipv2

incoming called-number [1-3]...

dtmf-relay rtp-nte sip-kpml

codec g711alaw

!

!

!

!

gatekeeper

shutdown

!

!

credentials

!

!

telephony-service

sdspfarm units 1

sdspfarm transcode sessions 10

sdspfarm tag 1 mytranscoder

max-ephones 58

max-dn 300

ip source-address 10.50.51.251 port 2000

cnf-file perphone

time-zone 51

time-format 24

date-format dd-mm-yy

max-conferences 8 gain -6

call-forward pattern .T

call-forward system redirecting-expanded

moh "summertime.au"

web admin system name ******** password ******

dn-webedit

time-webedit

transfer-system full-consult

transfer-pattern .T

after-hours date Jan 8 00:01 23:59

night-service day Sun 00:01 23:59

night-service day Sat 00:01 23:59

night-service date Jan 8 00:01 23:59

create cnf-files version-stamp Jan 01 2002 00:00:00

shutdown

!

!

banner login ^CWelcome to C2911^C

!

line con 0

line aux 0

line 2

no activation-character

no exec

transport preferred none

transport input all

transport output pad telnet rlogin lapb-ta mop udptn v120 ssh

stopbits 1

line 131

no activation-character

no exec

transport preferred none

transport input all

transport output pad telnet rlogin lapb-ta mop udptn v120 ssh

stopbits 1

line vty 0 4

exec-timeout 40 0

privilege level 15

transport input telnet ssh

line vty 5 15

access-class 23 in

privilege level 15

transport input telnet ssh

!

scheduler allocate 20000 1000

ntp logging

ntp authenticate

ntp server 10.50.51.250

end

Highlighted
New Member

Caller can not hear the internal network IP telephony, and they

Re: Caller can not hear the internal network IP telephony, and t

(слишком много данных сверху, посты теряются, так что переношу диалог сюда, а длинные данные можно продолжать выкладывать сверху)

"Кароче звонки проходят на четные номера.А на нечетные офис 2 не слышит, а 1 слышит.

И трасировка до не четных доходит только до интернета 2 офиса (криптошлюза и все)

а если пингуем четные то,норм доходит."

Четные номера телефона? Не вижу причин, по которым это должно быть существенно. Но назовите два IP адреса из офиса 2, из которых один слышит офис 1, а другой - нет.

И еще следующее.

1) C2800# traceroute 10.50.51.1 source fa0/0.50

traceroute 10.50.51.250 source fa0/0.50

С2800#ping

Protocol [ip]:

Target IP address: 10.50.51.1

Repeat count [5]:

Datagram size [100]:

Timeout in seconds [2]:

Extended commands [n]: y

Source address or interface: fa0/0.50

Type of service [0]: 184

2800#ping 10.50.51.1 so fa0/0.50

2) Опишите конфигурацию криптошлюза касательно того, между какими сетями маршрутизировать через туннель.

3) На свитчах 3560 и 2960 есть какие-нибудь VACLы и так далее? Вообще - где что может фильроваться?

New Member

Re: Caller can not hear the internal network IP telephony, and t

Отключая DHCP на телефонах вручную и вбивая четный IP телефоны работают=)

1).C2800# traceroute 10.50.51.1 source fa0/0.50

Type escape sequence to abort.

Tracing the route to 10.50.51.1

  1 5.8.193.118 0 msec 4 msec 4 msec

  2 5.8.193.118 !H  !H  !H

...............

C2800#traceroute 10.50.51.250 source fa0/0.50

Type escape sequence to abort.

Tracing the route to 10.50.51.250

  1 5.8.193.118 4 msec 0 msec 4 msec

  2 192.168.255.6 4 msec 0 msec 0 msec

  3 10.50.51.250 4 msec 4 msec 4 msec

.................................

C2800#ping 10.50.51.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.50.51.1, timeout is 2 seconds:

UUUUU

Success rate is 0 percent (0/5)

..................................

C2800#ping 10.50.51.250

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.50.51.250, timeout is 2 seconds:

UUUUU

Success rate is 0 percent (0/5)

..................................

2).

На криптошлюзе настроено:

Офис 2 10.30.х1.0/24 - Офис 1 10.50.52.0/22

Офис 2 192.168.х1.0/24 - Офис 1 10.50.52.0/22

Офис 2 10.50.48.0/24 - Офис 1 10.50.52.0/22

Офис 2 192.168.х1.0/24 - Офис 1 10.30.3.0/24

Офис 2 почта- Офис 1 10.30.3.0/24

Офис 2 контроллер домена - Офис 1 10.30.3.0/24

TCP\UDP\ICMP разрешено

3). VACL есть только на Vlan для Wi-Fi?который никак не влияет на эту сеть

Раньше было все по-другому.Был тоннель между Cisco. И все работало

New Member

Caller can not hear the internal network IP telephony, and they

И еще. У меня телефон с блокоп питания(т.е. не надо Poe Cisco) и сответсвенно сеть другая-к примеру 10.30.8.56

Так вот,вчера я слышал 1 офис, а сегодня утром у трех сотрудников(у которых блоки питания) включая мой телефон 1 офис не слышали. Пока на криптошлюзе не разрешили этим сетяч лазить туда.

Caller can not hear the internal network IP telephony, and they

По трассировкам видно, что криптошлюз не знает что делать с пакетом до 10.50.51.1. Однако, с 10.50.51.250 таких вопросов нет. В вашем списке я не увидел правил, разрешающих 10.50.51.250. Почему он на самом деле доступен - загадка.

Но в любом случае вижу проблему.

"Офис 2 10.50.48.0/24 - Офис 1 10.50.52.0/22"

Почему первая маска - /24, когда должно быть тоже /22?

И предположу, что смотреть на криптошлюзе надо в двух местах - в таблице маршрутизации и в настройках crypto самого туннеля.

New Member

Caller can not hear the internal network IP telephony, and they

Сори, опечатался.там так написано:

"Офис 2 10.50.48.0/22 - Офис 1 10.50.52.0/22"

На счет криптошлюза действительно считаю что в нем проблемма.Но, непостредственно человек который с ним работает-утверждает, что там все настроено.

Re: Caller can not hear the internal network IP telephony, and t

Выше фактура - две трассировки на хосты одной сети с одного адреса.

C2800# traceroute 10.50.51.1 source fa0/0.50

Type escape sequence to abort.

Tracing the route to 10.50.51.1

  1 5.8.193.118 0 msec 4 msec 4 msec

  2 5.8.193.118 !H  !H  !H

...............

C2800#traceroute 10.50.51.250 source fa0/0.50

Type escape sequence to abort.

Tracing the route to 10.50.51.250

  1 5.8.193.118 4 msec 0 msec 4 msec

  2 192.168.255.6 4 msec 0 msec 0 msec

  3 10.50.51.250 4 msec 4 msec 4 msec

На одну возвращается ICMP host unreachable, другая доходит. Человеку, поддерживающему криптошлюз, нечем крыть - криптошлюз совершенно точно принимает и никуда не отправляет пакет, так что в ответ на "там все настроено" смело говорите "настроено плохо, ищи и исправляй проблему". Причины могут быть разные.

И еще. Если начнется футбол и проблему не удастся решить, можно немного переделать архитектуру: поднять GRE туннель между 2800 и 2911 и перенастроить маршруты на него. В этом случае с точки зрения криптошлюза весь трафик будет ходить только между двумя адресами, и проблем вроде этой появляться не должно.

Если решите поднять его - не забывайте про MTU.

New Member

Re: Caller can not hear the internal network IP telephony, and t

Проблема решилась!

На КШ был прописан Vlan 50-убрали его (кто его прописал осталось в истории),который мешал,четные он пропускал,а нечетные не давал ходу(почему так?) и получается нужен был только маршрут на КШ.Спасибо за помощь!

681
Просмотры
0
Полезный материал
27
Ответы