Cisco Support Community
отмена
Отображаются результаты для 
Вместо этого искать 
Вы имели в виду: 
cancel
Объявления
Добро пожаловать в Сообщество Технической поддержки Cisco. Мы рады получить обратную связь .

Caller can not hear the internal network IP telephony, and they

Вот они, типичные проблемы отсутствия динамической маршрутизации

Итак, проблема: пакеты из 1 офиса не доходят до 2 офиса (конкретнее - до сети 10.50.51.0). Насколько я понял, трафик между офисами проходит через этот 3560-й. На нем есть маршрут до 10.50.51.0?

И я не вижу устройства, на котором приземляется сеть 10.50.52.0.

Давайте так. С устройства в сети 10.50.52.0 сделайте traceroute 10.50.51.1. Если на каком-то устройстве трассировка прервется, то сделайте на нем "show ip cef 10.50.51.1 detail". Если трассировка покажет, что пакеты ходят кругами, и здесь нет конфига устройства, которое первым послало пакет не туда - дайте с него "show run | sec interface|ip route".

Если есть визуальная схема топологии между этими двумя локациями - было бы здорово увидеть ее.

Community Member

Caller can not hear the internal network IP telephony, and they

Кароче звонки проходят на четные номера.А на нечетные офис 2 не слышит, а 1 слышит.

И трасировка до не четных доходит только до интернета 2 офиса (криптошлюза и все)

а если пингуем четные то,норм доходит.

Community Member

Caller can not hear the internal network IP telephony, and they

офис 1

C2960#tracer 10.30.4.56

Type escape sequence to abort.

Tracing the route to 10.30.4.56

  1 10.30.3.240 0 msec 0 msec 9 msec

  2 5.8.193.118 0 msec 8 msec 0 msec

  3 192.168.255.6 17 msec 0 msec 0 msec

  4 10.30.4.56 9 msec 0 msec 8 msec

нормально

C2960#tracer 10.50.51.15

Type escape sequence to abort.

Tracing the route to 10.50.51.15

  1 10.30.3.240 9 msec 0 msec 0 msec

  2 5.8.193.118 8 msec 0 msec 9 msec

  3  *  *  *

  4  *  *  !H

вот такая ерунда. Т.е.доходит до внешнего IP 2 офиса

Community Member

Re: Caller can not hear the internal network IP telephony, and t

сам

Gateway Configuration

Community Member

Caller can not hear the internal network IP telephony, and they

вот конфига 2 офиса с2911(в которую раньше была вставлена по туннелю с2800 1 офиса)

C2911#show run

Building configuration...

Current configuration : 12023 bytes

!

! Last configuration change at *** Wed Nov 27 2013 by *****

! NVRAM config last updated at ***Tue Oct 8 2013 by ***

! NVRAM config last updated at 18 Tue Oct 8 2013 by ****

version 15.2

service timestamps debug datetime localtime

service timestamps log datetime localtime

service password-encryption

!

hostname C2911

!

boot-start-marker

boot system flash c2900-universalk9-mz.SPA.152-1.T.bin

boot-end-marker

!

!

logging buffered 51200 notifications

no logging console

enable secret ******

!

aaa new-model

!

!

aaa authentication login default local

!

!

!

!

!

aaa session-id common

clock timezone ***

clock calendar-valid

!

no ipv6 cef

!

!

!

ip dhcp excluded-address 10.50.51.201 10.50.51.254

ip dhcp excluded-address 10.50.51.54

!

ip dhcp pool Phones

network 10.50.48.0 255.255.252.0

default-router 10.50.51.251

option 150 ip 10.50.51.250

!

!

no ip domain lookup

ip domain name *****

ip name-server ****

ip cef

multilink bundle-name authenticated

!

!

!

!

!

crypto pki token default removal timeout 0

!

crypto pki trustpoint TP-self-signed-****

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-****

revocation-check none

rsakeypair TP-self-signed-35645599

!

!

crypto pki certificate chain TP-self-signed-35645599

certificate self-signed 01

  3082024C 308201B5 A0030201 02020101 300D0609 2A864886 F70D0101 04050030

  2F312D30 2B060355 04031324 494F532D 53656C66 2D536967 6E65642D 43657274

  69666963 6174652D 33353634 35353939 301E170D 31313031 31323034 30393537

  5A170D32 30303130 31303030 3030305A 302F312D 302B0603 55040313 24494F53

  2D53656C 662D5369 676E6564 2D436572 74696669 63617465 2D333536 34353539

  3930819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281 8100AE8F

  3C0056CF 260A252F 35CC7C50 BB1091CE 274300FA 00AD8E2F BCFEB6D7 2D426AD1

  F2B82A89 7EE78E95 5ECAB794 4AFE2673 4C266A20 3380FB59 DDD9C43C 5C7901DF

  9EAC453F BA1D5488 5F69B458 4CD86C14 69211CEF 39767DB0 2F055145 8BF4E30E

  1D5AF6B6 C056A932 0A5B380F C7F448FD E6D7B8DA 2296D972 59B63350 41870203

  010001A3 78307630 0F060355 1D130101 FF040530 030101FF 30230603 551D1104

  1C301A82 18633239 31312D49 53542E79 6F757264 6F6D6169 6E2E636F 6D301F06

  03551D23 04183016 801403AF E6AED8EB E694F218 7F71766C 0D28957E 3133301D

  0603551D 0E041604 1403AFE6 AED8EBE6 94F2187F 71766C0D 28957E31 33300D06

  092A8648 86F70D01 01040500 03818100 36992A07 4698A358 7736BD32 AB18E439

  B26AE525 FDC61BF7 E9408B79 06C593C3 C8CE368D 41983448 0F16038C AE331098

  F518D4D3 DF5ADDDD 2587323C 546D1245 E4508960 BC4F6E38 D85E79DF 051CFB59

  8D3860AA 03338761 4D43C0F6 3D8263F0 1050FE65 041D2B36 BE3FC737 BDE7D129

  78328EA7 8A3F97F2 0A3D2A54 3AC00F00

        quit

voice-card 0

dsp services dspfarm

!

!

voice rtp send-recv

!

voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none

h323

  emptycapability

sip

  subscription maximum accept 24

  registrar server expires max 600 min 60

  early-offer forced

!

voice class codec 1

codec preference 1 g711alaw

codec preference 2 g711ulaw

!

voice class h323 1

  h225 timeout tcp establish 3

  h225 timeout setup 2

!

!

!

!

voice translation-rule 1

rule 1 /^0\(.*\)/ /\1/

!

voice translation-rule 2

rule 1 /^*****/ /1*/

!

voice translation-rule 3

rule 1 // /******/

!

voice translation-rule 4

rule 1 /^1\(.*\)/ /\1/

!

voice translation-rule 5

rule 1 /1*/ /*****/

!

!

voice translation-profile FAX

translate called 3

!

voice translation-profile TTK_IN_FAX

translate called 2

!

voice translation-profile TTK_OUT

translate calling 5

translate called 4

!

voice translation-profile to_*****

translate called 1

!

!

!

fax receive called-subscriber $d$

fax interface-type fax-mail

mta send server 192.168.0.147 port 25

mta send subject "FAX"

mta send origin-prefix "Cisco-powered Fax System"

mta send postmaster *********

mta send mail-from hostname cisco2911

mta send mail-from username ***

license udi pid ********* sn ******

license accept end user agreement

hw-module ism 0

!

hw-module pvdm 0/0

!

!

!

username ********** privilege 15 secret ******

!

redundancy

!

!

!

!

!

!

interface Tunnel0

no ip address

shutdown

!

interface Embedded-Service-Engine0/0

no ip address

shutdown

!

interface GigabitEthernet0/0

description ### LAN ###

no ip address

duplex auto

speed auto

!

interface GigabitEthernet0/0.50

description ### Voice CUCM ###

encapsulation dot1Q 50

ip address 10.50.51.251 255.255.252.0

h323-gateway voip interface

h323-gateway voip bind srcaddr 10.50.51.251

!

interface GigabitEthernet0/0.325

description ###_Data_LAN###

encapsulation dot1Q 325

ip address 192.168.0.245 255.255.255.0

ip nat outside

ip virtual-reassembly in

!

interface ISM0/0

ip address 192.168.250.250 255.255.255.0

ip nat inside

ip virtual-reassembly in

service-module ip address 192.168.250.251 255.255.255.0

!Application: CUE Running on ISM

service-module ip default-gateway 192.168.250.250

!

interface GigabitEthernet0/1

description ###_telephony_TTK_###

ip address ------------***

duplex auto

speed auto

!

interface GigabitEthernet0/2

description ### старая сеть(не действует) ###

no ip address

duplex auto

speed auto

!

interface ISM0/1

description Internal switch interface connected to Internal Service Module

no ip address

shutdown

!

interface Vlan1

no ip address

!

ip forward-protocol nd

!

ip http server

ip http authentication local

ip http secure-server

!

ip nat inside source list 1 interface GigabitEthernet0/0.325 overload

ip route 0.0.0.0 0.0.0.0 192.168.0.240

ip route 10.30.10.0 255.255.255.0 192.168.255.6

ip route 10.30.10.0 255.255.255.0 10.50.51.250

ip route ttk*********** ***********

ip route 192.168.0.0 255.255.255.0 192.168.0.240

ip route 192.168.250.251 255.255.255.255 ISM0/0

!

access-list 1 permit 192.168.250.0 0.0.0.255

access-list 23 permit 192.168.0.0 0.0.0.255

!

!

snmp-server community *******

snmp-server enable traps snmp authentication

snmp-server enable traps entity-sensor threshold

snmp-server enable traps config

snmp-server host **********

!

!

!

control-plane

!

!

voice-port 0/0/0

cptone RU

caller-id enable

!

voice-port 0/0/1

cptone RU

caller-id enable

!

voice-port 0/0/2

cptone RU

caller-id enable

!

voice-port 0/0/3

cptone RU

caller-id enable

!

voice-port 0/1/0

translation-profile incoming FAX

disc_pi_off

cptone RU

connection plar *******

caller-id enable

!

voice-port 0/1/1

!

voice-port 0/1/2

!

voice-port 0/1/3

!

!

!

mgcp profile default

!

sccp local GigabitEthernet0/0.50

sccp ccm 10.50.51.250 identifier 1 version 4.1

sccp

!

sccp ccm group 1

associate ccm 1 priority 1

associate profile 1 register mytranscoder

keepalive retries 5

switchover method immediate

switchback method immediate

switchback interval 15

!

dspfarm profile 1 transcode universal

codec g711alaw

codec g711ulaw

maximum sessions 8

associate application SCCP

!

dial-peer voice 100 voip

description ### TTK Outgoing ###

translation-profile outgoing TTK_OUT

destination-pattern 9T

rtp payload-type cisco-codec-fax-ack 126

session protocol sipv2

session target ipv4:*********

dtmf-relay rtp-nte

codec g711alaw

fax-relay sg3-to-g3

fax protocol pass-through g711alaw

no vad

!

dial-peer voice 101 voip

description ### TTK Incoming ###

session protocol sipv2

session target ipv4:*****

incoming called-number 11[1,2,34,5,6,66,]

dtmf-relay sip-notify

codec g711alaw

!

dial-peer voice 195 pots

description ### Loop to FXO 0/1/0 ###

destination-pattern 195

port 0/0/0

forward-digits all

!

dial-peer voice 196 pots

destination-pattern 196

port 0/0/1

!

dial-peer voice 197 pots

destination-pattern 197

port 0/0/2

!

dial-peer voice 198 pots

destination-pattern 198

port 0/0/3

!

dial-peer voice 102 voip

description ### TTK Incoming FAX ###

translation-profile incoming TTK_IN_FAX

session protocol sipv2

incoming called-number *******

dtmf-relay rtp-nte

codec g711alaw

fax-relay sg3-to-g3

fax protocol pass-through g711ulaw

!

dial-peer voice 2000 voip

description ## CUE VoiceMail ##

destination-pattern 707

b2bua

session protocol sipv2

session target ipv4:192.168.250.251

voice-class sip outbound-proxy ipv4:192.168.250.251

dtmf-relay sip-notify

codec g711ulaw

no vad

!

dial-peer voice 2010 voip

description ## CUE AutoAttendant ##

destination-pattern 700

b2bua

session protocol sipv2

session target ipv4:192.168.250.251

voice-class sip outbound-proxy ipv4:192.168.250.251

dtmf-relay sip-notify

codec g711ulaw

no vad

!

dial-peer voice 194 pots

description ### Inbound from FXS 0/0/0 ###

service onramp

shutdown

information-type fax

direct-inward-dial

port 0/1/0

forward-digits all

!

dial-peer voice 2200 mmoip

service fax_on_vfc_onramp_app out-bound

shutdown

destination-pattern ******

information-type fax

session target mailto:*******

image encoding MH

image resolution fine

!

dial-peer voice 200 voip

description ## to_CUCM ##

destination-pattern 12[1,2,3,4,56,]

session target ipv4:10.50.51.250

voice-class h323 1

dtmf-relay h245-alphanumeric

codec g711alaw

!

dial-peer voice 201 voip

description ## from_CUCM_to_City ##

incoming called-number 9T

voice-class h323 1

dtmf-relay h245-alphanumeric

codec g711alaw

no vad

!

dial-peer voice 202 voip

description ## to_CUCM_**** ##

destination-pattern ****

session target ipv4:10.50.51.250

voice-class h323 1

dtmf-relay h245-alphanumeric

codec g711alaw

!

dial-peer voice 103 voip

description ###_TTK_Inbound_***_###

session protocol sipv2

incoming called-number ****

dtmf-relay sip-notify

codec g711alaw

!

dial-peer voice 120 voip

description ###_Inbound_from_CUCM_###

incoming called-number 0...

voice-class h323 1

dtmf-relay h245-alphanumeric

codec g711alaw

no vad

!

dial-peer voice 121 voip

description ###_Outbound_to_1_###

translation-profile outgoing to_1

destination-pattern 0...

session protocol sipv2

session target ipv4:10.50.0.10

dtmf-relay rtp-nte sip-kpml

codec g711alaw

!

dial-peer voice 122 voip

description ###_to_Internal_CUCM_###

destination-pattern [1-3]...

session target ipv4:10.50.51.250

voice-class h323 1

dtmf-relay h245-alphanumeric

codec g711alaw

no vad

!

dial-peer voice 123 voip

description ###_I1_###

session protocol sipv2

incoming called-number [1-3]...

dtmf-relay rtp-nte sip-kpml

codec g711alaw

!

!

!

!

gatekeeper

shutdown

!

!

credentials

!

!

telephony-service

sdspfarm units 1

sdspfarm transcode sessions 10

sdspfarm tag 1 mytranscoder

max-ephones 58

max-dn 300

ip source-address 10.50.51.251 port 2000

cnf-file perphone

time-zone 51

time-format 24

date-format dd-mm-yy

max-conferences 8 gain -6

call-forward pattern .T

call-forward system redirecting-expanded

moh "summertime.au"

web admin system name ******** password ******

dn-webedit

time-webedit

transfer-system full-consult

transfer-pattern .T

after-hours date Jan 8 00:01 23:59

night-service day Sun 00:01 23:59

night-service day Sat 00:01 23:59

night-service date Jan 8 00:01 23:59

create cnf-files version-stamp Jan 01 2002 00:00:00

shutdown

!

!

banner login ^CWelcome to C2911^C

!

line con 0

line aux 0

line 2

no activation-character

no exec

transport preferred none

transport input all

transport output pad telnet rlogin lapb-ta mop udptn v120 ssh

stopbits 1

line 131

no activation-character

no exec

transport preferred none

transport input all

transport output pad telnet rlogin lapb-ta mop udptn v120 ssh

stopbits 1

line vty 0 4

exec-timeout 40 0

privilege level 15

transport input telnet ssh

line vty 5 15

access-class 23 in

privilege level 15

transport input telnet ssh

!

scheduler allocate 20000 1000

ntp logging

ntp authenticate

ntp server 10.50.51.250

end

Community Member

Caller can not hear the internal network IP telephony, and they

Re: Caller can not hear the internal network IP telephony, and t

(слишком много данных сверху, посты теряются, так что переношу диалог сюда, а длинные данные можно продолжать выкладывать сверху)

"Кароче звонки проходят на четные номера.А на нечетные офис 2 не слышит, а 1 слышит.

И трасировка до не четных доходит только до интернета 2 офиса (криптошлюза и все)

а если пингуем четные то,норм доходит."

Четные номера телефона? Не вижу причин, по которым это должно быть существенно. Но назовите два IP адреса из офиса 2, из которых один слышит офис 1, а другой - нет.

И еще следующее.

1) C2800# traceroute 10.50.51.1 source fa0/0.50

traceroute 10.50.51.250 source fa0/0.50

С2800#ping

Protocol [ip]:

Target IP address: 10.50.51.1

Repeat count [5]:

Datagram size [100]:

Timeout in seconds [2]:

Extended commands [n]: y

Source address or interface: fa0/0.50

Type of service [0]: 184

2800#ping 10.50.51.1 so fa0/0.50

2) Опишите конфигурацию криптошлюза касательно того, между какими сетями маршрутизировать через туннель.

3) На свитчах 3560 и 2960 есть какие-нибудь VACLы и так далее? Вообще - где что может фильроваться?

Community Member

Re: Caller can not hear the internal network IP telephony, and t

Отключая DHCP на телефонах вручную и вбивая четный IP телефоны работают=)

1).C2800# traceroute 10.50.51.1 source fa0/0.50

Type escape sequence to abort.

Tracing the route to 10.50.51.1

  1 5.8.193.118 0 msec 4 msec 4 msec

  2 5.8.193.118 !H  !H  !H

...............

C2800#traceroute 10.50.51.250 source fa0/0.50

Type escape sequence to abort.

Tracing the route to 10.50.51.250

  1 5.8.193.118 4 msec 0 msec 4 msec

  2 192.168.255.6 4 msec 0 msec 0 msec

  3 10.50.51.250 4 msec 4 msec 4 msec

.................................

C2800#ping 10.50.51.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.50.51.1, timeout is 2 seconds:

UUUUU

Success rate is 0 percent (0/5)

..................................

C2800#ping 10.50.51.250

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.50.51.250, timeout is 2 seconds:

UUUUU

Success rate is 0 percent (0/5)

..................................

2).

На криптошлюзе настроено:

Офис 2 10.30.х1.0/24 - Офис 1 10.50.52.0/22

Офис 2 192.168.х1.0/24 - Офис 1 10.50.52.0/22

Офис 2 10.50.48.0/24 - Офис 1 10.50.52.0/22

Офис 2 192.168.х1.0/24 - Офис 1 10.30.3.0/24

Офис 2 почта- Офис 1 10.30.3.0/24

Офис 2 контроллер домена - Офис 1 10.30.3.0/24

TCP\UDP\ICMP разрешено

3). VACL есть только на Vlan для Wi-Fi?который никак не влияет на эту сеть

Раньше было все по-другому.Был тоннель между Cisco. И все работало

Community Member

Caller can not hear the internal network IP telephony, and they

И еще. У меня телефон с блокоп питания(т.е. не надо Poe Cisco) и сответсвенно сеть другая-к примеру 10.30.8.56

Так вот,вчера я слышал 1 офис, а сегодня утром у трех сотрудников(у которых блоки питания) включая мой телефон 1 офис не слышали. Пока на криптошлюзе не разрешили этим сетяч лазить туда.

Highlighted

Caller can not hear the internal network IP telephony, and they

По трассировкам видно, что криптошлюз не знает что делать с пакетом до 10.50.51.1. Однако, с 10.50.51.250 таких вопросов нет. В вашем списке я не увидел правил, разрешающих 10.50.51.250. Почему он на самом деле доступен - загадка.

Но в любом случае вижу проблему.

"Офис 2 10.50.48.0/24 - Офис 1 10.50.52.0/22"

Почему первая маска - /24, когда должно быть тоже /22?

И предположу, что смотреть на криптошлюзе надо в двух местах - в таблице маршрутизации и в настройках crypto самого туннеля.

Community Member

Caller can not hear the internal network IP telephony, and they

Сори, опечатался.там так написано:

"Офис 2 10.50.48.0/22 - Офис 1 10.50.52.0/22"

На счет криптошлюза действительно считаю что в нем проблемма.Но, непостредственно человек который с ним работает-утверждает, что там все настроено.

Re: Caller can not hear the internal network IP telephony, and t

Выше фактура - две трассировки на хосты одной сети с одного адреса.

C2800# traceroute 10.50.51.1 source fa0/0.50

Type escape sequence to abort.

Tracing the route to 10.50.51.1

  1 5.8.193.118 0 msec 4 msec 4 msec

  2 5.8.193.118 !H  !H  !H

...............

C2800#traceroute 10.50.51.250 source fa0/0.50

Type escape sequence to abort.

Tracing the route to 10.50.51.250

  1 5.8.193.118 4 msec 0 msec 4 msec

  2 192.168.255.6 4 msec 0 msec 0 msec

  3 10.50.51.250 4 msec 4 msec 4 msec

На одну возвращается ICMP host unreachable, другая доходит. Человеку, поддерживающему криптошлюз, нечем крыть - криптошлюз совершенно точно принимает и никуда не отправляет пакет, так что в ответ на "там все настроено" смело говорите "настроено плохо, ищи и исправляй проблему". Причины могут быть разные.

И еще. Если начнется футбол и проблему не удастся решить, можно немного переделать архитектуру: поднять GRE туннель между 2800 и 2911 и перенастроить маршруты на него. В этом случае с точки зрения криптошлюза весь трафик будет ходить только между двумя адресами, и проблем вроде этой появляться не должно.

Если решите поднять его - не забывайте про MTU.

Community Member

Re: Caller can not hear the internal network IP telephony, and t

Проблема решилась!

На КШ был прописан Vlan 50-убрали его (кто его прописал осталось в истории),который мешал,четные он пропускал,а нечетные не давал ходу(почему так?) и получается нужен был только маршрут на КШ.Спасибо за помощь!

727
Просмотры
0
Полезный материал
27
Ответы
СоздатьДля создания публикации, пожалуйста в систему