Cisco Support Community
отмена
Отображаются результаты для 
Вместо этого искать 
Вы имели в виду: 
Объявления
Добро пожаловать в Сообщество Технической поддержки Cisco. Мы рады получить обратную связь .
New Member

CME&SIP+remote CME

Уважаемые эксперты, прошу помощи,

Имеется Cisco 2911 с приходящим SIP

HQrouter#sh run

!

!

!

voice service voip

no ip address trusted authenticate

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

no supplementary-service sip moved-temporarily

no supplementary-service sip refer

no supplementary-service sip handle-replaces

modem passthrough protocol codec g711alaw maximum-sessions 3

sip

  bind control source-interface GigabitEthernet0/2

  bind media source-interface GigabitEthernet0/2

  registrar server expires max 3600 min 3600

!

voice class codec 1

codec preference 1 g711alaw

!

!

dial-peer voice 1 voip

description **Incoming Call from SIP Trunk**

translation-profile incoming SIP_Incoming

session protocol sipv2

incoming called-number 0T

voice-class codec 1 

voice-class sip early-offer forced

voice-class sip bind media source-interface GigabitEthernet0/2

dtmf-relay rtp-nte

no vad  

!

dial-peer voice 2 voip

description OUTGOING

translation-profile outgoing SIP_Outgoing

destination-pattern 0T

session protocol sipv2

session target ipv4:112.12.123.2

voice-class codec 1 

voice-class sip early-offer forced

voice-class sip bind media source-interface GigabitEthernet0/2

dtmf-relay rtp-nte

no vad

!

dial-peer voice 4070 voip

description To remote CME

destination-pattern 407.

session target ipv4:10.22.20.2

voice-class codec 1

dtmf-relay h245-alphanumeric

ip qos dscp cs3 media

no vad

!

sip-ua

!

!

!

И удаленный CME, находящийся в той же сети:

remoteCME#sh run

!

!

voice service voip

no ip address trusted authenticate

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

no supplementary-service sip moved-temporarily

no supplementary-service sip refer

no supplementary-service sip handle-replaces

fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none

sip

!

voice class codec 1

codec preference 1 g711alaw

!

dial-peer voice 202 voip

description OUT_TO_CCM_HO

destination-pattern 00.........

session target ipv4:10.53.30.1

voice-class codec 1 

voice-class sip early-offer forced

dtmf-relay rtp-nte

ip qos dscp cs3 media

no vad

!

!

dial-peer voice 202 voip

description OUT_TO_CCM_HO

destination-pattern 0T

session target ipv4:10.22.20.1

voice-class codec 1 

voice-class sip early-offer forced

dtmf-relay h245-alphanumeric

ip qos dscp cs3 media

no vad

!

!

sip-ua

!

!

Проблема в следующем -

При звонке из удаленного CME на внешний номер - связь односторонняя, вызываемый всё слышит, вызывающий не слышит ничего.

При звонке извне на номер удаленного CME - все друг друга слышат отлично.

Сломал голову куда копать, все кодеки перебрал, dmtf менял везде, по моим представлениям и второй звонок извне-тоже не должен работать, но он работает...

Помогите, пожалуйста, наверняка решение какое-то очевидное...

заранее спасибо.

10 ОТВЕТ.
New Member

CME&SIP+remote CME

Некоторые уточнения:

конфиг второго CME:

remoteCME#sh run

!

!

voice service voip

no ip address trusted authenticate

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

no supplementary-service sip moved-temporarily

no supplementary-service sip refer

no supplementary-service sip handle-replaces

fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none

sip

!

voice class codec 1

codec preference 1 g711alaw

!

!

dial-peer voice 202 voip

description OUT_TO_CCM_HO

destination-pattern 0T

session target ipv4:10.22.20.1

voice-class codec 1

voice-class sip early-offer forced

dtmf-relay h245-alphanumeric

ip qos dscp cs3 media

no vad

!

!

sip-ua

!

!

Проблема в следующем -

При звонке из удаленного CME на внешний номер - связь односторонняя, вызываемый всё слышит, вызывающий не слышит ничего.

При наборе внешнего мобильного номера - мобильный показывает что звонок идёт, но в звонящей трубке ничего не меняется. После снятия трубки на мобильном - на звонящей трубке появляется счётчик что звонок пошёл. после отбоя на мобильном телефоне - в трубке которкие гудки "busy".

При звонке извне на номер удаленного CME - все друг друга слышат отлично.

Сломал голову куда копать, все кодеки перебрал, dmtf менял везде, по моим представлениям и второй звонок извне-тоже не должен работать, но он работает...

Помогите, пожалуйста, наверняка решение какое-то очевидное...

заранее спасибо.

CME&SIP+remote CME

Добрый день!

1) А CME на каком железе\софте поднят ?

2) Вы не приводите конфиг интерфейсов этих роутеров.

Проблемы подобные вашим иногда возникают, если не сделан однозначный bind для h323.

Делается на интерфейсе командой :

h323-gateway voip bind       srcaddr ip-address

3) Возможно у вас по каким-то причинам проблемы с прохождением команды "Connect", можно попробовать обходное решение, указать в глобальном конфиге

voice rtp send-recv

4) Если не помогает, то значит проблема кроется в чём-то чего вы не упоминаете, например фаервол на пути прохождения RTP-трафика, рекомендую ознакомиться:  Troubleshooting One Way Voice Issues

New Member

CME&SIP+remote CME

Интерфейсы на потоковой CIsco

interface GigabitEthernet0/0

description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$

ip address 172.17.1.54 255.255.255.252

duplex auto

speed auto

!

interface GigabitEthernet0/1

description === LAN ===

no ip address

duplex auto

speed auto

!

interface GigabitEthernet0/1.1

encapsulation dot1Q 1 native

ip address 10.53.30.1 255.255.255.224

h323-gateway voip interface

h323-gateway voip bind srcaddr 10.53.30.1

!

interface GigabitEthernet0/1.5

encapsulation dot1Q 5

ip address 10.10.77.1 255.255.255.0

!

interface GigabitEthernet0/2

ip address 172.20.254.70 255.255.255.252

ip access-group IN_1 in

no ip unreachables

no ip proxy-arp

ip flow ingress

ip flow egress

ip nat outside

ip virtual-reassembly in

duplex auto

speed auto

На удаленном CME:

interface GigabitEthernet0/0

ip address 172.17.1.58 255.255.255.252

duplex auto

speed auto

service-policy output OUT-1024

!

interface GigabitEthernet0/1

no ip address

duplex auto

speed auto

!

interface GigabitEthernet0/1.1

description DATA

encapsulation dot1Q 1 native

ip address 10.53.30.65 255.255.255.192

h323-gateway voip interface

h323-gateway voip bind srcaddr 10.53.30.65

!

interface GigabitEthernet0/1.5

description VOICE

encapsulation dot1Q 5

ip address 10.222.222.1 255.255.255.0


New Member

Re: CME&SIP+remote CME

Александр,

В Dial-Peer на удалённом CME вы указываете на некоторый IP-адрес: 10.22.20.1

dial-peer voice 202 voip

description OUT_TO_CCM_HO

destination-pattern 0T

session target ipv4:10.22.20.1

voice-class codec 1

voice-class sip early-offer forced

dtmf-relay h245-alphanumeric

ip qos dscp cs3 media

no vad

А на потоковой Cisco протокол H323 настроен на интерфейсе с IP 10.53.30.1:

interface GigabitEthernet0/1.1

encapsulation dot1Q 1 native

ip address 10.53.30.1 255.255.255.224

h323-gateway voip interface

h323-gateway voip bind srcaddr 10.53.30.1

Попробуйте на удалённом CME всё-таки прописать правильный IP:

dial-peer voice 202 voip

session target ipv4:10.53.30.1

Также на Cisco с внешним транком желательно сделать корректный входящий Dial-peer для H323-звонков с удалённого CME по аналогии с

Dial-peer voice 1 voip.

New Member

CME&SIP+remote CME

Указал корректный IP - безрезультатно.

dial-peer написал такой:

dial-peer voice 3 voip

description **Incoming Call from BTQ**

session target ipv4:10.53.30.65

incoming called-number 0T

voice-class codec 1 

voice-class sip early-offer forced

voice-class sip bind media source-interface GigabitEthernet0/2

dtmf-relay rtp-nte

no vad

безрезультатно.

фаерволлов и прочих ограничивающих штук - не настроено..

New Member

CME&SIP+remote CME

Как вариант, RTP может блокировать ACL IN_1, который применён на G0/2. На какой внешний номер Вы звоните ?

Я правильно понимаю, что звонок потом уходит на SIP Proxy провайдера 112.12.123.2 ?

Если да, то на G0/2 прописан внутренний IP-адрес, каким образом он транслируется во внешний ? Устройство, на котором настроен NAT, поддерживает инспекцию SIP-трафика ? Ведь в таком случае потребуется в заголовках SDP менять внутренний IP-адрес на внешний, иначе внешняя сторона не сможет слать RTP-трафик.

New Member

Re: CME&SIP+remote CME

Звоню на мобильный номер. Набираю как  0050XXXXXXX

Интерфейсы на потоковой CIsco

interface GigabitEthernet0/0

description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$

ip address 172.17.1.54 255.255.255.252

duplex auto

speed auto

!

interface GigabitEthernet0/1

description === LAN ===

no ip address

duplex auto

speed auto

!

interface GigabitEthernet0/1.1

encapsulation dot1Q 1 native

ip address 10.53.30.1 255.255.255.224

h323-gateway voip interface

h323-gateway voip bind srcaddr 10.53.30.1

!

interface GigabitEthernet0/1.5

encapsulation dot1Q 5

ip address 10.10.77.1 255.255.255.0

!

interface GigabitEthernet0/2

ip address 172.20.254.70 255.255.255.252

ip access-group IN_1 in

no ip unreachables

no ip proxy-arp

ip flow ingress

ip flow egress

ip nat outside

ip virtual-reassembly in

duplex auto

speed auto

ip access-list extended IN_1

permit ip host 10.53.30.1 any /внутренний адрес циски

permit ip host 172.20.254.70 any

permit ip host 172.20.252.2 any

permit udp any any

permit tcp any any

Устройство, на котором настроен NAT, поддерживает инспекцию SIP-трафика ? Ведь в таком случае потребуется в заголовках SDP менять внутренний IP-адрес на внешний, иначе внешняя сторона не сможет слать RTP-трафик. - по разговорам с провайдером - от меня к нему приходит голос, и от него в ответ уходит голос ко мне "на тот же адрес с которого приходит"(с). есть лог звонка присланный провайдером и снятый на его оборудовании, но он в формате pcap, не знаю как его анализировать и как выложить сюда ...


New Member

CME&SIP+remote CME

От Вас к провайдеру голос в любом случае будет ходить, даже через NAT. А вот обратно - могут быть проблемы.

Если на Вашем роутере - внутренние IP-адреса, а dial-peer указывает на внешний IP, значит где-то между Вами и провайдером должно быть устройство с настроенной NAT-трансляцией IP-адресов.

Файлы *.pcap можно открыть с помощью WireShark - http://www.wireshark.org/download.html

New Member

Re: CME&SIP+remote CME

по логам от провайдера звонок приходит к нему с адреса 172.20.254.70 и отправляется на адрес 172.20.254.70.

New Member

Re: CME&SIP+remote CME

Если используете NAT, то настройки такие

ip nat portmap sip

cisco-rtp-sip-high

cisco-rtp-sip-low

no ip nat service allow-sip-even-rtp-port

977
Просмотры
5
Полезный материал
10
Ответы
СоздатьДля создания публикации, пожалуйста в систему