отмена
Отображаются результаты для 
Вместо этого искать 
Вы имели в виду: 
Объявления
Добро пожаловать в Сообщество Технической поддержки Cisco. Мы рады получить обратную связь .
New Member

QoS голоса

Добрый день!

Есть такая задача: нужно настроить шйпинг на канале. Канал 10 мб, зарезервировать для телефонии 5 мб, остальное общий интернет.

С шейпингом никогда дел не имел, прошу совета.

Как я понял для резервирования пропускной полосы используется Class-Based Weighted Fair Queuing (CBWFQ):

class-map.......

policy-map......

service-policy......

 

Если использовать Class-Based Weighted Fair Queuing для конкретной внутренней подсети, service-policy применять на интерфейсе, на маршрутизаторе во внешку или на внутреннем интерфейсе?

 

Если у меня такая вот конфигурация:

 

ip access-list extended acl_voip
permit ip 172.30.91.0 0.0.0.127 any

class-map voip
match access-group name acl_voip

policy-map shaper
class voip
bandwidth 5000
class-default
fair-queue

int Gi0/1

description outside

ip nat outside
service-policy output shaper

 

То ведь сначала будет происходить трансляция, а потом сравнения policy? А в acl_voip у меня внутренняя подсеть.

 

Спасибо.

  • Другие темы (Other Topics)
2 ОТВЕТ.
New Member

Покопался в соседних темах.

Покопался в соседних темах. Стало более менее понятно. Единственное не понимаю, что нужно указывать в ACL для резервирования траффика для телефонии.

 

ip access-list extended acl_voice
 permit udp any any eq 5060

class-map match-all voip
match access-group acl_voice
!

policy-map PARENT_QOS
class class-default
shape average 10000000
service-policy Voice
!
policy-map Voice
class voip
bandwidth 5000
class class-default
fair-queue
!
interface Gi0/1
service-policy output Voice

Вариантов несколько.1) Если

Вариантов несколько.

1) Если маркировку пакетов нигде не сбиваете, то match ip dscp ef.

2) Если ресурсов много и трафик SIP (а не только RTP) проходит через роутер, то можно match protocol rtp.

3) В конце концов, можно просто взять и сделать по ACL, в котором диапазон портов. Чтобы с гарантией - это от 4000 и выше. Но туда может много чего лишнего попасть.

 

Предлагаю сделать так: идете по пунктам. Сделали match ip dscp ef, звоните и смотрите в реальном времени, начал ли быстрыми темпами расти класс voip в show policy-map int gi0/1.

 

Вы указываете в ACL порт 5060 - это лишь сигнализация, пара в момент установления соединения, это не сам голос.

 

Ну и для голоса традиционно принято использовать приоритетную очередь (priority 5000). Иначе при заполнении очередей задержка начнет дергаться в припадке туда-сюда, а голосу это не нравится.

69
Просмотры
0
Полезный материал
2
Ответы