отмена
Отображаются результаты для 
Вместо этого искать 
Вы имели в виду: 

Сравнение команд базовой настройки OSPF для IOS и IOS XR

Cisco Employee

Довольно долго компания Cisco использовала IOS в качестве основной операционной системы для всей линейки маршрутизаторов с практически одинаковым набором команд для всех выпускаемых моделей. Что с одной стороны было удобно, так как позволяло настроить и Cisco 2600 серии и Cisco 7600 серии с помощью одних и тех же команд, но с другой стороны синтаксис был не всегда удобен.

Например, чтобы сконфигурировать протокол маршрутизации OSPF в IOS надо было в режиме конфигурации протокола OSPF с помощью команды network указать IP адреса интерфейсов на которых будет запущен OSPF и в какой области он будет располагаться.

При настройке внутреннего маршрутизатора, у которого все интерфейсы смотрят в одну область можно было задать общий формат, который запускал OSPF на всех интерфейсах:

interface loopback 0

  ip address 192.168.1.1 255.255.255.255

interface Ethernet 0/0

  ip address 10.10.10.10 255.255.255.0

interface Ethernet 0/1

  ip address 10.10.20.20 255.255.255.0

  ip ospf network point-to-point

router ospf 100

  router-id 192.168.1.1

  network 0.0.0.0 255.255.255.255 area 1

Удобно, но опасность заключалась в том, что при появлении нового интерфейса на нем также автоматически запускался OSPF и эта сеть начинала автоматически анонсироваться соседям без дополнительного конфигурирования OSPF. Чаще всего используется другая схема конфигурирования (особенно при настройке граничных маршрутизаторов – ABR) при которой явно указаны IP адреса тех интерфейсов, где должен быть запущен OSPF:

interface loopback 0

ip address 192.168.1.1 255.255.255.255

interface Ethernet 0/0

  ip address 10.10.10.10 255.255.255.0

interface Ethernet 0/1

  ip address 10.10.20.20 255.255.255.0

router ospf 100

  router-id 192.168.1.1

  network 192.168.1.1 0.0.0.0 area 1

  network 10.10.10.10 0.0.0.0 area 1

  network 10.10.20.20 0.0.0.0 area 1

В такой записи у нас не будет запускаться OSPF на каких-либо интерфейсах, пока мы явно этого не укажем.

В IOS мы можем также использовать другой способ конфигурирования OSPF, путем задания команды ip ospf <id> area <area-id> на самих интерфейсах

interface loopback 0

  ip address 192.168.1.1 255.255.255.255

  ip ospf 100 area 1

interface Ethernet 0/0

  ip address 10.10.10.10 255.255.255.0

  ip ospf 100 area 1

interface Ethernet 0/1

  ip address 10.10.20.20 255.255.255.0

  ip ospf 100 area 1

  ip ospf network point-to-point

router ospf 100

  router-id 192.168.1.1

Все указанные выше примеры позволяют добиться идентичного результата. Неудобство заключается в том, что конфигурационный файл при такой настройке OSPF является довольно трудно читаемым, если нам нужно проанализировать на каких интерфейсах запущен OSPF и в каких областях находятся интерфейсы. Особенно усложняется задача анализа при просмотре конфигурационных файлов устройств с большим количеством интерфейсов уровня L3, например маршрутизаторов операторского класса.

В операционной системе IOS XR, которая сейчас используется на CRS-1, CRS-3, Cisco 12000 (GSR), ASR9000 используется модульная схема конфигурирования, позволяющая в одном разделе конфигурационного файла увидеть все параметры настройки протокола маршрутизации OSPF:

router ospf 100

router-id 192.168.1.1

  area 1

  interface Loopback0

  !

  interface GigabitEthernet0/0/0/0

  !

  interface GigabitEthernet0/0/0/1

   network point-to-point

Как мы видим в IOS XR гораздо удобнее и логичнее организован конфигурационный файл, позволяющий проанализировать секцию router ospf, чтобы понять как OSPF сконфигурирован на устройстве, а не просматривать настройки всех интерфейсов, чтобы получить ту же самую информацию.

678
Просмотры
0
Полезный материал
0
Комментарии