отмена
Отображаются результаты для 
Вместо этого искать 
Вы имели в виду: 

Настройка редистрибуции Internal BGP маршрутов в OSPF

 

Введение

 

Этот документ рассказывает как произвести редистрибуцию IBGP маршрутов в OSPF. По умолчанию редистрибуция из IBGP в IGP отключена. Чтобы ее включить выполните команду bgp redistribute-internal” в режиме конфигурации BGP на маршрутизаторе.

 

В сценарии, показанном в данном документе, на маршрутизаторах R1 и R2 запущен BGP. Также на маршрутизаторах R2 и R3 запущен OSPF и оба маршрутизатора принадлежат к OSPF Area 0. R1 объявляет два маршрута (1.1.1.1 /32 и 172.16.0.0 /16). R2 делает редистрибуцию из BGP в OSPF Area 0. Редистрибутиться только маршрут 172.16.0.0 /16. Это достигается использованием prefix-листов и route-map.

 

Следующий prefix-list B2O настроен на R2

 

              ip prefix-list B2O seq 5 permit 172.16.0.0/16

 

Следующий route-map BGP-To_OSPF настроен на R2

 

            route-map BGP-To_OSPF permit 10

              match ip address prefix-list B2O

 

Преквезиты

 

  • понимание проктолов маршрутизации – BGP и OSPF

 

Топология

 

Topology_Diag.GIF

Настройка

 

 

Router R1

interface Loopback0

ip address 1.1.1.1 255.255.255.255

!

interface Loopback1

ip address 172.16.1.1 255.255.0.0

!

interface Serial1/0

ip address 192.12.12.1 255.255.255.0

serial restart-delay 0

!

router bgp 100

no synchronization

bgp router-id 1.1.1.1

bgp log-neighbor-changes

network 1.1.1.1 mask 255.255.255.255

network 172.16.0.0

neighbor 192.12.12.2 remote-as 100

no auto-summary

 

!

 

 

Router R2

interface Loopback0

  ip address 2.2.2.2 255.255.255.255

  !

interface Serial1/0

  ip address 192.12.12.2 255.255.255.0

  serial restart-delay 0

  !

interface FastEthernet2/0

  ip address 192.23.23.2 255.255.255.0

  duplex auto

  speed auto

  !

router ospf 1

  router-id 2.2.2.2

  log-adjacency-changes

  redistribute bgp 100 metric 100 metric-type 1 subnets route-map BGP-To_OSPF

  network 192.23.23.2 0.0.0.0 area 0

!

router bgp 100

  no synchronization

  bgp router-id 2.2.2.2

  bgp log-neighbor-changes

  bgp redistribute-internal

  neighbor 192.12.12.1 remote-as 100

  no auto-summary

!

ip prefix-list B2O seq 5 permit 172.16.0.0/16

!

route-map BGP-To_OSPF permit 10

  match ip address prefix-list B2O

!

 

 

Router R3

interface FastEthernet1/0

  ip address 192.23.23.3 255.255.255.0

  duplex auto

  speed auto

  !

router ospf 1

  log-adjacency-changes

network 192.23.23.3 0.0.0.0 area 0

 

Проверка

 

R1#sh ip bgp sum

BGP router identifier 1.1.1.1, local AS number 100

BGP table version is 3, main routing table version 3

2 network entries using 240 bytes of memory

2 path entries using 104 bytes of memory

1/1 BGP path/bestpath attribute entries using 124 bytes of memory

0 BGP route-map cache entries using 0 bytes of memory

0 BGP filter-list cache entries using 0 bytes of memory

BGP using 468 total bytes of memory

BGP activity 2/0 prefixes, 2/0 paths, scan interval 60 secs

 

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd

192.12.12.2     4          100     117     119        3    0    0 01:43:47        0

 

R2#sh ip bgp sum

BGP router identifier 2.2.2.2, local AS number 100

BGP table version is 4, main routing table version 4

2 network entries using 240 bytes of memory

2 path entries using 104 bytes of memory

1/1 BGP path/bestpath attribute entries using 124 bytes of memory

0 BGP route-map cache entries using 0 bytes of memory

0 BGP filter-list cache entries using 0 bytes of memory

BGP using 468 total bytes of memory

BGP activity 2/0 prefixes, 2/0 paths, scan interval 60 secs

 

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd

192.12.12.1     4          100     119     118        4    0    0 01:43:36        2

 

R2#sh ip bgp

BGP table version is 4, local router ID is 2.2.2.2

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

              r RIB-failure, S Stale

Origin codes: i - IGP, e - EGP, ? - incomplete

 

   Network          Next Hop            Metric LocPrf Weight Path

*>i1.1.1.1/32       192.12.12.1              0    100      0 i

*>i172.16.0.0       192.12.12.1              0    100      0 i

 

R2#sh ip ospf ne

 

Neighbor ID     Pri   State           Dead Time   Address         Interface

192.23.23.3       1   FULL/DR         00:00:35    192.23.23.3     FastEthernet2/0

 

R2#sh ip route 172.16.0.0

Routing entry for 172.16.0.0/16

  Known via "bgp 100", distance 200, metric 0, type internal

  Redistributing via ospf 1

  Advertised by ospf 1 metric 100 metric-type 1 subnets route-map BGP-To_OSPF

  Last update from 192.12.12.1 01:01:54 ago

  Routing Descriptor Blocks:

  * 192.12.12.1, from 192.12.12.1, 01:01:54 ago

      Route metric is 0, traffic share count is 1

      AS Hops 0

      MPLS label: none

 

R3#sh ip route

Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route, + - replicated route

 

Gateway of last resort is not set

 

O E1  172.16.0.0/16 [110/101] via 192.23.23.2, 00:57:55, FastEthernet1/0

      192.23.23.0/24 is variably subnetted, 2 subnets, 2 masks

C        192.23.23.0/24 is directly connected, FastEthernet1/0

L        192.23.23.3/32 is directly connected, FastEthernet1/0

 

Дополнительная информация

 

 

Оригинал - Redistributing Internal BGP Routes Into OSPF

История версий
Редакция №
2 из 2
Последнее обновление:
‎08-30-2017 11:05 PM
Автор обновления:
 
Участники