Cisco Support Community
отмена
Отображаются результаты для 
Вместо этого искать 
Вы имели в виду: 
cancel
Объявления
Добро пожаловать в Сообщество Технической поддержки Cisco. Мы рады получить обратную связь .
Community Member

Ограничение скорости на 2950T EI

Согласно инструкции на данное железо настраиваю:

Switch(config)# policy-map policy1

Switch(config-pmap)# class class1

Switch(config-pmap-c)# police 1000000 65536 exceed-action drop

Switch(config-pmap-c)# exit

Все работает, меняю 1000000 на большие значения перестает работать.

Как правильно настроить ограничение входящего трафика порта для скоростей более 1 Мбит?

6 ОТВЕТ.
Community Member

Ограничение скорости на 2950T EI

For rate-bps, specify average traffic rate in bits per second (bps). The range is 1 Mbps to 100 Mbps for 10/100 Ethernet ports and 8 Mbps to 1000 Mbps for the Gigabit-capable Ethernet ports.

На какой порт применяете политику, его конфиг? Это полный конфиг полиси? Как увидели проблему? Трафик точно попадает в класс? Версия ПО? 

Community Member

Re: Ограничение скорости на 2950T EI

1.Конфиг применяю на порт FastEthernet, сам конфиг ниже:

!

class-map match-all class-policy-any

  match access-group 123

!

!

policy-map Client-policy-test

  class class-policy-any

    police 5000000 65536 exceed-action drop

!!

!

interface FastEthernet0/1

switchport mode access

service-policy input Client-policy-test

!

access-list 123 permit ip any any

2.В коммутатор втыкаю два компьютера. Измеряю с помощью iperf между ними. Ну и еще в win7 при копировании можно увидеть в окне копирования скорость. Судя по текущим настройкам должно быть примерно 5Мбит/с реально колеблется около 1 Мбит/с, изменения burst значений ни к чему не приводят.

3.Маркирую весь трафик порта так что он точно попадает? Согласны?

4. На коммутаторе последний из доступных ИОС Version 12.1(22)EA14

Результаты и процесс измерений:

C:\IPerf>iperf.exe -c 192.168.0.25 -t 10 -M 32

------------------------------------------------------------

Client connecting to 192.168.0.25, TCP port 5001

TCP window size: 8.00 KByte (default)

------------------------------------------------------------

[128] local 192.168.0.113 port 57588 connected with 192.168.0.25 port 5001

[ ID] Interval       Transfer     Bandwidth

[128]  0.0-10.0 sec  1.38 MBytes  1.15 Mbits/sec

C:\IPerf>iperf.exe -c 192.168.0.25 -t 10 -M 32

------------------------------------------------------------

Client connecting to 192.168.0.25, TCP port 5001

TCP window size: 8.00 KByte (default)

------------------------------------------------------------

[128] local 192.168.0.113 port 57600 connected with 192.168.0.25 port 5001

[ ID] Interval       Transfer     Bandwidth

[128]  0.0-10.4 sec  1.38 MBytes  1.12 Mbits/sec

C:\IPerf>iperf.exe -c 192.168.0.25 -t 10 -M 32

------------------------------------------------------------

Client connecting to 192.168.0.25, TCP port 5001

TCP window size: 8.00 KByte (default)

------------------------------------------------------------

[128] local 192.168.0.113 port 57612 connected with 192.168.0.25 port 5001

[ ID] Interval       Transfer     Bandwidth

[128]  0.0-10.3 sec  1.46 MBytes  1.19 Mbits/sec

Далее снимаю service-policy с интерфейса:

C:\IPerf>iperf.exe -c 192.168.0.25 -t 10 -M 32

------------------------------------------------------------

Client connecting to 192.168.0.25, TCP port 5001

TCP window size: 8.00 KByte (default)

------------------------------------------------------------

[128] local 192.168.0.113 port 57689 connected with 192.168.0.25 port 5001

[ ID] Interval       Transfer     Bandwidth

[128]  0.0-10.0 sec  95.6 MBytes  80.2 Mbits/sec


Community Member

Ограничение скорости на 2950T EI

про 3-ий пункт не понял - чем и где маркируете, с какой целью?

под рукой нет 2950, к сожалению.

Что если попробовать без некоторых уточнений, как в документации:

class-map class-policy-any

  match access-group 1

access-list 1 permit any any

policy-map Client-policy-test

  class class-policy-any

    police 5000000 8192 exceed-action drop

interface FastEthernet0/1

switchport mode access

service-policy input Client-policy-test

Community Member

Ограничение скорости на 2950T EI

Ну может я не правильно выразился насчет маркирую, но смысл в том что весь входящий трафик порта подпадает под Акцесс лист и соответсвенно в класс трафика назыываемый class-policy-any, чем ваш вариант от моего отличается?

Community Member

Ограничение скорости на 2950T EI

Все равно, попробовал ваш вариант:

Если burst 8192 (как у вас) скорость 151 Кбит/с

Если ставлю как в документации 65536 то скорость 233 Кбит/с

Community Member

Ограничение скорости на 2950T EI

Чтобы быть уверенным, что весь трафик попадет в класс, то лучше для начала использовать только class-default и в случае успеха постепенно усложнять конфигурацию. Получается, что если все верно, то у вас полоса ограничивается сильнее ожидаемого. Тут либо ошибка в ПО, либо проблема на хостах. Попробуйте передать что-то большое, поставьте лоад-интервал 30 сек и посмотрите по шоу интерфейс, какую скорость покажет иос.

1145
Просмотры
0
Полезный материал
6
Ответы
СоздатьДля создания публикации, пожалуйста в систему