отмена
Отображаются результаты для 
Вместо этого искать 
Вы имели в виду: 
Объявления
Добро пожаловать в Сообщество Технической поддержки Cisco. Мы рады получить обратную связь .
New Member

Access-List на виртуальном интерфейсе (не работает)

Добрый день!

Столкнулся с непонятной ситуацией.
Есть маршрутизатор, у него в конфиге прописано следующее:

ip access-list extended block_all
deny ip any any

interface GigabitEthernet0/1.135
encapsulation dot1Q 135
ip address 10.0.0.1 255.255.255.0
ip access-group block_all in
ip access-group block_all out
ip flow ingress
ip flow egress
no cdp enable
end

При этом, если сделать tracert с 10.0.0.2 на какой-нибудь внутренний адрес в другой подсети или в интернете, то от маршрутизатора приходит ответ "заданная сеть недоступна", однако пинги во внутреннюю сеть свободно проходят и сайты в интернете открываются!

Может кто-нибудь подсказать в чём косяк?

  • Маршрутизация и коммутация (Routing and Switching)
6 ОТВЕТ.

попробуйте явно proxy-arp

попробуйте явно proxy-arp запретить.

interface GigabitEthernet0/1.135
no ip proxy-arp
New Member

Ничего не изменилось.

Ничего не изменилось.

Как выяснилось, я немного не корректно описал проблему:

1. в интефейсе ещё прописано ip helper-address 

2. Когда в access-list'е прописана только одна строчка: deny ip any any, то он блочит всё, так как компьютер не получает адрес по DHCP.

Но стоит в него в начале добавить 2 строки:

permit udp any any eq 67
permit udp any any eq 68

и комп получает IP-адрес, то всё, access-list'а как будто и нет - весь инет пингуется и доступен (но tracert демонстративно упирается в access-list и говорит что сети нет).

на виртуальном интерфейсе или

на виртуальном интерфейсе или на физическом? что за устрйство и версия иос ?

New Member

interface GigabitEthernet0/1

interface GigabitEthernet0/1.135

На виртуальном.

Роутер 3845, прошивка 12.4(25a).

New Member

А какой шлюз по умолчанию

А какой шлюз по умолчанию назначает DHCP?

New Member

Спасибо, забыл отписать что

Спасибо, забыл отписать что проблема решена.

Оказался баг в старой прошивке (или что-то вроде), после обновления проблема исчезла.

17
Просмотры
0
Полезный материал
6
Ответы