отмена
Отображаются результаты для 
Вместо этого искать 
Вы имели в виду: 
Объявления
Добро пожаловать в Сообщество Технической поддержки Cisco. Мы рады получить обратную связь .
New Member

ASA 5510. Назначение внешнего IP внутреннему серверу.

На 5505 это было реализовано вот так:

interface Ethernet0/0

switchport access vlan 2

!

interface Ethernet0/1

!

interface Ethernet0/2

switchport access vlan 2

!

interface Ethernet0/3

!

interface Ethernet0/4

!

interface Ethernet0/5

!

interface Ethernet0/6

!

interface Ethernet0/7

!

interface Vlan1

nameif inside

security-level 100

ip address 172.16.0.1 255.255.0.0

!

interface Vlan2

nameif outside

security-level 0

ip address 222.222.222.221 255.255.255.252

same-security-traffic permit inter-interface

same-security-traffic permit intra-interface

So Ethernet0/0 is from ISP, Ethernet0/1 goes to big lan switch & Ethernet0/2 also goes to big lan switch.

The problem is that 5510 doesn't have switchports & vlans are configured somehow different

Please assist me in configuring 5510 to get the same result as on 5505.

Теги (3)
6 ОТВЕТ.
New Member

Re: ASA 5510. Назначение внешнего IP внут

Рассмотрите ASA 5510 как обычный роутер, который не имеет SVI (VLAN интерфейсы).

1. Назначте E0/0 адрес от провайдера:

interface Ethernet0/0
 description ISP
 nameif ISP
 security-level 0
 ip address 222.222.222.221 255.255.255.252 

2. Интерфесу E0/1 адрес из внутренней сети:


interface Ethernet0/1 description DMZ nameif DMZ security-level 50 ip address 172.16.0.1 255.255.0.0

И используйте статический NAT для вашего сервера:

static (DMZ, ISP) tcp 172.16.0.101 http 222.222.222.222 http netmask 255.255.255.255

Подробнее: https://supportforums.cisco.com/docs/DOC-2053

New Member

Re: ASA 5510. Назначение внешнего IP внут

Сервер находится во внутренней сети, но ему обязательно должен быть назначен внешний адрес, а не внутренний, так что, насколько я понял, ваше решение мне не подходит

New Member

Re: ASA 5510. Назначение внешнего IP внут

Команда:

static (DMZ, ISP) tcp 172.16.0.101 http 222.222.222.222 http netmask 255.255.255.255

назначает вашему внутреннему серверу 172.16.0.101 внешний адрес - 222.222.222.222.

Или вы имеете в виду что-то другое? Нарисуйте схему сети.

New Member

ASA 5510. Назначение внешнего IP внутре

Другое.

У сервера находящегося во внутренней сети на сетевом интерфейсе должен быть назначен только внешний адрес, не внутренний!

New Member

ASA 5510. Назначение внешнего IP внутре

Тогда не совсем ясно, что такое "внутренняя сеть".

Подключите к порту коммутатора интерфейс E0/0 (адрес от ISP), назначте порт коммутатора в vlan определённый для подсети выделенной вам провайдером, подключите сетевой интерфейс сервера в порт коммутатора, определите его в тот же vlan, назначте сетевой карте сервера внешний адрес.

Нарисуйте схему сети и вставте здесь как картинку, не ясно, что вы имеете ввиду.

New Member

ASA 5510. Назначение внешнего IP внутре

Как я понимаю вам нужен банальный свитч L2, который был встроен в 5505 и отсутствует в 5510. Я бы взял простой свитч (или дорогой) и использовал его. Ну или если есть роутер, делал бы там бриджинг. Но свитч и дешевле и надежнее.

Другого пути решения вашей проблемы я не вижу.

1404
Просмотры
0
Полезный материал
6
Ответы